Subject: [ippm] RE: [e2e] method to detect liveness of remote other than ping

From: "Cottrell, Les" <[email-masked]>
Date: Mon, 13 Oct 2003 07:17:31 -0700

The following was blocked by a spam filter complaining of non-English traffic.  So I am resending it to get around the spamcontrol

-----Original Message-----
From: Cottrell, Les 
Sent: Monday, October 13, 2003 7:07 AM
To: 'Jing Shen'; [email-masked]
Cc: end-to-end list
Subject: RE: [e2e] method to detect liveness of remote other than ping

If you know a port that is open (e.g. ssh, web (80), telnet, FTP, DNS) you can try probing one of those ports. However, this may appear to the remote host admin as unfriendly and blocks may then be added for your host.

We did some study on this a couple of years back (see http://www-iepm.slac.stanford.edu/monitoring/limit/limiting.html) mainly for the purpose of detecting ping rate limiting rather than outright blocking.  We used a tool called synack (see http://www-iepm.slac.stanford.edu/tools/synack/, but note it only runs on Solaris) to probe different TCP ports and looked for the difference with ICMP pings. 

-----Original Message-----
From: Jing Shen [mailto:[email-masked]] 
Sent: Monday, October 13, 2003 2:36 AM
To: [email-masked]
Cc: end-to-end list
Subject: [e2e] method to detect liveness of remote other than ping

Hi,

Usually, we detect remote end liveness by 'ping'
remote end IP address. I want to know, if ping packet
is filtered out by firewall which tools could be used
to detect remote end liveness?

thanks

jing shen

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: "Cottrell, Les" <[email-masked]>
Date: Mon, 13 Oct 2003 07:17:31 -0700

-----Original Message-----
From: Jing Shen [mailto:[email-masked]] 
Sent: Monday, October 13, 2003 2:36 AM
To: [email-masked]
Cc: end-to-end list
Subject: [e2e] method to detect liveness of remote other than ping

Hi,

thanks

jing shen