Subject: [ippm] Fwd: Re: Fwd: Expiration impending: draft-ietf-ippm-reporting-metrics

From: Al Morton <[email-masked]>
Date: Thu, 09 Feb 2012 08:20:52 -0500

Henk, Matt,

Just Prior to the WGLC, Daniel Genin sent the message below
to me and the list, and I just located it in the archive:
http://www.ietf.org/mail-archive/web/ippm/current/msg02769.html

In any case, the authors plan to address Daniel's comments
and issue a revised draft, hopefully this weekend.

regards,
Al

>Date: Tue, 17 Jan 2012 18:03:06 -0500
>From: Daniel Genin <[email-masked]>
>User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20111222 
>Thunderbird/9.0.1
>To: Al Morton <[email-masked]>
>CC: IETF IPPM WG <[email-masked]>
>Subject: Re: [ippm] Fwd: Expiration impending: 
>draft-ietf-ippm-reporting-metrics
>X-NIST-MailScanner: Found to be clean
>X-NIST-MailScanner-From: [email-masked]
>
>A very lucid and well written exposition on the relevance of 
>metric's consumer to the way that it should be defined. It is 
>surprising this important point has not been addressed earlier.
>
>Just a couple of comments:
>
>I. In Section 5.1.2 the bulleted list item 2 appears to suggest that 
>orthogonality of metrics is a desirable property, however, no 
>explanation for this is given. Moreover, metrics appearing in 
>Section 6 do not appear to be orthogonal suggesting that 
>orthogonality is not a necessary property. If orthogonality is a 
>desirable property in the case of delay and loss metrics but not in 
>the case of raw capacity metrics this probably needs to be clarified.
>
>II. Minor grammatical corrections:
>     1. Section 5.2, Paragraph 1, line 5 "...is based a conditional 
> distribution..." should probably be "...is based on a conditional
>distribution...".
>     2. Section 6.2, the first letter of the title needs to be capitalized.
>     3. Section 6.6, Paragraph 1, line 2 "...gives a the user..." 
> should probably be "...gives the user..."
>     4. Section 6.6, Paragraph 2, line 1 "What ways can 
> Utilization  be measured..." should probably be "In what ways can 
> Utilization be measured..." or "How can Utilization be measured..."
>     5. Section 7.5, Paragraph 1, line 2 "...gives a the user..." 
> should probably be "...gives the user..."
>
>Hope this is useful.
>Best regards,
>Daniel
>
>On 1/7/2012 10:26 AM, Al Morton wrote:
>>At 08:37 AM 1/2/2012, Henk Uijterwaal wrote:
>>>Authors: Please update this draft.
>>>All others: please read and comment on this document so we can finish it.
>>>
>>>Henk
>>As promised, here's the update of reporting metrics where we've
>>finished section 6 based on recent measurement and reporting
>>experience. Also checked nits and the list (discussion of this
>>draft has been rather long-term, dating back many years).
>>
>>regards,
>>Al
>>
>>
>>A New Internet-Draft is available from the on-line Internet-Drafts
>>directories. This draft is a work item of the IP Performance Metrics
>>Working Group of the IETF.
>>
>>           Title           : Reporting Metrics: Different Points of View
>>           Author(s)       : Al Morton
>>                             Gomathi Ramachandran
>>                             Ganga Maguluri
>>           Filename        : draft-ietf-ippm-reporting-metrics-06.txt
>>           Pages           : 26
>>           Date            : 2012-01-07
>>
>>      Consumers of IP network performance metrics have many different uses
>>      in mind.  The memo provides "long-term" reporting considerations
>>      (e.g, days, weeks or months, as opposed to 10 seconds), based on
>>      analysis of the two key audience points-of-view.  It describes how
>>      the audience categories affect the selection of metric parameters and
>>      options when seeking info that serves their needs.
>>
>>
>>
>>A URL for this Internet-Draft is:
>>http://www.ietf.org/internet-drafts/draft-ietf-ippm-reporting-metrics-06.txt
>>
>>
>>
>>_______________________________________________
>>ippm mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/ippm
>
>

---

From: Henk Uijterwaal <[email-masked]>
Date: Thu, 09 Feb 2012 15:05:15 +0100

Al,

> and issue a revised draft, hopefully this weekend.

Sorry, I seemed to have missed this mail.  Looking at it, section II are
all typo's, section I is a useful comment but addressing it is unlikely
to undo the rough consensus on this coument that we have.   So, I suggest
that you update the document and we submit the next version to the IESG.

Henk

>> User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
>> Subject: Re: [ippm] Fwd: Expiration impending: draft-ietf-ippm-reporting-metrics
>> A very lucid and well written exposition on the relevance of metric's consumer
>> to the way that it should be defined. It is surprising this important point
>> has not been addressed earlier.
>>
>> orthogonality of metrics is a desirable property, however, no explanation for
>> this is given. Moreover, metrics appearing in Section 6 do not appear to be
>> orthogonal suggesting that orthogonality is not a necessary property. If
>> orthogonality is a desirable property in the case of delay and loss metrics
>> but not in the case of raw capacity metrics this probably needs to be clarified.
>>
>>     3. Section 6.6, Paragraph 1, line 2 "...gives a the user..." should
>> probably be "...gives the user..."
>>     4. Section 6.6, Paragraph 2, line 1 "What ways can Utilization  be
>> measured..." should probably be "In what ways can Utilization be measured..."
>> or "How can Utilization be measured..."
>>     5. Section 7.5, Paragraph 1, line 2 "...gives a the user..." should
>> probably be "...gives the user..."
>>
>> Hope this is useful.
>> Best regards,
>> Daniel
>>

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk(at)uijterwaal.nl
                                          http://www.uijterwaal.nl
                                          Phone: +31.6.55861746
------------------------------------------------------------------------------

There appears to have been a collective retreat from reality that day.
                                 (John Glanfield, on an engineering project)