Subject: Re: [ippm] [lmap] BOF not approved?

From: Matt Mathis <[email-masked]>
Date: Fri, 5 Oct 2012 16:12:49 -0700

+IPPM

Consider doing this entire effort within IPPM.    A protocol to
control measurement is absolutely in scope (See for example RFC 4656)
as are discussions about the choice of measurement vantage points and
requirements for measurement platforms, etc.   Many of the topics that
might be out of scope for IPPM, are likely to be out of scope for both
IETF and IRTF, for example the design on a media specific link layer
control protocol probably belongs in some other forum entirely.

For things that are on the edge of IPPM's scope and don't fit
elsewhere, it would be far easier to tweak IPPM than to spin a new WG.

Thanks,
--MM--
The best way to predict the future is to create it.  - Alan Kay

On Fri, Oct 5, 2012 at 8:05 AM, Henning Schulzrinne
<[email-masked]> wrote:
> I can't speak for all the LMAP participants, obviously, but I was hoping that the LMAP requirements I-D made it reasonably clear that at least our needs are primarily in defining a specific set of protocols, with the metrics being delegated to IPPM (or successor). Thus, this would not be a BCP, but at least experimental. If the draft failed to make the point, I have obviously some work to do...
>
> Henning
>
> ________________________________________
> From: [email-masked] [[email-masked]] on behalf of Wesley Eddy [[email-masked]]
> Sent: Friday, October 05, 2012 10:59 AM
> To: Matthew Ford
> Cc: marcelo bagnulo braun; Hannes Tschofenig; Livingood,        Jason; [email-masked]
> Subject: Re: [lmap] BOF not approved?
>
> On 10/5/2012 9:55 AM, Matthew Ford wrote:
>>
>> On 5 Oct 2012, at 14:09, "Livingood, Jason" <[email-masked]> wrote:
>>
>>> My original suggestion to a few folks (before this list was established)
>>> was to do this work in the IRTF. Perhaps we can arrange something there,
>>> even if an informal discussion of what is needed and how we might proceed?
>>> Failing that, a bar BoF would be helpful.
>>>
>>
>> I don't have a strong opinion about IRTF vs. bar BoF but I would strongly support having a meeting in Atlanta to review the situation, potentially hear more about requirements from others, and try to figure out a (sustainable) way forward for this initiative.
>>
>
>
> Obviously some work has to take place to further identify what
> exactly people would like to do, and then the choice of goal
> for IETF or IRTF group would be more obvious, based on the
> desired outcome (e.g. standards or BCP work would indicate an
> IETF WG, or it may turn out that some work could fit within
> existing groups like IPPM).
>
> Until this is clear, I would suggest to just have a pure
> side-meeting.
>
> --
> Wes Eddy
> MTI Systems
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: Al Morton <[email-masked]>
Date: Sun, 07 Oct 2012 22:12:31 -0400

Thinking about the main classes of requirements in the draft,
both passive and active measurement systems are desired.
This may turn-out to be good combination.

While IPPM is strong in metric definitions and test protocols
for active measurements, I think there is some room for growth
in collection protocols (especially with the degree of inter-communication
envisaged in the requirements). But this is where the IETF developments
to support passive measurements might help fill the gap (ipfix is
the best example I can think of).

regards,
Al

At 07:12 PM 10/5/2012, Matt Mathis wrote:
> > I can't speak for all the LMAP participants, obviously, but I was 
> hoping that the LMAP requirements I-D made it reasonably clear that 
> at least our needs are primarily in defining a specific set of 
> protocols, with the metrics being delegated to IPPM (or successor). 
> Thus, this would not be a BCP, but at least experimental. If the 
> draft failed to make the point, I have obviously some work to do...
> >
> > Henning
> >
> >> On 5 Oct 2012, at 14:09, "Livingood, Jason" 
> <[email-masked]> wrote:
> >>
> >> I don't have a strong opinion about IRTF vs. bar BoF but I would 
> strongly support having a meeting in Atlanta to review the 
> situation, potentially hear more about requirements from others, 
> and try to figure out a (sustainable) way forward for this initiative.
> >>
> >
> >

---

From: William Check <[email-masked]>
Date: Sun, 7 Oct 2012 20:25:40 +0000

I tend to agree that an informal discussion within the IRTF would be a good way to proceed….  Bill

From: Matt Mathis <[email-masked]<mailto:[email-masked]>>
Date: Friday, October 5, 2012 7:12 PM
To: Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>
Cc: Matthew Ford <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Wesley Eddy <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, marcelo bagnulo braun <[email-masked]<mailto:[email-masked]>>, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>, Jason Livingood <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lmap] BOF not approved?

+IPPM

Thanks,
--MM--

On Fri, Oct 5, 2012 at 8:05 AM, Henning Schulzrinne
<[email-masked]<mailto:[email-masked]>> wrote:
I can't speak for all the LMAP participants, obviously, but I was hoping that the LMAP requirements I-D made it reasonably clear that at least our needs are primarily in defining a specific set of protocols, with the metrics being delegated to IPPM (or successor). Thus, this would not be a BCP, but at least experimental. If the draft failed to make the point, I have obviously some work to do...

Henning

________________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] on behalf of Wesley Eddy [[email-masked]<mailto:[email-masked]>]
Sent: Friday, October 05, 2012 10:59 AM
To: Matthew Ford
Cc: marcelo bagnulo braun; Hannes Tschofenig; Livingood,        Jason; [email-masked]<mailto:[email-masked]>
Subject: Re: [lmap] BOF not approved?

On 5 Oct 2012, at 14:09, "Livingood, Jason" <[email-masked]<mailto:[email-masked]>> wrote:

--
Wes Eddy
MTI Systems
_______________________________________________
lmap mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lmap
_______________________________________________
lmap mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lmap
_______________________________________________
lmap mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lmap

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 9 Oct 2012 14:42:27 +0000

+1, and it's an easy way to get started and focus on the work itself
rather than process/logistics of a BoF or WG formation.

Jason

On 10/5/12 7:12 PM, "Matt Mathis" <[email-masked]> wrote:

>>hoping that the LMAP requirements I-D made it reasonably clear that at
>>least our needs are primarily in defining a specific set of protocols,
>>with the metrics being delegated to IPPM (or successor). Thus, this
>>would not be a BCP, but at least experimental. If the draft failed to
>>make the point, I have obviously some work to do...
>>
>> Henning
>>
>>>strongly support having a meeting in Atlanta to review the situation,
>>>potentially hear more about requirements from others, and try to figure
>>>out a (sustainable) way forward for this initiative.
>>>
>>
>>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 10 Oct 2012 17:40:43 +0200

Hi,

at the beginning I though at well that this work might be in scope of IPPM. 
But after thinking more deeply about it, I'd say there is quite a lot of work 
to do and this might be worth forming an own working group. 

Then regarding a whole measurement architecture there might still be some more 
researchy questions but only focussing on the protocol(s) between the 
measurement entities, I believe the problem and requirements are very clear 
to be addressed in the ieft.

I would favor having a side meeting in Atlanta. From my point of view the 
first step would be to get an overview on existing measurement framework to 
validate if the requirements listed so far cover their needs. If people that 
have designed or are administrating thus a framework are on this list and 
would be willing to present their system that would be great. But I'm afraid 
that there are actually a lot of small companies running these systems (e.g. 
webpages where private costumers can check their lines) and those people 
might not be active in the ieft.

Mirja

On Tuesday 09 October 2012 20:02:47 Weil, Jason wrote:
> If there is agreement on initiating the discussion in the IPPM group, it
> might be useful to request a time slot during Tuesday's IPPM meeting
> fairly quickly to give an overview of the draft and gauge interest on work
> areas.
>
> Jason
>
> On 10/9/12 10:42 AM, "Livingood, Jason"
>
> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely
> for the use of the individual or entity to which it is addressed. If you
> are not the intended recipient of this E-mail, you are hereby notified that
> any dissemination, distribution, copying, or action taken in relation to
> the contents of and attachments to this E-mail is strictly prohibited and
> may be unlawful. If you have received this E-mail in error, please notify
> the sender immediately and permanently delete the original and any copy of
> this E-mail and any printout.

-- 
-------------------------------------------------------------------
Dipl.-Ing. Mirja Kühlewind
Institute of Communication Networks and Computer Engineering (IKR)
University of Stuttgart, Germany
Pfaffenwaldring 47, D-70569 Stuttgart

tel: +49(0)711/685-67973
email: [email-masked]
web: www.ikr.uni-stuttgart.de
-------------------------------------------------------------------

---

From: "Weil, Jason" <[email-masked]>
Date: Tue, 9 Oct 2012 14:02:47 -0400

Jason

>>>make the point, I have obviously some work to do...

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.