Subject: [ippm] On hybrid measurements

From: fabio ricciato <[email-masked]>
Date: Sat, 13 Oct 2012 16:26:03 +0200

Dear Brian, all

I'm new to the list, so I might have missed something, but I have a general
comment about the hybrid measurements.

Generally speaking, I see two possible approaches to marrying Active
MEasurements (AM) and PAssive Measurements (PM).

* Type I : coordinate one AM tool/techique (with test traffic generated
end2end) and one PM one (sniffing real user traffic, not test traffic) that
are run separately (with some level of mutual coordination) and make sense
jointly of their results.

* Type II: generate test traffic, as in AM, and capture it also inside the
network with additional PM probes. I.e., it's about the passive capturing
of test traffic.

I think it makes sense to make an explicit distinction between these two
approaches, and perhaps to address both of them in a single draft (?).

We have been using the term "hybrid measurement" (HM) to refer specifically
to Type II approach (see e.g. this paper on LTE one-way delays:  M. Laner
et al. A Comparison Between One-Way Delays in Operating HSPA and LTE
Networks, 8th Int'l workshop on Wireless Network Measurements
(WINMEE'12<http://wi-opt.cs.upb.de/winmee/program.htm>),
Pedeborn, Germany, 18 May 2012. )

As far as I understand, you are addressing primarily Type I techniques, is
that correct ?

I'm not sure whether it is preferable to keep the term "hybrid" for both
approaches, and then use Type I vs. Type II labeling for discriminating
them, or instead use different terms, e.g. use "combined" or "coordinated"
AM/PM for Type I and reserve "hybrid" for Type II.

I personally think that Hybrid Measurements of Type II have a very
interesting potential that is still to be developed. Basically, under many
respect they merge the advantages of both AM and PM. I can develop more the
concept on this mailing list if other are interested, and perhaps we could
consider to address both Type I and Type II in a single draft.

What do you think ?

ciao
fabio

On Fri, Oct 12, 2012 at 10:38 AM, Brian Trammell <[email-masked]>wrote:

> Greetings, all,
>
> I've just posted a very short draft on hybrid measurement, more a
> meta-requirements list and motivation than anything else, as a starting
> point for discussion at the Atlanta meeting.
>
> Best regards,
>
> Brian
>
> Begin forwarded message:
>
> > From: [email-masked]
> > Subject: New Version Notification for
> draft-trammell-ippm-hybrid-ps-00.txt
> > Date: October 12, 2012 10:31:22 AM GMT+02:00
> > To: [email-masked]
> >
> >
> > A new version of I-D, draft-trammell-ippm-hybrid-ps-00.txt
> > has been successfully submitted by Brian Trammell and posted to the
> > IETF repository.
> >
> > Filename:      draft-trammell-ippm-hybrid-ps
> > Revision:      00
> > Title:                 Hybrid Measurement using IPPM Metrics
> > Creation date:         2012-10-12
> > WG ID:                 Individual Submission
> > Number of pages: 4
> > URL:
> http://www.ietf.org/internet-drafts/draft-trammell-ippm-hybrid-ps-00.txt
> > Status:
> http://datatracker.ietf.org/doc/draft-trammell-ippm-hybrid-ps
> > Htmlized:
> http://tools.ietf.org/html/draft-trammell-ippm-hybrid-ps-00
> >
> >
> > Abstract:
> >   Hybrid measurement is the combination of metrics derived from passive
> >   and active measurement to produce a measurement result.  This
> >   document discusses use cases for hybrid measurement using metrics
> >   defined within the IPPM framework
> >
> >
> >
> >
> > The IETF Secretariat
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>

---

From: Brian Trammell <[email-masked]>
Date: Mon, 15 Oct 2012 12:16:26 +0200

Hi, Fabio, all,

Thanks for your comments, and welcome to IPPM. Comments inline....

On Oct 13, 2012, at 4:26 PM, fabio ricciato wrote:

> Dear Brian, all
> 
> I'm new to the list, so I might have missed something, but I have a general comment about the hybrid measurements.
> 
> Generally speaking, I see two possible approaches to marrying Active MEasurements (AM) and PAssive Measurements (PM).
> 
> * Type I : coordinate one AM tool/techique (with test traffic generated end2end) and one PM one (sniffing real user traffic, not test traffic) that are run separately (with some level of mutual coordination) and make sense jointly of their results.
> 
> * Type II: generate test traffic, as in AM, and capture it also inside the network with additional PM probes. I.e., it's about the passive capturing of test traffic.

The power of these (Type II) approaches comes from the fact that you get multiple observations of the same (known, active) test traffic, yes?

> I think it makes sense to make an explicit distinction between these two approaches, and perhaps to address both of them in a single draft (?).
> 
> We have been using the term "hybrid measurement" (HM) to refer specifically to Type II approach (see e.g. this paper on LTE one-way delays:  M. Laner et al. A Comparison Between One-Way Delays in Operating HSPA and LTE Networks, 8th Int'l workshop on Wireless Network Measurements (WINMEE'12), Pedeborn, Germany, 18 May 2012. )
> 
> As far as I understand, you are addressing primarily Type I techniques, is that correct ? 

Correct: while there's nothing in particular that would keep the problem statement from applying to Type II approaches, and indeed it seems that formalizing the comparability of active and passive measurement techniques for defined metrics could be used to improve the fidelity of these Type II measurements, I had only Type I approaches in mind.

> I'm not sure whether it is preferable to keep the term "hybrid" for both approaches, and then use Type I vs. Type II labeling for discriminating them, or instead use different terms, e.g. use "combined" or "coordinated" AM/PM for Type I and reserve "hybrid" for Type II. 

Hm. On the one hand, I like the use of "hybrid" for both Type I and Type II, because both meld active and passive measurements together to generate new information not available with either alone. On the other hand, I prefer descriptive terminology to numbered taxonomy, and I do think it's important to distinguish the two approaches.

How about something like "combined hybrid" for type I, as it is concerned by combination and comparison of active with passive at the metric level; and "concurrent hybrid" for type II, as it is concerned with the concurrent passive measurement of actively generated test traffic?

> I personally think that Hybrid Measurements of Type II have a very interesting potential that is still to be developed. Basically, under many respect they merge the advantages of both AM and PM. I can develop more the concept on this mailing list if other are interested,

I'd definitely be interested in this, especially seeing how it integrates with IPPM metrics.

> and perhaps we could consider to address both Type I and Type II in a single draft.

Please do contribute. :) An overview, problem statement, and requirements draft (which is what I see -hybrid-ps developing into) should definitely address both approaches. That said, I would like to keep this work a bit scoped, primarily toward the application of existing IPPM metrics to either or both types of hybrid measurement, in order to have a draft that can be finished in a reasonable amount of time.

Many thanks, best regards,

Brian
 
> 
> On Fri, Oct 12, 2012 at 10:38 AM, Brian Trammell <[email-masked]> wrote:
> Greetings, all,
> 
> I've just posted a very short draft on hybrid measurement, more a meta-requirements list and motivation than anything else, as a starting point for discussion at the Atlanta meeting.
> 
> Best regards,
> 
> Brian
> 
> Begin forwarded message:
> 
> > Subject: New Version Notification for draft-trammell-ippm-hybrid-ps-00.txt
> > URL:             http://www.ietf.org/internet-drafts/draft-trammell-ippm-hybrid-ps-00.txt
> > Status:          http://datatracker.ietf.org/doc/draft-trammell-ippm-hybrid-ps
> > Htmlized:        http://tools.ietf.org/html/draft-trammell-ippm-hybrid-ps-00
> >
> >
> > Abstract: