Subject: [ippm] ietf86 follow-up: draft-ietf-ippm-rate-problem-02.txt

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 3 Apr 2013 01:21:01 +0000

Hello :

This is regarding my comment at the IETF86 ippm meeting for the section 5 (Test Protocol Control & Generation Requirements) section.
Toward the end of the section, the document states:
"The ability to control packet size on the tested path and enable
asymmetrical packet size testing in a two-way architecture are
REQUIRED."

Request: Relax the requirement for "assymetrical" packet size so that the requirement document allows both symmetric and assymetric packet sizes in forward and reverse direction.

I was asked to provide a usecase for the request and here it is:
Normally in fixed Broadband network, so far we are mostly interested with data traffic download and thus we can see 80/20 (apprx) traffic distribution in forward and reverse direction. Most often in the forward path we have actual traffic packets and in upward direction it is most likely short packet sizes due to acknowledgements etc.
However, looking forward in current and future deployment and in Mobile Broadband networks when we consider applications like VoLTE, peer-to-peer communication, video-chat etc. we can easily expect that forward and reverse direction traffic rate and sizes are equivalent.  Since the converged network carries both mobile and fixed broadband traffic, it is important for many carriers to measure the IP-network performance by using active measurement protocol with same packet size of the traffic and in some cases with same rate in both directions ( i,e both symmetric and assymetric).
Thus, we will need to allow both symmetric and assymetric measurement packet sizes and rates in forward and reverse direction.
Hope this helps in understanding the requirement.

Best regards,
-Samita

---

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Thu, 11 Apr 2013 17:49:45 -0400

Sumita,

You make a case for testing with both symmetric and asymmetric sizes.
Is that correct?

Al

From: [email-masked] [mailto:[email-masked]] On Behalf Of Samita Chakrabarti
Sent: Tuesday, April 02, 2013 9:21 PM
To: [email-masked]; Brian Trammell
Subject: [ippm] ietf86 follow-up: draft-ietf-ippm-rate-problem-02.txt

Hello :

Best regards,
-Samita

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 12 Apr 2013 15:38:27 +0000

Hi Al,

 > You make a case for testing with both symmetric and asymmetric sizes.

Yes, that's right. I think we need to be able to measure with both symmetric and asymetric packet sizes in different usecase scenarios.

Thanks,
-Samita

Hello :

Best regards,
-Samita

---

From: Samita Chakrabarti <[email-masked]>
Date: Sat, 27 Apr 2013 00:04:49 +0000

Hi Al,

Does the new(03)  draft clarify the following issue of symmetric and asymmetric sizes  and address my comment below?
Please point to the location where it addresses the clarification.

Thanks so much.
-Samita
________________________________
From: Samita Chakrabarti
Sent: Thursday, April 11, 2013 9:22 PM
To: 'MORTON JR., ALFRED C (AL)'; [email-masked]; Brian Trammell
Subject: RE: ietf86 follow-up: draft-ietf-ippm-rate-problem-02.txt

Hi Al,

Thanks,
-Samita

Hello :

Best regards,
-Samita

---

From: "Guangqing Deng" <[email-masked]>
Date: Tue, 30 Apr 2013 01:10:30 +0800

It is revealed that the proportion of Internet traffic caused by peer-to-peer file and video sharing is still not low, see http://www.cisco.com/en/US/solutions/collateral/ns341/ns525/ns537/ns705/ns827/white_paper_c11-481360_ns827_Networking_Solutions_White_Paper.html. Also, it is predicted that the mobile data traffic will increase quickly in the next years. With the development of wireless access technology, people are increasingly inclined to upload the pictures, audios and videos gathered by their mobile phones to social websites and so on for sharing. In a word, Internet users are not only downloading content from but also creating and uploading content to Internet (and other Internet users).So it may be necessary to let this document allow both symmetric and asymmetric packet sizes and rates in forward and reverse direction. 

Guangqing Deng
cnnic 

From: Samita Chakrabarti
Date: 2013-04-03 09:21

Hello :

Best regards,
-Samita