Subject: Re: [ippm] [Ioam] IOAM Work Moving Forward

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 16 Feb 2017 17:24:24 -0000

[...scurries to subscribe to another mailing list]
 
Can the TSV ADs comment on whether there is a plan to re-charter IPPM:
- To be applicable to network layer and lower
- To be scoped beyond "metrics" (such as path trace)
- To attend to more detail than "characterize the network paths under test
 and/or the performance of transport and application layer protocols on 
  these paths"
 
Thanks,
Adrian
 
From: Ioam [mailto:[email-masked]] On Behalf Of Alvaro Retana (aretana)
Sent: 16 February 2017 16:58
To: [email-masked]
Subject: [Ioam] IOAM Work Moving Forward
 
Hi!
 
First of all, thank you all for the interest expressed in this topic and the discussions about the charter.
 
As you know, one of the discussions resulting from the Internal Review of the proposed IOAM charter was whether the work was already within the ippm WG scope or not.  Over the last couple of days, I have dug deeper into that question with the Transport ADs and the ippm WG Chairs, and our conclusion is that there is significant overlap between the current ippm Charter and the proposed IOAM work.  Enough to justify moving the work forward in the ippm WG and not splintering a related effort into a new WG.
 
I have then stopped the chartering effort for a new WG.  The proponents will start discussions on the ippm list soon – please join if you’re not there already.  I will keep this list open for a couple more days.
 
Clearly there is interest in developing this cross-area work in the IETF.  I hope that you will continue to participate as the topic progresses on the ippm WG.  It is important that this type of cross-area efforts be properly discussed and that we don’t create more silos.  I realize it took us a couple of tries to find what I think is a stable home for the IOAM work – I know that the open discussion has only helped the overall process.
 
Thanks!
 
Alvaro.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 16 Feb 2017 11:50:46 -0600

Hi, Adrian,

> [...scurries to subscribe to another mailing list]

:-)

>  and/or the performance of transport and application layer protocols on

Sure, I can comment (responsible AD for IPPM).

We spoke with Brian and Bill (co-chairs for IPPM this morning), and Brian
thinks IPPM would need to change about 15 percent of its charter to have
IOPM in scope.

If IPPM is willing to take this work on, I would, of course, want IPPM's
charter to reflect this work.

The discussions I've been involved with have been about the network layer,
but not about anything lower.

I could imagine path trace as a very basic metric, of course, but for the
kind of details you're asking about, we've been talking about the
relationship between IOAM and IPPM for less than 36 hours which overlapped
a formal telechat, so I'd expect us to have a better-thought-out plan in
the near future than we have today ...

Spencer

> Thanks,
>
> Adrian
>
>
>
> *From:* Ioam [mailto:[email-masked]] *On Behalf Of *Alvaro Retana
> (aretana)
> *Sent:* 16 February 2017 16:58
> *To:* [email-masked]
> *Subject:* [Ioam] IOAM Work Moving Forward
>
>
>
> Hi!
>
>
>
> As you know, one of the discussions resulting from the Internal Review of
> the proposed IOAM charter was whether the work was already within the ippm
> WG scope or not.  Over the last couple of days, I have dug deeper into that
> question with the Transport ADs and the ippm WG Chairs, and our conclusion
> is that there is significant overlap between the current ippm Charter and
> the proposed IOAM work.  Enough to justify moving the work forward in the
> ippm WG and not splintering a related effort into a new WG.
>
>
>
> I have then stopped the chartering effort for a new WG.  The proponents
> will start discussions on the ippm list soon – please join if you’re not
> there already.  I will keep this list open for a couple more days.
>
>
>
> Clearly there is interest in developing this cross-area work in the IETF.
> I hope that you will continue to participate as the topic progresses on the
> ippm WG.  It is important that this type of cross-area efforts be properly
> discussed and that we don’t create more silos.  I realize it took us a
> couple of tries to find what I think is a stable home for the IOAM work – I
> know that the open discussion has only helped the overall process.
>
>
>
> Thanks!
>
>
>
> Alvaro.
>