Subject: [ippm] Follow-up questions for ippm drafts

From: Michelle Cotton <[email-masked]>
Date: Tue, 7 Mar 2017 15:44:12 +0000

Hi Al,

I’m working on a full review of draft-ietf-ippm-initial-registry-02 and draft-ietf-ippm-metric-registry-10.  I have some questions that need clarification before I send the full review.  

In section 7.1.2 of the initial registry document, it lists multiple names:

   OWDelay_Active_IP-UDP-Poisson-Payload250B_RFCXXXXsecY_Seconds_<statistic>

   OWDelay_Active_IP-UDP-Poisson-Payload250B_RFCXXXXsecY_Seconds_95Percentile

   OWDelay_Active_IP-UDP-Poisson-Payload250B_RFCXXXXsecY_Seconds_Mean

   OWDelay_Active_IP-UDP-Poisson-Payload250B_RFCXXXXsecY_Seconds_Min

   OWDelay_Active_IP-UDP-Poisson-Payload250B_RFCXXXXsecY_Seconds_Max

   OWDelay_Active_IP-UDP-Poisson-Payload250B_RFCXXXXsecY_Seconds_StdDev

How does that work in the registry?  Do we add all of these names with the same ID number or different ID numbers?  Do they all have identical summary information in the table?  Will they all link to the same template?  Can you clarify?

Also, in section 7.1.3 of the metric registry document, it says the following URN will be created:

urn:ietf:metric:perf:

In some of our discussions “metric” was used and also “metrics”.  Please confirm which will be used.

In section 4.1.3. of the initial registry document, it shows the following URN:

URN: Prefix urn:ietf:params:performance:metric:<name>

I had understood these will not be going under “params” and also in this example “performance” is expanded.  Please confirm that this should not be under params and wheter “perf” or “performance” should be used.

This also appears in section 9.1.3.

Answers to these questions will contribute to the full review which I hope to have to you all later today.

Thanks!

--Michelle

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 7 Mar 2017 17:24:18 +0000

Hi Michelle,

You're right, section 7 ( and 8) are different from
the earlier ones, in that it specifies 5 separate 
Registry entries with unique IDs for each one.

Section 7.0 says:
   Note: Each Registry "Name" below specifies a single registry entry,
   whose output format varies according to a component of the name that
   specifies one form of statistical summary.

   IANA is asked to assign a different numeric identifiers to each Name.
   All column entries beside the Summary and Output categories are the
   same, thus this section proposes five closely-related registry
   entries.  As a result, IANA is also asked to assign corresponding
   URIs and URLs.

Every section, except section 7.4.2 is the same for all 5 registry entries.
7.4.2 contains subsections that correspond to each metric name,
so 7.4.2.1 "95Percentile" will correspond to the metric ending in 95Percentile.

As I was updating the draft yesterday, I noted that the URN sections were
Not consistent.  I will enusre that they are before uploading the revised
version.  

The URN we plan to request is   urn:ietf:metrics:perf: 
with two new sub-namespaces.

Hope this helps! I'll send the revised text after your complete review
later today.

Thanks again,
Al

________________________________________
From: Michelle Cotton [[email-masked]]
Sent: Tuesday, March 07, 2017 10:44 AM
To: MORTON, ALFRED C (AL)
Cc: [email-masked]; Amanda Baber; Sabrina Tanamal
Subject: Follow-up questions for ippm drafts

Hi Al,

urn:ietf:metric:perf:

Thanks!

--Michelle