Subject: Re: [ippm] I-D Action: draft-ietf-ippm-alt-mark-05.txt

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 4 Jul 2017 00:08:17 +0000

Ciao, Giuseppe! (Hi, Al)

Thanks for closing the loop on the list with the review, and for addressing comments and incorporating updates!

Looking at the diffs, I noticed the following new section:
https://tools.ietf.org/html/draft-ietf-ippm-alt-mark-05#section-5.3

Which includes text like:
   [I-D.mirsky-sfc-pmamm] describes how the alternate marking method can
   be used as the passive performance measurement method in a Service
   Function Chaining (SFC) domain.

I would love to hear Al’s take on this as the author of RFC 7799.

(and BTW, seems quite premature to reference that individual draft which targets SFC, when it does not even specify location of fields)

I get it that there are fields purposefully defined for alternate marking, as opposed to overloading other fields.

However, https://tools.ietf.org/html/rfc7799#section-3.6
      MUST NOT add, change, or remove packets or fields or
      change field values anywhere along the path

So this is changing field values, even through the fields are for this purpose. This really looks to me like a Hybrid. The extreme case is adding a shim like IOAM — is that passive? We agreed it is Hybrid.

Al, what do you think?

In any event, Giuseppe, thanks much for the rev++!

— Carlos.

On Jun 26, 2017, at 10:26 AM, Fioccola Giuseppe <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,
This new version of draft-ietf-ippm-alt-mark addresses comments received during WGLC phase.
I have included all the comments and the most important changes are:
- the title is now "Alternate Marking method for passive and hybrid performance monitoring".
- the addition of a paragraph in the introduction section about the RFC7799 definitions.
In addition there are other minor changes and typos.

Thanks to all the reviewers,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di [email-masked]<mailto:[email-masked]>
Inviato: lunedì 26 giugno 2017 16:16
A: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Oggetto: [ippm] I-D Action: draft-ietf-ippm-alt-mark-05.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Metrics of the IETF.

       Title           : Alternate Marking method for passive and hybrid performance monitoring
       Authors         : Giuseppe Fioccola
                         Alessandro Capello
                         Mauro Cociglio
                         Luca Castaldelli
                         Mach(Guoyi) Chen
                         Lianshu Zheng
                         Greg Mirsky
                         Tal Mizrahi
Filename        : draft-ietf-ippm-alt-mark-05.txt
Pages           : 31
Date            : 2017-06-26

Abstract:
  This document describes a method to perform packet loss, delay and
  jitter measurements on live traffic.  This method is based on
  Alternate Marking (Coloring) technique.  A report on the operational
  experiment done at Telecom Italia is explained in order to give an
  example and show the method applicability.  This technique can be
  applied in various situations as detailed in this document and could
  be considered passive or hybrid depending on the application.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-alt-mark-05
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-alt-mark-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-alt-mark-05

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

—
Carlos Pignataro, [email-masked]<mailto:[email-masked]>

“Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."

---

From: Fioccola Giuseppe <[email-masked]>
Date: Tue, 4 Jul 2017 08:52:00 +0000

Hi Carlos,
Agree, now the passive appellative is a little bit augmented for the SFC use case (we are not sure that SFC will dedicate 1 or 2 bits for alternate marking method).
Instead the BIER use case allow us to speak about passive performance measurements.
I’m taking note of this modification to do, upon receiving Al’s opinion as well.

Many thanks for your interest in this topic.
So, seen your experience within IETF and seen that IPPM is looking for a volunteer, would be great if you are willing to shepherd draft-ietf-ippm-alt-mark. ☺
What do you think?

Giuseppe

Da: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Inviato: martedì 4 luglio 2017 02:08
A: Fioccola Giuseppe; Al Morton
Cc: [email-masked]; [email-masked]; [email-masked]
Oggetto: Re: [ippm] I-D Action: draft-ietf-ippm-alt-mark-05.txt

Ciao, Giuseppe! (Hi, Al)

Al, what do you think?

— Carlos.

Hi All,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di [email-masked]<mailto:[email-masked]>
Inviato: lunedì 26 giugno 2017 16:16
A: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Oggetto: [ippm] I-D Action: draft-ietf-ippm-alt-mark-05.txt

Abstract:

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

—

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 4 Jul 2017 18:22:41 +0000

Hi Carlos and Giuseppe,

Thanks for raising the issue of the new text, Carlos,
which is clearly related to recent exchanges on the mailing list,
(where I agree with you):

The RFC 7799 discussion of "Class C" is about equivalent results.
There is no "conversion from hybrid to passive method" after extensive testing
shows that the results with each technique produces equivalent results
for a specific path under test. So, the wording:

"   [I-D.mirsky-sfc-pmamm] describes how the alternate marking method can
   be used as the passive performance measurement method in a Service
   Function Chaining (SFC) domain. "

 is suspect, pending further investigation.

Let's move ahead carefully here. There seems to be a
pattern of re-interpretation that could be an unnecessary 
use of  WG resources. 

Thanks and regards,
Al
 
________________________________________
From: Carlos Pignataro (cpignata) [[email-masked]]
Sent: Monday, July 03, 2017 8:08 PM
To: Fioccola Giuseppe; MORTON, ALFRED C (AL)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [ippm]  I-D Action: draft-ietf-ippm-alt-mark-05.txt

Ciao, Giuseppe! (Hi, Al)

Looking at the diffs, I noticed the following new section:
https://tools.ietf.org/html/draft-ietf-ippm-alt-mark-05#section-5.3<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dalt-2Dmark-2D05-23section-2D5.3&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=tH13nWRgBvpVXm_Ehpnqf_WWy6nYuD66GrMih-rsDfg&s=xGD0h-l8szaulPh2EmCSuHdktzu1u5ljLJldgGDIbxY&e=>

However, https://tools.ietf.org/html/rfc7799#section-3.6<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc7799-23section-2D3.6&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=tH13nWRgBvpVXm_Ehpnqf_WWy6nYuD66GrMih-rsDfg&s=o0yb8c6ZWuEXTmjNZS--JP3H13p-QBamnlBpVUKBiQg&e=>
      MUST NOT add, change, or remove packets or fields or
      change field values anywhere along the path

Al, what do you think?

— Carlos.

Hi All,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di [email-masked]<mailto:[email-masked]>
Inviato: lunedì 26 giugno 2017 16:16
A: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Oggetto: [ippm] I-D Action: draft-ietf-ippm-alt-mark-05.txt

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dalt-2Dmark_&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=tH13nWRgBvpVXm_Ehpnqf_WWy6nYuD66GrMih-rsDfg&s=gKaFcra0TCvmYvC7RGFAS9BhwtS7gfEJxAWVVjPn-tY&e=>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-alt-mark-05<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dalt-2Dmark-2D05&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=tH13nWRgBvpVXm_Ehpnqf_WWy6nYuD66GrMih-rsDfg&s=ugqXnkEKhEg3lHI-Wt59PT0jcEnLbMoR9bUUEa7NHt4&e=>
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-alt-mark-05

—

---

From: Fioccola Giuseppe <[email-masked]>
Date: Wed, 5 Jul 2017 08:53:54 +0000

Hi Al and Carlos,
Thank you, Al, for giving your valuable opinion. 
I also agree and the statement you mention will be revised or omitted in the next version that I can publish immediately after the submission pre-meeting block.

Thanks,

Giuseppe

-----Messaggio originale-----
Da: MORTON, ALFRED C (AL) [mailto:[email-masked]] 
Inviato: martedì 4 luglio 2017 20:23
A: Carlos Pignataro (cpignata); Fioccola Giuseppe
Cc: [email-masked]; [email-masked]; [email-masked]
Oggetto: RE: [ippm] I-D Action: draft-ietf-ippm-alt-mark-05.txt

Hi Carlos and Giuseppe,

Thanks for raising the issue of the new text, Carlos, which is clearly related to recent exchanges on the mailing list, (where I agree with you):

The RFC 7799 discussion of "Class C" is about equivalent results.
There is no "conversion from hybrid to passive method" after extensive testing shows that the results with each technique produces equivalent results for a specific path under test. So, the wording:

Let's move ahead carefully here. There seems to be a pattern of re-interpretation that could be an unnecessary use of  WG resources. 

Thanks and regards,
Al

Ciao, Giuseppe! (Hi, Al)

I would love to hear Al's take on this as the author of RFC 7799.

So this is changing field values, even through the fields are for this purpose. This really looks to me like a Hybrid. The extreme case is adding a shim like IOAM - is that passive? We agreed it is Hybrid.

Al, what do you think?

- Carlos.

Hi All,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di [email-masked]<mailto:[email-masked]>
Inviato: lunedì 26 giugno 2017 16:16
A: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Oggetto: [ippm] I-D Action: draft-ietf-ippm-alt-mark-05.txt

Abstract:

-

"Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."