Subject: [ippm] discussion on ioam data type extension

From: Haoyu song <[email-masked]>
Date: Thu, 20 Jul 2017 09:46:26 +0000

Dear WG members and those who authored or are interested in the IOAM work,

Since IOAM has been adopted, we'd like to have some deep discussion on some related issues. Let's first start from the following one.
We'd like to hear your opinion. We especially want to learn from people who are familiar with data plane technologies, chip design, and applications.

Do you think we need to consider to support more standard data types?
Current scheme support 16 types in total and 14 have been defined. Do you think this is enough in conceivable future?

The potential new data types that I can think of include identify for flows passing packet transforming middle boxes, data for optical/mobile/wireless network information.
Do you think these use cases make sense or not? Do you have other use cases?

If we think the data type needs to be extended, then what's the best scheme?
TLV is an obvious option, but it has two drawbacks (1) not comply with the current bitmap scheme; (2) not perform well on systems supporting parallel processing; (3) code efficiency is not as good as bitmap (e.g., 1 type + length would consume at least two bytes while a two-byte bitmap can indicate 16 new types)
Do you have any argument to support either way (TLV or bitmap) for data type extension?

I think we should address these issues earlier than later. Your feedbacks are highly appreciated. Thank you very much!

Please refer the following doc for more information.
https://datatracker.ietf.org/doc/draft-song-ippm-ioam-scalability/

Best,
Haoyu

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 20 Jul 2017 12:47:56 +0100

Hello Haoyu,

> Since IOAM has been adopted, we'd like to have some deep
> discussion on some related issues.

I applaud your desire for deep discussion, and thank you for bring them to the
list.

But I think we should defer to the chairs to make declarations of adoption. And
I believe that the poll is open until "EOB CEST (UTC +2) Tuesday 20 June 2017."
That is, it is still running.

Thanks,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 20 Jul 2017 12:55:23 +0100

Oh, I'm an idiot!

This month is July. 

More coffee please.

Many apologies

Adrian

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: 20 July 2017 12:48
> To: 'Haoyu song'; [email-masked]
> Subject: Re: [ippm] discussion on ioam data type extension
> 
> Hello Haoyu,
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Haoyu song <[email-masked]>
Date: Mon, 31 Jul 2017 18:44:14 +0000

Dear all,

I repost the following message in case you were busy and ignored it during the Prague meeting week. I think these issues are important to make IOAM future proof so please do help. Thanks!

Best,
Haoyu

From: ippm [mailto:[email-masked]] On Behalf Of Haoyu song
Sent: Thursday, July 20, 2017 2:46 AM
To: [email-masked]
Subject: [ippm] discussion on ioam data type extension

Best,
Haoyu