Subject: [ippm] Comment on draft-ietf-ippm-ioam-data-00

From: Liyizhou <[email-masked]>
Date: Thu, 26 Oct 2017 08:15:58 +0000

Hi co-authors,

draft-ietf-ippm-ioam-data-00 section 4.1.3 defines  app_data  and Opaque State Snapshot without N/A value .

>From the interoperability point of view, I would suggest to allow value 0xFFFFFFFF or a invalid indicator  to be filled if the node has no knowledge or intention to populate them. This is more friendly to hardware compliance design.

Thanks,
Yizhou

---

From: Liyizhou <[email-masked]>
Date: Sat, 28 Oct 2017 03:01:53 +0000

Hi,

In current section 4.1.2 Incremental Trace Option of the abovementioned document, when assessing the hardware implementation for timestamp and transit delay, there is a potential concern.

Timestamp is expected to be the first thing to be handled in pipeline and the transit delay should be last thing right before the packet is sent out in order to the make these numbers accurate.

Most packet parsers have the limit around 80-160B for packet editing. Take 96B as a typical number. MAC header with single vlan (18B) + IPv6 header (40B) + UDP (8B) + GPE (8B) + ioam header (4B) + option header (4B) + trace header( 4B) = 86B

With node_id and interface_id options  (8B) in front of time relevant option, timestamp starts from 94B which is almost not editable with 96B limit.

So it would be reasonable to put time relevant options as close to header as possible since accuracy with hardware processing is required while some info like node_id are more static and there would be some other way to deal with it.

Shall we swap the sequence for them, i.e. put current flags 2,3 & 4 which are timestamps and transit delay to  flag 0,1 & 2, and put current flags 0&1 which are node_id and interface_id to flag 3 &4?

Thanks,
Yizhou

From: ippm [mailto:[email-masked]] On Behalf Of Liyizhou
Sent: Thursday, October 26, 2017 4:16 PM
To: [email-masked]; [email-masked]
Cc: Guanyu; [email-masked]
Subject: [ippm] Comment on draft-ietf-ippm-ioam-data-00

Hi co-authors,

Thanks,
Yizhou