Subject: [ippm] Clock synchronization and the RFC 7679 (A One-Way Delay Metric for IP Performance Metrics)

From: J Ignacio Alvarez-Hamelin <[email-masked]>
Date: Wed, 8 Nov 2017 10:51:05 -0300

Dear all,

The one-way delay measurements need the clock synchronization between the two endpoints. Moreover, if you are interested in learning how congestioned is a particular path, you need to study the dynamics of delay (usually measured as RTT) on each way. The actual methods of clock synchronization include NTP, TSClosk, and IEEE-1588. While last two are used in a LAN environment, NTP is wide used in WAN or Internet in general. 
Due to NTP has not good accuracy (around 10ms and even worse when computers are far from NTP's sources), we are developing a new clock synchronization method for two endpoints on the Internet. This proposed approach could be useful for learning about path congestion since it can achieve an error of 10microseconds without any supplementary hardware. 
I think that next meeting could be an opportunity to present it if this WG welcomes this topic. 

With my best regards,

Dr. Ing. José Ignacio Alvarez-Hamelin
_______________________________________________________________

CONICET and Facultad de Ingeniería, Universidad de Buenos Aires
Av. Paseo Colón 850 - C1063ACV - Buenos Aires - Argentina
+54 (11) 5285 0716 / 5285 0705
e-mail: [email-masked]
web: http://cnet.fi.uba.ar/ignacio.alvarez-hamelin/
_______________________________________________________________

---

From: Geib, Rüdiger <[email-masked]>
Date: Wed, 8 Nov 2017 15:39:59 +0000

Hi Ignacio,

that sounds interesting. An Internet Draft may be a good starting point. 

There seem to be two aspects:
- how to make good use of accurate timestamps is known to most IPPM members
- if there's any standardization activity required by IETF and here specifically the IPPM WG 
  to achieve these accurate timestamps, then please post an ID. 

If there's no activity required by IPPM, I'd still be interested in reading a publication of your research. If there's a suitable document, I'd be grateful if you were able to distribute a link.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: ippm [mailto:[email-masked]] Im Auftrag von J Ignacio Alvarez-Hamelin
Gesendet: Mittwoch, 8. November 2017 14:51
An: [email-masked]; [email-masked]
Betreff: [ippm] Clock synchronization and the RFC 7679 (A One-Way Delay Metric for IP Performance Metrics)

Dear all,

With my best regards,

CONICET and Facultad de Ingeniería, Universidad de Buenos Aires Av. Paseo Colón 850 - C1063ACV - Buenos Aires - Argentina

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm