Subject: [ippm] Alissa Cooper's No Objection on draft-ietf-ippm-alt-mark-13: (with COMMENT)

From: Alissa Cooper <[email-masked]>
Date: Wed, 29 Nov 2017 18:35:50 -0800

Alissa Cooper has entered the following ballot position for
draft-ietf-ippm-alt-mark-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The normative SHOULD in Sec 5.1.1 seems a bit troubling. If there is to be a
normative recommendation about this, wouldn't it be a MUST? If not, under what
circumstances would it be ok to flip header bits at one endpoint or at an
intermediate node to color a packet when the other endpoint might interpret
those bits as being used for a different purpose?

---

From: Fioccola Giuseppe <[email-masked]>
Date: Thu, 30 Nov 2017 09:51:06 +0000

Hi Alissa,
Thank you for your opinion of the document.
Please see my answer below, tagged as [GF].

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: Alissa Cooper [mailto:[email-masked]] 
Inviato: giovedì 30 novembre 2017 03:36
A: The IESG
Cc: [email-masked]; Carlos Pignataro; [email-masked]; [email-masked]; [email-masked]
Oggetto: Alissa Cooper's No Objection on draft-ietf-ippm-alt-mark-13: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

The normative SHOULD in Sec 5.1.1 seems a bit troubling. If there is to be a normative recommendation about this, wouldn't it be a MUST? If not, under what circumstances would it be ok to flip header bits at one endpoint or at an intermediate node to color a packet when the other endpoint might interpret those bits as being used for a different purpose?

[GF]: You are right, we should explain better this point. The restoring technique is described because is used in our experiment exactly for the reason you bring up. In our experiment we monitor a section of an end-to-end service and we don't want to take the risk that the modified bit in the DSCP header is misinterpreted outside the Alternate Marking monitoring domain. From the network operator perspective, it is ok to flip header bits (not dedicated to alternate marking method) if those bits are not used for other scope. But this can be done only in a fully managed network domain and the initial value has to be restored for the packets outgoing from the managed domain. 

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 30 Nov 2017 14:19:33 +0000

Ciao, Giuseppe,

On 11/30/17, 4:51 AM, "Fioccola Giuseppe" <[email-masked]> wrote:

    Hi Alissa,

    Best Regards,

    Giuseppe

    -----Messaggio originale-----

    A: The IESG

    COMMENT:

[Carlos] I also think a MUST is perhaps more appropriate here. But also, the first sentence of that paragraph says “Since a Service Provider application is described here”, and I wonder if what is meant is “when an SP app is …” given that the method can be used for “non Service Providers”.

Thanks,

Carlos.

---

From: Fioccola Giuseppe <[email-masked]>
Date: Thu, 30 Nov 2017 14:30:05 +0000

Hi Carlos,

Thanks,

Giuseppe

Da: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Inviato: giovedì 30 novembre 2017 15:20
A: Fioccola Giuseppe; Alissa Cooper; The IESG
Cc: [email-masked]; [email-masked]; [email-masked]
Oggetto: Re: Alissa Cooper's No Objection on draft-ietf-ippm-alt-mark-13: (with COMMENT)

Ciao, Giuseppe,

On 11/30/17, 4:51 AM, "Fioccola Giuseppe" <[email-masked]<mailto:[email-masked]>> wrote:

    Hi Alissa,

    Best Regards,

    Giuseppe

    -----Messaggio originale-----

    A: The IESG

    Cc: [email-masked]<mailto:[email-masked]>; Carlos Pignataro; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

    COMMENT:

[GF] Of course, “MUST“ is more appropriate here. Also agree regarding your proposed change. Note that 5.1.1 is a subsection of 5.1 and it explains an issue that refers to the operational experiment and not to a general application of the methodology.

Thanks,

Carlos.

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 30 Nov 2017 15:01:02 +0000

Thank you!

Sent from my iPad

On Nov 30, 2017, at 9:30 AM, Fioccola Giuseppe <[email-masked]<mailto:[email-masked]>> wrote:

Hi Carlos,

Thanks,

Giuseppe

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Ciao, Giuseppe,

    Hi Alissa,

    Best Regards,

    Giuseppe

    -----Messaggio originale-----

    A: The IESG

    COMMENT:

Thanks,

Carlos.