Subject: Re: [ippm] Shepherd writeup: draft-ietf-ippm-twamp-yang-04

From: Greg Mirsky <[email-masked]>
Date: Sat, 11 Nov 2017 13:02:44 +0800

Hi Al,
excellent! I fully agree with the proposed new text and in particular with
the "for future specifications involving

TWAMP-Test to use this port as a default port".

Regards,

Greg

On Sat, Nov 11, 2017 at 10:54 AM, MORTON, ALFRED C (AL) <[email-masked]>
wrote:

> Hi Greg and all,
>
>
>
> We can clarify the wording in the –port draft,
>
> at least. I suggest to take the long sentence
>
> I wrote and structure it differently in three
>
> sentences:
>
>
>
> OLD
>
>    It may simplify some operations to have a well-known port
>
>    available for the Test protocols as a default port, and this memo
>
>    requests re-assignment of the UDP well-known port from the Control
>
>    protocol to the Test protocol (see the IANA Considerations
>
>    Section 7).
>
>
>
> NEW
>
> This memo requests re-assignment of the UDP well-known port from
>
> the Control protocol to the Test protocol (see the IANA
>
> Considerations Section 7).
>
>
>
> Use of this UDP port is OPTIONAL in standards-track OWAMP and TWAMP.
>
>
>
> It may simplify some operations to have a well-known port available
>
> for the Test protocols, or for future specifications involving
>
> TWAMP-Test to use this port as a default port.
>
>
>
> -=-=-=-=-
>
>
>
> It will also help to consider how we represent an option like
>
> this in the TWAMP YANG model, before we’re done with the wording ...
>
>
>
> regards,
>
> Al
>
>
>
>
>
>
>
> *From:* Greg Mirsky [mailto:[email-masked] <[email-masked]>]
>
> *Sent:* Monday, October 23, 2017 10:08 AM
>
> *To:* MORTON, ALFRED C (AL)
> *Cc:* Nalini J Elkins; IPPM Chairs; IETF IPPM WG
> *Subject:* Re: [ippm] Shepherd writeup: draft-ietf-ippm-twamp-yang-04
>
>
>
> Hi Al,
>
> thank you for your careful consideration of the proposal and the most
> detailed analysis in response. I agree that further discussion is needed.
> Perhaps we can hear from TWAMP implementors.
>
>
>
> Regards,
>
> Greg
>
>
>
> On Fri, Oct 20, 2017 at 11:54 AM, MORTON, ALFRED C (AL) <[email-masked]>
> wrote:
>
> Hi Greg,
>
>
>
> I think it will be difficult to refer to the
>
> re-assigned UDP port assignment as a new “default”
>
> port for all TWAMP Test Receivers. There are
>
> thousands of existing instances of RFC5357
>
> that will not use the re-assigned port.
>
> A new Default would be a kind of requirement
>
> applied retro-actively; I don’t think that works.
>
>
>
> In our re-assignment draft, we have this sentence
>
> in the section on New Well-Known Ports:
>
>
>
>    **It may simplify some operations** to have a well-known port
>
>    available for the Test protocols as a default port, and this memo
>
>    requests re-assignment of the UDP well-known port from the Control
>
>    protocol to the Test protocol (see the IANA Considerations
>
>    Section 7).
>
>
>
> I don’t read this as mandating support for
>
> the UDP port re-assigned to the Test protocol.
>
> We’re just making the well-known port **available**.
>
>
>
> Depending on the progression of the two drafts,
>
> I don’t think I have an issue with “range 862 | 49152..65535;”
>
> but let’s clarify the status of UDP port.
>
>
>
> regards,
>
> Al
>
>
>
>
>
>
>
> *From:* Greg Mirsky [mailto:[email-masked]]
> *Sent:* Friday, October 20, 2017 6:10 AM
> *To:* MORTON, ALFRED C (AL)
> *Cc:* Nalini J Elkins; IPPM Chairs; IETF IPPM WG
>
>
> *Subject:* Re: [ippm] Shepherd writeup: draft-ietf-ippm-twamp-yang-04
>
>
>
> Hi Nalini, et. al,
>
> in Prague meeting the WG had discussed  re-allocation of UDP port 862 as
> TWAMP-Test Receiver port and now we have joint draft OWAMP and TWAMP
> Well-Known Port Assignments
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmorton-2Dippm-2Dport-2Dtwamp-2Dtest_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=bbducXlgExF6ow6zT9UTlqfHopyr-B_u2OefdMVZVuI&s=9Xm1bN7mbll6O1GtB2HjK6hScyCD4h5q2bTL7QWeXFk&e=> ready
> to progress. If and when IANA re-assigns UDP port 862 to TWAMP-Test
> definition of reflector-udp-port must be changed  as it is no longer just dynamic-port-number
> but includes 862. One way to address may be to change type of
> reflector-udp-port to unint32, define range explicitly as "range 862 | 49152..65535;"
> and add "default 862;" as well. The changes are limited but there's some
> time until IANA acts. How these changes to be handled for YANG data model
> of TWAMP?
>
>
>
> Regards,
>
> Greg
>
>
>
> On Wed, Oct 18, 2017 at 9:13 AM, Greg Mirsky <[email-masked]>
> wrote:
>
> Hi Al,
>
> thank you for the most expedient response.
>
>
>
> Regards,
>
> Greg
>
>
>
> On Wed, Oct 18, 2017 at 9:10 AM, MORTON, ALFRED C (AL) <[email-masked]>
> wrote:
>
> Hi Greg, please see reply below,
>
>
>
> *From:* ippm [mailto:[email-masked]] *On Behalf Of *Greg Mirsky
> *Sent:* Wednesday, October 18, 2017 11:58 AM
> *To:* Nalini J Elkins
> *Cc:* IPPM Chairs; IETF IPPM WG
> *Subject:* Re: [ippm] Shepherd writeup: draft-ietf-ippm-twamp-yang-04
>
>
>
> Hi Nalini,
>
> thank you for volunteering for Shepherd of this document.
>
> I've noticed that the Technical Summary section mentions that TWAMP is
> being used to measure bandwidth among other performance parameters. Is that
> in reference to RFC 6802? AFAIK, TWAMP YANG model does not support
> extensions to TWAMP defined in RFC 6802.
>
> *[ACM] *
>
> *No, there are certainly many ways to assess bandwidth with UDP*
>
> *packets which do not involve the features and/or IPR of RFC 6802.*
>
>
>
> *Al*
>
>
>
>
>
> Regards,
>
> Greg
>
>
>
> On Tue, Oct 17, 2017 at 12:44 PM, Nalini J Elkins <
> [email-masked]> wrote:
>
> All,
>
> Please find the Shepherd write up at the link below:
>
> https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-
> yang/shepherdwriteup/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dtwamp-2Dyang_shepherdwriteup_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=NAHj4rOwsFji0DC-l8OmcrrwryVXj9PgIwTiTiJTqcY&s=nuTWIsuiVuV2xq5kK_B8VcIjcACNtUzhaiNpScySNTY&e=>
>
> Thanks,
>
> Nalini Elkins
> CEO and Founder
> Inside Products, Inc.
> www.insidethestack.com
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.insidethestack.com&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=NAHj4rOwsFji0DC-l8OmcrrwryVXj9PgIwTiTiJTqcY&s=bkvR6Q48p83khb55XrjQr5w5vwUlOdUlYZhm-TqT8lo&e=>
> (831) 659-8360
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ippm&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=NAHj4rOwsFji0DC-l8OmcrrwryVXj9PgIwTiTiJTqcY&s=3ELyRN1ZaFdNVH3FTJpL_Wm9J77U2S2mlusqXFnVCLA&e=>
>
>
>
>
>
>
>
>
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sat, 11 Nov 2017 02:54:00 +0000

Hi Greg and all,

OLD

NEW

-=-=-=-=-

regards,
Al

From: Greg Mirsky [mailto:[email-masked]]
Sent: Monday, October 23, 2017 10:08 AM
To: MORTON, ALFRED C (AL)
Cc: Nalini J Elkins; IPPM Chairs; IETF IPPM WG
Subject: Re: [ippm] Shepherd writeup: draft-ietf-ippm-twamp-yang-04

Hi Al,
thank you for your careful consideration of the proposal and the most detailed analysis in response. I agree that further discussion is needed. Perhaps we can hear from TWAMP implementors.

Regards,
Greg

On Fri, Oct 20, 2017 at 11:54 AM, MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

   *It may simplify some operations* to have a well-known port
   available for the Test protocols as a default port, and this memo
   requests re-assignment of the UDP well-known port from the Control
   protocol to the Test protocol (see the IANA Considerations
   Section 7).

I don’t read this as mandating support for
the UDP port re-assigned to the Test protocol.
We’re just making the well-known port *available*.

regards,
Al

From: Greg Mirsky [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, October 20, 2017 6:10 AM
To: MORTON, ALFRED C (AL)
Cc: Nalini J Elkins; IPPM Chairs; IETF IPPM WG

Subject: Re: [ippm] Shepherd writeup: draft-ietf-ippm-twamp-yang-04

Hi Nalini, et. al,
in Prague meeting the WG had discussed  re-allocation of UDP port 862 as TWAMP-Test Receiver port and now we have joint draft OWAMP and TWAMP Well-Known Port Assignments<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dmorton-2Dippm-2Dport-2Dtwamp-2Dtest_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=bbducXlgExF6ow6zT9UTlqfHopyr-B_u2OefdMVZVuI&s=9Xm1bN7mbll6O1GtB2HjK6hScyCD4h5q2bTL7QWeXFk&e=> ready to progress. If and when IANA re-assigns UDP port 862 to TWAMP-Test definition of reflector-udp-port must be changed  as it is no longer just dynamic-port-number but includes 862. One way to address may be to change type of reflector-udp-port to unint32, define range explicitly as "range 862 | 49152..65535;" and add "default 862;" as well. The changes are limited but there's some time until IANA acts. How these changes to be handled for YANG data model of TWAMP?

Regards,
Greg

On Wed, Oct 18, 2017 at 9:13 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
Hi Al,
thank you for the most expedient response.

Regards,
Greg

On Wed, Oct 18, 2017 at 9:10 AM, MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg, please see reply below,

From: ippm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Mirsky
Sent: Wednesday, October 18, 2017 11:58 AM
To: Nalini J Elkins
Cc: IPPM Chairs; IETF IPPM WG
Subject: Re: [ippm] Shepherd writeup: draft-ietf-ippm-twamp-yang-04

Hi Nalini,
thank you for volunteering for Shepherd of this document.
I've noticed that the Technical Summary section mentions that TWAMP is being used to measure bandwidth among other performance parameters. Is that in reference to RFC 6802? AFAIK, TWAMP YANG model does not support extensions to TWAMP defined in RFC 6802.
[ACM]
No, there are certainly many ways to assess bandwidth with UDP
packets which do not involve the features and/or IPR of RFC 6802.

Al

Regards,
Greg

On Tue, Oct 17, 2017 at 12:44 PM, Nalini J Elkins <[email-masked]<mailto:[email-masked]>> wrote:
All,

https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/shepherdwriteup/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dtwamp-2Dyang_shepherdwriteup_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=NAHj4rOwsFji0DC-l8OmcrrwryVXj9PgIwTiTiJTqcY&s=nuTWIsuiVuV2xq5kK_B8VcIjcACNtUzhaiNpScySNTY&e=>

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.insidethestack.com&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=NAHj4rOwsFji0DC-l8OmcrrwryVXj9PgIwTiTiJTqcY&s=bkvR6Q48p83khb55XrjQr5w5vwUlOdUlYZhm-TqT8lo&e=>
(831) 659-8360<tel:%28831%29%20659-8360>

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ippm&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=NAHj4rOwsFji0DC-l8OmcrrwryVXj9PgIwTiTiJTqcY&s=3ELyRN1ZaFdNVH3FTJpL_Wm9J77U2S2mlusqXFnVCLA&e=>