Subject: Re: [ippm] Clock synchronization and the RFC 7679 (A One-Way Delay Metric for IP Performance Metrics)

From: Qin Wu <[email-masked]>
Date: Wed, 8 Nov 2017 16:08:33 +0000

How TSClock is different from NTP or IEEE-1588? Is there any reference to TSClock? Is your new clock synchronization method a software based?

-Qin
-----邮件原件-----
发件人: ippm [mailto:[email-masked]] 代表 J Ignacio Alvarez-Hamelin
发送时间: 2017年11月8日 21:51
收件人: [email-masked]; [email-masked]
主题: [ippm] Clock synchronization and the RFC 7679 (A One-Way Delay Metric for IP Performance Metrics)

Dear all,

The one-way delay measurements need the clock synchronization between the two endpoints. Moreover, if you are interested in learning how congestioned is a particular path, you need to study the dynamics of delay (usually measured as RTT) on each way. The actual methods of clock synchronization include NTP, TSClosk, and IEEE-1588. While last two are used in a LAN environment, NTP is wide used in WAN or Internet in general. 
Due to NTP has not good accuracy (around 10ms and even worse when computers are far from NTP's sources), we are developing a new clock synchronization method for two endpoints on the Internet. This proposed approach could be useful for learning about path congestion since it can achieve an error of 10microseconds without any supplementary hardware. 
I think that next meeting could be an opportunity to present it if this WG welcomes this topic. 

With my best regards,

Dr. Ing. José Ignacio Alvarez-Hamelin
_______________________________________________________________

CONICET and Facultad de Ingeniería, Universidad de Buenos Aires Av. Paseo Colón 850 - C1063ACV - Buenos Aires - Argentina
+54 (11) 5285 0716 / 5285 0705
e-mail: [email-masked]
web: http://cnet.fi.uba.ar/ignacio.alvarez-hamelin/
_______________________________________________________________

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: J Ignacio Alvarez-Hamelin <[email-masked]>
Date: Wed, 8 Nov 2017 15:40:38 -0300

Dear Qin, 

The three methods are quite different, you can find information about TSClock here:
	• Lee, K. S., Wang, H., Shrivastav, V., and Weatherspoon, H. Globally synchronized time via datacenter networks. In Proceedings of the 2016 conference on ACM SIGCOMM 2016 Conference (2016), ACM, pp. 454–467.

The others are simpler to find. My proposition is software based. 

Best,

	Ignacio

Dr. Ing. José Ignacio Alvarez-Hamelin
CONICET and Facultad de Ingeniería, Universidad de Buenos Aires
Av. Paseo Colón 850 - C1063ACV - Buenos Aires - Argentina
+54 (11) 5285 0716 / 5285 0705
e-mail: [email-masked]
web: http://cnet.fi.uba.ar/ignacio.alvarez-hamelin/
_______________________________________________________________

> On Nov 8, 2017, at 1:08 PM, Qin Wu <[email-masked]> wrote:
>