Subject: Re: iSCSI : draft contradicts itself in sections 1.2.5 & 5.5

From: Santosh Rao <[email-masked]>
Date: Thu, 25 Jan 2001 10:05:14 -0800

[email-masked] wrote:

> SHOULD NOT means NOT unless you have a good reason not too. And with a
> digest error you have a good reason to - don't you?

Not if you consider all the problems raised regarding this
"discard and retry" policy on digest errors.
See :
http://ips.pdl.cs.cmu.edu/mail/msg03110.html

- Santosh

>
> Santosh Rao <[email-masked]> on 25/01/2001 00:18:11
>
> Please respond to Santosh Rao <[email-masked]>
>
> To:   IPS Reflector <[email-masked]>
> cc:
> Subject:  iSCSI : draft contradicts itself in sections 1.2.5 & 5.5
>
> Julian,
>
> In Section 1.2.5, the draft states that :
> "A target SHOULD NOT silently discard data and request re-transmission
> through R2T."
>
> In Section 5.5 the draft encourages the above to be performed by stating
> :
> "When a target receives an iSCSI Data PDU with a data payload digest
> error, it MUST discard it and request retransmission with a R2T."
>
> What is the intent of the former statement in Section 1.2.5, when digest
> error recovery requires just the opposite ?
>
> Regards,
> Santosh
>
>  - santoshr.vcf

---

From: [email-masked]
Date: Thu, 25 Jan 2001 19:16:56 +0200

Julo

Julian,

Regards,
Santosh

 - santoshr.vcf