Subject: Re: iSCSI-related conclusions from Orlando interim Meeting

From: [email-masked]
Date: Tue, 23 Jan 2001 16:17:40 +0200

I support this.

Julo

"Jim Hafner" <[email-masked]> on 23/01/2001 00:08:29

Please respond to "Jim Hafner" <[email-masked]>

To:   [email-masked]
cc:
Subject:  Re: iSCSI-related conclusions from Orlando interim Meeting

Mark and David,

Though we haven't discussed this within NDT, this issue is a bit broader
(applicable to all key:value pairs in login and text messages).

Some have suggested full C syntax, others have said that hex is sufficient.

I'd like to support the two most important cases:
1) representation of 'integer' type values with represent a quantity (like
length, size, count, etc.)
2) binary strings (as might occur in WWUIs, or other binary entities that
don't necessarily represent a 'quantity'

For the first, decimal seems the most natural.  For the latter, hex seems
best suited.    For WWUI's, we've already weakly proposed a format that
implies hex.  Perhaps in other cases, the prefix '0x' or the prefix 'hex='
would be a good way to indicate non-decimal format.

Jim Hafner

Mark Bakke <[email-masked]>@ece.cmu.edu on 01-22-2001 06:16:55 AM

Sent by:  [email-masked]

To:   David Robinson <[email-masked]>
cc:   [email-masked]
Subject:  Re: iSCSI-related conclusions from Orlando interim Meeting

That's right.  The N&D team will send a new draft soon with the
encodings.  Some of the options for encoding binary data are hex,
decimal, octal, and uuencode.  We will probably suggest hex; it
uses more space than unicode, but for most binary names, is the
simplest and most readable.  Please stay tuned.

David Robinson wrote:
>
> [email-masked] wrote:
> > It's a bit cryptic.  The conclusion in the room was
> > to convert binary values to/from text representations
> > for the purpose of negotiation (and use UTF-8 for the
> > text).  This was felt to be simpler than defining new
> > formats for binary values.
>
> So if I want to send the binary data 0101101011110000
> I first turn that into text "5AF0" then encode that into
> UTF-8 "5AF0" (printable ASCII is a no-op in UTF-8)?
>
> I'll buy that.
>
> Any statement as to the text encoding? Hex? Decimal? Octal?
>
>         -David

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Tue, 23 Jan 2001 08:48:03 -0600

I agree as well.  Anything that's a number in a text message header
should be decimal.  Anything that is a binary string (WWUI, authentication
info, etc) should be hex.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054