Subject: Re: iSCSI: Logout for a Session

From: Raghavendra Rao <[email-masked]>
Date: Thu, 11 Jan 2001 16:04:12 -0500 (GMT)

> 
> The use of a Logout to close the connection [and the session if this is
> the last connection being closed] is preferred to just closing the TCP
> connection since the logout command PDU provides the other end a "Reason
> Code" that explains the reason for the close.
> 

It may not be possible always to send LOGOUT or get the LOGOUT reach the
target under pathological conditions - So a target must be prepared to
cleanup and perform an equivalent of LOGOUT when the last TCP connection
is closed.

-JP

---

From: [email-masked]
Date: Fri, 12 Jan 2001 11:14:14 +0200

Not necessarily. After a while yes but for a brief interval you may want to
open another connection and recover.

Julo

"Grun, Paul" <[email-masked]> on 11/01/2001 00:16:46

Please respond to "Grun, Paul" <[email-masked]>

To:   "'Matt Wakeley'" <[email-masked]>, IPS Reflector
      <[email-masked]>
cc:
Subject:  RE: iSCSI: Logout for a Session

Isn't a session terminated when the last TCP connection is closed?
-paul

Paul Grun
Intel Corporation
Enterprise Platform Group
Fabric Components Division
(503) 677-6768
[email-masked] <mailto:[email-masked]>

> -----Original Message-----
> From: Matt Wakeley [mailto:[email-masked]]
> Sent: Wednesday, January 10, 2001 12:59 PM
> To: IPS Reflector
> Subject: iSCSI: Logout for a Session
>
>
> Throughout the iSCSI document, it talks about the logout
> command closing a TCP
> connection.  Especially for the purposes of error recover to
> terminate a TCP
> connection and "clean up" so that another TCP connection can
> be established to
> continue the session.  There seems to be no way to indicate
> that a session is
> being terminated.
>
> There should be a flag in the logout command that indicates
> that the *session*
> is being terminated (as well as the TCP connection).
>
> -Matt Wakeley
> Agilent Technologies
>