Subject: iSCSI: data numbering

From: Pierre Labat <[email-masked]>
Date: Mon, 08 Jan 2001 12:14:29 -0800

Julian,

Two points on the data numbering.

1) It seems to me that the negociation of the Data numbering
is useless and must be removed from the spec.

Because :
- there is the P bit in the SCSI data (READ) pdu header
and the initiator must ack if P is set. Doing this way
gives all flexibility to the target.
- if the target wants the data numbering, the initiator
MUST do it.

Based on that, negociating the data numbering doesn't
add any value. We have to remove it. The "P" bit is
perfect.

2) The SCSI data READ pdu header must contains a
target task tag.

Doing that, avoids the target to do a lookup
from the initiator task tag each time it receives
a data ack  (NOP out).

The lookups (using hashing table for ex) must be kept
to a minimum because they slow down operations.
We have to avoid them on the performance path.

In iSCSI the only place where a lookup takes place
is for Abort task (lookup done on the target side)
for "retry" a command (lookup done on the target side)
and for read data ack (lookup done on the target side too).

In the two first operations a lookup on the initiator task tag
can not be avoided because the target may not have time
to give a tag to the initiator before things go wrong.
However it is not a problem because it is not on the performance path.

But for read data acknowledgement, it is on the performance path.
This lookup can be easily avoided if the target provides a tag
in the data PDU, the NOP out passes back this tag to the target.
The tag is the same all along the [READ] command.

Regards,

Pierre

---

From: [email-masked]
Date: Tue, 9 Jan 2001 16:01:47 +0200

Pierre,

1 - is fixed already in 03 (the text was ambiguous)

2 -will fix in 03

Julo

Pierre Labat <[email-masked]> on 08/01/2001 22:14:29

Please respond to Pierre Labat <[email-masked]>

To:   [email-masked]
cc:
Subject:  iSCSI: data numbering

Julian,

Because :

Regards,

Pierre

---

From: [email-masked]
Date: Tue, 9 Jan 2001 18:27:27 +0200

It is already in 03. I discovered it also on rereading. Thanks, Julo

To:   [email-masked]
cc:

Julian,

Because :

Regards,

Pierre