Subject: RE: iSCSI: Logout for a Session

From: "Grun, Paul" <[email-masked]>
Date: Wed, 10 Jan 2001 14:16:46 -0800

Isn't a session terminated when the last TCP connection is closed?
-paul

Paul Grun                                              
Intel Corporation
Enterprise Platform Group
Fabric Components Division
(503) 677-6768
[email-masked] <mailto:[email-masked]> 

> -----Original Message-----
> From: Matt Wakeley [mailto:[email-masked]]
> Sent: Wednesday, January 10, 2001 12:59 PM
> To: IPS Reflector
> Subject: iSCSI: Logout for a Session
> 
> 
> Throughout the iSCSI document, it talks about the logout 
> command closing a TCP
> connection.  Especially for the purposes of error recover to 
> terminate a TCP
> connection and "clean up" so that another TCP connection can 
> be established to
> continue the session.  There seems to be no way to indicate 
> that a session is
> being terminated.
> 
> There should be a flag in the logout command that indicates 
> that the *session*
> is being terminated (as well as the TCP connection).
> 
> -Matt Wakeley
> Agilent Technologies
>

---

From: Santosh Rao <[email-masked]>
Date: Thu, 11 Jan 2001 00:12:49 -0800 (PST)

The use of a Logout to close the connection [and the session if this is
the last connection being closed] is preferred to just closing the TCP
connection since the logout command PDU provides the other end a "Reason
Code" that explains the reason for the close.

2 comments regarding logout :
i) The draft should change :
"An initiator MAY use a logout command to remove a connection from a 
   session."

   to :
"An initiator MUST use a logout command to remove a connection from a 
   session."

This ensures only one way of doing things, communicates a reason code for
the close of connection and does its bit for the cause of successful
interopability.

ii) The reason code :
"2 - Remove the connection at targets requests (requested 
      through an AEN)"

along with the corresponding AEN iSCSI event indicator :
"2    Target requests Logout on this connection "

MUST be removed and targets allowed to originate a logout. This allows
targets the ability to drive the logout and is a useful feature in cases
like targets wishing to commence an online firmware upgrade on one of
their channels. In such situations, it is un-desirable for the targets to
send AENs and then wait [and hope] that the initiator will log the target
out.

For all one knows, several O.S. drivers may decide to ignore AENs !

Targets SHOULD be allowed to originate logouts.

- Santosh

-- 
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################