Subject: RE: Coverage of Data Digest when using Header Digests

From: [email-masked]
Date: Tue, 23 Jan 2001 08:01:15 +0200

Barry,

We are well aware of this catch-22. You'll have to assume the additional
length field is OK and then check the CRC.

Julo

"Barry Reinhold" <[email-masked]> on 22/01/2001 18:40:06

Please respond to "Barry Reinhold" <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:
Subject:  RE: Coverage of Data Digest when using Header Digests

Well,
     If that's the case then you have to use the information in the
unchecked
header to figure out the how to check the header.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, January 22, 2001 11:00 AM
To: [email-masked]
Subject: RE: Coverage of Data Digest when using Header Digests

yes,

Julo

"Barry Reinhold" <[email-masked]> on 22/01/2001 17:49:29

Please respond to "Barry Reinhold" <[email-masked]>

To:   [email-masked], Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  RE: Coverage of Data Digest when using Header Digests

Ok,
     So if the bidi-read length and ADDCDB fields are not in the data
digest
then I assume we have to figure them into the header digest even though
they
are located past the header digets. Is that the expected behavior?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 22, 2001 10:22 AM
To: [email-masked]
Cc: [email-masked]; Barry Reinhold
Subject: Re: Coverage of Data Digest when using Header Digests

Barry-

In particular, the data digest covers only the SCSI Data part of an
iSCSI message; the header digest covers everything else.  This means
that in an 8k write, the data digest will cover only the 8k, and the
header digest will cover everything else.

Hope this helps,

Mark

[email-masked] wrote:
>
> Barry,
>
> Considering that one of the reasons to have a separate header and data
> digest was to enable data
> to carried through proxies, virtualizers etc. the current thinking is
that
> the data digest will cover only the data and the header (including
> extensions) will be covered by the header digest.
>
> Julo
>
> "Barry Reinhold" <[email-masked]> on 21/01/2001 21:50:04
>
> Please respond to "Barry Reinhold" <[email-masked]>
>
> To:   Julian Satran/Haifa/IBM@IBMIL
> cc:
> Subject:  Coverage of Data Digest when using Header Digests
>
> Julian,
>      Is the Data Digest intended to cover whatever follows the 48 byte
> iSCSI
> header? In particular in a command frame which has a CDB > 16 bytes, uses
> bidi, has immediate data, and is using both header and data digests -
what
> would the data digest cover?
>                                                              - barry
> reinhold

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: [email-masked]
Date: Tue, 23 Jan 2001 18:15:58 +0200

Sukha,

The length includes the ADCB and whatever fields are there after the 48
bytes.
It is not "clean" ... nor final :)-

Julo

"Sukha Ghosh" <[email-masked]> on 22/01/2001 21:05:25

Please respond to [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:   "Barry Reinhold" <[email-masked]>
Subject:  RE: Coverage of Data Digest when using Header Digests

Julian,

     In this case of optional extended header (Header length > 48 bytes,
AddCDB
having non-zero value), since the digest coverage is through the Header
digest, does it also mean that the Length field will cover the length after
the header extension or the length is all the bytes except the 48 byte
header and the padding bytes?

Thanks

Sukha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, January 22, 2001 1:25 AM
To: [email-masked]
Cc: Barry Reinhold
Subject: Re: Coverage of Data Digest when using Header Digests

Barry,

to carried through proxies, virtualizers etc. the current thinking is that

Julo

Julian,
     Is the Data Digest intended to cover whatever follows the 48 byte
iSCSI
header? In particular in a command frame which has a CDB > 16 bytes, uses
bidi, has immediate data, and is using both header and data digests - what
would the data digest cover?
                                                             - barry
reinhold