Subject: Questions about FCIP

From: "Kavi, Prabhu" <[email-masked]>
Date: Mon, 8 Jan 2001 13:07:41 -0500

I have some questions about the Fibre Channel over TCP/IP I-D.
I understand IP networks well, but am a Fibre Channel newbie and
am asking these questions to learn more about Fibre Channel's 
requirements rather than to challenge the document.  Here are
my questions:

1.  Why Fibre Channel over TCP, rather than over UDP?  Is it 
    because of an expectation of lossy IP networks?  Or is it
    equally valid to put Fibre Channel over UDP (and therefore
    can be the subject of another I-D).
2.  What are the typical values of the ED_TOV and R_A_TOV timers? 
    Do I understand this right to say that these timers effectively
    limit the latency across the IP network?
3.  What is an acceptable loss ratio of Fibre Channel datagrams
    that still allows the SAN devices to deliver appropriate
    end user performance (order of magnitude estimate is 
    sufficient).

The reasons I ask are:

* I believe it is invalid to assume that IP networks are 
  necessarily more lossy than Fibre Channel networks.  A 
  well-engineered IP network, using a combination of both 
  Diff-Serv and MPLS, can achieve (close to) zero loss.
* Stacking one reliable delivery protocol on top of another can
  possibly lead to interesting performance problems after a loss
  occurs, depending upon the timer values for TCP and Fibre Channel.

Thanks in advance for your answers.

Prabhu Kavi
----------------------------------------------------------------------
Prabhu Kavi                     Phone:  1-978-264-4900 x125 
Director, Adv. Prod. Planning   Fax:    1-978-264-0671
Tenor Networks                  Email:  [email-masked]
100 Nagog Park                  WWW:    www.tenornetworks.com
Acton, MA 01720

---

From: Matt Wakeley <[email-masked]>
Date: Tue, 09 Jan 2001 15:48:28 -0800

>     can be the subject of another I-D).

Because UDP does not implement congestion management.

>     limit the latency across the IP network?

In Fibre Channel, the ED_TOV and R_A_TOV timer values are advertised from the
switches to the N_Ports during fabric login.  If a switch knows it has a FCIP
port, it could increase theses values as needed (but they are already
unreasonably huge to begin with)

>   occurs, depending upon the timer values for TCP and Fibre Channel.

You talk about stacking one reliable protocol on another.  TCP is one, what is
the other?  Don't kid yourself into thinking fibre channel is reliable!

-Matt Wakeley
Agilent Technologies

---

From: "Murali Rajagopal" <[email-masked]>
Date: Thu, 11 Jan 2001 15:17:12 -0800

Kavi:

We will be discussing your second item in the upcoming interim meeting on

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Kavi, Prabhu
Sent: Monday, January 08, 2001 10:08 AM
To: [email-masked]'
Subject: Questions about FCIP

The reasons I ask are:

Prabhu Kavi

---

From: "Murali Rajagopal" <[email-masked]>
Date: Thu, 11 Jan 2001 15:55:13 -0800

Kavi:

We'll be discussing your second item in the upcoming meeting in Florida (Wed
17th Jan.).

Regards,

Murali

-----Original Message-----

The reasons I ask are:

Prabhu Kavi