Subject: Re: iSCSI : Abort Task Response violates SAM-2.

From: [email-masked]
Date: Sat, 13 Jan 2001 18:26:07 +0200

Santosh,

I would certainly not have used "violates the SAM-2" when what you probably
meant that is that wording should be in line with SAM-2.  I will change the
wording to read as in SAM-2 although in my English they have exactly the
same meaning.

Julo

Santosh Rao <[email-masked]> on 13/01/2001 06:06:31

Please respond to Santosh Rao <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  iSCSI : Abort Task Response violates SAM-2.

Julian,

SAM-2 Rev 15 Section 6.1 states that  :

"a response of FUNCTION COMPLETE shall indicate task was aborted or task
was
not in task set".

The iSCSI draft is violating SAM-2 by returning "task not found" when the
task
was not in task set.

Thanks,
Santosh

[email-masked] wrote:

> Well then Task does not exist will get all enough differentiation.
> If you could not agree with reject (not enough differentiation) another
use
> can
> have difficulty in accepting the other extreme - completed when a task is
> really not found.
>
> Julo
>
> Pierre Labat <[email-masked]> on 10/01/2001 01:00:01
>
> Please respond to Pierre Labat <[email-masked]>
>
> To:   [email-masked]
> cc:
> Subject:  iSCSI : Further review feedback on latest iSCSI-02.txt draft.
>
> Julian
>
> >>>>>>>>>
> Section 2.6. SCSI Task Management Response
> ==================================
> The referenced Task Tag field can be removed since the
> "No Task Found" response error is not valid.
> (A Target should respond with an accept for an Abort Task
> request specifying an invalid Initator Task Tag).
> [js]Different people have different opinions on this - even with HP -
> talk
> to Pierre! [/js]
> <<<<<<<<<
>
> We are in agreement, it is just a point of terminology.
>
> Some month ago, we had a discussion on the IPS about what to do in
> case the target doesn't find the task to abort.
> I requested that the Abort response returns "OK"
> (something different than Function rejected).
> You added the value "Task not found".
> But "Function complete" can works too.
>
> Regards,
>
> Pierre

 - santoshr.vcf

---

From: Santosh Rao <[email-masked]>
Date: Sat, 13 Jan 2001 14:07:06 -0800 (PST)

Julian,

Thanks for the clarification. The "Referenced Task Tag" field in the Abort
Task response PDU also could be removed since it was provided to accompany
the "No Task Found" response indicating the task tag.

Thanks & Regards,
Santosh

-- 
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################