Subject: RE: iFCP as an IP Storage Work Item

From: Charles Monia <[email-masked]>
Date: Mon, 8 Jan 2001 11:04:45 -0800

Hi Doug:

Maybe we're closer to agreement than you think.

Here's my response to Murali's call for consensus:

"Thanks for bringing this matter to a head.

Here's my .02:

1. Merging the iFCP and FCIP specifications --  No, not feasible on
technical grounds.    Anyhow, I think this is one decision that can't be
made by fiat.

2. Definition of a common encapsulation protocol --  Technically possible,
practically not feasible. From my perspective, it's risky and difficult to
manage as the client specs evolve over time.  Besides, I assume the FCIP
encapsulation is a done deal. Bottom line: I vote no (but would grudgingly
try to accommodate the WG consensus on this matter)."

The gist is that we're willing work with the FCIP community to achieve a
common encapsulation if that is the consensus of the WG.  Since the FCIP
folks also have a stake in this, I suggest addressing your concerns to them
as well.

Charles

> -----Original Message-----
> From: Douglas Otis [mailto:[email-masked]]
> Sent: Monday, January 08, 2001 10:41 AM
> To: Charles Monia; Y P Cheng
> Cc: Ips (E-mail)
> Subject: RE: iFCP as an IP Storage Work Item
> 
> 
> Charles,
> 
> With respect to merging FCIP and iFCP encapsulation, there are many
> technical merits for doing so without looking at the 
> marketing issues.  You
> have noted in your view of FCIP and iFCP as being in two 
> separate markets
> and thus not likely to cooperate at the encapsulation level. 
> It would seem
> you use marketing concerns in your positions.  I would hope 
> however that
> this group would have the ability to bring these two segments 
> of the SAN
> market a bit closer together.  I also see merit in the iFCP 
> effort in that
> iSCSI is divergent with respect to existing markets.  There 
> will be many
> areas where FCIP and iFCP will find common solutions with many common
> problems.
> 
> In the spirit of furthering common goals, iFCP and FCIP 
> should use a common
> encapsulation where possible.  I would not wish to bet if 
> iFCP or iSCSI
> becomes a larger player in the marketplace.  Looking at 
> complexity, I would
> not place too many chips on iSCSI.  I do not think this group needs to
> decide such winners and losers.  If there were two iSCSI 
> solutions or two
> iFCP solutions then there would a reason to merge these 
> proposals.  If there
> are two FC encapsulations proposals, this two should be merged.
> 
> Doug
> 

<stuff deleted>

---

From: "Douglas Otis" <[email-masked]>
Date: Mon, 8 Jan 2001 13:00:16 -0800

Charles,

Standards consolidation can not be placed one individual.  Those wishing to
create any FC encapsulating transport whether it is eventually used as a
tunnel, gateway, or target would need to justify lack of cooperation in
encapsulation consolidation.  Not interfering with a potential iSCSI market
is little justification for making an exception.  In my view, neither has a
strong case for not consolidating their encapsulation schemes.

Your concerns about eventual extensions can be handled through provisions
within the encapsulating structures.  In the long run, finding a means for
independent maturation will not degrade a final product, but improve it.
Success of any solution using a common encapsulation will improve the
standings of all solutions.  In that case, you may have a smaller piece of
the pie, but the pie gets bigger.

Doug