Subject: iFCP: Please calm down ...

From: [email-masked]
Date: Mon, 8 Jan 2001 18:50:15 -0500

Folks,

Some of the discussion about iFCP has drifted into
business and marketing concerns.  If you really feel
that you must share such items, please send them
directly to Steve Bellovin ([email-masked])
and myself - the list is for technical discussions
only.  The input on whether iFCP should be a work
item is appreciated, but some of it is getting
repetitive - I would ask people posting on this topic
to make sure they have something new to add, as opposed
to a "me too" or a desire to have the last word in
some discussion.  "me too"s can be sent directly
to Steve and me rather than consuming list bandwidth,
and "who has the last word on what" is not among the
important decision criteria for whether to undertake
work on iFCP.

I suspect the time from here to a decision is still
measured in weeks for a variety of reasons.  I would
hope that the enthusiasm equal to that shown for
commenting on iFCP could be applied to working out
the details of both iSCSI and FCIP on the list and
at the interim meeting - progress on these protocols
is necessary for the continued health of the WG.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 9 Jan 2001 09:33:06 -0800

At IETF 49, we had a presentation on use of IPSEC in
iSCSI. While I'm generally positive on the concept
of re-using IPSEC in this way, there are some things
to think about. 

One of these is the effect of the IPSEC replay window
on TCP behavior. At the 1+ Gbps speeds of iSCSI, it
strikes me that even a small variation in delay 
between two alternate paths will result in falling
outside the IPSEC replay window if it is set to a
small, fixed value (say 64 packets). 

So the size of the IPSEC replay window should probably
scale with transmission speed. 

Do we understand how this ought to work and is there
a potential for some unforseen effects?

Inquiring minds want to know ;)