Subject: iSCSI: Question on MaxCmdRN update rule

From: Charles Monia <[email-masked]>
Date: Wed, 10 Jan 2001 19:15:08 -0800

Hi Julo:

I don't understand the MaxCmdRN update policy as defined below:

"2.3.10 MaxCmdRN - maximum CmdRN acceptable from this initiator

MaxCmdRN is a reference number that the target iSCSI returns to the
initiator to indicate the maximum CmdRN the initiator can send. The
initiator must ignore values not between the current value of the
ExpCmdRN and MaxCmdRN; this may be required when updates arrive out
of order (they travel on different TCP connections)."

As I interpret the above, values not within the upper and lower limits given
above must be discarded.

I would think this parameter should be updated when a new value greater than
the current MaxCmdRN is received.

Charles

---

From: [email-masked]
Date: Fri, 12 Jan 2001 11:52:30 +0200

Charles,

What version of the document are you referring to?

Julo

Charles Monia <[email-masked]> on 11/01/2001 05:15:08

Please respond to Charles Monia <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   "Ips (E-mail)" <[email-masked]>
Subject:  iSCSI: Question on MaxCmdRN update rule

Hi Julo:

As I interpret the above, values not within the upper and lower limits
given
above must be discarded.

I would think this parameter should be updated when a new value greater
than
the current MaxCmdRN is received.

Charles

---

From: Charles Monia <[email-masked]>
Date: Fri, 12 Jan 2001 16:03:28 -0800

Hi Julo:

I was referring to rev 02, which was current as of the posting date.

The problem is fixed in rev 03.

Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, January 12, 2001 1:53 AM
> To: [email-masked]
> Subject: Re: iSCSI: Question on MaxCmdRN update rule
> 
> 
> 
> 
> Charles,
>