Subject: iSCSI: CmdRN mandatory

From: Pierre Labat <[email-masked]>
Date: Wed, 10 Jan 2001 17:27:47 -0800

Julian,

Where:
======

1.2.2.1 Command numbering
"Command numbering for sessions that will only be made up
of one connection is optional."

Problem
======

The targets have to be built to  handle
the case where a session doesn't use the command numbering
and the case where a session use it.

It is :
- two code paths to test
- a code bloat
- add complexity hence potential errors

Solution
======
Make CmdRN mandatory even with one connection per session.

Regards,

Pierre

---

From: Santosh Rao <[email-masked]>
Date: Wed, 10 Jan 2001 18:59:51 -0800

The additional advantage this provides is to allow ExpCmdRN based
dynamic flow control at the iSCSI Command layer to augment the current
SCSI Queue Full based flow control even with single connection sessions.

CmdRN should be made compulsory given the dis-advantages of not having
it as stated by pierre and the advantage of having it.

- Santosh Rao