Subject: RE: iSCSI-related conclusions from Orlando interim Meeting

From: [email-masked]
Date: Fri, 19 Jan 2001 19:58:24 -0500

It's a bit cryptic.  The conclusion in the room was
to convert binary values to/from text representations
for the purpose of negotiation (and use UTF-8 for the
text).  This was felt to be simpler than defining new
formats for binary values.  

--David

> -----Original Message-----
> From:	David Robinson [SMTP:[email-masked]]
> Sent:	Friday, January 19, 2001 7:47 PM
> To:	[email-masked]
> Subject:	Re: iSCSI-related conclusions from Orlando interim Meeting
> 
> > (5) Naming
> >         - UTF-8 will be used instead of ASCII for text strings in iSCSI
> > login and
> >                 text commands, naming, discovery, etc.
> >         - Binary values will be encoded in UTF-8 rather than adding
> > type/length support.
> 
> What does this mean? UTF-8 is an encoding of Unicode character sets, not
> arbitrary
> binary values. It is still just binary data so what
> possible advantage is this?
> 
> 	-David

---

From: David Robinson <[email-masked]>
Date: Fri, 19 Jan 2001 17:11:35 -0800

> formats for binary values.

So if I want to send the binary data 0101101011110000
I first turn that into text "5AF0" then encode that into
UTF-8 "5AF0" (printable ASCII is a no-op in UTF-8)?

I'll buy that.

Any statement as to the text encoding? Hex? Decimal? Octal?

	-David

---

From: Mark Bakke <[email-masked]>
Date: Mon, 22 Jan 2001 08:16:55 -0600

That's right.  The N&D team will send a new draft soon with the
encodings.  Some of the options for encoding binary data are hex,
decimal, octal, and uuencode.  We will probably suggest hex; it
uses more space than unicode, but for most binary names, is the
simplest and most readable.  Please stay tuned.

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054