Subject: What happened to the Length field?

From: [email-masked]
Date: Wed, 28 Feb 2001 09:56:02 -0800

In the latest version of the iSCSI spec, the total PDU length field has been
dropped
from the PDU header. This field significantly helps the parsing of the
incoming
iSCSI PDU stream without having to parse through several levels of headers
to
get to the  next PDU. This is especially useful in cases where out of order
data
placement is being done.

Mike Thompson
QLogic Corporation, Roseville
11768 Atwood Rd. Suite 23
Auburn, CA 95603
Ph# 530.886.0601 x17
Fx# 530.886.0746

---

From: [email-masked]
Date: Wed, 28 Feb 2001 22:20:06 +0200

It is in the NW now. Follow the new format (it was discussed on this list a
while ago).

Julo

[email-masked] on 28/02/2001 19:56:02

Please respond to [email-masked]

To:   "'ips'" <[email-masked]>
cc:
Subject:  What happened to the Length field?

In the latest version of the iSCSI spec, the total PDU length field has
been
dropped
from the PDU header. This field significantly helps the parsing of the
incoming
iSCSI PDU stream without having to parse through several levels of headers
to
get to the  next PDU. This is especially useful in cases where out of order
data
placement is being done.

Mike Thompson