Subject: Re: Section 4.1 (Login Phase)

From: [email-masked]
Date: Sun, 4 Feb 2001 11:52:00 +0200

wrong.  Julo

Santosh Rao <[email-masked]> on 02/02/2001 18:46:20

Please respond to Santosh Rao <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked] (Santosh Rao)
Subject:  Section 4.1 (Login Phase)

Julian,

The following sentence :

"Login reject with Final bit 0 is a format error."

needs to be removed from the draft. I believe the
Reject PDU is intended to communicate all format
errors on any PDU (?)

Regards,
Santosh

--
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################

---

From: "Santosh Rao" <[email-masked]>
Date: Sun, 04 Feb 2001 20:00:39

Julian,

Are you saying the Reject is NOT meant to be used for all format errors (?)

How then is the following description of Reject PDU (Section 2.19) to be interpreted :

"It may happen that a target receives a message with a format error
(inconsistent fields, reserved fields not 0, inexistent LUN etc.) or
a digest error (invalid payload or header). The target returns the
header of the message in error as the data of the response.

2.20 Reason

The reject Reason is coded as follows:

1 - Format Error
2 - Header Digest Error
3 - Payload Digest Error ""

Why are 2 mechanisms required to indicate format errors ? The one in Login response (reject with F=0) seems redundant.

- Santosh

>From: [email-masked]

>To: [email-masked]

>Subject: Re: Section 4.1 (Login Phase)

>Date: Sun, 4 Feb 2001 11:52:00 +0200

>Santosh Rao on 02/02/2001 18:46:20

>Please respond to Santosh Rao

Get your FREE download of MSN Explorer at http://explorer.msn.com

---

From: [email-masked]
Date: Mon, 5 Feb 2001 07:45:16 +0200

Santosh,

Norton Antivirus reports a virus in your attachment.
You may want to send plain text.

Julo

"Santosh Rao" <[email-masked]> on 04/02/2001 22:00:39

Please respond to "Santosh Rao" <[email-masked]>

To:   [email-masked]
cc:

 - att1.htm

---

From: "Santosh Rao" <[email-masked]>
Date: Tue, 06 Feb 2001 01:21:08 -0000

Re-sending...

Julian,

Are you saying the Reject is NOT meant to be used for all format
errors (?)

How then is the following description of Reject PDU (Section 2.19) to
be interpreted :

2.20 Reason

      1 - Format Error
      2 - Header Digest Error
      3 - Payload Digest Error "

Why are 2 mechanisms required to indicate format errors ? The one in Login 
response (reject with F=0) seems redundant.

Regards,
Santosh

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com