Subject: RE: Security Use Requirements

From: "John Hufferd" <[email-masked]>
Date: Tue, 6 Feb 2001 13:21:56 -0800

Bernard,
I think that Julian addressed this, but, an installation might want only
the connection to the local environment, and if so administratively tell
the iSCSI ends to not do the encryption etc.  Especially if some of the
ends are Laptops and Desktops.  But all side must implement the features.

By the way you might have slightly overstated the IPSec chips going at full
gig speed, when you talk about triple Des.  And if there are some they are
not within the normal costs one would expect for a iSCSI NIC HBA.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
(408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Internet address: [email-masked]

"Bernard Aboba" <[email-masked]>@ece.cmu.edu on 02/05/2001 03:26:13 PM

Sent by:  [email-masked]

To:   <[email-masked]>, <[email-masked]>
cc:   "RJ Atkinson" <[email-masked]>, "Smb@Research. Att. Com"
      <[email-masked]>
Subject:  RE: Security Use Requirements

It is hard for me to see how you could
get away with no security services at all
(e.g. no per-packet authentication and integrity
protection for iSCSI PDUs).

After all, we're talking about facilities
that are used by the world's major financial
institutions. If this data isn't worth protecting,
I don't know what is. Do you really want
attackers to be able to manipulate the contents
of bank accounts at will over the Internet?

Furthermore, there really isn't a sound technical
argument for dispensing with security. There are
chipsets available that can provide IPSEC
integrity and authentication services at
speeds of 1 Gbps or higher.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, February 05, 2001 12:54 PM
To: [email-masked]
Subject: Security Use Requirements

In Orlando, I picked up an action item to determine what
the requirements are for *use* of security features,
as opposed to requirements for *implementation*.  I
believe the answer to be that it is acceptable to
specify security measures weaker than those one would
want to use in full generality on a public network,
where "weaker" includes no security.

There are two important caveats that apply:
- Security of the negotiation mechanism becomes
     very important when this is done, as there's
     an obvious man-in-the-middle attack on the
     negotiation mechanism to get the endpoints
     to negotiate weaker security than they intended.
- The weaker security mechanisms need to be documented
     in terms of their security properties (and lack
     thereof), as well as environments in which they
     are appropriate.  The "Security Considerations"
     section of RFC 2338 (VRRP) has been recommended
     as a good example of this.

--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 06 Feb 2001 16:29:38 -0500

>ends are Laptops and Desktops.  But all side must implement the features.

        Implement != turn on operationally.  The above explains
why clever vendors might have a configuration knob to turn off
security.  The above does NOT make any kind of case for not 
always *implementing* security.

>not within the normal costs one would expect for a iSCSI NIC HBA.

        So if you believe the costs are so high, implement single DES.
For a lot of threat environments DES-CBC is sufficient and it surely beats the hell out of nothing.  By the way, the crypto parts vendors 
that I'm talking with must be giving me better prices than you, 
which I find surprising, since by the parts quotes I'm seeing
Bernard's math works just fine.

        Nothing anyone has said here has given any kind of reasonable
excuse to not make implementing security mandatory.  There has been
lots of rationale for making it optional for the user to turn on
for a given box, but nothing for making it optional to implement.
(Implement in the box != deploy operationally).

Ran
[email-masked]

---

From: "Dan Eakins" <[email-masked]>
Date: Tue, 6 Feb 2001 18:06:08 -0800

John and Bernard,

I can't agree more with Bernard's comments regarding a single security
solution.

By implementing a standard like IPsec and leveraging off the volumes of the
mainstream market you will achieve the end goal of lowering the cost of
adding security to the adapter, plus you will add the likelihood of many
silcon vendors implementing a solution which will in turn foster competition
and ultimately make the technology more affordable.

We have silicon that does 2.4 Gbps IPsec 3DES and MD5 authentication on
virtually all packet sizes today, and it is sampling.  Our plan is to move
this into mainstream PC servers, routers, and switches which will have full
duplex Gig Enet ports standard.  The way to get affordable silicon is to
make big markets for the devices.

So to help us engineer silicon solutions to fit this, what is the price
target of an iSCSI NIC HBA?  What is the market size that a silicon vendor
could expect here over a 18-36 month cycle?

Over the next 12-18 months the market will see the prices for these
solutions drop as the volumes build.  As a vendor sitting on the supply side
of the equation it would make our job of serving the market easier by
leveraging the R&D efforts already expended and aligning yourself with
industry roadmaps.

In addition the target of hitting 10G IPsec is not so far off as there is a
race to develop this techology first as a  chip or chipset solution already.
From what I see using IPsec here is a safe bet in hitting these objectives -
security, performance, scalability, and affordable solutions that can be
widely deployed.

Daniel Eakins
Senior Product Line Manager
Broadcom Corp.
Security Line of Business

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
John Hufferd
Sent: Tuesday, February 06, 2001 1:22 PM
To: Bernard Aboba
Cc: [email-masked]; [email-masked]; RJ Atkinson; Smb@Research.
Att. Com
Subject: RE: Security Use Requirements

Bernard,

.
.
.
John L. Hufferd

-----Original Message-----

--David