Subject: RE: iSCSI Naming: WWUIs, URNs, and namespaces

From: "Elliott, Robert" <[email-masked]>
Date: Fri, 23 Mar 2001 11:31:32 -0600

The SCSI over RDMA protocol (for InfiniBand) chose:

1.  initiator port identifier = 64-bit EUI-64 plus
    64-bit identifier extension
2.  target port identifier = 64-bit EUI-64

The target port identifier is the same as the InfiniBand 
IO controller (IOC) globally unique identifier (GUID).  
(InfiniBand GUIDs are EUI-64s)

Targets will often be hardware devices that already
have IOC GUIDs.  In the cases where they are not, we
assume the software provider can provide GUIDs just
like it provides license keys.  Software could allow
customers to specify their own EUI-64s, too.

Initiators are more likely to be software entities.
We assumed the software could take one of the GUIDs
of the hardware on which it is located (e.g. the 
InfiniBand port GUID) and append some sort of unique
identifier to it.  It is unspecified how to guarantee
software generates unique IDs.  If there is a name
server on the fabric, it may check if the ID it chooses
is already in use and pick another.  Alternatively,
the software provider could generate its own EUI-64
or the customer could provide one (as with targets
implemented in software).

I proposed using the iSCSI reverse DNS WWUI format so
SRP and iSCSI could share a namespace, but the group
preferred the EUI-64 based approach (among other
concerns, the 255 byte string is too big for some of
the packets).  If iSCSI drops the long WWUI format
and goes with EUI-64, we may achieve the common 
namespace goal.

---
Rob Elliott, Compaq Server Storage
[email-masked]

> -----Original Message-----
> From: Mark Bakke [mailto:[email-masked]]
> Sent: Friday, March 23, 2001 8:36 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: iSCSI Naming: WWUIs, URNs, and namespaces
> 
> 
> 
> David-
> 
> This is starting to seem like work.  In case they help,
> please see my comments below.  We can take this up in
> more detail in the N&D team.
> 
> --
> Mark
> 
> [email-masked] wrote:
> > 
> > <RANT> I don't like naming issues. </RANT> :-) :-)
> > 
> > After suitable consulting with some members of
> > the IESG and IAB, I have some news to convey about
> > the current approach to iSCSI naming.
> > 
> > The IESG will not approve another global namespace
> > for iSCSI's use - this means that WWUIs as currently
> 
> So I take it that WWUIs are fine, as long as they use
> existing global name spaces.
> 
> > designed will need to be revised out of the
> > naming and discovery draft, and that it will not be
> > possible to proceed with the WWUI URN draft
> > as an official IPS WG work item.  The best course of
> > action would probably be to allow the WWUI URN draft
> > to expire without further revision.
> > 
> > To a first approximation, WWUIs are/were a "grand
> > unified theory" of naming, in that any namespace could
> > be glued into the WWUI world (as several were).
> 
> The reason we glued these in was to avoid creating a new
> global name space.  We allowed the use of a few currently
> available global name spaces.  How can this be a problem?
> 
> > The WG is being directed to instead focus on the
> > individual namespaces and make sure that the ones that
> > are used are in fact necessary.  iSCSI can use text
> > keys to identify which sort of name is being used
> > (one key for each sort of format, for each instance
> > in which a name is used), and it may be possible
> > to encode the name format in the parse rules for the
> > values of iSCSI keys to avoid proliferation of keys.
> > 
> > Taking a look at the namespaces in the current iSCSI
> > naming and discovery draft, here's some initial
> > guidance from this WG co-chair:
> >   iscsi - canonical target -- This should be fine.
> >   eui - WWNs -- The use of these for storage makes eminent
> >         sense.  I don't see a problem here.
> 
> So far, so good.  Does that mean that we can keep the above
> two, in the current WWUI, as we have it formatted?
> 
> EUI, although it's not that flexible (see later), is required
> for interoperating with and adding iSCSI to existing devices.
> 
> >   dns - hostnames -- Use of these should be abandoned as
> >         not only are they not really URNs (as indicated
> >         in the draft), but their intended usage is straying
> >         into the tarpit known as "URN resolution".  Faster
> >         progress will made by staying out.  A DNS hostname
> >         can be put into an Alias or something new can be
> >         invented to carry it as a Location Hint, BUT the
> >         relevant URN WG RFCs and drafts on URN resolution
> >         should be reviewed before proceeding too far in this
> >         direction.
> 
> I don't like this one that much, either, for the same reasons.
> 
> >   iscsi - Reverse DNS and oui - Org. Unique Identifier --
> >         The rationale for these is not clear to me.
> >         Assuming that WWNs are going to be available for
> >         use in naming iSCSI Initiators and Targets, what
> >         are the problems that these sorts of names solve
> >         that WWNs don't?  It appears that one of the problems
> >         may be who can get/create them.  Discussion of this
> >         on the list would be appropriate.
> 
> These two formats use existing global name spaces, and allow
> the implementor or end user to take a more flexible approach
> to naming than is offered by the EUI-64.  When dealing with
> a large number of logical targets, burning WWNs (essentially,
> MAC addresses), and attempting to keep them tied to a logical
> entity without tying them to hardware is not practical.
> 
> Both of these formats accomplish the same thing, and we could
> make do with just one of them.  The only real differences are:
> 
> - OUI is a fixed length naming authority; reverse DNS is variable
>   and could result in longer names.
> 
> - A human looking at a reverse DNS-based name can easily determine
>   who the naming authority is; a human looking at an OUI-based
>   name will usually have to go look it up at IEEE.
> 
> - Only a hardware manufacturer (and a few software manufacters)
>   will already have an OUI.  Others, such as storage service
>   providers, large end customers, or software driver providers,
>   would either be out-of-luck for naming their devices, or would
>   have to register for an OUI, which would otherwise be a waste
>   of IEEE resources.  OTOH, a storage service provider could
>   provide its own names by using the reverse-DNS authority.
>   Everyone has a DNS name.  This would enable the SSP to provide
>   its customers with a WWUI that would not change if the back-end
>   storage device was replaced.  After all, it's not the device
>   that's important to this customer, it's the DATA.
> 
> - If we had to pick one or the other, I would pick the reverse
>   DNS, since it offers the ability to generate unique names to
>   a wider variety of users.
> 
> > In any case, the fewer name formats we have to deal with,
> > the better.
> 
> Although I probably should have discussed this with the rest
> of the NDT first, I would personally be happy with:
> 
> - iscsi - The canonical name.
> - eui - For compatibility with existing device naming schemes.
> - reverse-dns - For better naming flexibility moving forward.
> 
> Perhaps the IESG would accept the WWUI with just these three.
> Or perhaps we could just make the WWUI into a URN?  I don't
> know if that would help, but perhaps...
> 
> The main point is that we are NOT creating any new name
> spaces; we really are just using what's already there.  Maybe
> by specifying fewer of the options that are already there, we
> would be in better shape.
> 
> > I want to try to anticipate an objection to this, which
> > would note that from a functional viewpoint the basic
> > impact of this is to move some characters from one text
> > string to another (e.g., from a WWUI type designator
> > to part of an iSCSI text key), and wonder if this is
> > a distinction without a difference.  One of the reasons
> > for the <RANT> that started this post is that a functional
> > view is not sufficient for naming - how things are named,
> > the intended usage of names and their scope matter a lot.
> 
> So that leads to the question: Has any other WG come up with
> a world-wide-unique-identifier for something else that the
> IESG folks deems acceptable?  If we can see a few examples,
> we would be better able to anticipate what they want.
> 
> > This is particularly true when considering the structure
> > of a namespace and how that structure may be extended.
> > The upshot is that avoiding introduction of something
> > claiming to be yet another global namespace is important
> > (i.e., use existing namespaces with global scope in preference
> > to inventing new ones).  The resulting need to define
> > the name spaces/formats in the main iSCSI spec. is
> > probably a "feature" as it forces us to pay more
> > attention to the sorts of names we use and raises the
> > bar for adding additional sorts of names in the future.
>  
> > I will be working with
> > the naming and discovery team in my "copious spare time"
> > to make sure that we don't lose the valuable work and
> > progress they've made to date as a consequence of this
> > change.  Discussion on the list about what sort
> > of names are important (e.g., the Reverse DNS and OUI
> > namespaces) and why would be useful.
> 
> From a requirements point of view, please respond if any
> of the types of names are important to you (plural).
> 
> Hopefully, we can get this out of the way quickly.
> 
> 
> 
> > Thanks,
> > --David
> > 
> > ---------------------------------------------------
> > David L. Black, Senior Technologist
> > EMC Corporation, 42 South St., Hopkinton, MA  01748
> > +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> > [email-masked]       Mobile: +1 (978) 394-7754
> > ---------------------------------------------------
> 
> -- 
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054
>

---

From: "John Hufferd" <[email-masked]>
Date: Fri, 23 Mar 2001 11:06:39 -0800

Jim,
You are NOT wrong.  Things got a lot simpler after we came up with the
WWUIs.  Trying to tie ourselves to HW caused all sorts of problems.  (in
Fibre Channel also.) The ability to have a higher order name permitted us
the ability to have Security Authentication against something that made
sense.  We have all moved or swapped HBAs from one system to another
(especially within I/T supported groups), the last thing we would want to
do is have to reestablish across some network a new WWUI and Security
context, just because we changed our NICs.  Besides can you see the
additional work that would happen on the admin side.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
(408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Internet address: [email-masked]

Jim Hafner/Almaden/IBM@[email-masked] on 03/23/2001 10:34:06 AM

Sent by:  [email-masked]

To:   "Elliott, Robert" <[email-masked]>
cc:   "[email-masked]'" <[email-masked]>, "'Mark Bakke'"
      <[email-masked]>, "[email-masked]'" <[email-masked]>
Subject:  RE: iSCSI Naming: WWUIs, URNs, and namespaces

Rob,

Admittedly a lofty goal for a common namespace, but the problem we faced in
iSCSI is that (primarily) on the initiator side there is NO canonical
hardware component from which to derive an EUI-64+extra name.   Some
systems have motherboard identifiers, some have network mac addresses, some
have ...  I know of no common hardware component that lives on every single
IP device (including my PDA, my phone, my...).  Additionally, on the target
side, the virtualization of target devices through gateways (e.g., what an
SSP might set up) and the like (thinking of the device as a service and not
a hardware component) made a more user-manageable (less hardware driven)
namespace a better alternative.

I could be wrong on this "no canonical hardware component" point, and I'd
love to be corrected as it would make this a lot simpler.

Jim Hafner

"Elliott, Robert" <[email-masked]>@ece.cmu.edu on 03-23-2001
09:31:32 AM

Sent by:  [email-masked]

To:   "[email-masked]'" <[email-masked]>, "'Mark Bakke'"
      <[email-masked]>, "[email-masked]'" <[email-masked]>
cc:
Subject:  RE: iSCSI Naming: WWUIs, URNs, and namespaces

---