Subject: RE: description of recovery mechanisms

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Thu, 8 Mar 2001 17:01:11 -0800

More than just a description is necessary.  I believe the proliferation of
options regarding recovery will make for an interoperability nightmare
similar to early iterations of Fibre Channel protocols.  Too many options
and too much ambiguity result in too many conflicting interpretations.  We
need to simplify, remove options, over specify with examples.

Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions Org.
Hewlett-Packard
tel: +1 916 785 2656
fax: +1 916 785 0391
email: [email-masked] 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, March 08, 2001 4:34 PM
> To: [email-masked]; [email-masked]
> Subject: RE: description of recovery mechanisms
> 
> 
> What Somesh is asking for is necessary.  We can
> either put it in now, or discover it the hard
> way later in interoperability testing with
> considerably greater expenditure of time and
> effort.
> 
> --David 
> 
> > -----Original Message-----
> > From:	Somesh Gupta [SMTP:[email-masked]]
> > Sent:	Wednesday, March 07, 2001 10:24 PM
> > To:	[email-masked]
> > Subject:	description of recovery mechanisms
> > 
> > I hope David and Julian will excuse me for using the following
> > sentences from the Orlando minutes.
> > 
> > -----------  start of quote -------------------------------
> > 
> > - There will be a significant connection recovery write-up,
> > 	including details, procedures and examples added to the draft.
> > 
> > -----------  end of quote ---------------------------------
> > 
> > 
> > As an engineer, I believe that we do need detailed and thorough
> > description of the usage of all the recovery tools in the
> > protocol. This ensures
> > 
> > 1. Determination that there are no holes. Presence of "holes"
> >    will lead to the mechanisms not being used (but implemented)
> > 
> >    or determine that there are no holes which will lead
> >    to testing nightmares.
> > 
> > 2. Ensure interoperability among implementations
> > 
> > I hope this does not sound like I am asking Julian to do
> > my work for me. But it is better hashed out and debated
> > in one place.
> > 
>

---

From: Stephen Bailey <[email-masked]>
Date: Fri, 09 Mar 2001 10:47:16 -0500

> > considerably greater expenditure of time and

To be completely clear (as David know), we don't need to `discover'
this the hard way, because it's ALREADY been discovered in FC and
before that in ||SCSI.  We KNOW this needs to be specified (OR, we
won't interoperate---your choice).

> need to simplify, remove options, over specify with examples.

What she said.

Steph