Subject: iscsi: rev 05 2.5.1 requires ACA support

From: Ralph Weber <[email-masked]>
Date: Mon, 12 Mar 2001 22:16:45 -0600

The following two 2.5.1 statements require the use
of ACA and there is no way for an initiator that
doesn't implement ACA to stop them.

   For the <Clear Task Set>, ...
   The target MUST then enter the ACA state for any
   initiator for which it had pending tasks.

   In addition, for the <Target Warm Reset> the target
   enters the ACA state on all sessions and all LUs on
   which an AE was sent.

Have you all signed the operating system vendors up for
rewrites of their class drivers to support ACA?  If not
anticipate some serious deadlocks when iSCSI is first
attempted with a non ACA class driver, since the driver
will never clear these ACA conditions and no progress
will be made after that.

Alternatively, a way can be found to give the initiator
control over the "MUST" statements.

Thanks.

Ralph...

---

From: "Charles Binford" <[email-masked]>
Date: Thu, 15 Mar 2001 12:35:26 -0600

Ralph, you missed a reference in iSCSI where ACA is required.  In 7.2 (p 86)
it says:

  "ACA helps preserving ordered command execution
   in presence of errors. As iSCSI can have many commands
   in-flight between initiator and target iSCSI mandates
   support for ACA."

I agree with Ralph that iSCSI should not be mandating ACA support.  However,
I don't really understand what the problem/scenario is that ACA is supposed
to be solving.  Can someone please explain that to me?  Before I start
throwing more darts at ACA I'd like to better understand the perceived
value.

Charles Binford
Blue Spruce Networks
office: (316) 315-0382 / cell: (316) 210-6404
e-fax: (509) 756-4425

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Ralph Weber
Sent: Monday, March 12, 2001 10:17 PM
To: IPS Reflector
Subject: iscsi: rev 05 2.5.1 requires ACA support

Thanks.

Ralph...