Subject: RE: iSCSI: Naming and Discovery Draft...

From: "Elliott, Robert" <[email-masked]>
Date: Wed, 7 Mar 2001 20:32:24 -0600

"Busy" and "Reservation Conflict" are SCSI Status code names defined in
SAM-2; I'd avoid using them for this different purpose.
---
[email-masked]
Compaq Server Storage

> -----Original Message-----
> From: Renato E. Maranon [mailto:[email-masked]]
> Sent: Wednesday, March 07, 2001 11:12 AM
> To: [email-masked]; 'Tanjore K. Suresh'
> Cc: [email-masked]
> Subject: RE: iSCSI: Naming and Discovery Draft...
> 
> 
> My two cents.  I like to suggest "Target Reserved", "Target 
> Reservation
> Conflict" or "Target Committed".  For this condition to 
> occur, the target
> may not be necessarily busy, but just out of resources, or 
> can only handle
> one.  "Target Busy" seems to imply busy.  Building on Mark's 
> desciption
> below, something like:
> 
>    The target has committed resources to one or more 
> initiators and cannot
> handle
>    another one. The initiator MAY try again later. This can 
> be the case
>    for simple devices that can handle only one initiator at a time, or
>    for a target that has does not have the resources to 
> support one more
>    initiator.  In contrast to the  previous examples, this 
> rejection is
>    temporary.
> 
> 
> 
> Renato Maranon
> Maranti Networks, Inc
> 920 Hillview Court
> Milpitas, Ca 95035
> Phone:  408-719-9600 x309
> Fax:    408-719-9631
> email:  [email-masked]
> home:   www.marantinetworks.com
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Yaron Klein
> Sent: Wednesday, March 07, 2001 1:38 AM
> To: 'Tanjore K. Suresh'
> Cc: [email-masked]
> Subject: RE: iSCSI: Naming and Discovery Draft...
> 
> 
> Tanjore,
> 
> Some more comments:
> 
> The error statuses codes on Appendix B are not synchronized 
> with the main
> draft. We will fix it.
> 
> The term "target conflict" was borrowed from HTTP. Mark clarified this
> scenario well. I would like to add that this status enables better
> resolution and knowledge to the target. That is, in those 
> cases the target
> can just not open the connection or just reject it like server error.
> However, this will not give indication of the situation as 
> described by
> Mark.
> 
> Regards,
> 
> Yaron
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Mark
> Bakke
> Sent: Tuesday, March 06, 2001 6:51 PM
> To: Tanjore K. Suresh
> Cc: [email-masked]; [email-masked]
> Subject: Re: iSCSI: Naming and Discovery Draft...
> 
> 
> Tanjore-
> 
> Thanks for the feedback.  I can comment on #3:
> 
> "Tanjore K. Suresh" wrote:
> >         3. Appendix B, B.4.5,
> >           Target Conflict 45 doesnot seem to be appropriate.
> >
> >                 I have not reviewed all the documents yet to give a
> >                 recommendation and hence cannot give, but feel
> >                 " Target Conflict" doesnot
> >                 convey the meaning of the Scenario indicating
> >                 case of " simple devices that can handle 
> one device or
> >                 the target had reached the limit of its Initiators'
> capacity."
> 
> Perhaps we chose the wrong term for this one.  How about if call it
> "Target Busy", and slightly re-word it?
> 
>    The target is busy with another initiator and cannot handle
>    another one. The initiator MAY try again later. This can 
> be the case
>    for simple devices that can handle only one initiator at a time, or
>    for a target that has does not have the resources to 
> support one more
>    initiator.  In contrast to the  previous examples, this 
> rejection is
>    temporary.
> 
> --
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054
>

---

From: Mark Bakke <[email-masked]>
Date: Thu, 08 Mar 2001 08:01:27 -0600

Sounds like we are left with "Target Committed", which
Renato's new description seems to fit.

Any other ideas, or does that seem to work?

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054