Subject: Fwd: I-D ACTION:draft-bakke-iscsimib-02.txt

From: Mark Bakke <[email-masked]>
Date: Thu, 08 Mar 2001 08:06:14 -0600

FYI.  For a pictorial view of this MIB, please see

http://www.haifa.il.ibm.com/satran/ips/iscsi-mib-structure-02.pdf

--
Mark

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Definitions of Managed Objects for SCSI over TCP
>         Author(s)       : M. Bakke, J. Muchow, M. Krueger
>         Filename        : draft-bakke-iscsimib-02.txt
>         Pages           : 141
>         Date            : 06-Mar-01
>         
> This memo defines a portion of the Management Information Base (MIB)
> for use with network management protocols in TCP/IP based internets.
> In particular it defines objects for managing a client using the
> iSCSI (SCSI over TCP) protocol.  It is meant to match the latest
> version of iSCSI defined in [ISCSI].
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-bakke-iscsimib-02.txt
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
>         "get draft-bakke-iscsimib-02.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
>         [email-masked].
> In the body type:
>         "FILE /internet-drafts/draft-bakke-iscsimib-02.txt".
>         
> NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>                 
>  

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "Yaron Klein" <[email-masked]>
Date: Sun, 11 Mar 2001 15:46:09 -0000

Mark,

Great job with the MIB. Some questions and comments.

1.	Date should be change to February 2001.

2.	Can you take a student from UMN to fill the description fields of the
parameters :-).

3.	The StatusStatsEntry type parameters should be updated according to
version 05 new    status codes.

4.	What does the iscsiSsnOtherHdrIntegrity means? The text format of the
algorithm?

5.	The iscsiSsnDataIntegrity table should include the kerberos options as
well as the header digest (version 05).

6.	Can the AccessList entry include IP address as well as WWUI for initial
filtering?

Regards,

Yaron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Mark
Bakke
Sent: Thursday, March 08, 2001 2:06 PM
To: IPS
Subject: Fwd: I-D ACTION:draft-bakke-iscsimib-02.txt

--
Mark

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Mon, 12 Mar 2001 10:55:45 -0600

Yaron-

Thanks for looking through the draft.  My comments are
embedded.

--
Mark

> 1.      Date should be change to February 2001.

Oops.  I still have a Y2k bug in my chair-to-keyboard interface.  I'll
fix it.

> 2.      Can you take a student from UMN to fill the description fields of the

Actually, the team is working on descriptions for the fields.  Doing these
will take a while, and we did not have the time to get them done in time for
the meeting.

> version 05 new    status codes.

OK.

> 4.      What does the iscsiSsnOtherHdrIntegrity means? The text format of the

This would be the text name of the algorithm used for header integrity, if
there is no enumerated type for it.  We plan to get rid of the enums in the
next draft, and include only the UTF8 representations of header integrity, 
data integrity, initiator authentication, and target authentication.  So it
will look more like:

  iscsiSsnHeaderIntegrity   UTF8String,
  iscsiSsnDataIntegrity     UTF8String,
  iscsiSsnInitiatorAuth     UTF8String,
  iscsiSsnTargetAuth        UTF8String,

This will make handling of non-standard schemes identical to that used by
the standard schemes, and remove the need to keep updating enumerated types
in the MIB as these evolve.

> well as the header digest (version 05).

The new attributes from #4 will fix this. 

> 6.      Can the AccessList entry include IP address as well as WWUI for initial

That's one of the open issues I will bring up during the MIB presentation
next week.  In general, there are a lot of different things that can be done
with access lists; which of these will be universally-implemented to the
extent that they should be included in the MIB, and which should be left to
table augmentations in enterprise MIBs?

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054