Subject: iSCSI: Logout needs ISID

From: Joshua Tseng <[email-masked]>
Date: Tue, 13 Mar 2001 17:56:45 -0800

Julian,

Section 2.14 states that the logout command may
be sent on a second connection to clean up the
a single connection iSCSI session.  If the reason
code is 0 (close the session), then ISID is needed
to identify the iSCSI session to close.

Josh

---

From: [email-masked]
Date: Wed, 14 Mar 2001 07:57:29 +0200

Josh,

There is something I am missing. The Logout can be issued only after Login
(authentication and the rest).
The session is then implied.

Regards,
Julo

Joshua Tseng <[email-masked]> on 14/03/2001 03:56:45

Please respond to Joshua Tseng <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  iSCSI:  Logout needs ISID

Julian,

Josh

---

From: Joshua Tseng <[email-masked]>
Date: Wed, 14 Mar 2001 07:09:48 -0800

Julian,

In 2.14, you state that a logout command can be
sent on a different connection to destroy a single-
connection iSCSI session.  If you have multiple
sessions ongoing, and the logout command is sent
on a different connection than the one used
to support the session that is to be killed, then
you will need ISID to distinguish the session that
you want killed.

Regards,
Josh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, March 13, 2001 9:57 PM
> To: [email-masked]
> Subject: Re: iSCSI: Logout needs ISID
> 
> 
> 
> 
> Josh,
>

---

From: [email-masked]
Date: Wed, 14 Mar 2001 18:31:19 +0200

Mark,

If you have only one connection you are supposed to use a Login with the
restart bit one - and achieve a similar effect as a Login/Logout - i.e.
keep the session alive.  Even this might be a problem for a target that is
so poor it has only one socket (even SNMP won't work there).  For this case
the only way out is to drop the connection and hope the target will hear
you (it probably won't -:)). The comment is the draft is a memento for
implementers to keep looking for new connections always (even for a one
connection target) but probably it does not come through clear enough.

Regards,
Julo

Mark Bakke <[email-masked]> on 14/03/2001 18:17:14

Please respond to Mark Bakke <[email-masked]>

Julian-

A target that does not support multiple connections per session
will return "Initiator SID Error" when the login attempt is made.
In this case, there is no way to log in, so there's no way to
log out the old connection.  The initiator would be stuck waiting
until the target's side of the connection times out and goes
away, which could be a very long time.

There is an open question within the MIB team about whether anyone
needs to be able to kill connections or sessions from SNMP; however,
I don't think that anyone will want to use SNMP as part of error
recovery.

--
Mark

[email-masked] wrote:
>
> Josh,
>
> No command, including logout, can be sent without a login.
> The complete scenario is:
>
> -open a new connection
> -login in the same session as the old connection (this has the ISID &
TSID)
> -logout the old connection
> -recover commands
>
> You are not supposed to be able to kill a session from outside (at least
> not an iSCSI defined mode).
> You will need management support for that (SNMP?)
>
> Regards,
> Julo
>
> Joshua Tseng <[email-masked]> on 14/03/2001 17:09:48
>
> To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
> cc:
> Subject:  RE: iSCSI: Logout needs ISID
>
> Julian,
>

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054