Subject: iSCSI and Mode Pages

From: [email-masked]
Date: Fri, 2 Mar 2001 15:26:43 -0500

Section 3 describes several things that can be negotiated
via Text parameters or mode pages.  Requirements for
the behavior of the interaction between these two
mechanisms needs to be set out a little more precisely
(e.g., what happens if MODE SELECT is used on one
of these *after* login is complete), ditto implementation
requirements (e.g., on what fields do MODE SENSE and/or
MODE SELECT have to work).  This should just be a
few sentences indicating what has to be implemented
and what initiators can expect when accessing these
mode pages in an iSCSI target.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: "Douglas Otis" <[email-masked]>
Date: Sat, 3 Mar 2001 11:18:33 -0800

David,

Specifying SCSI responses with respect to Mode Select or Mode Sense seems to
be running into T10's domain.  Perhaps this work should be placed within an
appendix to indicate this information as advisory.

Doug