Subject: iSCSI : EndDataSN missing in READ Data PDU

From: Santosh Rao <[email-masked]>
Date: Fri, 9 Mar 2001 16:44:52 -0800 (PST)

Julian & All,

The EndDataSN is missing from the READ Data PDU. (Perhaps, this can
replace the "Residual Count" field, since any READ that encountered an
underrun would not result in Status being sent with the Data PDU.)

Regards,
Santosh

-- 
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################

---

From: [email-masked]
Date: Sat, 10 Mar 2001 18:58:14 +0200

Santosh,

Why would EndDataSN be needed?  In separate statuses it is there to make
sure that you have all
all the data PDUs. In the "combined" you have the DataSN itself to tell
you.

A side remark - Over/Underrun are not always an error (causing separate
status) - it depends on mode page settings?

Regards,
Julo

Santosh Rao <[email-masked]> on 10/03/2001 02:44:52

Please respond to Santosh Rao <[email-masked]>

To:   [email-masked] (ips)
cc:
Subject:  iSCSI : EndDataSN missing in READ Data PDU

Julian & All,

Regards,
Santosh