Subject: RE: iscsi: editorial comments to iSCSI-05

From: [email-masked]
Date: Fri, 9 Mar 2001 15:34:19 -0500

> Global:  "MUST", "SHOULD", etc are sometimes all upper case,
>     sometimes lowercase.  Please make them consistent.

Actually, that's deliberate.  Upper case versions of these
and other terms express requirements, recommendations, and
options for interoperability and the like and are defined
in RFC 2119 (see statement on p.3 of the iSCSI draft).  Lower
case versions of these terms may be used, but do not have
the RFC 2119 meanings and implications of the upper case terms.
The decision to use upper case vs. lower case is a deliberate
decision about whether this is an interoperability issue or
one of similar import/impact - in particular RFC 2119 advises
that these upper case terms "be used with care and sparingly".

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: Matt Wakeley <[email-masked]>
Date: Sat, 10 Mar 2001 23:54:57 -0800

I understand this, but it's not consistent.  For example, on page 15:

"data and the status for a command must be sent over the same TCP connection
that was used to deliver the SCSI command."  and in the very same paragraph,
"the target MUST return R2T, if any, and the status over the same TCP
connection" These are requirements, but must is sometimes capitalized,
sometimes not.

And on page 56: "The target MUST not set the Status to 0x'0000'", the must is
capitalized, but the not is not.

-Matt