Subject: RE: iSCSI: Naming and Discovery Draft

From: "Renato E. Maranon" <[email-masked]>
Date: Mon, 5 Mar 2001 14:43:01 -0800

Some minor feedback.

Appendix A is preceded by the text "8. ".  "8. " Should be removed?

Second.
In Appendix B, B.4.5 Login fail, the description for the sample login for
target removed (exception "Target removed 44") is split by the "Target
Conflict 45" sample.  Should probably be combined.

Original text:
   I->Login Request
      InitiatorWWUI= iscsi.com.os.hostid.34567890
      TargetWWUI= iscsi.com.acme.diskarray.sn.8675309
   T->Login Response ("Target removed 44", F set)

   In this case the target has been removed. In contrast with codes 31
   and 32 (in B.4.4), no redirection information is supplied.

   I->Login Request
      InitiatorWWUI= iscsi.com.os.hostid.34567890
      TargetWWUI= iscsi.com.acme.diskarray.sn.8675309
   T->Login Response ("Target Conflict 45", F set)

   Here, the target is busy with another initiator and cannot handle
   another one. The initiator MAY try again later. This can be the case
   of simple devices that can handle one device or the target has
   reached the limit of its initiators' capacity. In contrast to the
   previous examples, this rejection is temporary.

   I->Login Request
      InitiatorWWUI= iscsi.com.os.hostid.34567890
      TargetWWUI= iscsi.com.acme.diskarray.sn.8675309
   T->Login Response ("Target removed 44", F set)

   Here, the target has been removed. The initiator SHOULD terminate the
   login session. It MAY query the SNS for the new location of the
   target. (This should apply for the case when the target was not found
   - code 44).

Suggestion:

   I->Login Request
      InitiatorWWUI= iscsi.com.os.hostid.34567890
      TargetWWUI= iscsi.com.acme.diskarray.sn.8675309
   T->Login Response ("Target removed 44", F set)

   In this case the target has been removed. In contrast with codes 31
   and 32 (in B.4.4), no redirection information is supplied.

   Here, the target has been removed. The initiator SHOULD terminate the
   login session. It MAY query the SNS for the new location of the
   target. (This should apply for the case when the target was not found
   - code 44).

   I->Login Request
      InitiatorWWUI= iscsi.com.os.hostid.34567890
      TargetWWUI= iscsi.com.acme.diskarray.sn.8675309
   T->Login Response ("Target Conflict 45", F set)

   Here, the target is busy with another initiator and cannot handle
   another one. The initiator MAY try again later. This can be the case
   of simple devices that can handle one device or the target has
   reached the limit of its initiators' capacity. In contrast to the
   previous examples, this rejection is temporary.

Renato Maranon
Maranti Networks, Inc
920 Hillview Court
Milpitas, Ca 95035
Phone:  408-719-9600 x309
Fax:    408-719-9631
email:  [email-masked]
home:   www.marantinetworks.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Kaladhar Voruganti
Sent: Saturday, February 24, 2001 9:51 AM
To: [email-masked]
Subject: iSCSI: Naming and Discovery Draft

The following iSCSI naming and discovery draft has been submitted to IETF.
This naming and discovery draft has been produced by the iSCSI naming and
discovery team.

The draft contains the iSCSI naming and discovery details.

http://www.haifa.il.ibm.com/satran/ips/draft-ietf-ips-iSCSI-name-disc-00.txt

Kaladhar Voruganti
Computing Science Department
IBM Almaden Research Lab
San Jose, CA

---

From: Mark Bakke <[email-masked]>
Date: Tue, 06 Mar 2001 12:41:18 -0600

Renato-

You are correct; we had a duplicate example with two
descriptions.  We'll merge them.

Thanks,

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054