Subject: Re: iSCSI : SCSI Response PDU

From: [email-masked]
Date: Sat, 10 Mar 2001 18:52:09 +0200

responses in text:

Thanks,
Julo

Santosh Rao <[email-masked]> on 10/03/2001 01:11:23

Please respond to Santosh Rao <[email-masked]>

To:   [email-masked] (ips)
cc:   [email-masked] (Santosh Rao)
Subject:  iSCSI : SCSI Response PDU

Julian/All,

Some comments on recent changes to the SCSI Response PDU in Rev 04/05 :

1) Sense Length has been removed. This field is required and should be
re-introduced. (Can anyone comment on the reasons behind its removal(?) ).

+++ sense is in the data segment - data segment length is sense length +++

2) There is a reference to Response Data [without a corresponding
response length. Once again, response length is required, if a
response data is used.]. Response Data is modelled on the FC
response data and is useless in the current context.
(The FC response data only contained a response code).
Any target that wishes to send vendor unique information
could do so through vendor unique sense data.

All references to Response Data should be removed.
+++ Responses are not sense +++
3) A range of iSCSI Response codes should be assigned for vendor-unique
responses.
+++ Good Idea +++
4) The spec should state explicitly whether implementors are to use the
REJECT PDU or a Scsi Response PDU with iSCSI Response code to indicate
failure to process a command due to invalid command pdu fields. If the
SCSI Response PDU is to be used to convey this, an additional iSCSI
response code must be added for "Invalid Command PDU".
+++ section 6.1 covers this - Matt Wakeley proposed changing the name to
protocol errors +++
5) In section 2.5.1, pg 40, the spec states :
"For all these functions, the SCSI Task Management Response MUST be
returned using the Initiator Task Tag to identify the operation for
which it is responding."

The above MUST should be changed to SHOULD since a task mgmt command can be
responded to with a REJECT response on a format error.
+++ I will make " for all these functions, if executed ... +++
Comments ?

Regards,
Santosh Rao

--
#################################
Santosh Rao
Software Design Engineer,
HP, Cupertino.
email : [email-masked]
Phone : 408-447-3751
#################################

---

From: Matt Wakeley <[email-masked]>
Date: Sun, 11 Mar 2001 00:28:26 -0800

> +++ sense is in the data segment - data segment length is sense length +++

I figured that out, but there is nothing in the document stating that.  Since
this is a public spec, it should spell everything out (otherwise you, as the
author, will constantly get questions).

> 3) A range of iSCSI Response codes should be assigned for vendor-unique

Yeah, will contribute to interoperability... NOT!

---

From: Santosh Rao <[email-masked]>
Date: Mon, 12 Mar 2001 09:56:21 -0800

> +++ Responses are not sense +++

Julian,

What additional information does the response data convey which cannot be done
through the response codes ? As stated below, any vendor unique response data
can be communicated through the use of vendor unique response codes. (The
response code itself constitutes response data, as is the case with FC.)

Regards,
Santosh