Subject: iscsi: editorial comments to iSCSI-05

From: Matt Wakeley <[email-masked]>
Date: Fri, 09 Mar 2001 02:50:34 -0800

editorial comments to iSCSI 05:

Global: In 1.2 the iSCSI PDU is defined, yet the phrase "message" is
    used interchangeably with PDU.  Change all occurences of
    "message" to the correct term "PDU", especially fix instances
    of blahblah message.  Also, change "packets" to PDUs.

Global:  "MUST", "SHOULD", etc are sometimes all upper case,
    sometimes lowercase.  Please make them consistent.

Abstract, page 2; 1.2 page 10:
    change: "on top of TCP"
    to: "over TCP".

1.1, middle page 9:
    change: "SCSI is client-server..."
    to: "SCSI is a client-server..."

1.1, bottom page 9:
    change: "Command Descriptor Blocks (CDB) is ..."
    to: "The Command Descriptor Block (CDB) is ..."

1.2.2.1, last paragraph page 12:
    "iSCSI initiators and target ..." add "s" to target.

1.2.3, page 14, last paragraph:
    change: "Any message except login and text reaching a target on
      a TCP connection before the full feature phase MUST be ..."
    to: "... full feature phase is a protocol error (see 6.1) and
      MUST be..."

2.3.2, page 33:
    Include a reference to SAM-2.

2.3.6, page 34:
    Indicate that the "Extended CDB" what's next field must be used.
    Change "48-byte header" to "BHS".

2.4.5, page 37:
    Indicate that sense or response data is "data" and not part
    of the header.

2.7, page 43 and 44:
    Change "SCSI Data packet" to "iSCSI Data PDU"

2.8.3, page 48:
    move 'If the Text Response does not contain a key that was requested,
    the initiator must assume that the key was not understood by the
    target or, whenever appropriate, that the response was "none".'

    to after "Any other key not understood by the target may be ignored
    without affecting basic function."

2.10.1, page 51:
    change "command is performs" to "command performs"
    change "logout is not" to "logout was not"

2.10.6, page 52:
    change "This an" to "This is an".

2.11.3, page 54:
    The sentance "If the login phase involves two login responses
    then each of them will hold for the subsequent responses." does
    not make sense to me.

2.12.2, page 58:
    change "only if it issued" to "only if it is issued"

2.14.1, page 61:
    do you mean "close session" instead of "close connection"?

2.15, page 63:
    change "for the failed connection" to simply "for the connection".

2.16.4, page 65:
    change "additional missed" to "additional sequential missed".

2.17, page 66:
    "The last PDU should have the F bit set to 1".  Shouldn't this
    be "must have the F bit set to 1"?

2.17, page 66:
    change: "The target may send several R2T PDUs and..." to
    to: The target may send several R2T PDUs (if negotiated) and..."

2.18, page 68:
    change: "the target specifies the status for..."
    to: "the target specifies the status and reason for..."

2.18.1, page 69:
    change: "the codes returned for..."
    to: "the codes sent for..."  (and event is not "returned")

2.20, page 71:
    change "inexistent" to "non-existent"

6.1, page 80:
    change "format errors" to "protocol errors".

7.2, page 86:
    change "ACA helps preserving" to "ACA helps preserve"

8, page 87:
    The first paragraph says "iSCSI implementations MUST provide..."
    and the second says "should be provided".  Make these consistent.

---

From: [email-masked]
Date: Sat, 10 Mar 2001 17:27:52 +0200

Fixed  - Thanks, Julo

Matt Wakeley <[email-masked]> on 09/03/2001 12:50:34

Please respond to Matt Wakeley <[email-masked]>

To:   IPS Reflector <[email-masked]>
cc:
Subject:  iscsi: editorial comments to iSCSI-05

1.1, middle page 9:

1.1, bottom page 9:

2.3.2, page 33:

2.3.6, page 34:

2.4.5, page 37:

2.7, page 43 and 44:

2.8.3, page 48:

2.10.1, page 51:

2.10.6, page 52:

2.11.3, page 54:

2.12.2, page 58:

2.14.1, page 61:

2.15, page 63:

2.16.4, page 65:

2.17, page 66:

2.17, page 66:

2.18, page 68:

2.18.1, page 69:

2.20, page 71:

6.1, page 80:

7.2, page 86:

8, page 87:

---

From: [email-masked]
Date: Sat, 10 Mar 2001 18:19:43 +0200

correct - Julo

[email-masked] on 09/03/2001 22:34:19

Please respond to [email-masked]

To:   [email-masked], [email-masked]
cc:
Subject:  RE: iscsi: editorial comments to iSCSI-05

>     sometimes lowercase.  Please make them consistent.

Actually, that's deliberate.  Upper case versions of these
and other terms express requirements, recommendations, and
options for interoperability and the like and are defined
in RFC 2119 (see statement on p.3 of the iSCSI draft).  Lower
case versions of these terms may be used, but do not have
the RFC 2119 meanings and implications of the upper case terms.
The decision to use upper case vs. lower case is a deliberate
decision about whether this is an interoperability issue or
one of similar import/impact - in particular RFC 2119 advises
that these upper case terms "be used with care and sparingly".

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: [email-masked]
Date: Sun, 11 Mar 2001 10:43:10 +0200

Matt,

I fixed those that MUST and did not those that MUST NOT -:)

Julo

Matt Wakeley <[email-masked]> on 11/03/2001 09:54:57

To:   [email-masked]
cc:
Subject:  Re: iscsi: editorial comments to iSCSI-05

I understand this, but it's not consistent.  For example, on page 15:

"data and the status for a command must be sent over the same TCP
connection
that was used to deliver the SCSI command."  and in the very same
paragraph,
"the target MUST return R2T, if any, and the status over the same TCP
connection" These are requirements, but must is sometimes capitalized,
sometimes not.

And on page 56: "The target MUST not set the Status to 0x'0000'", the must
is
capitalized, but the not is not.

-Matt