Subject: RE: SACK (was RE:Async Message PDU)

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Thu, 22 Mar 2001 17:34:56 -0700

David,
Sorry for the delayed reaction, I'm just catching up - You stated that a
decision was made at the Orlando interim meeting to "change some of the
terminology with the goal of each term and acronym being unambiguously owned
by a single layer in the protocol stack".  I think that's the right thing to
do, so can we agree to rename SACK to something that doesn't cause confusion
with the TCP construct?

Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions Org.
Hewlett-Packard
tel: +1 916 785 2656
fax: +1 916 785 0391
email: [email-masked] 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, March 01, 2001 11:37 AM
> To: [email-masked]; [email-masked]
> Subject: RE: Async Message PDU
> 
> 
> Julian will doubtless pick up the rest of these,
> but I thought I'd take this issue, since it was
> part of what we did in Orlando.
> 
> > 4. Somehow, "Asynchronous Message" seems at odds with the 
> rest of the
> > usage in the draft in regards to PDUs (since a message is 
> introduced as
> > PDU in section 1.2).  Should we may be just call it an AEN 
> PDU?  Section
> > 2.14.3 calls this so.  (I realize that it may not always 
> result in a 
> > SCSI-level AER.)
> 
> One of the things we did in Orlando was to change
> some of the terminology with the goal of each term and
> acronym being unambiguously owned by a single layer
> in the protocol stack, in particular making a sharp
> distinction between SCSI concepts and iSCSI mechanisms.
> 
> All the *RN entities changed to *SN for this reason
> (SCSI has a CmdRN, so all *RN entities are SCSI, and
> all *SN entities are iSCSI).  Similarly, all AE*
> entities are SCSI, and we went with "Asynchronous
> Message <*>" to name the iSCSI entities.  This matters
> here because there are circumstances in which iSCSI
> will send Asynchronous Message PDUs for its own use
> even when SCSI has disabled AER.  The usage of "AEN
> PDU" in 2.14.3 is probably an editing oversight.
> Suggestions for words to use instead of "Message"
> are welcome, but they must not start with the letter
> "E" ;-).
> 
> Thanks,
> --David
> ---------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 42 South St., Hopkinton, MA  01748
> +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> [email-masked]       Mobile: +1 (978) 394-7754
> ---------------------------------------------------
>

---

From: [email-masked]
Date: Fri, 23 Mar 2001 17:43:06 +0200

how about SNACK?

Julo

[email-masked] on 23/03/2001 06:52:20

Please respond to [email-masked]

To:   [email-masked], [email-masked]
cc:
Subject:  RE: SACK (was RE:Async Message PDU)

I think picking a new name for SACK to avoid confusion
with TCP is an excellent idea.  Any suggestions for a
new name?

--David

> From:   KRUEGER,MARJORIE (HP-Roseville,ex1)
[SMTP:[email-masked]]
> Sent:   Thursday, March 22, 2001 7:35 PM
> To:     [email-masked]'; [email-masked]
> Subject:     RE: SACK (was RE:Async Message PDU)
>
> David,

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 23 Mar 2001 9:39:36 PST

Thanks to Marjorie for raising this question again.

How about SRR (Selective Run Request)?
--
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

>> From:	KRUEGER,MARJORIE (HP-Roseville,ex1) [SMTP:[email-masked]]

---

From: [email-masked]
Date: Mon, 26 Mar 2001 08:36:11 -0500

Let's see ... that's to report that something
ate some of the data that the receiver was
expecting, right :-) ??  Sounds like a
reasonable suggestion.

--David

> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	Friday, March 23, 2001 10:43 AM
> To:	[email-masked]
> > by a single layer in the protocol stack".  I think that's the right
> thing
> > to