Subject: Re: iSCSI and Mode Pages

From: [email-masked]
Date: Sat, 3 Mar 2001 18:21:06 +0200

OK - will do (probably in the mode pages chapter).

The intent was to have setting through MODE or Text be equivalent (Text is
only for convenience).

Regards,
Julo

[email-masked] on 02/03/2001 22:26:43

Please respond to [email-masked]

To:   [email-masked]
cc:
Subject:  iSCSI and Mode Pages

Section 3 describes several things that can be negotiated
via Text parameters or mode pages.  Requirements for
the behavior of the interaction between these two
mechanisms needs to be set out a little more precisely
(e.g., what happens if MODE SELECT is used on one
of these *after* login is complete), ditto implementation
requirements (e.g., on what fields do MODE SENSE and/or
MODE SELECT have to work).  This should just be a
few sentences indicating what has to be implemented
and what initiators can expect when accessing these
mode pages in an iSCSI target.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: [email-masked]
Date: Mon, 5 Mar 2001 09:04:19 -0500

> Specifying SCSI responses with respect to Mode Select or Mode Sense seems
to
> be running into T10's domain.  Perhaps this work should be placed within
an
> appendix to indicate this information as advisory.

In general, this is correct, but ... in this case all the mode pages in
question
are transport-specific, and hence iSCSI does need to specify how they
behave,
and the interaction with the non-SCSI mechanism (Text keys) that iSCSI
provides as an alternative way to set the (iSCSI-specific) values they
contain.

--David