Subject: iSCSI: Naming and Discovery Draft...

From: "Tanjore K. Suresh" <[email-masked]>
Date: Mon, 5 Mar 2001 16:27:48 -0800 (PST)

Voruganti,

	Here are some minor comments/feedback reading this document.
	
	1. Section 5.2 Discovery Domain
	
		DD Symbolic name
		DD ID
		
		DD Member: WWUI
		DD Member: IP Address

	What does this DD member signify, is this one iSCSI device
	part of Discovery Domain or should this be a list of iSCSI devices
	in that Discovery Domain.  I thought clarifying that would be
	usefull for the reader. Frankly, I didnot understand what it is?

	2. Appendix A iSCSI WWUI Notes...
	
		It looks to me the examples under
		
"Using Intitiator and Target WWUI During Login" can be clubbed with Appendix B
which provides the  different iSCSI Login Scenarios" It looks like some
of the scenarios presented are also in the Appendix B already which seems
to convey the same thing. 

	3. Appendix B, B.4.5,
	  Target Conflict 45 doesnot seem to be appropriate.
		
		I have not reviewed all the documents yet to give a 
		recommendation and hence cannot give, but feel 
		" Target Conflict" doesnot
		convey the meaning of the Scenario indicating
		case of " simple devices that can handle one device or
		the target had reached the limit of its Initiators' capacity."

	4. Typo in page 17
	
	Directory Agent(DA) is an optional part of discovery. If a DA..
	
	......... by the user Agents, to reduce the network load of all UAs
	trying to discovery all SAs
		  ^^^^^^^^ should be "discover".
		  
Thanks
sureshtk

---

From: Mark Bakke <[email-masked]>
Date: Tue, 06 Mar 2001 12:51:19 -0600

Tanjore-

Thanks for the feedback.  I can comment on #3:

>                 the target had reached the limit of its Initiators' capacity."

Perhaps we chose the wrong term for this one.  How about if call it
"Target Busy", and slightly re-word it?
    
   The target is busy with another initiator and cannot handle 
   another one. The initiator MAY try again later. This can be the case 
   for simple devices that can handle only one initiator at a time, or
   for a target that has does not have the resources to support one more
   initiator.  In contrast to the  previous examples, this rejection is
   temporary. 

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "Yaron Klein" <[email-masked]>
Date: Wed, 7 Mar 2001 09:38:07 -0000

Tanjore,

Some more comments:

The error statuses codes on Appendix B are not synchronized with the main
draft. We will fix it.

The term "target conflict" was borrowed from HTTP. Mark clarified this
scenario well. I would like to add that this status enables better
resolution and knowledge to the target. That is, in those cases the target
can just not open the connection or just reject it like server error.
However, this will not give indication of the situation as described by
Mark.

Regards,

Yaron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Mark
Bakke
Sent: Tuesday, March 06, 2001 6:51 PM
To: Tanjore K. Suresh
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: Naming and Discovery Draft...

Tanjore-

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "Renato E. Maranon" <[email-masked]>
Date: Wed, 7 Mar 2001 09:12:24 -0800

My two cents.  I like to suggest "Target Reserved", "Target Reservation
Conflict" or "Target Committed".  For this condition to occur, the target
may not be necessarily busy, but just out of resources, or can only handle
one.  "Target Busy" seems to imply busy.  Building on Mark's desciption
below, something like:

   The target has committed resources to one or more initiators and cannot
handle

Renato Maranon
Maranti Networks, Inc
920 Hillview Court
Milpitas, Ca 95035
Phone:  408-719-9600 x309
Fax:    408-719-9631
email:  [email-masked]
home:   www.marantinetworks.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Yaron Klein
Sent: Wednesday, March 07, 2001 1:38 AM
To: 'Tanjore K. Suresh'
Cc: [email-masked]
Subject: RE: iSCSI: Naming and Discovery Draft...

Tanjore,

Some more comments:

Regards,

Yaron

-----Original Message-----

Tanjore-

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054