Subject: RE: iSCSI: Naming and Discovery Draft...

From: "Tanjore K. Suresh" <[email-masked]>
Date: Thu, 8 Mar 2001 10:39:01 -0800 (PST)

Yaron,

> Some more comments:
> 
> The error statuses codes on Appendix B are not synchronized with the main
> draft. We will fix it.
> 
> The term "target conflict" was borrowed from HTTP. Mark clarified this
> scenario well. I would like to add that this status enables better
> resolution and knowledge to the target. That is, in those cases the target
> can just not open the connection or just reject it like server error.

	I donot understand this part of your statement.
	
	" or just reject it like server error"
	
	I thought reject (0x6f) is used only when the target receives
		- a message with format error
		- a digest error.
		
	Am i missing something here or have i misunderstood this.

> However, this will not give indication of the situation as described by
> Mark.
> 

	I aggree with Yaron to give  a better resolution error message
	depending on the scenerio.
	
	Today according to iSCSI revision 05 draft from Julian, it looks like
	two status codes are looking appropriate in the login response(0x43)
	
	0x205 which means " Target Conflict" ==> this means  target is in
				use by another Initiator and doesnot support
				Multiple initiators".
				
	0x300  which means " Target Error" == > this means error occurred in
				iSCSI target( out of resources... etc).

	I think first one corresponds to the scenario
	
		" The Target is busy with another Initiator and cannot handle
		   another one"
		   
	The second one corresponds to 
	
		" Case of simple device  and target has reached the limit of
		its initiator capacity (out of resources)."

	IMO, May be splitting into two examples is better here.
	
Thanks
sureshtk

> Regards,
> 
> Yaron
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Mark
> Bakke
> Sent: Tuesday, March 06, 2001 6:51 PM
> To: Tanjore K. Suresh
> Cc: [email-masked]; [email-masked]
> Subject: Re: iSCSI: Naming and Discovery Draft...
> 
> 
> Tanjore-
> 
> Thanks for the feedback.  I can comment on #3:
> 
> "Tanjore K. Suresh" wrote:
> >         3. Appendix B, B.4.5,
> >           Target Conflict 45 doesnot seem to be appropriate.
> >
> >                 I have not reviewed all the documents yet to give a
> >                 recommendation and hence cannot give, but feel
> >                 " Target Conflict" doesnot
> >                 convey the meaning of the Scenario indicating
> >                 case of " simple devices that can handle one device or
> >                 the target had reached the limit of its Initiators'
> capacity."
> 
> Perhaps we chose the wrong term for this one.  How about if call it
> "Target Busy", and slightly re-word it?
> 
>    The target is busy with another initiator and cannot handle
>    another one. The initiator MAY try again later. This can be the case
>    for simple devices that can handle only one initiator at a time, or
>    for a target that has does not have the resources to support one more
>    initiator.  In contrast to the  previous examples, this rejection is
>    temporary.
> 
> --
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054
>

---

From: "Yaron Klein" <[email-masked]>
Date: Sun, 11 Mar 2001 10:32:09 -0000

Tanjore,

In "Reject" I meant sending status of "Target Error", in no way it is
related to the reject command (6f).

Regards,

Yaron

Regards,

-----Original Message-----
From: Tanjore K. Suresh [mailto:[email-masked]]
Sent: Thursday, March 08, 2001 6:39 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: iSCSI: Naming and Discovery Draft...

Yaron,

Thanks
sureshtk