Subject: RE: iSCSI Target Reset

From: "John Hufferd" <[email-masked]>
Date: Thu, 26 Apr 2001 01:24:17 -0700

I received the following statement from the IBM Shark development team.

" For Fibre Channel, Shark supports Target Reset and it is used by almost
all the hosts as well.

Shark supports Target Reset by resetting all the LUNS that are configured
to the host that issues
the Target Reset.   The Target Reset, therefore, will not affect the LUNs
seen by other initiators,
unless they are in sharing the same LUNs. "

Therefore, it probably make some since to state, in the draft, that this
kind of approach should be considered by iSCSI implementers.

I do not think this is a large controller only problem, since with iSCSI,
lots of different desktop and Laptops will be getting at RAID arrays, which
might have previously been attached to only 2 Host via SCSI BUSes or a few
more hosts with Fibre Channel.

IOW, Target Reset has a larger impact then before, even on Storage
controllers that are in the "Mid Range" (and lower), which previously may
not have even worried about the issue.

So the mention of an approach such as the above might be a useful note in
the Spec.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
(408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Internet address: [email-masked]

Julian Satran/Haifa/IBM@[email-masked] on 04/26/2001 12:41:04 AM

Sent by:  [email-masked]

To:   [email-masked]
cc:
Subject:  RE: iSCSI Target Reset

I agree that this is an implementation decision.  However I wonder it it
won't be fair to tell the guy trying to do reset that although everything
is fine the reset was not performed - and do this in a way that does not
harm legacy initiators.

Julo

[email-masked] on 24/04/2001 02:31:24

Please respond to [email-masked]

To:    [email-masked]
cc:
Subject:  RE: iSCSI Target Reset

I agree with Charles that this is an implementation
issue.  If a Shark wants to reset all 32 adapters
when it receives a Target Reset on one of them, that's
a Shark implementation decision.  It's completely valid
to reset only the adapter that the Target Reset is
received on (common Fibre Channel behavior) or
only the iSCSI target to which the Target Reset is
addressed if there's more than one Target behind
the adapter.

As for leaving things out of iSCSI - the default modus
operandi should be to put in everything that's described
in SAM2 unless we can convince T10 to take the feature
out of SAM2.  Let's not go deciding to cast things out
of SCSI on T10's behalf.

Thanks,
--David

> -----Original Message-----
> From:   Charles Monia [SMTP:[email-masked]]
> Sent:   Monday, April 23, 2001 7:12 PM
> To:     [email-masked]
> Subject:     RE: iSCSI Target Reset
>
> Hi:
>
> These seem to be implementation decisions. I don't see how that justifies
> removing support from the protocol.
>
> Charles
>
> > -----Original Message-----
> > From: John Hufferd [mailto:[email-masked]]
> > Sent: Monday, April 23, 2001 2:34 PM
> > To: Santosh Rao
> > Cc: [email-masked]
> > Subject: Re: iSCSI Target Reset
> >
> >
> >
> > Absolutely not,  Why would we think that impacting 32 different other
> > initiators is an OK thing to do.  By the way there are lots
> > more Initiators
> > possible with FC on Shark, and would hope that there would be
> > even more
> > with iSCSI.
> >
> > I have been told that these large Storage Controllers do not
> > support Target
> > Reset today.  So I see no loss in not supporting such an item in iSCSI
> > especially since many Initiators will be beyond even the distances and
> > mischief that is possible with FC.
> >
> > .
> > .
> > .
> > John L. Hufferd
> > Senior Technical Staff Member (STSM)
> > IBM/SSG San Jose Ca
> > (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
> > Internet address: [email-masked]
> >
> >
> > Santosh Rao <[email-masked]>@ece.cmu.edu on 04/23/2001
> > 01:24:02 PM
> >
> > Sent by:  [email-masked]
> >
> >
> > To:   [email-masked]
> > cc:
> > Subject:  Re: iSCSI Target Reset
> >
> >
> >
> > "Dillard, David" wrote:
> > >
> > > When will STORPORT be generally available?  The latest
> > STORPORT document
> > > that I found on the MS web site is version 0.6a, dated
> > March 18, 2001.
> > > Given this it seems like STORPORT might not be available
> > soon.  In that
> > case
> > > do you know what happens with the current drivers?  Are we
> > going to be
> > > telling customers that if they want to use iSCSI and NT
> > clustering they
> > have
> > > to update to Whistler?
> >
> >
> > [One would hope that this list does not turn into a Microsoft
> > release/product discussion mailing list (?) ]
> >
> > Without going into specifics of A certain O.S., does it suffice to
> > require that iSCSI not break existing legacy SCSI applications ?
> >
> > If the above is a valid requirement, then, knowing that legacy
> > applications continue to use SCSI-2 Reserve/Release and the
> > target reset
> > as a mechanism of breaking SCSI-2 reservations, should'nt
> > iSCSI continue
> > to support the target reset ?
> >
> > - Santosh
> >
> >
> >
> >

---

From: Mark Mokryn <[email-masked]>
Date: Thu, 26 Apr 2001 18:18:49 +0200

The Shark approach cannot be easily adopted by many arrays, since only
some manufacturers implement ACLs at the array level. Others rely on
host software, intelligent switches, etc. for LUN masking and remapping.
For these types of arrays, a Target Reset is a headache.