Subject: RE: TCP framing and SCTP Checksum: TSVWG only

From: [email-masked]
Date: Thu, 19 Apr 2001 20:23:13 -0400

Doug - please follow instructions from your WG co-chair.
Both TCP framing and SCTP Checksums are tsvwg topics
and need to be taken up there.  If solutions emerge
there, they can be adopted by reference here - you
can be assured that you're not the only person on
both mailing lists.

--David

> -----Original Message-----
> From:	Douglas Otis [SMTP:[email-masked]]
> Sent:	Thursday, April 19, 2001 7:37 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	RE: TCP framing and SCTP Checksum: TSVWG only
> 
> David,
> 
> The various proposals on the table for either iFCP or FCIP encapsulation
> may
> benefit from utilization of a generalized framing layer suitable for both
> TCP and SCTP.  In that respect, I thought it advantageous to consider
> these
> aspects.  This goes into the generalized aspects of extended error
> detection, frame validation, higher level retry on a digest failure, and
> identification of the underlying payload and was my reasoning for
> including
> this within the IPS WG.  I understand if this proposal is to proceed on a
> standards path, it will be within TSVWG.  If there is no interest within
> this WG, then it will not be mentioned further.
> 
> Doug
> 
> 
> > Both TCP framing and SCTP checksums are topics
> > specific to TSVWG - please post on these only
> > to the tsvwg list and do not cross-post to the
> > ips list, as we already have more than enough
> > traffic.
> >
> > Thanks,
> > --David
> >
> > ---------------------------------------------------
> > David L. Black, Senior Technologist
> > EMC Corporation, 42 South St., Hopkinton, MA  01748
> > +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> > [email-masked]       Mobile: +1 (978) 394-7754
> > ---------------------------------------------------
> >
> >

---

From: "Douglas Otis" <[email-masked]>
Date: Thu, 19 Apr 2001 18:14:35 -0700

David,

I did not start the checksum thread, but I will be happy to follow your
instructions.  I can not guarantee actions of others.  I understand the
common interests where both groups have WIP related to evaluating end-to-end
error detection.  I have already given assurance with respect to TCP framing
if there is no related interest although I feel here again this is
potentially related to iFCP and FCIP encapsulation.  Opportunities are rare
for sharing efforts with mutual benefits.

Doug