Subject: FW: I-D ACTION:draft-ietf-ips-iscsi-reqmts-03.txt

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Mon, 23 Apr 2001 12:35:09 -0400

I haven't seen the I-D ACTION for the iSCSI Requirements Document, but it is
posted on the IETF web site, so I'm forwarding this link.  

Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions Org.
Hewlett-Packard
tel: +1 916 785 2656
fax: +1 916 785 0391
email: [email-masked] 

> -----Original Message-----
> Subject: I-D ACTION:draft-ietf-ips-iscsi-reqmts-03.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the IP Storage Working Group of the IETF.
> 
> 	Title		: iSCSI Requirements and Design Considerations
> 	Author(s)	: M. Krueger et al.
> 	Filename	: draft-ietf-ips-iscsi-reqmts-03.txt
> 	Pages		: 22
> 	Date		: 16-Apr-01
> 	
> The IP Storage Working group is chartered with developing 
> comprehensive 
> technology to transport block storage data over IP protocols. 
>  This effort includes a protocol to transport the Small 
> Computer Systems Interface (SCSI) protocol over the internet (iSCSI).
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ips-iscsi-reqmts-03.txt
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-ips-iscsi-reqmts-03.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-ips-iscsi-reqmts-03.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

Date: Wed, 11 Apr 2001 12:49:40 -0400

---

From: "Douglas Otis" <[email-masked]>
Date: Mon, 23 Apr 2001 13:14:48 -0700

Marjorie,

This requirements document makes it clear there is expectation of modifying
Ethernet adapters to support this protocol.  Should this required hardware
support be made in a general fashion to allow common use among other
protocols?  This hardware requirement is primarily based on two
requirements, to increase the level of error detection and to allow framing.
Presently, IETF supports a framing protocol that also increases the level of
error detection.

Presently TSVWG and IPS are working on a common error detection algorithm.
In addition, there are two other protocols expecting hardware for framing
and error detection.  This is iFCP and FCIP.

See:
http://www.ietf.org/internet-drafts/draft-ietf-ips-fcencapsulation-00.txt

It is possible to have all these protocols use the same error detection and
framing.  If this MUST be done using TCP, as this requirement document
demands, then here is a possible general propose header that would allow
common use of hardware and a easy transition into SCTP.

I will be happy to define a mapping from the present protocols into this
generalized form.  The advantage should be obvious.  One Ethernet adapter
can handle these various protocols without specialized hardware for each.

For those wishing to update and route based on encapsulated headers, a
fix-up field at the end of these headers will allow use of a common error
scheme using header fix-up.

Here is an example of how TCP can be made to look like SCTP.
http://www.ietf.org/internet-drafts/draft-otis-iscsi-fullack-00.txt

This header could become a TCP option field to allow for negotiation.

P.S.
One additional question however.

On page 18,
   "The iSCSI protocol document SHOULD NOT define the management
   architecture for iSCSI within the network infrastructure."

What does this mean?

Doug

> comprehensive technology to transport block storage data
> over IP protocols.  This effort includes a protocol to
> transport the Small Computer Systems Interface (SCSI)
> protocol over the internet (iSCSI).
>

---

From: "Douglas Otis" <[email-masked]>
Date: Tue, 24 Apr 2001 12:14:25 -0700

Marjorie,

Thanks for the change.  One question however.

On page 18,

 What does this mean?

I think it means that the iSCSI protocol document SHOULD NOT define the
management architecture.  The management architecture may be defined within
in a separate document.

I do not understand the phrase 'within network infrastructure.'

Doug