Subject: RE: iSCSI : Aborting non-SCSI tasks.

From: Charles Monia <[email-masked]>
Date: Tue, 24 Apr 2001 14:33:09 -0700

Hi Santosh:

My .02 (again):

Assuming these transactions are handled in the iSCSI layer:

a) No abort mechanism is required.  Like a 'ping' operation, these functions
are expected to complete in some fixed time or not at all.

b) A timeout indicates the iSCSI layer is broken -- i.e., timeouts are
fatal.

Charles

> -----Original Message-----
> From: Santosh Rao [mailto:[email-masked]]
> Sent: Tuesday, April 24, 2001 1:31 PM
> To: Charles Monia
> Cc: IPS Reflector
> Subject: Re: iSCSI : Aborting non-SCSI tasks.
> 
> 
> Hi Charles,
> 
> non-scsi tasks refers to Login, Logout, Text & NOP-OUT PDUs.
> 
> Initiators will need to time these tasks [exchanges ?] and how do they
> deal with a timeout of such non-scsi tasks [exchanges/PDUs/commands] ?
> 
> 
> Regards,
> Santosh
> 
> 
> Charles Monia wrote:
> > 
> > Hi Santosh:
> > 
> > > The iSCSI spec is missing description on how non-SCSI 
> tasks should be
> > > aborted
> > 
> > What is a non-SCSI task?
> > 
> > Charles
> > > -----Original Message-----
> > > From: Santosh Rao [mailto:[email-masked]]
> > > Sent: Tuesday, April 24, 2001 10:27 AM
> > > To: IPS Reflector
> > > Subject: iSCSI : Aborting non-SCSI tasks.
> > >
> > >
> > > All,
> > >
> > > The iSCSI spec is missing description on how non-SCSI 
> tasks should be
> > > aborted in order to flush stale PDUs of that task. Initiators will
> > > typically time non-SCSI [& SCSI] tasks and will need to 
> resort to some
> > > form of abort and cleanup action on a timeout of the 
> non-scsi task.
> > >
> > > This is required in order to safely re-use the task tag resources
> > > without the danger of stale PDUs arriving from a previous
> > > incarnation of
> > > that task tag.
> > >
> > > The spec should provide some description on how this is 
> to be done.
> > > Perhaps, the semantics of Abort Task can be extended to 
> non-SCSI tasks
> > > as well, to avoid defining a second abort mechanism for
> > > non-SCSI tasks.
> > >
> > > - Santosh
> > >
>

---

From: Santosh Rao <[email-masked]>
Date: Tue, 24 Apr 2001 16:20:01 -0700

Hi Charles,

Yes, this would be sufficient and simple enough for such an event. The
point here being that the iSCSI spec needs to explicitly address this
issue of deterministic termination of non-SCSI command PDUs like text,
nop-out, login, logout, etc.

The solution could be based on a timer with gross recovery on its
expiry. However, such a timer needs to be specified by the protocol and
tunable through an iSCSI login key (timers equivalent to RR_TOV, RA_TOV
in FC).

Regards,
Santosh