Subject: Re: iSCSI: Re: iSCSI & Linked Commands

From: Santosh Rao <[email-masked]>
Date: Thu, 26 Apr 2001 10:43:51 -0700

This thread on linked commands has no relevance to iSCSI any longer, as
has been mentioned several times by now.  

- Santosh

Douglas Otis wrote:
> 
> Robert,
> 
> Relative addressing is not defined because that is the only means of
> addressing.  Relative to the last block.
> 
> Doug
> 
> > Doug,
> >
> > Relative addressing is not defined in the SSC command set nor
> > in the SPC command set for tapes.
> >
> > Bob
> >
> > >  -----Original Message-----
> > >  From: Douglas Otis [mailto:[email-masked]]
> > >  Sent: Monday, April 23, 2001 9:36 AM
> > >  To: Stephen Bailey; [email-masked]
> > >  Subject: RE: iSCSI: Re: iSCSI & Linked Commands
> > >
> > >
> > >  Stephen,
> > >
> > >  Unlike random access devices, sequential access devices operate with
> > >  relative addressing.  For random access devices, this is a
> > >  seldom used
> > >  option.  There is a requirement to bind commands together to
> > >  ensure order of
> > >  execution on these devices.  By popular, you mean not sequential?
> > >
> > >  Doug
> > >
> > >
> > >  > Julian,
> > >  >
> > >  > > According to your logic no FCP implementation can use
> > >  linked commands?
> > >  > > Is this true for all OS's?  Is it a verified fact or foloklor?
> > >  >
> > >  > In my experience it's fact.  I have never used a SCSI
> > >  stack which both
> > >  > supported AND used linked commands.  Like some others
> > >  here, I always
> > >  > assumed AIX might :^) Ralph has pointed out that T10 is well aware
> > >  > that the feature is not popular.  There are other ways of
> > >  > accomplishing the same thing that are less likely to blow
> > >  up in your
> > >  > face.
> > >  >
> > >  > > Is it so also for the new MS StorPort driver?
> > >  >
> > >  > I don't know, but I'd be really surprised if they did use linked
> > >  > commands.  You have to be pretty nuts to rely on a feature
> > >  that's not
> > >  > even exercised by most SCSI implementations.
> > >  >
> > >  > Steph
> > >  >
> > >
> > >
> >

---

From: Robert Snively <[email-masked]>
Date: Thu, 26 Apr 2001 08:04:38 -0700

Doug,

Bob

---

From: "Douglas Otis" <[email-masked]>
Date: Thu, 26 Apr 2001 10:15:24 -0700

Robert,

Doug