Subject: Initiator-detected format or digest errors

From: "Thomas McSweeney" <[email-masked]>
Date: Wed, 4 Apr 2001 07:57:20 -0400

Section "2.20 Reject" talks about the target receiving a bad frame and
sending Reject.  What should an Initiator do if it receives a PDU with a
format or digest error?  Should it send Reject?  If so, we'll need to
ensure that the Initiator fields of the MIB include an object to count
Reject commands transmitted.

Tom McSweeney
iSCSI Development, Storage Systems Group, IBM
Email: [email-masked]
Phone: (USA) 919-254-5634  (tie line: 444-5634)
Fax:   (USA) 919-254-0391  (tie line: 444-0391)

---

From: [email-masked]
Date: Fri, 6 Apr 2001 03:59:58 +0200

Matt,

3 reasons:

a. the initiator drives recovery. What can a target do with the reject?
(he is probaly in need of a reset)

b.the initiator is unaware of the target state after thhe error

c.there is reject command (and response) -:)

Julo

Matt Wakeley <[email-masked]> on 06/04/2001 00:43:08

Please respond to Matt Wakeley <[email-masked]>

To:   IPS Reflector <[email-masked]>
cc:
Subject:  Re: Initiator-detected format or digest errors

Why not send a reject back to the originator of the bad frame, and just let
the task time out?

-Matt

[email-masked] wrote:
>
> Tom,
>
> An initiator will pass the appropriate response to the SCSI layer and
will
> abort the task if it can identify one.  Further behavior of initiators
and
> targets is implementation dependent.
>
> 6.2 specifies this.
>
> Julo
>
> "Thomas McSweeney" <[email-masked]> on 04/04/2001 13:57:20
>
> Please respond to "Thomas McSweeney" <[email-masked]>
>
> To:   [email-masked]
> cc:
> Subject:  Initiator-detected format or digest errors
>