Subject: RE: iSCSI: Re: iSCSI & Linked Commands

From: Charles Monia <[email-masked]>
Date: Mon, 23 Apr 2001 12:15:47 -0700

Hi:

This seems like a non-issue.

As I recall, what triggered this thread was the concern that the iSCSI had
transport had to do something special to support linked commands. While
there were and continue to be issues with existing implementations, these
seem to be strictly confined to the SCSI layer.

I don't believe linked commands impose any requirements on iSCSI over and
above what's needed to support normal unlinked commands.

Charles
> -----Original Message-----
> From: Stephen Bailey [mailto:[email-masked]]
> Sent: Monday, April 23, 2001 6:16 AM
> To: [email-masked]
> Subject: iSCSI: Re: iSCSI & Linked Commands 
> 
> 
> Julian,
> 
> > According to your logic no FCP implementation can use 
> linked commands?
> > Is this true for all OS's?  Is it a verified fact or foloklor?
> 
> In my experience it's fact.  I have never used a SCSI stack which both
> supported AND used linked commands.  Like some others here, I always
> assumed AIX might :^) Ralph has pointed out that T10 is well aware
> that the feature is not popular.  There are other ways of
> accomplishing the same thing that are less likely to blow up in your
> face.
> 
> > Is it so also for the new MS StorPort driver?
> 
> I don't know, but I'd be really surprised if they did use linked
> commands.  You have to be pretty nuts to rely on a feature that's not
> even exercised by most SCSI implementations.
> 
> Steph
>

---

From: "Douglas Otis" <[email-masked]>
Date: Mon, 30 Apr 2001 16:11:47 -0700

Robert,

You are correct in the explicit definitions of the SAMS dictionary.  I was
simply attempting to explain the reason for a concern about sequential
ordering as it relates to these two devices.  Perhaps they could add
nextitive addressing.  :)

Doug

> From: Robert Snively [mailto:[email-masked]]
> Sent: Monday, April 30, 2001 4:13 AM
> To: Douglas Otis; Robert Snively; Stephen Bailey; [email-masked]
> Subject: RE: iSCSI: Re: iSCSI & Linked Commands
>
>
> Doug,
>
> Sorry, that is not how the SCSI standards define relative
> addressing.  Relative addressing is a displacement from the
> last logical block transferred in an SCB read or write command
> and applies to the read or write command in which the RELADR
> bit is set.
>
> Tape devices have the property of sequential access.  Except
> for Locate (which is an absolute address), all tape addressing
> is "next".  To get to "next + n", you have to do a separate
> explicit command to step across the intervening blocks, which
> are not logical blocks and cannot be directly addressed.
>
> It may be that you are applying generic English definitions to
> words which SCSI has assigned a special meaning.
>
> Bob
>
> >  From: Douglas Otis [mailto:[email-masked]]
> >  Sent: Thursday, April 26, 2001 10:15 AM
> >  To: Robert Snively; Stephen Bailey; [email-masked]
> >  Subject: RE: iSCSI: Re: iSCSI & Linked Commands
> >
> >
> >  Robert,
> >
> >  Relative addressing is not defined because that is the only means of
> >  addressing.  Relative to the last block.
> >
> >  Doug
> >
> >
> >  > Doug,
> >  >
> >  > Relative addressing is not defined in the SSC command set nor
> >  > in the SPC command set for tapes.
> >  >
> >  > Bob
> >  >
> >  > >  From: Douglas Otis [mailto:[email-masked]]
> >  > >  Sent: Monday, April 23, 2001 9:36 AM
> >  > >  To: Stephen Bailey; [email-masked]
> >  > >  Subject: RE: iSCSI: Re: iSCSI & Linked Commands
> >  > >
> >  > >
> >  > >  Stephen,
> >  > >
> >  > >  Unlike random access devices, sequential access devices
> >  operate with
> >  > >  relative addressing.  For random access devices, this is a
> >  > >  seldom used
> >  > >  option.  There is a requirement to bind commands together to
> >  > >  ensure order of
> >  > >  execution on these devices.  By popular, you mean not
> >  sequential?
> >  > >
> >  > >  Doug
> >  > >
> >  > >
> >  > >  > Julian,
> >  > >  >