Subject: RE: iSCSI : login keys & mode page settings

From: [email-masked]
Date: Fri, 20 Apr 2001 13:12:04 -0400

Without getting into the technical details of the
discussion, I have a couple of observations:

(A) The issue of whether to allow mode page
	access to and modification of iSCSI parameters
	will need to be taken up at the interim
	meeting.  IMHO, access seems like a good
	idea, so that SCSI-generic code that doesn't
	know specifically about iSCSI can find
	what it expects where it expects it, but
	I'm unsure about modification because it
	may carry a risk of code that's iSCSI-unaware
	getting something wrong.  The mode page
	commands should be transparent to iSCSI.

(B) The mode page and text key mechanisms have
	to access the same data.  Section 3 of the
	-06 version says this, but needs some editing
	to enforce it by using "MUST" or its equivalent
	(cf. RFC 2119).  This is to prevent an
	implementation from having two instances of
	the same parameter - one for the mode page and
	one for the text keys - which would be a bad
	thing.

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: Santosh Rao <[email-masked]>
Date: Fri, 20 Apr 2001 17:09:23 -0700

David,

Some clarification on the basis for classifying login keys as LO would
also be helpful. Should login keys that can disrupt I/O on their change
be allowed to be non-LO ?

Thanks,
Santosh