Subject: Re: iSCSI : EnableACA

From: [email-masked]
Date: Fri, 27 Apr 2001 17:46:50 +0300

Ralph,

I am not sure that I understand the question.

After the reset task management functions iSCSI requires the target enter
Unit Atention for all other initiators connected to the same target (or LU)
and, after reporting the Unit Attention enter ACA.

You and Ed pointed out that many initiators will be unable to handle this
(will not reset the condition).

EnableACA is a hack intended to allow an initiator to control the target
behavior.

NormACA and the NACA CDB bit have similar purposes but NormACA is a
"read-only" flag and the ACA condition is not created in this case as a
result of a command execution error but as a result of an action by an
external factor (another initiator).

This situation is probably more general - and some other transports dealing
with commands in flight might experience a similar
problem but up to now SPC has no way of handling this situation.

If Ed is going to cover this within the "extended use of ACA" we discussed
for SCSI commands rejected with busy and task set full and for Unit
Attention we might have to coordinate.

Regards,
Julo

Ralph Weber <[email-masked]> on 27/04/2001 14:59:24

Please respond to [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  Re: iSCSI : EnableACA

Julian,

Regarding your discussion with Santosh...

> The task management functions for iSCSI contain a
> description the behaviour I am talking about. This
> was also subject to a long discussion on the list
> that included the need for ACA behaviour for things
> like task-set full, busy etc. - not considered for
> ACA. For the later T10 is handling making ACA
> behaviour available.
>
My question is... Exactly which what are the cases where
T10 is NOT considering making ACA behavior available so
that you believe the EnableACA function is necessary in
iSCSI?

My belief is that every behavior that EnableACA covers
but T10 does not needs to be taken to T10 to see if
they can find a better way to extend ACA coverage to
that area.

Thanks.

Ralph...

---

From: Ralph Weber <[email-masked]>
Date: Fri, 27 Apr 2001 13:24:26 -0500

} Ralph,
}
} I am not sure that I understand the question.

Looks like you have done a good job to me.

} After the reset task management functions iSCSI requires
} the target enter Unit Attention for all other initiators
} connected to the same target (or LU) and, after reporting
} the Unit Attention enter ACA.
}
} You and Ed pointed out that many initiators will be unable
} to handle this (will not reset the condition).
}
} EnableACA is a hack intended to allow an initiator to control
} the target behavior.

First off, unless Asynchronous Event Reporting is enabled,
Unit Attention conditions get reported with a CHECK CONDITION
status, bingo ACA is controlled in the usual way with the
NACA bit.

Second, Ed is going to cover Unit Attention conditions in his
proposal, in fact that was Ed's hot button that got him writing
a proposal.  Ed's proposal does not exactly make Unit Attention
engage an ACA, instead he is proposing to give the Unit Attention
condition an ACA-like longevity (i.e., the Unit Attention
condition stays active until the initiator acknowledges it).

So, I am wondering why the EnableACA is needed.  From my point of
view, putting something like EnableACA in the protocol definition
is bad layering (not that SCSI has always observed good layering,
but why continue to promote bad habits).

} NormACA and the NACA CDB bit have similar purposes but
} NormACA is a "read-only" flag and the ACA condition is not
} created in this case as a result of a command execution error
} but as a result of an action by an external factor (another
} initiator).
}
} This situation is probably more general - and some other
} transports dealing with commands in flight might experience
} a similar problem but up to now SPC has no way of handling
} this situation.
}
} If Ed is going to cover this within the "extended use of ACA"
} we discussed for SCSI commands rejected with busy and task set
} full and for Unit Attention we might have to coordinate.

I think we need to coordinate.  It also may be necessary to
give Ed a gentle nudge.

Thanks.

Ralph...