Subject: iSCSI: immediate data

From: [email-masked] (Sandeep Joshi)
Date: Sat, 5 May 2001 09:55:06 -0400 (EDT)

Julian,

I had a follow-up question on an old thread. 
  http://ips.pdl.cs.cmu.edu/mail/msg03373.html

The initiator is allowed to send firstburst in immediate 
or in separate PDUs...but can it do neither ?  I dont
see any statement to the effect that it MUST send a
firstburst. 

Here's a possible problem :
1) FirstBurst is 4K
2) Expected data length of command is 16K
3) Initiator sends the Scsi command without immediate 
   data.   (final flag on Scsi command is not set)
   And it decides to send no further data PDUs.

The target does not know if R2Ts can be sent since it does
not know if any unsolicited PDUs are expected.

Perhaps the semantics on the final flag on SCSI command
need to be changed to indicate that no unsolicited data 
will be sent with this command.  Currently, the flag implies
(Sec 2.3.1) that all the required data has been sent with 
the command.

And here's a typo to fix.  Appendix E (Key=immediateData)
The following should say "initialR2T is no".  
The table has got it right.

> If ImmediateData is set to yes and InitialR2T is set 
> to yes then the initiator MAY send unsolicited immediate 
> data or one unsolicited burst of Data-OUT PDUs but 
> MUST NOT send both immediate and a unsolicited burst of 
> Data-OUT PDUs for any one command. 

-Sandeep

---

From: "Matt Wakeley" <[email-masked]>
Date: Tue, 08 May 2001 12:29:43 -0700

The intention is that if an initiator requests to send immediate data (and is
granted the request), then it will always send immediate data.

It sounds like you are asking for wishy washy mode... sometimes send immediate
data, sometimes not.

-Matt