Subject: ISCSI: Flags in header indicating that digest is present

From: Venkat Rangan <[email-masked]>
Date: Fri, 18 May 2001 19:06:21 -0700

Julian,

At some point, we had bits in the BHS that indicated whether Header Digest
and/or Data Digest is present. They now have disappeared, perhaps when we
removed the WN-based PDUs for Draft-6. Now, how do we know from the PDU
itself whether it is present or not? If not, is the intention that we
maintain the current state of the digest negotiation and apply it to all
PDUs?

From Draft 5:
----------------
2.2.1 What's Next (WN)  
    
   This is an encoded field that indicates what the next segment is. 
    
      bit 7  - 1  Next is another header segment. 
         bit 6-4  Next header type code 
               0  Extended CDB 
               1  Bi-directional read-data transfer header 
               2  Long Data Header 
             3,4,5,6,7  Reserved 
         bit 3-0  Reserved 
      bit 7  - 0  Next is a data segment or no additional segment 
      (empty data segment) 
         bit 6 Header Digest Present (1) or Not (0) 
         bit 5 Data Digest Present (1) or Not (0) 
         bit 4-0  Reserved 
------------------

Thanks,

Venkat Rangan
Rhapsody Networks Inc.
http://www.rhapsodynetworks.com

---

From: [email-masked]
Date: Sat, 19 May 2001 08:48:04 +0300

Venkat,

Yes - the new format has a total length field that consumes too many bits
to have some left for digests.

Julo

Venkat Rangan <[email-masked]> on 19-05-2001 05:06:21

Please respond to Venkat Rangan <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject:  ISCSI: Flags in header indicating that digest is present

Julian,

From Draft 5:
----------------
2.2.1 What's Next (WN)

Thanks,

Venkat Rangan
Rhapsody Networks Inc.