Subject: Recovery mechanism

From: "Ajit Khaparde" <[email-masked]>
Date: Tue, 08 May 2001 19:15:15 +0530

Hello,
I'm currently going through the document "draft-ietf-ips-iscsi-05.txt".
I hope this is the latest document. Is it so?

Then I have few queries:
TO recover a device(a target or an initiator), within a Task, what is the 
number of retries to be given to prevent an initiator from requesting a dead 
target.
Also, how can an initiator know about the presence of a dead target.
Also is it possible for a device(initiator) to remember a dead target?

Thanking you.
Awaiting your reply.
Ajit
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: [email-masked]
Date: Wed, 9 May 2001 03:10:51 -0400

> I hope this is the latest document. Is it so?

No, -06 is the latest.  Check this page to find out and retrieve the
latest version of any IPS WG draft: 

http://www.ietf.org/html.charters/ips-charter.html

> number of retries to be given to prevent an initiator from requesting a
dead 

I suspect these are implementation-dependent in the draft you're looking
at.  A dead target has a nasty habit of not responding to anything, and
hence the Initiator has to make a decision to give up at some point.

> Also, how can an initiator know about the presence of a dead target.

See above.  Both SLP and iSNS may be able to help convey information
that a target is sufficiently non-responsive to no longer be part of
the discovery infrastructure.

> Also is it possible for a device(initiator) to remember a dead target?

It's definitely possible - doing so persistently to
avoid trying to discover that target (e.g., on reboot)
may be dangerous (e.g., the target may be back by then).

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------