Subject: Another shot at codes and please comment

From: [email-masked] (Sandeep Joshi)
Date: Tue, 1 May 2001 15:07:06 -0400 (EDT)

Julian,

I'd prefer this over the alternating opcode assignments.
(where nop-out was 0 and nop-in was 1)

Could you also define the behaviour if a vendor-specific 
opcode was not recognized ?   

I presume we always want to drop the session, since these 
opcodes would only be used if the target and initiator 
recognized/negotiated (in a vendor-specific way) their
use during session initiation.

-Sandeep

> Here is a another version of the opcodes part:
> 
> 1.1.1.1   Opcode
> 
>    The Opcode indicates what type of iSCSI PDU the header encapsulates.
> 
>    The Opcodes are divided into two categories: initiator opcodes and
>    target opcodes. Initiator opcodes are in PDUs sent by the initiators
>    (request PDUs), and target opcodes are in PDUs sent by the target
>    (response PDUs).
> 
>    Initiators MUST NOT use target opcodes and targets MUST NOT use
>    initiator opcodes.
> 
>    Valid initiator opcodes defined in this specification are:
> 
> 
>       0x00 NOP-Out (from initiator to target)
>       0x01 SCSI Command (encapsulates a SCSI Command Descriptor Block)
>       0x02 SCSI Task Management Command
>       0x03 Login Command
>       0x04 Text Command
>       0x05 SCSI Data-out (for WRITE operations)
>       0x06 Logout Command
>       0x10 SNACK Request
> 
>    Valid target opcodes are:
> 
> 
>       0x20 NOP-In (from target to initiator)
>       0x21 SCSI Response (contains SCSI status and possibly sense
>       information or other response information)
>       0x22 SCSI Task Management Response
>       0x23 Login Response
>       0x24 Text Response
>       0x25 SCSI Data-in (for READ operations)
>       0x26 Logout Response
>       0x31 Ready To Transfer (R2T - sent by target to initiator when it is
>       ready to receive data from initiator)
>       0x32 Asynchronous Message (sent by target to initiator to indicate
>       certain special conditions)
>       0x3f Reject
> 
>    Initiator opcodes 0x1c-0x1e and target opcodes 0x3c-0x3e are vendor
>    specific codes.
> 
> 
>    Please comment,
>    Julo
>

---

From: Venkat Rangan <[email-masked]>
Date: Fri, 18 May 2001 19:12:17 -0700

Julian,

What is the state of this change? Is this going to be in draft 7, or is
it in draft 6?

Thanks,

Venkat Rangan
Rhapsody Networks Inc.
http://www.rhapsodynetworks.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 01, 2001 6:50 AM
To: [email-masked]
Subject: Another shot at codes and please comment

1.1.1.1   Opcode

   Please comment,
   Julo

---

From: [email-masked]
Date: Sat, 19 May 2001 08:51:20 +0300

Venkat,

This seems to be the popular choice for 07 (2 voices for, none against and
silence from the bored majority).

Julo

Venkat Rangan <[email-masked]> on 19-05-2001 05:12:17

Please respond to Venkat Rangan <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject:  RE: Another shot at codes and please comment

Julian,

Thanks,

Venkat Rangan
Rhapsody Networks Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 01, 2001 6:50 AM
To: [email-masked]
Subject: Another shot at codes and please comment

1.1.1.1   Opcode

   Please comment,
   Julo

---

From: "Eddy Quicksall" <[email-masked]>
Date: Sun, 20 May 2001 20:54:22 -0400

I vote ok on these OpCodes.

BTW, I would prefer that the opcode field is used strictly for the opcode 
(i.e. not have the X and I bits).

However, if this has already been discussed or if there is just no other 
place for the bits, I will submit.

Eddy

----Original Message Follows----
From: [email-masked]
To: [email-masked]
Subject: RE: Another shot at codes and please comment
Date: Sat, 19 May 2001 08:51:20 +0300
Venkat,
This seems to be the popular choice for 07 (2 voices for, none against and
silence from the bored majority).
Julo
Venkat Rangan on 19-05-2001 05:12:17
Please respond to Venkat Rangan
To: Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject: RE: Another shot at codes and please comment
Julian,
What is the state of this change? Is this going to be in draft 7, or is
it in draft 6?
Thanks,
Venkat Rangan
Rhapsody Networks Inc.
http://www.rhapsodynetworks.com
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 01, 2001 6:50 AM
To: [email-masked]
Subject: Another shot at codes and please comment
_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com