Subject: RE: iSCSI: Aggregation tags in SendTargets

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Wed, 16 May 2001 13:57:36 -0600

I think you meant to ask
 
***    Anyone need Alpha-Numeric Aggregation Tags    ***
                   ^^^^^
                   Going once....

I have no strong opinion either.  Alpha's a little more user-friendly, but
that is not important enough in this feature to warrant any argument, so if
implementors want numeric tags, let them be numeric...

Marj 

> -----Original Message-----
> From: Mark Bakke [mailto:[email-masked]]
> Sent: Wednesday, May 16, 2001 9:13 AM
> To: Kevin Gibbons
> Cc: IPS; Marjorie Krueger
> Subject: Re: iSCSI: Aggregation tags in SendTargets
> 
> 
> Kevin-
> 
> I think that a numeric tag would be simpler as you had said.
> Marjorie had asked for the alpha-numeric tag; anyone needing
> more than a numeric tag, please speak up.  I don't have any
> particular opinion either way.
> 
> If nobody requires alpha-numeric tags, I will change it to
> a simple numeric tag.  Otherwise, I'll update the examples.
> 
> So,
> 
>    ***    Anyone need Numeric Aggregation Tags    ***
> 
>                    Going once....
> 
> --
> Mark
> 
> Kevin Gibbons wrote:
> > 
> > Mark,
> >         in the proposed change to the NDT document, you 
> state that the
> > aggregation "tag" is an ASCII, alpha-numeric string.  I 
> read this to mean
> > the tag can be any string value.
> > 
> >         Could you make the aggregation tag be a numeric 
> string, indicating
> > an aggregation group?  This would align with your example, 
> and should make
> > it easier to quickly index portals into different groups.
> > 
> >         Regards, Kevin
> > 
> > -----Original Message-----
> > From: Mark Bakke [mailto:[email-masked]]
> > Sent: Tuesday, May 15, 2001 1:06 PM
> > To: IPS
> > Subject: iSCSI: Aggregation tags in SendTargets
> > 
> > During the interim meeting, we had discussed a proposal to
> > add an aggregation tag to the SendTargets response, indicating
> > which (if any) target addresses supported multiple connections
> > per session, and which groups of addresses an initiator could
> > hope to aggregate a session across.
> > 
> > Aggregation tags were generally well-received; a small modification
> > to the proposed method also allows an initiator to know whether
> > a single address supports multiple connections per session just
> > by itself.
> > 
> > Here is the section that would go into the NDT document.
> > 
> > --
> > 
> > (This would be added to section 4.2, right before the 
> vendor-specific
> > paragraph at the end):
> > 
> >   If an iSCSI target supports multiple connections per session,
> >   it must indicate this by including an aggregation tag after each
> >   address, in the form of
> > 
> >     TargetAddress=address,tag
> > 
> >   Where "tag" is an ASCII, alpha-numeric string indicating 
> an address
> >   group.  Within a single session, a connection may be 
> requested to any
> >   combination of TCP addresses that have the same tag.  If 
> an address
> >   supports multiple connections per session, but does not support
> >   spanning a session across other addresses, it will have its own
> >   tag.
> > 
> >   Here is an example:
> > 
> >     TargetName=fqn.com.acme.diskarray.sn.8675309
> >     TargetAddress=10.1.0.45:3000,1
> >     TargetAddress=10.1.1.46:3000,1
> >     TargetAddress=10.1.0.47:3000,2
> >     TargetAddress=10.1.1.48:3000,2
> >     TargetAddress=10.1.1.49:3000
> >     TargetAddress=10.1.1.50:3000,3
> >     TargetAlias=Oracle tables
> > 
> >   In this example, any of the target addresses can be used to reach
> >   the same target.  A single-connection session can be established
> >   to any of these TCP addresses.  A multiple-connection 
> session could span
> >   addresses .45 and .46, or .47 and .48, but cannot span any other
> >   combination.  A TargetAddress without a tag (.49) cannot 
> be combined
> >   with any other address within the same session.  A TargetAddress
> >   with a tag that is not shared with other addresses 
> supports multiple
> >   connections per session, but all connections must be to the same
> >   address.
> > 
> >   To make this work, there are a few rules to follow:
> > 
> >   A target that does not support spanning sessions across 
> multiple addresses
> >   MUST NOT include the tags.
> > 
> >   A target that is accessible via multiple TCP addresses 
> SHOULD include
> >   all TCP addresses in a SendTargets response.
> > 
> >   A target with multiple TCP addresses that supports a 
> session spanning
> >   multiple TCP addresses MUST indicate TCP address groups 
> using aggregation
> >   tages in a SendTargets response.
> > 
> >   Aggregation tags have no meaning or persistence beyond a 
> particular
> >   SendTargets response.
> > 
> > --
> > Mark A. Bakke
> > Cisco Systems
> > [email-masked]
> > 763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Wed, 16 May 2001 15:52:32 -0500

Marjorie-

You are right; I meant alpha-numeric.  Again, if nobody really
needs them, we can stick with numeric tags.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054