Subject: Re: Another shot at codes and please comment

From: [email-masked]
Date: Wed, 2 May 2001 10:53:49 +0300

Sandeep,

I think that we can leave the behaviour for unrecognized vendor-specific
codes to be also vendor-specific :-)

Julo

[email-masked] (Sandeep Joshi) on 01-05-2001 22:07:06

Please respond to [email-masked] (Sandeep Joshi)

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  Another shot at codes and please comment

Julian,

I'd prefer this over the alternating opcode assignments.
(where nop-out was 0 and nop-in was 1)

Could you also define the behaviour if a vendor-specific
opcode was not recognized ?

I presume we always want to drop the session, since these
opcodes would only be used if the target and initiator
recognized/negotiated (in a vendor-specific way) their
use during session initiation.

-Sandeep

> Here is a another version of the opcodes part:
>
> 1.1.1.1   Opcode
>
>    The Opcode indicates what type of iSCSI PDU the header encapsulates.
>
>    The Opcodes are divided into two categories: initiator opcodes and
>    target opcodes. Initiator opcodes are in PDUs sent by the initiators
>    (request PDUs), and target opcodes are in PDUs sent by the target
>    (response PDUs).
>
>    Initiators MUST NOT use target opcodes and targets MUST NOT use
>    initiator opcodes.
>
>    Valid initiator opcodes defined in this specification are:
>
>
>       0x00 NOP-Out (from initiator to target)
>       0x01 SCSI Command (encapsulates a SCSI Command Descriptor Block)
>       0x02 SCSI Task Management Command
>       0x03 Login Command
>       0x04 Text Command
>       0x05 SCSI Data-out (for WRITE operations)
>       0x06 Logout Command
>       0x10 SNACK Request
>
>    Valid target opcodes are:
>
>
>       0x20 NOP-In (from target to initiator)
>       0x21 SCSI Response (contains SCSI status and possibly sense
>       information or other response information)
>       0x22 SCSI Task Management Response
>       0x23 Login Response
>       0x24 Text Response
>       0x25 SCSI Data-in (for READ operations)
>       0x26 Logout Response
>       0x31 Ready To Transfer (R2T - sent by target to initiator when it
is
>       ready to receive data from initiator)
>       0x32 Asynchronous Message (sent by target to initiator to indicate
>       certain special conditions)
>       0x3f Reject
>
>    Initiator opcodes 0x1c-0x1e and target opcodes 0x3c-0x3e are vendor
>    specific codes.
>
>
>    Please comment,
>    Julo
>

---

From: "Matt Wakeley" <[email-masked]>
Date: Wed, 02 May 2001 11:03:25 -0400

*all* unrecognized opcodes should be rejected.  There should be no distinction
between a unrecognized vendor specific opcode and a unrecognized non-vendor
specific opcode.

-Matt