Subject: Another shot at codes and please comment

From: [email-masked]
Date: Tue, 1 May 2001 16:50:16 +0300

Here is a another version of the opcodes part:

1.1.1.1   Opcode

   The Opcode indicates what type of iSCSI PDU the header encapsulates.

   The Opcodes are divided into two categories: initiator opcodes and
   target opcodes. Initiator opcodes are in PDUs sent by the initiators
   (request PDUs), and target opcodes are in PDUs sent by the target
   (response PDUs).

   Initiators MUST NOT use target opcodes and targets MUST NOT use
   initiator opcodes.

   Valid initiator opcodes defined in this specification are:

      0x00 NOP-Out (from initiator to target)
      0x01 SCSI Command (encapsulates a SCSI Command Descriptor Block)
      0x02 SCSI Task Management Command
      0x03 Login Command
      0x04 Text Command
      0x05 SCSI Data-out (for WRITE operations)
      0x06 Logout Command
      0x10 SNACK Request

   Valid target opcodes are:

      0x20 NOP-In (from target to initiator)
      0x21 SCSI Response (contains SCSI status and possibly sense
      information or other response information)
      0x22 SCSI Task Management Response
      0x23 Login Response
      0x24 Text Response
      0x25 SCSI Data-in (for READ operations)
      0x26 Logout Response
      0x31 Ready To Transfer (R2T - sent by target to initiator when it is
      ready to receive data from initiator)
      0x32 Asynchronous Message (sent by target to initiator to indicate
      certain special conditions)
      0x3f Reject

   Initiator opcodes 0x1c-0x1e and target opcodes 0x3c-0x3e are vendor
   specific codes.

   Please comment,
   Julo

---

From: "Matt Wakeley" <[email-masked]>
Date: Wed, 02 May 2001 09:50:00 -0400

This looks ok.

-Matt