Subject: RE: iSCSI: Aggregation tags in SendTargets

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Wed, 16 May 2001 15:59:36 -0400

> John Hufferd wrote:
> > 
> > Mark,
> > You might want to modify your first rule, it does not take 
> into count the
> > condition where a single address can have more then one 
> connection to the
> > same session, but only to the same IP address.
> 
> >   To make this work, there are a few rules to follow:
> > 
> >   A target that does not support spanning sessions across multiple
> > addresses
> >   MUST NOT include the tags.
> 
> A target address that does not support multiple connections per
> session MUST NOT include an aggregation tag.
> 
> A target address that supports multiple connections per session
> MUST include an aggregation tag.

If a target only has one IP address, and supports multiple connections per
session thru that IP address, why would it have to include an aggregation
tag?  I thought an aggregation tag is ONLY to indicate that a single
session's connections may span IP addresses.  Are you trying to overload it
to indicate multi-connection session support? 

Marj

---

From: Mark Bakke <[email-masked]>
Date: Wed, 16 May 2001 15:57:11 -0500

Marjorie-

The request was made at the interim meeting to use a tag
to specify that multiple connections per session was supported.

That way, an initiator discovering a target via SendTargets
would know whether or not to bother attempting multiple
connections on the session.  So you are right; it has been
overloaded to do that.

Of course, if there were some sort of flag or text key in
the iSCSI login response to indicate the support of multiple-
connection sessions, we wouldn't need to do this.  I don't
think it's in there, though.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054