Subject: RE: iSCSI: Aggregation tags in SendTargets

From: "CONGDON,PAUL (HP-Roseville,ex1)" <[email-masked]>
Date: Tue, 15 May 2001 17:08:01 -0700

Yes, I think the first rule should be re-worded to say
something like the following:

   A tag MUST NOT be used with addresses that do not support
   sessions spanning multiple connections.

I also think a new rule should be added to clarify the case
John is talking about.  Perhaps the following:

   A target that supports a session spanning multiple connections,
   but only to the same address MUST use a unique tag.

Paul
 
+--------------------------+----------------------------+
+ Paul Congdon             + Email: [email-masked] +
+ Hewlett Packard Company  + Mail Stop:  5662           +
+ HP ProCurve Networking   + Phone:  (916) 785-5753     +
+ 8000 Foothills Blvd      + Fax:    (916) 785-5949     +
+ Roseville, CA   95747    + Mobile: (916) 765-4056     +
+--------------------------+----------------------------+

> 
> Mark,
> You might want to modify your first rule, it does not take 
> into count the
> condition where a single address can have more then one 
> connection to the
> same session, but only to the same IP address.
> 
> .
> .
> .
> John L. Hufferd
> Senior Technical Staff Member (STSM)
> IBM/SSG San Jose Ca
> (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
> Internet address: [email-masked]
> 
> 
> Mark Bakke <[email-masked]>@ece.cmu.edu on 05/15/2001 01:06:24 PM
> 
> Sent by:  [email-masked]
> 
> 
> To:   IPS <[email-masked]>
> cc:
> Subject:  iSCSI: Aggregation tags in SendTargets
> 
> 
> 
> 
> During the interim meeting, we had discussed a proposal to
> add an aggregation tag to the SendTargets response, indicating
> which (if any) target addresses supported multiple connections
> per session, and which groups of addresses an initiator could
> hope to aggregate a session across.
> 
> Aggregation tags were generally well-received; a small modification
> to the proposed method also allows an initiator to know whether
> a single address supports multiple connections per session just
> by itself.
> 
> Here is the section that would go into the NDT document.
> 
> --
> 
> (This would be added to section 4.2, right before the vendor-specific
> paragraph at the end):
> 
> 
>   If an iSCSI target supports multiple connections per session,
>   it must indicate this by including an aggregation tag after each
>   address, in the form of
> 
>     TargetAddress=address,tag
> 
>   Where "tag" is an ASCII, alpha-numeric string indicating an address
>   group.  Within a single session, a connection may be 
> requested to any
>   combination of TCP addresses that have the same tag.  If an address
>   supports multiple connections per session, but does not support
>   spanning a session across other addresses, it will have its own
>   tag.
> 
>   Here is an example:
> 
>     TargetName=fqn.com.acme.diskarray.sn.8675309
>     TargetAddress=10.1.0.45:3000,1
>     TargetAddress=10.1.1.46:3000,1
>     TargetAddress=10.1.0.47:3000,2
>     TargetAddress=10.1.1.48:3000,2
>     TargetAddress=10.1.1.49:3000
>     TargetAddress=10.1.1.50:3000,3
>     TargetAlias=Oracle tables
> 
>   In this example, any of the target addresses can be used to reach
>   the same target.  A single-connection session can be established
>   to any of these TCP addresses.  A multiple-connection 
> session could span
>   addresses .45 and .46, or .47 and .48, but cannot span any other
>   combination.  A TargetAddress without a tag (.49) cannot be combined
>   with any other address within the same session.  A TargetAddress
>   with a tag that is not shared with other addresses supports multiple
>   connections per session, but all connections must be to the same
>   address.
> 
>   To make this work, there are a few rules to follow:
> 
>   A target that does not support spanning sessions across multiple
> addresses
>   MUST NOT include the tags.
> 
>   A target that is accessible via multiple TCP addresses 
> SHOULD include
>   all TCP addresses in a SendTargets response.
> 
>   A target with multiple TCP addresses that supports a 
> session spanning
>   multiple TCP addresses MUST indicate TCP address groups 
> using aggregation
>   tages in a SendTargets response.
> 
>   Aggregation tags have no meaning or persistence beyond a particular
>   SendTargets response.
> 
> 
> 
> --
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054
> 
> 
>

---

From: Mark Bakke <[email-masked]>
Date: Wed, 16 May 2001 11:09:29 -0500

>    sessions spanning multiple connections.

Done.

>    but only to the same address MUST use a unique tag.

This is implied by the new rules I just sent, but I will add it
since it's more explicit.

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054