Subject: Target selection in a multi-target TCP connection

From: "Yoav" <[email-masked]>
Date: Wed, 27 Jun 2001 15:59:07 +0200

Hello David,

 I hope you will consider this question:
   If several targets use the same TCP connection (in a gateway
application), how is the target selected in
     the Login process. Is it through Text command (maybe mapping the ISID
to a target name)?

 Regards,
Yoav Flint
Systems Engineer
SANcastle
[email-masked]

---

From: [email-masked]
Date: Thu, 28 Jun 2001 00:21:30 -0400

Huh?  Login is to a single iSCSI target and
binds the TCP connection to that target.  The
target name is specified in the login command
(see description of TargetName text key), and
the implementation has to track the connection
binding as part of the state established by
the login.  If this isn't clearly specified
in -06, please let us know what text needs
to be clarified.

Now, if one iSCSI target corresponds to multiple
targets of some other sort (e.g., SCSI, FC)
behind the gateway, dealing with this is the
responsibility of the gateway implementer.
One possibility is to create an iSCSI target
per target behind the gateway, another might
be to do some sort of clever LUN mapping.

--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From:	Yoav [SMTP:[email-masked]]
> Sent:	Wednesday, June 27, 2001 9:59 AM
> To:	[email-masked]; [email-masked]
> Subject:	Target selection in a multi-target TCP connection
> 
> Hello David,
>

---

From: "Yoav" <[email-masked]>
Date: Thu, 28 Jun 2001 12:59:26 +0200

Thanks for the pointer and the reply.
My interpration was wrong, however it could be better if some of the Login
parameters which are a MUST (like TargetName text key?) would be mentioned
under section 2.10.9

  Yoav

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Thu, June 28, 2001 6:22 AM
To: [email-masked]; [email-masked]
Subject: RE: Target selection in a multi-target TCP connection

--David