Subject: iSCSI: UNH plugfest

From: "Rod Harrison" <[email-masked]>
Date: Thu, 28 Jun 2001 22:02:32 +0100

A couple of general questions regarding the upcoming iSCSI
plugfest at UNH.

	What was the final decision on who is allowed to attend?
Everyone or SNIA members only?

	Was there consensus on what op-codes to use after Julian's
suggestion to use v07 codes with the v06 spec?

	Is there a collated version of the v06 errata? There have
been quite a few changes as we move to v07, some of which
were bug fixes in v06, I remember some header stuff
specifically. It's probably a good idea to make sure
everyone at the plugfest starts out on the same version of
v06 if we can.

	Thanks,

	- Rod

---

From: "Dave Peterson" <[email-masked]>
Date: Thu, 28 Jun 2001 21:56:48 -0500

Some answers to your questions:

Anyone who has paid the appropriate fees and has a valid implementation is
allowed to attend this plugfest.

Below are the opcodes applicable for Rev 06+ testing at the UNH Plugfest:

Valid initiator opcodes are:
	0x00 NOP-Out (from initiator to target)
	0x01 SCSI Command (encapsulates a SCSI Command Descriptor Block)
	0x02 SCSI Task Management Command
	0x03 Login Command
	0x04 Text Command
	0x05 SCSI Data-out (for WRITE operations)
	0x06 Logout Command
	0x10 SNACK Request

Valid target opcodes are:

	0x20 NOP-In (from target to initiator)
	0x21 SCSI Response (contains SCSI status and possibly sense
		information or other response information)
	0x22 SCSI Task Management Response
	0x23 Login Response
	0x24 Text Response
	0x25 SCSI Data-in (for READ operations)
	0x26 Logout Response
	0x31 Ready To Transfer (R2T - sent by target to initiator when it
				is ready to receive data from initiator)
	0x32 Asynchronous Message (sent by target to initiator to indicate
                                     certain special conditions)
	0x3f Reject

Initiator opcodes 0x1c-0x1e and target opcodes 0x3c-0x3e are vendor specific
codes.

Rev 0.0 interoperability testing will be performed against the July 10, 2000
version of iSCSI (draft-satran-iscsi-01.txt) along with the SendTargets
command.

Not aware of any collated rev 06 errata at this time. I'll see if we can up
with something.

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Rod Harrison
Sent: Thursday, June 28, 2001 4:03 PM
To: [email-masked]
Cc: [email-masked]
Subject: iSCSI: UNH plugfest

	Thanks,

	- Rod

---

From: Gwendal Grignou <[email-masked]>
Date: Fri, 29 Jun 2001 12:27:42 -0700

> Below are the opcodes applicable for Rev 06+ testing at the UNH Plugfest:

Those opcodes are different from Rev6 and I didn't find any document defining
precisely Rev6+, just a bunch of mails.
Not having a precise Rev6+ iSCSI draft will not ease interoperabilty.
Why not stick to Rev6 draft published 04/19/2001 ?

Regards,

Gwendal.

---

From: "Dave Peterson" <[email-masked]>
Date: Fri, 29 Jun 2001 14:57:40 -0500

As previously announced by UNH they will be using the opcodes below.
Thus it would be a good idea for us to also use them.

Dave

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Gwendal Grignou
Sent: Friday, June 29, 2001 2:28 PM
To: Dave Peterson
Cc: [email-masked]
Subject: Re: iSCSI: UNH plugfest

> Below are the opcodes applicable for Rev 06+ testing at the UNH Plugfest:

Those opcodes are different from Rev6 and I didn't find any document
defining
precisely Rev6+, just a bunch of mails.
Not having a precise Rev6+ iSCSI draft will not ease interoperabilty.
Why not stick to Rev6 draft published 04/19/2001 ?

Regards,

Gwendal.