Subject: Re: iSCSI: More draft-06 comments

From: "Matt Wakeley" <[email-masked]>
Date: Tue, 05 Jun 2001 18:18:24 -0700

[email-masked] wrote:

> ++++ although this text has no ambiguity there is still a raging debate
> between the proponents of an always explicit response (Matt and - in some
> covoluted form Steph - and those like Steve Senum who whould like a hiatus
> signaling a default.  The current text let you set none by default.  This
> can be changed by removing the "  and MAY be selected by omission... "  +++

I would like the "and MAY be selected by omission..." removed.

> 2.1 - Need to say that padding is not included in the
> length field.  Should also specify a MUST for the pad byte value.
>
> +++  the PDU outline in 2.2 is clear enough.

It's obviously not clear enough - you wrote it so you understand it.  You want
to make it clear to someone just picking up the spec.

>  The negative specification
> (does not include like)
> is unbounded.

I have no idea what the above means.

> +++ I have a tool problem here ... and was unable to fix it up to now
> (Word!) +++

use a real tool, not a toy! :)

-Matt

---

From: Steve Senum <[email-masked]>
Date: Wed, 06 Jun 2001 17:58:27 -0500

> I would like the "and MAY be selected by omission..." removed.

If the "NotUnderstood" response exists, I would also like to see
the option of not sending a response of key:none removed.

Steve Senum