Subject: Re: profiles - a way to simplify iSCSI

From: [email-masked]
Date: Fri, 22 Jun 2001 09:52:39 +0300

Sandeep,

Yes. Profiles will be all or nothing and the what is mandated in every
profile will appear in the draft and what is not mandated at a profile will
never be used (can as well not be there).

A simple two profile scheme can be built using as a profile 0 whatever is
today mandatory
(or defaulted to yes or equivalent) and as profile one everything else.

Regards,
Julo

Sandeep Joshi <[email-masked]> on 21-06-2001 21:19:21

Please respond to Sandeep Joshi <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  Re: profiles - a way to simplify iSCSI

Hmm..this is somewhat tempting.

 The parameters seem to fall into 2-3 clusters
(1)  initialR2T, maxR2T, immediate data, firstburst, pdulength, etc
(2)  the marker related keys
(3)  names, aliases, bootsession, maxconnections, loginlogout min-max.

It would be nice if a "profile" could simplify these dependencies.

Under this proposed setup, I presume the target & initiator would first
send a profile-name which would initialize the appropriate parameters
in the set.  If a vendor is unsure of a particular profile, support
for it would not be advertised.  Once a profile is decided, only
numeric keys would be negotiated.

Could you elaborate further on your proposal ?

-Sandeep

[email-masked] wrote:
>
> Dear colleagues,
>
> iSCSI keeps getting richer in negotiable parameters/features.
> Although flexibility is a great thing every new negotiable
> parameter/feature get us all worrying about:
>
>    what it will break when used in combination with other
>    parameters/features
>    how are we going to test that all our combinations work as we think
that
>    they are specified
>    are we understanding/specifying the combinations the same way as
anybody
>    else
>
> I assume that many of you are wondering, as I do, if all this flexibility
> is really worth it's price.
> Would the community not be better served by specifying profiles that are
a
> complete-and-invariable combination of features and very small set of
> numerical parameters?
>
> I would start with 2 profiles:
>
>    the minimal profile (only basic features)
>    the maximum profile (all the features)
>
> and then (only if we are strongly convinced it is needed) add a middle
> point.
>
> Please comment,
> Julo

---

From: "Matt Wakeley" <[email-masked]>
Date: Fri, 22 Jun 2001 16:35:40 -0700

Why have two profiles?  Just like in fibre channel, have one profile that
describes the parameters to be used to be interoperable with other devices
(would be your profile 0).  The other profile is simply the iSCSI spec, where
everything is open and negotiable.

-Matt