Subject: RE: profiles - a way to simplify iSCSI

From: [email-masked]
Date: Fri, 22 Jun 2001 10:13:49 +0300

Somesh,

I am saying (loud and clear) PROFILES WILL ELIMINATE negotiation (except
some numeric values).

Regards,
Julo

"Somesh Gupta" <[email-masked]> on 21-06-2001 21:59:09

Please respond to [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject:  RE: profiles - a way to simplify iSCSI

I think this is indicative of the complexity we have in
the standard. The first order of preference should be
to reduce the complexity.

Secondly, given the confusing decision process in the
IETF, it is not certain whether we would meet the following
two goals that I would have

1. Speedy process.
2. A large community of vendors and customers agreeing on
an ideal profile that would be implemented widely.
(of course, that means that everything else in the spec
would be relegated to the position where 5 yrs from now
only few will be able to explain why it is in the spec)

Otherwise profiles are just going to add another dimension
to negotiate without providing much benefit. Unless you
say that profiles completely eliminate parameter negotiation
(then it does add a lot of value).

Somesh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Thursday, June 21, 2001 10:15 AM
> To: [email-masked]
> Subject: profiles - a way to simplify iSCSI
>
>
>
>
> Dear colleagues,
>
> iSCSI keeps getting richer in negotiable parameters/features.
> Although flexibility is a great thing every new negotiable
> parameter/feature get us all worrying about:
>
>    what it will break when used in combination with other
>    parameters/features
>    how are we going to test that all our combinations work as we
> think that
>    they are specified
>    are we understanding/specifying the combinations the same way
> as anybody
>    else
>
>
> I assume that many of you are wondering, as I do, if all this flexibility
> is really worth it's price.
> Would the community not be better served by specifying profiles that are
a
> complete-and-invariable combination of features and very small set of
> numerical parameters?
>
> I would start with 2 profiles:
>
>    the minimal profile (only basic features)
>    the maximum profile (all the features)
>
> and then (only if we are strongly convinced it is needed) add a middle
> point.
>
> Please comment,
> Julo
>

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---

From: "Somesh Gupta" <[email-masked]>
Date: Fri, 22 Jun 2001 18:59:09 -0700

and without shouting at you :-) but to repeat myself,
let us just come up with one reasonable "profile" i.e.
RFC and then we can defer all other features till the
next rev when we know what the shortcomings, if any,
may be.

Regards,
Somesh
> Sent: Friday, June 22, 2001 12:14 AM
> To: [email-masked]