Subject: Re: Questions about FCIP

From: "Jon William Toigo" <[email-masked]>
Date: Wed, 13 Jun 2001 19:25:46 -0400

Apologies to David and all if my questions moved outside appropriate
boundaries for the group.  It was not my intention to encourage food fights
or other forms of disorder.

JWT
"Just Call Me A Troublemaker"
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 13, 2001 7:21 PM
Subject: RE: Questions about FCIP

> Note that the purpose of this list is discussion of specification
> and standardization issues surrounding IP Storage protocols.  Some
> of Jon's questions should be discussed in some forum other than this
> list.
>
> > 1.  Where does the FCIP protocol spec stand at present?  Has it been
moved
> up the food chain for ratification?
> > If not, is there any thinking on when this will happen?
>
> It's an Internet-Draft.  The IPS WG charter currently has a goal of
> September for completion.  This may change
> as the WG charter is revised over the summer.
>
> > 2.  Are there any reasons or situations in which FCIP might be
considered
> preferable to iFCP?  What are
> > its strengths?
>
> We've already had one food fight on this topic on the list - let's not do
> that again.  Those with opinions
> or comments on this should send them directly to Jon - please DO NOT reply
> to or discuss this on the list.
>
> > 3.  How is FC SAN node addressing handled in a multi-"island" SAN
> interconnected by FCIP links?
>
> An FCIP link looks like an inter-switch link as far as Fibre Channel is
> concerned, so addressing works
> in the same fashion as if everything were Fibre Channel.
>
> > 4.  How are IP performance problems handled in FCIP?  Is radical
> reconstruction required each time an
> > IP network-related interruption occurs?
>
> FCIP runs over TCP.  If all the TCP connections for a link close, the
> inter-switch link is down and FC takes
> whatever action is appropriate.  How radical that would be depends on the
> topology at the FC level.
>
> > 5.  Where will the heavy lifting of FCIP (the encapsulation of the data
> for transmission through the tunnel) be
> > implemented?  On the FC switch blade? on an IP switch or router blade?
On
> some third party device?  Are
> > their different implementations?  Any benefits or drawbacks of each?
>
> This one is at best borderline for discussion on this list, especially if
> it turns into a "beauty contest" over who has the best implementation
> approach/architecture.  Please send any replies/comments directly to Jon
> and DO NOT reply or discuss this on the list.
>
> Thanks,
> --David
>
> ---------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 42 South St., Hopkinton, MA  01748
> +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> [email-masked]       Mobile: +1 (978) 394-7754
> ---------------------------------------------------
>

---

From: [email-masked]
Date: Wed, 13 Jun 2001 19:21:36 -0400

> 1.  Where does the FCIP protocol spec stand at present?  Has it been moved

> 2.  Are there any reasons or situations in which FCIP might be considered

> implemented?  On the FC switch blade? on an IP switch or router blade?  On

Thanks,
--David