Subject: Re: iSCSI: Indication of final data-out sequence

From: [email-masked]
Date: Thu, 5 Jul 2001 08:46:41 +0300

the F bit. Julo

Rishabh Srivastav <[email-masked]> on 04-07-2001 18:59:32

Please respond to Rishabh Srivastav <[email-masked]>

To:   [email-masked]
cc:
Subject:  iSCSI: Indication of final data-out sequence

A doubt regarding the final sequence of data-out PDUs
: My apologies if this had already been discussed long
time ago. Couldn't locate it in the huge mail
repository.
In FC, the last sequence of an exchange is indicated
by a 'Last_Sequence' bit in F_CTL of FC-FS header.
What is the equivalent of it in iSCSI, specifically in
the case of Data-Out ? If there is none, will not the
presence of a similar bit be useful for iSCSI-FCP
gateways ?

Thanks,
Rishabh

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: Rishabh Srivastav <[email-masked]>
Date: Thu, 5 Jul 2001 02:18:47 -0700 (PDT)

Julo,
I'm still not convinced.
There can be multiple data-out PDU's in response to
one R2T. In this case the F bit indicates the end of
sequence corresponding to that particular R2T and not
for the whole write operation. However, the
last_sequence bit in FC-FS is something which
indicates the final data IU for that whole exchange.
So, how can 'F' bit be equated to the last_sequence
bit ?? The semantics of 'F' bit is same as
last_sequence bit in the case of Data-In PDUs and not
in the case of data-out PDU. 
Where am i going wrong in my assumptions ?
Please clarify.
Thanks,
Rishabh