Subject: iSCSI Check Condition

From: Mike Donohoe <[email-masked]>
Date: Fri, 13 Jul 2001 09:54:23 -0700

Based on the iSCSI 06 spec what is the proper way to handle a check
condition when the Initiator is not expecting Input (R=0)?

	For instance if an initiator sends a SCSI Command CBD=="Rewind" with
the R bit set to 0 and there no media in the drive.  Then the Target sends a
SCSI Response with S=1 and CHECK CONDITION in the Status Field.  Then it
seems the target should put the sense data at the end of the message, but
the Initiator is not expecting any Input.

	Please clarify my fuzzy understanding.

Thank you.

Mike Donohoe
Quantum | ATL

---

From: [email-masked]
Date: Fri, 13 Jul 2001 15:09:28 -0400

The short answer is "Autosense is REQUIRED", see
section 2.4.5 of -06.  If CHECK CONDITION comes
back, the Initiator MUST look for the sense data
even if the Initiator doesn't expect any response
data from a successful command execution, and hence
the Target sends the sense data back with the
response.

--David

> -----Original Message-----
> From:	Mike Donohoe [SMTP:[email-masked]]
> Sent:	Friday, July 13, 2001 12:54 PM
> To:	[email-masked]'
> Subject:	iSCSI Check Condition
> 
>

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 14 Jul 2001 09:30:11 +0300

How is that initiator is not expecting status?  Any SCSI command (including
rewind) ends with status.

Julo

Mike Donohoe <[email-masked]> on 13-07-2001 19:54:23

Please respond to Mike Donohoe <[email-masked]>

To:   "[email-masked]'" <[email-masked]>
cc:
Subject:  iSCSI Check Condition

the R bit set to 0 and there no media in the drive.  Then the Target sends
a

Thank you.

Mike Donohoe
Quantum | ATL