Subject: iSCSI version number

From: "Robert D. Russell" <[email-masked]>
Date: Tue, 3 Jul 2001 15:06:00 -0400

Julian:

The 06-91 draft section 2.10.4 on page 57 lists the version number
of the current draft as 0x2, whereas previously it was always 0x1.
Shouldn't it still be 0x1??  After all, there has been no
approved version 0x1, and the 06-91 draft is only a small
incremental improvement over the 06 draft, not a major revision.
Changing to version 0x2 implies a consensus on what 0x1 was,
and there is none (was it the 06 draft, the 06 draft updated
by some (all) of the mailing list e-mails that followed, or what?)
What exactly would it mean to support version 0x1 when the current
(still under revision draft) is 0x2 and there is no consensus on
what version 0x1 was?  And what criteria will you use to decide
when a version number changes and when it doesn't?

I believe these drafts should remain version 0x1 until the "final"
draft in this sequence is approved by IETF.  Otherwise, you will
end up will a bunch of meaningless version numbers that will
be impossible to track.

Bob Russell
InterOperability Lab
University of New Hampshire
[email-masked]
603-862-3774

---

From: "Elliott, Robert" <[email-masked]>
Date: Thu, 5 Jul 2001 10:34:03 -0500

The UNH plugfest is testing implementations based version 0 or version 6.
These are conveniently differentiated by using version code 0x00 for version
0 and 0x01 for version 6.  Implementations based on versions 1-5 are
discouraged by the plugfest choice.  Since there will exist numerous version
6 implementations, I think it's advantageous for the iSCSI version number to
increment from this point forward to differentiate them from newer
implementations.

Unfortunately, UNH created a bit of a mess by asking that version 7 opcode
encoding be used with the version 6 implementations without incrementing the
version number.  I expect that to create some confusion (easily solved by a
recompile, I hope).
---
Rob Elliott, Compaq Server Storage
[email-masked]

> -----Original Message-----
> From: Ayman Ghanem [mailto:[email-masked]]
> Sent: Thursday, July 05, 2001 1:40 AM
> To: [email-masked]
> Subject: RE: iSCSI version number
> 
> 
> I am not sure that increasing the version number in draft-07 
> will provide
> this protection. I believe drafts 3 through 6 had the same 
> version number
> (0x01) but they don't interoperate. On the other hand, drafts 
> 6 and 7 will
> have different version numbers and they very much 
> interoperate. I prefer
> keeping the version number at 0x01 until the final draft.
> 
> -Ayman
> 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Eddy Quicksall
> > Sent: Wednesday, July 04, 2001 2:52 PM
> > To: [email-masked]; [email-masked]
> > Cc: Tri.G[[email-masked]]
> > Subject: Re: iSCSI version number
> >
> >
> > I have mixed emotions ... I agree with Bob in principal.
> >
> > But, I figured the reason you changed it was actually to 
> distinguish from
> > rev 0 ... as I understand it, Intel has already released code
> > that conforms
> > to rev 0 (but Intel should respond to this).
> >
> > If we don't increase the version, how do we protect 
> ourselves from running
> > into one of the Intel controllers?
> >
> > Eddy
> >
> > ----- Original Message -----
> > From: <[email-masked]>
> > To: <[email-masked]>
> > Sent: Wednesday, July 04, 2001 1:13 AM
> > Subject: Re: iSCSI version number
> >
> >
> > >
> > >
> > > Robert,
> > >
> > > You have a good point - and for this reason  I intended 
> to keep the
> > version
> > > number to 01 up to the RFC date.
> > > But several folks on the list tought that we are too far from
> > 01 (one even
> > > suggested that we number according to the draft number).
> > >
> > > I would like to hear some more voices.
> > >
> > > Julo
> > >
> > > "Robert D. Russell" <[email-masked]> on 03-07-2001 22:06:00
> > >
> > > Please respond to "Robert D. Russell" <[email-masked]>
> > >
> > > To:   Julian Satran/Haifa/IBM@IBMIL
> > > cc:   [email-masked]
> > > Subject:  iSCSI version number
> > >
> > >
> > >
> > >
> > > Julian:
> > >

---

From: "Lawrence J. Lamers" <[email-masked]>
Date: Fri, 06 Jul 2001 08:09:06 -0700

If we need intermediate versions we should clone an approach similar to 
what Gene Milligan put in the SCSI Block Devices command set.  This 
intermediate versions will continue to be an issue, Gene recognized that 
many folks implement before there is an 'official' standard and that we 
need to deal with it.

> > > > University of New Hampshire

Regards,

==========================================
Lawrence J. Lamers
email:  [email-masked]
Cell Phone:  (408) 234-0071
Home Phone:  (408) 578-1709