Subject: RE: Unsupported target LUN

From: David Lee <[email-masked]>
Date: Fri, 27 Jul 2001 17:13:12 -0700

Rick,

I would prefer not to see an iSCSI response at all, but rather a SCSI Check
Condition status with appropriate Sense Data.

David Lee
Vicom Systems, Inc.
47821 Bayside Parkway
Fremont, CA  94538
Phone: (510) 743-1162
Fax: (510) 743-1131
Email: [email-masked]

-----Original Message-----
From: Rick Ellis [mailto:[email-masked]]
Sent: Friday, July 27, 2001 4:13 PM
To: [email-masked]
Subject: Unsupported target LUN 

What response code should be sent from the target for a LUN
that isn't valid?  Would "target failure" suffice?

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 27 Jul 2001 19:19:01 PDT

Shawn is right.  So to answer Rick's original question,
the SCSI Status for illegal LUN CHECK CONDITION should be 
qualified by the iSCSI response code of "0x00" - "Command 
Completed at Target".
--
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

>From: "ERICKSON,SHAWN (HP-Roseville,ex1)" <[email-masked]>
>To: "'David Lee'" <[email-masked]>, "'Rick Ellis'" <[email-masked]>,
>        [email-masked]
>Subject: RE: Unsupported target LUN 
>Date: Fri, 27 Jul 2001 18:39:46 -0700
>MIME-Version: 1.0
>X-Mailer: Internet Mail Service (5.5.2653.19)
>Content-Type: text/plain;
>	charset="iso-8859-1"
>Sender: [email-masked]
>Precedence: bulk
>Status: RO
>
>The way things are currently defined for iSCSI (as most other SCSI
>"transports") it doesn't really care about LUNs. iSCSI has fields to
>transport the information regarding LUNs that matches with the SCSI protocol
>but that is about where it ends.
>
>LUN handling is up the SCSI protocol.
>
>One could argue to have LUN discovery lifted up to iSCSI for "easy of use"
>but I think the line should be drawn at that.
>
>-Shawn
>
>-------------------------------------------------------
> Shawn Carl Erickson           (805) 883-4319 [Telnet]
> Hewlett Packard Company         OV NSSO Joint Venture
>  Storage Resource Management R&D Lab (Santa Barbara)
>-------------------------------------------------------
>            <http://ecardfile.com/id/shawnce>
>-------------------------------------------------------
>
>
>
>> From: David Lee [mailto:[email-masked]]
>> Sent: Friday, July 27, 2001 5:13 PM
>> To: 'Rick Ellis'; [email-masked]
>> Subject: RE: Unsupported target LUN 
>> 
>> 
>> Rick,
>>

---

From: "ERICKSON,SHAWN (HP-Roseville,ex1)" <[email-masked]>
Date: Fri, 27 Jul 2001 18:39:46 -0700

-Shawn