Subject: Re: iSCSI version number

From: [email-masked]
Date: Wed, 4 Jul 2001 08:13:15 +0300

Robert,

You have a good point - and for this reason  I intended to keep the version
number to 01 up to the RFC date.
But several folks on the list tought that we are too far from 01 (one even
suggested that we number according to the draft number).

I would like to hear some more voices.

Julo

"Robert D. Russell" <[email-masked]> on 03-07-2001 22:06:00

Please respond to "Robert D. Russell" <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  iSCSI version number

Julian:

The 06-91 draft section 2.10.4 on page 57 lists the version number
of the current draft as 0x2, whereas previously it was always 0x1.
Shouldn't it still be 0x1??  After all, there has been no
approved version 0x1, and the 06-91 draft is only a small
incremental improvement over the 06 draft, not a major revision.
Changing to version 0x2 implies a consensus on what 0x1 was,
and there is none (was it the 06 draft, the 06 draft updated
by some (all) of the mailing list e-mails that followed, or what?)
What exactly would it mean to support version 0x1 when the current
(still under revision draft) is 0x2 and there is no consensus on
what version 0x1 was?  And what criteria will you use to decide
when a version number changes and when it doesn't?

I believe these drafts should remain version 0x1 until the "final"
draft in this sequence is approved by IETF.  Otherwise, you will
end up will a bunch of meaningless version numbers that will
be impossible to track.

Bob Russell
InterOperability Lab
University of New Hampshire
[email-masked]
603-862-3774

---

From: "Eddy Quicksall" <[email-masked]>
Date: Wed, 4 Jul 2001 15:52:13 -0400

I have mixed emotions ... I agree with Bob in principal.

But, I figured the reason you changed it was actually to distinguish from
rev 0 ... as I understand it, Intel has already released code that conforms
to rev 0 (but Intel should respond to this).

If we don't increase the version, how do we protect ourselves from running
into one of the Intel controllers?

Eddy

---

From: "Ayman Ghanem" <[email-masked]>
Date: Thu, 5 Jul 2001 01:39:33 -0500

I am not sure that increasing the version number in draft-07 will provide
this protection. I believe drafts 3 through 6 had the same version number
(0x01) but they don't interoperate. On the other hand, drafts 6 and 7 will
have different version numbers and they very much interoperate. I prefer
keeping the version number at 0x01 until the final draft.

-Ayman

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Eddy Quicksall
> Sent: Wednesday, July 04, 2001 2:52 PM
> To: [email-masked]; [email-masked]
> Cc: Tri.G[[email-masked]]