Subject: Re: iSCSI: Case-sensitivity in iSCSI names

From: Mark Bakke <[email-masked]>
Date: Thu, 26 Jul 2001 08:35:02 -0500

John Hufferd wrote:
> 
> Glen,
> Perhaps I have this wrong, but I think what we are talking about is a Name
> that gets Generated via some sort of Management Tool.  Then the iSCSI
> Initiator, or the iSCSI Target saves the string that the Management or
> Discovery process gives to them.

Correct.
 
> This String is then suppose to be able to be use in simple comparisons.
> That is it is the TargetID or InitiatorID, may save the string to be used
> during negations.

I think you meant negotiations (finger ck :-)).

> If the manufacture assigns the name, it will also be inserted into the unit
> via some kind of interactive Tool.
> 
> I do not understand why the Target or Initiator needs to have the purifying
> function called "NAMEPREP".  This function should be done on the
> interactive Tool/Management routine, on which the Administrator, (or
> Manufacture) uses to enter the name.

And most of the time, the name is automatically generated, and not
entered by a human at all, so not even all management routines will
need NAMEPREP.

> So I can not see that this causes us any significant problems, and it helps
> the Admin ease of use, and a help in reducing finger ck errors.
> 
> Please set me straight if I have this wrong.
> 
> .
> John L. Hufferd
> Senior Technical Staff Member (STSM)
> IBM/SSG San Jose Ca
> Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
> Home Office (408) 997-6136
> Internet address: [email-masked]
> 
> Glen Turner <[email-masked]>@ece.cmu.edu on 07/25/2001 01:03:40
> AM
> 
> Sent by:  [email-masked]
> 
> To:   John Hufferd/San Jose/IBM@IBMUS
> cc:   IPS <[email-masked]>
> Subject:  Re: iSCSI: Case-sensitivity in iSCSI names
> 
> John Hufferd wrote:
> >
> > I want to jump on this bandwagon too.  This seems to be exactly the right
> > approach.
> 
> I'm showing some caution.
> 
> It seems that NAMEPREP still requires casing tables.  Where
> and how are these maintained?
> 
> Does the proposal lead to language-based variants of
> iSCSI products.  At the moment I can safely buy a
> hard disk drive from the USA and use it anywhere in
> the world: IDE, FC or SCSI.  That should be so for
> iSCSI.
> 
> Mark wrote:
> > Anyway, if this is to be used for domain names, we ought to use it,
> > too.
> 
> Except that no-one is suggesting embedding DNS in a platform
> that won't be maintained after sale.
> 
> Before support one way or the other I'd like to be
> clearer about the boundaries of iSCSI naming.
> 
> Regards,
> Glen
> 
> --
>  Glen Turner                                 Network Engineer
>  (08) 8303 3936      Australian Academic and Research Network
>  [email-masked]          http://www.aarnet.edu.au/
> --
>  The revolution will not be televised, it will be digitised

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "John Hufferd" <[email-masked]>
Date: Thu, 26 Jul 2001 00:35:02 -0700

Glen,

.
John L. Hufferd

Regards,
Glen