Subject: iSCSI: Discovery Sessions

From: Mark Bakke <[email-masked]>
Date: Tue, 17 Jul 2001 15:36:00 -0500

Given the discussions on how to define discovery sessions
for SendTargets, whether to call the thing that is logged in
to a canonical, default, or well-known targets, as well as the
discussions about other uses for a well-known target, we have
what looks like a simper solution.

Julian had suggested that we simply provide a text key at
login that says

   DiscoverySession=yes

to indicate that the session was to be used for SendTargets;
no TargetName would need to be specified at all for the session.

Since this was analogous to other "special" sessions, such as
boot and copy manager sessions, we further combined these
separate booleans into a SessionType.

This means that rather than specifying the target "iscsi" in
the login request, the initiator would instead specify:

   SessionType=Discovery

That's it.  The session has not been established to any particular
target (it doesn't need one), the session type is as a discovery
session, and the target can properly restrict the operations on
the session to SendTargets.

Anyway, this is a very minor change, but is a lot simpler to
describe than the way we were doing it.

It also leaves the use of the default target "iscsi" for other
purposes.

Here's the definition of SessionType, from -97:

     32 SessionType  
         
        Use: LO 
        Who can send: Initiator 
         
        SessionType= <Boot|CopyManager|Discovery|Normal> 

        Default is Normal. 
         
        The Initiator indicates the type of session it wants to create.  The 
        target can accept or reject it. 
         
        A Boot Session indicates to the Target that the only purpose of this 
        Session is boot.  The target MAY restrict the type of iSCSI requests 
        it accepts in such a Session to Logout, NOP-out, and SCSI read 
        commands.  Accepting other commands in this type of session is 
        vendor-dependent.  A target MAY reject a boot-session. 
         
        A CopyManager session MAY indicates to the Target that the only 
        purpose of this Session is a Copy Manager Function.  The target MAY 
        restrict the type of SCSI requests it accepts in such a Session.  A 
        target MAY reject a copy manager session. 
         
        A Discovery session indicates to the Target that the only purpose of 
        this Session is discovery.  The only command accepted by a target in 
        this type of session is a text command with a SendTargets key 

The above description replaces the CopyManagerSession, BootSession, and
DiscoverySession keys.

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Stephen Bailey <[email-masked]>
Date: Tue, 17 Jul 2001 17:54:03 -0400

> Julian had suggested that we simply provide a text key at

Amen.

Steph