Subject: iSCSI state transitions question [was: new iSCSI draft 07.txt]

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 20 Jul 2001 20:00:33 -0700

Sanjay,

You are right to the extent that S1 and S13 are similar
since neither has a valid associated transport connection,
but they differ in if active iSCSI tasks could possibly be 
associated with the state.  S1 can not have any unfinished 
tasks, while S13 may.
To quote 6.1 -
        The BUSY state (S13) implies that there are possibly 
        iSCSI tasks that have not reached conclusion and are 
        still considered busy.

S13 is reached either through S19-* transitions, or S20-* 
transitions, both of which happen without a clean iSCSI Logout
hence the possibility of unfinished iSCSI tasks.

To quote 6.1 again -
        Whenever a connection state machine (say, CSM-R) enters 
        the BUSY state (S13), it must go through the state transitions
        additionally described in the connection recovery state 
        diagram.

The above is to eventually get to S1.

Please review the pdf file I posted to this list as well 
which additionally contains a graphical representation of standard 
connection state diagram.

Regards.
-- 
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard Roseville
[email-masked]

Sanjay Goyal wrote:
> 
> Hi
>  It is regarding Rev7.0,
>    6.1 Standard connection state diagram
> 
>   The transition condition from S12 to S13 seems illogical to me. After both
> sides close the connection, should not the state be S1.
>   to me either the condition T18 is not correct or the transition to S13 is
> not correct.
>  Please clarify the issue.
> 
> Regards
> Sanjay Goyal
> 
> 
> -----Original Message-----
> From: Julian Satran [mailto:[email-masked]]
> Sent: Friday, July 20, 2001 4:38 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: new iSCSI draft 07.txt
> 
> On  behalf of a group of authors from several organizations as part of the
> IPS working group  I submit a revision of an IETF-draft for immediate
> publication. It specifies iSCSI - a SCSI Over TCP protocol and the file
> name is "draft-ietf-ips-iSCSI-07.txt".  It completely replaces
> "draft-ietf-ips-iSCSI-06.txt".
> 
> The draft can be found at:
> 
> http://www.haifa.il.ibm.com/satran/ips/draft-ietf-ips-iSCSI-07.txt
> 
> Julian Satran - IBM Research Laboratory at Haifa

---

From: "Mallikarjun C." <[email-masked]>
Date: Sat, 21 Jul 2001 17:27:34 PDT

Sorry, the sentence below:

>S13 is reached either through S19-* transitions, or S20-*....

should have read:

S13 is reached either through T19-* transitions, or T20-*....

BTW, the iSCSI state diagrams pdf file is now posted on Julian's
website.
--
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]