Subject: RE: iSCSI Naming: iqn format specification

From: [email-masked]
Date: Mon, 16 Jul 2001 17:24:00 -0400

That would work - REQUIRE the enterprise
number and possibly  RECOMMEND that it be
followed by the reverse DNS name for
human-friendliness.  --David

> -----Original Message-----
> From:	Mark Bakke [SMTP:[email-masked]]
> Sent:	Monday, July 16, 2001 4:28 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	Re: iSCSI Naming: iqn format specification
> 
> So, should we require the enterprise number?  It's a whole
> lot cheaper than getting an OUI.
> 
> [email-masked] wrote:
> > 
> > A couple of comments on this:
> > 
> > > Anyone wanting to ensure that their names
> > > will never conflict with someone else's can add the enterprise number.
> > 
> > Nice try, but not good enough.  If this course is followed the
> > enterprise number has to be REQUIRED independent of the whims
> > of those who are creating the names so that this conflict can't
> > happen, period.
> > 
> > > > Finally, we should use the URI name and format for the namespace
> > > > where a URI format exists.  This is simply for consistency.
> > > >
> > > > For example:
> > > >    backwardsdns:au.edu.example.faculty
> > > >    oid:1.32.43.5.3.2.43.2.2.34
> > > >    oui:2e319c65786e
> > >
> > > I had suggested this before, in my draft on iSCSI URNs; the IESG
> > > completely shot this down, and I'm still not sure why.  Anyway,
> > > I don't have the energy to push the URN/URI thing any further.
> > 
> > What the IESG shot down was the notion of WWUI as a new URN
> > namespace into which other namespaces could be glued.  Anyone
> > whose reaction to this is "but it's functionally equivalent", has missed
> > the point, and should be thankful that they don't spend all their time
> > on naming issues ;-).  The issues here are syntax, intent, and
> > control; the IESG is not prepared to allow the IPS WG to define
> > a new global namespace into which the IPS WG could decide
> > to glue in other namespaces at its discretion.  AFAIK, the IESG
> > would be interested in things like an OUI URN definition (anyone
> > want to write a draft? - it should be good for at least 15 minutes of
> > fame).
> > 
> > --David
> > 
> > ---------------------------------------------------
> > David L. Black, Senior Technologist
> > EMC Corporation, 42 South St., Hopkinton, MA  01748
> > +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> > [email-masked]       Mobile: +1 (978) 394-7754
> > ---------------------------------------------------
> 
> -- 
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Tue, 17 Jul 2001 15:08:17 -0500

Works for me.  Anyone wanting to do their own naming schemes would
fall into three categories:

1. iSCSI hardware and software manufacturers

   Most iSCSI names would be generated by these folks; they would
   make them up either statically (based on a chassis number or
   something) or dynamically (based on user configuration, but not
   explicitly configured by the user), or a combination of the two.

   These have their own enterprise # anyway.

2. Service-minded end-users that want control over naming.

   These are sophisticated enough to want an enterprise number; I
   anticipate that only folks such as SSPs would want to do this
   sort of thing; most will leave the manufacturer-assigned names
   along.

3. Researchers building iSCSI experimental stuff

   These would not be concerned with being "iSCSI-compliant"; they
   would simply want to be reasonably sure that they won't conflict
   with other equipment in a lab environment.  These folks could just
   use enterprise # 0, along with their reversed domain name, and be
   reasonably assured of this. 

We don't have to mention #3 in the spec, if that's a problem, since
this decision of iSCSI-compliance would be up to the implementor

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Wed, 18 Jul 2001 15:31:20 -0500

To get the draft out, I am going to require the enterprise number.

A second possibility exists; the reversed DNS name could be qualified
by the date on which the iSCSI name was generated.  Since two entities
cannot own the same DNS name at the same time, the separate naming
authorities would not generate these using the same dates.

Anyone want dates instead of enterprise numbers?

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054