Subject: RE: iSCSI Framing Formats

From: "WENDT,JIM (HP-Roseville,ex1)" <[email-masked]>
Date: Mon, 9 Jul 2001 16:27:20 -0700

> From: Trang Nguyen [mailto:[email-masked]]
> 
....
> I am just wondering if any method of iSCSI framing has been 
> finalized yet?
> What is the status of this issue?  Will the next version of 
> iSCSI I-D have
> more information about it?
> 

Trang,
The Framing and Error Recovery design teams met recently to discuss the
framing issue and possible solutions. We should be posting a summary of the
outcomes from this meeting within the next few days for IPS discussion.

> Thank you in advance for your reply,
> 
> 
> Trang Nguyen
>
Regards, 
Jim Wendt
Networked Storage Architecture / NSSO
Hewlett-Packard Company
[email-masked] 916-785-5198

---

From: "Julian Satran" <[email-masked]>
Date: Tue, 10 Jul 2001 09:04:12 +0300

Mike & All,

We don't want this thread to be started again in this forum.
For anything related to framing go to the TSWG or to the RDMA mailing list.

Julo

"Mike Parkhurst" <[email-masked]> on 10-07-2001 02:23:54

Please respond to [email-masked]

To:   [email-masked], [email-masked], Julian
      Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject:  RE: iSCSI Framing Formats

Hello All,

I've had the same thoughts after reading the spec. Pardon my lack of
knowledge as to the previous discussions, but why not use a framing bit
pattern as a marker? Pick some 32 bit number, anything but all zeros or
ones would work, and prefix each header with it. If there is a packet
loss then the receiver can scan for the next "possible" marker. Once a
marker pattern is found the receiver then does a sanity check on the
header. If it passes then the receiver is re-synced. If not then the
search continues until a valid marker & header is found.

Mike Parkhurst

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Trang Nguyen
Sent: Monday, July 09, 2001 1:44 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: Trang Nguyen
Subject: iSCSI Framing Formats

Hello everyone,

I've read your discussion about how to find iSCSI PDU header from the
TCP
stream at the receiving end.  There are 2 different approaches with
various
ways:

1.  TCP unaware approach suggests: periodic marker, fixed length
messages,
byte stuffing, chunks.
2.  TCP aware approach suggests: Urgent pointer, and PSH bit.

I found that there are some objections about using Urgent point and PSH
bit
because the TCP has to be modified.  The iSCSI internet draft suggests
the
use of periodic marker.  The problem with the periodic marker in the
iSCSI
I-D is that both initiator and target have to agree on the marker.  "In
certain environments a sender not willing to supply markers to a
receiver
willing to accept marker MAY suffer from a considerable performance
degradation."  (draft-ietf-ips-iscsi-06.txt).

I am just wondering if any method of iSCSI framing has been finalized
yet?
What is the status of this issue?  Will the next version of iSCSI I-D
have
more information about it?

Trang Nguyen