Subject: iSCSI: Indication of final data-out sequence

From: Rishabh Srivastav <[email-masked]>
Date: Wed, 4 Jul 2001 08:59:32 -0700 (PDT)

A doubt regarding the final sequence of data-out PDUs
: My apologies if this had already been discussed long
time ago. Couldn't locate it in the huge mail
repository. 
In FC, the last sequence of an exchange is indicated
by a 'Last_Sequence' bit in F_CTL of FC-FS header.
What is the equivalent of it in iSCSI, specifically in
the case of Data-Out ? If there is none, will not the
presence of a similar bit be useful for iSCSI-FCP
gateways ?

Thanks,
Rishabh

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: [email-masked]
Date: Thu, 5 Jul 2001 14:08:27 +0300

There is no need for an additional bit.
Every outstanding R2T has a target task tag (and a number...)
The target has to keep track of what he got and send the status
after the last R2T sequence.  Thee is also an ordering delivery requirement
but that is weaker.

Julo

Rishabh Srivastav <[email-masked]> on 05-07-2001 12:18:47

Please respond to Rishabh Srivastav <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject:  Re: iSCSI: Indication of final data-out sequence

Julo,
I'm still not convinced.
There can be multiple data-out PDU's in response to
one R2T. In this case the F bit indicates the end of
sequence corresponding to that particular R2T and not
for the whole write operation. However, the
last_sequence bit in FC-FS is something which
indicates the final data IU for that whole exchange.
So, how can 'F' bit be equated to the last_sequence
bit ?? The semantics of 'F' bit is same as
last_sequence bit in the case of Data-In PDUs and not
in the case of data-out PDU.
Where am i going wrong in my assumptions ?
Please clarify.
Thanks,
Rishabh

--- [email-masked] wrote:
> the F bit. Julo

---

From: "Binford, Charles" <[email-masked]>
Date: Thu, 12 Jul 2001 10:22:22 -0400

Rishabh,  The 'Last_Sequence' bit in an FC/FCP exchange would be set on the
last frame of the FCP_RSP sequence.  It does not "indicates the final data
IU for that whole exchange".

FCP requires an XFER_RDY to be satisfied with a single sequence of FCP_DATA
(data out "phase"). The last frame of that single sequence can be recognized
by at least two methods: EOFt (vs. EOFn) and End_Sequence bit in F_CTL.
Also, with FCP you can only have one XFER_RDY outstanding at a time.

With iSCSI, the F bit tells you when you have received the final PDU of data
satisfying an R2T.  If you as a target choose to send multiple R2T's, then
you expect multiple PDUs with the F bit.

Charles Binford
Pirus Networks
316.315.0382 x222

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 05, 2001 6:08 AM
To: [email-masked]
Subject: Re: iSCSI: Indication of final data-out sequence

Julo

Julo,
I'm still not convinced.