Subject: RE: iSCSI padding should be 0

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 27 Jul 2001 12:24:24 -0400

Sounds good to me.

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, July 27, 2001 11:46 AM
To: [email-masked]
Cc: ips
Subject: Re: iSCSI padding should be 0

Perhaps we should say MUST be sent as 0 and keep quiet about what the
receiver should  do (check for 0 - we don't want that).

Thanks,Julo

"Eddy Quicksall" <[email-masked]> on 27-07-2001 18:18:33

Please respond to [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject:  iSCSI padding should be 0

Julian,

Section 2.1 says the padding should be 0. I guess that is correct because
one may not use CRC and therefore may not want to set them to 0. Wouldn't
it
be better if section 2.1 was more specific and mentioned when they must be
0
if there is a CRC. Also, I noticed at the UNH plug fest that at least one
person thought "should" meant "must". Therefore, I don't think it should
say
"should" ... I think it should not mention the 0'ness unless there is a CRC
present.

Also,

        transmission.  Padding bytes, when presents in a segment covered by
a
        CRC, have to be set to 0 and are included in the CRC.

should say "when present in".

[email-masked]

---

From: "Rod Harrison" <[email-masked]>
Date: Fri, 27 Jul 2001 14:19:17 -0500

Can we not leave the pad bytes out of the digest
calculation and allow them to be any value. Having to zero
the pad bytes is the only reason to touch the payload
buffer. Is it really a security problem to allow the pad
bytes to be any value?

	- Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of
Eddy Quicksall
Sent: Friday, July 27, 2001 11:24 AM
To: 'Julian Satran'
Cc: 'ips'
Subject: RE: iSCSI padding should be 0

Sounds good to me.

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, July 27, 2001 11:46 AM
To: [email-masked]
Cc: ips
Subject: Re: iSCSI padding should be 0

Perhaps we should say MUST be sent as 0 and keep quiet about
what the
receiver should  do (check for 0 - we don't want that).

Thanks,Julo

"Eddy Quicksall" <[email-masked]> on 27-07-2001
18:18:33

Julian,

Section 2.1 says the padding should be 0. I guess that is
correct because
one may not use CRC and therefore may not want to set them
to 0. Wouldn't
it
be better if section 2.1 was more specific and mentioned
when they must be
0
if there is a CRC. Also, I noticed at the UNH plug fest that
at least one
person thought "should" meant "must". Therefore, I don't
think it should
say
"should" ... I think it should not mention the 0'ness unless
there is a CRC
present.

Also,

        transmission.  Padding bytes, when presents in a
segment covered by
a
        CRC, have to be set to 0 and are included in the
CRC.

---

From: Mark Bakke <[email-masked]>
Date: Fri, 27 Jul 2001 16:14:43 -0500

Rod-

The pad bytes are set to zero, rather than just sending whatever
data is there, for minor security purposes.

The pad bytes are included in the digest to simplify the hardware.

I suggest we leave this as is.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054