Subject: ISCSI MIB

From: "Michele Hallak - Stamler" <[email-masked]>
Date: Mon, 16 Jul 2001 14:22:56 +0200

Hi,
I'm new in the storage group and in iSCSI specially.
Are there any reason why the iSCSI MIB is almost read-only?
Why a manager cannot create a target for example? 
Thanks for enlightning me,

	Michele

---

From: Mark Bakke <[email-masked]>
Date: Mon, 16 Jul 2001 07:45:14 -0500

Michele-

Targets (and the logical units that are behind them) are
created at the SCSI level; iSCSI only provides addressing
for these.  Since we don't have a way to create and destroy
targets and LUs at the SCSI level (there's no SCSI MIB yet),
there's not much point in allowing SETs in iSCSI, either.

Most people are counting on using other interfaces, such as
CIM, for doing this type of configuration, rather than using
SNMP.  With any luck, we'll have some sort of effort (probably
within SNIA) to define CIM models for these.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054