Subject: Re: iSCSI: Discovery Sessions

From: Mark Bakke <[email-masked]>
Date: Tue, 17 Jul 2001 16:02:31 -0500

Sorry, I was working through history there.  DiscoverySession,
BootSesion, and CopyManagerSession are all gone.

Only SessionType is needed.

--
Mark

"KRUEGER,MARJORIE (HP-Roseville,ex1)" wrote:
> 
> .. snip ..
> 
> > Julian had suggested that we simply provide a text key at
> > login that says
> >
> >    DiscoverySession=yes
> >
> > to indicate that the session was to be used for SendTargets;
> > no TargetName would need to be specified at all for the session.
> >
> > Since this was analogous to other "special" sessions, such as
> > boot and copy manager sessions, we further combined these
> > separate booleans into a SessionType.
> >
> > This means that rather than specifying the target "iscsi" in
> > the login request, the initiator would instead specify:
> >
> >    SessionType=Discovery
> 
> So which is it, "DiscoverySession" or "SessionType"?  If both, why do we
> need both?
> 
> On another note, Appendix D should *clearly* indicate which of these keys
> are mandatory to implement (which means offer and answer).
> 
> Marjorie Krueger
> Networked Storage Architecture
> Networked Storage Solutions Org.
> Hewlett-Packard

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Tue, 17 Jul 2001 13:59:35 -0700

.. snip ..

Marjorie Krueger