Subject: The iSCSI Plugfest - update for Wednesday

From: "Barry Reinhold" <[email-masked]>
Date: Wed, 18 Jul 2001 18:53:30 -0400

The plugfest process has settled down to the detailed process of isolating
implementation bugs. A significant percentage of the implementors are now
able to connect and perform I/O operations - though this is often achieved
by first compiling with -D "company Name" switches to handle the different
issues that have already been discovered.

New Issues: A detailed posting of the issues to date will (or has) be done
by Bob Russell. In brief  only one additional standards issues came to light
that impacted interoperability in the days testing:

1. The current wording of the standard appears to allow for the transmission
of IO data in response frames. This is actually being done in a few
implementations. Although this was perhaps a vision at the start of the
iSCSI effort there is little support for this. Most implementors were not
prepared to handle this.

Progress:

Test progressed to round 17 and it appears that it is highly likely that
developers will get a chance to test against all other parties by the end of
the week.

Two vendors were able to establish a multi connection session, getting
through the login process and the start of IO.

Two other vendors established an iSCSI session with header digests,
completing the security phase of the login process.

Some generic problem areas that come up:

0 Length data frames
Target initiated text negotiation
Response information in data PDUs.
SCSI compatibility issues

There was a UNH iSCSI consortium meeting at the end of the day

1. Overview of UNH iSCSI consortium
2. Discussion on dates/time for next plug fest
3. Election of steering team

People flowing out at 7:00 -- sign that things are pretty good.

Barry Reinhold
Principal Architect
Trebia Networks
[email-masked]
603-868-5144/603-659-0885/978-929-0830 x138

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 19 Jul 2001 20:13:10 +0300

That was never supported. The data space is reserved for sense & response.
Julo

"Barry Reinhold" <[email-masked]> on 19-07-2001 19:44:04

Please respond to "Barry Reinhold" <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:
Subject:  RE: The iSCSI Plugfest - update for Wednesday

There is no problem with this feature. It is the sending of data in iscsi
command response PDUs that was an issue.

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>Julian Satran
>Sent: Thursday, July 19, 2001 12:31 PM
>To: [email-masked]
>Subject: RE: The iSCSI Plugfest - update for Wednesday
>
>
>
>No - only sending good status on Data-In PDU.  And again this did not
>change from draft 00.  Julo
>
>"Barry Reinhold" <[email-masked]> on 19-07-2001 15:23:47
>
>Please respond to "Barry Reinhold" <[email-masked]>
>
>To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
>cc:
>Subject:  RE: The iSCSI Plugfest - update for Wednesday
>
>
>
>
>Julian,
>     Am I to understand from this that iSCSI intends to support both (1)
>sending
>of status information in iSCSI data PDUs and also sending of data in iSCSI
>response PDUS?
>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>>Julian Satran
>>Sent: Thursday, July 19, 2001 6:27 AM
>>To: [email-masked]
>>Subject: Re: The iSCSI Plugfest - update for Wednesday
>>
>>
>>
>>Status and Data where (and) are part of the standard.
>>They are important to reduce the protocol overhead and performance of the
>>software implementation
>>is substantially reduced without it.
>>
>>It is clearly stated in several places (1.2, the Data-In PDU) etc. and
has
>>never changed (from version 0).
>>
>>As for the plugfest - congratulations - great work.
>>
>>Julo
>>
>>
>>
>>
>>Please respond to "Barry Reinhold" <[email-masked]>
>>
>>To:   "ISCSI" <[email-masked]>
>>cc:
>>Subject:  The iSCSI Plugfest - update for Wednesday
>>
>>
>>
>>