Subject: iSCSI: R2T and Bidi R2T

From: Mark Bakke <[email-masked]>
Date: Thu, 09 Aug 2001 09:49:11 -0500

Julian-

I received some comments on the iSCSI MIB about the fact
that if InitialR2T and BidiInitialR2T are not independent,
then they should be combined into the same variable instead
of negotiated separately.

Since we don't do anything with bi-directional data right
now, I hadn't looked at this before, but is it possible
to have InitialR2T=yes with BidiInitialR2T=no?  If not,
then we should probably combine them into:

InitialR2T=<all|bidi-only|none>

or something like that.

Any thoughts?  Is there someone out there planning to use the
Bidi stuff who can comment?

Thanks,

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 10 Aug 2001 08:57:34 +0300

Mark,

I am not sure what the usage pattern will be. There are 2 different bits
for SCSI so they must have had a reason to keep them separate and I think
that so should we.

Julo

Mark Bakke <[email-masked]>@cisco.com on 09-08-2001 17:49:11

Please respond to Mark Bakke <[email-masked]>

Sent by:  [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL, IPS <[email-masked]>
cc:
Subject:  iSCSI: R2T and Bidi R2T

Julian-

or something like that.

Thanks,

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054