Subject: RE: iSCSI: Support Alias in the protocol

From: Robert Snively <[email-masked]>
Date: Mon, 20 Aug 2001 14:24:40 -0700

Folks,

I remain concerned about this called consensus.  Clearly there
will be thousands of Targets and Initiators running around
a network.  Creating a set of human useable aliases
that will distinguish all these seems to me somewhat farfetched.
We don't even do very well on kings.  George, George II, etc.

To create aliases in the context of a single management environment
makes some sense, but again, that should be outside the 
scope of iSCSI.

That we call our car Skeezix (human useable, for management
purposes within the tightly constrained context of our own
family) is non-architected information.  Whenever anyone cares 
which car it is (including during servicing and upgrades) they 
use the VIN, a registered and architected non-human-readable value.

If Marjorie and I are the only voices in the woods, we have
clearly had the consensus called against us, but this is high
on my list of things that really aren't much help to anyone
and shouldn't be in the document.

Bob

> >Let me also acknowledge as valid Marj's opinion that anything of
> >this sort belongs in a management tool rather than the protocol.
> 
> But it only works if everyone uses the same management tool, 
> or the tools agree upon the location and storage format of the 
> information 
> --  Somebody dig me up from my grave when Tivoli and 
> OpenView merge.
> 
> As a way of easily identifying virtual LUN's or LU's within a 
> Target Space of potential hundreds or thousands the alias 
> is very valuable.

---

From: Stephen Bailey <[email-masked]>
Date: Tue, 21 Aug 2001 22:37:50 -0400

Bob,

> family) is non-architected information.

What's your position on the SCSI LU alias?  Do you think that was a
bad idea too?