Subject: iSCSI names on login - consensus call

From: [email-masked]
Date: Thu, 30 Aug 2001 23:02:00 -0400

Yesterday, Steve Senum suggested:

> 2. Requiring Initiator and (if not a discovery session)
>    Target names on login command, so they are always
>    available if needed by the initial phase.

This definitely simplifies login, as the target no longer
has to check for the absence of the names and ask for them
if they are necessary.  Given the selection of IKE for
keying, the security concerns about always sending
the names are no longer valid - if the names need to
be hidden, an encrypted IPsec SA should be set
up by IKE (and Main Mode should be used if the IKE
identities also need to be hidden).

Based on discussion since Steve's post, I believe the
rough consensus of the IPS WG is to require the names on
the login command.  Julian Satran's disagreement with this
is noted - anyone else who objects should post to the
list and include a cogent technical rationale for the
objection.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 31 Aug 2001 07:27:01 +0300

David,

You might as well call a consensus "blowing away an old session when asked
to do so".
I think that it is a bad decision but I failed to convince the list that it
is so.  Please note for the record
my strong opposition.

Julo

[email-masked]@ece.cmu.edu on 31-08-2001 06:02:00

Please respond to [email-masked]

Sent by:  [email-masked]

To:   [email-masked], [email-masked]
cc:
Subject:  iSCSI names on login - consensus call

Thanks,
--David