Subject: RE: iSCSI - Change - Login/Text commands with the binary stage code - IMPORTANT PROPOSAL

From: "Julian Satran" <[email-masked]>
Date: Thu, 30 Aug 2001 08:50:47 +0300

The situation is not symmetric anyway. If we keep the final login we have a
text request answered by
a Login request.

I think that considering that text & login are equivalent during login if
you care for complete symmetry you may want to use only login during the
login phase.

This way we could even remove the phases field from the text commands.

So again the proposal is USE ONLY LOGIN during Login (the reason I did no
put initially is now history anyway).

COMMENTS?

Julo

"Ayman Ghanem" <[email-masked]>@ece.cmu.edu on 30-08-2001 05:26:27

Please respond to "Ayman Ghanem" <[email-masked]>

Sent by:  [email-masked]

To:   <[email-masked]>
cc:
Subject:  RE: iSCSI - Change - Login/Text commands with the binary stage
      code

Julian,

One could also argue for symmetry; only one login response per login cmd.
On
the other hand, the only time a partial login is returned at the moment is
when status class is 0 and F=0. Any other status class results in a final
login response. For status class 0, there exists 3 status detail codes: 0,
1, and 2. The first two are implied from the negotiation phase, and the
third case will no longer exist if we enforce the ITN to be sent in the
login cmd. The session parameters returned in a partial login response are
not needed because the connection has not joined the session yet during
login.

-Ayman

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Julian Satran
> Sent: Wednesday, August 29, 2001 4:18 PM
> To: [email-masked]
> Subject: Re: iSCSI - Change - Login/Text commands with the binary stage
> code
>
>
> Steve,
>
> The partial response is not strictly needed it is just handy to have the
> login request answered
> with a login response. On this we can put the partial/final answer. For a
> text it would have been arbitrary (text outside login does not need it).
>
> As for the names - I though that security people might object having the
> name in clear if the security phase does not make use of the name.
> Otherwise we can mandate them on the login but I wonder if that is a real
> improvement or we are getting carelles.
>
> Julo
>
>
> Steve Senum <[email-masked]>@ece.cmu.edu on 29-08-2001 23:59:36
>
> Please respond to Steve Senum <[email-masked]>
>
> Sent by:  [email-masked]
>
>
> To:   ietf-ips <[email-masked]>
> cc:
> Subject:  Re: iSCSI - Change - Login/Text commands with the binary stage
>       code
>
>
>
> Julian,
>
> A couple of ideas from Matthew Burbridge & Co.'s
> login proposal that has generated some interest here:
>
> 1. Removal of partial login response.  Is it still needed?
>
> 2. Requiring Initiator and (if not a discovery session)
>    Target names on login command, so they are always
>    available if needed by the initial phase.
>
> Comments?
>
> Regards,
> Steve Senum
>
>
>
>

---

From: "Guru" <[email-masked]>
Date: Thu, 30 Aug 2001 00:15:24 -0700

----- Original Message -----
From: "Julian Satran" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, August 29, 2001 10:50 PM
Subject: RE: iSCSI - Change - Login/Text commands with the binary stage
code - IMPORTANT PROPOSAL

---

From: Steve Senum <[email-masked]>
Date: Thu, 30 Aug 2001 11:12:38 -0500

Julian,

> put initially is now history anyway).

Ayman and I would prefer having only one login command and one login
response, seperated by zero or more text response/text command
pairs (like in Matthew Burbridge & Co.'s proposal).

Second choice would be leaving the spec as is, with the partial
login response.

Regards,
Steve Senum