Subject: Re: iSCSI: SendTargets in login or FFP?

From: "Robert D. Russell" <[email-masked]>
Date: Thu, 2 Aug 2001 13:49:08 -0400

Julian:

In order to try to organize information about the key parameters,
I developed the attached ASCII text file which characterizes each
key from draft 7 according to 4 attributes:

1.  what type of key it is, which determines in which login phase
    it can be used.
2.  when the key can be negotiated.
3.  who can send the key.
4.  the scope of application of the key's information.

The values of these attributes were drawn from Appendixes A and D.
The only new information added (i.e., information not in draft 7)
is the characterization of keys into 3 types - security, operational,
and informational, where the new category "informational"
applies to keys, such as TargetAddress, TargetName, InitiatorName,
etc. which can be sent in either the security or operational
subphases of login, and which simply provide information rather
than negotiate values.

There is still a question with regard to the SendTargets key
-- many of the recent postings regarding the use of SendTargets for
discovery sessions indicates that people expect this key to be used
only in Full Feature Phase.  Quoting from Mark Bakke's e-mail of
24-July:

> "Anyway, SendTargets is always done in full feature phase, and
> never during the login phase."

and later in the same message:

> No.  The point of doing SendTarget in full feature phase is that the
> initiators must first go through their normal authentication;
> SendTargets responses will often be based on the initiator's identity.

Is this limitation correct?  Or does this limitation apply only for
discovery sessions?

The draft currently characterizes SendTargets as ALL, which
does not imply this limitation.

If SendTargets is so limited, it would be the only key that could not
be used somewhere during login.  To cover this case in the attached table
I have added the category FFP to the 3 existing categories IO, LO,
and ALL.  Draft 7 would have to be modified to reflect this.

If this limitation is not correct, the category FPP
disappears and the ALL category would continue to apply to SendTargets
(and targest can expect to receive SendTargets during login).

Thanks,

Bob Russell
InterOperability Lab
University of New Hampshire
[email-masked]
603-862-3774

On Tue, 24 Jul 2001, Julian Satran wrote:

> Eddy,
> 
> SendTargets can be used in both discovery session and normal session.
> Would you please clarify when you think this restriction should apply?
> 
> Julo
> 
> "Eddy Quicksall" <[email-masked]> on 24-07-2001 04:15:56
> 
> Please respond to "Eddy Quicksall" <[email-masked]>
> 
> To:   Julian Satran/Haifa/IBM@IBMIL, [email-masked]
> cc:
> Subject:  iSCSI: SendTargets in login or FFP?
> 
> 
> 
> 
> The spec says:
> 
>   An initiator can log into this default target [iSCSI]
>   name, and use a command called "SendTargets" to retrieve a list of
>   iSCSI targets that exist at that address
> 
> I assume this means the SendTargets would be used in Full Feature Phase ...
> the initiator would login using TargetName=iSCSI. That would get into FFP
> and then the initiator would use SendTargets= to get the list of targets.
> Then, login again with the appropriate target.
> 
> The spec says:
> 
>   In full feature phase the initiator may send SCSI
>   commands and data to the various LUs on the target by wrapping them
>   in iSCSI PDUs that go over the established iSCSI session.
> 
> That means the target has to do something if a CDB is received to the iSCSI
> canonical target. The spec doesn't give any suggestions here. I am assuming
> the target would give a reject PDU with a reason of "Protocol Error" (code
> 5).
> 
> Do you agree that this is what should happen?
> 
> We shouldn't require that the target enter FFP when it would not be valid
> to
> send a CDB. I think SendTargets should be done only at LO or IO time and
> that iSCSI should not get you into FFP. That would simplify coding.
> 
> 
> [email-masked]
> 
> 
> 
>

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 3 Aug 2001 16:27:32 +0300

Yes - There is probably a need for FFP and SendTargets falls in this
category.

Julo

"Robert D. Russell" <[email-masked]> on 02-08-2001 20:49:08

Please respond to "Robert D. Russell" <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  Re: iSCSI: SendTargets in login or FFP?

Julian:

Thanks,

Bob Russell
InterOperability Lab

> [email-masked]

 - keys.txt

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 4 Aug 2001 09:15:23 +0300

Matthew,

That is an (editorial) mistake. They are still IO.  But this whole area
might change - look for the framing report in London.

Julo

"BURBRIDGE,MATTHEW (HP-UnitedKingdom,ex2)" <[email-masked]> on
03-08-2001 18:31:24

Please respond to "BURBRIDGE,MATTHEW (HP-UnitedKingdom,ex2)"
      <[email-masked]>

To:   "'Robert D. Russell'" <[email-masked]>, Julian
      Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  RE: iSCSI: SendTargets in login or FFP?

Hi Robert,

In your attachment, you have stated that FMarker (and its dependencies) are
per connection.  I believe this was the case in 0.6 but in 0.7 it is now on
the LO connection and therefore is it not per session or am I missing
something here?

Cheers

Matthew Burbridge
Senior Development Engineer
NIS-Bristol
Hewlett Packard
Telnet: 312 7010
E-mail: [email-masked]

-----Original Message-----
From: Robert D. Russell [mailto:[email-masked]]
Sent: Thursday, August 02, 2001 6:49 PM
To: Julian Satran
Cc: [email-masked]
Subject: Re: iSCSI: SendTargets in login or FFP?

Julian:

Thanks,

Bob Russell
InterOperability Lab