Subject: Re: iSCSI: [Fwd: Crc-32c example in iSCSI spec]

From: "Julian Satran" <[email-masked]>
Date: Mon, 20 Aug 2001 17:52:05 +0300

Mark,

I appologize - since I built the examples I just transcribed the results
and the data from two different runs.
They value used are 1f to 0 and not ff to e0.

Julo

Mark Bakke <[email-masked]>@cisco.com on 20-08-2001 17:03:50

Please respond to Mark Bakke <[email-masked]>

Sent by:  [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL
cc:
Subject:  Re: iSCSI: [Fwd: Crc-32c example in iSCSI spec]

Julian-

I have to run out for a while, so I'll look at the rest of the
message later today.  I noticed that you've added a new example,
but when I run it through my generator I get a different CRC.

Julian Satran wrote:

>    32 bytes of decrementing ff..e0:
>
>      Byte:        0  1  2  3
>
>         0:       ff fe fd fc
>       ...
>        28:       e3 e2 e1 e0
>
>       CRC:       5c db 3f 11

I get   CRC:       a7 e4 e4 ae

--
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Mon, 20 Aug 2001 14:16:02 -0500

> They value used are 1f to 0 and not ff to e0.

OK; when I use 1f..00 my CRC matches yours.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054