Subject: RE: Iscsi: Fault tolerance

From: "Merhar, Milan" <[email-masked]>
Date: Tue, 31 Jul 2001 15:26:49 -0400

Sanjeev, 

I think that your clients will actually be accessing a file system 
your server has created on the raw volume accessed by iSCSI.  They do so 
by using a network file protocol - in the case of Microsoft products,
probably CIFS, connecting to the server which then in turn does 
block mode accesses to the iSCSI volume.

So, if the server goes away, the clients can no longer reach 
the files stored on the iSCSI device.  Of course, unlike 
a server with a direct-attached drive, in the situation you 
describe another server could step into the place of the first one, 
mounting the iSCSI volume and again offering shared file access to 
those clients. (In other words, you've got a NAS server accessing 
its storage over a SAN - an IP SAN.)

Depending on how the server "went away", there may be some startup 
transients bringing its replacement online, as the file system is 
verified, cleaned up, etc.  The transition is also not transparent
to the clients, as they will need to reconnect to this new server, 
with its different IP address, as well.

Hope this helps.

	- milan

Milan Merhar, Chief Scientist, Pirus Networks

> -----Original Message-----
> From: Sanjeev Bhagat (TRIPACE/Zoetermeer) [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2001 2:18 PM
> To: 'Julian Satran'; [email-masked]
> Subject: RE: Iscsi: Fault tolerance
> 
> 
> Julian and all!!
> 
> The server connects to the iscsi target (Say just a disk) 
> with the help of
> an iSCSI initiator driver installed on the server. The NT 
> server thus shows
> an extra physical disk present on the server. The sys admin 
> then assigns the
> permission to other clients/users to share this target. The 
> clients can then
> access this this disk (iscsi target) or any sharable 
> directory on this disk
> (iscsi target)present on the server by connecting to the network.
> 
> Hope it is clear by now!! If it is not then please provide me 
> your contact
> number and I will try to explain you better.
> 
> I am sorry if there is any ambiguity but i cant find better words to
> explain.
> 
> Sanjeev
> 
> -----Original Message-----
> From: Julian Satran [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2001 6:35 PM
> To: [email-masked]
> Subject: Re: Iscsi: Fault tolerance
> 
> 
> 
> How exactly will the clients use the initiator on the server?
> 
> Julo
> 
> "Sanjeev Bhagat (TRIPACE/Zoetermeer)" <[email-masked]> 
> on 31-07-2001
> 18:57:41
> 
> Please respond to "Sanjeev Bhagat (TRIPACE/Zoetermeer)"
>       <[email-masked]>
> 
> To:   "'IPS Reflector'" <[email-masked]>
> cc:
> Subject:  Iscsi: Fault tolerance
> 
> 
> 
> 
> Hi
> 
> Consider a case where the clients of a Windows NT server are 
> accessing the
> iSCSI target with iSCSI initiator driver installed  on the Windows NT
> server
> to access a ISCSI target on NET. So all the clients on this Windows NT
> server can share the iSCSI target of this server. In case the 
> server goes
> down , will the clients still be able to access the iSCSI Target??
> 
> I hope I have put my question peoperly. In case not then 
> please feel free
> to
> call me at +31 624685051
> 
> 
> Sincerely,
> 
> Sanjeev Bhagat
> 
> Tripace Europe
> 
> 
>  - att1.htm
> 
>

---

From: "John Hufferd" <[email-masked]>
Date: Fri, 3 Aug 2001 09:59:04 -0700

What Milan says is probable, however, let me address it in a slightly
different way.

There are Servers, Today, that share their Data on a FC SAN.  They have
either a Shared File System or use something like "SANergy" to share out
the files.  In the case of a shared file system, each surviving member of
the Cluster can continue to access the Disks.  In the case of SANergy, the
other members can continue until the extent list needs to be updated.

These are solutions that are in use today, in FC SAN environments.  If you
are talking about general clients scattered around a campus that need
sharing, they will best be handled by a Filer (as Milan said).

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136
Internet address: [email-masked]

"Merhar, Milan" <[email-masked]>@ece.cmu.edu on 07/31/2001 12:26:49 PM

Sent by:  [email-masked]

To:   "'Sanjeev Bhagat (TRIPACE/Zoetermeer)'" <[email-masked]>
cc:   [email-masked]
Subject:  RE: Iscsi: Fault tolerance

Sanjeev,

Hope this helps.

     - milan

---

From: "John Hufferd" <[email-masked]>
Date: Fri, 3 Aug 2001 12:51:12 -0700

Correct.

.
.
.
John L. Hufferd

"Merhar, Milan" <[email-masked]> on 08/03/2001 10:58:34 AM

To:   John Hufferd/San Jose/IBM@IBMUS, "Merhar, Milan" <[email-masked]>
cc:   "'Sanjeev Bhagat (TRIPACE/Zoetermeer)'" <[email-masked]>,
      [email-masked]
Subject:  RE: Iscsi: Fault tolerance

Thanks for adding that, John. These "direct" file sharing
solutions are powerful tools, but not often seen in
general use at present. The ones that I'm familiar with
run over FC SANs, although there is no reason why they
wouldn't run very nicely over iSCSI.

In your application, the box that had been a "file server"
now becomes a "metadata server" and "lock manager".  Once
the clients are presented with the list of blocks comprising
a file (and the write lock, if they're doing writes), they
can go off and fetch the actual data from the iSCSI volume
themselves.

A failed metadata server behaves pretty much like a
failed file server in terms of bringing a spare online, doing
file system recovery, etc, except that clients already
having been granted file access can continue accessing
those blocks (and only those blocks) during the outage.

As for client support, a special driver is needed on each client,
to handle the split metadata/direct access operations.

- milan

> From: John Hufferd [mailto:[email-masked]]
> Sent: Friday, August 03, 2001 12:59 PM
> To: Merhar, Milan
> Cc: 'Sanjeev Bhagat (TRIPACE/Zoetermeer)'; [email-masked]

---

From: "Merhar, Milan" <[email-masked]>
Date: Fri, 3 Aug 2001 13:58:34 -0400

- milan