Subject: Re: CmdSN during login

From: Mark Bakke <[email-masked]>
Date: Thu, 09 Aug 2001 15:55:25 -0500

Sanjay-

I absolutely agree with this; CmdSN is owned by the session, and
should not be used until the connection has fully joined the session,
which means full feature phase.

This should also clean up any ambiguity on when to start
using CmdSN.

--
Mark

Sanjay Goyal wrote:
> 
> Hi
> 
>  Assuming Target and Initiator support multiple connections and the session
> is having multiple connections. Assuming out-of-order CmdSN is a possibility
> for this session.
> 
>  Connection #   1       |       2       |       3
> -------------------------------------------------------
> Login Cmd  CmdSN=0      |   CmdSN=8     |  CmdSN=9
> Txt   Cmd  CmdSN=1      |               |
>                                 |               |
>                                 |               |
> Login Cmd  CmdSN=7      |  CmdSN=10     |  CmdSN=11
> -------------------------------------------------------
> Data Cmd   CmdSN=12     | CmdSN=14      | CmdSN=15
> Data Cmd   CmdSN=13     |               |
>                                 |               |
> 
> CmdSN=7 is last of the Login sequence and it is acknowledged by the Target
> with "accept login" response.
> 
> Target would receive the PDUs in this CmdSN order
>  0 to 7, 8, 9, 12, 10, 11, 13, 14, 15
> 
> Now as Login and Text PDUs are being processed even though you have received
> Data Cmd PDUs, you can not pass them to iSCSI layer and hence you are adding
> latency.
> 
> What I want to convey from this example is why not use CmdSN just during the
> FullFeature phase only.
> 
> Regards
> Sanjay Goyal
> 
>   ----------------------------------------------------------------------------------------------------
> 
>    Part 1.2    Type: application/ms-tnef
>            Encoding: base64

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Sanjay Goyal <[email-masked]>
Date: Thu, 9 Aug 2001 16:34:58 -0400

Hi

 Connection #	1	|	2	|	3

Regards
Sanjay Goyal