Subject: RE: [Fwd: Crc-32c example in iSCSI spec]

From: "Wheat, Stephen R" <[email-masked]>
Date: Tue, 14 Aug 2001 18:27:46 -0700

For what it's worth, I also get the same results as you two; matching three
of the four examples; with the exception being where I get 62 a8 ab 43 for
all 0xff's.

Stephen

-----Original Message-----
From: Steve Blightman [mailto:[email-masked]]
Sent: Thursday, August 09, 2001 2:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Fwd: Crc-32c example in iSCSI spec]

Sanjay -
Did you ever get any response to this email? - I have the same problem.  I
wonder if we can get whoever generated these examples to double check them &
respond.
Thanks for any help
Steve Blightman

>
> Subject: Crc-32c example in iSCSI spec
> Date: Fri, 27 Jul 2001 09:52:44 -0400
> From: Sanjay Goyal <[email-masked]>
> To: [email-masked]
> CC: Sanjay Goyal <[email-masked]>
>
> Hi
>  I tried matching the crc32c example results with mine for all ZEROs and
all
> ONEs
>  the result for Zeros matches whereas it does not match for all Ones. My
> result instead of
>       21 44 df 1c
>             is
>       62 a8 ab 43
>
> Can somebody clarify me on the issue.
>
> Regards
> Sanjay Goyal

---

From: Mark Bakke <[email-masked]>
Date: Wed, 15 Aug 2001 07:45:30 -0500

I had done the examples, and I apologize for missing the first
email.  You are right; the "all ones" CRC is 62 a8 ab 43.  I
just ran my generator again, and found the problem.  I was running
both the iSCSI and Ethernet CRCs on each pattern, so I could check
the Ethernet CRC against other specs as well.  When I wrote the
examples, I copied the wrong CRC for the all ones example.

We'll fix it.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054