Subject: Re: iSCSI: draft 7: Abort Task and RefCmdSN

From: "Julian Satran" <[email-masked]>
Date: Sun, 5 Aug 2001 21:36:44 +0300

Robert,

This is related to the fact that the abort command can arrive before the
command to be aborted if sent on a different connection (or the command has
been dropped due to some error). As such RefCmdSN indicates where the
command would have been in the command queue.  If they don't agree the
target should not abbort. And the main criteria for finding a task is the
Initiator Task Tag.
I've changed the wording to:

1.1.1     RefCmdSN

   For abort-task the task CmdSN to enable task removal. If RefCmdSN does
   not match the CmdSN of the command to be aborted at the target
The abort action MUST not be performed and the response MUST be function
rejected.

Julo

"Elliott, Robert" <[email-masked]>@ece.cmu.edu on 05-08-2001
20:36:10

Please respond to "Elliott, Robert" <[email-masked]>

Sent by:  [email-masked]

To:   "[email-masked]'" <[email-masked]>
cc:
Subject:  iSCSI: draft 7: Abort Task and RefCmdSN

The Task Management [function] Command PDU includes two fields
currently only used by the ABORT TASK function:

2.5.2 Referenced Task Tag
  Initiator Task Tag of the task to be aborted - for abort task

2.5.3 RefCmdSN [Referenced command sequence number]
  For abort-task the task CmdSN to enable task removal. If RefCmdSN is
  is lower that ExpCmdSN or higher than MaxCmdSN the target will ignore
  RefCmdSN.

Both fields identify the task to be aborted.  The Referenced Task
Tag field sits at the SCSI level and matches the SAM-2 function
call description (SAM-2 revision 18):
6.2 ABORT TASK
  Function call:
    Service Response = ABORT TASK (IN (I_T_L_Q Nexus) )

The RefCmdSN field sits at the iSCSI level.

I suggest removing one of these fields.  Having two ways to
specify the same thing just raises the question of what to do
when the values don't agree.  If that happens, should the
target:
send back a Reject PDU
abort both tasks
abort the task indicated by the Referenced Task Tag
abort the task indicated by the RefCmdSN
abort one of the tasks but also report an error
do any of the above

Since task management functions in general may rely on the
SCSI tag (although Abort Task is the only current user of it),
I suggest keeping that flag and dropping the iSCSI field.

--
[email-masked]
Compaq Computer Server Storage

---

From: "Nicolson, Alex" <[email-masked]>
Date: Mon, 6 Aug 2001 14:16:28 -0400

Julo,

I must be misunderstanding something. I thought that Task Management
commands were to be executed as if they had arrived in sequence based on
their CmdSN.

        "Task management commands must be executed
        as if all the commands having a CmdSN lower or equal to the task
        management CmdSN have been received by the target (i.e., have to be
        executed as if received for ordered delivery even when marked for
        immediate delivery)."

Why wouldn't that be the case with Abort Task?

[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Julian Satran
> Sent: Sunday, August 05, 2001 2:37 PM
> To: [email-masked]
> Subject: Re: iSCSI: draft 7: Abort Task and RefCmdSN
>
>
> Robert,
>