Subject: iSCSI: error recovery striation for rev08 (Was: iSCSI - open issues - no discussion - recovery levels)

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 31 Aug 2001 10:56:32 PDT

>- on the recovery there is consesus that it is a good idea; there is no
>consensus on how many layers to enforce (I think that 2 - all or nothing is
>a good choice).

I am sure Julian is trying to kick off a discussion here, after 
collaborating with me on the London proposals  :-)

Seriously, Julian and I were both hoping for more comments before
rev08 in this area - which I haven't seen too many of.

Let me state for the record (as I already said in London) that 
all-or-nothing is not to my favor - IMHO, that erects a too steep 
barrier between the two levels.

I however can see the case for considering decreasing the number 
of levels.  Allow me sometime for cogitation on this once rev08 
is published.  I hope to post an alternative scheme of striation 
by the end of next week for WG consideration.  For rev08, current 
plan is to capture what was presented in London, but state clearly
that this area is still under debate.

Thanks.
--
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

>Dear colleagues,
>
>Considering that the next plugfest is getting close and we would like to
>have
>version 08 ready for it.
>
>We have two open items that got little attention on the list up to now:
>
>- taking out the markers and inserting a reference to an external framing
>draft (what is mandatory, what is optional etc.)
>- recovery the recovery levels proposal
>
>The status  with both is as follows:
>
>- on the framing there is consensus that it is a good idea; there is no
>consensus on what is  MUST, SHOULD etc.
>- on the recovery there is consesus that it is a good idea; there is no
>consensus on how many layers to enforce (I think that 2 - all or nothing is
>a good choice).
>
>Regards,
>Julo
>
>
>

---

From: Sandeep Joshi <[email-masked]>
Date: Fri, 31 Aug 2001 14:44:13 -0400

Mallikarjun,

My vote would be for two levels only.

If its bad weather(transport), you turn on maximum error recovery.
If its good weather, you live with session recovery.
Anything in-between may complicate implementations which
wish to isolate logic paths.

Since you wish to suggest a better division, let me add that
a new scheme for dividing recovery levels would need to be
backed up by potential usage scenarios.  
e.g. if you are doing tape backup, use level A
     if this is within-enterprise access, use level B
     if this is <something..something>, use level C

IMHO, more than two levels would make good sense only if there
were some good real-world scenarios to exploit them.  Otherwise
it may just end up as a case of over-engineering.

-Sandeep