Subject: ISCSI: A propos MIB and specially iSCSI MIB

From: "Michele Hallak - Stamler" <[email-masked]>
Date: Mon, 27 Aug 2001 10:22:26 +0200

Since you are meeting at interim meetings on MIBs:

The following mail summarizes my suggestions concerning the improvement
of iSCSI MIB:

1. New Textual Convention:
 AuthenticationMethodTC  ::= TEXTUAL-CONVENTION
    STATUS current
    DESCRIPTION
        "List of possible authentication methods."
    SYNTAX INTEGER {
		none(1),
		crc32(2),
		crc64(3),
		md5(4),
		kerberosMd5(5),
		kerberosMd5des(6),
		kerberosMd5desHmark(7)
	}

2. Add RowStatus and Read-Write Access to the portals and to the
authorized list of initiators.

3. Add RowStatus to iscsiTargetAttributesTable in order to allow an
administrator to create target and 
set the access of the fields:     iscsiTgtName  and iscsiTgtAlias as
read-create   

I hope that you'll aggree to make the change,

	Michele

---

From: Mark Bakke <[email-masked]>
Date: Mon, 27 Aug 2001 08:47:07 -0500

Michele-

Thanks for the comments.  My comments are below.

--
Mark

>         "List of possible authentication methods."

This is a text field in the current MIB; it will change to
an OID field in the next version, which acts a little like
your enumerated types, but is extensible without modifying
the MIB.  BTW, this is a set of two attributes called DataDigest
and HeaderDigest; AuthMethod is something completely different.
All of the digest methods will be removed from draft-08 with
the exception of "none" and "crc-32c".  With the new OID scheme;
values for these can be added to your enterprise MIB if you
choose to implement them.

> authorized list of initiators.

Which attributes to write and which rows to delete are currently
under consideration.  We are looking for detailed input on this.

Please send the list of attributes you wish to write, and why
you wish to write them.

> set the access of the fields:     iscsiTgtName  and iscsiTgtAlias as

It's not possible to create an iSCSI target without first creating
a SCSI target.  I don't think we will be ready to explore this until
we have made progress on a SCSI MIB.  If you have some ideas on how
a management station would make use of this (with both MIBs) to create
new targets, please send them.

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054