Subject: iSCSI: draft 7: Final bit in Data PDUs

From: "Elliott, Robert" <[email-masked]>
Date: Mon, 6 Aug 2001 10:02:10 -0500

iSCSI draft 7 section 2.7.1 describes when the (F) Final bit is 
set in the Data-out and Data-in PDUs:

  For outgoing data, this bit is 1 for the last PDU of unsolicited
  data  or the last PDU of a sequence answering a R2T. 
         
  For incoming data, this bit is 1 for the last input (read) data
  PDU of a sequence.  

It needs to define how this works for bidirectional commands.
Is the F bit set to one on both the last Data-out PDU and the last
Data-in PDU?  Or is it set to one only on the last Data PDU, 
whatever direction it may be?

--
[email-masked]
Compaq Computer Server Storage

---

From: "Julian Satran" <[email-masked]>
Date: Mon, 6 Aug 2001 19:57:27 +0300

Elliot,

I have no clue how those commands are going to work.
Can you help?
I assume that the F bit will have to be there at both ends?

Julo

"Elliott, Robert" <[email-masked]>@ece.cmu.edu on 06-08-2001
18:02:10

Please respond to "Elliott, Robert" <[email-masked]>

Sent by:  [email-masked]

To:   "[email-masked]'" <[email-masked]>
cc:
Subject:  iSCSI: draft 7: Final bit in Data PDUs

---

From: "Elliott, Robert" <[email-masked]>
Date: Tue, 7 Aug 2001 12:25:13 -0500

I think an F bit per direction would be most useful.

Bidirectional command background:  the target chooses what order to run the
reads and writes.  It can start with either, and switch from one to the
other as often as it wishes.  These are all legal:

1.  read all data, write all data
2.  write all data, read all data
3.  read some, write some, read some, ...
4.  write some, read some, ...

There are two independent data pointers active, one per stream.  EMDP
applies to both.

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Monday, August 06, 2001 5:57 PM
To: [email-masked]
Subject: Re: iSCSI: draft 7: Final bit in Data PDUs

Elliot,

Julo

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 8 Aug 2001 14:26:22 +0300

Elliot,

Thanks .  Will change 2.7.1 to read:

1.1.1     F (Final) Bit

   For outgoing data, this bit is 1 for the last PDU of unsolicited data or
   the last PDU of a sequence answering a R2T.

   For incoming data, this bit is 1 for the last input (read) data PDU of a
   sequence.  Input can be split in several sequences each one having it's
   own F bit. Splitting in sequences does not affect DataSN counting on
   Data-IN PDUs but MAY be used as a "change direction" indication for
   Bidirectional operations that need such a change and/or end of
   recoverable sequences by targets with a limited replay buffer.

   For Bidirectional operations, the F bit is 1 both for the end of the
   input sequences as well as the end of the output sequences.

 Comments?

 Julo

"Elliott, Robert" <[email-masked]>@ece.cmu.edu on 07-08-2001
20:25:13

To:   [email-masked]
cc:
Subject:  RE: iSCSI: draft 7: Final bit in Data PDUs

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Monday, August 06, 2001 5:57 PM
To: [email-masked]
Subject: Re: iSCSI: draft 7: Final bit in Data PDUs

Elliot,

Julo

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 9 Aug 2001 13:11:34 +0300

Yes. Julo

Rishabh Srivastav <[email-masked]> on 08-08-2001 20:48:40

Please respond to Rishabh Srivastav <[email-masked]>

To:   Julian Satran/Haifa/IBM@IBMIL
cc:
Subject:  Re: iSCSI: draft 7: Final bit in Data PDUs

which means, there can even be a case of consecutive
sequences of Data-in PDUs,
with each sequence consisting of 1 PDU with F bit set.
is it so ?

-rishabh

Julian Satran wrote:

  Elliot,

  1.1.1     F (Final) Bit

     For outgoing data, this bit is 1 for the last PDU
of unsolicited data or
     the last PDU of a sequence answering a R2T.

     For incoming data, this bit is 1 for the last
input (read) data PDU of a
     sequence.  Input can be split in several
sequences each one having it's
     own F bit. Splitting in sequences does not affect
DataSN counting on
     Data-IN PDUs but MAY be used as a "change
direction" indication for
     Bidirectional operations that need such a change
and/or end of
     recoverable sequences by targets with a limited
replay buffer.

     For Bidirectional operations, the F bit is 1 both
for the end of the
     input sequences as well as the end of the output
sequences.

   Comments?

   Julo

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: "Julian Satran" <[email-masked]>
Date: Sun, 12 Aug 2001 02:00:26 +0300

Rishab,

I am not sure what you are asking for.
Both for read and for write the status is the one that dictate when things
end.
For bidirectional this does not change.
It is obvious an error to have a status arrive when a data sequence is not
terminated.

Julo

Rishabh Srivastav <[email-masked]> on 10-08-2001 19:48:43

Julian,
Can we retain the previous definition of F bit ? In
the case of write, the term "sequence of PDU's" has a
meaning since a sequence is always demarcated by an
R2T. However, the new concept of "sequence of PDU's"
in the case of read is not analogous to the write
sequence as there is no definite demarcation like R2T
even in the case of bi-di reads.
I would rather ask for another bit in the case of
write that tells that the whole write transaction is
over, synonymous to the old F-bit defintion for read.
regards,
Rishabh