Subject: RE: Review of the 07 draft

From: "Julian Satran" <[email-masked]>
Date: Sun, 5 Aug 2001 18:21:56 +0300

I've added a statement saying:

The iSCSI specific parameter change with text mode commands MUST be
performed following the SCSI rules as stated by [SAM2] and [SPC].

Julo

"Dev" <[email-masked]>@ece.cmu.edu on 04-08-2001 03:18:45

Please respond to <[email-masked]>

Sent by:  [email-masked]

To:   Jim Hafner/Almaden/IBM@IBMUS, "Robert Griswold"
      <[email-masked]>
cc:   <[email-masked]>
Subject:  RE: Review of the 07 draft

Jim,

You wrote:
>Of course, the draft doesn't say whether MODE PARAMETERS HAVE
>CHANGED unit attentions get thrown up at the SCSI layer when this happens
>at the iSCSI layer.... You later have a clarifying question (Section 3) on
>this as well.

Yes it is necessary to return  unit attentions for Mode parameter changes
(changed through SCSI command).
it is within the domain of SCSI, not iSCSI . However a note on
implementation in the iSCSI spec that
discusses the mode parameters will be good.

Thanks

Deva
Platys communications

---

From: "Dev" <[email-masked]>
Date: Tue, 7 Aug 2001 11:42:06 -0700

Julian,

I suggest that,
"The iSCSI specific parameter change with text mode commands are initiator
specific and
MUST be performed following the SCSI rules as stated by [SAM2] and [SPC]."

Because, the iSCSI mode parameter changes are implemented per initiator,
there is no need to
raise unit attention for other initiators should the mode parameters change.
The above change
explicitly states that the mode changes are effected per initiator.

Jim, are you fine with this and address the concern you raise ?

Thanks

Deva
Platys communications

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
Sent: Sunday, August 05, 2001 8:22 AM
To: [email-masked]
Subject: RE: Review of the 07 draft

Julo

Jim,

Thanks

Deva
Platys communications