Subject: RE: IPS: FCIP & this list

From: "Harmon, Robert" <[email-masked]>
Date: Wed, 22 Aug 2001 13:00:28 -0400

Perhaps the IETF IPS web page could be updated 
to point to an FCIP/iFCP site.

-----Original Message-----
From: Ralph Weber [mailto:[email-masked]]
Sent: Wednesday, August 22, 2001 12:04 PM
To: IPS Reflector
Subject: Re: IPS: FCIP & this list

David,

Your responses are most excellent.

There are minutes (well, more like discussion notes) from the 
conference call and I will ask that they be posted to this 
reflector.

The interim FCIP drafts and issues lists are maintained in PDF
format, amounting to between .2M and .5M of new material per 
week. Since this is Rome, they cannot be posted to this reflector.
It is totally impractical to translate the PDFs to text, sorry.

} WG Last Call will be conducted on this reflector for FCIP
} and iFCP.  If the FCIP authors continue in their current
} direction, those WG Last Calls could take a very long time.

There appears to be no alternative, however, I doubt that the
WG Last Calls time requirement would be shortened by more than
10% even if everything done by the FCIP authors was posted
to this reflector.  In particular, I see no reason to believe 
that the people who will raise Last Call issues will remember
earlier postings here, or bother to participate on this 
reflector prior to Last Call.  You are the sole exception 
to this perception.

Thanks for the well written, thoughtful response. I regret
that I see so few ways to be more accommodating.

Ralph...

[email-masked] wrote:

>
> Ralph,
>
> > On 17 August 2001, David Black wrote:
> >
> > > While I'm at it, it appears to me that the FCIP authors
> > > are reverting to the unfortunate habit of holding technical
> > > discussions off-line and not sharing them with the list.
> >
> > First, the FCIP authors are posting their works to this
> > reflector.  Otherwise, there would have been nothing
> > to complain about vis-a-vis the content of the FCIP
> > draft on 17 August.
>
> Unfortunately, posting the "works" is not enough.  The rationale
> behind the design decisions needs to be visible and open to
> discussion on the list.  The fact that the FCIP authors have
> discussed an issue offline will not be sufficient to resolve
> a related WG Last Call objection on the list - to oversimplify
> things slightly, the choice is between doing this right and
> doing it over.
>
> > Second, this reflector is clearly the ALL iSCSI ALL THE
> > TIME reflector.  In the last 24 hours, no fewer than two
> > new postings to this reflector have failed to include the
> > project identifier in the subject as requested by John
> > Hufferd and myself less than two weeks ago.
>
> There's a chicken and egg problem here in that the FCIP
> authors have chosen to do their technical work offline
> and invite anyone who expresses any interest in FCIP into
> that offline community including the conference calls.
> That is a major contributing factor to the current traffic
> mix on the reflector, as anyone with an FCIP issue will take
> it to the conference call.  My attitude towards the conference
> calls has been one of tolerating them *as long as*
> the issues/discussion/results are summarized to the list,
> which has not been happening.  I can't promise that the
> Area Directors will be as accommodating.
>
> > And why should people bother to prefix iSCSI postings with
> > "iSCSI:" when one of the co-chairs violated the protocol
> > as recently as yesterday morning with a posting titled
> > "FW: I-D ACTION:draft-black-ips-iscsi-security-01.txt".
>
> IIRC, the FCIP authors have stated an intention to follow
> iSCSI's security direction, making iSCSI security drafts
> (both that and draft-aboba) relevant to FCIP.  If the FCIP
> authors have made an offline decision that iSCSI security
> is no longer relevant to FCIP, than I apologize for the
> lack of tag, but I do wish someone had paid me the courtesy
> of letting me know about this change in direction ...
>
> > The FCIP authors are trying to complete their draft
> > under clearly disadvantaged circumstances.  Due diligence
> > is being made to bring issues to this reflector and to
> > respond to the concerns raised here.  And, I have no
> > doubt that the issue raised on 17 August will be addressed
> > in due course.
> >
> > But it is patent nonsense to claim that the FCIP authors
> > should be trying to use this reflector in the traditional
> > IETF manner.  This reflector belongs to iSCSI, and to all
> > practical purposes it belongs ONLY to iSCSI.
>
> When in Rome ...
>
> > FCIP (and for that matter iFCP) are barely tolerated,
> > uninvited guests, or at least that is how it feels
> > every time I review the directory the day's new messages.
>
> WG Last Call will be conducted on this reflector for FCIP
> and iFCP.  If the FCIP authors continue in their current
> direction, those WG Last Calls could take a very long time.
>
> Thanks,
> --David
>
> ---------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 42 South St., Hopkinton, MA  01748
> +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> [email-masked]       Mobile: +1 (978) 394-7754
> ---------------------------------------------------

---

From: Robert Snively <[email-masked]>
Date: Thu, 23 Aug 2001 11:35:48 -0700

Dave,

At the open-mic session at the last IETF meeting, I specifically 
raised the issue of pdf as a documentation capability.  If I
interpreted the reply correctly, the primary document must
be text only.  However, versions of the documents in pdf format
were explicitly allowed in order to bring graphics and
better text formatting to the task of making the document
clearer.

>From that, I would have expected that, as long as you provided
paired txt and pdf documents, that they should both be
available on the IETF web-sites and registered through the
I-D servers.  In the case of personal drafts, it would be
even possible that only the pdf existed, since they would be
notes and supplemental texts to the txt formal drafts.

I would like to push the IETF to step up to their stated
flexibility in this area, if they have not already done so.

Bob

> That's a judgment call.  Actually sending the PDFs to the list
> or the I-D servers is a no-no, but it would be ok to put them
> on a web site and post URLs to the list, as long as new text
> versions of the draft do go to the I-D servers at reasonable
> intervals.  It would also be ok to keep the interim PDF versions
> private among the authors until the next major revision of
> the draft is ready for the I-D servers.  There's
> no requirement to make all working notes visible.

---

From: [email-masked]
Date: Thu, 23 Aug 2001 18:15:22 -0400

Bob,

You left out the piece of Ralph's email which said
that converting the intermediate PDFs to text was not

> It is totally impractical to translate the PDFs to text, sorry.

Submitting paired text and PDF documents to the I-D servers
is fine, but keep in mind that the text version must be
self-contained by the time it is last called in the WG (i.e.,
only figures that are not crucial to understanding the
document can be omitted from the text version).

> flexibility in this area, if they have not already done so.

If you want those intermediate PDF versions on the I-D servers,
you need to push Ralph to generate their text counterparts.
The IETF secretariat stands ready to do what was promised.

Thanks,
--David

> From: Robert Snively [mailto:[email-masked]]
> Sent: Thursday, August 23, 2001 2:36 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: IPS: FCIP & this list
> 
> 
> 
> Dave,
>

---

From: Robert Snively <[email-masked]>
Date: Thu, 23 Aug 2001 18:05:32 -0700

David,

That is perfect.  Ralph already provides both the text and
pdf versions of the standards path documents.  Shall he 
just send both up together next time?  For non-standards
path documents or for informational RFCs, would we be
able to use pdf alone?  The pdf format seems to be particularly
handy for tutorial diagrams which may be found in such 
documents.

Bob

> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, August 23, 2001 3:15 PM
> To: [email-masked]; [email-masked]

---

From: [email-masked]
Date: Fri, 24 Aug 2001 08:51:39 -0400

> just send both up together next time?

I presume this refers to submission of the next version of
the draft to the Internet-Draft servers.  The answer is "yes"
- send both versions to [email-masked] in one message.

> For non-standards

A text version is still required, but there should be significantly
more leeway available in leaving diagrams out of the text version
because the document's not standards track.

--David