Subject: Re: iSCSI: draft 7: remove S bit and Status field from the Data-i (fwd)

From: Dave Sheehy <[email-masked]>
Date: Wed, 29 Aug 2001 18:28:55 PDT

> I am sure we don't want to enter this. The sequencing rules are there to
> asure:
> 
>    that there is no deadlock (order of data must follow the order of
>    commands)
>    that the target command buffer does not overflow (MaxCmdSN) - this will
>    eliminate an "unlimited number of immediate"

So, if my target concurrently supports 1000 solicited data commands and has 
buffering for 8 unsolicited data commands I must set my CmdSN window to 8 
(instead of 1008) to avoid overflowing my buffering. That does not sound to 
me like a good thing.

Dave Sheehy

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 30 Aug 2001 08:38:39 +0300

How exactly would ordering help you ease this.  Julo

Dave Sheehy <[email-masked]>@ece.cmu.edu on 30-08-2001
04:28:55

Please respond to Dave Sheehy <[email-masked]>

Sent by:  [email-masked]

To:   [email-masked] (IETF IP SAN Reflector)
cc:
Subject:  Re: iSCSI: draft 7: remove S bit and Status field from the Data-i
      (fwd)

Dave Sheehy