Subject: iSCSI: ImmediateData & InitialR2T

From: "Ayman Ghanem" <[email-masked]>
Date: Thu, 4 Oct 2001 10:42:57 -0500

Julian,

The use of these two keys is currently set to "Use: ALL". I think they
should be allowed only on the leading connection, so a second connection can
not change them on the first.

-Ayman

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 6 Oct 2001 09:48:47 +0300

Ayman,

iSCSI connections are not separate entities. Commands are sent over a 
session and connection should not be visible over a certain level.  Using 
Immediate data belongs to a very high level layer (where the endpoint 
facilities are handled).
Connections should have nothing to say about it.

Julo

"Ayman Ghanem" <[email-masked]>
Sent by: [email-masked]
05-10-01 16:02
Please respond to "Ayman Ghanem"

        To:     <[email-masked]>
        cc: 
        Subject:        RE: iSCSI: ImmediateData & InitialR2T

The text doesn't say these are connection specific, so they must be 
session
specific. Connection 1 logs in and doesn't send the ImmediateData key
because it wants to use the default "yes". If connection 2 sends
ImmediateData=no and the target agrees to that, how is this going to 
affect
connection 1 which thinks it can send immediate data, and may actually 
have
data in flight to the target. I think these two keys should have the same
use restrictions as DataPDULength, FirstBurstSize, and MaxBurstSize, all
have Use:LO.

-Ayman

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Julian Satran
> Sent: Friday, October 05, 2001 4:24 AM
> To: [email-masked]
> Subject: Re: iSCSI: ImmediateData & InitialR2T
>
>
>
> why ?  Julo
>
>
>
>
>                     "Ayman Ghanem"
>
>                     <aghanem@cisco       To:
> <[email-masked]>
>                     .com>                cc:
>
>                     Sent by:             Subject:     iSCSI:
> ImmediateData & InitialR2T
>                     owner-ips@ece.
>
>                     cmu.edu
>
>
>
>
>
>                     04-10-01 17:42
>
>                     Please respond
>
>                     to "Ayman
>
>                     Ghanem"
>
>
>
>
>
>
>
>
> Julian,
>