Subject: Re: ips : Negotiation Reset.

From: "Julian Satran" <[email-masked]>
Date: Wed, 10 Oct 2001 17:27:30 +0300

8.7 has all the answers. Julo

                    Santosh Rao                                                               
                    <santoshr@cup.       To:     IPS Reflector <[email-masked]>              
                    hp.com>              cc:                                                  
                    Sent by:             Subject:     ips : Negotiation Reset.                
                    owner-ips@ece.                                                            
                    cmu.edu                                                                   

                    09-10-01 03:44                                                            
                    Please respond                                                            
                    to Santosh Rao                                                            

Julian,

The reject reason code "Negotiation Reset" is listed (newly) in Section
3.17.1.

If one of the text commands from an initiator were to be rejected by the
target for some other reason code than "Negotiation Reset", what is the
effect of such a reject on the operational parameters ?

Are'nt all operational parameters reset, any time a text exchange ends
unsuccessfully ? I suggest the draft clearly state that ANY
un-successful termination of a login/text exchange results in a reset of
operational parameters. The "Negotiation Reset" reject reason code can
be removed as well.

2) Also, what does the phrase "reset an operational parameter
negotiation " mean ? Are the parameters reset to their default values ,
or are they reset to their previous values ? This needs to be explicitly
clarified.

Thanks,
Santosh

--
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: Santosh Rao <[email-masked]>
Date: Wed, 10 Oct 2001 09:20:40 -0700

Julian,

(I think I did'nt come across the first time. Here's another attempt !)

Why is the reject reason code "Negotiation Reset" required ? Per Section
8.7, any failure of a text cmd/rsp while in FFP causes a "negotiation
reset" (i.e. operational parameters are reset to thee values agreed upon
during an earlier successful negotiation). 

So, why do you need an explicit reason called "negotiation reset" (?)
Any failure of a text cmd at the target end would be conveyed through
either a "data digest error" or "protocol error". The operational
parameters are understood to be reset on any failure of the text
sequence.

Also, I suggest that the reject reason codes 0x09 & 0x0a (Bookmark
Reject) be removed and replaced by a reason called "Invalid Target
Transfer Tag".  (now that bookmarks are gone.)

Thanks,
Santosh