Subject: iSCSI: Third Party Copy

From: "Ron Cohen" <[email-masked]>
Date: Tue, 30 Oct 2001 13:05:53 -0000

I was looking through the Extended Copy command in SPC-2 and came across the problem of the format of a Target Descriptor for an iSCSI device.  The current format for a Target Descriptor is 32-bytes which does not provide much in the way of possibilities for identifying a source or destination device in terms of its iSCSI name.  If this has been handled already, can anyone direct me to the references which discuss the implementation of the Extended Copy command in an iSCSI SAN. 

Ronald Cohen
E-mail:  [email-masked]
Telephone:  +44 (0) 117 930 9615

---

From: David Dillard <[email-masked]>
Date: Tue, 30 Oct 2001 09:16:36 -0500

Ron,
 
Take a look at section 2.3 and appendix F.  These areas discuss using the
CHANGE ALIASES and REPORT ALIASES commands to handle this issue.

David

-----Original Message-----
From: Ron Cohen [mailto:[email-masked]]
Sent: Tuesday, October 30, 2001 8:06 AM
To: ips
Subject: iSCSI: Third Party Copy

I was looking through the Extended Copy command in SPC-2 and came across the
problem of the format of a Target Descriptor for an iSCSI device.  The
current format for a Target Descriptor is 32-bytes which does not provide
much in the way of possibilities for identifying a source or destination
device in terms of its iSCSI name.  If this has been handled already, can
anyone direct me to the references which discuss the implementation of the
Extended Copy command in an iSCSI SAN. 
 
Ronald Cohen
E-mail:  [email-masked] <mailto:[email-masked]> 
Telephone:  +44 (0) 117 930 9615