Subject: Re: iSCSI - TTT in negotiations

From: "Julian Satran" <[email-masked]>
Date: Wed, 10 Oct 2001 19:17:02 +0300

Bookmarks (TTT) are not mandated for a a general purpose negotiation (a 
sequence of text request responses). We created it for long responses 
mainly (SendTargets and futures)..

What we are proposing now is to mandate it for every request/response that 
has F=0 and use it to reset/time-out
a negotiation in general.

Julo

Santosh Rao <[email-masked]>
Sent by: [email-masked]
10-10-01 18:05
Please respond to Santosh Rao

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        Re: iSCSI - TTT in negotiations

Julian,

I thought we already had the below mechanism in place since 7.9x and TTT
in text cmd/rsp had already replaced the bookmark mechanisms.

What, then, is being proposed below ??

- Santosh

Julian Satran wrote:
> 
> Dear colleagues,
> 
> It occurred to us that we may want to have a simple (more regular) way
> to "index" at target into ongoing text negotiations (not login) and we
> may want the target to be able to set it's TTT whenever the F bit is
> not 0 and to mandate the initiator to copy it in the next text command
> in the chain.  This might make bookmarks and long negotiations behave
> similarly (and time-out,/ be reset similarly).
> 
> Comments?
> 
> Julo

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: "Deva-Adaptec" <[email-masked]>
Date: Wed, 10 Oct 2001 10:15:07 -0700

Julian,

If it is being done for general purpose also, how will the initiator know if
a target has a long text to send and wait for it, when F bit is zero? Am I
missing something?

Deva
Adaptec

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
  Sent: Wednesday, October 10, 2001 9:17 AM
  To: [email-masked]
  Subject: Re: iSCSI - TTT in negotiations

  Bookmarks (TTT) are not mandated for a a general purpose negotiation (a
sequence of text request responses). We created it for long responses mainly
(SendTargets and futures)..

  Julo

  Julian,

  - Santosh