Subject: RE: iSCSI : iSCSI parameter default values

From: Robert Snively <[email-masked]>
Date: Tue, 2 Oct 2001 08:45:05 -0700

Dave,

Of course there can, but during normal operation, all of
them are either data or commands, since SCSI has no other
outbound transactions from an initiator.  In either case,
they are useful functions that overlap and make proper use
of the link during any latency periods.  

If a target is capable of handling data immediately following
a command (by allowing any form of unsolicited data, immediate
or not), then a wise initiator will help the target along by
providing that data in a timely fashion.  That could be as 
soon as a few nanoseconds after the command, whether or not
the data was in a separate PDU.

Bob

> -----Original Message-----
> From: Dave Sheehy [mailto:[email-masked]]
> Sent: Monday, October 01, 2001 3:35 PM
> To: [email-masked]
> Subject: RE: iscsi : iscsi parameter default values
> 
> 
> 
> Robert,
> 
> > For these problems, immediate data and unsolicited data are
> > equivalent.  Frankly, I see no functional difference between
> > sending data in the same PDU and sending data in an immediately
> > following PDU.  
> 
> I just want to point out that the data is NOT required to be in an 
> immediately following PDU. There can be any number (up to MaxCmdSN) of
> intervening non-data PDUs between the command and data.
> 
> Dave
> 
>

---

From: "Rod Harrison" <[email-masked]>
Date: Tue, 2 Oct 2001 19:15:18 +0100

A target supporting unsolicited data must be prepared to receive
"other" PDUs between the command PDU and the separate DATA-IN carrying
the data.

	The most important thing for an initiator when a new command is
starting is to get the command PDU to the target as soon as possible.
This allows the target to send R2Ts for data past the FirstBurstSize.
To that end, upon receipt of a SCSI CDB from the host an initiator
could immediately queue a DMA, then build and send the command PDU.
Many other CDBs could be processed in this way before the first DMA
completes, in which case the target may see a series of command PDUs
before it sees any DATA-OUTs. The only limitation I can find in the
spec in this area is the last paragraph of 2.2.5 (v08) which says the
initiator MUST send unsolicited data on the same connection and in the
same order as the commands.

	- Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Robert Snively
Sent: Tuesday, October 02, 2001 4:45 PM
To: 'Dave Sheehy'; [email-masked]
Subject: RE: iSCSI : iSCSI parameter default values

Dave,

Bob