Subject: iSCSI: MaxBurstSize clarification

From: "Dave Peterson" <[email-masked]>
Date: Tue, 16 Oct 2001 11:43:57 -0500

The most recent text I could find regarding MaxBurstSize:

"Initiator and target negotiate maximum SCSI data payload in bytes in an
Data-In or a solicited Data-Out iSCSI sequence (a sequence of Data-In or
Data-Out PDUs ending with a Data-In or Data-Out PDU with the F bit set to
one)."

Given the text above and a negotiated MaxBurstSize=64k, if the target
receives a 256k read request
the target is required to send four 64k sequences. IOW, the target is not
allowed to send a 256k
sequence.

Correct?

Dave

---

From: "Julian Satran" <[email-masked]>
Date: Tue, 16 Oct 2001 21:22:13 +0300

That is correct.
It has to set the F flag for times (and the A flag it wants acks).

Regards,
Julo

"Dave Peterson" <[email-masked]>
Sent by: [email-masked]
16-10-01 18:43
Please respond to "Dave Peterson"

        To:     "Ips@Ece. Cmu. Edu" <[email-masked]>
        cc: 
        Subject:        iSCSI: MaxBurstSize clarification

Correct?

Dave