Subject: iSCSI:Login Phase and SessionType

From: "John Hufferd" <[email-masked]>
Date: Sun, 7 Oct 2001 15:30:50 -0700

Julian,
Section 5,  Login Phase, contains the statement

"The initial Login request MUST include the InitiatorName and SessionType
key=value pairs."

Since the SessionType key=value pair has a default of normal, perhaps the
above quoted text is not correct.

Perhaps the text should read,

"The initial Login request MUST include the InitiatorName and MAY contain
SessionType key=value pairs."

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136
Internet address: [email-masked]

---

From: "Julian Satran" <[email-masked]>
Date: Mon, 8 Oct 2001 14:55:29 +0300

Correct. The text will be:

The initial Login request MUST include the InitiatorName key=value pair. 
The initial Login request MAY also include the SessionType key=value pair 
in which case if the SessionType is not "discovery" then the initial Login 
Request MUST also include the key=value pair TargetName.

Thanks,
Julo

John Hufferd@IBMUS
08-10-01 00:30

        To:     Julian Satran/Haifa/IBM@IBMIL@IBMDE
        cc:     [email-masked]
        From:   John Hufferd/San Jose/IBM@IBMUS
        Subject:        iSCSI:Login Phase and SessionType

Julian,

.
.
.
John L. Hufferd