Subject: RE: iSCSI minimum PDU length

From: "Martin, Nick" <[email-masked]>
Date: Wed, 24 Oct 2001 14:26:52 -0500

Julian,

This is for the data after the PDU header right?
This will be the guaranteed lowest value anyone will be forced to deal
with.
Implementations may negotiate for any value greater than or equal to
this value.

This is acceptable and it is a good choice because it is the largest
power of 2 that will fit within minimum Ethernet MTU of ~1500 and leaves
plenty of room for iSCSI and LLP headers.

Thanks,
Nick

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Wednesday, October 24, 2001 12:35 PM
To: [email-masked]
Subject: iSCSI minimum PDU length

With no votes against we have settled (again) on single PDU length (per 
connection, per direction) for all types of PDUs.
But I think we erred on the low side by suggesting 64 as a minimum. It
is 
low (it was mentioned) and bad for text request/response.

How about settling for 1024?

Julo

---

From: Santosh Rao <[email-masked]>
Date: Wed, 24 Oct 2001 13:52:54 -0700

Does the MaxRecvPDULength include the AHS length ? 

- Santosh

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################