Subject: Re: iSCSI: NOPs on discovery session

From: "John Hufferd" <[email-masked]>
Date: Thu, 25 Oct 2001 21:19:37 -0700

Ayman,
SendTargets is not that long of a process,  if it times out, drop it and
try again, or issue the SendTargets again.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136
Internet address: [email-masked]

"Ayman Ghanem" <[email-masked]>@ece.cmu.edu on 10/25/2001 08:29:00 PM

Sent by:  [email-masked]

To:   <[email-masked]>
cc:
Subject:  iSCSI: NOPs on discovery session

Julian,

I am not sure if this came up before, but we also need to include NOP-OUT
to
the set of commands allowed on the discovery session. An initiator may keep
the discovery session active, and send NOP-OUT to ping the target, or in
response to a target ping.

-Ayman

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 26 Oct 2001 11:38:17 +0300

Ron,

We are defining a wire protocol so that we should not be concerned if 
closing is mandatary or not.
An open discovery session could be used (with proprietary exchanges) to 
announce new LUN and target creation.

Julo

"Ron Cohen" <[email-masked]>
Sent by: [email-masked]
26-10-01 08:16
Please respond to "Ron Cohen"

        To:     "ips" <[email-masked]>
        cc: 
        Subject:        Re: iSCSI: NOPs on discovery session

This brings up an interesting point:

Is it intended that discovery sessions remain open?
Should an initiator close a discovery session after the SendTargets 
command
has completed?
Should a target request a logout and session closure if an initiator does
not close the session?
What would the application of leaving a discovery session open be?

Ron

----- Original Message -----
From: "Ayman Ghanem" <[email-masked]>
To: <[email-masked]>
Sent: Friday, October 26, 2001 4:29 AM
Subject: iSCSI: NOPs on discovery session

to

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 26 Oct 2001 11:41:34 +0300

You are probably right. Messages could be used for new target discovery.

Comments?

Julo

"Ayman Ghanem" <[email-masked]>
Sent by: [email-masked]
26-10-01 05:29
Please respond to "Ayman Ghanem"

        To:     <[email-masked]>
        cc: 

Julian,

I am not sure if this came up before, but we also need to include NOP-OUT 
to
the set of commands allowed on the discovery session. An initiator may 
keep
the discovery session active, and send NOP-OUT to ping the target, or in
response to a target ping.

-Ayman

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 27 Oct 2001 12:40:48 +0300

Somesh,

NOPs are used for more than keep alive. They carry number acknowledgements 
and are done by the iSCSI layer while TCPs keep alive being kept at the 
TCP level does not say anything about the layers above (usually works 
between  brain-dead machines).  In general the higher the level of a 
"keep-alive" the more functional it is.

Julo

"Somesh Gupta" <[email-masked]>
Sent by: [email-masked]
27-10-01 03:31
Please respond to somesh_gupta

        To:     "Ayman Ghanem" <[email-masked]>, <[email-masked]>
        cc: 
        Subject:        RE: iSCSI: NOPs on discovery session

Ayman,

It is not completely clear what the objective of the
NOP command is? TCP itself has a keep-alive "feature"
that can be used to ensure that the system at the
other end is alive. So you don't need anything else
to ensure that the "target is alive".

However, we could use it as an opportunity to add
another feature in the protocol and reinvent TCP
twice.

Somesh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Ayman Ghanem
> Sent: Thursday, October 25, 2001 8:29 PM
> To: [email-masked]
> I am not sure if this came up before, but we also need to include 
> NOP-OUT to

---

From: "Peter Mellquist" <[email-masked]>
Date: Mon, 29 Oct 2001 15:27:53 -0800

Changes to targets/LUNs should be announced via unsolicited SLP. Since we
are already pushing SLP, it makes sense to use it. A target server utilizing
SLP in this manner would not need a long lived discovery session around. As
far as 'pinging' the target via a NOP-OUT I'm not sure of the intent?? If
one would like to determine if the target server is up and running, this can
also be accomplished via standard protocols such as SNMP. Is there currently
an iSCSI MIB object to determine the health/status of a target server? MIB objects 
could be used to monitor the status / health of each session as well.

-peter

Peter Mellquist
Seven-Systems

----- Original Message -----
From: "Julian Satran" <[email-masked]>
To: <[email-masked]>
Sent: Friday, October 26, 2001 12:38 AM
Subject: Re: iSCSI: NOPs on discovery session

> NOP-OUT