Subject: RE: Question

From: "shesha bhushan" <[email-masked]>
Date: Thu, 25 Oct 2001 18:55:06

If we assumme that we are transferring scsi packets over the local LAN where 
there is no congestion, can we actually send the packets only on IP ???? I 
have read thru the some doccuments. But i havent got a clear picture. can 
you also suggest me how to go about in this ?????

Thanks
Shesha Bhushan S
Research Assistant
Arizona State University

>From: "Sukanta Ganguly" <[email-masked]>
>Reply-To: [email-masked]
>To: [email-masked],   "shesha bhushan" 
><[email-masked]>, "IPS" <[email-masked]>
>Subject: RE: Question
>Date: Thu, 25 Oct 2001 07:21:06 -0700
>
>Well TCP's congestion control will still be functional but the the iSCSI 
>cannot make much use of it as it sits at a higher layer than TCP. What 
>really is required is a congestion control within the iSCSI layer and run 
>it over plain IP, that would be the most efficient way of doing it. I agree 
>to that some amount of TCP like congestion control will be built into iSCSI 
>but will be much less than the overheads of the TCP layer (their are 
>multiple ways of achieving reliability and congestion avoidance on UDP), 
>and also will make useful sense for the iSCSI layer.
>   I don't know whether it is too late of not, cause I see many companies 
>spending a huge amount of money doing TCP offloads. According to them iSCSI 
>is going to benefit out of it. Yeah it make the un-optimal way of doing 
>SCSI over IP a little more fast by having a dedicated processor, but is it 
>the most optimal way of doing the work ????
>   I have nothing against TCP offload. but lets have a good iSCSI solution 
>rather than patching up a unoptimal one.
>
>SG
>
>
>*********** REPLY SEPARATOR  ***********
>
>On 10/24/2001 at 2:25 PM Somesh Gupta wrote:
>
> >The question is not crazy at all (the answer
> >might be :-)). New protocols are required (and
> >really should for everyone's benefit) implement
> >some congestion avoidance mechanism.
> >
> >Currently the easiest way to achieve this is to
> >use TCP. Unfortunately we do not depend enough
> >on it, leading to significant complexity
> >in the protocol.
> >
> >Somesh
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> >> shesha bhushan
> >> Sent: Wednesday, October 24, 2001 6:39 PM
> >> To: [email-masked]
> >> Subject: Question
> >>
> >>
> >> Hi,
> >>   I am doing a research project at Arizona State University on SCSI and
> >> iSCSI. I was going through both the protocols. I have a crazy question.
> >> iSCSI = SCSI/(TCP/IP). But SCSI is a reliable protocol so is TCP.
> >> so can't
> >> we just try to send SCSI packets on IP or SCSI/UDP. Any & All
> >> comments are
> >> welcome.
> >>
> >> Thanks
> >> Shesha Bhushan S
> >> Research Assistant
> >> Arizona State University
> >>
> >>
> >> _________________________________________________________________
> >> Get your FREE download of MSN Explorer at
> >http://explorer.msn.com/intl.asp
> >>
> >>
>
>
>

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: "Bill Strahm" <[email-masked]>
Date: Thu, 25 Oct 2001 13:45:06 -0700

Ok, first question I guess, is why do you want to save 20 bytes in the face
of the extra user level protocol complexity (to get in-order, reliability,
etc.).  Also it is a VERY carefully engineered LAN that doesn't have any
congestion at any time.  If you go through all of that effort, you might as
well just deploy FC..

To answer your other question, just open a RAW socket, pick a random unused
protocol number, and put the iSCSI packet into the IP data... Not hard to
do, but don't expect it to go through firewalls, NAT, etc. and you will have
to add something to the header to help address it (removing a few bytes from
the 20 that you are saving, maybe 2 for a small implementation)

Those that try to implement around TCP are doomed to re-implement it
(usually poorly)

Bill
+========+=========+=========+=========+=========+=========+=========+
Bill Strahm     Software Development is a race between Programmers
Member of the   trying to build bigger and better idiot proof software
Technical Staff and the Universe trying to produce bigger and better
[email-masked] idiots.
(503) 601-0263  So far the Universe is winning --- Rich Cook

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
shesha bhushan
Sent: Thursday, October 25, 2001 6:55 PM
To: [email-masked]; [email-masked];
[email-masked]
Subject: RE: Question

Thanks
Shesha Bhushan S
Research Assistant
Arizona State University