Subject: iSCSI:SCSI responses for iSCSI errors

From: "Ken Sandars" <[email-masked]>
Date: Wed, 31 Oct 2001 17:08:57 -0000

Gidday all,

With reference to 3.4.2, when a target detects an error
does:

'...MUST wait until it receives a Data PDU with the F
bit set, in the last expected sequence, before sending the 
Response PDU' 

imply the target waits for the entire Expected Data Transfer
Length worth to be transferred? 

If so, the target may have to R2T for the solicited data! Should
it R2T with 'correct' values, regardless of what the initiator sent?

In this case it is possible that this clean-up action actually solicits
all the required data, however, the command is still going to get
a response with sense data indicating an abort.

Is it possible to just reject the original command PDU when validity 
checking picks up one of these errors? Any Data-Out PDUs
in the pipeline which belong to this rejected command can be silently
discarded by the target. What am I missing?

Thoughts?

Ken Sandars
[email-masked]
Eurologic Systems
+44 117 930 9616

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 31 Oct 2001 11:39:55 -0800

Ken,

> Length worth to be transferred? 

I don't believe so.  Target is expected to wait for the data in the pipe
to drain (I believe this section is describing the fundamental behavior
from the context of one outstanding R2T, section 8.4 spells out what
ought to be done for multiple).  So, the target does not have to generate 
a new R2T.

The above behavior is to take care of the race condition where the
initiator re-uses the same ITT (on receiving a response)  for a different 
task on a different connection, when the stale data is still in the pipe.

> Is it possible to just reject the original command PDU 

If you meant the usage of Reject PDU, the answer is no - as section
8.2 clearly calls out.  A response PDU must be returned for concluding
an instantiated task.

Hope that helps.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard MS 5668 
Roseville CA 95747