Subject: Re: Data Digest Error question

From: "Julian Satran" <[email-masked]>
Date: Fri, 5 Oct 2001 14:04:11 +0300

Yes there is a typo (the second appearance is yes).
However the function is correctly stated as OR  i.e. the result is yes if 
at least one of them wants order (it requires both to agree to say no).

Julo

"Mallikarjun C." <[email-masked]>
Sent by: [email-masked]
04-10-01 21:35
Please respond to cbm

        To:     ips <[email-masked]>
        cc: 
        Subject:        Re: Data Digest Error question

"Mallikarjun C." wrote:
> 
> Prasenjit,
> 
> The Reject mechanism is intended to be uniformly applicable to
> all (recovery-savvy and otherwise) targets.
> 
> Recovery R2T, OTOH, is only for ErrorRecoveryLevel>=1 capable
> implementations (DataSequenceInOrder=true 

Sorry, that was supposed to be DataSequenceInOrder=no.

Also, it appears to me that the result function for this key
should be AND, and there's a typo in the description - it says
"no" for both cases.  Julian, comments?

>as well, I think this
> needs to be called out in its description), since a recovery R2T
> implies going back in the data stream.
> 
> The delivery subsystem failure status is the final termination
> status (even though there were several good data PDUs after the
> failed one) for ErrorRecoveryLevel=0 implementations, sent after
> waiting for the F-bit.
> 
> Hope that helps.
> 
> Regards.
> --
> Mallikarjun
> 
> Mallikarjun Chadalapaka
> Networked Storage Architecture
> Network Storage Solutions Organization
> MS 5668 Hewlett-Packard, Roseville.
> [email-masked]
> 
> Prasenjit Sarkar wrote:
> >
> > This question relates to how the target handles data digest errors for 
data
> > pdus.
> >
> > The spec says the target has to send a reject pdu with the attached 
pdu
> > header
> > + (recovery R2T OR delivery subsystem failure status)
> >
> > Why do we need two mechanisms? Wouldnt the pdu header indicate what 
needed
> > to be transmitted? Maybe a word of motivation might help.
> >
> >    Prasenjit Sarkar
> >    Research Staff Member
> >    IBM Almaden Research
> >    San Jose

-- 
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668 Hewlett-Packard, Roseville.
[email-masked]

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 05 Oct 2001 11:19:07 -0700

Julian Satran wrote:
> However the function is correctly stated as OR  i.e. the result is yes
> if at least one of them wants order (it requires both to agree to say
> no).

Yes, you are right.  I guess I was thinking negative logic.  Thanks.
-- 
Mallikarjun 

Mallikarjun Chadalapaka

> 
> Julo
> 
>   "Mallikarjun C."
>   <[email-masked]>                        To:        ips
>   Sent by: [email-masked]   <[email-masked]>
>                                            cc:
>   04-10-01 21:35                           Subject:        Re: Data
>   Please respond to cbm            Digest Error question
> 
> 
> 
> "Mallikarjun C." wrote:
> >
> > Prasenjit,
> >
> > > This question relates to how the target handles data digest errors
> for data
> > > pdus.
> > >
> > > The spec says the target has to send a reject pdu with the
> attached pdu
> > > header
> > > Why do we need two mechanisms? Wouldnt the pdu header indicate
> what needed