Subject: iscsi: discovery session - logout

From: andy currid <[email-masked]>
Date: Mon, 8 Oct 2001 09:01:35 -0700 (PDT)

iSCSI version 8, sections 2.4 and and Appendix D.31, states that
the only command accepted in full feature phase of a discovery
session is a Text Request with the SendTargets key.

Shouldn't a discovery session also accept a Logout command?

Andy
--
Andy Currid                                       [email-masked]
Server Products Group                       http://www.windriver.com
Wind River Networks                         Phone : (1) 510 749 2191
500 Wind River Way, Alameda, CA 94501       Fax   : (1) 510 749 2560

---

From: Dave Sheehy <[email-masked]>
Date: Tue, 09 Oct 2001 12:28:14 PDT

> I agree that a discovery session type should be capable of processing a
> logout command. This keeps the initiator's close_session() code the same
> for normal & discovery sessions. 
> No need to special case the handling of discovery sessions.

Agreed, I don't see any compelling reason for this special case behavior.

Dave

> 
> - Santosh
> 
> 
> Julian Satran wrote:
> > 
> > I am not sure that you want this.
> > You may just close the connections.
> > The idea was that discovery may be implemented by a gateway that has
> > not many other things.
> > 
> > But we can add Logout if many more on the list want it (just to clean
> > the SSID records).
> > 
> > Julo
> > 
> >   andy currid <[email-masked]>
> >                                           To:        [email-masked]
> >   Sent by: [email-masked]          cc:
> >                                           Subject:        iscsi:
> >   08-10-01 18:01                  discovery session - logout
> >   Please respond to andy currid
> > 
> > 
> ##################################
> Santosh Rao
> Software Design Engineer,
> HP-UX iSCSI Driver Team,
> Hewlett Packard, Cupertino.
> email : [email-masked]
> Phone : 408-447-3751
> ##################################
>