Subject: Question

From: "shesha bhushan" <[email-masked]>
Date: Wed, 24 Oct 2001 18:38:32

Hi,
  I am doing a research project at Arizona State University on SCSI and 
iSCSI. I was going through both the protocols. I have a crazy question. 
iSCSI = SCSI/(TCP/IP). But SCSI is a reliable protocol so is TCP. so can't 
we just try to send SCSI packets on IP or SCSI/UDP. Any & All comments are 
welcome.

Thanks
Shesha Bhushan S
Research Assistant
Arizona State University

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: "Somesh Gupta" <[email-masked]>
Date: Wed, 24 Oct 2001 14:25:56 -0700

The question is not crazy at all (the answer
might be :-)). New protocols are required (and
really should for everyone's benefit) implement
some congestion avoidance mechanism.

Currently the easiest way to achieve this is to
use TCP. Unfortunately we do not depend enough
on it, leading to significant complexity
in the protocol.

Somesh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> shesha bhushan
> Sent: Wednesday, October 24, 2001 6:39 PM
> To: [email-masked]
> Subject: Question
>
>
> Hi,

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Thu, 25 Oct 2001 07:21:06 -0700

Well TCP's congestion control will still be functional but the the iSCSI cannot make much use of it as it sits at a higher layer than TCP. What really is required is a congestion control within the iSCSI layer and run it over plain IP, that would be the most efficient way of doing it. I agree to that some amount of TCP like congestion control will be built into iSCSI but will be much less than the overheads of the TCP layer (their are multiple ways of achieving reliability and congestion avoidance on UDP), and also will make useful sense for the iSCSI layer.
  I don't know whether it is too late of not, cause I see many companies spending a huge amount of money doing TCP offloads. According to them iSCSI is going to benefit out of it. Yeah it make the un-optimal way of doing SCSI over IP a little more fast by having a dedicated processor, but is it the most optimal way of doing the work ????
  I have nothing against TCP offload. but lets have a good iSCSI solution rather than patching up a unoptimal one.

SG

*********** REPLY SEPARATOR  ***********