Subject: Questions

From: "Ron Cohen" <[email-masked]>
Date: Wed, 17 Oct 2001 08:58:56 +0100

Please excuse if the questions I ask have already been handled.  I have just come back to reading the reflector after changing jobs.

1.  In section 2.2.7  it states that for a discovery session the iSCSI Target Name can be ignored.  It also states the default name "iSCSI" is reserved and is not used as an indivdiual initiator or target name.  Two points.  1) Does this imply that the canonical name "iscsi" no longer exists or can it still be used for a discovery session?  2) If the name still exists, is it case sensitive and has its syntax changed from "iscsi" to "iSCSI"?

2.  As I understand it, two sessions may be established between an iSCSI initiator and an iSCSI target by setting different values to the ISID.  If we consider that an iSCSI session is roughly an I_T Nexus, would this constitute two nexii?  How should SCSI device reservations and operating mode parameters (Mode Sense/Mode Select) be handled in this case?

To be continued...

Ronald Cohen
E-mail:  [email-masked]
Telephone:  +44 (0) 117 930 9615

---

From: Mark Bakke <[email-masked]>
Date: Wed, 17 Oct 2001 09:51:34 -0500

Ron-

I can reply to the first question.  The canonical name "iscsi"
is no longer used.  Also, only lower-case characters are allowed
in iSCSI names, so "iSCSI" is no longer be a valid iSCSI name.

--
Mark

> Ron Cohen wrote:
> 1.  In section 2.2.7  it states that for a discovery session the iSCSI Target Name can be
> ignored.  It also states the default name "iSCSI" is reserved and is not used as an indivdiual
> initiator or target name.  Two points.  1) Does this imply that the canonical name "iscsi" no
> longer exists or can it still be used for a discovery session?  2) If the name still exists, is it
> case sensitive and has its syntax changed from "iscsi" to "iSCSI"?

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054