Subject: iSCSI - TTT in negotiations

From: "Julian Satran" <[email-masked]>
Date: Wed, 10 Oct 2001 15:03:29 +0300

Dear colleagues,

It occurred to us that we may want to have a simple (more regular) way to 
"index" at target into ongoing text negotiations (not login) and we may 
want the target to be able to set it's TTT whenever the F bit is not 0 and 
to mandate the initiator to copy it in the next text command in the chain. 
 This might make bookmarks and long negotiations behave similarly (and 
time-out,/ be reset similarly).

Comments?

Julo

---

From: Santosh Rao <[email-masked]>
Date: Wed, 10 Oct 2001 09:05:52 -0700

Julian,

I thought we already had the below mechanism in place since 7.9x and TTT
in text cmd/rsp had already replaced the bookmark mechanisms.

What, then, is being proposed below ??

- Santosh

Julian Satran wrote:
> 
> Dear colleagues,
> 
> It occurred to us that we may want to have a simple (more regular) way
> to "index" at target into ongoing text negotiations (not login) and we
> may want the target to be able to set it's TTT whenever the F bit is
> not 0 and to mandate the initiator to copy it in the next text command
> in the chain.  This might make bookmarks and long negotiations behave
> similarly (and time-out,/ be reset similarly).
> 
> Comments?
> 
> Julo

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################