Subject: Re: iscsi: discovery session - logout

From: "Julian Satran" <[email-masked]>
Date: Tue, 9 Oct 2001 16:41:34 +0200

I am not sure that you want this.
You may just close the connections.
The idea was that discovery may be implemented by a gateway that has not 
many other things.

But we can add Logout if many more on the list want it (just to clean the 
SSID records).

Julo

andy currid <[email-masked]>
Sent by: [email-masked]
08-10-01 18:01
Please respond to andy currid

        To:     [email-masked]
        cc: 
        Subject:        iscsi: discovery session - logout

iSCSI version 8, sections 2.4 and and Appendix D.31, states that
the only command accepted in full feature phase of a discovery
session is a Text Request with the SendTargets key.

Shouldn't a discovery session also accept a Logout command?

Andy
--
Andy Currid                                       [email-masked]
Server Products Group                       http://www.windriver.com
Wind River Networks                         Phone : (1) 510 749 2191
500 Wind River Way, Alameda, CA 94501       Fax   : (1) 510 749 2560

---

From: Santosh Rao <[email-masked]>
Date: Tue, 09 Oct 2001 08:55:12 -0700

I agree that a discovery session type should be capable of processing a
logout command. This keeps the initiator's close_session() code the same
for normal & discovery sessions. 
No need to special case the handling of discovery sessions.

- Santosh

Julian Satran wrote:
> The idea was that discovery may be implemented by a gateway that has
> not many other things.
> 
> But we can add Logout if many more on the list want it (just to clean
> the SSID records).
> 
> Julo
> 
>   Sent by: [email-masked]          cc:
>                                           Subject:        iscsi:
>   08-10-01 18:01                  discovery session - logout

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: andy currid <[email-masked]>
Date: Tue, 9 Oct 2001 10:01:12 -0700 (PDT)

Julian

As a target implementor, I'll certainly handle a discovery session
simply having its connection closed, as I do for all sessions.

As an initiator implementor, I'd like the option of closing down
a discovery session the same way I close down a normal session -
with a logout. It makes my code more uniform.

The current spec prohibits closure of a discovery session with
a logout. I think the wording should be changed to permit use
of logout on discovery sessions, without requiring that it be
used. That still permits lightweight gateways, etc., to not
use logout if needs be.

Regards

Andy