Subject: RE: how much "Desired Data Transfer Length" in R2T

From: Nitin Dhingra <[email-masked]>
Date: Mon, 22 Oct 2001 16:27:00 +0530

Hi sastry,
What you specified is during negotiation, I am referring to after the
negotiation, when 
DataPDULength has been decided. But Later when R2T's needs to be send from
target, 
examples have been given in the draft that depicts one R2T is sent from the
target and it receives 
2 Data PDU's. It means that target specified more size than DataPDULength
in the R2T, on what 
basis did the target decide that.

Thanks,
nitin

 -----Original Message-----
From: 	Subrahmanya Sastry K.V [mailto:[email-masked]] 
Sent:	Monday, October 22, 2001 3:32 AM
To:	Nitin Dhingra
Cc:	[email-masked]
Subject:	Re: how much "Desired Data Transfer Length" in R2T

Nitin,

I think  the "Desired Data Tranfer Length" field of R2T PDU  should be equal
to
the DataPDULength
value that the initiator has sent to the target during text parameter
negotiation. Since the DataPDULength
can be different in the two directions, the initiator sends this value to
the
target as DataPDULength=<value>.
So the initiator only  sends/receives a PDU having length less than or equal
to  the negotiated DataPDULength
(non-zero).

Any comments are welcome..

Sastry

Nitin Dhingra wrote:

> How is the target going to decide how much "desired data transfer length"
he
> has
> to fill apart from the negotiated "DataPDULength".
>
> Thanks in advance,
> nitin

---

From: "Subrahmanya Sastry K.V" <[email-masked]>
Date: Mon, 22 Oct 2001 16:57:36 +0530

Hi Nitin,

It seems that the case you mentioned (send R2T, get two Data PDUs)
can happen when the DataPDULength value of the target is greater than the
DataPDULength value of the initiator because
the minimum of the two DataPDULengths is selected.
In that case, the target may get more than one DataPDU in response to one R2T.
The target knows the end of data when the F bit is set in the DataPDU that it
receives.

Any more comments?

Sastry

---

From: "Subrahmanya Sastry K.V" <[email-masked]>
Date: Mon, 22 Oct 2001 18:43:56 +0530

inline

Nitin Dhingra wrote:

> in the R2T,

As per section 3.8 of iscsi-draft-08:

"The data length of the Data PDU MUST
  not exceed the Desired Data Transfer Length specified in the R2T. "

This means that the target may mention a greater value for Desired Data
Transfer Length
than the initiator can send at a time i.e.,  the DataPDULength of the
initiator.
In that case the data lengths of one or more Data PDUs (from the initiator)
add up to  the value of Desired Data Transfer Length. This is indicated by the
F bit
of the last Data PDU set to 1.

Suppose the initiator has the DataPDULength of 5k.

The target asked for 10k (Desired Data Tranfer Length) and sent an R2T.

Now the initiator sends two DataPDUs of data length 5k each to fulfill the
request.

> on what

This is what I understood. comments ?

Sastry