Subject: iSCSI: NOPs on discovery session

From: "Ayman Ghanem" <[email-masked]>
Date: Thu, 25 Oct 2001 22:29:00 -0500

Julian,

I am not sure if this came up before, but we also need to include NOP-OUT to
the set of commands allowed on the discovery session. An initiator may keep
the discovery session active, and send NOP-OUT to ping the target, or in
response to a target ping.

-Ayman

---

From: "Ron Cohen" <[email-masked]>
Date: Fri, 26 Oct 2001 07:16:25 +0100

This brings up an interesting point:

Is it intended that discovery sessions remain open?
Should an initiator close a discovery session after the SendTargets command
has completed?
Should a target request a logout and session closure if an initiator does
not close the session?
What would the application of leaving a discovery session open be?

Ron

---

From: "Somesh Gupta" <[email-masked]>
Date: Fri, 26 Oct 2001 18:31:18 -0700

Ayman,

It is not completely clear what the objective of the
NOP command is? TCP itself has a keep-alive "feature"
that can be used to ensure that the system at the
other end is alive. So you don't need anything else
to ensure that the "target is alive".

However, we could use it as an opportunity to add
another feature in the protocol and reinvent TCP
twice.

Somesh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Ayman Ghanem
> Sent: Thursday, October 25, 2001 8:29 PM
> To: [email-masked]