Subject: RE: FCencap: List ALL SOF/EOF codes

From: Vi Chau <[email-masked]>
Date: Wed, 7 Nov 2001 11:08:38 -0800

Ralph,

   The first FCIP draft included the entire SOF/EOF
table from FC-BB. It was during the Orlando meeting
when we decided to drop class 1 support because of
a lack of applications that use class 1 and thus the
table in FCIP was trimmed.

   I agree that listing all codes from FC-BB is the
right thing to do.

Vi

-----Original Message-----
From: Ralph Weber [mailto:[email-masked]]
Sent: Wednesday, November 07, 2001 5:16 AM
To: IPS Reflector
Cc: Murali Rajagopal; Franco Travostino; Rodriguez, Elizabeth
Subject: FCencap: List ALL SOF/EOF codes

Upon further reflection, I think the right thing to do
is to list all the SOF/EOF codes defined in FC-BB in
the FC Encapsulation draft.

FIRST

There is nothing in the FC Encapsulation draft other
than to omission of Class 1 SOF/EOF codes that prevents
encapsulating FC Class 1 frames for TCP transport.
Sure, a TCP ULP that is smarter than anything anybody
has thought about will be required to do it.  BUT
there is (or should be) nothing the the FC Encapsulation
draft that prevents such a protocol from being invented.
AND the FC Encapsulation draft specifically says that
you need the wisdom of some other protocol document in
order to get any use out of the FC Encapsulation draft.
Why force the mad man that devises a way to transport
Class 1 over TCP/IP to revise the FC Encapsulation
SOF/EOF tables?

SECOND

It is conceivable that a future version of iFCP
(or maybe even FCIP) might want to support Class 4.
Again, there is nothing in the FC Encapsulation
draft that prevents this, except the omission
of the SOF/EOF codes.

FINALLY

I believe that the elimination of all SOF/EOF
codes other than Class 2, Class 3, AND CLASS F
is a hold over from the early FCIP work, before
the FC Encapsulation was split into a separate
draft. I believe that decision was right for
FCIP but wrong for an FC Encapsulation intended
to be used by ALL FC protocols running over
TCP/IP.

Thanks for your consideration.

Ralph...

---

From: "Murali Rajagopal" <[email-masked]>
Date: Wed, 7 Nov 2001 12:02:12 -0800

Vi:

I also recollect that there was some discussion about some illegal codes in
that table either in that meeting or in one of the ensuing T11 meetings.

-Murali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Vi
Chau
Sent: Wednesday, November 07, 2001 11:09 AM
To: [email-masked]'; IPS Reflector
Subject: RE: FCencap: List ALL SOF/EOF codes

Ralph,

Vi

-----Original Message-----
From: Ralph Weber [mailto:[email-masked]]
Sent: Wednesday, November 07, 2001 5:16 AM
To: IPS Reflector
Cc: Murali Rajagopal; Franco Travostino; Rodriguez, Elizabeth
Subject: FCencap: List ALL SOF/EOF codes

FIRST

SECOND

FINALLY

Ralph...