Subject: RE: iSCSI: Representing iSCSI devices on FC fabrics

From: "Elliott, Robert" <[email-masked]>
Date: Fri, 16 Nov 2001 09:33:27 -0600

Beware than a FC WWN is not the same as an EUI-64.  They're both based
on the IEEE OUI/company_id, but the FC WWN uses the 4 most significant
bits for a "Name Address Authority" field and has 4 fewer bits available
in the vendor specified portion.

EUI-64 = (MSB) { 20-bit company_id, 
                 44-bit vendor specified } (LSB)

FC WWN = (MSB) { 4-bit NAA field, 
                 20-bit company_id, 
                 40-bit vendor specified } (LSB)
         (for the IEEE Registered NAA type)

---
Rob Elliott, Compaq Server Storage
[email-masked]

> -----Original Message-----
> From: Thanu Skariah [mailto:[email-masked]]
> Sent: Friday, November 16, 2001 1:12 AM
> To: Robert Grant
> Cc: [email-masked]'
> Subject: Re: iSCSI: Representing iSCSI devices on FC fabrics
> 
> 
> Robert,
> 
> 
>     iSCSI allows different naming formats, of which one 
> format is the EUI format  (See the example in sec 2.2 .7 and 
> the naming draft -
> http://www.ietf.org/internet-drafts/draft-ietf-ips-iscsi-name-
> disc-02.txt )
> 
>     The EUI representation  is of the form eui . <WWN>.  Each 
> FC device's WWName can be used to form the corresponding iSCSI 
> name for the  device.  This is what we are doing on a linux 
> based software FCP/iSCSI gateway that we are implementing, 
> and this is why :
> 
> (From the naming and discovery draft ):
> 
> BeginQuote "
> 
> Type "eui." (IEEE EUI format)
> 
>    The IEEE iSCSI name might be used when a manufacturer is already
>    basing unique identifiers on World-Wide Names as defined 
>    in the SCSI SPC-2 specification.
> 
>    It may also be used by a gateway representing a Fibre Channel or
>    SCSI device that is already adequately identified using a 
>    world-wide name.
> 
> " End Quote
> 
> 
> Thanks,
> Thanu

---

From: "Jim Hafner" <[email-masked]>
Date: Fri, 16 Nov 2001 07:51:51 -0800

Rob,

You make a good point.  But I think it should also be mentioned that going
the route indicated in the first reply may NOT guarantee WWUniqueness (what
if two vendors do the same thing!).

Jim Hafner

"Elliott, Robert" <[email-masked]>@ece.cmu.edu on 11/16/2001
07:33:27 am

Sent by:  [email-masked]

To:   <[email-masked]>
cc:
Subject:  RE: iSCSI: Representing iSCSI devices on FC fabrics

---

---

From: Robert Snively <[email-masked]>
Date: Fri, 16 Nov 2001 08:29:38 -0800

Folks,

Robert Grant has a legitimate concern.  The iqn.* format and the
eui.* format do not correctly map the name space used by
FCP or SCSI disk drives, which use either a Fibre Channel
name format (specified in FC-FS from www.t11.org, clause 14) 
or a SCSI format (specified in SPC-2 from www.t10.org, clause 8.4.4).
The Fibre Channel name format applies to targets, initiators,
ports, and logical units.  The SCSI format only applies to ports
and logical units.

Neither of these map to the eui.* format.  However, a 
specialized FC name format is now defined to map from
an eui.* format, which should be useful for at least some
FCP/iSCSI bridges.

You can of course map the iqn.* format very successfully by
simply including the appropriate FC WWN as part of the 
text string, but that is done at a level outside the scope
of iSCSI.

If you want to make a STANDARD way to do this (instead of
a user administered way such as iqn.*), then two new formats
could be defined:

	fc.*  =  where * equals the FC-FS clause 14 defined 64-bit value.

and   scsi.* = where * equals the multiple variable length values 
			specified in SPC-2, clause 8.4.4

Fortunately, at the logical unit level (which is the only level
that any true SCSI bigot cares about anyway :-) ), the identifier
(usually an FC WWN) is mapped through the INQUIRY command independent
of the transport mechanism.  There are several useful mappings
that can be used to instantiate iSCSI LUs in FC or vice versa.

Bob Snively                        e-mail:    [email-masked]
Brocade Communications Systems     phone:  408 487 8135
1745 Technology Drive
San Jose, CA 95110

> Sent: Thursday, November 15, 2001 11:12 PM
> To: Robert Grant
> Cc: [email-masked]'
> format is the EUI
> format  (See the example
> in sec 2.2 .7 and the naming draft -
> FC device's
> WWName
> can be used to form the corresponding iSCSI name for the 
> device.  This is what
> we are
> doing on a linux based software FCP/iSCSI gateway that we are 
> implementing, and
> this
> is why :
> 
> world-wide
>    name.
> Robert Grant wrote:
> >                         Hello all,
> >                         I have a question on the 
> representation of iSCSI
> > devices into Fibre Channel fabrics for an iSCSI-to-FC 
> "gateway" device and
> > would like to solicit people's thoughts on how best to do 
> this. A gateway
> > device will allow iSCSI devices and FCP devices to access 
> each other, but in
> > order to do this a consistent representation of the devices 
> is needed. I
> > haven't been able to reconcile the iSCSI and FCP standards 
> using what's
> > currently in the iSCSI standard, and wanted to see if there 
> was any support
> > to expanding the iSCSI standard to address this (a standard 
> solution is, of
> > course, much more preferred to every gateway vendor doing 
> it in their own
> > proprietary way). In particular, how would an iSCSI device 
> map onto Fibre
> > Channel's World Wide Name (WWN)? Would every device have 
> its own WWN, or
> > could many iSCSI devices use a single WWN? There have been 
> some discussions
> > (for example, there was even discussion of including a WWN 
> field in the
> > iSCSI Login for a Gateway to proxy with in
> > 
> http://www.pdl.cmu.edu/mailinglists/ips/mail/msg01616.html), 
> but what is the
> > current view?
> >
> >                         A first approach might be that many 
> iSCSI devices
> > could use a single WWN. This can work well for FC-AL 
> devices "directly
> > attached " to the IP network or for small FC fabrics - and where the
> > predominant interconnect and management of that 
> interconnect is the IP
> > network.
> >
> >                         This approach views the FC fabric 
> as flat (or at
> > least perhaps that FC zoning is "turned off"). As the FC 
> fabric gets bigger,
> > though, this first approach can create two layers of 
> management - one must
> > first configure the FC network and then configure the IP 
> network (since the
> > individual iSCSI devices sharing a single WWN can only be 
> zoned as a group).
> > The two layers are first "this group of iSCSI devices can 
> access this zone"
> > on the FC side and then "this iSCSI device can access this 
> FC device in this
> > zone" on the iSCSI side. If there was a clean integration 
> with FC zoning
> > (and associated management of the FC zoning), this may be avoided.
> >
> >                         A further complication is that, as 
> the FC fabric
> > gets even bigger, a single iSCSI device could end up with 
> multiple entry
> > points (i.e. paths through multiple gateways) into a single 
> FC fabric. Is
> > there any common way to represent iSCSI devices (for 
> instance, with respect
> > to WWNs) that allows the unique identification of that 
> iSCSI device - even
> > though there are multiple entrypoints onto the FC fabric? 
> The case of
> > multiple gateways (possibly from different vendors) is the 
> clearest example
> > of the need for a standard.
> >
> >                         Thank you for your time and I look 
> forward to all
> > comments/suggestions.
> >
> > Regards,
> > Rob
> >
> > Rob Grant
> > McDATA Corporation
> 
>

---

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Fri, 16 Nov 2001 17:31:39 -0500

This use of the eui. naming format will ONLY be acceptable if the iSCSI
gateway device is the only iSCSI gateway device in the world that is allowed
to "represent" these FC devices - can your implementation guarantee that?
Another iSCSI gateway on the same FC fabric (another of your gateways?)
might also use that naming convention (as Jim H points out) and that would
violate the requirements of iSCSI naming.

The eui. naming format was intended for use when the iSCSI device "owns" the
EUI number (as those FC devices "own" their WWN).  This gateway usage is not
what was intended.

Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions Org.
Hewlett-Packard
tel: +1 916 785 2656
fax: +1 916 785 0391
email: [email-masked] 

> > iSCSI Login for a Gateway to proxy with in
http://www.pdl.cmu.edu/mailinglists/ips/mail/msg01616.html), but what is the
> current view?
>
>                         A first approach might be that many iSCSI devices
> could use a single WWN. This can work well for FC-AL devices "directly
> predominant interconnect and management of that interconnect is the IP
> network.
>
>                         This approach views the FC fabric as flat (or at
> least perhaps that FC zoning is "turned off"). As the FC fabric gets
bigger,
> though, this first approach can create two layers of management - one must
> first configure the FC network and then configure the IP network (since
the
> individual iSCSI devices sharing a single WWN can only be zoned as a
group).
> The two layers are first "this group of iSCSI devices can access this
zone"
> on the FC side and then "this iSCSI device can access this FC device in
this
> zone" on the iSCSI side. If there was a clean integration with FC zoning
>                         A further complication is that, as the FC fabric
> gets even bigger, a single iSCSI device could end up with multiple entry
> points (i.e. paths through multiple gateways) into a single FC fabric. Is
> there any common way to represent iSCSI devices (for instance, with
respect
> to WWNs) that allows the unique identification of that iSCSI device - even
> though there are multiple entrypoints onto the FC fabric? The case of
> multiple gateways (possibly from different vendors) is the clearest
example
>                         Thank you for your time and I look forward to all
> comments/suggestions.
>
> Regards,
> Rob
>
> Rob Grant
> McDATA Corporation