Subject: iSCSI: Digests and Multiple Connections

From: "Prasenjit Sarkar" <[email-masked]>
Date: Thu, 29 Nov 2001 11:33:20 -0800

The standard says:

When Initiator and Target agree on a digest, this digest MUST be used
for every PDU in full feature phase.

Also, it appears that digests are a session-level parameter.

Scenario:

The first connection of a multiple-connection session agrees on digests
and proceeds to full-feature phase with digests.

What about the subsequent connections that try to login? Do these
connections
suspend digests during non-full feature phase and turn it on during
full feature.

The standard is silent on this issue.

   Prasenjit Sarkar
   Research Staff Member
   IBM Almaden Research
   San Jose

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 29 Nov 2001 23:39:07 +0200

Prasenjit,

Digests and security are connection level characteristics.

Regards,
Julo

Prasenjit Sarkar/Almaden/IBM@IBMUS
Sent by: [email-masked]
11/29/2001 09:33 PM

        To:     [email-masked]
        cc: 
        Subject:        iSCSI: Digests and Multiple Connections

The standard says:

Scenario:

   Prasenjit Sarkar
   Research Staff Member
   IBM Almaden Research
   San Jose

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 30 Nov 2001 04:45:27 +0200

Prasenjit,

The use is clearly indicated as IO in appendix D.
However I will remove the statement about keys being session only - as all 
the keys state clearly what their use is and the statement creates some 
confusion.

Regards,
Julo

Prasenjit Sarkar@IBMUS
11/30/2001 12:47 AM

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        From:   Prasenjit Sarkar/Almaden/IBM@IBMUS
        Subject:        Re: iSCSI: Digests and Multiple Connections

Julian,

My question was about digests only and you ought to put that
assertion in Appendix D to avoid confusion.

   Prasenjit Sarkar
   Research Staff Member
   IBM Almaden Research 
   San Jose

Julian Satran/Haifa/IBM@IBMIL
Sent by: [email-masked]
11/29/2001 01:39 PM

        To:     [email-masked]
        cc: 
        Subject:        Re: iSCSI: Digests and Multiple Connections

Prasenjit, 

Regards, 
Julo 

        To:        [email-masked] 
        cc:         

The standard says:

Scenario:

  Prasenjit Sarkar
  Research Staff Member
  IBM Almaden Research
  San Jose