Subject: RE: FCencap: List ALL SOF/EOF codes

From: Charles Monia <[email-masked]>
Date: Tue, 13 Nov 2001 18:48:55 -0800

Hi:

Option 3 is agreeable to me.

Charles
> -----Original Message-----
> From: Elizabeth Rodriguez [mailto:[email-masked]]
> Sent: Tuesday, November 13, 2001 11:05 AM
> To: Murali Rajagopal; Charles Monia; IPS Reflector
> Subject: RE: FCencap: List ALL SOF/EOF codes
> 
> 
> (Chair hat on)
> 
> Let me jump back in here, and summarize as I see it:
> 
> Codes from FC-BB cannot be taken intact, since there are invalid codes
> in that specification.
> Codes initially trimmed in January of this year, but Ralph correctly
> points out, that was prior to the formation of the FC encapsulation
> draft (e.g. discussion pertained directly to FCIP; did not take into
> consideration iFCP)
> 
> That said, we can modify the current FC encapsulation draft to include
> other classes of service, if we so choose.
> 
> We can choose to 
> 1) Keep the table as is.  
> Note: The current SOF/EOF codes defined in the FC encapsulation draft
> match the currently defined FC-BB-2 subset.
> 
> 2) Add Class 1 codes
> Note:  FC-MI (technical report, not a standard) does not support Class
> 1.
> Note2: Practicality of Class 1 over IP questioned.
> 
> 3) Add Class 4 codes
> Note:  Class 4 work is ongoing, but SOF/EOF codes currently 
> defined for
> class 4 unchanged.
> 
> 4) Add both class 1 and class 4 codes
> 
> I would like to solicit input from everyone on what codes people feel
> should be included in the FC encapsulation draft.
> Note:  Drafts following FC encapsulation may restrict classes 
> of service
> that draft supports.
> 
> Thanks,
> 
> Elizabeth
> 
> -----Original Message-----
> From: Murali Rajagopal [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 6:01 PM
> To: Charles Monia; IPS Reflector
> Subject: RE: FCencap: List ALL SOF/EOF codes
> 
> 
> On the specific topic of supported SOF and EOF codes the ietf 
> documents
> should be driven by the specification provided in the *most relevant *
> document which in this case happens to be FC-BB-2 ant FC-MI.  FC-MI
> should
> be kept out of this.
> 
> If we simply accept to adopt the SOF and EOF codes listed for BB-2 the
> problem is solved. FYI, BB-2 only supports Class 2, 3, and F codes.
> I don't see why we are making a big deal about this.
> 
> -Murali
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Charles Monia
> Sent: Monday, November 12, 2001 3:33 PM
> To: IPS Reflector
> Subject: RE: FCencap: List ALL SOF/EOF codes
> 
> Hi Folks:
> 
> > David's observation is correct. FC-MI rev 1.8 (28 Sept 2001)
> > prohibits Class 1 and I can find no letter ballot comments
> > asking that it be reinstated.
> 
> The last time I checked, the FC-MI spec was not a "standards track"
> document
> (to use IETF terminology). If that's still the case, is FC-MI's
> prohibition
> of class 1 a sufficient basis for precluding class 1 support in the
> encapsulation spec?
> 
> Charles
> > -----Original Message-----
> > From: Ralph Weber [mailto:[email-masked]]
> > Sent: Saturday, November 10, 2001 8:52 AM
> > To: IPS Reflector
> > Cc: [email-masked]
> > Subject: Re: FCencap: List ALL SOF/EOF codes
> >
> >
> > David's observation is correct. FC-MI rev 1.8 (28 Sept 2001)
> > prohibits Class 1 and I can find no letter ballot comments
> > asking that it be reinstated.
> >
> > Therefore, I am forced to agree with David. Class 1 MUST NOT
> > be mentioned in the FC Encapsulation draft. If necessary, a
> > note discussing interoperability and FC-MI can be added.
> >
> > Thanks.
> >
> > Ralph...
> >
> > [email-masked] wrote:
> >
> > > FC-MI was going to prohibit Class 1 last time I checked.  
> Since the
> > > I in FC-MI stands for "Interoperability", this seems like a
> > reasonable
> > > rationale for excluding Class 1 service.
> > >
> > > --David
> > > ---------------------------------------------------
> > > David L. Black, Senior Technologist
> > > EMC Corporation, 42 South St., Hopkinton, MA  01748
> > > +1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
> > > [email-masked]       Mobile: +1 (978) 394-7754
> > > ---------------------------------------------------
> >
>

---

From: "Joe Dean" <[email-masked]>
Date: Tue, 13 Nov 2001 22:24:24 -0500

I say option 3 is the best route.

---------------------------------------
Joe Dean
Storage Systems Engineer
Compaq Computer Corporation
[email-masked]
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Charles Monia
Sent: Tuesday, November 13, 2001 9:49 PM
To: IPS Reflector
Subject: RE: FCencap: List ALL SOF/EOF codes

Hi:

Charles