Subject: SRP vs PKI for authentication

From: [email-masked]
Date: Tue, 13 Nov 2001 19:12:56 EST

iSCSI draft 08 requires use of SRP for authentication, while for Fabric switch authentication, there are proposals in T11 that use PKI. The iSNS also allows PKI for authentication. I have also seen some IP concerns raised recently about SRP...

So my question is - for iSCSI login-time authentication, are there compelling reasons for using SRP instead of PKI?

---

From: "Ofer Biran" <[email-masked]>
Date: Wed, 14 Nov 2001 12:53:39 +0200

iSCSI doesn't require the use of SRP - it's just the authentication
method that MUST be implemented by each compliant iSCSI implementation
s.t. interoperability is guaranteed. PKI (by SPKM-1 or SPKM-2) is
defined and optional to implement and use in iSCSI.

SRP was chosen in the Nashua May 2001 interim meeting, after long review
of 6 authentication methods according to 6 criteria. The main issues with
SPKM was complex administration of CAs/CRLs and lack of existing
implementations. You can see the presentation for this review on
http://www.haifa.il.ibm.com/satran/ips/iSCSI-Sec-review-Nashua.pdf .

  Regards,
    Ofer

Ofer Biran
Storage and Systems Technology
IBM Research Lab in Haifa
[email-masked]  972-4-8296253

[email-masked]@ece.cmu.edu on 14/11/2001 02:12:56

Please respond to [email-masked]

Sent by:  [email-masked]

To:   <[email-masked]>
cc:
Subject:  SRP vs PKI for authentication

iSCSI draft 08 requires use of SRP for authentication, while for Fabric
switch authentication, there are proposals in T11 that use PKI. The iSNS
also allows PKI for authentication. I have also seen some IP concerns
raised recently about SRP...

So my question is - for iSCSI login-time authentication, are there
compelling reasons for using SRP instead of PKI?

---

From: [email-masked]
Date: Wed, 14 Nov 2001 17:42:42 -0500

Ofer's provided part of the answer, in addition this is
based in part on considerations for environments that
are not prepared to invest heavily in security (so IPsec
is not in use), but for which authentication is appropriate.
SRP is considerably easier to set up and use than a PKI-based
mechanism, and hence is the "MUST implement" to make
good authentication easier to use in such environments
in contrast to one of the SPKMs and the associated PKI
and/or key generation and key management it requires.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, November 13, 2001 7:13 PM
> To: [email-masked]
> iSCSI draft 08 requires use of SRP for authentication, while 
> for Fabric switch authentication, there are proposals in T11 
> that use PKI. The iSNS also allows PKI for authentication. I 
> have also seen some IP concerns raised recently about SRP...
> 
> So my question is - for iSCSI login-time authentication, are 
> there compelling reasons for using SRP instead of PKI? 
>

---

From: [email-masked]
Date: Fri, 16 Nov 2001 21:45:17 EST

David,
I understand your and Ofer's views. But lets view from another point. For the 
same storage network, we may potentially have PKI as the choice for 
authentication for one part, and SRP for another. There are ways to simplify 
built-in PKI for storage networks as being applied for FC security (I expect 
you dont need an RA or a CA, and the trust hierarchy is left to the 
customer). So for those networks that want to ONLY authenticate entities in 
storage networks, we may potentially have two schemes that "MUST"  be 
implemented.

---

From: [email-masked]
Date: Mon, 19 Nov 2001 12:35:12 -0500

Such is life.  The alternative of allowing implementers to choose
to implement one of SRP or PKI as the "MUST" mechanism results in
an implementation that chooses SRP and doesn't implement PKI failing
to interoperate with an implementation that chooses PKI and doesn't
implement SRP.  This is not acceptable, hence there has to be at least
one "MUST" mechanism that everyone has to implement.

Thanks,
--David

> Sent: Friday, November 16, 2001 9:45 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: SRP vs PKI for authentication
> 
> 
> David,