Subject: Re: unsolicited data out PDU delivery

From: [email-masked] (Sandeep Joshi)
Date: Wed, 28 Nov 2001 12:50:49 -0500 (EST)

> Any update on adding context information (i.e. cmdSN, static target tag,
> etc.)
> to unsolicited data PDUs in order to facilitate simple task lookup by the
> iSCSI target?
> 
> Thanks,
> 
> Amir

You could rely on the fact that unsolicited data PDUs come 
in the same order as the commands, and directly match the 
data PDU to the first outstanding command in a connection. 

Sec 2.2.5
  Unsolicited data MUST be sent on every connection in the
  same order in which commands were sent

See http://www.pdl.cmu.edu/mailinglists/ips/mail/msg07197.html

-Sandeep

---

From: "Amir Shalit" <[email-masked]>
Date: Wed, 28 Nov 2001 11:34:36 -0800

A simple solution will be to let iSCSI initiator assign target tags in
the form of 0x800000xx that can be sent along with unsolicited data out
PDUs. 

A storage switch that has to handle N*M sessions, will struggle buffering
and matching unsolicited data PDUs with command PDUs.

Amir

-----Original Message-----
From: Sandeep Joshi [mailto:[email-masked]]
Sent: Wednesday, November 28, 2001 9:51 AM
To: [email-masked]; [email-masked]
Subject: Re: unsolicited data out PDU delivery

Sec 2.2.5

-Sandeep