Subject: RE: iSCSI: New iSCSI MIB draft

From: "Michele Hallak - Stamler" <[email-masked]>
Date: Thu, 1 Nov 2001 09:52:53 +0200

Hi,
1.I see that the target access list is still read-only. How do you think
that it should be configured?
2. Who should configure the aliases of the iscsi targets and initiators?
3. Same question for the portals.
Thanks,
	Michele

-----Original Message-----
From: Mark Bakke [mailto:[email-masked]]
Sent: Wednesday, October 31, 2001 9:01 PM
To: IPS
Subject: Re: iSCSI: New iSCSI MIB draft

For those who are more pictorially inclined when looking at
MIBs, I have an updated MIB tree drawing available at:

ftp://ftpeng.cisco.com/mbakke/iscsi/Visio-ietf-iscsi-mib-structure-03.pd
f

--
Mark

Mark Bakke wrote:
> 
> We have submitted a new iSCSI MIB draft to the repository.
> Until it becomes available, it may be retrieved as either
> a gzipped or text version from:
> 
> ftp://ftpeng.cisco.com/mbakke/iscsi/draft-ietf-ips-iscsi-mib-03.txt.gz
> 
> ftp://ftpeng.cisco.com/mbakke/iscsi/draft-ietf-ips-iscsi-mib-03.txt
> 
> A matching UML drawing is available at:
> 
> ftp://ftpeng.cisco.com/mbakke/iscsi/Visio-ietf-iscsi-uml-model-03.pdf
> 
> The table hierarchy has been significantly flattened.  This does
> not change the object model, but does reduce the number of redundant
> levels of OIDs when address individual objects.  I will send a
> new table structure drawing soon.
> 
> We will send a list of open issues to the IPS list shortly.
> 
> Thanks,
> 
> --
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "Peter Mellquist" <[email-masked]>
Date: Thu, 1 Nov 2001 14:31:35 -0800

I agree. I would assume that I can use SNMPv3 to manage the ACL in a secure
manner. This would  require read/write access. Basically, it should be
possible to manage and control an iSCSI target or initiator via SNMP.

-peter

Peter Mellquist
Seven Systems Technology
[email-masked]

---

From: Mark Bakke <[email-masked]>
Date: Tue, 06 Nov 2001 08:19:24 -0600

Michele-

Answers inline.  Basically, we have discussed making parts of the
MIB writable, and need to start working on it some more.  Please keep
posting anything that you think might be useful as a writable attribute
or a creatable/deletable row.

--
Mark

> that it should be configured?

I had originally assumed that these would be configured by other
means than SNMP, but it is certainly something that makes sense to
configure.  I will post another message to start a thread on this.

> 2. Who should configure the aliases of the iscsi targets and initiators?

These could easily be writable as well.

> 3. Same question for the portals.

Have to think about this one.  Any ideas?

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054