Subject: FCIP: v0.7 editorial suggestion

From: Sudhir Srinivasan <[email-masked]>
Date: Sat, 24 Nov 2001 08:54:10 -0500

Ralph,

An editorial suggestion: 

The pFlags definition is:
       |----------------Bit--------------------|
       |                                       |
       | 31   30   29   28   27   26   25   24 |
       +-----------------------------+----+----+
       |             Reserved        | Ch | SF |
       +-----------------------------+----+----+
        Fig. 8  pFlags Field Bits

with the "Ch" bit to the left of the "SF" bit.

I suggest the first two columns in Table 1 be swapped
to reflect this. When looking at Figure 9, it was
slightly confusing at first to map the pFlags value
shown in the Short Frame header back to Table 1.

Regards,
Sudhir

---

From: Ralph Weber <[email-masked]>
Date: Sun, 25 Nov 2001 06:41:31 -0600

I believe that the logic and conceptual structure of
Table 1 will be less clear if the columns are swapped.
For better or for worse, the positions of the bits in
Figure 8 represents the order in which they were
defined not the logic and purpose of the bits.
So the figure and the table are disjoint, as would
be the case for any design that evolved over time.

Finally, I find it impossible to believe that anyone
capable of understanding NAPTs could become confused
by Figure 8 and Table 1.

Thanks.

Ralph...