Subject: RE: iSCSI: Representing iSCSI devices on FC fabrics

From: "Elliott, Robert" <[email-masked]>
Date: Fri, 16 Nov 2001 13:18:24 -0600

Correction - the company_id is 24 bits, not 20 bits.

EUI-64 = (MSB) { 24-bit company_id, 
                 40-bit vendor specified } (LSB)

FC WWN = (MSB) { 4-bit NAA field, 
                 24-bit company_id, 
                 36-bit vendor specified } (LSB)
         (for the IEEE Registered NAA type)

> -----Original Message-----
> From: Elliott, Robert 
> Sent: Friday, November 16, 2001 9:33 AM
> To: [email-masked]
> Subject: RE: iSCSI: Representing iSCSI devices on FC fabrics
> 
> 
> Beware than a FC WWN is not the same as an EUI-64.  They're both based
> on the IEEE OUI/company_id, but the FC WWN uses the 4 most significant
> bits for a "Name Address Authority" field and has 4 fewer 
> bits available
> in the vendor specified portion.
> 
> EUI-64 = (MSB) { 20-bit company_id, 
>                  44-bit vendor specified } (LSB)
> 
> FC WWN = (MSB) { 4-bit NAA field, 
>                  20-bit company_id, 
>                  40-bit vendor specified } (LSB)
>          (for the IEEE Registered NAA type)
> 
> ---
> Rob Elliott, Compaq Server Storage
> [email-masked]

---

From: Thanu Skariah <[email-masked]>
Date: Mon, 19 Nov 2001 19:33:24 +0530

Hi,

    There is one document on T11 which deals with the
mapping required below (though not for all NAA types).

Check out   ftp://209.26.30.221/t11/pub/fc/fs/01-531v2.pdf

Thanks,
Thanu