Subject: RE: iSCSI minimum PDU length

From: "Shailesh Manjrekar" <[email-masked]>
Date: Thu, 15 Nov 2001 15:44:08 -0800

Julian,

Have we reached a consensus whether the minimum PDU size would be 512 or
1024. Also for command PDU's ( 48bytes + header ) does it mean that we
would end up using a MTU size ( 1500 bytes ) TCP segment for this. This
would add segment processing overheads at offload engine for just
48bytes + header.
Please clarify,

Regards,
Shailesh.
Aarohi Communications.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
John Hufferd
Sent: Thursday, October 25, 2001 2:36 AM
To: Julian Satran
Cc: [email-masked]
Subject: Re: iSCSI minimum PDU length

If you are only talking about Data PDUs, then at least I understand.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136
Internet address: [email-masked]
---------------------- Forwarded by John Hufferd/San Jose/IBM on
10/25/2001
02:34 AM ---------------------------

John Hufferd/San Jose/IBM@[email-masked] on 10/25/2001 02:12:07 AM

Sent by:  [email-masked]

To:   Julian Satran/Haifa/IBM@IBMIL
cc:   [email-masked]
Subject:  Re: iSCSI minimum PDU length

Julian,
Perhaps I do not understand what you are getting at here, but since
there
will be implementations with only R2T type Sessions, then there should
be a
lot of PDUs that just carry the Command (48 bytes + digest) it seems
that a
1024 is kind of big.  What am I missing?
.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136
Internet address: [email-masked]

Julian Satran/Haifa/IBM@[email-masked] on 10/24/2001 10:34:38 AM

Sent by:  [email-masked]

To:   [email-masked]
cc:
Subject:  iSCSI minimum PDU length

With no votes against we have settled (again) on single PDU length (per
connection, per direction) for all types of PDUs.
But I think we erred on the low side by suggesting 64 as a minimum. It
is
low (it was mentioned) and bad for text request/response.

How about settling for 1024?

Julo

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 16 Nov 2001 10:05:43 +0200

Shailesh,

With a high level of enthusiasm  the consensus was on 512 (2 voices for 
512 against 1 voice for 1024).
I am not sure about what you are asking in the second part of the message.
The 512 refers to the data-segment of an iSCSI PDU and states the minimum 
that MUST be supported.
If you are asking about TCP it says nothing about TCP (TCP is a stream of 
bytes). In practical terms you would like to have TCP support packets that 
are at least 560 (or 564 if CRCs are enabled - 512+48).

Julo

"Shailesh Manjrekar" <[email-masked]>
16-11-01 01:44
Please respond to "Shailesh Manjrekar"

        To:     John Hufferd/San Jose/IBM@IBMUS, Julian Satran/Haifa/IBM@IBMIL
        cc:     <[email-masked]>
        Subject:        RE: iSCSI minimum PDU length

Julian,

Regards,
Shailesh.
Aarohi Communications.
-----Original Message-----

.
.
.
John L. Hufferd

Julian,

To:   [email-masked]
cc:

Julo