Subject: FCencap: Missing SOF/EOF characters

From: Ralph Weber <[email-masked]>
Date: Thu, 01 Nov 2001 06:33:00 -0600

Off and on I hear complaints that it is not obvious
why draft-ietf-ips-fcencapsulation-03.txt fails to
list all the possible Fibre Channel SOF and EOF
characters in 5.3.

To address this concern, I propose adding the following
text at the end of 5.3.

  Note: Some of the SOF and EOF characters defined by
  Fibre Channel are not listed in Table 1 and Table 2
  because the design an operating characteristics
  of an IP Network make it inappropriate for
  transporting FC Frames containing those SOF and/or
  EOF characters.

I proposed to make this addition in a new draft that
will be available in time for consideration in Salt
Lake.

Comment appreciated.

Ralph Weber

---

From: "Franco Travostino" <[email-masked]>
Date: Thu, 01 Nov 2001 11:23:15 -0500

Ralph,
why should we be waiting until 5.3 (last page) to break this news (e.g., 
Class 1 isn't supported)?
Can we move your text up to section 1, aptly titled "Scope". Alternately, 
we could narrow down the very title of the document.

0.02
-franco

>will be available in time for consideration in Salt

Franco Travostino, Director Content Internetworking Lab
Advanced Technology Investments
Nortel Networks, Inc.
600 Technology Park
Billerica, MA 01821 USA
Tel: 978 288 7708 Fax: 978 288 4690
email: [email-masked]

---

From: Ralph Weber <[email-masked]>
Date: Tue, 06 Nov 2001 11:54:04 -0600

I would be willing to change the first paragraph of the scope from:

  "This document describes common mechanisms for the transport
  of Fibre Channel frames over an IP network, including the
  encapsulation format and a mechanism for enforcing the Fibre
  Channel frame lifetime limits."

to:

  "This document describes common mechanisms for the transport
  of Fibre Channel frames over an IP network within the limitations
  of service provided by an IP network. The topics described in
  this document include the encapsulation format and a mechanism
  for enforcing the Fibre Channel frame lifetime limits."

I am NOT willing to discuss Fibre Channel Classes in the draft
because to do so would require adding a definition of the term.
Fibre Channel Classes are not discussed in the draft as it is
currently written.

Ralph...

Franco Travostino wrote:

> Ralph,
> why should we be waiting until 5.3 (last page) to break this news (e.g., Class 1 isn't supported)?
> Can we move your text up to section 1, aptly titled "Scope". Alternately, we could narrow down the very title of the document.
>
> 0.02
> -franco

---

From: "Franco Travostino" <[email-masked]>
Date: Tue, 06 Nov 2001 14:30:42 -0500

>   for enforcing the Fibre Channel frame lifetime limits."

This proposed text comes a tad closer, but it's cryptic still.

>Fibre Channel Classes are not discussed in the draft as it is

I agree that a definition/discussion would be way inappropriate here. A T11 
citation should do the trick instead. We already have a sentence like "The 
format and content of an FC frame is described in the FC standards (e.g., 
FC-FS [3], FC-SW-2 [4], and FC-PI [5])." I don't see a problem with 
writing  "Scope is limited to FC Class 2 and 3,  which are described in the 
FC standard ([x]), and then adding [x] and the authoritative T11 document 
to Section 7 References. This direct and simple.

-franco

> > Can we move your text up to section 1, aptly titled "Scope". 
> Alternately, we could narrow down the very title of the document.
> >
> > 0.02
> > -franco

---

From: "Murali Rajagopal" <[email-masked]>
Date: Tue, 6 Nov 2001 15:10:32 -0800

How about stating something that we do support in the Scope section:

"This document only considers encapsulation for only FC Classes 2 and 3."

-Murali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Franco Travostino
Sent: Tuesday, November 06, 2001 11:31 AM
To: [email-masked]; IPS Reflector
Subject: Re: FCencap: Missing SOF/EOF characters

I agree that a definition/discussion would be way inappropriate here. A T11
citation should do the trick instead. We already have a sentence like "The
format and content of an FC frame is described in the FC standards (e.g.,
FC-FS [3], FC-SW-2 [4], and FC-PI [5])." I don't see a problem with writing
"Scope is limited to FC Class 2 and 3,  which are described in the FC
standard ([x]), and then adding [x] and the authoritative T11 document to
Section 7 References. This direct and simple.

-franco

Ralph...

---

From: Ralph Weber <[email-masked]>
Date: Wed, 07 Nov 2001 06:48:53 -0600

Murali, Franco,

I thank you both for pointing out just how slippery a slope this is.

Until receiving your e-mail messages I had been under the misimpression
that Class F was an important part of the FCIP mission.  :-)

Vague may be vague but it also is not unnecessarily constraining.

All the best.

Ralph...

Murali Rajagopal wrote:

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Franco Travostino
> I agree that a definition/discussion would be way inappropriate here. 
> A T11 citation should do the trick instead. We already have a sentence
> like "The format and content of an FC frame is described in the FC 
> standards (e.g., FC-FS [3], FC-SW-2 [4], and FC-PI [5])." I don't see 
> a problem with writing  "Scope is limited to FC Class 2 and 3,  which 
> are described in the FC standard ([x]), and then adding [x] and the 
> authoritative T11 document to Section 7 References. This direct and 
> simple.
>
> -franco

---

From: "Murali Rajagopal" <[email-masked]>
Date: Wed, 7 Nov 2001 08:30:35 -0800

Ralph:

Missed Class F in the slippery slopes of the wonderful world of FC Classes!

-Murali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Ralph
Weber
Sent: Wednesday, November 07, 2001 4:49 AM
To: IPS Reflector
Cc: Murali Rajagopal; Franco Travostino
Subject: Re: FCencap: Missing SOF/EOF characters

Murali, Franco,

All the best.

Ralph...

Franco Travostino