Subject: Re: iSCSI: Digests and Multiple Connections

From: "Prasenjit Sarkar" <[email-masked]>
Date: Thu, 29 Nov 2001 14:47:31 -0800

Julian,

My question was about digests only and you ought to put that
assertion in Appendix D to avoid confusion.

   Prasenjit Sarkar
   Research Staff Member
   IBM Almaden Research
   San Jose

                    Julian                                                                                                                    
                    Satran/Haifa/I       To:     [email-masked]                                                                              
                    BM@IBMIL             cc:                                                                                                  
                    Sent by:             Subject:     Re: iSCSI: Digests and Multiple Connections                                             
                    owner-ips@ece.                                                                                                            
                    cmu.edu                                                                                                                   

                    11/29/2001                                                                                                                
                    01:39 PM                                                                                                                  

Prasenjit,

Digests and security are connection level characteristics.

Regards,
Julo

   Prasenjit                                                              
   Sarkar/Almaden/IBM@IBMUS                To:        [email-masked]     
   Sent by: [email-masked]          cc:                            
                                           Subject:        iSCSI: Digests 
                                   and Multiple Connections               
   11/29/2001 09:33 PM                                                    

The standard says:

When Initiator and Target agree on a digest, this digest MUST be used
for every PDU in full feature phase.

Also, it appears that digests are a session-level parameter.

Scenario:

The first connection of a multiple-connection session agrees on digests
and proceeds to full-feature phase with digests.

What about the subsequent connections that try to login? Do these
connections
suspend digests during non-full feature phase and turn it on during
full feature.

The standard is silent on this issue.

  Prasenjit Sarkar
  Research Staff Member
  IBM Almaden Research
  San Jose

---

From: "Anshul Chadda" <[email-masked]>
Date: Thu, 29 Nov 2001 19:03:44 -0500

The field "Use:IO" implicitly makes a key a connection level characteristic.
This holds for Digests as well as Markers.
But I agree it is not explicitly stated.

Anshul