Subject: iSCSI acknowledgment mechanism

From: Ron Grinfeld <[email-masked]>
Date: Wed, 7 Nov 2001 08:36:15 +0200

Hello,
	After monitoring the Q&A resulting from the UNH I'm a little puzzled
and in need for some clarifications:
	1. Does the ExpStatSn acknowledges the status received on a task and
all its data PDUs (not only the receive of the status itself) ?
		If so then the ExpStatSn is incremented only after receiving
all the Data-In PDUs and the related status.
	2. Does the 'A' bit in the Data-In PDUs relates only to data sent on
a specific task (triggered by the target when sending long bursts of Data-In
PDUs relating to the same task) and the SNACK response with type DataACK
(positive acknowledge of Data-In PDUs) acknowledges this specific task as
well ?

	_________________________

	Ron Grinfeld, Siliquent
	[email-masked] 
	Israel office:
	tel:	 +972 3 6948671
	e-fax	 +972 3 6953736
	USA office:
	2929 Campus Drive, suite #400
	San Mateo, CA 94403
	tel:     650-358-2854

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 7 Nov 2001 09:54:01 +0200

Ron,

ExpStaSN acknowledges status.  This is per connection and since status and 
data for a task have allegiance to one connection acknowledging status 
implicitly acknowledges data.

Data are counted per command - and A refers only to a given command - and 
so does the dataACK.

Julo

Ron Grinfeld <[email-masked]>
Sent by: [email-masked]
07-11-01 08:36
Please respond to Ron Grinfeld

        To:     "[email-masked]'" <[email-masked]>
        cc: 
        Subject:        iSCSI acknowledgment mechanism

                 Hello,
                 After monitoring the Q&A resulting from the UNH I'm a 
little puzzled
and in need for some clarifications:
                 1. Does the ExpStatSn acknowledges the status received on 
a task and
all its data PDUs (not only the receive of the status itself) ?
                                 If so then the ExpStatSn is incremented 
only after receiving
all the Data-In PDUs and the related status.
                 2. Does the 'A' bit in the Data-In PDUs relates only to 
data sent on
a specific task (triggered by the target when sending long bursts of 
Data-In
PDUs relating to the same task) and the SNACK response with type DataACK
(positive acknowledge of Data-In PDUs) acknowledges this specific task as
well ?

                 Ron Grinfeld, Siliquent
                 [email-masked] 
                 Israel office:
                 tel:             +972 3 6948671
                 e-fax            +972 3 6953736
                 USA office: