Subject: FCencap: List ALL SOF/EOF codes

From: Ralph Weber <[email-masked]>
Date: Wed, 07 Nov 2001 07:15:35 -0600

Upon further reflection, I think the right thing to do
is to list all the SOF/EOF codes defined in FC-BB in
the FC Encapsulation draft.

FIRST

There is nothing in the FC Encapsulation draft other
than to omission of Class 1 SOF/EOF codes that prevents
encapsulating FC Class 1 frames for TCP transport.
Sure, a TCP ULP that is smarter than anything anybody
has thought about will be required to do it.  BUT
there is (or should be) nothing the the FC Encapsulation
draft that prevents such a protocol from being invented.
AND the FC Encapsulation draft specifically says that
you need the wisdom of some other protocol document in
order to get any use out of the FC Encapsulation draft.
Why force the mad man that devises a way to transport
Class 1 over TCP/IP to revise the FC Encapsulation
SOF/EOF tables?

SECOND

It is conceivable that a future version of iFCP
(or maybe even FCIP) might want to support Class 4.
Again, there is nothing in the FC Encapsulation
draft that prevents this, except the omission
of the SOF/EOF codes.

FINALLY

I believe that the elimination of all SOF/EOF
codes other than Class 2, Class 3, AND CLASS F
is a hold over from the early FCIP work, before
the FC Encapsulation was split into a separate
draft. I believe that decision was right for
FCIP but wrong for an FC Encapsulation intended
to be used by ALL FC protocols running over
TCP/IP.

Thanks for your consideration.

Ralph...

---

From: "Franco Travostino" <[email-masked]>
Date: Wed, 07 Nov 2001 10:31:42 -0500

I agree with this motion.

You wrote under another heading: "Vague may be vague but it also is not 
unnecessarily constraining." What a troubling statement was this. I'm glad 
we now appear to be moving towards a constructive end after all.

thanks
-franco