Subject: iSCSI: Function 4 Of Task Mgmt Command

From: Nitin Dhingra <[email-masked]>
Date: Sat, 17 Nov 2001 19:08:16 +0530

How does the initiator decide to choose Task Management Function 4    
i.e. Clear Task Set - Aborts all Tasks (from all initiators) for the Logical
Unit?

---

From: [email-masked]
Date: Mon, 19 Nov 2001 12:40:42 -0500

By means not specified here.  Clear Task Set is a defined
SCSI task management function - see Section 6 of SAM-2 - and
hence this is a SCSI level decision.  SCSI has had to deal
with ill-behaved devices that have occasionally needed hard
whacks to get them to behave (e.g., start paying attention
to the Initiator again).  Clear Task Set is among the "hard
whacks" available for this purpose.  iSCSI is required to
provide the means for Clear Task Set to work if a SCSI
Initiator chooses to use it.

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Nitin Dhingra [mailto:[email-masked]]
> Sent: Saturday, November 17, 2001 8:38 AM
> To: [email-masked]'
> Subject: iSCSI: Function 4 Of Task Mgmt Command
> 
>