Subject: RE: iScsi: InitialR2T

From: Nitin Dhingra <[email-masked]>
Date: Thu, 22 Nov 2001 15:41:39 +0530

Unsolicited data means "solicited data with an implied R2T" very fine 
I have no objections

I'll put my question in a different manner:
If you are sending unsolicited data ( means implied R2T's no R2T's to be
sent from the target )
Then why do you need to send an R2T for the first outgoing data if
InitialR2T is "no"?

Let me know if somehow I have misinterpreted the last sentence of
InitialR2T.

- nitin

 -----Original Message-----
From: 	Rahul Bhagwat [mailto:[email-masked]] 
Sent:	Thursday, November 22, 2001 1:37 AM
To:	Nitin Dhingra; 'Julian Satran'; [email-masked]
Subject:	Re: iScsi: InitialR2T

Hi,

The use of InitialR2T=no means unsolicited data.

The way the specs look at unsolicited data is "solicited data with
an implied R2T".

Regards,
Rahul
----- Original Message -----
From: "Nitin Dhingra" <[email-masked]>
To: "'Julian Satran'" <[email-masked]>; <[email-masked]>
Sent: Thursday, November 22, 2001 2:54 PM
Subject: iScsi: InitialR2T

>
> Under The Section "InitialR2T" the last sentence says
>
> "Note that only the first outgoing data burst (immediate data and/or or
> separate PDUs) can be sent unsolicited by an R2T."
>
> My question : If you are sending unsolicited data why do you send an R2T
for
> that?
> - Nitin

---

From: "BURBRIDGE,MATTHEW (HP-UnitedKingdom,ex2)" <[email-masked]>
Date: Thu, 22 Nov 2001 10:38:10 -0000

Nitin,

Perhaps I can explain:

Under normal (default) circumstances after sending a SCSI Command PDU (with
W=1) the initiator must wait for the target to issue an R2T before it can
send any Data-out PDUs.  This first R2T is what is termed the InitialR2T.
However, as you have encountered there is a text parameter that can
negotiated (InitialR2T) which (if both sides agree) allow the initiator to
send a burst of data no longer than the FirstBurstSize.  This first burst
can be in one or more Data-out PDUs (depending on the value of
MaxRecvPDULength). After the first burst (denoted by the F bit being set in
the last Data-PDU of the first burst), the initiator MUST wait for an R2T
before sending the next burst of data.  This next burst is then solicited.

To be able to make use of the unsolicited feature, both sides must agree to
it by each side sending InitialR2T=no.  If either party sends InitialR2T=yes
then I'm afraid all data has to be sent solicited.

I'd agreed that the sentence is a little misleading so perhaps it should
read:

"Note that only the first outgoing data burst (immediate data and/or or
separate PDUs) can be sent unsolicited (i.e. not requiring an explicit
R2T)."

Julian, please could you make the above change.

Cheers

Matthew Burbridge
Senior Development Engineer
NIS-Bristol
Hewlett Packard
Telnet: 312 7010
E-mail: [email-masked]

-----Original Message-----
From: Nitin Dhingra [mailto:[email-masked]]
Sent: Thursday, November 22, 2001 10:12 AM
To: 'Rahul Bhagwat'; 'Julian Satran'; [email-masked]
Subject: RE: iScsi: InitialR2T

- nitin

 -----Original Message-----
From: 	Rahul Bhagwat [mailto:[email-masked]] 
Sent:	Thursday, November 22, 2001 1:37 AM
To:	Nitin Dhingra; 'Julian Satran'; [email-masked]
Subject:	Re: iScsi: InitialR2T

Hi,

Regards,
Rahul
----- Original Message -----
From: "Nitin Dhingra" <[email-masked]>
To: "'Julian Satran'" <[email-masked]>; <[email-masked]>
Sent: Thursday, November 22, 2001 2:54 PM
Subject: iScsi: InitialR2T

for