Subject: iSCSI: responding to a logout request

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 17 Dec 2001 15:31:26 -0500

Section 3.9.1 says:

 Initiator MUST send a Logout with a reason code of "Close the
 connection" to cleanly shutdown the connection. The initiator
 MAY also issue a Logout with the reason code of "Close the
 session" [ESQ1] , to completely close the session, but ONLY if it does
 not support or use multiple connections in the specific
 session.

I think this should say:

 Initiator MUST send a Logout with a reason code of “Close the
 connection" (if not the only connection) or “Close the session”
 (if using multiple connections).

Because once you comply with the 1st sentence, you would not be able
To comply with the 2nd sentence.

Eddy
  _____

  [ESQ1] If a target closes the connection and there is only one connection,
issue two logouts (one to close the connection and one to close the
session)? But how if you just closed the connection.

---

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 17 Dec 2001 18:43:05 -0500

I think I made an error in my suggested wording…

It should be:

 Initiator MUST send a Logout with a reason code of “Close the
 connection" (if using multiple connections) or “Close the
 session” (if not using multiple connections).

Eddy

-----Original Message-----
From: Amir Shalit [mailto:[email-masked]]
Sent: Monday, December 17, 2001 5:23 PM
To: Eddy Quicksall
Subject: RE: iSCSI: responding to a logout request

It can also change to:

 Initiator MUST send a Logout with a reason code of “Close the
 connection" or “Close the session”.

Why do we have to close multiple connections, at the iSCSI level, one by
one?

Amir

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eddy
Quicksall
Sent: Monday, December 17, 2001 12:31 PM
To: ips@ece. cmu. edu (E-mail)
Subject: iSCSI: responding to a logout request
Section 3.9.1 says:

I think this should say:

Eddy
  _____

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 20 Dec 2001 00:34:20 +0200

thanks - julo

                    "Eddy Quicksall"                                                                      
                    <Eddy_Quicksall@iv       To:     "ips@ece. cmu. edu \(E-mail\)"                       
                    ivity.com>                <[email-masked]>                                           
                    Sent by:                 cc:                                                          
                    [email-masked].       Subject:     RE: iSCSI: responding to a                      
                    edu                       logout request                                              

                    18-12-01 01:43                                                                        

I think I made an error in my suggested wording?

It should be:

 connection" (if using multiple connections) or "Close the

 session" (if not using multiple connections).

Eddy

     -----Original Message-----
     From: Amir Shalit [mailto:[email-masked]]
     Sent: Monday, December 17, 2001 5:23 PM
     To: Eddy Quicksall
     Subject: RE: iSCSI: responding to a logout request

     It can also change to:

      connection" or "Close the session".

     Why do we have to close multiple connections, at the iSCSI level, one
     by one?

     Amir

          -----Original Message-----
          From: [email-masked] [mailto:[email-masked]]On
          Behalf Of Eddy Quicksall
          Sent: Monday, December 17, 2001 12:31 PM
          To: ips@ece. cmu. edu (E-mail)
          Subject: iSCSI: responding to a logout request

          Section 3.9.1 says:

           session"[ESQ1] , to completely close the session, but ONLY if it
          does

           session.

          I think this should say:

           connection" (if not the only connection) or "Close the session"

          Because once you comply with the 1(superscript: st) sentence, you
          would not be able

          To comply with the 2(superscript: nd) sentence.

          Eddy

      [ESQ1] If a target closes the connection and there is only one
     connection, issue two logouts (one to close the connection and one to
     close the session)? But how if you just closed the connection.