Subject: iSCSI: first CmdSN clearification

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 18 Dec 2001 16:27:06 -0500

3.12.9 CmdSN

  CmdSN is either the initial command sequence number of a session (for
  the first Login request of a session - the "leading" login) or the
  command sequence number in the command stream (e.g., if the leading
  login carries the CmdSN 123 all other Login requests carry the CmdSN
  123 and the first non-immediate command also carries the CmdSN 123).

  The target MUST use the value presented with the first login request.

Why does it spell out “the first non-immediate command”? It would seem like
it should just say “the first command … “. Because immediate commands always
get the next CmdSN anyway.

Eddy

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 20 Dec 2001 03:05:50 +0200

It is an example. It stresses that the first non-immediate after login
still carries the same number - as you would expect.

Julo

                    "Eddy Quicksall"                                                                      
                    <Eddy_Quicksall@iv       To:     "ips@ece. cmu. edu \(E-mail\)"                       
                    ivity.com>                <[email-masked]>                                           
                    Sent by:                 cc:                                                          
                    [email-masked].       Subject:     iSCSI: first CmdSN                              
                    edu                       clearification                                              

                    18-12-01 23:27                                                                        

 3.12.9 CmdSN

Why does it spell out "the first non-immediate command"? It would seem like
it should just say "the first command ? ". Because immediate commands
always get the next CmdSN anyway.

Eddy