Subject: iSCSI: LUN in Data-out and NOP PDU's

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 21 Dec 2001 15:38:44 -0500

What is the LUN for in Data-out and NOP-out PDU’s?

I assume the LUN in Data-out could be used for steering but I don’t know
what the LUN in NOP-out PDU’s is for.

Eddy

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 22 Dec 2001 10:37:15 +0200

Eddy,

It was felt that TTT management could be kept local to the LU or group of 
LUs (no requirement to be unique on target).
The combination LU and TTT is used instead. That enables groups of 
entities to form a "virtual target".

Julo

"Eddy Quicksall" <[email-masked]>
Sent by: [email-masked]
21-12-01 22:38

        To:     "ips@ece. cmu. edu \(E-mail\)" <[email-masked]>
        cc: 
        Subject:        iSCSI: LUN in Data-out and NOP PDU's

What is the LUN for in Data-out and NOP-out PDU?s?
 
I assume the LUN in Data-out could be used for steering but I don?t know 
what the LUN in NOP-out PDU?s is for.
 
Eddy

---

From: Sanjay Goyal <[email-masked]>
Date: Thu, 27 Dec 2001 11:09:54 -0500

Hi  
to be very specific on the question,
 Nop-out and Nop-in PDUs are used by Initiators and Targets also to ping
each other. If a target is trying to ping the Initiator, why does it need to
use a particular combination of TTT and LUN i.e. the "virtual target". 
Should we really use TTT and LUN pair for a function which is for target and
not for "virtual target"  OR am i missing something.
 
Regards
Sanjay Goyal

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Saturday, December 22, 2001 3:37 AM
To: Eddy Quicksall
Cc: ips@ece. cmu. edu (E-mail); [email-masked]
Subject: Re: iSCSI: LUN in Data-out and NOP PDU's

Eddy, 

It was felt that TTT management could be kept local to the LU or group of
LUs (no requirement to be unique on target). 
The combination LU and TTT is used instead. That enables groups of entities
to form a "virtual target". 

Julo 

21-12-01 22:38 

What is the LUN for in Data-out and NOP-out PDU's? 

I assume the LUN in Data-out could be used for steering but I don't know
what the LUN in NOP-out PDU's is for. 

Eddy

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 28 Dec 2001 13:58:32 -0500

1) Can someone please give an example of how the LUN would be used in
a NOP PDU.
2) If the NOP-In is used as a ping, the TTT is set to a valid value
and the LUN must be set to a correct value when the TTT is valid. But,
if the ping comes from the target (not an LU), then what should the
LUN contain?

Eddy

-----Original Message-----
From: Sanjay Goyal [mailto:[email-masked]]
Sent: Friday, December 28, 2001 1:38 PM
To: Eddy Quicksall
Subject: FW: iSCSI: LUN in Data-out and NOP PDU's

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, December 28, 2001 11:17 AM
To: Sanjay Goyal
Subject: RE: iSCSI: LUN in Data-out and NOP PDU's

Sanjay,

I am not sure I understand you question.
The NOPs follow the pattern of all other target to initiator PDUs that
expect a follow-up action (like R2T) when they do.
For this they use TTT+LUN.

If they are originated or not at the LU or a front-end device is an
"implementation detail".

Julo

                    Sanjay Goyal

                    <sanjay_goyal@iv       To:     Julian
Satran/Haifa/IBM@IBMIL, Eddy Quicksall
                    ivity.com>
<[email-masked]>

                                           cc:     "[email-masked]'"
<[email-masked]>
                    27-12-01 18:09         Subject:     RE: iSCSI: LUN
in Data-out and NOP PDU's

Hi
to be very specific on the question,
 Nop-out and Nop-in PDUs are used by Initiators and Targets also to
ping
each other. If a target is trying to ping the Initiator, why does it
need
to use a particular combination of TTT and LUN i.e. the "virtual
target".
Should we really use TTT and LUN pair for a function which is for
target
and not for "virtual target"  OR am i missing something.

Regards
Sanjay Goyal
     -----Original Message-----
     From: Julian Satran [mailto:[email-masked]]
     Sent: Saturday, December 22, 2001 3:37 AM
     To: Eddy Quicksall
     Cc: ips@ece. cmu. edu (E-mail); [email-masked]
     Subject: Re: iSCSI: LUN in Data-out and NOP PDU's

     Eddy,

     It was felt that TTT management could be kept local to the LU or
group
     of LUs (no requirement to be unique on target).
     The combination LU and TTT is used instead. That enables groups
of
     entities to form a "virtual target".

     Julo

   "Eddy Quicksall"

   <[email-masked]>            To:        "ips@ece. cmu.

   Sent by: [email-masked]  edu \(E-mail\)" <[email-masked]>

                                           cc:

                                           Subject:        iSCSI: LUN

   21-12-01 22:38                  in Data-out and NOP PDU's

     I assume the LUN in Data-out could be used for steering but I
don't
     know what the LUN in NOP-out PDU's is for.

     Eddy