Subject: RE:iSCSI: Outboard Tunnel Mode

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Mon, 17 Dec 2001 12:39:08 -0800

If it is NOT MUST USE, I guess most implementations would just 
choose "None" for security options. What is the point in saying 
MUST IMPLEMENT but is NOT MUST USE?

 -lakshmi

-----Original Message-----
From: John Hufferd [mailto:[email-masked]] 
Sent: Monday, December 17, 2001 11:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Outboard Tunnel Mode

Installations can do what ever they want.  The Security functions are
must implement, NOT must use.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688 Home
Office (408) 997-6136, Cell: (408) 499-9702 Internet address:
[email-masked]

[email-masked]@ece.cmu.edu on 12/17/2001 10:09:10 AM

Sent by:  [email-masked]

To:   [email-masked]
cc:
Subject:  Outboard Tunnel Mode

Folks,

May be I missed something in SLC meeting.  I can expect several
implementations of iSCSI not include any security.Reason - I can see
that customers would often rely on the company's existing VPNs (outboard
Router
etc) to protect their data (storage or otherwise) over IP networks. From
a CIO's viewpoint, this approach may make more sense than extending yet
another layer of IPSec into its servers just for storage data.

 It is not clear to me from the standard if it will be a non-compliance
of iSCSI standard. If so, we may potentially have many non-compliances.

---

From: "John Hufferd" <[email-masked]>
Date: Mon, 17 Dec 2001 17:26:46 -0800

You need to parse the word Installation and Implementation more carefully.
"Use" applies to the Installation locations choices. Implement is what the
vendors must provide.

We do not need to go over this any more!  There is an IETF requirement for
"MUST Implement, and Optional to USE".  Debate is useless.  Lets move on.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

"Lakshmi Ramasubramanian" <[email-masked]>@ece.cmu.edu on
12/17/2001 12:39:08 PM

To:   John Hufferd/San Jose/IBM@IBMUS, <[email-masked]>
cc:   <[email-masked]>
Subject:  RE:iSCSI: Outboard Tunnel Mode

 -lakshmi

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Monday, December 17, 2001 11:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Outboard Tunnel Mode

.
.
.
John L. Hufferd

To:   [email-masked]
cc:

Folks,

---

From: [email-masked]
Date: Tue, 18 Dec 2001 10:20:47 -0500

So that when a situation arises in which the security is needed,
it's available to be used.  It's usually easy to disable something
that is present but not needed, but it's much harder to enable
something that is needed but present.  As John indicated earlier,
this is a closed issue based on instructions from the IESG.
Comments questioning the IESG's wisdom should be sent to the IESG
or (preferably) /dev/null.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000            FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

> From: Lakshmi Ramasubramanian [mailto:[email-masked]]
> Sent: Monday, December 17, 2001 3:39 PM
> To: John Hufferd; [email-masked]
> Cc: [email-masked]

---

From: [email-masked]
Date: Tue, 18 Dec 2001 10:26:49 -0500

Trying again with an important correction:

So that when a situation arises in which the security is needed,
it's available to be used.  It's usually easy to disable something
that is present but not needed, but it's much harder to enable
something that is needed but **not** present.  As John indicated
earlier, this is a closed issue based on instructions from the IESG.
Comments questioning the IESG's wisdom should be sent to the IESG
or (preferably) /dev/null.

Thanks,
--David

> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, December 18, 2001 10:21 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: iSCSI: Outboard Tunnel Mode
> 
>

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 19 Dec 2001 23:30:18 +0200

Lakshmi,

I think that what must implements means is that the function should be
available if an administrator decides to activate it.
May use refers to the fact that not using a facility can be a result of an
agreement between parties.

Julo

                    "Lakshmi                                                                                
                    Ramasubramanian"           To:     John Hufferd/San                                     
                    <[email-masked]        Jose/IBM@IBMUS, <[email-masked]>                            
                    osoft.com>                 cc:     <[email-masked]>                                    
                    Sent by:                   Subject:     RE:iSCSI: Outboard Tunnel                       
                    [email-masked]        Mode                                                        
                    u                                                                                       

                    17-12-01 22:39                                                                          

 -lakshmi

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Monday, December 17, 2001 11:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Outboard Tunnel Mode

.
.
.
John L. Hufferd

To:   [email-masked]
cc:

Folks,