Subject: Questions about implementation of Multiple connections

From: Mengqiu Wang <[email-masked]>
Date: Sun, 9 Dec 2001 22:28:42 -0800 (PST)

I have several questions about multiple connections:

(1) Are multiple connections between initiator and a
target common? I mean, how many applications will
require iSCSI implementation to be able to handle
multiple connections within a session? Can anybody
give me some overview idea about the application of
multiple TCP connections, like: is it an exceptional
case? or common case?

(2) Consider a hard drive on the network. It only has
one hardware port. If we want to develop a iSCSI box
to handle all incoming iSCSI commands for it, is it
necessary for the box to handle multiple TCP
connections for this hard drive? How? Does the box
need more than one IP addresses?

Thanks,
Meng

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 12 Dec 2001 02:54:15 +0200

----- Forwarded by Julian Satran/Haifa/IBM on 12-12-01 02:37 -----

Julian Satran
10-12-01 20:05

        To:     ips
        cc:     [email-masked], [email-masked]
        Subject:        Re: Questions about implementation of Multiple connections

Meng,

> multiple TCP connections, like: is it an exceptional

I  assume that many mid and high end boxes (RAID, JBOD and NAS with iSCSI 
"personality") will have it.

> need more than one IP addresses?

I don't think you need this for one disk although you may want to admit 
two for  recovery.

> Meng

Julo

---

From: Julian_Satran/Haifa/[email-masked]
Date: Mon, 10 Dec 2001 20:05:23 +0200

Meng,

Julo

---

From: Julian_Satran/Haifa/[email-masked]
Date: Mon, 10 Dec 2001 20:05:23 +0200

Meng,

Julo