Subject: RE: iSCSI: scope of keys

From: "John Hufferd" <[email-masked]>
Date: Thu, 20 Dec 2001 22:05:24 -0800

Eddy,
It not only OK, it is required.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

"Eddy Quicksall" <[email-masked]>@ece.cmu.edu on 12/18/2001
07:25:44 AM

Sent by:    [email-masked]

To:    Julian Satran/Haifa/IBM@IBMIL, <[email-masked]>
cc:
Subject:    RE: iSCSI: scope of keys

IO means "only during login". It does not mean "connection only".

 13 TargetName

 Use: IO by initiator ALL by target, Declarative

 This key must be provided by the initiator of the TCP connection to
 the remote endpoint in the first login request ...

So, here is a case where it is session wide ... so IO cannot mean
"connection only" (I assume that since TargetName is not LO, then it must
be
ok to send this key for each connection).

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, December 14, 2001 3:50 PM
To: [email-masked]
Subject: Re: iSCSI: scope of keys

Eddy,

I think the text says it - but if people love headers better I can add
it (some voices needed).

Julo

        "Eddy Quicksall" <[email-masked]>
Sent by: [email-masked]

14-12-01 22:12

        To:        "ips@ece. cmu. edu \(E-mail\)" <[email-masked]>
        cc:
        Subject:        iSCSI: scope of keys

Would it make sense to add a "scope" to each key definition? The IO and
LO "use:" labels almost do that but not in all cases. For example:

 SW = Session wide

 CO = Connection only

 Use: IO

 Who can send: Initiator

 Scope: SW

 Key=<value>

Eddy

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 21 Dec 2001 09:13:29 -0500

John,

I think my point was missed. Now you have possibly pointed out another angle
to my point.

My point is that "use" does not contain enough information. In your response
below, you have implied that IO now means "required" ... but it does not.

I think that "use" has been overloaded and I think each key should have a
list of properties (use is one, scope is another and now maybe required
should be a third).

Eddy

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Friday, December 21, 2001 1:05 AM
To: Eddy Quicksall
Cc: Julian Satran; [email-masked]
Subject: RE: iSCSI: scope of keys

Eddy,

.
.
.
John L. Hufferd

 13 TargetName

So, here is a case where it is session wide ... so IO cannot mean
"connection only" (I assume that since TargetName is not LO, then it
must
be
ok to send this key for each connection).

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, December 14, 2001 3:50 PM
To: [email-masked]
Subject: Re: iSCSI: scope of keys

Eddy,

Julo

14-12-01 22:12

 SW = Session wide

 CO = Connection only

 Use: IO

 Who can send: Initiator

 Scope: SW

 Key=<value>

Eddy