Subject: iSCSI: the I bit in response PDU's

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 28 Dec 2001 16:00:51 -0500

A while back, I wondered why the I bit needs to be set in all response
PDU’s. That generated some discussion but none had the answer.

What is the reason? If there is not one, can we make it a 0?

Eddy

---

From: "Julian Satran" <[email-masked]>
Date: Sun, 30 Dec 2001 06:31:24 +0200

People have become sensitive even to minor changes so we may want to call 
for a consensus.

Julo

"Eddy Quicksall" <[email-masked]>
29-12-01 15:51

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc: 
        Subject:        RE: iSCSI: the I bit in response PDU's

Well, the problem I see, if it is left in just due to history, you will 
get people thinking like we have seen IOL think ? "it must be checked" or 
like me ? "what is it for" or like someone else ? "attaching an assumed 
significance to it".
 
Also, if it is left a 1 for no reason, it is more difficult to give it a 
meaning later if it is needed.
 
My vote would be to make it a 0 and call it "reserved".
 
I wonder if others have simply forgotten about it and the question needs 
to be asked for a consensus?
 
Eddy
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 4:20 AM
To: Eddy Quicksall
Subject: Re: iSCSI: the I bit in response PDU's

Eddy, 

It is only history and nobody (including myself) bothered to change it. 
We could make it 0 - but what exactly would that buy us? 
I am waiting for others to share your concern about regularity. 

Regards, 
Julo 

"Eddy Quicksall" <[email-masked]> 
Sent by: [email-masked] 
28-12-01 23:00 
        
        To:        Julian Satran/Haifa/IBM@IBMIL 
        cc:        "ips@ece. cmu. edu \(E-mail\)" <[email-masked]> 
        Subject:        iSCSI: the I bit in response PDU's 

A while back, I wondered why the I bit needs to be set in all response 
PDU's. That generated some discussion but none had the answer. 

Eddy