Subject: Few basic doubts

From: pratima <[email-masked]>
Date: Thu, 13 Dec 2001 12:42:41 -0800

Hi all,
I am just a beginner in iSCSI. I have gone through
draft-ietf-ips-iscsi-09.txt.
I have few basic doubts. I am very thankful if some one clarrifies those.
I am listing them.

1) Data segment length in the BHS is not including the padding
   bytes how to reach the end of PDU.
   is it only padded to the nearest integer multiple of 4?
   Can we assume like pad can be maximum of 3?
   @3.2.1.5

2) Digests are not included in data or header length fields
   How do we know Digest is present or not?
   @3.2.3
   During Login Negotiation PDU where Digest is negotiated What will be the
digest?
 
3) In ISCSI Command format both W and F setting to 0
   is an error.
   Read command(R=1) but further reads can follow is not valid?
   @ 3.3.1

4) If the Initiator Sent less than FirstBurstSize( negotiated 
   maximum amount of unsolicated Data the target will accept)
   Why it is an error? 
   Sending Maximum than allowed can be an error but sending lesser
   than allowed how it can be an error?
   @ 3.3.5

5) Residual overflow error why it has kept target can read more
   and give only what the initiator is requesting.
   @ 3.4.1

Pratima

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 14 Dec 2001 18:41:36 +0200

[email-masked] wrote on 13-12-2001 22:42:41:

> I have few basic doubts. I am very thankful if some one clarifies those.
> I am listing them.
> 
pad bytes are not included in the length (there must be a way to convey 
the real length) and there are maximum 3 bytes of padding (minimum neede 
to reach a multiple of 4)
 
> 3) In ISCSI Command format both W and F setting to 0

+++ yes it is an error +++
>    Read command(R=1) but further reads can follow is not valid?
??? what is the question ???
>    than allowed how it can be an error?

It may negatively affect performance of targets that send R2T immediately 
after seeing the command an not waiting to see the F=1 for unsolicited - 
to "beat" the turnaround time.