Subject: iSCSI: text spanning

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 18 Dec 2001 11:54:54 -0500

Section 3.10.4 says:

 A Key=value pair can span Text request or response boundaries (i.e. a
 key=value pair can start in one PDU and continue on the next).

This paragraph says that code must be able to process every text
request/response in such a way as to accommodate really silly possibilities
(like “ke” in one PDU and “y=value” in the next). This could be a bit of a
burden for low end controllers.

I don’t think that was the intent of the statement.

Can we think of better wording to cover the needed case without impacting
the simple case?

Eddy
  _____

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 20 Dec 2001 01:39:35 +0200

Eddy,

This very issue was subject of debate and I supported the idea of text keys
not spanning a record.
Unfortunately some other requirements made us support a single receive
dictated PDU length and the minimum
is uncomfortably low for text keys (512 bytes).  This is what made me
change sides and  support keys spanning PDUs.

Julo

                    "Eddy Quicksall"                                                                      
                    <Eddy_Quicksall@iv       To:     "ips@ece. cmu. edu \(E-mail\)"                       
                    ivity.com>                <[email-masked]>                                           
                    Sent by:                 cc:                                                          
                    [email-masked].       Subject:     iSCSI: text spanning                            
                    edu                                                                                   

                    18-12-01 18:54                                                                        

Section 3.10.4 says:

This paragraph says that code must be able to process every text
request/response in such a way as to accommodate really silly possibilities
(like "ke" in one PDU and "y=value" in the next). This could be a bit of a
burden for low end controllers.

I don't think that was the intent of the statement.

Eddy