Subject: Session state and Text Sequence

From: "Rahul Bhagwat" <[email-masked]>
Date: Wed, 5 Dec 2001 14:53:11 +0530

Hi,

I have two questions here

1. The description for Q2 state for Session says "at least one connection"
    "is XPT_UP"

    A connection goes in XPT_UP state means that only the TCP connection
    is established and no login PDU is received.
    
    In this state, it is not possible for a connection to belong to any session
    as such (It is possible only after receiving the first login PDU which means
    the connection goes into IN_LOGIN state.

    So the description for Q2 state should be "at least one connection is 
    IN_LOGIN" 

2. The specification says that it is possible to split a key value pair across
    multiple Text PDUs.

    Consider a case where only one key value pair is to be sent by the initiator.
    How should the target respond to it ? Is the following valid request-response
    sequence in that case

    I  -> T  Text Request with partial key=value pair F=0
    T -> I   Text Response empty F=1
    I  -> T  Text Request with remaining key=value pair F=1
    T -> I   Text Response for the key=value pair F=1.

Regards,
Rahul

---

From: "Mallikarjun C." <[email-masked]>
Date: Sat, 8 Dec 2001 13:04:06 -0800

> So the description for Q2 state should be "at least one connection is

You are right, I will change it.  Thanks for the review.

>Is the following valid request-response sequence in that case

I believe so.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard MS 5668
Roseville CA 95747

----- Original Message -----
From: "Rahul Bhagwat" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, December 05, 2001 1:23 AM
Subject: Session state and Text Sequence

Hi,

    In this state, it is not possible for a connection to belong to any
session
    as such (It is possible only after receiving the first login PDU which
means
    the connection goes into IN_LOGIN state.

    Consider a case where only one key value pair is to be sent by the
initiator.
    How should the target respond to it ? Is the following valid
request-response
    sequence in that case

Regards,
Rahul