Subject: Re: iSCSI: scope of keys

From: "Julian Satran" <[email-masked]>
Date: Fri, 14 Dec 2001 22:50:15 +0200

Eddy,

I think the text says it - but if people love headers better I can add it 
(some voices needed).

Julo

"Eddy Quicksall" <[email-masked]>
Sent by: [email-masked]
14-12-01 22:12

        To:     "ips@ece. cmu. edu \(E-mail\)" <[email-masked]>
        cc: 
        Subject:        iSCSI: scope of keys

Would it make sense to add a ?scope? to each key definition? The IO and LO 
?use:? labels almost do that but not in all cases. For example:
 
 SW = Session wide 
 CO = Connection only
 
 Use: IO
 Who can send: Initiator
 Scope: SW
 
 Key=<value>
 
Eddy

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 14 Dec 2001 16:44:45 -0800

Julian,

I actually suggest something along the following lines at the beginning of
Appendix D, than labelling each key.  This would also allow us to not
specifically
call out each "IO" key as we currently do.

  All keys with LO or  FFPO, or qualified as Declarative use have session-wide
  applicability.  All keys with IO or ALL usage have connection-wide
applicability.

With that said, some general comments on keys -

- InitiatorAlias, TargetAlias and TargetAddress keys should be qualified with
   the "Declarative" label.

- I recommend changing InitialR2T, BidiInitialR2T and ImmediateData as IO,
   fom the current ALL (with the one-time change restrictions).   This makes
it
   simple, and besides I can not quite picture a scenario the current
allowance
   could be useful in.

- InitiatorAlias and TargetAlias are keys that merely report an alias set in a
  different management domain (hence declarative), with the currently
specified
  usage as ALL.  I assume it is so because the alias could be changed while
the
  session is in progress outside of iSCSI.  iSCSI does not however require
this
  key to be sent everytime the alias is changed during a session.  We should
either
  require this to avoid stale values, or much better, drop aliases altogether
from
  iSCSI (can be asynchronously set in a different domain, and not useful for
iSCSI
  protocol interactions)....

- Editorial: MaxRecvPDULength - s/b "Use: All" with "Use: ALL".
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard MS 5668
Roseville CA 95747

----- Original Message -----
From: "Julian Satran" <[email-masked]>
To: <[email-masked]>
Sent: Friday, December 14, 2001 12:50 PM
Subject: Re: iSCSI: scope of keys

Eddy,

Julo

 SW = Session wide
 CO = Connection only

 Use: IO
 Who can send: Initiator
 Scope: SW

 Key=<value>

Eddy

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 18 Dec 2001 10:25:44 -0500

IO means "only during login". It does not mean "connection only".

 13 TargetName

 Use: IO by initiator ALL by target, Declarative

 This key must be provided by the initiator of the TCP connection to
 the remote endpoint in the first login request ...

So, here is a case where it is session wide ... so IO cannot mean
"connection only" (I assume that since TargetName is not LO, then it must be
ok to send this key for each connection).

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, December 14, 2001 3:50 PM
To: [email-masked]
Subject: Re: iSCSI: scope of keys

Eddy,

I think the text says it - but if people love headers better I can add
it (some voices needed).

Julo

14-12-01 22:12

Would it make sense to add a "scope" to each key definition? The IO and
LO "use:" labels almost do that but not in all cases. For example:

 SW = Session wide

 CO = Connection only

 Use: IO

 Who can send: Initiator

 Scope: SW

 Key=<value>

Eddy