Subject: iSCSI: scope of keys

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 14 Dec 2001 15:12:12 -0500

Would it make sense to add a “scope” to each key definition? The IO and LO
“use:” labels almost do that but not in all cases. For example:

 SW = Session wide
 CO = Connection only

 Use: IO
 Who can send: Initiator
 Scope: SW

 Key=<value>

Eddy

---

From: "John Hufferd" <[email-masked]>
Date: Sun, 16 Dec 2001 23:03:51 -0800

I do not think that this has anything to do with sending stale values.
Whenever it is sent, it will be the value at that time.  Regardless of how
set.  No need to have async updates.   That is the way normal reporting
values work.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

"Mallikarjun C." <[email-masked]>@ece.cmu.edu on 12/14/2001 04:44:45 PM

Sent by:  [email-masked]

To:   "ips" <[email-masked]>
cc:
Subject:  Re: iSCSI: scope of keys

Julian,

I actually suggest something along the following lines at the beginning of
Appendix D, than labelling each key.  This would also allow us to not
specifically
call out each "IO" key as we currently do.

  All keys with LO or  FFPO, or qualified as Declarative use have
session-wide
  applicability.  All keys with IO or ALL usage have connection-wide
applicability.

With that said, some general comments on keys -

- InitiatorAlias, TargetAlias and TargetAddress keys should be qualified
with
   the "Declarative" label.

- I recommend changing InitialR2T, BidiInitialR2T and ImmediateData as IO,
   fom the current ALL (with the one-time change restrictions).   This
makes
it
   simple, and besides I can not quite picture a scenario the current
allowance
   could be useful in.

- InitiatorAlias and TargetAlias are keys that merely report an alias set
in a
  different management domain (hence declarative), with the currently
specified
  usage as ALL.  I assume it is so because the alias could be changed while
the
  session is in progress outside of iSCSI.  iSCSI does not however require
this
  key to be sent everytime the alias is changed during a session.  We
should
either
  require this to avoid stale values, or much better, drop aliases
altogether
from
  iSCSI (can be asynchronously set in a different domain, and not useful
for
iSCSI
  protocol interactions)....

- Editorial: MaxRecvPDULength - s/b "Use: All" with "Use: ALL".
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard MS 5668
Roseville CA 95747

----- Original Message -----
From: "Julian Satran" <[email-masked]>
To: <[email-masked]>
Sent: Friday, December 14, 2001 12:50 PM
Subject: Re: iSCSI: scope of keys

Eddy,

I think the text says it - but if people love headers better I can add it
(some voices needed).

Julo

"Eddy Quicksall" <[email-masked]>
Sent by: [email-masked]
14-12-01 22:12

        To:     "ips@ece. cmu. edu \(E-mail\)" <[email-masked]>
        cc:
        Subject:        iSCSI: scope of keys

Would it make sense to add a ?scope? to each key definition? The IO and LO
?use:? labels almost do that but not in all cases. For example:

 SW = Session wide
 CO = Connection only

 Use: IO
 Who can send: Initiator
 Scope: SW

 Key=<value>

Eddy

---

From: "John Hufferd" <[email-masked]>
Date: Sat, 22 Dec 2001 17:16:48 -0800

Eddy,
you read to much into my reply.  The Requirement is stated elsewhere, I do
not think all commentary can be included in that appendix.  The important
thing is it is consistent with the rest of the Draft.

I understand your point, but I do not know what the right trade off is
here.  Each time we repeat, in a different way, what is said elsewhere, we
increase the possibility of document errors and continue to extend the
length of the document.  As we push for Last Call, unless it is wrong, I
say leave it alone.

.
.
.
John L. Hufferd

"Eddy Quicksall" <[email-masked]>@ece.cmu.edu on 12/21/2001
06:13:29 AM

To:    John Hufferd/San Jose/IBM@IBMUS
cc:    Julian Satran/Haifa/IBM@IBMIL, <[email-masked]>
Subject:    RE: iSCSI: scope of keys

John,

I think my point was missed. Now you have possibly pointed out another
angle
to my point.

My point is that "use" does not contain enough information. In your
response
below, you have implied that IO now means "required" ... but it does not.

I think that "use" has been overloaded and I think each key should have a
list of properties (use is one, scope is another and now maybe required
should be a third).

Eddy

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Friday, December 21, 2001 1:05 AM
To: Eddy Quicksall
Cc: Julian Satran; [email-masked]
Subject: RE: iSCSI: scope of keys

Eddy,
It not only OK, it is required.

.
.
.
John L. Hufferd

"Eddy Quicksall" <[email-masked]>@ece.cmu.edu on 12/18/2001
07:25:44 AM

To:    Julian Satran/Haifa/IBM@IBMIL, <[email-masked]>
cc:
Subject:    RE: iSCSI: scope of keys

IO means "only during login". It does not mean "connection only".

 13 TargetName

 Use: IO by initiator ALL by target, Declarative

 This key must be provided by the initiator of the TCP connection to
 the remote endpoint in the first login request ...

So, here is a case where it is session wide ... so IO cannot mean
"connection only" (I assume that since TargetName is not LO, then it
must
be
ok to send this key for each connection).

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, December 14, 2001 3:50 PM
To: [email-masked]
Subject: Re: iSCSI: scope of keys

Eddy,

I think the text says it - but if people love headers better I can add
it (some voices needed).

Julo

14-12-01 22:12

Would it make sense to add a "scope" to each key definition? The IO and
LO "use:" labels almost do that but not in all cases. For example:

 SW = Session wide

 CO = Connection only

 Use: IO

 Who can send: Initiator

 Scope: SW

 Key=<value>

Eddy