Subject: iSCSI: SNACK and ExpDataSN

From: "John Hufferd" <[email-masked]>
Date: Sun, 30 Dec 2001 15:53:34 -0800

Julian,
The Section 3.16.1(dealing with SNACK) states:

"For a Status SNACK the ExpDataSN field is reserved."

I can not think of a reason that it should be used for Data/R2T SNACK
either.  Especially since the Begin Run field identifies the begging of the
missing Data.

Perhaps it should be revised to state "The ExpDataSN field is reserved
except for use with the Positive Acknowledgement SNACK."

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

---

From: "Julian Satran" <[email-masked]>
Date: Mon, 31 Dec 2001 07:54:20 +0200

John,

If look at the field numbering you will see that my intent was to take out 
ExpDataSN.
I don't know how it ended up staying in.

Thanks anyhow,
Julo

John Hufferd@IBMUS
31-12-01 01:53

        To:     Julian Satran/Haifa/IBM@IBMIL@IBMDE
        cc:     [email-masked]
        From:   John Hufferd/San Jose/IBM@IBMUS
        Subject:        iSCSI: SNACK and ExpDataSN

Julian,

I can not think of a reason that it should be used for Data/R2T SNACK 
either.  Especially since the Begin Run field identifies the begging of 
the missing Data.

.
.
.
John L. Hufferd