Subject: RE: iSCSI: not offering a key

From: Eddy Quicksall <[email-masked]>
Date: Fri, 25 Jan 2002 14:55:31 -0500

Maybe I don't understand the sentence. I interpret it to mean that if the
default value is acceptable to me then not offering it is somehow different
than the default ... and that confuses me (well, actually it makes me wonder
if the sentence is trying to say something else).
 
I think I get it ... the default for MaxConnections is 1. If I offer
MaxConnections=1 (the default) then the target can't negotiate for more
connections even though I could have supported more connections. Is that
what you are trying to say?
 
It is probably just me but is there a clearer way to convey what you are
trying to say?

Eddy 
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, January 25, 2002 2:00 PM
To: Eddy Quicksall
Cc: ips@ece. cmu. edu (E-mail)
Subject: Re: iSCSI: not offering a key

To keep the negotiation stateless - Julo 

Eddy Quicksall <[email-masked]> 
25-01-02 17:08 
        
        To:        "ips@ece. cmu. edu (E-mail)" <[email-masked]> 
        cc:        Julian Satran/Haifa/IBM@IBMIL 
        Subject:        iSCSI: not offering a key 

The spec says: 
  
Not offering a key for negotiation is not 
equivalent to offering the current (or default) value. 
  
Does anyone know why? 
  
Eddy

---

From: "Robert D. Russell" <[email-masked]>
Date: Fri, 25 Jan 2002 17:52:34 -0500 (EST)

I believe this sentence was added to the spec because at the
last UNH plugfest, several people were interpreting "no explicit
offer" of a key as an "implicit" offer of the default for the key,
and were therefore expecting a reply.  This sentence is intended
to prevent that interpretation -- if you don't make an explict offer
you cannot expect a reply -- there are no such things as implicit offers.

Bob Russell