Subject: iSCSI: changelog ver8 to ver9

From: "Prasenjit Sarkar" <[email-masked]>
Date: Tue, 22 Jan 2002 05:15:10 -0800

The units for FirstBurstSize, MaxBurstSize, etc has been changed from 512
bytes to bytes and has not been reflected in the changelog.

Prasenjit

   Prasenjit Sarkar
   Research Staff Member
   IBM Almaden Research
   San Jose

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 24 Jan 2002 07:52:45 +0200

We can debate for ever if 3m are equivalent or not to 0.003km.
If a nuit change breaks your implementation you certainly have to look 
closer at it.
I won't comment anymore on this noise.

Julo

Paul Koning <[email-masked]>
23-01-02 15:59

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        Re: iSCSI: changelog ver8 to ver9

Excerpt of message (sent 22 January 2002) by Julian Satran:
> Prasenjit,
> 
> Should I read your statement as a question - i.e., with a why preceding 
it?
> They where many other editorial changes that are not reflected in the 
log -
> they have no major
> significance and the change bars in the pdf file reflect them.
> The new units are clearly stated everywhere.

But a change in units is not an editorial change.  Editorial changes
are changes that affect the way things are described but not the way
the implementations are coded.  A change in units is a message
encoding change and requires changes to implementations.

                  paul

---

From: [email-masked]
Date: Thu, 24 Jan 2002 02:16:50 -0500

Julian,
 
Paul is right because the units aren't sent in the message -
in your example if the meaning of 3 changes from 3 meters to
3 kilometers, the implementation has to be revised to send
0.003 instead of 3.  This is a small change, but it is a change
(not just editorial).  Please add this to the change log for
the next version.
 
Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, January 24, 2002 12:53 AM
To: [email-masked]
Subject: Re: iSCSI: changelog ver8 to ver9

Julo 

23-01-02 15:59 

it?
> They where many other editorial changes that are not reflected in the log
-

                 paul