Subject: RE: iSCSI Text Request

From: Eddy Quicksall <[email-masked]>
Date: Wed, 16 Jan 2002 08:54:56 -0500

A "protocol error" is only represented by a Reject and the login phase only
allows Login PDU's (see 2.2.3). So, I use a Login Response with status =
0200 (Initiator Error).

There should probably be more status's defined. For example, Section 5.1
(Login Phase Start) says:
 
        the target may reply with a Login Response indicating that it is 
        unwilling to accept the connection without SecurityNegotiation and 
        terminate the connection. 
         
But the table in 3.13 (Login Response) does not give a status for explicitly
that. So, I give 0201 (Authentication Failure).

Comments?

Eddy

-----Original Message-----
From: BURBRIDGE,MATTHEW (HP-UnitedKingdom,ex2)
[mailto:[email-masked]]
Sent: Friday, December 14, 2001 3:12 AM
To: 'Dave Francheski'; [email-masked]
Subject: RE: iSCSI Text Request 

Dave,

You are correct: only Login Requests and Login Responses are allowed
during the login phase.  Until FFP, any other PDU is protocol? error.
The use of Text PDUs were removed when we revised the login procedure as
there were no benefits for using different PDUs (i.e. Text PDUs).

Matthew Burbridge
Senior Development Engineer
NIS-Bristol
Hewlett Packard
Telnet: 312 7010
E-mail: [email-masked]

-----Original Message-----
-----Original Message-----
From: Dave Francheski [mailto:[email-masked]]
Sent: Thursday, December 13, 2001 7:23 PM
To: [email-masked]
Subject: iSCSI Text Request

Before full feature phase is entered, is it valid for an initiator to
send a
Text Request PDU for parameter negotiation purposes?   In other words,
are only Login Request PDUs and Login Response PDUs allowed during
the login phase?

I believe iSCSI draft 9 only permits Login Request/Response PDUs
during the login phase, but we've noticed that some initiators violate
this restriction.

Regards,

David Francheski   
Seven Systems Technologies
575 Menlo Drive Suite 2
Rocklin CA
916-577-1281
[email-masked]

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 17 Jan 2002 09:45:33 +0200

Eddy,

We did not think that it is worth having a variety of statuses for
different errors.
After a (relatively long) debate we reduced them to the current list.
It could have been shorter (as in the old Unix ?).
In any case your choices are the ones we had in mind too.

Regards,
Julo

                    Eddy Quicksall                                                                  
                    <Eddy_Quicksall@iv       To:     "BURBRIDGE,MATTHEW (HP-UnitedKingdom,ex2)"     
                    ivity.com>                <[email-masked]>, "'Dave Francheski'"       
                    Sent by:                  <[email-masked]>, [email-masked]            
                    [email-masked].       cc:                                                    
                    edu                      Subject:     RE: iSCSI Text Request                    

                    16-01-02 15:54                                                                  

But the table in 3.13 (Login Response) does not give a status for
explicitly
that. So, I give 0201 (Authentication Failure).

Comments?

Eddy

-----Original Message-----

Dave,

Matthew Burbridge

-----Original Message-----
-----Original Message-----
From: Dave Francheski [mailto:[email-masked]]
Sent: Thursday, December 13, 2001 7:23 PM
To: [email-masked]
Subject: iSCSI Text Request

Regards,

David Francheski