Subject: RE: iSCSI: NopIn in ping mode can contain data?

From: "Julian Satran" <[email-masked]>
Date: Tue, 22 Jan 2002 09:38:15 +0200

Rod,

Initiators are usually build under the assumption that they are "in 
control" - e.g., no unsolicited data.
Having them prepare for unsolicited data without good cause does not seem 
a good idea.

Julo

"Rod Harrison" <[email-masked]>
21-01-02 17:31

        To:     Julian Satran/Haifa/IBM@IBMIL, <[email-masked]>
        cc: 
        Subject:        RE: iSCSI: NopIn in ping mode can contain data?

Julian,

                 What's the reason behind preventing the target sending 
ping data? I
would have thought it would be just as much use for a target as it is
for an initiator.

                 - Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
Sent: Saturday, January 19, 2002 3:23 PM
To: [email-masked]
Subject: Re: iSCSI: NopIn in ping mode can contain data?

No  data - will indicate this in 10 - Julo

Tow Wang <[email-masked]>
Sent by: [email-masked]
16-01-02 01:10

        To:        [email-masked]
        cc:
        Subject:        iSCSI: NopIn in ping mode can contain data?

Hello everybody.

1) When a target sends out a NopIn as a ping, is it allowed to contain
a
data segment?
2) If yes,
   a) why would anyone send data along?
   b) must the initiator echo back the data?

I haven't found a clear answer in draft 9. Thanks for any
clarifications.
--
Tow Wang
Adaptec Software Engineer

---

From: Ajit Aryan <[email-masked]>
Date: Tue, 22 Jan 2002 14:53:23 +0530

Julo,
By this we should be able to say one thing, NOPIn in ping mode can 
contain data. What every care has to be taken about the data. Now, what
should be the solicited data? In sense, the data which the initiator
could use for tuning, negotiation etc...??

Aryan

Julian Satran wrote:

> Having them prepare for unsolicited data without good cause does not 
> seem a good idea.
> 
> Julo
> 
>

---

From: Tow Wang <[email-masked]>
Date: Wed, 23 Jan 2002 10:47:57 -0800

Hello.

For negotiation you'd use login and text commands; we have said before that
targets can offer text key=value pairs out of their own initiative.

I don't see your reasoning here, and can't understand your second sentence.

Tow

--
Tow Wang
Adaptec Software Engineer       Telephone: 408 957 4838
Mail stop 46                               800 869 8883 x4838
691 South Milpitas Boulevard    Fax:       530 686 8023
Milpitas, California 95035      E-mail:    [email-masked]