Subject: RE: iSCSI: One Node or Two?

From: David Dillard <[email-masked]>
Date: Mon, 28 Jan 2002 12:21:12 -0500

Mark,

I agree that your suggested rewordings clear things up (certainly works for
me anyway).

Thanks,

David

> -----Original Message-----
> From: Mark Bakke [mailto:[email-masked]]
> Sent: Monday, January 28, 2002 11:30 AM
> To: David Dillard
> Cc: IETF IPS Workgroup Reflector (E-mail)
> Subject: Re: iSCSI: One Node or Two?
> 
> 
> David-
> 
> The "or" is meant to be a non-exclusive or.  An iSCSI Node can
> be both an initiator and a target, and have the same iSCSI name
> for both.  See draft-ietf-ips-iscsi-name-disc-04:
>            
> >           2. iSCSI Names 
> >               
> >                 The main addressable, discoverable entity 
> in iSCSI is an iSCSI 
> >                 Node.  An iSCSI node can be either an 
> initiator, a target, or 
> >                 both. 
> 
> I agree that we should fix up the wording in the iSCSI draft to
> clarify this.  How about changing:
> 
> Section 1. Definitions:
> >         - iSCSI Name: The name of an iSCSI initiator or 
> iSCSI target.  
> 
> To:
> 
>         - iSCSI Name: The name of an iSCSI node, which can be an iSCSI
>           initiator, target, or both.
> 
> 2.5.1 iSCSI Architecture Model
> >                 b) iSCSI Node - The iSCSI Node represents a 
> single iSCSI 
> >                 initiator or iSCSI target.  There are one 
> or more iSCSI 
> >                 Nodes within a Network Entity.
> 
> To:
> 
>                 b) iSCSI Node - The iSCSI Node represents a 
> single iSCSI 
>                 initiator and/or iSCSI target.  An iSCSI Node 
> can be both
>                 and initiator and a target.  There are one or 
> more iSCSI 
>                 Nodes within a Network Entity. 
> 
> 
> I think that these two changes should clear this up.
> 
> --
> Mark
> 
> 
> David Dillard wrote:
> > 
> > As defined in the latest draft an iSCSI Node "... 
> represents a single iSCSI
> > initiator or iSCSI target."
> > 
> > By this definition an LU that acts as both an initiator and 
> a target, such
> > as a data mover for extended copy, is two iSCSI nodes.  
> This LU will have
> > two iSCSI names, one for the initiator side of the LU and 
> one for the
> > target.  Therefore, there will be two  iSNS "entries" for this LU.
> > 
> > My question is: Is this intended?
> > 
> > Regards,
> > 
> > David
> 
> -- 
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054
>

---

From: "John Hufferd" <[email-masked]>
Date: Mon, 28 Jan 2002 09:48:46 -0800

David.
It is possible that this 2 way target has two different Names.  However,
since the SCSI Initiator Port is a dynamically created entity, and the only
unique part of its ID (within the Initiator Node) is its ISID,  there is no
reason there has to be a different iSCSI Node Name.

An implementation, however, could create a node that is uses for all iSCSI
Initiator functions,  however, there is no hard reason for that, and
depending on how it is named it may either be more or less confusing to the
Administrator.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

David Dillard <[email-masked]>@ece.cmu.edu on 01/28/2002
08:03:24 AM

Sent by:    [email-masked]

To:    "IETF IPS Workgroup Reflector (E-mail)" <[email-masked]>
cc:
Subject:    iSCSI: One Node or Two?

As defined in the latest draft an iSCSI Node "... represents a single iSCSI
initiator or iSCSI target."

By this definition an LU that acts as both an initiator and a target, such
as a data mover for extended copy, is two iSCSI nodes.  This LU will have
two iSCSI names, one for the initiator side of the LU and one for the
target.  Therefore, there will be two  iSNS "entries" for this LU.

Regards,

David