Subject: RE: iScsi:

From: Nitin Dhingra <[email-masked]>
Date: Thu, 3 Jan 2002 10:36:50 +0530

Well, let's take a case 
where you have one target and many initiators connected that target

And as iScsi is at block level, so if more than one initiator have requested
to write at the same block address at the same time at the same target 
this can create synchronization problems, don't you think?

Shouldn't you give an option like most other protocols like NFS does,
where you have a separate optional layer for locking/synchronization...

Don't you think this should be handled by iScsi??

- Nitin

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Wednesday, January 02, 2002 3:10 PM
To:	[email-masked]; [email-masked]
Subject:	RE: iScsi:

I don't understand this - what exactly is broken that you think
needs to be fixed?  Many SCSI targets do implement access controls
at the logical unit level, which is in T10's domain, not iSCSI's.

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Nitin Dhingra [mailto:[email-masked]]
> Sent: Wednesday, January 02, 2002 12:40 AM
> To: [email-masked]
> Subject: iScsi:
> 
> 
> Why don't you put a restriction on the read/write access to a target?
> This can solve some of the synchronization problems that can occur...
> 
> And Yeah Happy New Year to All...
> 
> - Nitin 
>

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Thu, 03 Jan 2002 00:39:16 -0800

Without iSCSI, in a normal circumstance where you have one target device and multiple HBA's acting as initiator, Who handles the synchronization? How is iSCSI bring up this issue. Isn't is already handled ?

SG

*********** REPLY SEPARATOR  ***********