Subject: UNH iSCSI Initiator install: /proc/scsi/iscsi_initiator/X Operation not permitted

From: "Nike Chen" <[email-masked]>
Date: Thu, 17 Jan 2002 15:13:24 +0800

Hi All:

After I build the UNH iSCSI linux project v6.09 successfully,
I run the following command:

1. insmod iscsi_initiator.o
2. iscsi_config up ip=*** port=4000

and iscsi_config response the follwoing message:

/proc/scsi/iscsi_initiator/0 Operation not permitted

But I do see the exact file in /proc/scsi/iscsi_initaiator,
and I was loggin as root.

Does anyone tell me where may be went wrong, and how to check?

Thanks.
Nike

---

From: Thanu Skariah <[email-masked]>
Date: Fri, 18 Jan 2002 09:34:44 +0530

Hi,

We met with similar error messages in earlier versions when installing
them, some time back. This was solved then by giving 
the hostname and the ip address of the target machine in /etc/hosts file
of the initiator machine. 
Let me know if that helped.

Thanks,
Thanu

> Nike Chen wrote:

-- 
Thanu Skariah
Member Technical Staff
Hcl Technologies , Chennai.
http://www.san.hcltech.com