Subject: Re: iSCSI: NopIn in ping mode can contain data?

From: "Julian Satran" <[email-masked]>
Date: Sat, 19 Jan 2002 17:23:27 +0200

No  data - will indicate this in 10 - Julo

Tow Wang <[email-masked]>
Sent by: [email-masked]
16-01-02 01:10

        To:     [email-masked]
        cc: 
        Subject:        iSCSI: NopIn in ping mode can contain data?

Hello everybody.

1) When a target sends out a NopIn as a ping, is it allowed to contain a
data segment?
2) If yes,
    a) why would anyone send data along?
    b) must the initiator echo back the data?

I haven't found a clear answer in draft 9. Thanks for any
clarifications.
--
Tow Wang
Adaptec Software Engineer

---

From: "Rod Harrison" <[email-masked]>
Date: Mon, 21 Jan 2002 15:31:43 -0000

Julian,

	What's the reason behind preventing the target sending ping data? I
would have thought it would be just as much use for a target as it is
for an initiator.

	- Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
Sent: Saturday, January 19, 2002 3:23 PM
To: [email-masked]
Subject: Re: iSCSI: NopIn in ping mode can contain data?

        To:        [email-masked]
        cc:

Hello everybody.

1) When a target sends out a NopIn as a ping, is it allowed to contain
a
data segment?
2) If yes,
   a) why would anyone send data along?
   b) must the initiator echo back the data?