Subject: iSCSI: invalid key value

From: Eddy Quicksall <[email-masked]>
Date: Fri, 25 Jan 2002 10:17:12 -0500

If a key has a value that is not valid, do you know how I respond?
 
For example, DataDigest=#$C32C,none. The valid values are CRC32C,none.
 
If I say DataDigest=NotUnderstood, wouldn't that mean the key was not
understood?
 
If I say DataDigest=Reject, that would mean I don't support the key for the
current initiator.
 
If I say DataDigest=Irrelevant, that would mean the digest is not relevant
for the current negotiation.
 
If I say DataDigest=none, that would mean I don't support CRC32C when in
reality I do. It could be that, since there is no digest in login, the 1st
two letters got changed.
 
If I treat it as a protocol error and send a response with status == 0200 or
0201, then the initiator does not know why.
 
Eddy

---

From: Steve Senum <[email-masked]>
Date: Fri, 25 Jan 2002 09:56:43 -0600

Eddy,

If someone sends me "DataDigest=#$C32C,none".
I will respond "DataDigest=none".

I think responding with "DataDigest=NotUnderstoood"
or one of the other special responses would be wrong,
as there is nothing wrong with the key ("DataDigest").

Since I support "none", and can't tell "#$C32C"
is really "CRC32C", I believe "DataDigest=none"
is the only correct response.

Steve Senum

-----------------------------------------
Subject: iSCSI: invalid key value
   Date: Fri, 25 Jan 2002 10:17:12 -0500
   From: Eddy Quicksall <[email-masked]>
     To: "ips@ece. cmu. edu (E-mail)" <[email-masked]>

If I say DataDigest=Irrelevant, that would mean the digest is not relevant for
the current negotiation.

If I say DataDigest=none, that would mean I don’t support CRC32C when in reality
I do. It could be that, since there is no digest in login,
the 1st two letters got changed.

Eddy