Subject: RE: Differences between iSCSI Router (ex. CISCO RN5420) and iSCSI Switch (ex. SANRAD Switch 3000)

From: Camden Ford <[email-masked]>
Date: Tue, 15 Jan 2002 08:13:45 -0800

Nike,
 
Please be careful about the difference between technical capabilities and
Marketing fluff.  Cisco's iSCSI Router is simply a  bridge between FC and
iSCSI.  It performs protocol conversion for SCSI commands encapsulated in
iSCSI on TCP and SCSI commands encapsulated in FC.  This product also
provides simplistic mapping between iSCSI devices and FC domains.
 
I am not familiar with the SANRAD switch, but I suspect that provides very
similar capabilities.
 
If you were to compare either of these products to our notion of Switching
and Routing in the IP/Ethernet world, these are neither Switches or
Routers....but simple Bridges, much like the early Ethernet Bridges.
 
iSCSI switches are simple Ethernet Switches or any other switch that can
switch or route TCP/IP.  Because iSCSI utilizes TCP/IP, the iSCSI protocol
rides as a byte stream on top of TCP.  Therefore, most switches are unaware
that the packets that they are switching or routing are actually iSCSI.
They simply appear as another TCP byte stream.  So if you think in terms of
Layer X switching, a simple Layer 2 switch is a switch based in a transports
like EThernet, a Layer 3 switch is a simple version of a router with IP
forwarding inmplemented in HW.  A Layer 4 switch can prioritize traffic
based on TCP connections.  In order to provide intelligence in a switch that
recognizes iSCSI, it would be somewhere in Layer 5-7 depending on what you
filter on.
 
I would imaging that in order for any product to be a Storage Router, there
would have to be the notion of Global Addressing of storage
elements....something which does not exist today.
 
Technically, FC switching is based on logical addressing, and not physical
addresses, so it is most similar to Layer 3 switching in
IP/EThernet....which some might call a router.
 
Camden ford

-----Original Message-----
From: Nike Chen [mailto:[email-masked]]
Sent: Tuesday, January 15, 2002 12:29 AM
To: [email-masked]
Subject: Differences between iSCSI Router (ex. CISCO RN5420) and iSCSI
Switch (ex. SANRAD Switch 3000)

Hi All:
 
Would anybody tell me the function differences between iSCSI Router and
Switch, 
or just like performance difference in Layer 3 switch and Router?
When it say it is a iSCSI switch, what level do it operate, level 2, 3 or 4?
When it say it is a iSCSI Router, what level do it operate, or just a
protocol
converting gateway?
Is there any definition for iSCSI Router or iSCSI switch?
 
Thanks,
Nike

---

From: "Naveen Nimmu" <[email-masked]>
Date: Tue, 15 Jan 2002 10:34:48 -0800

[snip]

Camden,
  Given that iSCSI  is defined above TCP it falls in layer 5 . FCP on FC
also does a similar function. From the networking protocol perspective It
may be better to call the ‘cisco  Storage router’ a SCSI gateway than a
simple bridge.

Naveen nimmu

Camden ford
-----Original Message-----
From: Nike Chen [mailto:[email-masked]]
Sent: Tuesday, January 15, 2002 12:29 AM
To: [email-masked]
Subject: Differences between iSCSI Router (ex. CISCO RN5420) and iSCSI

Thanks,
Nike

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Wed, 16 Jan 2002 08:49:43 -0800

Camden,
   I would like to add a point here that there is the World Wide Name (WWN) convention that is responsible for a unique identification of a storage device.
   
SG

*********** REPLY SEPARATOR ***********

On 1/15/2002 at 10:34 AM Naveen Nimmu wrote:

 [snip]
If you were to compare either of these products to our notion of Switching and Routing in the IP/Ethernet world, these are neither Switches or Routers....but simple Bridges, much like the early Ethernet Bridges.
 
Camden,
  Given that iSCSI  is defined above TCP it falls in layer 5 . FCP on FC also does a similar function. From the networking protocol perspective It may be better to call the ¡¥cisco  Storage router¡¦ a SCSI gateway than a simple bridge. 
 
Naveen nimmu

iSCSI switches are simple Ethernet Switches or any other switch that can switch or route TCP/IP.  Because iSCSI utilizes TCP/IP, the iSCSI protocol rides as a byte stream on top of TCP.  Therefore, most switches are unaware that the packets that they are switching or routing are actually iSCSI.  They simply appear as another TCP byte stream.  So if you think in terms of Layer X switching, a simple Layer 2 switch is a switch based in a transports like EThernet, a Layer 3 switch is a simple version of a router with IP forwarding inmplemented in HW.  A Layer 4 switch can prioritize traffic based on TCP connections.  In order to provide intelligence in a switch that recognizes iSCSI, it would be somewhere in Layer 5-7 depending on what you filter on.
 
I would imaging that in order for any product to be a Storage Router, there would have to be the notion of Global Addressing of storage elements....something which does not exist today.
 
Technically, FC switching is based on logical addressing, and not physical addresses, so it is most similar to Layer 3 switching in IP/EThernet....which some might call a router.
 
Camden ford
-----Original Message-----
From: Nike Chen [mailto:[email-masked]]
Sent: Tuesday, January 15, 2002 12:29 AM
To: [email-masked]
Subject: Differences between iSCSI Router (ex. CISCO RN5420) and iSCSI Switch (ex. SANRAD Switch 3000)
Hi All:
 
Would anybody tell me the function differences between iSCSI Router and Switch, 
or just like performance difference in Layer 3 switch and Router?
When it say it is a iSCSI switch, what level do it operate, level 2, 3 or 4?
When it say it is a iSCSI Router, what level do it operate, or just a protocol
converting gateway?
Is there any definition for iSCSI Router or iSCSI switch?
 
Thanks,
Nike

---

From: Sajay Selvaraj <[email-masked]>
Date: Mon, 21 Jan 2002 21:47:38 +0530

Sukanta,

   I suppose you are referring to an FC node. I remember an old thread on 'a standard
way of representing/mapping WWNames in iSCSI' ? This was with special reference to
iSCSI-FC address mapping. Any new ideas on a standard way to do this ?

Regards,
Sajay

Camden,
   I would like to add a point here that there is the World Wide Name (WWN) convention that is
responsible for a unique identification of a storage device.
   
SG

        [snip]
<sniped>
-- 
http://san.hcltech.com

---

From: Sukanta ganguly <[email-masked]>
Date: Mon, 21 Jan 2002 10:12:07 -0800 (PST)

I don't have one now, but am working on defining one.
All I was trying to state in my reply to the Camden
was the WWN does exist and can be leveraged for the
unique identification.

SG
--- Sajay Selvaraj <[email-masked]> wrote:
>    I would like to add a point here that there is
> the World Wide Name (WWN) convention that is

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/