Subject: Fw: Session state and Text Sequence

From: "Rahul Bhagwat" <[email-masked]>
Date: Fri, 25 Jan 2002 13:42:23 +0530

Hi,

In the v10 specification, I think there is a problem in explanation of connection state
transition T6 for target which reads
"target: Timed out waiting for an iSCSI Login, or 
            transport disconnect indication was received, or 
            transport reset was received, or an internal event 
            indicating a transport timeout was received, or an 
            internal event of sending a Logout response (suc-
           cess) on another connection for a  close the ses-
           sion  Logout command was received. In all these 
           cases, the connection is to be closed."

The part of the statement "on another connection for a close the
session Logout command was received" does not seem correct.

T6 change happens only when target is in S3 (XPT_UP) state.
In this state, the connection cannot belong to any session and
must not be closed.
In a specific case, if there was only one initiator and one session,
(which means that the connection was actually intended for the
session being logged out) the connection can probably get closed
due to login timeout at target side or initiator explicitly closing it.

Please let me know if this is correct.

Regards,
Rahul

----- Original Message ----- 
From: Rahul Bhagwat 
To: [email-masked] 
Sent: Wednesday, December 05, 2001 2:53 PM
Subject: Session state and Text Sequence

Hi,

I have two questions here

1. The description for Q2 state for Session says "at least one connection"
    "is XPT_UP"

    A connection goes in XPT_UP state means that only the TCP connection
    is established and no login PDU is received.
    
    In this state, it is not possible for a connection to belong to any session
    as such (It is possible only after receiving the first login PDU which means
    the connection goes into IN_LOGIN state.

    So the description for Q2 state should be "at least one connection is 
    IN_LOGIN" 

2. The specification says that it is possible to split a key value pair across
    multiple Text PDUs.

    Consider a case where only one key value pair is to be sent by the initiator.
    How should the target respond to it ? Is the following valid request-response
    sequence in that case

    I  -> T  Text Request with partial key=value pair F=0
    T -> I   Text Response empty F=1
    I  -> T  Text Request with remaining key=value pair F=1
    T -> I   Text Response for the key=value pair F=1.

Regards,
Rahul

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 25 Jan 2002 12:00:50 -0800

Rahul,

>In this state, the connection cannot belong to any session...

You are correct!  I will remove the wording.

Thanks for the review.
-- 
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

Hi,
 
In the v10 specification, I think there is a problem in explanation of
connection state

 
 
Regards,
Rahul