Subject: RE: iSCSI: Markers

From: "Williams, Jim" <[email-masked]>
Date: Thu, 10 Jan 2002 16:50:35 -0500

> -----Original Message-----
> From: Somesh Gupta [mailto:[email-masked]]
> Sent: Thursday, January 10, 2002 1:48 PM
> To: Stephen Bailey; [email-masked]
> Subject: RE: iSCSI: Markers 
> 
> 
> Jim,
> 
> What are the issues with "one PDU per TCP segment"? I
> think this would really enable simple, high performance
> Upper Layer protocol processing over TCP.

I have some doubts that the ability to place data out
of order will actually result in a more cost effective
NIC.  Even without out of order placement, there may
be some benefit to "one PDU per TCP segment", of course
in this case there is no need for markers.

In any case, the only thing I have objected to is
making markers a requirement to use if other end
requests it.  I don't have a problem with making it
an option (both ends agree) and see if it flies.

> Of course,
> you always have the issue that no matter what method
> is used, data can only be placed and not processed
> out of sequence (which implies that there is additional
> complexity if barrier lists and so on and having to do
> control processing at a faster rate when you do perform
> out of order processing).
> 
> Somesh

---

From: "Somesh Gupta" <[email-masked]>
Date: Thu, 10 Jan 2002 15:22:48 -0800

I agree that there is no rigorous system level analysis
to back this up (no disrespect intended but none has been
shared). On the surface it seems it should help. (One
area where it should help is in latency reduction).

1. Assuming out of order segments happen due to
packet loss (and yes routers have pretty much stopped
reordering segments), it has an impact on the TCP
send rate - you are really not going to go full speed
anymore.

2. The memory requirement is always round trip delay *
bandwidth. It is not a product of number of connections
& the window size on each connection. Pathological cases
can require more memory, but then we have chose TCP because
we can recover from lost (or dropped in this case) packets.

   It is the memory access speed required which is
really the problem. At 1 Gig or even multi-1G, it is not
an issue today.

3. The processing of Upper Layer Protocol has to wait
(at least theoretically) for the out of order segment to
arrive. So when out of order segment arrives, we have a
flood of protocol processing to take care of - previously
received segments, and new segments that are arriving.

Anyhow, it is an interesting concept and worth further
exploration.

Somesh

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Williams, Jim
> Sent: Thursday, January 10, 2002 1:51 PM
> To: [email-masked]