Subject: Re: SCSI Format/Copy CDB support

From: "Julian Satran" <[email-masked]>
Date: Fri, 25 Jan 2002 11:21:14 +0200

Amir,

The draft says in several places that CmdSN is not important after the 
task gets to SCSI.
On 2 yes you might be right but that is purely an implementation issue. 
Format commands do not time-out
at SCSI level and iSCSI has no cause to e "nervous" - nothing is expected.

Julo

"Amir Shalit" <[email-masked]>
Sent by: [email-masked]
25-01-02 02:10

        To:     "ips@ece. cmu. edu \(E-mail\)" <[email-masked]>
        cc: 
        Subject:        SCSI Format/Copy CDB support

I see a few problems in implementing the format/copy commands over iSCSI
 
1) CmdSN may wrap between command and response (assuming multiple LUNs)
 
2) iSCSI keepalive NOPs may be required to keep the connection open during 
format

---

From: "Amir Shalit" <[email-masked]>
Date: Fri, 25 Jan 2002 08:49:51 -0800

Julo,

I agree with you on (2).

Section 2.2.2.1 is saying:
"A numbered iSCSI request will not change its allocated CmdSN
regardless of the number of times and circumstances in which it is
reissued."

A long duration SCSI command may be aborted by a task management
command and than reissued by iSCSI with a stale CmdSN.

Amir
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
  Sent: Friday, January 25, 2002 1:21 AM
  To: Amir Shalit
  Cc: ips@ece. cmu. edu (E-mail); [email-masked]
  Subject: Re: SCSI Format/Copy CDB support

  Amir,

  Julo