Subject: iSCSI: keys allowed during security stage

From: Eddy Quicksall <[email-masked]>
Date: Thu, 24 Jan 2002 17:33:38 -0500

Julian,
 
What would you think about putting a list of keys that are allowed during
security stage in Section 11? The reason I ask this is because currently you
have to read through each key to figure that out.
 
I think the only keys allowed during security stage are:
 
SessionType
InitiatorName
TargetName
AuthMethod
And all keys listed under AuthMethod along with all of their associated
keys.
 
If you don't want to list them, can you please confirm that I am correct
above (e.g., HeaderDigest is not allowed in security stage)?
 
Eddy

---

From: "Amir Shalit" <[email-masked]>
Date: Thu, 24 Jan 2002 16:10:23 -0800

I see a few problems in implementing the format/copy commands over iSCSI

1) CmdSN may wrap between command and response (assuming multiple LUNs)

2) iSCSI keepalive NOPs may be required to keep the connection open during
format