Subject: iSCSI:regarding connection shutdown

From: Subrahmanya Sastry K V <[email-masked]>
Date: Thu, 17 Jan 2002 20:13:22 +0530

Hi all,

 Section 1.2.6 of the iscsi draft 07 says :
"Graceful connection shutdowns MUST only occur when there are no
outstanding tasks that have allegiance to the connection or when the
connection is not in full-feature phase."

But section 2.2.6 of the iscsi draft 08 and 09 say :
"Graceful connection shutdowns MUST only occur when there are no
outstanding tasks that have allegiance to the connection and when the
connection is not in full-feature phase."

The sentence mentioned in draft 07 sounds clear as it talks about the
two possibilities of graceful connection shutdown.
But the same sentence in draft 08 and 09 suggests a different meaning
because of 'and'. Is there any reason why this has been changed to 'and'
?

I'm asking this because this change has not been recorded in the change
log. Please clarify .

Regards,
Sastry

--
Subrahmanya Sastry K V
Member Technical Staff
HCLTech, Chennai, INDIA
http://san.hcltech.com

---

From: "Mallikarjun C." <[email-masked]>
Date: Thu, 17 Jan 2002 11:19:06 -0800

Sastry,

Thanks for the close review.

As I mentioned in an earlier response to Nandakumar 
on this subject, the "graceful connection shutdown"
is referring to a graceful TCP connection shutdown.

With that said, the usage of "and" in the quoted sentence
was meant to underline the point that a connection shutdown
must be initiated only after the Logout dialogue is cleanly
complete - a mere `no active tasks` is not sufficient to
drop the connection - since iSCSI connection and session 
structures would hang around (until timeout, waiting for
session continuation) if a clean logout is not done.  This
was sought to be actively discouraged.

On thinking more about it, I think perhaps this sentence
says more than is necessary.  It's completely legitimate
for initiators to Logout("close") a connection to implicitly 
abort all active tasks.  If one merely ensures that the 
connection is *not* in the FFP to start a TCP connection 
close, that is completely adequate (since the active tasks 
if any, were automatically taken care of in the Logout process).  
So, I would actually suggest wording like -

 "A graceful connection shutdown MUST be initiated only
  when the connection is not in full-feature phase."  

We already have wording there that takes care of outstanding
tasks -"Connection termination with outstanding commands
may require recovery actions."

Also, I noticed that the section doesn't consistently use 
"termination" - we need to address that aspect as well.

Please comment if something isn't clear.

Thanks.
-- 
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

Subrahmanya Sastry K V wrote:
> because of 'and'. Is there any reason why this has been changed to
> 'and' ?
> 
> I'm asking this because this change has not been recorded in the
> change log. Please clarify .
> 
> Regards,
> Sastry
> 
> --
> Subrahmanya Sastry K V
> Member Technical Staff
> HCLTech, Chennai, INDIA
> http://san.hcltech.com
>