Subject: iSCSI: data-out initiator transfer tags

From: "Buck Landry" <[email-masked]>
Date: Wed, 2 Jan 2002 18:18:19 -0600

Is it required that the initiator transfer tag (ITT) for a data-out pdu be identical to the ITT of the scsi command pdu it is associated with?

I would assume so for consistency's sake, but have seen implementations that assumed the target would use the data-out pdu's target transfer tag to look up the associated command.

Thanks,
Buck

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 3 Jan 2002 10:07:35 +0200

Buck,

Yes ITT in data and command have to be the same.
And yes the targets will use the TTT to speed-up the look-up and match 
data to buffers.

Julo

"Buck Landry" <[email-masked]>
Sent by: [email-masked]
03-01-02 02:18

        To:     <[email-masked]>
        cc: 
        Subject:        iSCSI: data-out initiator transfer tags

Is it required that the initiator transfer tag (ITT) for a data-out pdu be 
identical to the ITT of the scsi command pdu it is associated with?

I would assume so for consistency's sake, but have seen implementations 
that assumed the target would use the data-out pdu's target transfer tag 
to look up the associated command.

Thanks,
Buck