Subject: iSCSI: Format of LUN in iSCSI PDU

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Mon, 7 Jan 2002 12:24:41 -0800

Section 3.2.1.6 LUN : 

 The LUN field is 64-bits and it is to be 
 formatted in accordance with [SAM2].

Section 3. iSCSI PDU Formats :

 Any field appearing in this document assumes that the most 
 significant byte is the lowest numbered byte.

So, the first byte, as given in SAM2, should be set in 
LUN[0] or it should be set in LUN[7]?

thanks!
 -lakshmi

---

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Tue, 8 Jan 2002 10:14:02 -0800

Subject line seem to have got chopped in the message I posted earlier.
Resending.

 -lakshmi

-----Original Message-----
From: Lakshmi Ramasubramanian 
Sent: Monday, January 07, 2002 12:25 PM
To: [email-masked]
Subject: iSCSI: Format of LUN in iSCSI PDU

Section 3.2.1.6 LUN : 

thanks!
 -lakshmi

---

From: Eddy Quicksall <[email-masked]>
Date: Wed, 9 Jan 2002 09:01:09 -0500

I think section 3 is talking about integers, not SCSI fields. I think the
authors meant for this field to be a SCSI field. So it would be in the order
specified by SAM2.

Eddy

-----Original Message-----
From: Lakshmi Ramasubramanian [mailto:[email-masked]]
Sent: Monday, January 07, 2002 3:25 PM
To: [email-masked]
Subject: iSCSI: Format of LUN in iSCSI PDU

Section 3.2.1.6 LUN :

thanks!
 -lakshmi