Subject: iSCSI: NopIn in ping mode can contain data?

From: Tow Wang <[email-masked]>
Date: Tue, 15 Jan 2002 15:10:55 -0800

Hello everybody.

1) When a target sends out a NopIn as a ping, is it allowed to contain a
data segment?
2) If yes,
    a) why would anyone send data along?
    b) must the initiator echo back the data?

I haven't found a clear answer in draft 9. Thanks for any
clarifications.
--
Tow Wang
Adaptec Software Engineer

---

From: "Martin, Nick" <[email-masked]>
Date: Wed, 23 Jan 2002 14:25:54 -0600

Aryan,

I believe you are reading too much into "data".  A [NOP-Out or] NOP-In
may contain a payload called "ping data", the format of which is not
specified.  That payload, if present is not iSCSI Data-IN "data" nor
Text Response "data".  If this NOP-In is a response to a NOP-Out then it
is a copy (a.k.a. an echo) of the payload contained in the NOP-Out which
solicited this response.  

This was intended as a way for an Initiator to verify that packets of a
certain length can currently be successfully transmitted over this
connection.

The question being asked is whether a Target, which may send a NOP-In
that is not a response to a NOP-Out, should be allowed to include a
payload to be echoed by the Initiator.  This would allow the Target to
similarly test the connection with various packet lengths.

The answer, now clarified in draft 10 is no, the Target may not send a
NOP-In containing "ping data" except in response to a NOP-Out containing
"ping data".

Thanks,
Nick

Ajit Aryan wrote: 
> 
> 
> Julo,
> By this we should be able to say one thing, NOPIn in ping mode can 
> contain data. What every care has to be taken about the data. 
> Now, what
> should be the solicited data? In sense, the data which the initiator
> could use for tuning, negotiation etc...??
> 
> Aryan
> 
> Julian Satran wrote:
> 
> > 
> > Rod,
> > 
> > Initiators are usually build under the assumption that they are "in 
> > control" - e.g., no unsolicited data.
> > Having them prepare for unsolicited data without good cause 
> does not 
> > seem a good idea.
> > 
> > Julo
> > 
> > 
> > "Rod Harrison" <[email-masked]>
> > 
> > 21-01-02 17:31
> > 
> >        
> >         To:        Julian Satran/Haifa/IBM@IBMIL, <[email-masked]>
> >         cc:        
> >         Subject:        RE: iSCSI: NopIn in ping mode can 
> contain data?
> > 
> >        
> > 
> > 
> > 
> > Julian,
> > 
> >                 What's the reason behind preventing the 
> target sending 
> > ping data? I
> > would have thought it would be just as much use for a 
> target as it is
> > for an initiator.
> > 
> >                 - Rod
> > 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Julian Satran
> > Sent: Saturday, January 19, 2002 3:23 PM
> > To: [email-masked]
> > Subject: Re: iSCSI: NopIn in ping mode can contain data?
> > 
> > 
> > 
> > No  data - will indicate this in 10 - Julo
> > 
> > 
> > Tow Wang <[email-masked]>
> > Sent by: [email-masked]
> > 16-01-02 01:10
> > 
> >        To:        [email-masked]
> >        cc:
> >        Subject:        iSCSI: NopIn in ping mode can contain data?
> > 
> > 
> > 
> > 
> > Hello everybody.
> > 
> > 1) When a target sends out a NopIn as a ping, is it allowed 
> to contain
> > a
> > data segment?
> > 2) If yes,

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 24 Jan 2002 19:53:42 +0200

Within an exchane - everytthing an initiator sees is sollicited and 
expected. Julo
----- Forwarded by Julian Satran/Haifa/IBM on 24-01-02 09:31 -----

23-01-02 20:47

        To:     [email-masked]
        cc: 

Hello.

For negotiation you'd use login and text commands; we have said before 
that
targets can offer text key=value pairs out of their own initiative.

I don't see your reasoning here, and can't understand your second 
sentence.

Tow

Ajit Aryan wrote:

> contain data. What every care has to be taken about the data. Now, what
> > Having them prepare for unsolicited data without good cause does not
> > seem a good idea.
> >
> > Julo
> >
> >
> >         Subject:        RE: iSCSI: NopIn in ping mode can contain 
data?
> >
> >
> >
> >
> >
> > Julian,
> >
> >                 What's the reason behind preventing the target sending
> > ping data? I
> > would have thought it would be just as much use for a target as it is
> > for an initiator.
> >
> >                 - Rod
> >
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > Julian Satran

--
Tow Wang
Adaptec Software Engineer       Telephone: 408 957 4838
Mail stop 46                               800 869 8883 x4838
691 South Milpitas Boulevard    Fax:       530 686 8023
Milpitas, California 95035      E-mail:    [email-masked]