Subject: State Transitions..

From: "Naveen Nimmu" <[email-masked]>
Date: Mon, 28 Jan 2002 17:49:26 -0800

This may have been discussed before , I will ask this anyway.
The states S6 and S7 seem to be flipped if we consider all the states in the
time scale
For example I could put the state diagram in page 68 (v.10) in a timeline
kind of state diagram (text diagram attached),
Where S7 appears naturally before S6.

It seems to me by Exchanging S6 and S7 definitions we might have more clear
(almost unidirectional) state diagrams..
All comments welcome..
Naveen Nimmu

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 30 Jan 2002 11:25:51 -0800

Naveen,

I see that you are suggesting a different "lay-out"
for the current state diagram.

The lay-out logic for the current state diagram is 
different.  All the "regular" transitions (that 
take place in the absence of exceptions) are laid
out in a single flow (two segments, one vertical
to LOGGED_IN, one horizontal to log out).  Please 
note that S7 is not a regular state - ditto for S8.

In any case, there's a subjective element here.  I
need more voices wanting an exception state in the
middle of the "regular" flow, to convince me to invest 
my time in doing ASCII redrawings in a FrameMaker doc...

Thanks.
-- 
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

Naveen Nimmu wrote:
>   ------------------------------------------------------------------------
>               Name: diagram
>    diagram    Type: unspecified type (application/octet-stream)
>           Encoding: quoted-printable