Subject: iSCSI: Rejecting immediate commands

From: "Ayman Ghanem" <[email-masked]>
Date: Fri, 18 Jan 2002 11:32:36 -0600

Julian,

In draft-09 section 2.2.2.1, 6th paragraph:

        "..........................  Immediate commands can be rejected by
        the iSCSI target due to lack of resources. An iSCSI target MUST be
        able to handle at least one immediate task management command and
one
        immediate non-task-management iSCSI request per connection at any
        time."

If the target MUST handle two immediate commands per connection, and with
number of connections possibly negotiated to a large value
<number-from-1-to-65535>, this can add up to significant resources the
session has to have.

Since the command sequence numbering is session wide, I would think the
limit should be per session, not per connection.

-Ayman

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 19 Jan 2002 17:27:58 +0200

Ayman,

The reason for requirement is to be able to handle task management commands
and logout on every connection.
It all adds up to the resources you allocate per connection. Task Abort
must be given on the same connection as the aborting task.

Julo

                    "Ayman Ghanem"                                                            
                    <aghanem@cisco       To:     <[email-masked]>                            
                    .com>                cc:                                                  
                    Sent by:             Subject:     iSCSI: Rejecting immediate commands     
                    owner-ips@ece.                                                            
                    cmu.edu                                                                   

                    18-01-02 19:32                                                            

Julian,

-Ayman