Subject: Re: iSCSI : Reject PDU reserved fields.

From: "Julian Satran" <[email-masked]>
Date: Wed, 20 Feb 2002 09:44:59 +0200

I think we may want to do this.

Julo

Gwendal Grignou <[email-masked]>
Sent by: [email-masked]
20-02-02 00:40

        To:     iSCSI <[email-masked]>
        cc: 
        Subject:        iSCSI : Reject PDU reserved fields.

Hello,

I wonder if it would be possible to have the 4 bytes word at offset 16-19 
set 
to 0xFFFFFFFF in case of a Reject PDU.
All iSCSI PDU either carries a valid ITT or 0xFFFFFFFF. Only Reject PDU 
carries an invalid ITT which will not be 0xFFFFFFFF - most probably 
0x00000000.
As of today, an initiator has to be sure the PDU is not a Reject PDU to 
interpret the ITT. By setting the ITT to 0xFFFFFFFF, we avoid this test.

Gwendal.

---

From: Santosh Rao <[email-masked]>
Date: Wed, 20 Feb 2002 11:15:22 -0800

> interpret the ITT. By setting the ITT to 0xFFFFFFFF, we avoid this

The above is'nt sufficient in itself. The word 4 (ITT position in other
PDUs) in the Async PDU also does not contain the ITT field and is set to
reserved. (0).

If we're adding the ITT field (and requiring it to be 0xFFFFFFFF) in
word 4 of the Reject PDU, it also needs to be added to the Async pdu.

Regards,
Santosh

Julian Satran wrote:
>  Gwendal Grignou
>  <[email-masked]>                 To:        iSCSI
>  Sent by: [email-masked]           <[email-masked]>
>                                                   cc:
>  20-02-02 00:40                                   Subject:
>                                            iSCSI : Reject PDU
>                                           reserved fields.
> 
> 
> 
> Hello,
> 
> I wonder if it would be possible to have the 4 bytes word at offset
> 16-19 set

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################