Subject: iscsi: version number in draft 11

From: "Robert D. Russell" <[email-masked]>
Date: Wed, 27 Feb 2002 14:36:12 -0500 (EST)

Julian:

The version number in draft 10-94 is still 0x3,
the same as it was in draft 9 and draft 10.

Would you please change it to 0x4 for draft 11.

Of course these numbers still need to be taken with
a grain of salt, but testing is considerably
simpler and more robust when one side identifies the
draft it intends to conform to in a manner that can
be checked by the other side.

Thanks,

Bob Russell
InterOperability Lab
University of New Hampshire
[email-masked]
603-862-3774

---

From: [email-masked]
Date: Wed, 27 Feb 2002 18:13:00 -0500

Folks, 

I've warned in the past that this use of version numbers
is going to cause problems, as it encourages the longevity
of obsolete implementations that don't interoperate.  Version
numbers should NEVER have been used for identification of
draft versions - in 20/20 hindsight a text key that could
have been dropped from the final RFC would have been better.

Prior guidance from the ADs has been that a version number
change from 0 to 1 in going to RFC would be ok.  Let's
reset the version number to 0, and anyone still using
something based on a draft from back when the version number
was still 0 has something truly ancient and is SOL.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Robert D. Russell [mailto:[email-masked]]
> Sent: Wednesday, February 27, 2002 2:36 PM
> To: [email-masked]
> Subject: iscsi: version number in draft 11
> 
> 
> Julian:
>