Subject: iscsi: version number in draft 11

From: "Robert D. Russell" <[email-masked]>
Date: Wed, 27 Feb 2002 14:36:12 -0500 (EST)

Julian:

The version number in draft 10-94 is still 0x3,
the same as it was in draft 9 and draft 10.

Would you please change it to 0x4 for draft 11.

Of course these numbers still need to be taken with
a grain of salt, but testing is considerably
simpler and more robust when one side identifies the
draft it intends to conform to in a manner that can
be checked by the other side.

Thanks,

Bob Russell
InterOperability Lab
University of New Hampshire
[email-masked]
603-862-3774

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 28 Feb 2002 08:58:34 +0200

sure - julo

"Robert D. Russell" <[email-masked]>
Sent by: [email-masked]
27-02-02 21:36

        To:     [email-masked]
        cc: 
        Subject:        iscsi: version number in draft 11

Julian:

Thanks,

Bob Russell
InterOperability Lab

---

From: Eddy Quicksall <[email-masked]>
Date: Thu, 28 Feb 2002 08:22:28 -0500

I agree. One thing we could do is to all agree to a "vendor specific" key
that is used during our testing. Being vendor specific, it could still be
used in the future.

I suggest something like:

X-draft=11

or

X-draft=9,11

(that is assuming that no one will have a company called "draft") :-)

Eddy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, February 27, 2002 6:13 PM
To: [email-masked]; [email-masked]
Subject: RE: iscsi: version number in draft 11

Folks, 

I've warned in the past that this use of version numbers
is going to cause problems, as it encourages the longevity
of obsolete implementations that don't interoperate.  Version
numbers should NEVER have been used for identification of
draft versions - in 20/20 hindsight a text key that could
have been dropped from the final RFC would have been better.

Prior guidance from the ADs has been that a version number
change from 0 to 1 in going to RFC would be ok.  Let's
reset the version number to 0, and anyone still using
something based on a draft from back when the version number
was still 0 has something truly ancient and is SOL.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Robert D. Russell [mailto:[email-masked]]
> Sent: Wednesday, February 27, 2002 2:36 PM
> To: [email-masked]

---

From: [email-masked]
Date: Thu, 28 Feb 2002 10:51:38 -0500

Julian,
 
The problem here is that I don't think the IESG regards them
as arbitrary.  Mark's message on this topic reveals the underlying
issue here:
> BTW, there are paying customers that are buying and using
>"ancient" iSCSI products that use version 0.

Resetting the version number gives vendors a very strong incentive to
update those products so that they'll interoperate.  The IESG has
little interest in helping out folks who have shipped products based
on Internet-Drafts (see the boilerplate introduction to every draft),
and to the extent that this is the motivation for playing games with
the version number, we're going to get a very poor reception.

--David

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 2:53 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: iscsi: version number in draft 11

David, 

We could move to 10 when going RFC - version numbers are arbitrary anyhow. 

Julo 

	[email-masked] 

28-02-02 01:13 

        To:        [email-masked], [email-masked] 
        cc:         
        Subject:        RE: iscsi: version number in draft 11 

Folks, 

Thanks,
--David