Subject: Re: iSCSI: key negotiation - Unrecognized value?

From: "Julian Satran" <[email-masked]>
Date: Thu, 21 Feb 2002 08:18:04 +0200

Marjorie is correct - the text is (quite) explicit about requiring reject.
As for you example - the value to be answered by the target is the maximum 
acceptable - see the rules for numeric negotiations.

Julo

Luben Tuikov <[email-masked]>
Sent by: [email-masked]
20-02-02 22:21

        To:     "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
        cc:     "Ips Reflector (E-mail)" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL
        Subject:        Re: iSCSI: key negotiation - Unrecognized value?

"KRUEGER,MARJORIE (HP-Roseville,ex1)" wrote:
> 
> What is the proper response if you recognize a key, but are offered a 
value
> that you don't recognize?  For instance, what if MaxConnections=yes is
> offered?
> 
> Where is that specified in the document?

v10, pg 34, top:

 Any other key not understood by the responder may be ignored
 by the responder without affecting the basic function. However,
 the Text Response for a key not understood MUST be
 key=NotUnderstood.

v10, pg 33, middle:

 If a responder does not support or is not allowed to use
 all of the offered options with a specific originator,
 it may use the constant "Reject".

Comments?

-- 
Luben Tuikov, Senior Software Engineer, Splentec Ltd.
Bus: +1-905-707-1954x112, 9-5 EST. Fax: +1-905-707-1974.

---

From: Luben Tuikov <[email-masked]>
Date: Thu, 21 Feb 2002 11:26:35 -0500

Oh, sorry!

I guess I pay too much attention on semantics (meaning),
rather than just read what the draft says and try not to
interpret it.

Julian Satran wrote:
> As for you example - the value to be answered by the target is the maximum acceptable - see the
> rules for numeric negotiations.
> 
> Julo
> 
>   Sent by: [email-masked]            To:        "KRUEGER,MARJORIE (HP-Roseville,ex1)"
>                                     <[email-masked]>
>   20-02-02 22:21                            cc:        "Ips Reflector (E-mail)"
>                                     <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL
> > What is the proper response if you recognize a key, but are offered a value