Subject: RE: iSCSI: error text

From: Eddy Quicksall <[email-masked]>
Date: Fri, 1 Feb 2002 07:46:28 -0500

I forgot about the language thing :-).
 
I guess this is already acceptable since there is not anything in the draft
that says one can't send text with a Login Response with Status-Class
non-zero.
 
e.g. T->I Login Response, Status-Class=2, DataSegmentLength=30,
DataSegment=X-CSG is incorrect
 
Would that be acceptable under the specification?
 
Eddy
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Tuesday, January 29, 2002 3:52 PM
To: Eddy Quicksall
Cc: ips@ece. cmu. edu (E-mail)
Subject: Re: iSCSI: error text

Eddy - nice thought - there are vendor keys for that - If you ask me to add
them as part of the standard - I will do it in HEBREW Julo 

Eddy Quicksall <[email-masked]> 
29-01-02 21:04 
        
        To:        Julian Satran/Haifa/IBM@IBMIL, "ips@ece. cmu. edu
(E-mail)" <[email-masked]> 
        cc:         
        Subject:        iSCSI: error text 

It would be nice if we could send some error text in the Login Response when
the Status-Class is non zero. 
  
Since so many things fit into Initiator Error, that would allow anyone
looking at an analyzer to see the actual reason. 
  
The text would not be defined by the spec but would be defined only by the
target and would not be interpreted by anything other than a person trying
to diagnose the problem. 
  
Eddy

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 1 Feb 2002 19:29:24 +0200

Eddy,

Certainly correct and better than to force everybody to prduce the 
message.

Julo

Eddy Quicksall <[email-masked]>
Sent by: [email-masked]
01-02-02 14:46

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     "ips@ece. cmu. edu (E-mail)" <[email-masked]>
        Subject:        RE: iSCSI: error text

I forgot about the language thing J.
 
I guess this is already acceptable since there is not anything in the 
draft that says one can't send text with a Login Response with 
Status-Class non-zero.

 
Eddy
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Tuesday, January 29, 2002 3:52 PM
To: Eddy Quicksall
Cc: ips@ece. cmu. edu (E-mail)
Subject: Re: iSCSI: error text

Eddy - nice thought - there are vendor keys for that - If you ask me to 
add them as part of the standard - I will do it in HEBREW Julo 

        

It would be nice if we could send some error text in the Login Response 
when the Status-Class is non zero. 

  
Eddy

---

From: Eddy Quicksall <[email-masked]>
Date: Sat, 2 Feb 2002 15:12:49 -0500

Actually, I didn't mean to mandate it. I just don't want it to be illegal.
 
Eddy
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, February 01, 2002 12:29 PM
To: [email-masked]
Subject: RE: iSCSI: error text

Eddy, 

Certainly correct and better than to force everybody to prduce the message. 

Julo 

        

  

Eddy 
  
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Tuesday, January 29, 2002 3:52 PM
To: Eddy Quicksall
Cc: ips@ece. cmu. edu (E-mail)
Subject: Re: iSCSI: error text 

        

  
  
Eddy