Subject: RE: SCSI command order issue

From: Eddy Quicksall <[email-masked]>
Date: Mon, 25 Feb 2002 10:21:15 -0500

Every operating system will deal with this. It is the nature of
multi-threaded disk access. It is a ULP issue and there are lots of ways
that the OS's handle it.

iSCSI and SCSI are no different in this respect.

Eddy

-----Original Message-----
From: Wang Yong Hong, Wilson [mailto:[email-masked]]
Sent: Sunday, February 24, 2002 6:54 AM
To: [email-masked]
Subject: SCSI command order issue 

Hello,

Here I ask one question about SCSI protocol.

I traced the linux kernel source code about SCSI module.

In SCSI module, every SCSI command block is assigned
one unique serial number. However this number is only
valid before the block is returned to the SCSI middle layer.

There is no mechanism of sequence control for SCSI.
What is your opinion about the SCSI block out of order
when they return to upper layer ? What do your people
think about this ?

Thanks

Wilson

---

From: [email-masked]
Date: Mon, 25 Feb 2002 13:13:07 -0700

Wilson,

That is the way the SCSI protocol is defined by T10 so this isn't an IETF
issue.

Regards,
Pat

-----Original Message-----
From: Wang Yong Hong, Wilson [mailto:[email-masked]]
Sent: Sunday, February 24, 2002 3:54 AM
To: [email-masked]
Subject: SCSI command order issue 

Hello,

Thanks 

Wilson

---

From: "Wang Yong Hong, Wilson" <[email-masked]>
Date: Tue, 26 Feb 2002 10:04:36 +0800

Hello Pat,

Thanks all the fellows for the reply. 

Does that mean it is safe for iSCSI and other network related protocols that do not provide 
SCSI command order control, as we assume the higher layer (or Operating System) may 
take the responsibility to control the order issue ?

Thanks 

Wilson

>>> <[email-masked]> 02/26/02 04:13AM >>>
Wilson,

Regards,
Pat

-----Original Message-----
From: Wang Yong Hong, Wilson [mailto:[email-masked]] 
Sent: Sunday, February 24, 2002 3:54 AM
To: [email-masked] 
Subject: SCSI command order issue 

Hello,

Thanks 

Wilson

---

From: [email-masked]
Date: Mon, 25 Feb 2002 21:29:39 -0500

> take the responsibility to control the order issue ?
Yes, that is the way that SCSI is generally used.  Most code that cares
about SCSI command A completing before SCSI command B waits for A to
complete before issuing B.  Examples include databases and filesystems,
and out of order completion of concurrent SCSI operations is the expected
behavior (e.g., many disks reorder their command queues for seek and
rotational optimization, and a disk array with a cache will usually
complete operations that hit in cache before operations that miss).

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------