Subject: ISCSI: [Q] connection timeout?

From: Luben Tuikov <[email-masked]>
Date: Thu, 14 Feb 2002 17:33:26 -0500

If T/I gets half a PDU, what is the timeout
on the active socket of the connection?

What should be done after such [data read from
socket] timeout?

-- 
Luben

---

From: "Mallikarjun C." <[email-masked]>
Date: Thu, 14 Feb 2002 16:03:47 -0800

Luben,

iSCSI does not define the absolute timeout value
to be used for assuming a transport connection timeout.
That's left to implementations.

Regarding your second question, the only option is 
to unceremoniously terminate the FFP connection.
State transition description for T15 in chapter 6 of 
rev10 details this case.

Once the connection enters the CLEANUP_WAIT 
as a result of this, the DefaultTime2Wait/DefaultTime2Retain
timeouts come into picture.  Please refer to the new 
proposed text that I posted to the list earlier today.

Regards.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard MS 5668 
Roseville CA 95747

----- Original Message ----- 
From: Luben Tuikov 
To: iSCSI 
Sent: Thursday, February 14, 2002 2:33 PM
Subject: ISCSI: [Q] connection timeout?

-- 
Luben