Subject: RE: iSCSI:reservations

From: "Elliott, Robert" <[email-masked]>
Date: Thu, 28 Feb 2002 10:05:52 -0600

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 1:24 AM
To: [email-masked]
Subject: Re: iSCSI:reservations

> We had long discussions on the reservation-clearing being
> done (or not) at session close (FCP does this). 
>  We concluded that it is probably a thing that should be
> handled at SCSI level (it would be wrong for the transport
> to mes-up SCSI state) and perhaps we should only state that
> an indication about session failure should be passed to
> SCSI.  Mallikarjun and Randy have a set of good arguments 
> for not doing this implicitly that they would probably
> want to share them with you. 
>
> This is only a warning that this item in the clearing
> appendix is going to change as this issue was debated
> earlier on the list. 
>
> Comments? 

T10 is going to discuss this issue on a Friday conference call for both
iSCSI and SRP (InfiniBand) and should have a recommendation for you
then.  Anyone interested is welcome to join the discussion.

Here is the meeting announcement posted to the T10 mailing list:

* From the T10 Reflector ([email-masked]), posted by:
* "Simpson, Cris" <[email-masked]>
*
The SRP WG will discuss reservation issues for at least the first hour
of
this Friday's conference call. As the issues are of wide concern to the
SCSI community, all interested parties are invited to participate.

References:
"Response to T10 Letter Ballot comments on SRP", 
Comment IBM050, Pages 37 and 104
ftp://ftp.t10.org/t10/document.01/01-328r3.pdf 
Rob Elliott, "Clearing effects of logouts on different protocols", 
t10 mailing list, 21 Feb 2002,
<[email-masked]>
Mallikarjun Chadalapaka, "Reservations & Nexus"
ftp://ftp.t10.org/t10/document.02/02-078r0.pdf

Conference call information:
March 1 0900-1100 PST
1.888.316.5901 or +1.617.801.9781
If you are not an SRP 'regular', please send 
mail to mailto:[email-masked]?subject=Mar_1_passcode for the 
passcode. (This will ensure that I schedule enough lines.)
Cris

---
Rob Elliott, Compaq Server Storage
[email-masked]

---

From: "Mallikarjun C." <[email-masked]>
Date: Thu, 28 Feb 2002 11:34:18 -0800

> then.  

I would like that.  The reservations discussion is also currently 
scheduled on CAP agenda for the upcoming Dallas T10 meetings 
starting March 11.

For a discussion of why reservations must surive session failures/logouts,
please see the discussion paper at:

ftp://ftp.t10.org/t10/document.02/02-078r1.pdf
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard MS 5668 
Roseville CA 95747