Subject: RE: iSCSI: Boolean value (yes, no) negotiation

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Wed, 6 Feb 2002 10:10:27 -0800

So that means, if the target needs to use ONLY immediate data,
it has to fail the login because the initiator said NO to ImmediateData?

thanks!
 -lakshmi

-----Original Message-----
From: Rahul Bhagwat [mailto:[email-masked]] 
Sent: Wednesday, February 06, 2002 10:07 AM
To: Lakshmi Ramasubramanian; [email-masked]
Subject: Re: iSCSI: Boolean value (yes, no) negotiation

I believe a key is not negotiated thrice as you have pointed out. That
is a sender offers a value, receiver offers it's own and that's it. (I
think specs has a mention that a key cannot be negotiated twice. This
example falls into that category.) The result of the negotiation is key
dependent. For example, in this particular key, when initiator sends 
ImmediateData=no, the negotiation is over as this is an
AND function. However it is not an error to send back a response. In any
case, the outcome of the result was decided for the initiator when it
sent the key first and for the target when it received the key.

Regards,
Rahul
----- Original Message ----- 
From: "Lakshmi Ramasubramanian" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, February 06, 2002 10:56 PM
Subject: iSCSI: Boolean value (yes, no) negotiation

> Could someone please clarify Boolean key=value usage
> (such as "ImmediateData=yes", etc)?
> 
> For example, the initiator sends to target "ImmediateData=no".
> But the target wants ImmediateData. So, it sends back
> "ImmediateData=yes".
> The initiator, being able to handle it, sends back "ImmediateData=no".
> Now, they use immediate data in the PDUs. 
> 
> Is this valid? Or, in the above case if the target can't handle
> non-immediate data it has to reject the login ?
> 
> thanks!
>  -lakshmi
>

---

From: "Rahul Bhagwat" <[email-masked]>
Date: Thu, 7 Feb 2002 00:14:28 +0530

In this particular case, the default value for the key is "Yes". Initiator
should
be able to express it's preference that it wants to do away with immediate
date if the target is willing to do so (without forcing it through the AND
function),
else the initiator is okay to work with immedidate data. Looks like this is
not
possible with the boolean  negotiation. Can we use ImmediateData=? to get
the
supported value from the target. If the target responds with yes, the
initiator can
either use immediate data (by responding Yes) or not use it (by responding
No).
If the target response no, the initiator does not use immediate data. In
this case,
the Login need not terminate. Does this give the solution ? Is this a valid
thing ?

Regards,
Rahul