Subject: Re: iSCSI: key negotiation - Unrecognized value?

From: "Julian Satran" <[email-masked]>
Date: Wed, 20 Feb 2002 10:10:40 +0200

If it is not a list element the it is Reject. If it is a list element and 
you recognize others then ignore the "bad" value else "Reject".

Regards,
Julo

"KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Sent by: [email-masked]
20-02-02 03:22

        To:     "Ips Reflector (E-mail)" <[email-masked]>
        cc: 
        Subject:        iSCSI: key negotiation - Unrecognized value?

What is the proper response if you recognize a key, but are offered a 
value
that you don't recognize?  For instance, what if MaxConnections=yes is
offered?

Where is that specified in the document? 

Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions Org.
Hewlett-Packard
tel: +1 916 785 2656
fax: +1 916 785 0391
email: [email-masked]

---

From: Santosh Rao <[email-masked]>
Date: Wed, 20 Feb 2002 12:08:17 -0800

Hello,

It seems like there are several possible responses on seeing a numeric
key being offered with a non-numeric key value. (ex :
"MaxBurstSize=yes", or "MaxConnections=yes").

1) Target ignores the received key, without affecting basic function. 
It responds to the key with NotUnderstood. 
Login negotiation outcome is then initiator implementation dependent.
Most likely, the initiator will terminate the TCP connection and error
back to the caller indicating that it could not open an iscsi
connection.  

2) Target may respond with a Reject PDU response indicating a "protocol
error". No login response is sent in this case (?). 

3) Target responds with a login response pdu indicating a
status_class_detail of 0x0207 (Missing Parameter).

4) Target may react to this error as a "format error" and close the TCP
connection. 

In all the cases, the end result is TCP connection termination. However,
the response (2) is the least desirable, since no long response is
generated.

I believe that (1) coupled with (3) is the most desirable behaviour. 

Regards,
Santosh

Julian Satran wrote:
> 
> If it is not a list element the it is Reject. If it is a list element
> and you recognize others then ignore the "bad" value else "Reject".
> 
> Regards,
> Julo
> 
>  "KRUEGER,MARJORIE (HP-Roseville,ex1)"
>  <[email-masked]>                     To:        "Ips
>  Sent by: [email-masked]        Reflector (E-mail)"
>                                        <[email-masked]>
>  20-02-02 03:22                                cc:
>                                                Subject:        iSCSI:
>                                        key negotiation - Unrecognized
>                                        value?
> 
> 
> 

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################