Subject: Re: iSCSI: DataACK SNACK

From: "Julian Satran" <[email-masked]>
Date: Fri, 15 Feb 2002 19:30:00 +0200

DataACK is a "bulk ack". Answering the last (in case of several) is good 
enough.
I fail to see your point.

Julo

"Chuck Micalizzi" <[email-masked]>
Sent by: [email-masked]
14-02-02 21:02

        To:     <[email-masked]>
        cc: 
        Subject:        iSCSI: DataACK SNACK

All,
 
    I have a question regarding DataACK.

    Rev. 10 section 10.16.1 states:

    For a Data/R2T SNACK, the Initiator Task Tag MUST be set
    to the Initiator Task Tag of the referenced Command.
    Otherwise, it is reserved.

    it also states:

    The DataACK is used to free resources at the target and 
    not to request or imply data retransmission.

    Is the target allowed to have more than one DataACK
    outstanding on a connection? 

    If multiple outstanding DataACKs are allowed per connection
    then in my opinion the DataACK must have a valid task tag
    inorder for the target to associate the DataACK with the
    appropriate resources to be freed.

chuck micalizzi
Qlogic Corp.

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 15 Feb 2002 12:24:10 -0800

Julian,

Since the DataACK mechanism is based on DataSNs and
hence per-task, I think Chuck is suggesting changing:

"For a Data/R2T SNACK, the Initiator Task Tag MUST be set to the Initi-
ator Task Tag of the referenced Command. Otherwise, it is reserved."

to something like:

"For Status SNACK, the Initiator Task Tag is reserved.  In all other
cases,
the Initiator Task Tag field MUST be set to the Initiator Task Tag of
the 
referenced command."

I think the change is required. 
-- 
Mallikarjun 

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
MS 5668	Hewlett-Packard, Roseville.
[email-masked]

Julian Satran wrote:
> 
> DataACK is a "bulk ack". Answering the last (in case of several) is
> good enough.
>   "Chuck Micalizzi"
>   <[email-masked]>                   To:
>   Sent by: [email-masked]          <[email-masked]>
>                                                  cc:
>   14-02-02 21:02                                 Subject:
>                                           iSCSI: DataACK SNACK
> 
> 
> 
> All,
>