Subject: Re: ips : Is FirstBurstSize valid when InitialR2T=yes ?

From: Santosh Rao <[email-masked]>
Date: Wed, 06 Feb 2002 12:01:16 -0800

IMO, the FirstBurstSize key value negotiated during login is a don't
care if *BOTH* immediate data and un-solicited data have been disabled. 

However, if the target knows up-front that it does not support either
immediate or un-solcited and it receives the key FirstBurstSize during
login negotiation, it should return a 0 value as the result of the
negotiation for FirstBurstSize. 

(Note that the special semantics of 0 implying no limit is no longer
true for FirstBurstSize and hence, the target can just return 0 iff both
immediata data and un-solicited data are disabled in login negotiation.)

- Santosh

"Fischer, Michael" wrote:
> 
> What if the sequence is as follows:
> 
> I->T    FirstBurstSize=512; T=0; NSG=CSG;
> T->I    FirstBurstSize=512; T=0; NSG=CSG;
> I->T    InitialR2T=no, ImmediateData=no; T=1; NSG=FULL
> 
> If the target does not support InitialR2T=no..  Does login now fail?  There
> does not seem to be a way for the target to say that it requires R2T.  Why
> did the Initiator send FirstBurstSize if it was setting InitialR2T to no?
> There is no negotiation with an AND function.
> 
> Michael Fischer
> 
> -----Original Message-----
> From: Eddy Quicksall [mailto:[email-masked]]
> Sent: Wednesday, February 06, 2002 9:47 AM
> To: Santosh Rao; IPS Reflector
> Subject: RE: ips : Is FirstBurstSize valid when InitialR2T=yes ?
> 
> That is how I am interpreting it.
> 
> BTW: How about this one ...
> 
> I->T FirstBurstSize=512, InitialR2T=no, ImmediateData=no
> 
> If the target does not support InitialR2T=no, how should it respond to
> FirstBurstSize?
> 
> Should the target do this (for draft >= 9)?
> 
> T->I FirstBurstSize=irrelevant, InitialR2T=yes, ImmediateData=no
> 
> Eddy
> 
> -----Original Message-----
> From: Santosh Rao [mailto:[email-masked]]
> Sent: Tuesday, February 05, 2002 2:56 PM
> To: IPS Reflector
> Subject: ips : Is FirstBurstSize valid when InitialR2T=yes ?
> 
> Hello,
> 
> Can someone clarify if the login key FirstBurstSize is valid when :
> InitialR2T=yes  and ImmediateData=yes ?
> 
> i.e. if immediate data is enabled and un-solicited data is disabled
> during login negotiation, is the value of FirstBurstSize received in the
> login response to be interpreted ?
> 
> My current understanding is that FirstBurstSize is inclusive of the
> immediate data portion, and so, if immediate data is enabled, but
> un-solicited data is disabled, then, FirstBurstSize *must* be valid and
> must be <= DataPDULength. (after rev 09, it would be <=
> (MaxRecvPDULength - the header components size)).
> 
> For example, a target implementation may offer a FirstBurstSize <
> DataPDULength, in which case, the immediate data size is the
> MIN(DataPDULength, FirstBurstSize, bytes_to_send).
> 
> Can someone clarify if this is a correct interpretation or set me right
> on this ?
> 
> Thanks,
> Santosh
> 
> --
> ##################################
> Santosh Rao
> Software Design Engineer,
> HP-UX iSCSI Driver Team,
> Hewlett Packard, Cupertino.
> email : [email-masked]
> Phone : 408-447-3751
> ##################################

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: "Fischer, Michael" <[email-masked]>
Date: Wed, 6 Feb 2002 11:38:54 -0800

Michael Fischer

-----Original Message-----
From: Eddy Quicksall [mailto:[email-masked]]
Sent: Wednesday, February 06, 2002 9:47 AM
To: Santosh Rao; IPS Reflector
Subject: RE: ips : Is FirstBurstSize valid when InitialR2T=yes ?

Eddy

-----Original Message-----
From: Santosh Rao [mailto:[email-masked]]
Sent: Tuesday, February 05, 2002 2:56 PM
To: IPS Reflector
Subject: ips : Is FirstBurstSize valid when InitialR2T=yes ?

Hello,

Thanks,
Santosh