Subject: Re: iSCSI: Question: ISID Rule?

From: "John Hufferd" <[email-masked]>
Date: Fri, 8 Mar 2002 02:09:04 -0800

Not exactly.

There is a CID in the equation also.  if TSID is not 0, and assuming other
things match, the CID will be used to determine if this is an implicit
logout and re-login for that connection.  If the CID is unique within the
session, then it will start a new session, else, it will log out the old
connection and create a new one.  Then of course, you need to use the Task
Management Request PDU, on the new connection to move the allegiance of the
existing tasks (one at a time) from the old connection to the new
connection.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

Luben Tuikov <[email-masked]>@ece.cmu.edu on 03/07/2002 02:32:42 PM

Please respond to iSCSI <[email-masked]>

Sent by:    [email-masked]

To:    iSCSI <[email-masked]>
cc:
Subject:    Re: iSCSI: Question: ISID Rule?

"KRUEGER,MARJORIE (HP-Roseville,ex1)" wrote:
>
> It's the SCSI device that is the comparison point, so you are comparing
the
> iSCSI node name of the two entities to determine if they are
"the same".

Then this implies that a session is uniquely identified by (InitiatorName,
TargetName).

Then for a new connection at the target:

 i) TSID!=0 provides implicit uniqueness,
    since a new connection will be added,
    if the session already exists.

ii) TSID=0, implies that there does NOT exist
    a session with the given TargetName, InitatorName
    and ISID given in the Login Request PDU, else close the
    connection.

Is this true?

--
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Fri, 08 Mar 2002 16:44:05 -0500

> existing tasks (one at a time) from the old connection to the new

I see. Then would you say that this is correct:

ISID TSID CID       Action
---------------------------------
 V    0    U      New Session.
 P    0    0      Session Reinstatement.
 P    P    U      Add a connection to a session.
 P    P    P      Connection reinstatement.

Legend:
0    NULL, i.e. 0.
V        Valid.
P        Present.
U        Unique at target.

Table 1: iSCSI Target with just a single Portal Group.

-- 
Luben Tuikov, Senior Software Engineer, Splentec Ltd.
Bus: +1-905-707-1954x112, 9-5 EST. Fax: +1-905-707-1974.

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 8 Mar 2002 18:04:37 -0800

> I see. Then would you say that this is correct:

That's pretty close.  I would describe it as  -

ISID          TSID              CID                  Target action
new           non-zero           X                    fail the login ("session does
not exist")
new           zero                  X                    instantiate a new session
existing      zero                  X                    do session reinstatement
existing      valid                 new                 add a new connection to the
session
existing      valid                 existing            do connection reinstatement
existing      invalid                X                   fail the login ("session
does not exist")

(X: don't care)
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions Organization
Hewlett-Packard MS 5668
Roseville CA 95747

---

From: Luben Tuikov <[email-masked]>
Date: Sat, 09 Mar 2002 01:20:20 -0500

> existing      invalid                X                   fail the login ("session

Yep, I had a "X: don't care" but removed it as I wasn't sure.

Would it be so much trouble if this table is included into
the iSCSI draft? It makes things a lot clearer.

-- 
Luben