Subject: iScsi: Param Negotiation

From: Nitin Dhingra <[email-masked]>
Date: Fri, 22 Mar 2002 13:01:48 +0530

I have a query that is it possible that Target sends its own key-value pairs
that are supposed to 
be negotiated in addition to the negotiated key-value pairs that were sent
in the Login or Text Request
in the same Login or Text Response... 

Or will target wait for the T bit to be set in the Login or 
Text Request & send a response with T bit 0 to tell the initiator it has its
own keys to negotiate 
and after the initiator sends a Login or Text Request then it will start
sending its own key-value 
pairs...

- Nitin

---

From: "Randy Jennings" <[email-masked]>
Date: Fri, 22 Mar 2002 06:48:11 -0800

See pg 60 of the iSCSI spec, 1st paragraph.  As far as I can see, setting
the T bit is controlled by the desire to send key=value pairs, not sending
key=value pairs being controlled by the T bit.  IOW, I do not think it
matters when the target starts sending its own required key=value pairs.

HTH,
Randy Jennings
Data Transit

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Nitin Dhingra
> Sent: Thursday, March 21, 2002 11:32 PM
> To: Ips (E-mail)
> Subject: iScsi: Param Negotiation
>
>