Subject: Asynchronous events at the target

From: sanquery <[email-masked]>
Date: Tue, 19 Mar 2002 04:55:05 +0000

Hi all,
  I wanted to know is there any means by which an initiator can be notified of some asynchronous events at the target. 
 According to SAM2(Page 73), Asynchronous Event Reporting takes place when one of the following events occur:
a)An exception condition was encountered after command completion;
b)A newly initialized device is available;
c)Some other type of unit attention condition has occured; or
d)An asynchronous event has occured.

How does the notification for a newly initialized device available at the target go to the Initiator? Is it done by suddenly sending an Asynchronous PDU with an Async Event value of 0 corresponding to Sense Data? Or is there any other means of handling this notification?

Regards,
Sanquery.

---

From: "Sumit Agarwal" <[email-masked]>
Date: Wed, 20 Mar 2002 13:03:36 +0500

AFAIK, there are various ways to dispatch an asynchronous events. They 
can be considered as interrupts. The interrupts can be issued either 
through signals or sending some know packet format for intialization.
1) Signals  - used mostly for directly attached devices
2) Transport Specific routines - fore.g RSCN in FC, A configured RPC 
may be invoked, Hello message can be sent e.t.c

Someone please correct me, if I am wrong.

Thanks,
Sumit

----- Original Message -----
From: sanquery <[email-masked]>
Date: Tuesday, March 19, 2002 10:25 am
Subject: Asynchronous events at the target

> Hi all,
>  I wanted to know is there any means by which an initiator can be 
> notified of some asynchronous events at the target. 
> According to SAM2(Page 73), Asynchronous Event Reporting takes 
> place when one of the following events occur:
> How does the notification for a newly initialized device available 
> at the target go to the Initiator? Is it done by suddenly sending 
> an Asynchronous PDU with an Async Event value of 0 corresponding 
> to Sense Data? Or is there any other means of handling this 
> notification?
> Regards,
> Sanquery.
> 
> 
> 
> 
>