Subject: Re: iSCSI: Login stage transition; T bit

From: "Julian Satran" <[email-masked]>
Date: Wed, 27 Mar 2002 09:15:49 +0200

Comments in text.

Basically we had a a login with very little redundance earlier and it wa 
deemed cryptic and error prne.
Currently every step is clearly stated and although some infor is 
redundant it clearly states the intentions of the issuying party.
I suggest we stop improving on this.

Julo

Luben Tuikov <[email-masked]>
Sent by: [email-masked]
26-03-02 22:31
Please respond to Luben Tuikov; Please respond to iSCSI

        To:     iSCSI <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL, "Mallikarjun C." 
<[email-masked]>
        cc: 
        Subject:        iSCSI: Login stage transition; T bit

Hello there,

Q1. It appears to be the case that 
   o  CSG =/= NSG iff T=1, and 
   o  CSG < NSG, from the table on pg. 64, v11.

Thus, T=1 iff CSG < NSG, so the T bit can be retired,
by imposing that there be no garbage in NSG (that is
NSG >= CSG for all login PDU's).

+++ yes it is redundant but intentionally so NSG hast to be 0 if T is not 
1 +++
Q2. After a request/response with T=1 and NSG > CSG
(appropriately), what is the RFC verb for
the initiator. That is, MUST the initiator switch
to the next stage, or SHOULD or MAY?
+++ it must switch as the initiator is the one that requested it.
Q3. Same as Q2 but NSG=3?
+++ same answer +++
Thanks,
-- 
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Wed, 27 Mar 2002 15:16:17 -0500

Thanks Julian.

> +++ it must switch as the initiator is the one that requested it.

Do you think that it will be a good idea that this sentence
be included in the draft, since it makes the requrements
explicit. I.e.:

That is, if a req and resp stage transition sequence is communicated,
i.e. T=1 and NSG > CSG, then the initiator MUST switch to NSG, i.e.
the next PDU has to be an I->T PDU AND it MUST carry
a CSG = NSG(of the sequence). The target MUST close
the connection if such a PDU is not received, that is
a different PDU was received, after the stage transition sequence communication.

Comments on the above paragraph, appreciated.

Ok, no more improvement on the T bit. But as a side note:

> +++ yes it is redundant but intentionally so NSG hast to be 0 if T is not 1 +++

The text says that if T = 0 then NSG is reserved. That is it is invalid
whatever the value therein. T <==> NSG, thus the redundancy.

-- 
Luben