Subject: RE: iSCSI - Range of values can be negotiated for integers?

From: "LEMAY,KEVIN (A-Roseville,ex1)" <[email-masked]>
Date: Wed, 6 Mar 2002 09:10:17 -0700

One could take the most liberal interpretation and offer:

MaxConnections=1,15
MaxBurstSize=8192,64456
FirstBurstSize=8192,64456
....

Where in the spec does it say which integer keys are allowed to use ranges
in the negotiation?

Kevin Lemay

-----Original Message-----
From: Robert D. Russell [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 8:02 AM
To: LEMAY,KEVIN (A-Roseville,ex1)
Cc: [email-masked]; 'Satran, Julian'
Subject: Re: iSCSI - Range of values can be negotiated for integers?

Kevin:

I believe that the sentence you quote should be prefaced as
follows:

"Depending on the key, the value offered can be an integer,
a range defined by a lower and upper value, ..."

This makes it clear that it does NOT apply to all numeric keys.

Julian, if you agree would you please add the "Depending on the key,"
prefix to the sentence in question?

Thanks,
Bob Russell

On Tue, 5 Mar 2002, LEMAY,KEVIN (A-Roseville,ex1) wrote:

> On page 60 of iSCSI v11 says that:
>
> "The value can be an integer, a range defined by a lower and upper
> value...."
>
> I must assume that any numeric key may use this feature?
>
> I don't see any reference to this new capabilty anywhere else in the
> document. I am sure that we are going to have problems at plugfest if this
> is not cleared up now.
>
> Thanks,
>
> Kevin Lemay
> Agilent Technologies
>

---

From: "Robert D. Russell" <[email-masked]>
Date: Wed, 6 Mar 2002 12:05:00 -0500 (EST)

Kevin:

In section 11 of Draft 11, when each key is defined, the form of
the value side is indicated explicitly.  For example, section 11.2
defines the MaxConnections key and shows its form as:

  MaxConnections=<number-from-1-to-65535>

This clearly shows that the value on the right of the = can only
be a single number, not a range of numbers.  The only keys which can
take a range of numbers are those in section A.3.2 of draft 11 for
markers (the OFMarkInt and IFMarkInt keys).

Not that your idea is a bad one, but do we want the complication
of these ranges on all the keys that have been just single numbers
up to now?  What significant advantage would there be that would make
it worthwhile for everyone to change the way it works now?

Bob Russell

---

From: Paul Koning <[email-masked]>
Date: Wed, 6 Mar 2002 17:44:24 -0500

> it worthwhile for everyone to change the way it works now?

I was wondering the same thing.  Did I miss the discussion on the
list, or in the meeting, where this was covered?

I'm assuming that we're not making any changes to the spec at this
stage unless they are explicitly discussed on the list and agreed to
by the usual "rough consensus" criterion.

   paul

---

From: Ajit Aryan <[email-masked]>
Date: Thu, 07 Mar 2002 09:41:29 +0530

Yes,
Even I would like to hear about the advantages.

Aryan

-- 

Ajit Khaparde
Storage Networking Group
Adaptec India Design Center

Phone Daytime : +91-40-6661555 (237)
Phone Nighttime : +91-40-4456206
======================================================
This email and any files transmitted are confidential
and are intended solely for the use of the individual
or entity to which they are addressed. Access to this
e-mail by anyone else is unauthorized. If you are not
the intended recipient, any disclosure, copying,
distribution or any action taken or omitted to be taken
in reliance on it, is prohibited.