Subject: iscsi : TSID rule.

From: Santosh Rao <[email-masked]>
Date: Fri, 15 Mar 2002 16:05:02 -0800

Hello,

Section 2.4.3 states the following requirement :

"a) Between a given iSCSI Initiator and iSCSI Target, at any given time,
only one session can exist with a given session identifier (SSID)."

This requirement is then translated into, what is called a TSID rule,
which is expressed in the same section as :

"TSID RULE: The iSCSI Target SHOULD NOT select a TSID for a given login
request if the resulting SSID is already in use by an existing session
between the target and the requesting iSCSI Initiator. See Section 8.1.1
Conservative Reuse of ISIDs."

I have the following questions regarding the above requirement and
corresponding rule :

1) What is the basis for this requirement ? Why is a SSID required to be
unique for a given initiator-target node pair ?(My thinking was that
requirement (b) was all that was needed.)

2) What is the SSID used for and why is its unique-ness required ?

3) If there is some valid reason that justifies the retention of this
rule, then, why is the rule stated as "SHOULD NOT" and not "MUST NOT".
It seems that "SHOULD NOT" allows for conforming implementation to
violate this rule. Is that ok ?

Any clarifications would be appreciated.

Thanks,
Santosh

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: "Julian Satran" <[email-masked]>
Date: Sun, 17 Mar 2002 14:34:14 +0200

Santosh,

This  text is old and has not being updated for a while.
The Session uniqueness is assured now by the
Inititaor-name+ISID+TPGT+Target-name.
The text will be updated to reflect the fact the TSID - except for the
value "0" (reserved to indicate a new session) is there for the convenience
of the target and has no meaning for the protocol.
SSID has no meaning associated with it either and will be removed.  Your
issue about TPGT has also a neat solution - endorsed by the NDT - that they
may want to/have relayed to list.

Julo

                      Santosh Rao                                                             
                      <[email-masked].        To:       IPS Reflector <[email-masked]>      
                      com>                     cc:                                            
                      Sent by:                 Subject:  iscsi : TSID rule.                   
                      [email-masked]                                                       
                      .edu                                                                    

                      16-03-02 02:05                                                          
                      Please respond to                                                       
                      Santosh Rao                                                             

Hello,

Thanks,
Santosh