Subject: Question? Re: iSCSI range separator

From: Luben Tuikov <[email-masked]>
Date: Thu, 21 Mar 2002 14:33:26 -0500

[email-masked] wrote:
> 
> Bill,
> 
> We are trying to avoid overloading characters.

Pat, why are we trying to avoid overloading of characters?

Given that a context for each variable already exists
and we cannot avoid it.

We already know what a variable takes, so then
we can just parse for THAT particular thing.

How about this (BNF) (Just an example, just an example):

IFMarkInt=<RangeValue>
OFMarkInt=<RangeValue>

<RangeValue> ::= <integer>
<RangeValue> ::= <integer><RS><integer>
<RangeValue> ::= <RangeValue>,<RangeValue>
<RS> ::= : | - | ~

-- 
Luben

---

From: [email-masked]
Date: Thu, 21 Mar 2002 11:45:42 -0700

Bill,

We are trying to avoid overloading characters. If we were willing to
overload, we could use : (colon) which is used by some applications as a
range separater. I don't think we should overload the minus sign.

If we are not overloading, I vote for tilde.
If we are willing to overload, I vote for colon.

Pat

-----Original Message-----
From: Bill Studenmund [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 7:37 AM
To: Eddy Quicksall
Cc: iSCSI; [email-masked]; Rod Harrison; Julian Satran
Subject: RE: 

On Thu, 21 Mar 2002, Eddy Quicksall wrote:

> A dash is also used for negative numbers (we don't have any yet but could
in
> the future).

True, but is that a concern here? For a range, you have to have two
numbers with the dash/minus between them. "-number" would not be a
valid range. So even if we ever get negative numbers, ranges should be
readily different.

The only point of confusion would be if we ever permitted algebraic
expressions, when the '-' would look like subtraction. But I think that
would neither be sensible nor likely.

Take care,

Bill