Subject: Re: iscsi : changes involving tgt portal group tag.

From: "Julian Satran" <[email-masked]>
Date: Tue, 12 Mar 2002 21:42:18 +0200

I did not hear compelling arguments for it and it drags us even more into 
discovery teritory - Julo

Santosh Rao <[email-masked]>
Sent by: [email-masked]
12-03-02 21:04
Please respond to Santosh Rao

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     IPS Reflector <[email-masked]>
        Subject:        Re: iscsi : changes involving tgt portal group tag.

What is the closure on this issue ? Will the Target Portal Group Tag be
a part of the login request ? 

- Santosh

> (assuming we have the TPGT in the Login Request PDU), 

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: Robert Snively <[email-masked]>
Date: Wed, 13 Mar 2002 09:34:02 -0800

In SCSI (and I presume in iSCSI), there is no requirement that
the logical unit number to logical unit mapping be the same as
seen by all ports.  In other words, it is a Port||LUN combination
that identifies a logical unit, not a LUN alone.  The mappings
can be determined by a number of discovery mechanisms and verified
by use of the logical units world-wide name identifier from the
INQUIRY VPD page.

I don't think this has much effect on the rest of the ongoing
discussion, but if it does, please keep it in mind.

> Part of the concern appears to be around the worry that an initiator
> might reconnect to "the wrong" port and as a result end up talking to
> the wrong LU when it issues additional commands to a LUN it knows.
> 
> I don't understand how that's possible.  SAM-2 section 4.7.3 shows
> that an LU is a component of a Device (not of a Port).  And 4.8 says
> that a LUN "identifies the logical unit within a SCSI target device".
> 
> In other words, no matter what port you use to access a device, a
> given LUN identifies the same LU in that device.
>