Subject: RE:

From: "Julian Satran" <[email-masked]>
Date: Thu, 21 Mar 2002 17:47:11 +0200

I was looking at what would be appropriate (and perhaps familiar to 
programmers - double dot is used in Pascal for ranges).  (- or +) may come 
handy later for other things. And BTW double characters are already there 
in addresses. 
We could use semicolon(;) (I for some reason do not like it).

So we have 2 proposals:

1) .. (2 votes)
2); (1 vote?)

The tally is on! (untill tomorrow)

Julo

"Rod Harrison" <[email-masked]>
21-03-02 02:04
Please respond to "Rod Harrison"

        To:     Julian Satran/Haifa/IBM@IBMIL, <[email-masked]>
        cc: 
        Subject:        RE:

                 I would prefer one character. I don't care what it is, 
any character
will do, but having only one there is slightly easier to parse that
having two.

                 - Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
Sent: Wednesday, March 20, 2002 5:05 PM
To: [email-masked]
Subject:

Dear colleagues,

I suggested using : (colon) to separate values in a range.
Unfortunately :
is overused (in addresses and in names).
I suggest we use the (old) two dots (..) to mark a range.

Comments?
Julo

---

From: Bill Studenmund <[email-masked]>
Date: Thu, 21 Mar 2002 09:44:35 -0800 (PST)

> We could use semicolon(;) (I for some reason do not like it).

I think actually we have three proposals, don't we?

> 2); (1 vote?)

3) '-', and it seems to have at least two supporters. :-)

> The tally is on! (untill tomorrow)

Take care,

Bill

---

From: Luben Tuikov <[email-masked]>
Date: Thu, 21 Mar 2002 14:18:01 -0500

> 2); (1 vote?)

Note that the complexity is between 1 and N (N > 1)
character as you'll have to ``put back'' those
characters in the buffer/IO stream if they don't
match, and going about it with a single char
is so much easy...

Hmm, why do we need a _different_
character for ranges? Don't we have the
variable context already?

As Bill pointed out, even if we use dash/minus,
allowing negative numbers in ranges is NO problem.

You can see this for yourselves by either
writing down the context free grammar rules for it,
or equivalently an automata for parsing it.

If we decide on ``..'', then this _is_equivalent_
to ``range'', i.e.
              OFMarkInt=1..10
parses as
              OFMarkInt=1range10

since you'll have to get to _another_ state upon
parsing the second ``.'', the only difference
is that you need more states for ``range''.

-- 
Luben

---

From: Bill Studenmund <[email-masked]>
Date: Thu, 21 Mar 2002 12:15:51 -0800 (PST)

> handy later for other things. And BTW double characters are already there

One thing I would like to suggest also in choosing a value is to pick one
that will make sense to more than just programmers. One of the advantages
of using a text-based negotiation is that in case of negotiation problems,
an administrator could read the negotiation transcript and hopefully
figure out what was wrong. My suggestion is that we pick something that
will make sense to administrators also.

Take care,

Bill

---

From: "Kleinman, Barry" <[email-masked]>
Date: Thu, 21 Mar 2002 15:52:50 -0500

At 05:47 PM 3/21/2002 +0200, Julian Satran wrote:

I was looking at what would be appropriate (and perhaps familiar to
programmers - double dot is used in Pascal for ranges).  (- or +) may
come handy later for other things. And BTW double characters are already
there in addresses. 
We could use semicolon(;) (I for some reason do not like it). 

So we have 2 proposals: 

1) .. (2 votes) 
2); (1 vote?) 

How about underscore?  Looks sort of like a dash, never used in
arithmetic or floating point numbers.

-- Barry