Subject: RE: CmdSN, StatSN initial value?

From: "Martin, Nick" <[email-masked]>
Date: Tue, 12 Mar 2002 18:00:31 -0600

Martins,

The initial CmdSN to be used in a session is selected by the initiator
and transmitted in the first login PDU of the first connection.

The initial StatSN is selected by the target and transmitted in the
login response PDU for the initial login request of the connection.

The starting number for each is arbitrary.  Zero is not an unusual
choice.  The recipient of the PDU is required to extract the value and
begin using it.  There is no validation of the contents on an initial
login.

Note that CmdSN is session wide, while StatSN is per connection.

These are described in the Login Request and Login Response sections at
9.12.8 and 9.13.4 in draft 11.

Thanks,
Nick

-- You'll have to work hard to ask more "stupid questions" than I do.

> -----Original Message-----
> From: Martins Krikis [mailto:[email-masked]]
> Sent: Tuesday, March 12, 2002 3:43 PM
> To: [email-masked]
> Subject: CmdSN, StatSN initial value?
> 
> 
> Dear list members,
> 
> This must be a stupid question, but I can't find the
> intial values of CmdSN and StatSN specified in
> draft 11. I only see a requirement to start DataSN
> at 0.
> 
> Are CmdSN and StatSN also supposed to start with 0,
> or is the starting value completely arbitrary?
> 
> (I followed an old discussion about CmdSN, but this
> issue is still unclear to me.)
> 
> Any help is much appreciated.
> 
>   Martins Krikis, Intel Corp.
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Try FREE Yahoo! Mail - the world's greatest free email!
> http://mail.yahoo.com/
>

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 13 Mar 2002 09:37:22 +0200

Read the Login in Chapter 9. Julo

                      Martins Krikis                                                         
                      <[email-masked]        To:       [email-masked]                     
                      m>                       cc:                                           
                      Sent by:                 Subject:  CmdSN, StatSN initial value?        
                      [email-masked]                                                      
                      .edu                                                                   

                      12-03-02 23:43                                                         
                      Please respond to                                                      
                      Martins Krikis                                                         

Dear list members,