Subject: RE: iSCSI - Range of values can be negotiated for integers?

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Wed, 6 Mar 2002 16:11:59 -0700

Paul,

Most of the numeric negotiations are resolved by choosing the lesser of the
values that the initiator and target are willing to offer. Sending 

MaxConnections = 50

means one will support max connections anywhere from 1 to 50. It is not
clear to me that making it an explicit range provides any significant value
and it does add some complexity. Therefore, I do not think we should change
it.

Regards,
Pat Thaler

-----Original Message-----
From: Paul Koning [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 2:44 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: iSCSI - Range of values can be negotiated for integers?

Excerpt of message (sent 6 March 2002) by Robert D. Russell:
> Kevin:
> 
> In section 11 of Draft 11, when each key is defined, the form of
> the value side is indicated explicitly.  For example, section 11.2
> defines the MaxConnections key and shows its form as:
> 
>   MaxConnections=<number-from-1-to-65535>
> 
> This clearly shows that the value on the right of the = can only
> be a single number, not a range of numbers.  The only keys which can
> take a range of numbers are those in section A.3.2 of draft 11 for
> markers (the OFMarkInt and IFMarkInt keys).
> 
> Not that your idea is a bad one, but do we want the complication
> of these ranges on all the keys that have been just single numbers
> up to now?  What significant advantage would there be that would make
> it worthwhile for everyone to change the way it works now?

I was wondering the same thing.  Did I miss the discussion on the
list, or in the meeting, where this was covered?

I'm assuming that we're not making any changes to the spec at this
stage unless they are explicitly discussed on the list and agreed to
by the usual "rough consensus" criterion.

   paul

---

From: Luben Tuikov <[email-masked]>
Date: Thu, 07 Mar 2002 12:25:39 -0500

> Sending
> 
> MaxConnections = 50
> 
> means one will support max connections anywhere from 1 to 50. 

Yes, and this is implicit because of the _nature_ of the key (_maximum_ connections), that is it is
a range key in and of itself.

Allowing a range in numerical key offers is good since you can check your resources at that time and
choose a suitable value... 
No added complexity.

It's just string and atoi() manipuation, checking the next char for comma or dash (my own
extension), checking your own resources at that point in time and choosing a suitable value.

BTW, does anyone have a state transition diagram for processing the (contents of the) first login
PDU?

-- 
Luben