Subject: iSCSI: Login after FFP

From: Michael Schoberg <[email-masked]>
Date: Fri, 22 Mar 2002 12:16:31 -0600

This should be quick.  

Is it compliant for an iSCSI initiator to send a LOGIN request on a
connection already in FFP?  I couldn't find anything in the draft that
explicitly said this was allowed or not.  How should a target handle this?

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 23 Mar 2002 02:52:20 +0200

No the target should reject it. If the text does not say it I will add the 
text.

Thanks,
Julo

Michael Schoberg <[email-masked]>
Sent by: [email-masked]
22-03-02 20:16
Please respond to Michael Schoberg

        To:     "IPS Reflector (E-mail)" <[email-masked]>
        cc: 
        Subject:        iSCSI: Login after FFP

This should be quick.

---

From: Sanjay Goyal <[email-masked]>
Date: Sat, 23 Mar 2002 10:50:50 -0500

The text does say it.

2.5.3.2 Login Request and Login Response

Login Requests and Responses are used exclusively during the login phase of
each connection to set up the session and connection parame- ters (the login
phase consists of a sequence of login requests and responses carrying the
same Initiator Task Tag).

Regards 
Sanjay G 

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, March 22, 2002 7:52 PM
To: Michael Schoberg
Cc: IPS Reflector (E-mail); [email-masked]
Subject: Re: iSCSI: Login after FFP

Thanks, 
Julo 

22-03-02 20:16 

This should be quick.

---

From: Michael Schoberg <[email-masked]>
Date: Mon, 25 Mar 2002 15:04:37 -0600

This was mainly to track down a bug in an initiator and I just wanted to
verify that it was not valid.  I was wondering if there was wording that
prevents a connection in FFP from re-entering login negotiation mode to
attempt to form a new session, attach to a different session, or offer a new
CID or other parameters.  The wording I was hunting for would say that Login
negotiation is a one time event per TCP connection; renegotiation (re-login)
is not possible after entering FFP.  

-----Original Message-----
From: Sanjay Goyal [mailto:[email-masked]]
Sent: Saturday, March 23, 2002 9:51 AM
To: 'Julian Satran'
Cc: IPS Reflector (E-mail); [email-masked]
Subject: RE: iSCSI: Login after FFP

The text does say it.

Regards 
Sanjay G 

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, March 22, 2002 7:52 PM
To: Michael Schoberg
Cc: IPS Reflector (E-mail); [email-masked]
Subject: Re: iSCSI: Login after FFP

Thanks, 
Julo 

22-03-02 20:16 

This should be quick.