Subject: RE: iSCSI - Range of values can be negotiated for integers?

From: "Julian Satran" <[email-masked]>
Date: Wed, 6 Mar 2002 19:02:59 +0200

Kevin,

You have a good point. I have observed myself that I created this problem 
when introducing ranges and I fixed it - but too late (yesterday :-)) The 
section 4 text will read:

The value offered can be an integer, a range defined by lower and upper 
value - both integers separated by a comma, a single literal constant a 
Boolean value (Yes or No), or a list of comma separated, literal constant 
values. A range MAY ONLY be offered only if it is explicitly allowed for a 
key. A selected value can be an integer, a single literal constant or a 
Boolean value.

Regards,
Julo

"LEMAY,KEVIN (A-Roseville,ex1)" <[email-masked]>
Sent by: [email-masked]
06-03-02 18:10
Please respond to "LEMAY,KEVIN (A-Roseville,ex1)"

        To:     "'Robert D. Russell'" <[email-masked]>
        cc:     [email-masked], "'Satran, Julian'" <[email-masked]>
        Subject:        RE: iSCSI - Range of values can be negotiated for integers?

One could take the most liberal interpretation and offer:

MaxConnections=1,15
MaxBurstSize=8192,64456
FirstBurstSize=8192,64456
....

Where in the spec does it say which integer keys are allowed to use ranges
in the negotiation?

Kevin Lemay

-----Original Message-----
From: Robert D. Russell [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 8:02 AM
To: LEMAY,KEVIN (A-Roseville,ex1)
Cc: [email-masked]; 'Satran, Julian'
Subject: Re: iSCSI - Range of values can be negotiated for integers?

Kevin:

I believe that the sentence you quote should be prefaced as
follows:

"Depending on the key, the value offered can be an integer,
a range defined by a lower and upper value, ..."

This makes it clear that it does NOT apply to all numeric keys.

Julian, if you agree would you please add the "Depending on the key,"
prefix to the sentence in question?

Thanks,
Bob Russell

On Tue, 5 Mar 2002, LEMAY,KEVIN (A-Roseville,ex1) wrote:

> On page 60 of iSCSI v11 says that:
>
> "The value can be an integer, a range defined by a lower and upper
> value...."
>
> I must assume that any numeric key may use this feature?
>
> I don't see any reference to this new capabilty anywhere else in the
> document. I am sure that we are going to have problems at plugfest if 
this
> is not cleared up now.
> Thanks,
> Kevin Lemay
> Agilent Technologies

---

From: [email-masked]
Date: Wed, 6 Mar 2002 10:38:06 -0700

I don't want to change it. I missed the the OFMarkInt and IFMarkInt keys and
no operational keys seemed to reference the ranges. I didn't see where it
was used.

Now it is clear.

I still need to change my login code to handle the ranges for OFMarkInt and
IFMarkInt.

Kevin

-----Original Message-----
From: Robert D. Russell [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 9:05 AM
To: LEMAY,KEVIN (A-Roseville,ex1)
Cc: [email-masked]; 'Satran, Julian'
Subject: RE: iSCSI - Range of values can be negotiated for integers?

Kevin:

In section 11 of Draft 11, when each key is defined, the form of
the value side is indicated explicitly.  For example, section 11.2
defines the MaxConnections key and shows its form as:

  MaxConnections=<number-from-1-to-65535>

This clearly shows that the value on the right of the = can only
be a single number, not a range of numbers.  The only keys which can
take a range of numbers are those in section A.3.2 of draft 11 for
markers (the OFMarkInt and IFMarkInt keys).

Not that your idea is a bad one, but do we want the complication
of these ranges on all the keys that have been just single numbers
up to now?  What significant advantage would there be that would make
it worthwhile for everyone to change the way it works now?

Bob Russell

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 7 Mar 2002 09:01:44 +0200

There was a discussion on the "irregularity" of the marker negotiation.
Ranges are now covered as a "regular" negotiation - and have to be used 
only when allowed explicitly (see my earlier note).

Julo

Paul Koning <[email-masked]>
Sent by: [email-masked]
07-03-02 00:44
Please respond to Paul Koning

        To:     [email-masked]
        cc:     [email-masked]

> it worthwhile for everyone to change the way it works now?

I was wondering the same thing.  Did I miss the discussion on the
list, or in the meeting, where this was covered?

I'm assuming that we're not making any changes to the spec at this
stage unless they are explicitly discussed on the list and agreed to
by the usual "rough consensus" criterion.

   paul