Subject: RE: iSCSI: Question: ISID Rule?

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Thu, 7 Mar 2002 13:00:05 -0800

It's the SCSI device that is the comparison point, so you are comparing the
iSCSI node name of the two entities to determine if they are "the same".

Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions Org.
Hewlett-Packard
tel: +1 916 785 2656
fax: +1 916 785 0391
email: [email-masked] 

> -----Original Message-----
> From: Luben Tuikov [mailto:[email-masked]]
> Sent: Thursday, March 07, 2002 11:33 AM
> To: iSCSI
> Subject: iSCSI: Question: ISID Rule?
> 
> 
> Could someone clarify a) and b) in 2.4.3 (pg. 51) of draft 11.
> 
> More specifically in a): what makes two of ``iSCSI 
> initiator'' or two of ``iSCSI Target'' the same
> so that I can check they are the same and impose uniqueness of SSID.
> 
> Is it ISID/TSID or Network Portals or both, or the Name or...?
> 
> Thanks,
> -- 
> Luben
>

---

From: Luben Tuikov <[email-masked]>
Date: Thu, 07 Mar 2002 17:32:42 -0500

> iSCSI node name of the two entities to determine if they are 
"the same".

Then this implies that a session is uniquely identified by (InitiatorName, TargetName).

Then for a new connection at the target:

 i) TSID!=0 provides implicit uniqueness,
    since a new connection will be added,
    if the session already exists.

ii) TSID=0, implies that there does NOT exist
    a session with the given TargetName, InitatorName
    and ISID given in the Login Request PDU, else close the
    connection.

Is this true?

-- 
Luben