Subject: iSCSI: padding on intermediate sequences

From: Eddy Quicksall <[email-masked]>
Date: Tue, 26 Mar 2002 09:52:50 -0500

Section 9.7.7 says:
 
The Data Segments of Data-in and Data-out PDUs SHOULD be filled to the
integer number of 4 byte words (real payload) unless the F bit is set
to 1.
 
This allows one to pad intermediate sequences of a transfer. But, there are
reasons why padding on intermediate sequences within a transfer can make
life difficult.
 
Can we forbid padding on all but the last PDU for the transfer? If that is
objectionable, could we forbid padding on all but the last PDU of a transfer
if DataInOrder=yes. 
 
Eddy

---

From: "Robert D. Russell" <[email-masked]>
Date: Tue, 26 Mar 2002 14:48:20 -0500 (EST)

Eddy:

I may not be understanding you correctly, but the
words in section 9.7.7 I believe mean that these data
segments should contain an integer number of 4 byte words
of data, not arbitrary "pad" bytes.  If the data segment
length is a multiple of 4 then there will be NO pad bytes.

There seems to be confusion over your use of "pad"
and the standard's use of "pad".  Would you please clarify?

Thanks,
Bob