Subject: RE: iscsi : changes involving tgt portal group tag.

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Tue, 12 Mar 2002 19:12:47 -0500

Perhaps we should discuss this in Minneapolis.  I agree with Santosh, TPG
should be added to the login message to verify that this is the intended
target port.  I don't see how that is interpreted as "discovery territory",
since it's just the initiator explicitly identifying the intended target
port.  Currently a login contains initiator and target names, and initiator
port number (ISID), so adding target port number is consistent.  There's
still room in the login header, and this wouldn't break any current
implementations.  Why is this a problem?
 
Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions Org.
Hewlett-Packard
tel: +1 916 785 2656
fax: +1 916 785 0391
email: [email-masked] 

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Tuesday, March 12, 2002 11:42 AM
To: Santosh Rao
Cc: IPS Reflector; [email-masked]
Subject: Re: iscsi : changes involving tgt portal group tag.

I did not hear compelling arguments for it and it drags us even more into
discovery teritory - Julo 

	Santosh Rao <[email-masked]> 
Sent by: [email-masked] 

12-03-02 21:04 
Please respond to Santosh Rao 

        To:        Julian Satran/Haifa/IBM@IBMIL 
        cc:        IPS Reflector <[email-masked]> 
        Subject:        Re: iscsi : changes involving tgt portal group tag. 

What is the closure on this issue ? Will the Target Portal Group Tag be
a part of the login request ? 

- Santosh

> (assuming we have the TPGT in the Login Request PDU), 

-- 
##################################
Santosh Rao
Software Design Engineer,
HP-UX iSCSI Driver Team,
Hewlett Packard, Cupertino.
email : [email-masked]
Phone : 408-447-3751
##################################

---

From: "Rod Harrison" <[email-masked]>
Date: Wed, 13 Mar 2002 03:32:43 -0000

We would also have to change SendTargets to mandate returning the
targetAddress, or specify a default TPG for use in the cases where
SendTargets returns no targetAddress.

	- Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
KRUEGER,MARJORIE (HP-Roseville,ex1)
Sent: Wednesday, March 13, 2002 12:13 AM
To: IPS Reflector
Subject: RE: iscsi : changes involving tgt portal group tag.

Perhaps we should discuss this in Minneapolis.  I agree with Santosh,
TPG should be added to the login message to verify that this is the
intended target port.  I don't see how that is interpreted as
"discovery territory", since it's just the initiator explicitly
identifying the intended target port.  Currently a login contains
initiator and target names, and initiator port number (ISID), so
adding target port number is consistent.  There's still room in the
login header, and this wouldn't break any current implementations.
Why is this a problem?

Marjorie Krueger
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Tuesday, March 12, 2002 11:42 AM
To: Santosh Rao
Cc: IPS Reflector; [email-masked]
Subject: Re: iscsi : changes involving tgt portal group tag.

I did not hear compelling arguments for it and it drags us even more
into discovery teritory - Julo

        To:        Julian Satran/Haifa/IBM@IBMIL
        cc:        IPS Reflector <[email-masked]>
        Subject:        Re: iscsi : changes involving tgt portal group
tag.

What is the closure on this issue ? Will the Target Portal Group Tag
be
a part of the login request ?

- Santosh