Subject: RE: iSCSI: Use of the A bit

From: Eddy Quicksall <[email-masked]>
Date: Fri, 15 Mar 2002 15:09:00 -0500

By status ack, if you mean a SCSI Response with ExpStatSN, then that does
not acknowledge the Data-In unless the Data-In was followed by status.
 
Julian, all we are asking is that you don't create a spec that has a
pitfall. If one is worried about performance then he should work that out by
not asking for the Ack in the first place. Don't mandate it in the spec,
just say it in a note.
 
Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, March 15, 2002 2:51 PM
To: Paul Koning
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: RE: iSCSI: Use of the A bit

That could be so but it would be overkill. Status ACK can implicitly
acknowledge the last transfer. 
And Yes the fact that the last transfer is not mentioned is an oversight
that I will correct. 
This does not mean that you HAVE TO raise the A flag or that you are
ENCOURAGED to do so :-) 

Julo 

	Paul Koning <[email-masked]> 
Sent by: [email-masked] 

15-03-02 16:09 
Please respond to Paul Koning 

        To:        [email-masked] 
        cc:        [email-masked], [email-masked] 
        Subject:        RE: iSCSI: Use of the A bit 

>>>>> "Eddy" == Eddy Quicksall <[email-masked]> writes:

Eddy> I think we may need better explanation about why some folks
Eddy> don't want to do the "positive ack".

>> We got to this position, since so many folks did not want to
>> support the positive ack.

Something doesn't compute here.

I don't believe the discussion has anything to do with whether you
support positive ACK or not.  If you're doing error recovery level 1
or above, then you are required to support it, because the other end
is allowed to say A=1 and you're required to answer that.

If you don't want to support positive ACK, the solution is to support
only error recovery level 0.

The issue under discussion is whether the rule "you are allowed to set
A=1 only once per MaxBurstSize" is correct.  At this point it's clear
to me that it is not, because you need to be able to set A=1 at the
end of the transfer.  The current rule forbids that unless the total
transfer size is >= MaxBurstSize.

Kevin's proposal is a simple fix to this problem.

                 paul

---

From: Martins Krikis <[email-masked]>
Date: Fri, 15 Mar 2002 13:45:14 -0800 (PST)

Just a quick note. Some people have implied that the
use of A-bit necessarily means poor performance.

I would like to disagree. If the target is just
sitting there waiting for acknowledgment to come
back before sending the next Data-In sequence, then
yes, that's poor performance. But I can imagine
targets that keep sending data while waiting for
the outstanding acknowledgments. Yes, it requires
more buffer space, but the acknowledgments are
actually helpful in managing that bigger buffer space.
It's a very similar situation to multiple outstanding
R2T-s. Hopefully everybody agrees that there may be
benefits to those. 

Or am I just missing something again?

  Martins Krikis, Intel Corp.

Disclaimer: These opinions are mine and may not
            reflect those of my employer.

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - live college hoops coverage
http://sports.yahoo.com/