Subject: RE: Range Seperator

From: "LEMAY,KEVIN (A-Roseville,ex1)" <[email-masked]>
Date: Thu, 21 Mar 2002 09:20:27 -0700

I do not like the ';' but I would prefer a single character. There have been
objections to using the comma or colon, then my third choice is the ".."
 
I really don't see any conflict using either the comma or colon.
 
Using comma is already used to separate list values. Colon being used in
addresses is irrelevant because those are different parameters. I certainly
keep track of which one we are working on.
 
Kevin Lemay
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 7:47 AM
To: Rod Harrison
Cc: [email-masked]
Subject: RE:

I was looking at what would be appropriate (and perhaps familiar to
programmers - double dot is used in Pascal for ranges).  (- or +) may come
handy later for other things. And BTW double characters are already there in
addresses. 
We could use semicolon(;) (I for some reason do not like it). 

So we have 2 proposals: 

1) .. (2 votes) 
2); (1 vote?) 

The tally is on! (untill tomorrow) 

Julo 

	"Rod Harrison" <[email-masked]> 

21-03-02 02:04 
Please respond to "Rod Harrison" 

        To:        Julian Satran/Haifa/IBM@IBMIL, <[email-masked]> 
        cc:         
        Subject:        RE: 

                I would prefer one character. I don't care what it is, any
character
will do, but having only one there is slightly easier to parse that
having two.

                - Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Julian Satran
Sent: Wednesday, March 20, 2002 5:05 PM
To: [email-masked]
Subject:

Dear colleagues,

I suggested using : (colon) to separate values in a range.
Unfortunately :
is overused (in addresses and in names).
I suggest we use the (old) two dots (..) to mark a range.

Comments?
Julo

---

From: "Rod Harrison" <[email-masked]>
Date: Thu, 21 Mar 2002 17:06:15 -0000

I don't care what the character is since the focus is to make this
easy to parse, and not human readable. So to that end consider my vote
to be for whichever of the single characters is nearest to winning.
;-)

	However, if we do have to pay some mind to aesthetics then how about
the < character? So we would have MyKey=3<65,93<123

	- Rod

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
LEMAY,KEVIN (A-Roseville,ex1)
Sent: Thursday, March 21, 2002 4:20 PM
To: 'Julian Satran'
Cc: [email-masked]
Subject: RE: Range Seperator

I do not like the ';' but I would prefer a single character. There
have been
objections to using the comma or colon, then my third choice is the
".."

Using comma is already used to separate list values. Colon being used
in
addresses is irrelevant because those are different parameters. I
certainly
keep track of which one we are working on.

Kevin Lemay

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, March 21, 2002 7:47 AM
To: Rod Harrison
Cc: [email-masked]
Subject: RE:

I was looking at what would be appropriate (and perhaps familiar to
programmers - double dot is used in Pascal for ranges).  (- or +) may
come
handy later for other things. And BTW double characters are already
there in
addresses.
We could use semicolon(;) (I for some reason do not like it).

So we have 2 proposals:

1) .. (2 votes)
2); (1 vote?)

Julo

21-03-02 02:04

                I would prefer one character. I don't care what it is,
any
character
will do, but having only one there is slightly easier to parse that
having two.

                - Rod

-----Original Message-----

Dear colleagues,

Comments?
Julo