Subject: RE: iSCSI: New Lucent stmt on SRP

From: [email-masked]
Date: Fri, 29 Mar 2002 13:58:36 -0500

Amir,

Not completely, but it helps.  The IESG is now requesting
that the WG consider use of a version of CHAP strengthened
by an anonymous Diffie-Hellman key exchange as an alternative
to SRP.  In essence, the DH key exchange would produce the
CHAP challenge and replace passing it as part of the protocol.
In addition, I believe the IESG could accept CHAP without
DH strengthening if the WG believes that to be the best choice.

Ted Ts'o has done us the favor of posting many of the issues
that the IESG expects the WG to consider in his post from
this past Wednesday:

http://www.pdl.cmu.edu/mailinglists/ips/mail/msg09358.html

I would hope that a strawman design for this mechanism
could be posted in the next week, and apologize for the
delay ... I'm afraid that all attempts to clone me have
failed, and I need to ensure that some real cryptographers
check the resulting design before it is posted  ;-).

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Amir Shalit [mailto:[email-masked]]
> Sent: Friday, March 29, 2002 12:10 PM
> To: [email-masked]; [email-masked]
> Subject: RE: iSCSI: New Lucent stmt on SRP
> 
> 
> David,
> 
> Does it solve the SRP dilemma? 
> 
> Amir
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Friday, March 29, 2002 7:03 AM
> To: [email-masked]
> Subject: iSCSI: New Lucent stmt on SRP
> 
> 
>    http://www.ietf.org/ietf/IPR/LUCENT-SRP
> 
> --David
> ---------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 42 South St., Hopkinton, MA  01748
> +1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
> [email-masked]         Cell: +1 (978) 394-7754
> ---------------------------------------------------

---

From: David Jablon <[email-masked]>
Date: Sat, 30 Mar 2002 14:51:17 -0500

>> Does [the new Lucent letter] solve the SRP dilemma?

At 01:58 PM 3/29/02 -0500, [email-masked] wrote:
>Not completely, but it helps. ...

David, can you elaborate on how it helps, what is missing, etc.?

>... The IESG is now requesting
>to SRP. ...

I'm not sure what "alternative" means in this context.  An alternative
"option" in addition to something like SRP would achieve the
goal of guaranteed free interoperability.  Or has the IESG suggested
"replacement", which is something else entirely?

>http://www.pdl.cmu.edu/mailinglists/ips/mail/msg09358.html

Have these IESG requests to the WG and expectations of the WG
been formally posted directly to the list?  It would be nice to
know what the other issues are too, that weren't included in
Ted's post.

>check the resulting design before it is posted  ;-).

As legitimate review is an open process, I assume your wink
means that the secret initial checking by "real cryptographers"
is just a necessary first step.  Ted's post has stimulated an
initial thread of security discussion, which can continue
after the design is posted.

-- David