Subject: Re: iSCSI using IPSEC

From: "Julian Satran" <[email-masked]>
Date: Fri, 22 Mar 2002 18:33:40 +0200

iSCSI can use  any IPsec implementation. Obviously iSCSI will not be
implemented at iSCSI level as it sits somewhere else in the stack.  The
coordination between IPsec and iSCSI is by administrative means and some
things that should or should not be done (key negotiations, SA use) are
specified in the IPS security draft.

Julo

                      Rahul Gupta                                                                               
                      <Rahul.gupta@dcmt        To:       "[email-masked]'" <[email-masked]>                  
                      ech.co.in>               cc:                                                              
                      Sent by:                 Subject:  iSCSI using IPSEC                                      
                      [email-masked]                                                                         
                      .edu                                                                                      

                      22-03-02 09:32                                                                            
                      Please respond to                                                                         
                      Rahul Gupta                                                                               

Hi all,
I am new developer on iscsi & ipsec . I have a small basic query.

1) Does Ipsec needs to be developed at the iscsi level and incorporated as
a
part of iscsi or it is a standalone entity ???

2) How does iscsi utilizes the ipsec functionality ..?? ( Since Ipsec is
between TCP and IP in the stack while iscsi is above TCP...)

Regards
Rahul Gupta

---

From: Bill Studenmund <[email-masked]>
Date: Fri, 22 Mar 2002 16:52:32 -0800 (PST)

> iSCSI can use  any IPsec implementation. Obviously iSCSI will not be
                                                     IPsec :-)

> specified in the IPS security draft.

Put another way, the admin configures iSCSI between two machines. As a
seperate, independant step, the admin configures IPsec between those two
machines. When iSCSI starts up, since it is a TCP protocol, it will use
the IPsec settings between the two machines.

Take care,

Bill