Subject: Connection Recovery in case of a single connection in a session

From: "Monisha Barooah" <[email-masked]>
Date: Fri, 10 May 2002 09:46:26 +0000

Hi All,
  I wanted to know how to perform Connection Recovery for a connection when it is the only connection of a session. 

 Connection Recovery invloves the logout of the failed connection and the reassignment of the tasks of the failed connection to a full feature phased connection.

In case there is only one connection in a session. How do we do the Connection Recovery? Shall we open up another connection to do implicit logout? But in this case the CID of the new connection will be the same as that of the failed connection and the task reassignment will not come into picture at all.

Regards,
Monisha.

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 15 May 2002 12:45:59 +0300

Yes and No. You should be able to open a new connection but that can be AS 
A REPLACEMENT of the old connection and reassign.
The only unfortunate case where you may have to have 2 connection 
capability is when your iSCSI time-outs are shorter than the TCP time-outs 
and
either initiator or target will not detect a failed TCP before the iSCSI 
state disappears.

Julo

Parthi <[email-masked]>
Sent by: [email-masked]
05/15/2002 08:39 AM
Please respond to Parthi

        To:     [email-masked], [email-masked], [email-masked]
        cc: 
        Subject:        Re: Connection Recovery in case of a single connection in a session

Target should support opening a second connection even though they do not 
support multiple connections in full feature phase. The purpose of second 
connection is to reassign the tasks. 
Parthi 
[email-masked] wrote: 
This recovery requires the ability to support more than one 
connection in a session.  Once the first connection is logged 
out, its tasks are gone.  An implementation that does not 
support multi-connection sessions cannot do this sort of 
recovery. 
Thanks, 
--David 
> -----Original Message----- 
> From: Monisha Barooah [mailto:[email-masked]] 
> Sent: Friday, May 10, 2002 5:46 AM 
> To: [email-masked] 
> Subject: Connection Recovery in case of a single connection 
> in a session 
> 
> 
> 
>  Hi All, 
>   I wanted to know how to perform Connection Recovery for a 
> connection when it is the only connection of a session. 
> 
>  Connection Recovery invloves the logout of the failed 
> connection and the reassignment of the tasks of the failed 
> connection to a full feature phased connection. 
> 
> In case there is only one connection in a session. How do we 
> do the Connection Recovery? Shall we open up another 
> connection to do implicit logout? But in this case the CID of 
> the new connection will be the same as that of the failed 
> connection and the task reassignment will not come into 
> picture at all. 
> 
> Regards, 
> Monisha. 
>
-- 
Parthiban M,
HCL Technologies Ltd.,          Tel : (+91)-44-3741939 to 42, Extn. 2332
http://san.hcltech.com