Subject: Re: [iSCSI:] Logout request -- reason? Correction

From: "John Hufferd" <[email-masked]>
Date: Mon, 27 May 2002 16:30:27 -0700

There is nothing broken here, this is preference.  I see no reason to move
it again.  Julian, did announce it and we accepted it.
We should be moving towards closure.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

Luben Tuikov <[email-masked]>@ece.cmu.edu on 05/27/2002 01:45:49 PM

Sent by:    [email-masked]

To:    Julian Satran/Haifa/IBM@IBMIL
cc:    iSCSI <[email-masked]>
Subject:    Re: [iSCSI:] Logout request -- reason? Correction

Julian Satran wrote:
>
> Reason  & Function codes are there for several request types. (e.g., task
management).
>
> I did announce my intent to move it there for uniformity  - a long time
ago - when it was
> requested by a list member - and waited for comments.

You have my vote on moving the function numeric to
byte 2 (Logout Request & TMF Request).

As well as moving the Type numeric to byte 2 in
SNACK.

This will make things pretty consistent.

Everyone okay with this?

--
Luben

> BTW - you appear to be sending mail from ns.splentec.com and a reply
there ends always with
> bounced mail.

Attached below is a copy of the SMTP header of the message
which arrived at the mailing list.

Yes, the last stop of our (Splentec) messages do go through
ns.splentec.com, but your MUA (Mail User Agent) SHOULD
go with its reply by either Reply To: or of not available
by From:. It SHOULD NOT reply to any of the
Received: headers' machines. Which RFC was this in?

emacs, netscape, yahoo.com, etc. have no problem replying to
my messages.

So I guess the problem is in Lotus Notes, NOT in sendmail.
Please contact your vendor.

--cut----

---

From: "John Hufferd" <[email-masked]>
Date: Tue, 28 May 2002 09:33:10 -0700

I think you are over stating you case.  I, and others I have talked to do
not see this as a problem with OO code.  In any event, we are not in the
business of "code beauty".  If we put that as a base, we would never
complete.

Lets focus on what is broken!

.
.
.
John L. Hufferd

Luben Tuikov <[email-masked]>@ece.cmu.edu on 05/28/2002 08:53:21 AM

To:    Paul Koning <[email-masked]>
cc:    [email-masked], John Hufferd/San Jose/IBM@IBMUS
Subject:    Re: [iSCSI:] Logout request -- reason? Correction

Paul Koning wrote:
>
> I objected before and I'll object again.
>
> It would be very nice if we could stop making gratuitous changes to
> packet formats and get the spec finished instead.

In other words you have no problem with those changes
taking place, you simply oppose to them, lest the
PDU format become more object oriented friendly.

The people in C wouldn't mind that much since they are used to
dealing with bit shifting and what not, but the people in
C++ where this inconsistency would mean an ugly base class,
and an unbecoming implementation would cringe at the look of it.

You should've at least recognised that this would
be a _good_ architectural change, and then give your reasons
for _not_ implementing it, rather than calling them
``gratuitous changes''.

I'm not posting here out of whim -- I really do care.

--
Luben

---

From: [email-masked]
Date: Tue, 28 May 2002 13:29:41 -0400

Luben,

> PDU format become more object oriented friendly.

I think that's somewhat overdone and out of line.  The formats
have been this way for a while now, and we are well past the
point where this sort of change is appropriate for abstract
beautification reasons such as "object oriented friendly".
We could spend the next 6 months rearranging the iSCSI header
structures to suit some ideals of beauty and architectural
cleanliness, and even though there are doubtless some
people who would like to "help" with this, I'm fairly certain
that the rough consensus of the WG is not to spend the next
6 months on this activity.

> for _not_ implementing it, rather than calling them

There's quite a bit of "running code" out there that deserves
some degree of respect - the fact that these changes break it
suggests that something other than an opinion that the result
will be more "object oriented friendly" is needed to motivate
them.  At the moment, both "rough consensus" and "running code"
appear to suggest that they are not appropriate.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Luben Tuikov [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 11:53 AM
> To: Paul Koning
> Cc: [email-masked]; John Hufferd