Subject: Re: iSCSI: Logout and recovery notes

From: "chhavi_garg" <[email-masked]>
Date: Wed, 15 May 2002 13:09:04 +0530

Hi Mallikarjun,

I've a confusion regarding the mapping of Logout reason codes that you have refered in the mail attached below. 

You have written,

The entire logout discussion in logout section is completely applicable also for an implicit Logout effected by way of a connection reinstatement or session reinstatement. The Logout reason codes for implicit Logout are specified as below -

Reason code Type of implicit Logout

0 session reinstatement

1 connection reinstatement when the operational ErrorRecoveryLevel &lt; 2

2 connection reinstatement when the operational ErrorRecoveryLevel = 2

As per my understanding, in case of implicit logout i,e in CSM-I scenario, We will proceed with Login request with the same CID in case of connection reinstatement and with TSIH=0 in case of session reinstatement. When will we send the Logout request with the above reason code in this scenario. 

-regards,

Chhavi.

"Mallikarjun C." wrote:

Julian,

A couple of notes -

1. Section 9.14 (last para on page 170) still contains references
to the restart option of the Login command - they should be
removed.

2. The following text in the next paragraph says that some unacknowledged
commands may be discarded on a Logout. Since some of the unacknowledged
commands may be instantiated and could legally be reassigned by virtue of being
active tasks (just like acknowledged commands), I suggest we make the current
text more specific to exclude that case by rewording the current sentence -

"Sending a logout request with the reason code of "close the connection" or "remove the connection for
recovery" may result in the discarding of some unacknowledged commands."

to:

"A successful completion of a logout request with the reason code of "close the connection" or "remove the
connection for recovery" results in the discarding of all tasks waiting in the command reordering queue that
are allegiant to the connection being logged out."

3. In general, the Logout section should add text along the lines of -

The entire logout discussion in this section is completely applicable also
for an implicit Logout effected by way of a connection reinstatement or
session reinstatement. The Logout reason codes for implicit Logout are
specified as below -
Reason code Type of implicit Logout
0 session reinstatement
1 connection reinstatement when the operational ErrorRecoveryLevel &lt; 2
2 connection reinstatement when the operational ErrorRecoveryLevel = 2

4. It seems to me that continuing text tasks across connection failures is prone
to error since some of the negotiated ones can be CO, and some can be (perhaps
vendor-unique) SW. The discussion on text negotiation (probably section 9.10)
should add text along the lines of -

On a connection failure, an initiator must either explicitly abort any active allegiant
text negotiation task or must cause such a task to be implicitly terminated by the target.

Regards.

Mallikarjun

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 15 May 2002 11:23:33 -0700

> I've a confusion regarding the mapping of Logout reason codes that you have refered in the mail attached
below.

I thought I had responded to a private email query, but perhaps it didn't
get through (our email server was briefly down).  Here it is attached.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
[email-masked]

Subject: Re: iSCSI: Logout and recovery notes
From: "Mallikarjun C." <[email-masked]>
To: "chhavi_garg" <[email-masked]>, "Julian Satran" <[email-masked]>
Date: Mon, 13 May 2002 08:35:32 -0700

Chhavi, comments below.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
[email-masked]

----- Original Message -----
From: "chhavi_garg" <[email-masked]>
To: "Mallikarjun C" <[email-masked]>; "Julian Satran" <[email-masked]>
Sent: Monday, May 13, 2002 5:10 AM
Subject: Re: iSCSI: Logout and recovery notes

>
>
>
> Hello Mallikarjun,
>
>
> I've a confusion regarding the mapping of reason codes that you have refered in the mail attached below.
>
>
> You have written,
>
>
>
> As per my understanding, in case of implicit logout i,e in CSM-I scenario, We will proceed with Login
request with the same CID in case of connection reinstatement

And that has two sub-cases as listed above.  A connection reinstatement for a session
whose ErrorRecoveryLevel = 2, and < 2.  Each of those "context-sensitive" connection
reinstatements imply an implicit Logout with a different reason code - per the new text.

>and with TSIH=0 in case of session reinstatement. When will we send the Logout request with the above reason
code in this scenario ??