Subject: Re: iSCSI: TotalAHSlength in response pdus

From: "Julian Satran" <[email-masked]>
Date: Fri, 24 May 2002 07:56:48 +0300

AHS could be used for more than encapsulating an extended CDB - Julo

Parthi <[email-masked]>
Sent by: [email-masked]
05/24/2002 06:01 AM
Please respond to Parthi

        To:     Ashok Rajagopalan <[email-masked]>
        cc:     [email-masked]
        Subject:        Re: iSCSI: TotalAHSlength in response pdus

Ashok Rajagopalan wrote: 
Hello, 
Since section 9.2 states "iSCSI response PDUs do not have AH segments" 
why do SCSI response PDU, Task Management Resp PDU etc.. have 
TotalAHSLength? 
Shouldn't it be reserved. In addition DataSegmentLength to be made 
reserved 
in most of the response pdus e.g. Task Mgt resp etc.. 
Thanks, 
Ashok
Ashok, 
    TotalAHSLength must be 0 "reserved" for PDUs that don't have AHS. 
AHS is only used to encapsulate an extended CDB. This scenario 
TotalAHSLength would be 0. 
-- 
Parthiban M,
iSCSI Driver Team,
HCL Technologies Ltd.,          Tel : (+91)-44-3741939 to 42, Extn. 2332
http://san.hcltech.com

---

From: Bill Studenmund <[email-masked]>
Date: Fri, 24 May 2002 10:24:33 -0700 (PDT)

> AHS could be used for more than encapsulating an extended CDB - Julo

While the above is quite true, doesn't that go against the statement
quoted below that responses don't have AH segments?

I think the question is more doesn't the spec contradict itself rather
than should we or shouldn't we have AH segments in a response; right now
we seem to be saying both yes AND no. :-)

Take care,

Bill