Subject: Logout request -- reason?

From: Luben Tuikov <[email-masked]>
Date: Mon, 27 May 2002 09:44:16 -0400

I was under the impression that byte 1 in BHS
is a flags byte -- i.e. bit values.

I now see that the reason code is moved exactly there,
in the Logout request PDU. 

Could anyone please explain the logic behind this?

At the same time byte 3 and 4 are reserved to 0.

Why don't we:

1)  Move the reason code to byte 1. This will
    make it _consistent_ with the response byte
    in Logout Response.

2)  Make the value start at 0x80, as to hide
    the ugliness of F = 1, and the fact that
    we are trying to fit a numerical value (!)
    and a bit value (!) in the same octet.

Comments?

-- 
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Mon, 27 May 2002 09:48:55 -0400

Let me correct this:

 

At the same time byte 2 and 3 are reserved to 0.

Why don't we:

1)  Move the reason code to byte 2. This will
    make it _consistent_ with the response byte
    in Logout Response.

Comments?

--
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Mon, 27 May 2002 12:20:49 -0400

Could we do the same to Task Mgmt. Func. Req.
(Function -> byte 2) and to SNACK (Type -> byte 2).
Both PDUs have byte 2 reserved to 0.

If not, please elaborate.

-- 
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Mon, 27 May 2002 09:48:55 -0400

--cut--

---

From: Paul Koning <[email-masked]>
Date: Tue, 28 May 2002 09:53:01 -0400

>>>>> "Luben" == Luben Tuikov <[email-masked]> writes:

 Luben> Could we do the same to Task Mgmt. Func. Req.  (Function ->
 Luben> byte 2) and to SNACK (Type -> byte 2).  Both PDUs have byte 2
 Luben> reserved to 0.

 Luben> If not, please elaborate.

I objected before and I'll object again.

It would be very nice if we could stop making gratuitous changes to
packet formats and get the spec finished instead.

       paul

---

From: Luben Tuikov <[email-masked]>
Date: Tue, 28 May 2002 11:53:21 -0400

John Hufferd wrote:
> 
> There is nothing broken here, this is preference.  I see no reason to move
> it again.  Julian, did announce it and we accepted it.
> We should be moving towards closure.
> 

> packet formats and get the spec finished instead.

In other words you have no problem with those changes
taking place, you simply oppose to them, lest the
PDU format become more object oriented friendly.

The people in C wouldn't mind that much since they are used to
dealing with bit shifting and what not, but the people in
C++ where this inconsistency would mean an ugly base class,
and an unbecoming implementation would cringe at the look of it.

You should've at least recognised that this would
be a _good_ architectural change, and then give your reasons
for _not_ implementing it, rather than calling them
``gratuitous changes''.

I'm not posting here out of whim -- I really do care.

-- 
Luben

---

From: Santosh Rao <[email-masked]>
Date: Tue, 28 May 2002 10:39:57 -0700

Hello,

Can we stop making changes to the iscsi pdu formats ? We are never going
to make it to RFC and ship some iscsi products, if we continue to keep
requesting cosmetic changes to the spec. We should freeze the spec now
and stop making changes, unless the change fixes something that is
broken.

Thanks,
Santosh

-- 
The world is so fast that there are days when the person who says 
it can't be done is interrupted by the person who is doing it.
	~ Anon