Subject: iSCSI: SCSI Asynchronous Event clarification, reference to [SPC3] and [SAM]

From: "Dave Peterson" <[email-masked]>
Date: Thu, 30 May 2002 14:34:29 -0500

Howdy All,

Clause 9.9.1 in Rev 12-95 currently states:

"The sending of a SCSI Event (Asynchronous Event Notification in SCSI
terminology)
is controlled by a SCSI Control Mode Page bit."

The notion of "Asynchronous Event Notification" is now obsolete in SAM-2
(and SPC-3).
Instead, it is coined asynchronous event reporting (AER).
And the sending of a SCSI async event is actually enabled by three bits in
the SCSI Control mode page:

RAERP - ready AER permission
UAAERP - unit attention AER permission
EAERP - error AER permission

So I think the sentence should be reworded to something like:

"If the target supports SCSI asynchronous event reporting (see SAM-2) as
indicated in the standard INQUIRY data (see SPC-3), its use may be enabled
by parameters in the SCSI Control mode page (see SPC-3)."

Also, the reference [SPC3] is not quite correct and may be misleading.

[SPC3]T10/1416-D, SCSI-3 Primary Commands (SPC).

s/b

[SPC3]T10/1416-D, SCSI Primary Commands - 3 (SPC-3).

Lastly, all references to [SAM] should be replaced with [SAM2].

...dap

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 31 May 2002 14:54:47 +0300

thanks - Julo

"Dave Peterson" <[email-masked]>
Sent by: [email-masked]
05/30/2002 10:34 PM
Please respond to "Dave Peterson"

        To:     "Ips@Ece. Cmu. Edu" <[email-masked]>
        cc: 
        Subject:        iSCSI: SCSI Asynchronous Event clarification, reference to [SPC3] and 
[SAM]

Howdy All,

s/b

...dap