Subject: Re: iSCSI: Request to change Logout Request

From: "Julian Satran" <[email-masked]>
Date: Sun, 5 May 2002 22:52:10 +0300

I have looked into it and unfortunately we can't keep everything everywhere
in place.

CID is bytes 20-21 in Login and Logout (so that the TTT place can't be kept
everywhere).

We could move the reason (function) in byte 1 (as it is in most requests).

If nobody shouts loudly against this we might do move reason (function)
into byte 1

Julo
----- Forwarded by Julian Satran/Haifa/IBM on 05/05/2002 10:46 PM -----
                                                                                                                                                  
                      Julian Satran                                                                                                               
                                               To:      Jarda Beran <[email-masked]>                                                  
                      05/02/2002 03:45         cc:      [email-masked]                                                                           
                      PM                       From:    Julian Satran/Haifa/IBM@IBMIL                                                             
                                               Subject: Re: iSCSI: Request to change Logout Request(Document link: Julian Satran - Mail)          

                                                                                                                                                  

I will look into it - Julo

                      Jarda Beran                                                                                                                  
                      <jaroslav.beran@s        To:       Julian Satran/Haifa/IBM@IBMIL                                                             
                      3group.com>              cc:       [email-masked]                                                                           
                                               Subject:  iSCSI: Request to change Logout Request                                                   
                      05/02/2002 11:21                                                                                                             
                      AM                                                                                                                           
                      Please respond to                                                                                                            
                      Jarda Beran                                                                                                                  

Hello Julian,

Can I make a request to change the position of the field "Reason code"
in
the Logout Request from offset 23 to 3.
This change would make the PDU consistent with others and make decoding
simpler as most PDUs have fields "Reason" or "Response" at offset 3.

As you know offsets 20-23 are usually used for "Target Transfer Tag",
except
"Expected Data Transfer Length" in the SCSI command (it have no reserved
fields) and "CID" for Login/Logout requests. I think that "CID" could be
placed e.g. at offset 40 as an "additional" parameter.

Regards,

    Jarda

-------
Jarda Beran
Software Engineer
Silicon & Software Systems
Safrankova 1
155 00  Praha 5
Czech Republic

---

From: Paul Koning <[email-masked]>
Date: Mon, 6 May 2002 09:44:13 -0400

> If nobody shouts loudly against this we might do move reason (function)

I don't like that at all.  "Function" is not anything like "Reason".

"Last call" is the time to fix BUGS in the spec.  This isn't a bug.
Let's stop changing things for the sake of esthetics, or other similar
non-bug reasons.

      paul