Subject: RE: iSCSI:Can each do there own thing?

From: [email-masked]
Date: Thu, 30 May 2002 12:00:28 -0600

On Wed, 29 May 2002, Martins Krikis wrote:

[very large snip]

> Summary:
>
> 1. "no-originating on split-key scheme"
> 2. "no-originating (except declarations) on split-key scheme"
> 3. "no-originating on split-pair scheme"
> 4. "no-originating (except declarations) on split-pair scheme"
> 5. "empty-PDUs until end-of-data scheme"
> 6. "empty-PDU on split-pair scheme"
  7. "no-originating until end-of-data scheme"

(I added 7)
My preference is for 5 or 7. 

I think having to check for a split key or pair before making 
the decision on what to send is undesireable.

However, I would also like to point out that 5 is almost
equivalent to allowing an unlimited PDU size (or a PDU size up to
the buffer size at the end of 4.1) during negotiation. The only
difference is that the receiver can pace the arrival of the 
data by sending blank PDUs with 5 but it is not clear to me 
that that makes much implementation difference when one must be
able to buffer the whole negotiation.

Regards,
Pat

---

From: Bill Studenmund <[email-masked]>
Date: Thu, 30 May 2002 11:58:59 -0700 (PDT)

> the decision on what to send is undesireable.

Agreed.

> able to buffer the whole negotiation.

I agree that with 5 you do have to be able to buffer the whole negotiation
payload. But that size only has to be 16k if you don't do the long-key
cryptographic techniques, and 64k if you do.

If an extended negotiation payload weighs in at over 64k, I think it's
fair to indicate an error (if you're the target) and close the connection.

If you aren't doing long-key crypto negotiation (kerberos and SPKM AFAIK),
it would be fine to stop after 16k.

Thoughts?

Take care,

Bill