Subject: Re: iSCSI 4.1 & 4.2

From: "Julian Satran" <[email-masked]>
Date: Wed, 1 May 2002 23:50:24 +0300

Mark,

I thought that this will be handled within NDT and I will see the 
end-result.
I can't make the reference before looking at the list of characters for 
conflicts and scan dead-ends.

Julo

Mark Bakke <[email-masked]>
Sent by: [email-masked]
05/01/2002 10:59 PM
Please respond to Mark Bakke

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        Re: iSCSI 4.1 & 4.2

Julian-

The specification is at

http://search.ietf.org/internet-drafts/draft-ietf-ips-iscsi-string-prep-00.txt

It would be better to reference the specification rather than attempt
to add the individual characters to iSCSI; the point
of the separate specification is to leverage the same work that
the IDN folks are doing.

--
Mark

Julian Satran wrote:
> 
> Please send me a list of the characters to add or a specification for 
them. Julo
> 
>   Mark Bakke <[email-masked]>
>   Sent by: [email-masked]                   To:        Julian 
Satran/Haifa/IBM@IBMIL
>                                               cc:        [email-masked]
>   05/01/2002 09:40 PM                         Subject:        Re: iSCSI 
4.1 & 4.2
>   Please respond to Mark Bakke
> 
> 
> Julian-
> 
> Sorry, I've been unavailable the last few days.  What do you mean
> about the note not being concrete?  The string-prep draft says
> exactly which additional characters we need for the name-value
> (all of the international lower-case equivalent characters
> are valid), and the utf8-value specifies that any UTF-8
> character is legal (other than \0).
> 
> Without adding these, we would have to ditch internationalization
> completely within iSCSI names, but since the DNS folks are going
> through the pain of internationalizing host and domain names, we
> should keep internationalization in iSCSI as well.
> 
> --
> Mark
> 
> Julian Satran wrote:
> >
> > Mark,
> >
> > John Hufferd has solicited twice input from NDT about their additional 
requirement.
> > I did not hear back from you.
> > The attached note does not say anything concrete (are some characters 
that you need missing?)
> > either.
> >
> > Julo
> >
> >   Mark Bakke <[email-masked]>
> >   Sent by: [email-masked]                   To:        Julian 
Satran/Haifa/IBM@IBMIL
> >                                               cc: [email-masked]
> >   05/01/2002 08:52 PM                         Subject:        Re: 
iSCSI 4.1 & 4.2
> >   Please respond to Mark Bakke
> >
> >
> > Julian-
> >
> > Text-value is also used for initiator names, target names,
> > and aliases, which are UTF-8 encoded, so they don't fit into
> > the current text-value definition.   Here are two more
> > text value types we should add.
> >
> > --
> > Mark
> >
> > Julian Satran wrote:
> > >
> > > text-value: a string defined by the regular expression
> > > "[][a-zA-Z0-9.-+@_/\[\]=]*"
> >
> > Used by InitiatorName and TargetName:
> >
> > name-value: a UTF-8 string, with its valid character set
> > defined in draft-ietf-ips-iscsi-string-prep-00.
> >
> > Used by InitiatorAlias and TargetAlias:
> >
> > utf8-value: any UTF-8 string, terminated by a null character,
> > Ranges and comma-separated lists are not allowed for keys
> > that use this type.
> >
> > --
> > Mark
> 
> --
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Wed, 01 May 2002 15:35:29 -0500

Julian-

We originally were going to just deal with this in the NDT
spec, but since the NDT spec (and the referenced stringprep
spec) affects the character set that is being defined in 4.1
and 4.2, it will be hard to avoid referencing it from 4.1 and
4.2 as well.

--
Mark

Julian Satran wrote:
> 
> Mark,
> 
> I thought that this will be handled within NDT and I will see the end-result.
> I can't make the reference before looking at the list of characters for conflicts and scan
> dead-ends.
> 
> Julo
> 
>   Sent by: [email-masked]                   To:        Julian Satran/Haifa/IBM@IBMIL
>                                               cc:        [email-masked]
>   05/01/2002 10:59 PM                         Subject:        Re: iSCSI 4.1 & 4.2
> > Please send me a list of the characters to add or a specification for them. Julo
> >
> >   Sent by: [email-masked]                   To:        Julian Satran/Haifa/IBM@IBMIL
> >                                               cc:        [email-masked]
> >   05/01/2002 09:40 PM                         Subject:        Re: iSCSI 4.1 & 4.2
> > > John Hufferd has solicited twice input from NDT about their additional requirement.
> > > The attached note does not say anything concrete (are some characters that you need missing?)
> > > either.
> > >
> > > Julo
> > >
> > >   Sent by: [email-masked]                   To:        Julian Satran/Haifa/IBM@IBMIL
> > >                                               cc:        [email-masked]
> > >   05/01/2002 08:52 PM                         Subject:        Re: iSCSI 4.1 & 4.2

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054