Subject: Re: iSCSI: NOP-In

From: "Julian Satran" <[email-masked]>
Date: Thu, 9 May 2002 17:25:53 +0300

OK - thanks - Julo

"Robert D. Russell" <[email-masked]>
05/09/2002 04:44 PM
Please respond to "Robert D. Russell"

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked], <[email-masked]>
        Subject:        iSCSI: NOP-In

Julian:

A request for two small changes in wording in draft 12:

1) The last paragraph of section 9.19 says:

  "When a target sends a NOP-In as a "ping" (the Initiator
  Task Tag is 0xffffffff) it MUST NOT send any data in the
  data segment (DataSegmentLength MUST be 0)."

I believe this should be restated to read simply:

  "When a target sends a NOP-In with an Initiator Task Tag
  value of 0xffffffff, it MUST NOT send any data in the data
  segment (DataSegmentLength MUST be 0)."

The reason for this change is that the Initiator Task Tag can
also be 0xffffffff when the target sends a NOP-In "as a means
to carry a changed ExpCmdSN and/or MaxCmdSN".  This is not a
"ping", but I believe there should not be any data in the data
segment for this case either.

2) For the same reason, I believe the last paragraph of section
9.19.1, which now reads:

  "Whenever the NOP-In is sent as a "ping" to an initiator (not as
  a response to a NOP-Out), the StatSN field will contain the next
  StatSN.  However, StatSN for this connection is not advanced."

should be changed to read:

  "The NOP-In always contains a valid StatSN field.  However,
  when the NOP-In is sent with an Initiator Task Tag value of
  0xffffffff, the StatSN field is not advanced."

If this change is not made, it is unclear whether or not to advance
the StatSN field when the target sends a NOP-In "as a means
to carry a changed ExpCmdSN and/or MaxCmdSN".  I believe this case
should be treated the same as when the target sends a NOP-In as a
"ping".

Thanks,

Bob Russell
InterOperability Lab
University of New Hampshire
[email-masked]
603-862-3774

---

From: "John Hufferd" <[email-masked]>
Date: Thu, 9 May 2002 14:53:49 -0700

You may be correct, but I think we need to use the Ping word, so that it
becomes obvious, as it does now, that Ping from Initiator can have data but
ping from Target can not.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

---

From: "Julian Satran" <[email-masked]>
Date: Sun, 12 May 2002 14:58:38 +0300

John.

Ping from target is prohibited from having data only if  TTT is 
0xfffffffff i.e., when no reply request is requested.

Julo

John Hufferd@IBMUS
05/10/2002 12:53 AM

        To:     "Robert D. Russell" <[email-masked]>
        cc:     Julian Satran/Haifa/IBM@IBMIL, [email-masked], <[email-masked]>
        From:   John Hufferd/San Jose/IBM@IBMUS
        Subject:        Re: iSCSI: NOP-In

You may be correct, but I think we need to use the Ping word, so that it 
becomes obvious, as it does now, that Ping from Initiator can have data 
but ping from Target can not.

.
.
.
John L. Hufferd

---

From: "John Hufferd" <[email-masked]>
Date: Sun, 12 May 2002 12:10:02 -0700

Julian,
you are of course correct.  My implied (though perhaps not so well written)
point was that a ping INITIATED by the target, is also possible, but can
not have data.  And that the removal of the word "ping" would perhaps
prevent that concept from being obvious.

.
.
.
John L. Hufferd

Julian Satran@IBMIL
05/12/2002 04:47 AM

To:    John Hufferd/San Jose/IBM@IBMUS@IBMDE
cc:    [email-masked], [email-masked], "Robert D. Russell"
       <[email-masked]>
From:  Julian Satran/Haifa/IBM@IBMIL
Subject:    Re: iSCSI: NOP-In  (Document link: John Hufferd)

John.

Ping from target is prohibited from having data only if  TTT is 0xfffffffff
i.e., when no reply request is requested.

Julo

                      John                                                                                                    
                      Hufferd@IBMUS            To:      "Robert D. Russell" <[email-masked]>                              
                                               cc:      Julian Satran/Haifa/IBM@IBMIL, [email-masked],                       
                      05/10/2002 12:53         <[email-masked]>                                                        
                      AM                       From:    John Hufferd/San Jose/IBM@IBMUS                                       
                                               Subject: Re: iSCSI: NOP-In(Document link: Julian Satran - Mail)                

                                                                                                                              

.
.
.
John L. Hufferd

---

From: Eddy Quicksall <[email-masked]>
Date: Sun, 12 May 2002 20:28:10 -0400

BTW, What is the reason for a Target Ping not to carry any data?

Eddy

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Sunday, May 12, 2002 3:10 PM
To: Julian Satran
Cc: ips; owner-ips; ""Robert D. Russell" <rdr"
Subject: Re: iSCSI: NOP-In

Julian,

.
.
.
John L. Hufferd

Julian Satran@IBMIL
05/12/2002 04:47 AM

John.

Julo

                      John

                      Hufferd@IBMUS            To:      "Robert D. Russell"
<[email-masked]>                              
                                               cc:      Julian
Satran/Haifa/IBM@IBMIL, [email-masked],                       
                      05/10/2002 12:53         <[email-masked]>

                      AM                       From:    John Hufferd/San
Jose/IBM@IBMUS                                       
                                               Subject: Re: iSCSI:
NOP-In(Document link: Julian Satran - Mail)                

 

.
.
.
John L. Hufferd

---

From: "Julian Satran" <[email-masked]>
Date: Mon, 13 May 2002 08:56:23 +0300

The implied use for data is to echo it. Julo

Eddy Quicksall <[email-masked]>
05/13/2002 03:28 AM
Please respond to Eddy Quicksall

        To:     John Hufferd/San Jose/IBM@IBMUS, Julian Satran/Haifa/IBM@IBMIL
        cc:     ips <[email-masked]>, owner-ips <[email-masked]>, "\"\"Robert D. 
Russell\" <rdr\""
        Subject:        RE: iSCSI: NOP-In

Eddy

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Sunday, May 12, 2002 3:10 PM
To: Julian Satran
Cc: ips; owner-ips; ""Robert D. Russell" <rdr"
Subject: Re: iSCSI: NOP-In

Julian,
you are of course correct.  My implied (though perhaps not so well 
written)
point was that a ping INITIATED by the target, is also possible, but can
not have data.  And that the removal of the word "ping" would perhaps
prevent that concept from being obvious.

.
.
.
John L. Hufferd

Julian Satran@IBMIL
05/12/2002 04:47 AM

John.

0xfffffffff

Julo

                      John

                      Hufferd@IBMUS            To:      "Robert D. 
Russell"
<[email-masked]> 
                                               cc:      Julian
Satran/Haifa/IBM@IBMIL, [email-masked], 
                      05/10/2002 12:53         <[email-masked]>

 

 

but

.
.
.
John L. Hufferd

---

From: "John Hufferd" <[email-masked]>
Date: Mon, 13 May 2002 09:15:26 -0700

Eddy, et.al.
Initiators can not originate a ping with data.  But it can echo a ping with
data.  That is, it can reflect back to the initiator, via a NOP-In, the
data that was sent to it within a NOP-Out from the initiator.  However, the
target may not originate a ping via a NOP-In and include Data.

This was done, if I remember the history correctly, because initiators are
never prepared to accept unsolicited data of any kind.  They always solicit
data if they are to receive it.  Hence, an unsolicited NOP-In with data,
seemed to some to be problematical, and that capability was removed.

.
.
.
John L. Hufferd

Eddy Quicksall <[email-masked]> on 05/13/2002 05:21:11 AM

To:    Julian Satran/Haifa/IBM@IBMIL
cc:    ips <[email-masked]>, John Hufferd/San Jose/IBM@IBMUS
Subject:    RE: iSCSI: NOP-In

Maybe I misunderstood John's statement. John, aren't you saying that the
target is not allowed to send ping data at all (i.e., that is MUST always
use  0xFFFFFFFF in the TTT)?

My implied (though perhaps not so well written)
point was that a ping  INITIATED by the target

Eddy

-----Original Message-----
From: Julian Satran  [mailto:[email-masked]]
Sent: Monday, May 13, 2002 1:56  AM
To: Eddy Quicksall
Cc: ips; John Hufferd;  owner-ips
Subject: RE: iSCSI: NOP-In

                                                                          
     Eddy Quicksall                                                       
     <[email-masked]                To:         John Hufferd/San       
     >                         Jose/IBM@IBMUS, Julian                     
                               Satran/Haifa/IBM@IBMIL                     
     05/13/2002 03:28                   cc:        ips                    
     AM                        <[email-masked]>, owner-ips               
     Please respond to         <[email-masked]>,  "\"\"Robert D.   
     Eddy Quicksall            Russell\" <rdr\""                          
                                       Subject:         RE: iSCSI: NOP-In 

Eddy

-----Original Message-----
From: John  Hufferd [mailto:[email-masked]]
Sent: Sunday, May 12, 2002 3:10  PM
To: Julian Satran
Cc: ips; owner-ips; ""Robert D. Russell"  <rdr"
Subject: Re: iSCSI: NOP-In

Julian,

.
.
.
John L.  Hufferd

Julian Satran@IBMIL
05/12/2002 04:47  AM

John.

Julo

                       John

.
.
.
John L. Hufferd

---

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Mon, 13 May 2002 11:43:05 -0600

See inline below. Pat

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Monday, May 13, 2002 9:15 AM
To: Eddy Quicksall
Cc: ips
Subject: RE: iSCSI: NOP-In

Eddy, et.al.
^^^^^^^^^^
Targets ??

.
.
.
John L. Hufferd

---

From: Eddy Quicksall <[email-masked]>
Date: Mon, 13 May 2002 13:02:30 -0400

Thanks,

That makes sense. BTW, I don't know if I am reflecting because our server is
using eddyq instead of Eddy_Quicksall. I'm having them fix that.

Eddy

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Monday, May 13, 2002 12:15 PM
To: Eddy Quicksall
Cc: ips
Subject: RE: iSCSI: NOP-In

Eddy, et.al.

.
.
.
John L. Hufferd

Eddy

-----Original Message-----
From: Julian Satran  [mailto:[email-masked]]
Sent: Monday, May 13, 2002 1:56  AM
To: Eddy Quicksall
Cc: ips; John Hufferd;  owner-ips
Subject: RE: iSCSI: NOP-In

                                                                          
     Eddy Quicksall                                                       
                               Satran/Haifa/IBM@IBMIL                     
     05/13/2002 03:28                   cc:        ips                    

Eddy

-----Original Message-----
From: John  Hufferd [mailto:[email-masked]]
Sent: Sunday, May 12, 2002 3:10  PM
To: Julian Satran
Cc: ips; owner-ips; ""Robert D. Russell"  <rdr"
Subject: Re: iSCSI: NOP-In

Julian,

.
.
.
John L.  Hufferd

Julian Satran@IBMIL
05/12/2002 04:47  AM

John.

Julo

                       John

.
.
.
John L. Hufferd

---

From: "John Hufferd" <[email-masked]>
Date: Mon, 13 May 2002 10:09:08 -0700

I do not think you are reflecting since I am only getting one copy of your
notes.

.
.
.
John L. Hufferd

Eddy Quicksall <[email-masked]> on 05/13/2002 10:02:30 AM

To:    John Hufferd/San Jose/IBM@IBMUS
cc:    ips <[email-masked]>, [email-masked]
Subject:    RE: iSCSI: NOP-In

Thanks,

That makes sense. BTW, I don't know if I am reflecting because our server
is
using eddyq instead of Eddy_Quicksall. I'm having them fix that.

Eddy

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Monday, May 13, 2002 12:15 PM
To: Eddy Quicksall
Cc: ips
Subject: RE: iSCSI: NOP-In

Eddy, et.al.

.
.
.
John L. Hufferd

Eddy

-----Original Message-----
From: Julian Satran  [mailto:[email-masked]]
Sent: Monday, May 13, 2002 1:56  AM
To: Eddy Quicksall
Cc: ips; John Hufferd;  owner-ips
Subject: RE: iSCSI: NOP-In

     Eddy Quicksall
                               Satran/Haifa/IBM@IBMIL
     05/13/2002 03:28                   cc:        ips

Eddy

-----Original Message-----
From: John  Hufferd [mailto:[email-masked]]
Sent: Sunday, May 12, 2002 3:10  PM
To: Julian Satran
Cc: ips; owner-ips; ""Robert D. Russell"  <rdr"
Subject: Re: iSCSI: NOP-In

Julian,

.
.
.
John L.  Hufferd

Julian Satran@IBMIL
05/12/2002 04:47  AM

John.

Julo

                       John

.
.
.
John L. Hufferd

---

From: "John Hufferd" <[email-masked]>
Date: Mon, 13 May 2002 11:25:19 -0700

Yes, target.

.
.
.
John L. Hufferd

"THALER,PAT (A-Roseville,ex1)" <[email-masked]> on 05/13/2002
10:43:05 AM

To:    John Hufferd/San Jose/IBM@IBMUS, Eddy Quicksall <[email-masked]>
cc:    ips <[email-masked]>
Subject:    RE: iSCSI: NOP-In

See inline below. Pat

-----Original Message-----
From: John Hufferd [mailto:[email-masked]]
Sent: Monday, May 13, 2002 9:15 AM
To: Eddy Quicksall
Cc: ips
Subject: RE: iSCSI: NOP-In

Eddy, et.al.

.
.
.
John L. Hufferd