Subject: RE: iSCSI: Negotiation clarifications still needed

From: "Julian Satran" <[email-masked]>
Date: Thu, 30 May 2002 06:52:51 +0300

Login is coming - I just wanted to get the list off this topic and look at 
Security! - Julo

Bill Studenmund <[email-masked]>
Sent by: [email-masked]
05/30/2002 01:59 AM
Please respond to Bill Studenmund

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     <[email-masked]>, Martins Krikis <[email-masked]>, 
<[email-masked]>, <[email-masked]>
        Subject:        RE: iSCSI: Negotiation clarifications still needed

On Thu, 30 May 2002, Julian Satran wrote:

> it is already there - thank you. Julo

Thank you. I had not seen 12-95 was available.

The use of the 'C' bit in Text Request and Response cleanly implememnts
what Martins was suggesting.

However I did not see where we state that login negotiations use a
comparable mechanism. Actually, it looks like the text indicating login
negotiations can span PDUs was removed. Was that the desired effect?

> On Wed, 29 May 2002, Julian Satran wrote:
>
> > Martins & Pat,
> >
> > In going over the list of the arguments for the ongoing negotiation
> (that
> > we have now) versus. "stop-until-you-have-full-buffer" I think that I 
am
> > more inclined now to accept that Martins's point about absolute
> simplicity
> > is valid and we should accept it (i.e., stop untill you have a full
> > buffer.
> > AFAIK it  will not break any existing implementation as all/most of 
them
> > are rudimentary and they are not in silicon (I hope).
>
> If there is intereste, I'm willing to help write suggested algorithms to
> implement this, a la appendix E.
>
> Take care,
>
> Bill
>
>
>
>

---

From: Bill Studenmund <[email-masked]>
Date: Thu, 30 May 2002 09:01:50 -0700 (PDT)

> Login is coming - I just wanted to get the list off this topic and look at

Thank you! Sounds good, and I eagerly await your results. :-)

Take care,

Bill