Subject: Re: iSCSI - re-phrase of 4.1

From: "Julian Satran" <[email-masked]>
Date: Fri, 3 May 2002 20:15:13 +0300

The issue of leading 0s was brought up in the context of decimal numbers.
In the context of hex or base 64 encoding for binaries (not numbers) the 
leading 0 has value - it implies length -
0x0015 is different from 0x15.

Julo

Luben Tuikov <[email-masked]>
Sent by: [email-masked]
05/03/2002 05:18 PM
Please respond to iSCSI; Please respond to Luben Tuikov

        To:     "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
        cc:     Julian Satran/Haifa/IBM@IBMIL, [email-masked]
        Subject:        Re: iSCSI - re-phrase of 4.1

> "THALER,PAT (A-Roseville,ex1)" wrote:
> 
> hex-constant: unsigned hexadecimal constant described by regu-lar 
expression "0[xX][0-9a-zA-Z]+"
> Hexidecimal only uses the alphabet up to F so the regular expression 
should be:
> "0[xX][0-9a-fA-F]+"

Wasn't there some consenus that there will be no extra leading 0, unless
part of the base identifier (and thus at most one)? Else I can
put 1e9 zeros like this: 0x0000...03 to be a valid hex const.

Also why do we need to _restrict_ as to the sign of
a hex constant. I'm sure that sooner or later it will
have its applications. If a value cannot be negative
and a node sent it as negative then the peer will
reply with Reject or appropriately.

Isn't all this the whole point of interoperability and
the use of Reject, et al?

Thus,
hex const: 0[xX][1-9A-Fa-f]+[0-9A-Fa-f]*

And similarly for the others.

-- 
Luben

---

From: Mark Bakke <[email-masked]>
Date: Fri, 03 May 2002 12:23:13 -0500

Julian-

That works great!

Thanks,

Mark

Julian Satran wrote:
> In the context of hex or base 64 encoding for binaries (not numbers) the leading 0 has value - it
> implies length -
>   Sent by: [email-masked]                     To:        "THALER,PAT (A-Roseville,ex1)"
>                                              <[email-masked]>
>   05/03/2002 05:18 PM                                cc:        Julian Satran/Haifa/IBM@IBMIL,
>   Please respond to iSCSI; Please respond to [email-masked]
>   Luben Tuikov                                       Subject:        Re: iSCSI - re-phrase of 4.1
> 
> 
> 
> > hex-constant: unsigned hexadecimal constant described by regu-lar expression "0[xX][0-9a-zA-Z]+"
> > Hexidecimal only uses the alphabet up to F so the regular expression should be:
> > "0[xX][0-9a-fA-F]+"
> 

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054