Subject: RE: iSCSI - re-phrase of 4.1

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Fri, 3 May 2002 11:56:38 -0600

Randy,

I'm not young and I have never seen a signed hex constant either. I don't
see any need to use signed hex constants. I also agree with Julian on
leading zeros for hex (and base 64). They should be allowed.

Pat

-----Original Message-----
From: Randy Jennings [mailto:[email-masked]]
Sent: Thursday, May 02, 2002 7:58 PM
To: iSCSI; Luben Tuikov
Subject: RE: iSCSI - re-phrase of 4.1

Comments in text

> Also why do we need to _restrict_ as to the sign of
> a hex constant. I'm sure that sooner or later it will
> have its applications. If a value cannot be negative
> and a node sent it as negative then the peer will
> reply with Reject or appropriately.
Granted, I am a young engineer, but I have never seen a signed hex constant.
I've always seen decimal when signed.  In my (vast :-> ) experience, hex is
always used to represent straight bits.  Period.  You have enough zeros for
place holders for the bits and that is all you ever have.  If it happens to
translate into a numeric value, that is ducky, but not necessary.

> Thus,
> hex const: 0[xX][1-9A-Fa-f]+[0-9A-Fa-f]*
In any case, with this regex, 0x0 is no longer valid.  If you persist in not
wanting leading zeros, try:
hex const: 0[xX](([1-9A-Fa-f][0-9A-Fa-f]*)|0)
                 ^                       ^
I do not know if these are needed, but they should not hurt

I also removed the + because the * after the second term takes care of it.

Sincerely,
Randy
Data Transit

---

From: Luben Tuikov <[email-masked]>
Date: Sat, 04 May 2002 14:51:31 -0400

> leading zeros for hex (and base 64). They should be allowed.

I got it; for some reason I was still thinking
about integers (Z), rather than bits (string of {0,1}).

You could've just mentioned that: bits, not
integers...

Nevertheless, ``signed hex constants'' do exist,
as do floating point hex representations, granted in
a different context.

-- 
Luben