Subject: RE: Connection Recovery in case of a single connection in a sessi on

From: [email-masked]
Date: Fri, 10 May 2002 14:46:00 -0400

This recovery requires the ability to support more than one
connection in a session.  Once the first connection is logged
out, its tasks are gone.  An implementation that does not
support multi-connection sessions cannot do this sort of
recovery.

Thanks,
--David

> -----Original Message-----
> From: Monisha Barooah [mailto:[email-masked]]
> Sent: Friday, May 10, 2002 5:46 AM
> To: [email-masked]
> Subject: Connection Recovery in case of a single connection 
> in a session
> 
> 
> 
>  Hi All,
>   I wanted to know how to perform Connection Recovery for a 
> connection when it is the only connection of a session. 
> 
>  Connection Recovery invloves the logout of the failed 
> connection and the reassignment of the tasks of the failed 
> connection to a full feature phased connection.
> 
> In case there is only one connection in a session. How do we 
> do the Connection Recovery? Shall we open up another 
> connection to do implicit logout? But in this case the CID of 
> the new connection will be the same as that of the failed 
> connection and the task reassignment will not come into 
> picture at all.
> 
> Regards,
> Monisha.
>

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 10 May 2002 13:08:33 -0700

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Friday, May 10, 2002 11:46 AM
Subject: RE: Connection Recovery in case of a single connection in a session

> support multi-connection sessions cannot do this sort of

Not quite accurate.  A single-connection session could do 
task reassignment.  A connection reinstatement (same CID)
login (when operational ErrorRecoveryLevel=2) would be 
an implicit recovery Logout.  The initiator has the option
either to reassign the tasks, or simply let the tasks timeout
(or even abort the non-allegiant tasks).

New wording regarding the mapping of session/connection
reinstatements to Logout reason codes was posted to this 
list two weeks ago (by me), and will appear in rev13.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668 
Roseville CA 95747
[email-masked]

---

From: Parthi <[email-masked]>
Date: Wed, 15 May 2002 11:09:53 +0530

Target should support opening a second connection even though they do
not support multiple connections in full feature phase. The purpose of
second connection is to reassign the tasks.

Parthi

--
Parthiban M,
HCL Technologies Ltd.,          Tel : (+91)-44-3741939 to 42, Extn. 2332
http://san.hcltech.com