Subject: iSCSI: list negotiation description

From: Martins Krikis <[email-masked]>
Date: Wed, 22 May 2002 14:37:24 -0700 (PDT)

First a question again:

What is the point of allowing "inadmissible
values" (or in case of lists, lack of acceptable
values) be answered with an "admissible value"?

Now the problems.

Page 69, bottom paragraph:

  If a responder does support, understand or
  is allowed to use none of the offered options
  with a specific originator, it MAY use the
  constant "Reject" or it MAY respond with an
  admissible value. The selection of a value
  not offered is considered a negotiation
  failure and is handled as a protocol error.

http://www.pdl.cmu.edu/mailinglists/ips/mail/msg10066.html
made me believe that the phrase "or it MAY respond
with an admissible value..." will be removed.

Since it hasn't been, I'll point out again that
it contradicts the very next sentence, because
this "admissible value" would be a "value not
offered".
Also, I must say that I almost regret having
started picking on the beginning of this paragraph,
because IMHO it has gotten worse. I'm still
proposing this:

  If each of the offered values is not understood
  or not supported, or the responder is not allowed
  to use it with the specific originator, it MUST
  use the constant "Reject".

Note that because other reasonable alternatives
are eliminated, the original "MAY" can change to
"MUST". (Which should be a good thing, BTW.)

Thanks,

  Martins Krikis, Intel Corp.

Disclaimer: these opinions are my own and may not
            not be those of my employer

__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 23 May 2002 22:40:28 +0300

In fact - depending on what it rejects - it may also decide to terminate 
the connection (e.g., a security negotiation with unacceptable 
parameters).
It is probably better to make this explicit as in:

If a responder does not understand any particular value in a list it MUST 
ignore it. If a responder does support, understand or is allowed to use 
none of the offered options with a specific originator, it may use the 
constant "Reject" or terminate the negotiation.

Julo

Martins Krikis <[email-masked]>
Sent by: [email-masked]
05/23/2002 09:26 PM
Please respond to Martins Krikis

        To:     [email-masked]
        cc: 
        Subject:        Re: iSCSI: list negotiation description

I looked at 12-90. I hadn't seen the announcements
for newer drafts. My fault. So 12-92 does not have
the text I was referring to anymore, which is good,
thanks. However, since it still says "MAY use the
constant Reject", can we know what other options
there are? I.e., why "MAY" and not "MUST"?
(This is now page 73 of 12-92.)

--- Julian Satran <[email-masked]> wrote:
> What version did you look at?  Considering the date
> of your mail it must 
> have been 12-91 only that 12-91 does not contain the
> text you quote - Julo
> 
> 
> 
> 
> Martins Krikis <[email-masked]>
> Sent by: [email-masked]
> 05/23/2002 12:37 AM
> Please respond to Martins Krikis
> 
> 
>         To:     [email-masked]
>         cc: 
>         Subject:        iSCSI: list negotiation
> description
> 
> 
> 
> First a question again:
>