Subject: RE: iSCSI base64 and 12-92

From: "ERICKSON,SHAWN (HP-Roseville,ex1)" <[email-masked]>
Date: Fri, 24 May 2002 15:01:39 -0400

I agree with Paul & Bill. I don't see the need for base64 encoding of
numbers or for iSCSI caring/knowing about big numbers, treat them as binary
and let the end consumers of the information handle any needed translation.

-Shawn

> -----Original Message-----
> From: Bill Studenmund [mailto:[email-masked]]
> Sent: Friday, May 24, 2002 10:19 AM
> To: Julian Satran
> Cc: Paul Koning; [email-masked]
> Subject: Re: iSCSI base64 and 12-92
> 
> 
> On Thu, 23 May 2002, Julian Satran wrote:
> 
> > If base 64 is neede for large integers there is no good 
> reason to test
> > that it is not used for short integers.
> 
> Julo,
> 
> You still haven't explained why we need base64 for large numbers. What
> security negotiation schemes are we using that need to exchange large
> numbers as numbers; where the scheme expects the number in 
> host byte order
> as opposed to a specific on-wire format.
> 
> More specifically you have not explained why the iSCSI parameter
> negotiation system needs to be able to deal with large base64 numbers.
> 
> If we actually have any protocol which strangely wants large 
> numbers in
> local byte order, why not have the keys in question defined 
> as exchanging
> a binary string which is the number in network byte order?
> 
> The advantage of the above is that we then can drop base64 as a number
> encoding scheme. The key negotiation system(s) need only deal 
> with base64
> binary strings, things base64 is good (no, great) for. And we 
> can support
> any cryptographic scheme we choose to in the future; the only 
> thing we're
> loosing is pain.
> 
> So what is wrong with the above?
> 
> I mean do we really want to have to support "MaxConnections=0b0Q=="?
> 
> Take care,
> 
> Bill
>

---

From: [email-masked]
Date: Fri, 24 May 2002 20:44:37 -0400

In the hope of putting an end to this thread, I believe I
see rough consensus for the position that Paul Koning
succinctly states as:

> I would like to see Base64 permitted ONLY for those parameters that
> are long octetstrings.  Basically, that's only the crypto parameters.

And the succinct answer to the question of why it shouldn't be supported
for everything is that it confines the b64 support to the crypto-related
code in an implementation.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------