Subject: RE: MaxRecvPDULength question

From: [email-masked]
Date: Tue, 21 May 2002 15:38:24 -0600

I'm working on that but being authoritative on that subject turns out to require a fair amount of work combing the draft and has been impacted by some other tasks. I expect to put out something by the end of the day. Pat

-----Original Message-----
From: Luben Tuikov [mailto:[email-masked]]
Sent: Tuesday, May 21, 2002 2:34 PM
To: THALER,PAT (A-Roseville,ex1); iSCSI
Subject: Re: MaxRecvPDULength question

"THALER,PAT (A-Roseville,ex1)" wrote:
> 
> 
> BTW your email seemed to imply that MaxRecvPDULength is a power of two.

My computer says: 2^13 = 8192, which in turn is equal to the
default value of MaxRecvPDULength.

> Currently, MaxRecvPDULength is not limited to be a power of two.
> (I recall a discussion about that and I think the concensus was
> consistant with the current draft.)

True, but if it changes after login, I can deal with it.
I.e. I'd not allocate more memory if it shrinks,
and I'll increase it by PAGE_SIZE if it grows.

Anyway, this was just a suggestion, not so important.

I was more interested in getting an authoritative answer
on the ``Login Request Error'' thread's last message.

-- 
Luben

---

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Wed, 22 May 2002 13:34:14 -0600

Martins,

If we are going to rename it, the name should be accurate and clear. I don't think MaxRecvDataLength is clear because there are lots of data lengths involved in the draft. Also, some of the parameters use length and some use size.

MaxRecvDataSegmentSize or
MaxRecvPDUDataSize

would be clear, consistant with other names and accurate. I don't feel strongly about changing the name to improve it but removing the context for which data length is being negotiated would reduce accuracy/clarity of the name.

Regards,
Pat

-----Original Message-----
From: Martins Krikis [mailto:[email-masked]]
Sent: Wednesday, May 22, 2002 12:20 PM
To: [email-masked]
Subject: Re: MaxRecvPDULength question

--- Paul Koning <[email-masked]> wrote:

> Are you proposing to rename the key so its name is
> "MaxRecvDataLength"?  Yes, that would be more
> accurate, but why bother
> at this point?

Because it would be more accurate!

I personally don't mind changes in the draft that
make it clearer but require me to change one string
constant.

  Martins Krikis, Intel Corp.

__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 23 May 2002 06:29:18 +0300

That might be good as it is closer to what we mean anyhow and should not 
affect any existing implementation anyhow. 

Julo

Martins Krikis <[email-masked]>
Sent by: [email-masked]
05/22/2002 10:19 PM
Please respond to Martins Krikis

        To:     [email-masked]
        cc: