Subject: Re: [iSCSI:] Logout request -- reason? Correction

From: "Julian Satran" <[email-masked]>
Date: Mon, 27 May 2002 21:32:21 +0300

Reason  & Function codes are there for several request types. (e.g., task 
management).

I did announce my intent to move it there for uniformity  - a long time 
ago - when it was requested by a list member - and waited for comments.

Julo

BTW - you appear to be sending mail from ns.splentec.com and a reply there 
ends always with bounced mail.

Luben Tuikov <[email-masked]>
Sent by: [email-masked]
05/27/2002 04:48 PM
Please respond to Luben Tuikov

        To:     iSCSI <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL
        cc: 
        Subject:        [iSCSI:] Logout request -- reason? Correction

Let me correct this:

I was under the impression that byte 1 in BHS
is a flags byte -- i.e. bit values.
 
I now see that the reason code is moved exactly there,
in the Logout request PDU.
 
Could anyone please explain the logic behind this?

At the same time byte 2 and 3 are reserved to 0.

Why don't we:

1)  Move the reason code to byte 2. This will
    make it _consistent_ with the response byte
    in Logout Response.

2)  Make the value start at 0x80, as to hide
    the ugliness of F = 1, and the fact that
    we are trying to fit a numerical value (!)
    and a bit value (!) in the same octet.

Comments?

--
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Mon, 27 May 2002 16:45:49 -0400

Julian Satran wrote:
> 
> Reason  & Function codes are there for several request types. (e.g., task management).
> 
> I did announce my intent to move it there for uniformity  - a long time ago - when it was
> requested by a list member - and waited for comments.

You have my vote on moving the function numeric to
byte 2 (Logout Request & TMF Request).

As well as moving the Type numeric to byte 2 in
SNACK.

This will make things pretty consistent.

Everyone okay with this?

-- 
Luben

> BTW - you appear to be sending mail from ns.splentec.com and a reply there ends always with
> bounced mail.

Attached below is a copy of the SMTP header of the message
which arrived at the mailing list.

Yes, the last stop of our (Splentec) messages do go through
ns.splentec.com, but your MUA (Mail User Agent) SHOULD
go with its reply by either Reply To: or of not available
by From:. It SHOULD NOT reply to any of the
Received: headers' machines. Which RFC was this in?

emacs, netscape, yahoo.com, etc. have no problem replying to
my messages.

So I guess the problem is in Lotus Notes, NOT in sendmail.
Please contact your vendor.

--cut----