Subject: RE: [iSCSI:] Logout request -- reason? Correction

From: [email-masked]
Date: Tue, 28 May 2002 11:28:45 -0600

Luben,

I don't see where you got that impression. The BHS layout shows bytes 1 through 3 as opcode specific fields. The kinds of opcode specific fields will be different depending upon opcode.

Pat

-----Original Message-----
From: Luben Tuikov [mailto:[email-masked]]
Sent: Monday, May 27, 2002 6:49 AM
To: iSCSI; Julian Satran
Subject: [iSCSI:] Logout request -- reason? Correction

Let me correct this:

I was under the impression that byte 1 in BHS
is a flags byte -- i.e. bit values.
 
I now see that the reason code is moved exactly there,
in the Logout request PDU.
 
Could anyone please explain the logic behind this?

At the same time byte 2 and 3 are reserved to 0.

Why don't we:

1)  Move the reason code to byte 2. This will
    make it _consistent_ with the response byte
    in Logout Response.

2)  Make the value start at 0x80, as to hide
    the ugliness of F = 1, and the fact that
    we are trying to fit a numerical value (!)
    and a bit value (!) in the same octet.

Comments?

--
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Tue, 28 May 2002 14:24:24 -0400

[email-masked] wrote:
> 
> Luben,
> 
> I don't see where you got that impression. The BHS layout shows bytes 1 through
> 3 as opcode specific fields. The kinds of opcode specific fields will be different
> depending upon opcode.

Pat,

I KNOW about the BHS template.

If you had read my mail carefully you'd notice that
I mention that putting a bit value _and_ a numeric
value in the same octet is not a sound architectural idea.

Then you'd deduce that since the F bit is used in _that_
PDU, it'd be a good idea to leave the rest 7 bits
be bits (thus making one octet) and use the _next_ _whole_
_empty_ _reserved_ octet for the status/response code.

Certainly everyone else understood what I meant.

And the objection was _not_ your argument, but
the fact that we are running out of time.

-- 
Luben