Subject: iSCSI: Data-In PDU having MaxBurstSize restriction for a sequence

From: Sanjay Goyal <[email-masked]>
Date: Thu, 23 May 2002 17:01:10 -0400

Hi
 What is the rational behind having MaxBurstSize constraining a Sequence for
Data-In PDUs?
 As Initiator has to receive all the data from Target as Data-In PDUs
anyway, what good is it to set F-bit every MaxBurstSize? It rather should be
set, after whatever amount of data Target has in its buffer has been
transmitted.
 Would somebody suggest a good example when Initiator can take advantage of
F-bit being set every MaxBurstSize.
 I understand that A-bit is used in conjuction with MaxBurstSize, however my
context of the question is when A-bit is not used.

Regards
Sanjay Goyal

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 24 May 2002 16:14:19 -0700

Sanjay,

There were earlier messages on this in the archive.

One of the reasons we decided to require F-bit for every
MaxBurstSize of Data-In is to ensure that initiator may use that
as a hint to send Data-Out in the case of bidirectional commands.
The truth is that we don't know if such a hint is required, but 
it is architected for a possible use if implementations need it.

Note that A-bit is not related to F-bit really - except both bits
are somehow related to MaxBurstSize ("at most once" Vs "at least
once").

Hope that helps.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668 
Roseville CA 95747
[email-masked]