Subject: RE: FCIP: Comment 120

From: [email-masked]
Date: Thu, 9 May 2002 19:44:10 -0400

> >I also believe that the rough
> > consensus of the WG is not to change FCIP in this fashion.
> 
> I am *not* advocating a change.  I am simply concerned that the FCIP 
> text is neither ruling out certain possibilities explicitly, 
> nor defining the
> architectural hooks to cater to all possibilities.  I'd be 
> perfectly okay with
> a statement that states that each IP-TCP Address-Port belongs 
> to exactly
> one Pair (though the text then should ideally say why).

That's a reasonable request that I'm sure the FCIP draft editor
would be happy to accommodate.  The reason why is probably going
to be some version of simplicity.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Mallikarjun C. [mailto:[email-masked]]
> Sent: Thursday, May 09, 2002 7:32 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: FCIP: Comment 120
> 
> 
> David,
> 
> From the text that Murali posted on this thread - 
> 
> " The FC-BB-2_IP Reference Model supports one logical IP Interface and
> allows sharing a 4-byte IPv4 or 16-byte IPv6 address in the 
> following ways:
> 
> a)A single IP address per FC-BB-2_IP device
>   - A single IP address shared by all FC/FCIP Entity pairs"
> 
> 
> It's a simple extension to assume that the same well-known TCP port
> *could* be used for all Pairs, which results in multiple 
> Pairs at the same *address*
> necessitating a *name* of some sort to identify the intended 
> FSF recipient.
> 
> >Having seen no other
> > participants in this discussion,
> 
> Please see Murali's message.
> 
> >I also believe that the rough
> > consensus of the WG is not to change FCIP in this fashion.
> 
> I am *not* advocating a change.  I am simply concerned that the FCIP 
> text is neither ruling out certain possibilities explicitly, 
> nor defining the 
> architectural hooks to cater to all possibilities.  I'd be 
> perfectly okay with
> a statement that states that each IP-TCP Address-Port belongs 
> to exactly
> one Pair (though the text then should ideally say why). 
> 
> Thanks.
> --
> Mallikarjun
> 
> Mallikarjun Chadalapaka
> Networked Storage Architecture
> Network Storage Solutions Organization
> Hewlett-Packard MS 5668 
> Roseville CA 95747
> [email-masked]
> 
> 
> ----- Original Message ----- 
> From: <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, May 09, 2002 1:39 PM
> Subject: RE: FCIP: Comment 120
> 
> 
> > > > Besides, I don't see anything in the current document 
> that prohibits
> > multiple
> > > > FC/FCIP Entity Pairs from sharing the same IP/TCP 
> address/port - and I
> > believe
> > > > that is the right architectural approach.
> > > 
> > > In the Orange County meeting, the FCIP contributors were 
> told that we
> > > had to stop relying on knowing the exact IP Address and 
> Port to decide
> > > the end points of the FCIP Links. We were NOT told that we had to
> > > allow multiple FC/FCIP Entity Pairs to share a single IP 
> Address/Port.
> > > In fact, I believe we were told that we could proceed using such
> > > an assumption.
> > 
> > While Ralph doth protest a bit much, I believe he has the 
> better part
> > of this discussion.  It is completely reasonable to identify an IP
> > service instance as "that which responds when contacting TCP port X
> > at IP address a.b.c.d" - for example, there's only one http server
> > behind port 80, but there might be a different one behind port 8080.
> > 
> > If there's a NAT involved, the discussion gets a bit subtle, but
> > the principle remains - one opens a TCP connection to port X at
> > IP address a.b.c.d, and expects to talk directly to a 
> specific instance
> > of an IP-based service.  I don't see any need to change FCIP to
> > allow multiple FC/FCIP Entity Pairs to share a single IP 
> Address/Port;
> > the fact that multiple TCP connections to the same FC/FCIP Entity
> > Pair can share that TCP Port seems sufficient.  Having seen no other
> > participants in this discussion, I also believe that the rough
> > consensus of the WG is not to change FCIP in this fashion.
> > 
> > Thanks,
> > --David
> > ---------------------------------------------------
> > David L. Black, Senior Technologist
> > EMC Corporation, 42 South St., Hopkinton, MA  01748
> > +1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
> > [email-masked]         Cell: +1 (978) 394-7754
> > ---------------------------------------------------
> > 
> > 
> > 
>

---

From: Ralph Weber <[email-masked]>
Date: Fri, 10 May 2002 08:05:25 -0500

Slight modifications to the first sentence after Figure 4 (in section
6.4) would seem to suffice for the requirement aspect.

Change:

  The FCIP Entity is the connection interface point for the IP Network 
  and is the owner of the IP Address and Well Known Port used to form 
  TCP Connections.

to:

  The FCIP Entity is the connection interface point for the IP Network 
  and is the sole owner of at least one IP Address and Well Known Port 
  used to form TCP Connections.

The change from "owner" to "sole owner" addresses Mallikarjun's requirement
issue, and the change from "one" to "at least one" addresses the FC-BB-2
text posted by Murali.

A new sentence can be added immediately following the sentence cited
above to address the "why" issue.

Add:

  The TCP Connection establishment algorithms in section 9.1 and FSF usage
  described in section 8.2 assume that TCP connect requests for a given
  FC/FCIP Entity pair are received via uniquely identifiable IP Address
  and Well Known Port.

Thanks.

.Ralph