Subject: iSCSI: CRC32C Table generation

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Wed, 29 May 2002 14:40:07 -0700

In the code given in RFC-1952 for generating the table
for CRC32 algorithm, the constant 0xedb88320 is used.
Since this constant is derived from the polynomial,
it's different than 0xedb88320 for iSCSI. It took
some effort to find out the steps to arrive at the constant
from the given CRC32 polynomial. 

May I suggest we include this conversion steps in an appendix 
in the spec? 

thanks!
 -lakshmi

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 30 May 2002 07:05:07 +0300

Lakshmi,

Those steps are widely described in literature.
The iSCSI draft is overly large and IMHO overly burdened with 
explanations.
I am afraid that I must answer negatively your request.

Julo

"Lakshmi Ramasubramanian" <[email-masked]>
05/30/2002 12:40 AM
Please respond to "Lakshmi Ramasubramanian"

        To:     <[email-masked]>, "Julian Satran" <[email-masked]>
        cc: 
        Subject:        iSCSI: CRC32C Table generation

thanks!
 -lakshmi