Subject: RE: iSCSI: large keys during login?

From: Bill Studenmund <[email-masked]>
Date: Fri, 3 May 2002 13:38:39 -0700 (PDT)

On Fri, 3 May 2002, Eddy Quicksall wrote:

> Regarding the following sentence in 9.10.4, can we say the key and equal
> sign most not be spanned? The reason I ask for this is because it makes the
> parsing of the key much easier if you don't have it cut into two PDUs.

Wouldn't it just be easier to just read the whole extended text and then
parse? i.e.

	do {
		Read_packet(&empty part of buffer)
		if (packet doesn't end with a NUL) {
			send response asking for more
			make sure there's more space in buffer
		}
	} while (packet doesn't end with a NUL)

	parse while buffer

Why would you be parsing the text before it has all arrived? Or is it more
you were going to keep things in different buffers, and don't want to
fumble with the key spanning buffers?

Take care,

Bill

---

From: Eddy Quicksall <[email-masked]>
Date: Fri, 3 May 2002 16:22:42 -0400

A key=value pair can span Text request or response boundaries (i.e., a

key=value pair can start in one PDU and continue on the next).

Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Monday, April 29, 2002 8:35 PM
To: THALER,PAT (A-Roseville,ex1)
Cc: andy currid; [email-masked]; [email-masked]; Bill Studenmund
Subject: RE: iSCSI: large keys during login?

Pat, 

For spanning look at 9.10.4 and 9.11.4. 

I assume that the text covers whatever does not fit. 

Regards, 
Julo 

	"THALER,PAT (A-Roseville,ex1)" <[email-masked]> 

04/30/2002 02:24 AM 
Please respond to "THALER,PAT (A-Roseville,ex1)" 

        To:        Julian Satran/Haifa/IBM@IBMIL, Bill Studenmund
<[email-masked]> 
        cc:        andy currid <[email-masked]>, [email-masked],
[email-masked] 
        Subject:        RE: iSCSI: large keys during login? 

Julian, 
  
I assume you mean that keys can span requests as well. I can't find anything
in the draft that says that they can though there also isn't anything that
says they can't. Does this only apply to key-value pairs too long to fit in
a single response or can a short key-value pair span a request/response when
multiple key-value pairs are packed into a PDU? 
  
The draft should clarify. 
  
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Monday, April 29, 2002 3:54 PM
To: Bill Studenmund
Cc: andy currid; [email-masked]; [email-masked]
Subject: Re: iSCSI: large keys during login?

Key can span responses. Bookmarking is for things that have multiple answers
- like the SendTargets - Julo 

	Bill Studenmund <[email-masked]> 
Sent by: [email-masked] 

04/30/2002 01:15 AM 
Please respond to Bill Studenmund 

       To:        andy currid <[email-masked]> 
       cc:        <[email-masked]> 
       Subject:        Re: iSCSI: large keys during login? 

On Mon, 29 Apr 2002, andy currid wrote:

>
> Hi
>
> In iSCSI draft 12, chapter 10, the Kerberos and SPKM authentication
> mechanisms specify a limit of 64k on their unencoded key values.
>
> Given that these keys are only used during login and, during login,
> the PDU size in use is 8k and, unlike text commands, there is no
> bookmarking, how can you send a key value of this size during login?

I thought that was covered. If you say you can do kerberos or SPKM, you
are saying you can do 64k.

Take care,

Bill