Subject: Re: Flipped locations between d11 and d12.

From: "Julian Satran" <[email-masked]>
Date: Wed, 22 May 2002 08:34:43 +0300

It is no mistake. It is only that this new notation is the one preferred by
the RFC editor.

Julo

                      "Sankar, Ranga"                                                                                            
                      <Ranga.Sankar@net        To:       "[email-masked]'" <[email-masked]>                                   
                      app.com>                 cc:       Julian Satran/Haifa/IBM@IBMIL                                           
                                               Subject:  Flipped locations between d11 and d12.                                  
                      05/21/2002 10:54                                                                                           
                      PM                                                                                                         
                      Please respond to                                                                                          
                      "Sankar, Ranga"                                                                                            

Looks like the bit locations are flipped between Version 11 and 12.

For example  Bit 0 of Byte 1 corresponds to T bit in Version 12
In Version 11 and below Bit 7 of Byte 1 corresponds to T bit.

Is this intended or an error in the draft.

Version 12

Login Response
Byte / 0           | 1                     | 2                     | 3
             |
|0 1 2 3 4 5 6 7|0 1 2 3 4 5 6 7|0 1 2 3 4 5 6 7|0 1 2 3 4 5 6 7|
<---------
 . .       0x23

Version 11
Byte / 0 | 1 | 2 | 3 | / | | | |
|7 6 5 4 3 2 1 0|7 6 5 4 3 2 1 0|7 6 5 4 3 2 1 0|7 6 5 4 3 2 1 0|
<----------
+---------------+---------------+---------------+---------------+
0|.|.| 0x23              |T|0 0 0|CSG|NSG| Version-max | Version-active|

-ranga

---

From: "Sankar, Ranga" <[email-masked]>
Date: Wed, 22 May 2002 09:28:28 -0700

The new notation is counter intuitive and causes confusion. 
If there is no specific reasoni would prefer it to be the way it 
was in earlier drafts (D11).

-ranga

> -----Original Message-----
> From: Julian Satran [mailto:[email-masked]]
> Sent: Wednesday, May 22, 2002 1:35 AM
> To: Sankar, Ranga
> Cc: [email-masked]'; Julian Satran
> Subject: Re: Flipped locations between d11 and d12.
> 
> 
>

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 22 May 2002 21:36:17 +0300

IETF rules - Julo

"Sankar, Ranga" <[email-masked]>
05/22/2002 07:28 PM
Please respond to "Sankar, Ranga"

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     "[email-masked]'" <[email-masked]>, "Pittman, Joseph" 
<[email-masked]>
        Subject:        RE: Flipped locations between d11 and d12.

-ranga

---

From: [email-masked]
Date: Thu, 23 May 2002 13:56:55 -0400

The new notation has a long history of use in networking
specifications and is required (not just "preferred")
in all IETF standards-track RFCs.  See the
"Bit and Byte order in drawings" Section of

http://www.ietf.org/ID-nits.html

It's unfortunate that we caught the need to make this
change relatively late in the process, but the change
does need to be made ... otherwise the draft will be
returned to the WG with instructions to make the change.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> From: Sankar, Ranga [mailto:[email-masked]]
> Sent: Wednesday, May 22, 2002 12:28 PM
> To: 'Julian Satran'
> Cc: [email-masked]'; Pittman, Joseph
> > Byte / 0           | 1                     | 2              
>        | 3