Subject: Re: iSCSI: large keys during login?

From: "Julian Satran" <[email-masked]>
Date: Wed, 1 May 2002 08:36:11 +0300

Andy,

The data part is the same on both text and login.
I will make o note to say this again in chapter 9.

Julo

andy currid <[email-masked]>
05/01/2002 08:15 AM
Please respond to andy currid

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked] ("THALER,PAT (A-Roseville,ex1)"), 
[email-masked] (andy currid), [email-masked], [email-masked], 
[email-masked] (Bill Studenmund)
        Subject:        Re: iSCSI: large keys during login?

Julian

The sections you refer to describe Text Request and Text Response PDUs.
Unless I've misunderstood the spec, neither of those PDUs can be used
during login; the only PDUs that are valid for use during login are Login
Request and Login Response.

I was under the impression that login phase was a very simple
exchange; initiator sends a single Login Request PDU, target replies
with a single Login Response PDU, repeat until logged in or rejected.

How can you have a key value span multiple Login Request or Response
PDUs? Unlike the Text PDUs, the Login PDUs do not contain the fields
required to permit text to span PDUs (target tag, final bit, etc.). So
there's no defined way to determine a text payload is being continued
in a subsequent Login Request or Response PDU.

Regards

Andy

> Pat,
> 
> For spanning look at 9.10.4 and 9.11.4.
> 
> I assume that the text covers whatever does not fit.
> 
> 
> Regards,
> Julo
> 
> 
> 
> 
> "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
> 04/30/2002 02:24 AM
> Please respond to "THALER,PAT (A-Roseville,ex1)"
> 
> 
>         To:     Julian Satran/Haifa/IBM@IBMIL, Bill Studenmund 
> <[email-masked]>
>         cc:     andy currid <[email-masked]>, [email-masked], 
[email-masked]
>         Subject:        RE: iSCSI: large keys during login?
> 
> 
> 
> Julian,
> 
> I assume you mean that keys can span requests as well. I can't find 
> anything in the draft that says that they can though there also isn't 
> anything that says they can't. Does this only apply to key-value pairs 
too 
> long to fit in a single response or can a short key-value pair span a 
> request/response when multiple key-value pairs are packed into a PDU?
> 
> The draft should clarify.
> 
> -----Original Message-----
> From: Julian Satran [mailto:[email-masked]]
> Sent: Monday, April 29, 2002 3:54 PM
> To: Bill Studenmund
> Cc: andy currid; [email-masked]; [email-masked]
> Subject: Re: iSCSI: large keys during login?
> 
> 
> Key can span responses. Bookmarking is for things that have multiple 
> answers - like the SendTargets - Julo 
> 
> 
> 
> Bill Studenmund <[email-masked]> 
> Sent by: [email-masked] 
> 04/30/2002 01:15 AM 
> Please respond to Bill Studenmund 
> 
>         To:        andy currid <[email-masked]> 
>         cc:        <[email-masked]> 
>         Subject:        Re: iSCSI: large keys during login? 
> 
> 
> 
> 
> On Mon, 29 Apr 2002, andy currid wrote:
> 
> >
> > Hi
> >
> > In iSCSI draft 12, chapter 10, the Kerberos and SPKM authentication
> > mechanisms specify a limit of 64k on their unencoded key values.
> >
> > Given that these keys are only used during login and, during login,
> > the PDU size in use is 8k and, unlike text commands, there is no
> > bookmarking, how can you send a key value of this size during login?
> 
> I thought that was covered. If you say you can do kerberos or SPKM, you
> are saying you can do 64k.
> 
> Take care,
> 
> Bill
> 

--
Andy Currid                                       [email-masked]
Server Products Group                       http://www.windriver.com
Wind River Networks                         Phone : (1) 510 749 2191
500 Wind River Way, Alameda, CA 94501       Fax   : (1) 510 749 2560

---

From: Bill Studenmund <[email-masked]>
Date: Wed, 1 May 2002 09:14:18 -0700 (PDT)

> I will make o note to say this again in chapter 9.

Julian, I think the grit of Andy's question still stands. At least I'm now
puzzled by a question he raised. :-)

I agree that the section you quote, 9.12.10, describes what keys can be
used when & refers to the correct chapters.

I think Andy's question, or the question I now have, is how do we do the
equivalent of the multi-part exchange shown in section 9.10.3 (towards the
bottom of page 156) with Login PDU's? We don't have a Target Transfer Tag
field?

Do we need to add one?

Take care,

Bill

---

From: Carlos Rimola <[email-masked]>
Date: Wed, 01 May 2002 11:04:02 -0700

Hello,

I believe the other point was the use of the F bit in Text 
requests/responses.  In Login Text requests/responses, the same bit 
position is known as the T bit and is defined as the "Transition" to next 
stage indicator.

Does this mean that the T bit in login request/responses should be 
interpreted in the same way as the F bit in text requests/responses?

If this is the case, is this dual meaning of the T bit desirable?  At the 
least, it would be useful for the spec to explicitly state the dual usage 
to remove any ambiguity.

Carlos Rimola
Silverback Systems