Subject: ISCSI: Error Recovery Level 0

From: "LEMAY,KEVIN (A-Roseville,ex1)" <[email-masked]>
Date: Wed, 29 May 2002 13:14:30 -0600

I have the following question on error Recovery level 0.

On page 105, v12, it says that error recovery level 0 must perform Session recovery as described in 6.12.4.

This seems to imply that:
If I have a multi-connection session were one connection experiences a digest error, then I must close all connections on the session, even killing IOs over the good connection.

This is absurd! Why not just close the one connection that has a problem and allow the IO to be restarted on one of the other live connections? There is nothing wrong with the session, only a single connection.

I guess I am calling for a level 0.5, so that I can abort only the troublesome connection. This would allow for a much faster IO recovery without adding hardly any coding complexity that is required for level 1.

Comments?

Kevin Lemay

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 29 May 2002 14:45:47 -0700

Kevin,

From: "LEMAY,KEVIN (A-Roseville,ex1)" <[email-masked]>
> On page 105, v12, it says that error recovery level 0 must perform Session recovery as described in 6.12.4.

I can't find it.

It's only saying that the minimally expected error recovery capabilities for level 0 are as described
in 6.12.4, not that session recovery must be performed for every error....

If you look in 6.12.4, it specifically states that session recovery is done only if all other recovery
attempts fail.

> If I have a multi-connection session were one connection experiences a digest error, then I must close all
connections on the session, even killing IOs over the good connection.
> This is absurd!

Indeed it would be if so implemented (even while it's legal).

>Why not just close the one connection that has a problem and allow the IO to be restarted on one of the other
live connections? There is nothing wrong with the session, only a single connection.

That's a reasonable recovery strategy (if it's a SCSI restart).
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
[email-masked]

>
> I guess I am calling for a level 0.5, so that I can abort only the troublesome connection. This would allow
for a much faster IO recovery without adding hardly any coding complexity that is required for level 1.