Subject: RE: iSCSI: ImmediateData negotiation

From: Dennis Young <[email-masked]>
Date: Wed, 8 May 2002 11:45:08 -0700

The following paragraphs in section 4.2 of draft 12
lead me to believe otherwise:
  ...
  The responding party answers with the first value that
  it supports and is allowed to use for the specfic originator
  selected from the originator list. 
  ...
  An offer of a value not admissible MAY be answered with
  the constant "Reject".

My interpretation of the two paragraphs is that the responding
party can only respond with value offered in the originator list,
and since "Yes" is not admissible, responding with "Reject"
seems correct.

Dennis

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Wednesday, May 08, 2002 11:08 AM
>To: [email-masked]; [email-masked]
>Subject: RE: iSCSI: ImmediateData negotiation
>
>
>Actually, both are incorrect. It is illegal to negotiate a 
>parameter more
>than once during a login. The correct sequence is:
>
>I->T: ImmediateData=Yes
>T->I: ImmediateData=No
>
>Both initiator and target must send ImmediateData=Yes for 
>immediate data to
>be used.
>
>Kevin Lemay
>
>-----Original Message-----
>From: Dennis Young [mailto:[email-masked]]
>Sent: Wednesday, May 08, 2002 11:02 AM
>To: [email-masked]
>Subject: iSCSI: ImmediateData negotiation
>
>
>I have a question on how a target should respond to
>"ImmediateData=Yes" from an initiator if the target
>doesn't support ImmediateData.  Here are two scenarios:
>
>Scenario 1:
>/* The target here only considers the value offered by the
> * initiator, if the value is not acceptable, it simply 
> * rejects it rather than suggesting another value.
> */
>I->T: ImmediateData=Yes
>T->I: ImmediateData=Reject
>I->T: ImmediateData=No  /* Should initiator offer No? */
>T->I: ImmediateData=No
>
>Scenario 2:
>/* The target here simply returns a value it supports 
> * without rejecting the value offered by the initiator.
> */
>I->T: ImmediateData=Yes
>T->I: ImmediateData=No
>I->T: ImmediateData=No  /* Should initiator reply No? */
>T->I: ImmediateData=No
>
>Based on section 4.2 of draft 12, I believe scenario 1 is 
>correct, right?
>
>In addition, does the Result function of a text parameter (AND 
>or OR) make a
>difference here?
>
>Thanks,
>Dennis
>

---

From: David Woolf <[email-masked]>
Date: Wed, 8 May 2002 18:53:27 -0400 (EDT)

Hello, I've included comments below:

>   selected from the originator list.

I would agree with Kevin here, FirstBurstSize and ImmediateData are
numerical and boolean keys respectively, and the above paragraph does not
apply.

>   An offer of a value not admissible MAY be answered with

It looks like theres some confusion about the meaning of the phrase
'not admissible'. I interpreted it to be refering to any value that is
illegal for that type of negotiation. For example, if negotiating
ImmediateData, a key value of ImmediateData=5 would be 'not admissible'.
The phrase 'not admissible' would not apply if the offered value for
the given key was something the device did not support or did not have
the resources for.

> and since "Yes" is not admissible, responding with "Reject"

thank you,

David Woolf
************************************************
University of New Hampshire Interoperability Lab
iSCSI and Fibre Channel Consortiums
Durham, NH 03824
(603) 862 0701
************************************************