Subject: RE: iSCSI: BASE64 and numerical values

From: Michael Schoberg <[email-masked]>
Date: Wed, 22 May 2002 12:20:23 -0500

: CHAP challenges are strings, not numbers.

Funny that at least one predominant initiator out there only accepts
hex-valued CHAP challenges.  Perhaps this should be either made clearer in
the draft or it should be opened up to all iSCSI formats.

I personally don't see the problem with large decimal, base64, or hex.  It
seems like the algorithms to convert these back to machine values are
relatively simple.  They're far simpler than the authentication and
encryption algorithms we're working with.

:-----Original Message-----
:From: Paul Koning [mailto:[email-masked]]
:Sent: Tuesday, May 21, 2002 3:06 PM
:To: [email-masked]
:Cc: [email-masked]; [email-masked]; [email-masked]
:Subject: RE: iSCSI: BASE64 and numerical values
:
:
:Excerpt of message (sent 21 May 2002) by Bill Studenmund:
:> On Tue, 21 May 2002, Julian Satran wrote:
:> 
:> > Bill,
:> >
:> > Your point was clear. I am still loking at the cases where 
:LARGE NUMBERS
:> > might be needed and I am sure we don't want them to be strings but
:> > numbers.
:> 
:> Sounds excelent.
:> 
:> One thing I haven't figured out how to do is add implicit 
:binary length to
:> the numbers used for CHAP challenges (and possibly others). 
:It's a little
:> bit of semantics (since we define the length for binary 
:strings), but the
:> ones I came up with felt heavy and cumbersome.
:
:CHAP challenges are strings, not numbers.
:
:     paul
:

---

From: Martins Krikis <[email-masked]>
Date: Wed, 22 May 2002 12:08:07 -0700 (PDT)

> encryption algorithms we're working with.

Getting rid of encoding large numbers/binary-strings
in decimal was a very good thing. Conversion from
decimal to binary is simple but it is time and/or
space consuming. I looked it up in Knuth last time
when I saw the casual comment of it not being so.
From what I understood, the simple algorithms
all (both?) are O(n^2) time. If you want to do better
than that, they get complicated fast and you start
losing space (I think, mostly to store precomputed
multiplication results and such).

  Martins Krikis, Intel Corp.

Disclaimer: these opinions are mine and may not
            be those of my employer.

__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com