Subject: Re: base64 byte-length formula

From: "Julian Satran" <[email-masked]>
Date: Thu, 13 Jun 2002 02:56:26 +0300

I said already that your formula is correct. 
I do not understand why you say that the 2 formulas are not equivalent for 
all the lengths (good aor bad)?
I would appreciate if you respond although you don't have to.

Julo

Martins Krikis <[email-masked]>
Sent by: [email-masked]
06/13/2002 02:34 AM
Please respond to Martins Krikis

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        Re: base64 byte-length formula

--- Julian Satran <[email-masked]> wrote:

> The difference between our formulas is that I
> (mistakenly) took 1 digit as 
> a possible string (or 5, 9 etc.)
> For those you need the +3 TERM.
> 
> For all the good length 2,3,4 6,7,8 etc the two
> formulas are equivalent.

No they are not. They are only equivalent for
n = 0 (mod 4). So I'm still insisting that
n * 3 / 4 is the simplest right formula.

Martins Krikis, Intel Corp.

Disclaimer: these are my opinions and
            may not be Intel's.

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

---

From: Martins Krikis <[email-masked]>
Date: Wed, 12 Jun 2002 17:38:14 -0700 (PDT)

> all the lengths (good aor bad)?

Because 
floor((n * 3 + 3) / 4) > floor(n * 3 / 4)
for n such as 2, 3, 6, 7, etc.
(Also for 1, 5, etc, but those are bad
lengths.)

BTW, my apologies for forgetting "iSCSI"
in front of the subject line.