Subject: RE: iSCSI: minor conflict introduced by C bit

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Mon, 3 Jun 2002 10:47:01 -0600

Julian,
 
I have noticed a minor conflict of the C bit with existing text.
 
11.4 and 11.9 require the target to return TargetName and TargetPortal group in the first Login Response PDU but the new text on the C bit in 4.2 requires the target to return an empty response if the C bit is set. Therefore, if the C bit is set on the first Login Request PDU, the target will have conflicting requirements on it. 
 
One could resolve this by:
1) Specify that the C bit MUST NOT be set in the first Login Request PDU; or
2) Allow declarations to be sent in PDUs when the other side has the C bit set; or
3) Change the requirement in 11.4 and 11.9 to be the response to the first Login Request PDU with the C bit set to zero.
 
Regards,
Pat

---

From: Martins Krikis <[email-masked]>
Date: Mon, 3 Jun 2002 14:51:04 -0700 (PDT)

> 3) Change the requirement in 11.4 and 11.9 to be the
> response to the first Login Request PDU with the C
> bit set to zero.

I think 3 is the most natural way for the current
meaning of C-bit. I can live with 2 as well (even
responses could be sent, just no new originations
of non-declarations). 1 would take us back to
square-1, i.e., strictly speaking, the sender will
be forced to check whether things fit or not.

Martins Krikis, Intel Corp.

Disclaimer: my opinions, not necessarily Intel's.

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

---

From: Bill Studenmund <[email-masked]>
Date: Mon, 3 Jun 2002 16:11:00 -0700 (PDT)

Sorry, meant to answer earlier but deleted too fast.

> be forced to check whether things fit or not.

I think that 3) is the most natural. It captures what I think is the
intent of the working group and adapts it for the case where the initial
offer won't fit in one PDU.

Take care,

Bill