Subject: iSCSI: TargetAuth

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Wed, 19 Jun 2002 16:52:22 -0700

In the Login phase examples given, the key TargetAuth is used
ONLY with SRP. Does this mean that target authentication needs
to be negotiated only for SRP? If so, what is the default
behaviour for other authentication methods? Is there any way
to negotiate this?
 
It'll be good to have both sides authenticate each other (by default)
for all authentication methods.
 
thanks!
 -lakshmi

---

From: "Ofer Biran" <[email-masked]>
Date: Thu, 20 Jun 2002 10:31:50 +0300

lakshmi,

In all authentication methods, initiator authentication is
mandatory, and target authentication is dictated by the
initiator (they are both mandatory to implement of course).

In SRP, the initiator dictates it by the TargetAuth
key. In CHAP, by sending the CHAP_I, CHAP_C keys in
the right step (see 10.5). In Kerberos and SPKM it is
by setting a mutual field in the initiator token (see
10.2, 10.3).

  Regards,
     Ofer

Ofer Biran
Storage and Systems Technology
IBM Research Lab in Haifa
[email-masked]  972-4-8296253

"Lakshmi Ramasubramanian" <[email-masked]>@ece.cmu.edu on
20/06/2002 02:52:22

Please respond to "Lakshmi Ramasubramanian" <[email-masked]>

Sent by:    [email-masked]

To:    <[email-masked]>
cc:
Subject:    iSCSI: TargetAuth

thanks!
 -lakshmi