Subject: RE: iSCSI: 12-97 Bit Rule

From: [email-masked]
Date: Thu, 13 Jun 2002 16:58:15 -0600

Luben,

TCP/IP Illustrated numbers bits with bit 0 as the 
most significant. My books on Sonet number bits
in a byte from 1 to 8. I guess you could argue 
these are not books on computer architecture, but
the point is that not everyone numbers bits the 
same.

If you will read 1.3.1 through 1.3.3, they do
explicitly state the significance of bits in 
iSCSI words, half-words and bytes.

Julian's new description is accurate and clear.
Item 8 in your description is unclear and confusing
because the bits do not "follow" each other in the
order you state (and any viewing of bits in a message
as a serial stream is entirely hypothetical).

Regards,
Pat

-----Original Message-----
From: Luben Tuikov [mailto:[email-masked]]
Sent: Thursday, June 13, 2002 12:20 PM
To: Julian Satran
Cc: iSCSI
Subject: Re: iSCSI: 12-97 Bit Rule

Julian Satran wrote:
> 
> Luben,
> 
> The draft has figure that are an integral part of it.
> In every one of those bit 7 is the least significant.
> I don't know what your NORMALLY means.

Julian, any book you open on computer architecture,
assumes that bit 7 is more significant than bit 6,
simply because 2^7 > 2^6.

Stipulating that bit 7 is less significant than
bit 6, needs explicitly to be said so, NOT
inferred from ``figures in the text''.

Nevertheless, as you may have already noticed,
the algorithm which I sent you, is _independent_
of iSCSI's implication that bit 7 is less significant
than bit 6.

So, anywhich way you order the bits in the bytes
for the rest of the draft, the algoritm would
produce the same results, simply because
it explicitly mentions ordering in step 1 (and 2).

-- 
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Thu, 13 Jun 2002 19:13:24 -0400

> the point is that not everyone numbers bits the

Uuuh, here we go again...

Yes, I can argue that those are NOT books
on computer architecure. Let me get home
I'll send you the titles/authors/ISBN
of a few books on Computer Architecture
which use the NATURAL bit ordering:

2^(x+1) > 2^x, x >= 0,
so it only _makes_sense_ to say that
bit x+1 is more significant than bit x.

Take the number 791, is the 2rd digit
more significant than the 1nd?
Well: 791 = 7*10^2 + 9*10^1 + 1*10^0.

> iSCSI words, half-words and bytes.

Yep, and you were complaining that it was
200 pages away from 11.1 where the CRC
digest was --- or was that in a private
email? Trying to score points?

> Julian's new description is accurate and clear.

Are you sure? Are you really sure?

> as a serial stream is entirely hypothetical).

Here is 8:

8) The message sent is P and appended at the end are the
   bit coefficients of CRC(x), with x^31 bit coefficient
   first, then x^30, etc.

That is after you send P, send CRC(x) as indicated.
What doesn't follow what?

Of course it is hypothetical...

Pat, let me ask you this: Is Mathematics hypothetical?

-- 
Luben