Subject: RE: iSCSI variable CDB length

From: "Elliott, Robert (Server Storage)" <[email-masked]>
Date: Mon, 10 Jun 2002 09:01:07 -0500

> -----Original Message-----
> From: Michael J. S. Smith (PacBell) [mailto:[email-masked]] 
> Sent: Sunday, June 09, 2002 2:24 PM
> Subject: variable CDB length
> 
> I'm trying to bound some of the iSCSI structures. This email 
> is regarding the AHS for extended CDBs.
> 
> The following (page 37 of the PDF, page 7 in the draft page 
> numbering) is from ftp://ftp.t10.org/t10/drafts/spc3/spc3r07.pdf. 
> [quote]
> Command descriptor block (CDB): The structure used to communicate 
> commands from an application client to a device server. A CDB may 
> have a fixed length of up to 16 bytes or a variable length of 
> between 12 and 260 bytes.
> [end quote]
> 
> I can't find another reference within the 442 pages of the 07 
> draft of SPC-3 to the 260-byte maximum length for a 
> variable-length CDB.
> 
> 1. Is the 260-byte figure in the definitions section of the 
> 07 draft of SPC-3 correct?

The variable length CDB structure (spc3r07 table 7) has an 8 byte
header, with a one byte ADDITIONAL CDB LENGTH field indicating the
additional size in bytes.  That field must be a multiple of 4, so
the maximum value is 252, restricting the maximum CDB length 
to 260 bytes.

> 2. Is it intended that the maximum length of ExtendedCDB 
> field in the iSCSI Extended CDB AHS comes from SPC-3?

The iSCSI AHS carries bytes 16-259 of a variable length CDB.
The 2-byte AHSLength field needs to contain a value big enough
to hold the CDB. It should be 8 less than the ADDITIONAL CDB
LENGTH field in the CDB itself.

> ...
> Mike Smith
> CTO, iReady

--
Rob Elliott, [email-masked]
Industry Standard Server Storage Advanced Technology
Hewlett-Packard

---

From: "Pat LaVarre" <[email-masked]>
Date: Mon, 10 Jun 2002 08:21:33 -0600

> restricting the maximum CDB length to 260 bytes.
 
Max allowed is 260 = 8 + 252, yes.
 
Max expressible is 263 = 8 + 255.  We can only hope nobody visits the land between max allowed and max expressible.
 
> That field must be a multiple of 4
 
The day's soon coming when people will prefer multiples of 8 ...
 
Pat LaVarre

---

From: "Pat LaVarre" <[email-masked]>
Date: Mon, 10 Jun 2002 08:21:33 -0600

Pat LaVarre