Subject: RE: iSCSI: ordered command delivery at the target

From: Eddy Quicksall <[email-masked]>
Date: Fri, 7 Jun 2002 13:57:59 -0400

Luben

The Device Server may need to use the iSCSI SDS to get the data ... so all
data-out PDUs may not have been delivered yet. Does that make a difference
to your case?

Eddy 

-----Original Message-----
From: Luben Tuikov
To: Amir Shalit
Cc: iSCSI; Julian Satran
Sent: 6/7/02 12:56 PM
Subject: Re: iSCSI: ordered command delivery at the target

Amir Shalit wrote:
> 
> It does it for new commands but not for existing once
> like what you are suggesting. It's all about "delivery".

Even the more reason to implement this.

Once a command has been delivered for execution to the
device server, this means that Data-out pdu's (if any)
have already been delivered (i.e. the command with its
data (if any) has been delivered to the target).
Thus no new ones are coming, thus, CmdSN may wrap
around that CmdSN (submitted task).

As for SNACK -- it will become a command
if assigned CmdSN. (i.e. no reference to tasks,
since they are refered to by SNACK->ITT).
And for SNACK of type DataAck, this can be
Immediate since the Target is keeping the whole
thing into a ``pending (data) ack'' queue.

Anyway...

Comments? (on the original postng)

-- 
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Fri, 07 Jun 2002 14:27:32 -0400

> data-out PDUs may not have been delivered yet. Does that make a difference

Eddy,

By ``device server'' I mean ``device controller'' which
will most likely do bus mastering on the PCI bus to
obtain the data from the host's memory.

So, I'd put all data in the target node's host memory.

Else, what you are suggesting, the device server will
time out immediately... network (Ethernet) latencies...

-- 
Luben