Subject: RE: iSCSI: 12-97 Bit Rule

From: [email-masked]
Date: Thu, 13 Jun 2002 17:15:31 -0600

Luben,

You seem intent on taking an injured and combative tone which makes it difficult to have a reasoned discussion with you.

Yesterday, there was content that was inconsistent on bit numbering and the CRC process and I pointed out the problems with it.

Today's changes from Julian resolved those inconsistencies to my satisfaction. The new text clearly says how to process the bits. Therefore my message today is different from my message yesterday. If the situation changes then my assessment of it can change.

I did make a leap of faith in my response that reformulated text from Julian's message will be in the next draft. With those changes the new draft will be clear and consistent on the topic of bit numbering and the subject of CRC. (Obviously I didn't mean that the draft is clear and consistent on all points - just that the inconsistencies that we are dealing with in this string have been resolved. I'm sorry I was not clear enough.)

Sincerely,
Pat

-----Original Message-----
From: Luben Tuikov [mailto:[email-masked]]
Sent: Thursday, June 13, 2002 3:58 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: 12-97 Bit Rule

[email-masked] wrote:
> 
> The meaning of bit numbers 0 through 7 is clear and explicit in this
> document. Both the information in 1.3 and the diagrams Chapter 9 make it
> clear that iSCSI normally uses bit 0 as the most significant bit of a byte.
> This is also the general IETF convention.

Uuuuh, I know all this Pat, why do you waste bandwidth?

BTW, this is NOT what you were saying in your other emails.
 
> I know that some of us find the alternate numbering more logical, but we are
> bound by IETF conventions.

We, in general are bound by many things, e.g. gravity.

This is why I tried to put forward an explanation of the
computation steps which are not bound by the conventions used,
but set forth their own ordering, and numbering, so as much
as you can take it out of context and it would still work!
 
> The draft is now consistant and unambiguous.

Are you sure Pat?

This is a big matso ball out there to make a statement like
this and tomorrow post a message saying that something somewhere
is ``unclear''.

Pat, you should stick with your story, and not change it on a daily
basis, like yesterday saying that ``bit rule is this and that'', and
``the CRC is this and that'', and today saying that ``everything is fine''.

Less politics, more constructive algorithms. (you can quote me on this)

-- 
Luben

---

From: Luben Tuikov <[email-masked]>
Date: Thu, 13 Jun 2002 19:41:46 -0400

> You seem intent on taking an injured and combative tone which makes it difficult to have a reasoned discussion with you.

Well, I'm just trying to sift out 0-content emails from
more constructive criticism emails.

And believe me, ``I agree with so and so.... blah... blah''
repeated 1e9 times in an email is NOT, I repeat NOT constructive
criticism, especially in a science bound mailing list.

A reasoned discussion with me goes as follows:
1+1 = 2, ok, 1+2 = 1+(1+1) = 3, etc., i.e. highly
constructve, rather than, essay like.

But this is _my_ problem.

In other words, I expect a message of the sort:
``you (I) said a+b = c, but a+b = c+1''
i.e. constructive and straight to the point.

This is so much more helpful than the general
essays with content ``Y:I agree with X''.

I'm reading other mailing lists and I cannot find
anywhere ``I agree with X''! It is as if ppl avoid it
to preserve their own identity!!!

-- 
Luben