Subject: iSCSI SCSI Port Name

From: Jeff Fellin <[email-masked]>
Date: Tue, 4 Jun 2002 17:02:46 -0400 (EDT)

Julian,
In reading 12-96, I came across two different definitions of a
SCSI Port Name.
In Section 1.1
	SCSI Port Name: A name made up as UTF-8 characters and is the
		iSCSI name + 'i' or 't' + ISID or Portal Group Tag
In Section 2.4.2
	SCSI Port Name is mandatory in iSCSI. WHen used in SCSI parameter data,
	the SCSI port name MUST be encoded as:
	- The iSCSI Name in UTF-8 format, followed by
	- a comma separator (1 byte), followed by
	- the ASCII character 'i' (<snip>) or the ASCII character 't' (<snip>), followed by
	- a comma separator (1 byte), followed by
	- zero to 3 null pad bytes <snip>, followed by
	- the 6 byte value of the ISID or the 2 byte value of the Portal Group Tag

I'm assumming the definition in Section 2.4.2 is the "correct definition", and the one
in Section 1.1 needs to be changed to match this definition.

Jeff Fellin
Bell Labs

---

From: [email-masked]
Date: Tue, 4 Jun 2002 15:44:45 -0600

Jeff,

It appears that the problem is that section 1.1. ignores details of the format (commas and pad). One way to fix this while still allowing the section 1.1 definition to be brief and keeping the rigorous definition in just on place would be to replace "and is" with "includes", "based on", or "containing" and adding a reference to the detailed description:
In Section 1.1
	SCSI Port Name: A name made up as UTF-8 characters containing the
		iSCSI name, 'i' or 't', and ISID or Portal Group Tag (see 2.4.2)
Perhaps the UTF-8 character part isn't needed at the glossary level of detail.
     SCSI Port Name: A name containing the iSCSI name, 'i' or 't', and ISID 
		or Portal Group Tag (see 2.4.2)

Pat

-----Original Message-----
From: Jeff Fellin [mailto:[email-masked]]
Sent: Tuesday, June 04, 2002 2:03 PM
To: [email-masked]
Subject: iSCSI SCSI Port Name

Julian,

Jeff Fellin
Bell Labs

---

From: "John Hufferd" <[email-masked]>
Date: Tue, 4 Jun 2002 15:21:50 -0700

Actually I think the difference is the difference in the name (which has no
commas) and the way SCSI needs the name structured in a parameter.  These
do not have to be exactly the same syntax.  We actually only use the Name
(not the SCSI parameter) in written communication.  So  the SCSI parameter
syntax is probably not the best form for that type of use.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

[email-masked]@ece.cmu.edu on 06/04/2002 02:44:45 PM

Sent by:    [email-masked]

To:    [email-masked], [email-masked]
cc:
Subject:    RE: iSCSI SCSI Port Name

Jeff,

It appears that the problem is that section 1.1. ignores details of the
format (commas and pad). One way to fix this while still allowing the
section 1.1 definition to be brief and keeping the rigorous definition in
just on place would be to replace "and is" with "includes", "based on", or
"containing" and adding a reference to the detailed description:
In Section 1.1
 SCSI Port Name: A name made up as UTF-8 characters containing the
  iSCSI name, 'i' or 't', and ISID or Portal Group Tag (see 2.4.2)
Perhaps the UTF-8 character part isn't needed at the glossary level of
     detail.
     SCSI Port Name: A name containing the iSCSI name, 'i' or 't', and ISID
  or Portal Group Tag (see 2.4.2)

Pat

-----Original Message-----
From: Jeff Fellin [mailto:[email-masked]]
Sent: Tuesday, June 04, 2002 2:03 PM
To: [email-masked]
Subject: iSCSI SCSI Port Name

Julian,
 - the ASCII character 'i' (<snip>) or the ASCII character 't' (<snip>),
 followed by

I'm assumming the definition in Section 2.4.2 is the "correct definition",
and the one
in Section 1.1 needs to be changed to match this definition.

Jeff Fellin
Bell Labs