Subject: Question regarding SNACK and bidi transfers

From: Bill Studenmund <[email-masked]>
Date: Tue, 18 Jun 2002 16:55:31 -0700 (PDT)

I have a question about SNACK type 0 requests. In the text, they are
described as being for Data-In PDUs or R2T PDUs.

For a bidi command, how do you know which? Does this mean that for a bidi
command, data-in and R2TSNs have to be mutually-unique (i.e. drawn from
the same pool)?

Take care,

Bill

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 19 Jun 2002 18:35:14 +0300

Eddy,

In fact 2.2.2.3 contains:

For bidirectional commands, the target uses the DataSN/R2TSN to sequence 
Data-In and R2T PDUs in one continuous sequence (undifferentiated). 

Do you think I should repeat this in 9.8.1 and 9.7 ?

Julo

Eddy Quicksall <[email-masked]>
06/19/2002 01:11 PM
Please respond to Eddy Quicksall

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked], Bill Studenmund <[email-masked]>
        Subject:        RE: Question regarding SNACK and bidi transfers

Julo,

Since the answer to the 2nd question is "yes" (see your EMAIL with subject
"Emailing: msg10874.txt"), then I think the spec should make that more 
clear
in sections 9.8.1 and 9.7.

Perhaps in section 9.8.1, it should say something like "Except, when used
with a bidirectional command and SNACK is being supported, the R2TSN must
start with a number that couples the R2TSN and DataSN together as one
continuous sequence". And a similar statement added to 9.7.

Eddy

-----Original Message-----
From: Bill Studenmund [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 7:56 PM
To: [email-masked]
Subject: Question regarding SNACK and bidi transfers

Take care,

Bill

---

From: Eddy Quicksall <[email-masked]>
Date: Wed, 19 Jun 2002 21:40:08 -0400

It wouldn't really have to be repeated but I don't think 9.8.1 and 9.7
should say something other than "(starting with 0").
 
I just didn't know the best way to suggest the clarification.
 
Maybe something more light, like "except when used with bidirectional
commands (see section 2.2.2.3)".
 
The problem with a blanket statement like "(starting with 0)" is that one
can easily miss the other section contradicting it.
 
Eddy

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Wednesday, June 19, 2002 11:35 AM
To: Eddy Quicksall
Cc: [email-masked]; Bill Studenmund
Subject: RE: Question regarding SNACK and bidi transfers

Eddy, 

Julo 

06/19/2002 01:11 PM 

        To:        Julian Satran/Haifa/IBM@IBMIL 
        cc:        [email-masked], Bill Studenmund
<[email-masked]> 
        Subject:        RE: Question regarding SNACK and bidi transfers 

Julo,

Since the answer to the 2nd question is "yes" (see your EMAIL with subject
"Emailing: msg10874.txt"), then I think the spec should make that more clear
in sections 9.8.1 and 9.7.

Eddy

-----Original Message-----
From: Bill Studenmund [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 7:56 PM
To: [email-masked]
Subject: Question regarding SNACK and bidi transfers

Take care,

Bill

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 20 Jun 2002 11:58:28 +0300

Eddy,

I will add a reference.

It was also brought to my attention that we should state that the total 
limit for R2T and Data is 2**32.
I will add those to the text 

Thanks,
Julo

06/20/2002 04:40 AM

        To:     Julian Satran <[email-masked]>
        cc:     [email-masked], Bill Studenmund <[email-masked]>
        Subject:        RE: Question regarding SNACK and bidi transfers

 

Eddy
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Wednesday, June 19, 2002 11:35 AM
To: Eddy Quicksall
Cc: [email-masked]; Bill Studenmund
Subject: RE: Question regarding SNACK and bidi transfers

Eddy, 

Julo 

Julo,

Eddy

-----Original Message-----
From: Bill Studenmund [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 7:56 PM
To: [email-masked]
Subject: Question regarding SNACK and bidi transfers

Take care,

Bill

---

From: Eddy Quicksall <[email-masked]>
Date: Thu, 20 Jun 2002 09:21:49 -0400

I'm running one counter that applies to both.

Eddy

-----Original Message-----
From: Amir Shalit [mailto:[email-masked]]
Sent: Wednesday, June 19, 2002 11:44 AM
To: Eddy Quicksall; [email-masked]
Cc: [email-masked]; Bill Studenmund
Subject: RE: Question regarding SNACK and bidi transfers

Eddy,

How do you "couple" R2TSN and DataSN together? Would it be better
using an option bit indicating what we are asking for?

Amir

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Eddy Quicksall
Sent: Wednesday, June 19, 2002 3:12 AM
To: [email-masked]
Cc: [email-masked]; Bill Studenmund
Subject: RE: Question regarding SNACK and bidi transfers

Julo,

Eddy

-----Original Message-----
From: Bill Studenmund [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 7:56 PM
To: [email-masked]
Subject: Question regarding SNACK and bidi transfers

Take care,

Bill