Subject: RE: iSCSI: minor conflict introduced by C bit

From: "Julian Satran" <[email-masked]>
Date: Tue, 4 Jun 2002 06:54:01 +0300

Thanks Pat - I think that 3 is acceptable and keeps current semantics 
unchanged.

Julo

"THALER,PAT (A-Roseville,ex1)" <[email-masked]>
06/03/2002 07:47 PM
Please respond to "THALER,PAT (A-Roseville,ex1)"

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        RE: iSCSI: minor conflict introduced by C bit

Julian,
 
I have noticed a minor conflict of the C bit with existing text.
 
11.4 and 11.9 require the target to return TargetName and TargetPortal 
group in the first Login Response PDU but the new text on the C bit in 4.2 
requires the target to return an empty response if the C bit is set. 
Therefore, if the C bit is set on the first Login Request PDU, the target 
will have conflicting requirements on it. 
 
One could resolve this by:
1) Specify that the C bit MUST NOT be set in the first Login Request PDU; 
or
2) Allow declarations to be sent in PDUs when the other side has the C bit 
set; or
3) Change the requirement in 11.4 and 11.9 to be the response to the first 
Login Request PDU with the C bit set to zero.
 
Regards,
Pat

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 6 Jun 2002 18:11:18 +0300

In fact for 11.9 the text will be:

Target portal group tag is a 16-bit numerical-value that uniquely 
identifies a portal group within an iSCSI target node. This key car-ries 
the value of the tag of the portal group that is servicing the Login 
request. The iSCSI target returns this key to the initiator in the first 
non-empty Login Response PDU (where empty responses may be required by 
Login Requests with the C bit set to 1). 

11.4 refers to the Sendtargets response that will be presented whenever 
and has no other apparent conflict with C.

Julo
----- Forwarded by Julian Satran/Haifa/IBM on 06/06/2002 06:06 PM -----

Julian Satran
06/03/2002 08:21 PM

        To:     "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
        cc:     [email-masked]
        From:   Julian Satran/Haifa/IBM@IBMIL
        Subject:        RE: iSCSI: minor conflict introduced by C bit

Julo

Julian,

 
 
Regards,
Pat

---

From: [email-masked]
Date: Thu, 6 Jun 2002 10:10:59 -0600

Julian,
 
I don't think that does it because the text is ambiguous about whether the target could delay sending the tag by sending empty Login Response PDUs when the C bit is set to 0. I suggest:
 
Target portal group tag is a 16-bit numerical-value that uniquely identifies a portal group within an iSCSI target node. This key car-ries the value of the tag of the portal group that is servicing the Login request. The iSCSI target returns this key to the initiator in the Login Response PDU to the first Login Request PDU that has the C bit set to 0. 

Pat
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, June 06, 2002 8:11 AM
To: [email-masked]
Subject: RE: iSCSI: minor conflict introduced by C bit

Target portal group tag is a 16-bit numerical-value that uniquely identifies a portal group within an iSCSI target node. This key car-ries the value of the tag of the portal group that is servicing the Login request. The iSCSI target returns this key to the initiator in the first non-empty Login Response PDU (where empty responses may be required by Login Requests with the C bit set to 1). 

11.4 refers to the Sendtargets response that will be presented whenever and has no other apparent conflict with C. 

Julo 
----- Forwarded by Julian Satran/Haifa/IBM on 06/06/2002 06:06 PM ----- 

	Julian Satran 

06/03/2002 08:21 PM 

        To:        "THALER,PAT (A-Roseville,ex1)" <[email-masked]> 
        cc:        [email-masked] 
        From:        Julian Satran/Haifa/IBM@IBMIL 
        Subject:        RE: iSCSI: minor conflict introduced by C bit Link <Notes:///C225670D0041573F/0D671BC8A76F3374C2256926007869EC/210325502F66C11EC2256BCD005C39DD>  

Thanks Pat - I think that 3 is acceptable and keeps current semantics unchanged. 

Julo 

06/03/2002 07:47 PM 

Julian, 

11.4 and 11.9 require the target to return TargetName and TargetPortal group in the first Login Response PDU but the new text on the C bit in 4.2 requires the target to return an empty response if the C bit is set. Therefore, if the C bit is set on the first Login Request PDU, the target will have conflicting requirements on it. 
  
One could resolve this by: 
1) Specify that the C bit MUST NOT be set in the first Login Request PDU; or 
2) Allow declarations to be sent in PDUs when the other side has the C bit set; or 
3) Change the requirement in 11.4 and 11.9 to be the response to the first Login Request PDU with the C bit set to zero. 
  
Regards, 
Pat

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 6 Jun 2002 22:04:04 +0300

OK - julo

[email-masked]
06/06/2002 07:10 PM
Please respond to pat_thaler

        To:     Julian Satran/Haifa/IBM@IBMIL, [email-masked]
        cc: 
        Subject:        RE: iSCSI: minor conflict introduced by C bit

Julian,
 
I don't think that does it because the text is ambiguous about whether the 
target could delay sending the tag by sending empty Login Response PDUs 
when the C bit is set to 0. I suggest:
 
Target portal group tag is a 16-bit numerical-value that uniquely 
identifies a portal group within an iSCSI target node. This key car-ries 
the value of the tag of the portal group that is servicing the Login 
request. The iSCSI target returns this key to the initiator in the Login 
Response PDU to the first Login Request PDU that has the C bit set to 0. 

Pat
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Thursday, June 06, 2002 8:11 AM
To: [email-masked]
Subject: RE: iSCSI: minor conflict introduced by C bit

Julo 
----- Forwarded by Julian Satran/Haifa/IBM on 06/06/2002 06:06 PM ----- 

Julian Satran 
06/03/2002 08:21 PM 

        To:        "THALER,PAT (A-Roseville,ex1)" <[email-masked]> 
        cc:        [email-masked] 
        From:        Julian Satran/Haifa/IBM@IBMIL 
        Subject:        RE: iSCSI: minor conflict introduced by C bitLink 

Julo 

Julian, 

  
  
Regards, 
Pat