Subject: Another question of the obvious

From: Ken Sandars <[email-masked]>
Date: Tue, 18 Jun 2002 15:39:17 +0000

Hi again,

I've re-re-read (no, not a stutter) the spec and cannot determine the correct 
handling for the LUN field in the Data-In and/or Response pdus.

If an initiator issues a SCSI READ10 command on LUN52 does the target set its 
LUN field in the Data-In pdu to:
(a) 52 (ie same as what the initiator had)
(b) 0   (treating it as reserved)?

And does the target set its LUN field in the Response pdu to:
(a) 52 (ie same as what the initiator had)
(b) 0   (treating it as reserved)?

Could the answers to the above change for different SCSI Commands?

TIA,
Ken

-- 
Ken Sandars
Eurologic Systems Ltd
[email-masked]

---

From: "John Hufferd" <[email-masked]>
Date: Tue, 18 Jun 2002 09:43:56 -0700

The general answer to your questions is "b." in both cases.  The SCSI
Response PDU only shows that field as Reserved (with no other options).
The only time that the LUN field is used with Data-In PDUs, is in
relationship to setting the A-bit.  In that case it is set along with the
TTT so that it can be returned with the SNACK.

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

Ken Sandars <[email-masked]>@ece.cmu.edu on 06/18/2002 08:39:17 AM

Sent by:    [email-masked]

To:    [email-masked]
cc:
Subject:    Another question of the obvious

Hi again,

I've re-re-read (no, not a stutter) the spec and cannot determine the
correct
handling for the LUN field in the Data-In and/or Response pdus.

If an initiator issues a SCSI READ10 command on LUN52 does the target set
its
LUN field in the Data-In pdu to:
(a) 52 (ie same as what the initiator had)
(b) 0   (treating it as reserved)?

TIA,
Ken

--
Ken Sandars
Eurologic Systems Ltd
[email-masked]