Subject: Re: target reset

From: Michael Morrison <[email-masked]>
Date: 12 Jun 2002 09:34:39 -0400

Sorry for being obtuse, but I don't understand your response.

Are you saying 'yes, cancel all operations == clear task set
description'
- or -
'yes, the statement has another meaning'

On Wed, 2002-06-12 at 09:15, Julian Satran wrote:
    yes it means cancel all operations - look for the fine differences
    on cancelling other initiators tasks.
    That is a SAM issue that we don't want to touch!
    
    Julo

    
    Michael Morrison
    <[email-masked]>
    Sent by:
    [email-masked]
    
    06/12/2002 02:04 AM
    Please respond to
    Michael Morrison

            To:      
    iSCSI
    <[email-masked]>
            cc:        
            Subject:      
    target reset

    
    On page 148 of draft 12-97, in the paragraph ...
    
    "For the TARGET WARM RESET and TARGET COLD RESET functions, the
    target
    cancels all pending operations.  Both functions are equivalent to
    the
    Target Reset function specified by [SAM2].  They can affect many
    other
    initiators"
    
    In these cases, SAM2 refers to Logical Unit Reset, which refers to
    Aborting Tasks.
    
    This implies to me that TARGET RESET (WARM or COLD) is equivalent to
    CLEAR TASK SET.  The behavior in the iSCSI draft for CLEAR TASK SET
    is
    fairly well described.  Is the
    description presented in the discussion on CLEAR TASK SET supposed
    to
    define "cancels all pending operations?"  Or does this statement
    have
    another meaning?

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 12 Jun 2002 16:15:23 +0300

yes it means cancel all operations - look for the fine differences on 
cancelling other initiators tasks.
That is a SAM issue that we don't want to touch!

Julo

Michael Morrison <[email-masked]>
Sent by: [email-masked]
06/12/2002 02:04 AM
Please respond to Michael Morrison

        To:     iSCSI <[email-masked]>
        cc: 
        Subject:        target reset

"For the TARGET WARM RESET and TARGET COLD RESET functions, the target
cancels all pending operations.  Both functions are equivalent to the
Target Reset function specified by [SAM2].  They can affect many other
initiators"

This implies to me that TARGET RESET (WARM or COLD) is equivalent to
CLEAR TASK SET.  The behavior in the iSCSI draft for CLEAR TASK SET is
fairly well described.  Is the
description presented in the discussion on CLEAR TASK SET supposed to
define "cancels all pending operations?"  Or does this statement have
another meaning?

--
Michael Morrison
[email-masked]
ISTOR Networks
7585 Irvine Center Dr. Ste 250
Irvine Ca. 92618
PGP Key ID:
http://pgp.mit.edu:11371/pks/lookup?search=0x74C30155&op=index

#### signature.asc has been removed from this note on June 12 2002 by 
Julian Satran