Subject: SCSI-Target ID in ISCSI

From: "shesha bhushan" <[email-masked]>
Date: Fri, 14 Jun 2002 21:19:57 +0000

Hi All,
  I have a disk array. Each disk in that array has a saperate ID. The 
devices are internally conncted using SCSI. If I have iSCSI HBA on the 
array, (with a router attached to it). The router will have an IP address. 
Say IP Address + target ID indentifies uniquily a disk.

How is the SCSI-Target ID(NOT the LUN#) is transmitted from the 
iSCSI-Initiator to the iSCSI-Target.

Thanks in advance for any of your comments
Shesha

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

---

From: [email-masked]
Date: Fri, 14 Jun 2002 18:19:05 -0400

The value of the iSCSI TargetName key names the iSCSI Target;
your disk array implementation is responsible for keeping an
internal mapping of how its internal SCSI Target IDs correspond
to the externally visible iSCSI TargetNames.  --David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: shesha bhushan [mailto:[email-masked]]
> Sent: Friday, June 14, 2002 5:20 PM
> To: [email-masked]
> Subject: SCSI-Target ID in ISCSI
> 
> 
> Hi All,

---

From: "ERICKSON,SHAWN (HP-Roseville,ex1)" <[email-masked]>
Date: Fri, 14 Jun 2002 15:20:15 -0700

Not sure I follow... it this array wanting to act as a JBOD or some type of
RAID device?

In other words are clients expecting to connect to your array at its IP
address and talk to a logical unit identified by a LUN, with the LU being
synthesized by hardware in the array out of one or more of the internal SCSI
disks?

Or are they expecting to talk with the individual SCSI disks in the "array"
over iSCSI?

-Shawn

-------------------------------------------------------
 Shawn Carl Erickson           (805) 883-4319 [Telnet]
 Hewlett Packard Company         OV NSSO Joint Venture
  Storage Resource Management R&D Lab (Santa Barbara)
-------------------------------------------------------
            <http://ecardfile.com/id/shawnce>
-------------------------------------------------------

> Sent: Friday, June 14, 2002 2:20 PM
> To: [email-masked]

---

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Tue, 18 Jun 2002 11:23:37 -0600

Shesha,

I'm not clear on why you bring a router and its IP address into this question. An iSCSI server or client (HBA) will have an IP address (or in some cases it may have multiple IP addresses). 

An iSCSI server may contain multiple targets but when an iSCSI session is created, the initiator identifies the target for that session using the iSCSI Target name. Once that session is created, the target is accessed using SCSI commands and the process of reading disk or LUN identifications would be done the same as over any other SCSI transport. 

Pat 

-----Original Message-----
From: shesha bhushan [mailto:[email-masked]]
Sent: Friday, June 14, 2002 2:20 PM
To: [email-masked]
Subject: SCSI-Target ID in ISCSI

Hi All,