Subject: Re: MaxRecvPDULength question

From: "Julian Satran" <[email-masked]>
Date: Mon, 10 Jun 2002 19:01:37 +0300

Bob - you had your other voice! - Julo

Ken Sandars <[email-masked]>
06/10/2002 07:49 PM
Please respond to Ken Sandars

        To:     Julian Satran/Haifa/IBM@IBMIL, "Robert D. Russell" <[email-masked]>
        cc:     [email-masked]
        Subject:        Re: MaxRecvPDULength question

Hi Julo & Bob,

I support Bob on this change to the completely unambiguous 

      "MaxRecvDataSegmentLength"

Cheers,
Ken

-- 
Ken Sandars
Eurologic Systems Ltd
[email-masked]

On Monday 10 June 2002 1:51 pm, Julian Satran wrote:
> Bob,
>
>  I can do that too - and if we wait for consensus for a name - well that
> will be forever.
> So  if at least one more person wants the change and nobody is against 
we
> will have it as you wish if not then not.
>
> Julo
>
>
>
>
> "Robert D. Russell" <[email-masked]>
> 06/10/2002 10:42 AM
> Please respond to "Robert D. Russell"
>
>
>         To:     Julian Satran/Haifa/IBM@IBMIL, <[email-masked]>
>         cc:
>         Subject:        Re: MaxRecvPDULength question
>
>
>
>
> Julian:
>
> It has been stated several times that at this late stage we
> should not be requesting changes that are just preferences.
>
> Nevertheless, due to apparent misunderstandings of its meaning,
> the key named MaxRecvPDULength in draft 12 is apparently going
> to have its name changed in draft 13.
>
> Fine.  No problem.
>
> However, to remove all possibility of future misunderstandings,
> why don't we give it a name that says precisely what it is:
>
> MaxRecvDataSegmentLength
>
> That way, the first sentence in the third paragraph of section
> 9.7.1 would begin:
>
> "DataSegmentLength MUST not exceed MaxRecvDataSegmentLength
>  for the direction it is sent ..."
>
> which seems to me to be the classic definition of a maximum.
>
> The issue of changing the name from MaxRecvPDULength started with an
> e-mail sent by Luben Tuikov on 21 May (who, by the way, did NOT want
> to change the name, just its meaning), and was followed by a short
> flurry of e-mails under the thread "MaxRecvPDULength question".
>
> Some of the names suggested on that thread were:
>   MaxRecvDataLength        (21 May by Paul Konig)
>   MaxRecvDataSegmentSize   (21 May by Pat Thaler)
>   MaxRecvDataSegSize       (21 May by Pat Thaler)
>   MaxRecvPDUDataSize       (22 May by Pat Thaler)
>
> and what got into the draft was this last suggestion by Pat.
>
> I don't believe there was a consensus for this choice (probably, as
> was stated by Pat several times, because most people don't really see
> the need for a renaming and didn't bother to participate in the thread).
> Therefore, I would ask you to reconsider the new name and ask for
> consensus on the new choice.
>
> I believe the name MaxRecvDataSegmentLength is so closely linked to the
> name DataSegmentLength that its meaning should be clear to even a
> first-time reader, especially given the statement in section 9.7.1
> quoted above.
>
> Furthermore, there clearly is the concept of DataSegmentLength elsewhere
> in the standard -- every PDU has a DataSegmentLength field.
> I could find no concept of PDUDataSize (or even "data size") elsewhere 
in
> the current draft.
>
>
> Whether or not this renaming happens (again), I believe there should be
> the following rewordings to be more precise in order to avoid any
> ambiguities and/or future misinterpretations.
>
> The first sentence in section 9.10.5 should be changed to read:
>
>  "The DataSegmentLength in a Text Request MUST NOT exceed the
>  iSCSI target's MaxRecvDataSegmentLength (a per connection and per
>  direction negotiated parameter)."
>
> and the first sentence in section 9.11.6 should be changed to read:
>
>  "The DataSegmentLength in a Text Request MUST NOT exceed the
>  iSCSI initiator's MaxRecvDataSegmentLength (a per connection and per
>  direction negotiated parameter)."
>
> Finally, two sentences in section 11.13 should be changed to read:
>
>  "The initiator or target declares the maximum DataSegmentLength in
>  bytes it can receive in an iSCSI PDU."
>
> and
>
>  "The transmitter (initiator or target) is required to send PDUs with a
>  DataSegmentLength not exceeding MaxRecvDataSegmentLength of the
> receiver."
>
>
> Thank you for your consideration,
>
>
> Bob Russell
> InterOperability Lab
> University of New Hampshire
> [email-masked]
> 603-862-3774

---

From: Eddy Quicksall <[email-masked]>
Date: Mon, 10 Jun 2002 16:58:06 -0400

Below it says:

 "The DataSegmentLength in a Text *Request* MUST NOT exceed the
 iSCSI initiator's MaxRecvDataSegmentLength (a per connection and per
 direction negotiated parameter)."

But it seems it should say "Response".

Eddy

-----Original Message-----
From: Robert D. Russell [mailto:[email-masked]]
Sent: Monday, June 10, 2002 3:43 AM
To: [email-masked]; [email-masked]
Subject: Re: MaxRecvPDULength question

Julian:

Fine.  No problem.

MaxRecvDataSegmentLength

Furthermore, there clearly is the concept of DataSegmentLength elsewhere
in the standard -- every PDU has a DataSegmentLength field.
I could find no concept of PDUDataSize (or even "data size") elsewhere in
the current draft.

and

 "The transmitter (initiator or target) is required to send PDUs with a
 DataSegmentLength not exceeding MaxRecvDataSegmentLength of the receiver."

Bob Russell
InterOperability Lab

---

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Wed, 12 Jun 2002 17:40:57 -0600

Robert,

The reason for size rather than length in the name is that the other parameters limiting length/size of data transfers use size (MaxBurstSize and FirstBurstSize). I don't really care whether "size" or "length" is used to describe the number of bytes sent, but we should consistantly use the same term for the same meaning. 

The rest of the document uses a mix of length and size. Length appears more frequently (largely because of its use in field names in packet formats), but size predominates in the key names where a change affects implementations.

Regards,
Pat

-----Original Message-----
From: Eddy Quicksall [mailto:[email-masked]]
Sent: Monday, June 10, 2002 1:58 PM
To: Robert D. Russell; [email-masked]; [email-masked]
Subject: RE: MaxRecvPDULength question

Below it says:

Eddy

-----Original Message-----
From: Robert D. Russell [mailto:[email-masked]]
Sent: Monday, June 10, 2002 3:43 AM
To: [email-masked]; [email-masked]
Subject: Re: MaxRecvPDULength question

Julian:

Fine.  No problem.

MaxRecvDataSegmentLength

and

Bob Russell
InterOperability Lab

---

From: Eddy Quicksall <[email-masked]>
Date: Mon, 10 Jun 2002 16:58:06 -0400

Below it says:

Eddy

-----Original Message-----
From: Robert D. Russell [mailto:[email-masked]]
Sent: Monday, June 10, 2002 3:43 AM
To: [email-masked]; [email-masked]
Subject: Re: MaxRecvPDULength question

Julian:

Fine.  No problem.

MaxRecvDataSegmentLength

and

Bob Russell
InterOperability Lab