Subject: RE: Question regarding SNACK and bidi transfers

From: Eddy Quicksall <[email-masked]>
Date: Wed, 19 Jun 2002 06:11:52 -0400

Julo,

Since the answer to the 2nd question is "yes" (see your EMAIL with subject
"Emailing: msg10874.txt"), then I think the spec should make that more clear
in sections 9.8.1 and 9.7.

Perhaps in section 9.8.1, it should say something like "Except, when used
with a bidirectional command and SNACK is being supported, the R2TSN must
start with a number that couples the R2TSN and DataSN together as one
continuous sequence". And a similar statement added to 9.7.

Eddy

-----Original Message-----
From: Bill Studenmund [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 7:56 PM
To: [email-masked]
Subject: Question regarding SNACK and bidi transfers

I have a question about SNACK type 0 requests. In the text, they are
described as being for Data-In PDUs or R2T PDUs.

For a bidi command, how do you know which? Does this mean that for a bidi
command, data-in and R2TSNs have to be mutually-unique (i.e. drawn from
the same pool)?

Take care,

Bill

---

From: Bill Studenmund <[email-masked]>
Date: Wed, 19 Jun 2002 09:03:35 -0700 (PDT)

> continuous sequence". And a similar statement added to 9.7.

I'm curious about the use of except. I would think that bidi commands are
the very time we would have both R2TSN and DataSN in use at once. ??

Take care,

Bill

---

From: Bill Studenmund <[email-masked]>
Date: Wed, 19 Jun 2002 08:57:36 -0700 (PDT)

On Wed, 19 Jun 2002, Amir Shalit wrote:

> How do you "couple" R2TSN and DataSN together? Would it be better
> using an option bit indicating what we are asking for?

Well, I'm not Eddie, but I envision it as you have a counter that you
start at zero. You grab the current value & incriment each time you number
a data-in pdu or you need an R2TSN. That way a SNACK number refers to
either a DATA-IN or an R2T PDU.

Take care,

Bill

---

From: "Amir Shalit" <[email-masked]>
Date: Wed, 19 Jun 2002 08:44:14 -0700

Eddy,

Amir

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Eddy Quicksall
Sent: Wednesday, June 19, 2002 3:12 AM
To: [email-masked]
Cc: [email-masked]; Bill Studenmund
Subject: RE: Question regarding SNACK and bidi transfers

Julo,

Eddy

-----Original Message-----
From: Bill Studenmund [mailto:[email-masked]]
Sent: Tuesday, June 18, 2002 7:56 PM
To: [email-masked]
Subject: Question regarding SNACK and bidi transfers

Take care,

Bill

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 19 Jun 2002 10:34:22 -0700

Section 2.2.2.3 of rev13 currently says the following, which seems the right
place for specifying this. 

"For bidirectional commands, the target uses the DataSN/R2TSN to sequence
Data-In and R2T PDUs in one continuous sequence (undifferentiated)."
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668 
Roseville CA 95747
[email-masked]