Subject: iSCSI: length and size

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Fri, 14 Jun 2002 17:50:37 -0600

Julian,

iSCSI-13 uses "length" quite a bit more than 100 times. Many of those times are in regard to the length of data, headers, and PDUs 

e.g.
The basic header segment has a fixed length of 48 bytes.
Expected Data Transfer Length
Each PDU contains the payload length and the data offset....

It also uses size about 40 times with the same meaning as length. Most of these are the terms MaxBurstSize and FirstBurstSize and text associated with those terms.

It would be better (less likely to confuse readers and better for those of us who look for information using search tools) to choose one of those terms and always use it when talking about length/size. I don't care which is chosen.

Pat

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 15 Jun 2002 19:05:50 +0300

Pat,

Is this a wish or an issue for the WG last call?

Julo

"THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Sent by: [email-masked]
06/15/2002 02:50 AM
Please respond to "THALER,PAT (A-Roseville,ex1)"

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        iSCSI: length and size

Julian,

iSCSI-13 uses "length" quite a bit more than 100 times. Many of those 
times are in regard to the length of data, headers, and PDUs 

e.g.

It also uses size about 40 times with the same meaning as length. Most of 
these are the terms MaxBurstSize and FirstBurstSize and text associated 
with those terms.

It would be better (less likely to confuse readers and better for those of 
us who look for information using search tools) to choose one of those 
terms and always use it when talking about length/size. I don't care which 
is chosen.

Pat

---

From: [email-masked]
Date: Mon, 17 Jun 2002 10:14:43 -0600

Julian, It is an issue for last call. Pat
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Saturday, June 15, 2002 9:06 AM
To: THALER,PAT (A-Roseville,ex1)
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: length and size

Pat, 

Julo 

06/15/2002 02:50 AM 

Julian,

e.g.

Pat

---

From: "Julian Satran" <[email-masked]>
Date: Mon, 17 Jun 2002 19:54:18 +0300

I personally find this as an abuse of the last call process.

Julo

[email-masked]
06/17/2002 07:14 PM
Please respond to pat_thaler

        To:     Julian Satran/Haifa/IBM@IBMIL, [email-masked]
        cc:     [email-masked], [email-masked]
        Subject:        RE: iSCSI: length and size

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Saturday, June 15, 2002 9:06 AM
To: THALER,PAT (A-Roseville,ex1)
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: length and size

Pat, 

Julo 

Julian,

e.g.

Pat

---

From: [email-masked]
Date: Mon, 17 Jun 2002 15:30:35 -0600

I don't understand why you find that.
 
Pat
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Monday, June 17, 2002 9:54 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: iSCSI: length and size

Julo 

	[email-masked] 

06/17/2002 07:14 PM 

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Saturday, June 15, 2002 9:06 AM
To: THALER,PAT (A-Roseville,ex1)
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: length and size

Pat, 

Julo 

06/15/2002 02:50 AM 

Julian,

e.g.

Pat

---

From: [email-masked]
Date: Tue, 18 Jun 2002 19:41:05 -0400

Julian,
 
I tend to agree with Pat - this is an editorial issue
regarding clarity of the document, and raising it is not
abuse of the WG Last Call process.  It's ok to raise
the issue - given your (document editor/primary author)
reluctance to make the requested change, the WG co-chairs
will have to make a decision about how to resolve this
(probably around the end of the Last Call period) - one
possible resolution is to decide that the document is ok
without the change.
 
BTW - this is a general principle of WG Last Call - the
WG co-chairs have some discretion (particularly with editorial
comments) in deciding whether an issue raised during WG
Last Call requires changes in the draft.
 
Thanks,
--David 

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, June 17, 2002 5:31 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: iSCSI: length and size

Pat
 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Monday, June 17, 2002 9:54 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: iSCSI: length and size

Julo 

	[email-masked] 

06/17/2002 07:14 PM 

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Saturday, June 15, 2002 9:06 AM
To: THALER,PAT (A-Roseville,ex1)
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: length and size

Pat, 

Julo 

06/15/2002 02:50 AM 

Julian,

iSCSI-13 uses "length" quite a bit more than 100 times. Many of those times
are in regard to the length of data, headers, and PDUs 

e.g.

It also uses size about 40 times with the same meaning as length. Most of
these are the terms MaxBurstSize and FirstBurstSize and text associated with
those terms.

It would be better (less likely to confuse readers and better for those of
us who look for information using search tools) to choose one of those terms
and always use it when talking about length/size. I don't care which is
chosen.

Pat