Subject: RE: Emailing: msg10855.txt

From: [email-masked]
Date: Wed, 19 Jun 2002 11:30:57 -0600

Julian,
 
I don't think it is a misreading of the text. I will try restating the question.
 
You say below "the barrier "stays"  while the connection is operational and will be "removed" if the connection goes away.
 
Does "the connection goes away" mean that the connection state machine leaves S5: LOGGED_IN state or does it mean that the connection state machine has returned to S1: FREE state?
 
Pat

-----Original Message-----
From: Juian Satran (Hotmail) [mailto:[email-masked]]
Sent: Wednesday, June 19, 2002 8:41 AM
To: ips
Cc: Juian Satran (Hotmail)
Subject: Emailing: msg10855.txt

Pat,
 
Your "issue" with operational is probably related to a missreading of the text.
The barrier (dissalow wrapping) is on CmdSN. CmdSN advances accross al connections  but the barrier "stays"  while the connection is operational and will be "removed" if the connection goes away.
The barrier is there to avoid stale commands popping-up at the target after a recovery.
 
Julo

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 19 Jun 2002 12:40:31 -0700

Pat,

The answer is the latter - initiator connection state machine must return
to S1 (FREE) before the barrier is removed.  An explanation follows.

The reason behind the rule was to ensure that a target doesn't see a stale
command (which was in fact a retry of an old command delivered at just
the wrong time).  A target would continue to "see" commands arriving
on a connection as long as the *target's* connection state machine is
in LOGGED_IN (even after the initiator's connection state machine
may have transitioned to CLEANUP_WAIT, say on a local NIC failure).
For this reason, initiator must ensure that the connection state machine
transitions to FREE (going through the connection cleanup state diagram),
before advancing the CmdSN window.

May be we should replace the phrase "if the connection is still operational,"
with "if the connection is in the LOGGED_IN state or the connection cleanup
(see Section 5.2) is not complete,".

Thanks.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
[email-masked]

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Wednesday, June 19, 2002 10:30 AM
Subject: RE: Emailing: msg10855.txt

> Does "the connection goes away" mean that the connection state machine leaves S5: LOGGED_IN state or does it
mean that the connection state machine has returned to S1: FREE state?
> The barrier (dissalow wrapping) is on CmdSN. CmdSN advances accross al connections  but the barrier "stays"
while the connection is operational and will be "removed" if the connection goes away.