Subject: RE: iSCSI: FirstBurstSize and unsolicited data

From: "Julian Satran" <[email-masked]>
Date: Fri, 21 Jun 2002 09:11:33 +0300

Eddy,

I assume you meant EDTL not DSL and then the answer is yes and I again 
forgot to subtract  the immediate. A better formulation would be:

The target reports the "Incorrect amount of data" condition if dur-ing 
data output the total data length to output is greater than 
First-BurstSize and the initiator sent unsolicited non-immediate data but 
the total amount of unsolicited data is different than FirstBurst-Size. 
The target reports the same error when the amount of data sent as a reply 
to an R2T does not match the amount requested.

Julo

"Eddy Quicksall" <[email-masked]>
06/21/2002 12:22 AM
Please respond to "Eddy Quicksall"

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc: 
        Subject:        RE: iSCSI: FirstBurstSize and unsolicited data

Isn't this saying that if DSL > FirstBurstSize, it would be incorrect to 
send non-immediate unsolicited which is not equal to FirstBurstSize?
 
The target reports the "Incorrect amount of data" condition if dur-ing 
data output the total data length to output is greater than 
First-BurstSize, but the initiator sent an amount different than 
FirstBurstSize of unsolicited non-immediate data or the amount of data 
sent as a reply to an R2T does not match the amount requested. 
 
Eddy

---

From: "Nandakumar Ramamurthy" <[email-masked]>
Date: Fri, 21 Jun 2002 14:05:50 +0530

Hi,

I have been following the discussion on this thread.

I still have certain doubts regarding the
conditions I specified in my original mail.

The conditions are :

FirstBurstSize = 64KB
EDTL = 100KB ( EDTL > FirstBurstSize)
MaxRecvDataSegmentLength = 8KB
ImmediateData = Yes
InitialR2T = Yes

In the above case the initiator cannot send unsolicited Data-out PDUs.
Here unsolicited data(ImmediateData) < FirstBurstSize.

Will the target report any error in this case?

The modified text for Section 9.4.6.2 only refers to the cases
where unsolicited Data-outs can be sent.

Please clarify if I am missing something very obvious.

Thanks,
Nandakumar
Member Technical Staff
HCL Technologies, Chennai, INDIA.
http://san.hcltech.com

  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Friday, June 21, 2002 11:41 AM
  Subject: RE: iSCSI: FirstBurstSize and unsolicited data

  Eddy, 

  I assume you meant EDTL not DSL and then the answer is yes and I again forgot to subtract  the immediate. A better formulation would be: 

  The target reports the "Incorrect amount of data" condition if dur-ing data output the total data length to output is greater than First-BurstSize and the initiator sent unsolicited non-immediate data but the total amount of unsolicited data is different than FirstBurst-Size. The target reports the same error when the amount of data sent as a reply to an R2T does not match the amount requested. 

  Julo 

  Isn't this saying that if DSL > FirstBurstSize, it would be incorrect to send non-immediate unsolicited which is not equal to FirstBurstSize? 
    
  The target reports the "Incorrect amount of data" condition if dur-ing data output the total data length to output is greater than First-BurstSize, but the initiator sent an amount different than FirstBurstSize of unsolicited non-immediate data or the amount of data sent as a reply to an R2T does not match the amount requested. 
    
  Eddy