Subject: iscsi: unsolicited data question

From: Dennis Young <[email-masked]>
Date: Tue, 11 Jun 2002 20:20:40 -0700

I have a question which has been asked before, but I couldn't find a direct 
answer in the archive.  The table on page 200 of draft 12 doesn't directly
answer this question either.

The first paragraph on page 36 of draft 12 says "Targets operate in either 
solicitied (R2T) data mode or unsolicited (non R2T) data mode."
tells me that a target, at all times during a data sequence transfer, can be

one or the other, but not both (non R2T for the initial data out, R2T for
the
remaining data).  Is this correct?

Thanks,
Dennis

---snip from an old email dated 3/30/2001---

" Hi Julian 
Sorry if I'm covering old ground... Is it possible to use unsolicited data
for the first burst and then request any remaining data using R2T? For
example, if the target has a previously allocated buffer available (length
defined by FirstBurstSize) for unsolicited data, then once the initiator has
sent unsolicited data up to and including this amount then the remaining
data (if any) can be requested using R2T once the target has the buffer
space available. 
...Matthew Burbridge Hewlett Packard, Bristol Telnet: 312 7010 E-mail:
[email-masked] "

---

From: Priya Viswambharan <[email-masked]>
Date: Wed, 12 Jun 2002 10:04:58 +0530

Hi Dennis,

These parameters ImmediateData and InitialR2T are session 
specific parameters that are negotiated during the Leading 
Only negotiations. Once negotiated they hold true for the 
life of the session because parameters once negotiated 
cannot be renegotiated.

If a target is operating in unsolicited mode, then the 
unsolicited mode is only for the initial data that the 
initiator wants to send to the target. In other words, for 
a target in unsolicited mode, the initiator does not have 
to wait for an R2T from the target to start sending data. 
Such unsolicited data may be sent either in the form of 
immediate data or through DATA Out PDUs. The maximum amount 
of unsolicited data that can be sent is up to the 
FirstBurstSize negotiated. If the initiator has more data 
to send then it must necessarily be solicited by the target 
through R2Ts.

Hope this clarifies.

Thanks
Priya

On Wednesday 12 June 2002 08:50 am, Dennis Young wrote:
> I have a question which has been asked before, but I
> couldn't find a direct answer in the archive.  The table
> on page 200 of draft 12 doesn't directly answer this
> question either.
>
> The first paragraph on page 36 of draft 12 says "Targets
> operate in either solicitied (R2T) data mode or
> unsolicited (non R2T) data mode." tells me that a target,
> at all times during a data sequence transfer, can be
>
> one or the other, but not both (non R2T for the initial
> data out, R2T for the
> Sorry if I'm covering old ground... Is it possible to use
> unsolicited data for the first burst and then request any
> remaining data using R2T? For example, if the target has
> a previously allocated buffer available (length defined
> by FirstBurstSize) for unsolicited data, then once the
> initiator has sent unsolicited data up to and including
> this amount then the remaining data (if any) can be
> requested using R2T once the target has the buffer space
> available.
> ...Matthew Burbridge Hewlett Packard, Bristol Telnet: 312
> 7010 E-mail: [email-masked] "

_________________________________________________
HCL Technologies, Chennai, India
http://san.hcltech.com

---

From: Thanu Skariah <[email-masked]>
Date: Wed, 12 Jun 2002 10:30:37 +0530

A target can operate in nonR2T (unsolicited) mode for initial data out
and 
in solicited mode for the remaining data.
Also if the ImmediateData=Yes is the agreed value during negotiation,
then it will
operate in unsolicited mode upto a data size of negotiated maximum PDU
size.
If during login negotiation, InitialR2T=No is the agreed value, then 
the initiator and the target will operate in unsolicited mode upto a
data size of 
negotiated FirstBurstSize.
If InitialR2T is Yes, and immediate data also yes, then target can
operate in nonR2T
mode for a size of data upto the maxmimum PDU size only.
If initialR2T is yes and immediate data is no, then the target cannot
operated in
nonR2T mode at all. All the data must be solicited in this case.
(draft - 12.97,Sec 2.2.3, page 35, last paragraph)

Thanks,
Thanu

-- 
Thanu Skariah
Member Technical Staff
HCL Technologies
http://san.hcltech.com