Subject: iSCSI: FirstBurstSize and unsolicited data

From: "Nandakumar Ramamurthy" <[email-masked]>
Date: Fri, 14 Jun 2002 16:45:56 +0530

Hi All,

Consider the case where InitialR2T=yes and ImmediateData=yes.
All other values are the defaults.

The expected data transfer length for a SCSI write
operation is a value exceeding FirstBurstSize (64KB).

In the above case, the initiator will send immediate
unsolicited data (MaxRecvPDULength=8192 bytes).
After that it has to wait for an R2T from the target.

In this scenario, FirstBurstSize of data will not be sent
to the target as unsolicited data-out's cannot be sent here.

My understanding is that the remaining data can be
sent only through solicited Data-out PDUs,
and this is the expected way according to the draft.

What does the following statement(in Section 9.4.6.2 Sense Data) mean in
this context ?

<quote>

The target reports the "Not enough unsolicited data" condition only
if it does not support output (write) operations in which the total

data length is greater than FirstBurstSize, but the initiator sent

less than FirstBurstSize amount of unsolicited data, and out-of-order

R2Ts cannot be used.

</quote>

If this is specific to the SCSI layer at the target,
what is the dependency on FirstBurstSize?

Please clarify.

Thanks,
Nandakumar
Member Technical Staff
HCL Technologies, Chennai, INDIA.
http://san.hcltech.com

---

From: Bill Studenmund <[email-masked]>
Date: Fri, 14 Jun 2002 10:22:00 -0700 (PDT)

> After that it has to wait for an R2T from the target.

That is correct.

> less than FirstBurstSize amount of unsolicited data, and out-of-order

I think what that's getting at is if you do a write command and send
unsolicited data-out PDUs, you've promised to send FirstBurstSize worth of
data. If you don't, to continue the operation, the target needs to send an
R2T for the missing data. But that would be an out-of-order R2T since by
sending unsolicited data, you are acting as if you received an R2T for
FirstBurstSize data; this error R2T would be going backwards.

Take care,

Bill