Subject: Re: iSCSI: response reason

From: "Julian Satran" <[email-masked]>
Date: Fri, 7 Jun 2002 17:07:29 +0300

thanks - it is fixed in 12-97 - Julo

                      "Eddy Quicksall"                                                                                                         
                      <[email-masked]        To:       Julian Satran/Haifa/IBM@IBMIL                                                         
                      om>                      cc:       <[email-masked]>                                                                     
                                               Subject:  iSCSI: response reason                                                                
                      06/06/2002 11:28                                                                                                         
                      PM                                                                                                                       
                      Please respond to                                                                                                        
                      Eddy                                                                                                                     

Section 6.5 Digest Errors uses the phrase "iSCSI response reason" and
refers to section 9.4.3. But there is no such term used in that section.

There is, however, a term used called "iSCSI service response". But,
section 6.5 is not talking about that.

I believe section 6.5 is talking about the heading "reason" that appears in
the 1st column of the table in section 9.4.6.2.

So to clarify things, how about changing the table heading in 9.4.6.2 to
say "iSCSI Condition" and section 6.5 to say "iSCSI Condition (Section
9.4.6.2  Sense Data)?

The term "iSCSI Condition" is also compatible with the same term used in
the 2nd paragraph of 9.4.6.2.

Eddy

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 7 Jun 2002 14:26:13 -0700

Julian,

I was about to send a message to you on this myself.

I think it's better to leave the wording in 12-96 as is, and
change the "Reason" to "Response reason" in the table in
section 9.4.6.2.

The problem with the changed wording in 12-97 is that
it still does not mention the sense key, and states something
that isn't accurate (for ex., there is no 'Sense of "protocol
service CRC error" ', the SPC-3 name for it is "CRC error
detected").  The more descriptive "reason" terminology is
an iSCSI notion we had adopted quite a while ago.

I reason I had used "Response reason" as in index into the
said table is to avoid repeating the CHECKCONDITION/Key/
ASC/ASCQ information everywhere - but I had overlooked that the
table doesn't use "response reason".  I'd recommend fixing just
that.

Thanks.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
[email-masked]