Subject: RE: iSCSI: draft vs. 14 typos, suggestion, questions

From: [email-masked]
Date: Wed, 3 Jul 2002 12:38:37 -0600

See comment below. Pat
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Wednesday, July 03, 2002 9:20 AM
To: Tomá? Bartu?ek
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: draft vs. 14 typos, suggestion, questions

*** Section 6.11 : QUESTION
Draft says:
  When the session timeout (the connection state timeout for the last
  failed connection) happens on the target, it takes the following
  actions:

    - Resets or closes the TCP connections (closes the session).
    - Aborts all Tasks in the task set for the corresponding initi-
      ator.

What does the "corresponding initiator" mean? We think (:-)), that
there is only one initiator for the session. The only possible
explanation we see for that paragraph is, that the target should
abort also other tasks of the same in __other__ sessions, but
why?
+++ your interpretation is correct - the statement means the initiator that "owned" the session. 
Are you suggesting other wording?   
++++ 
<PAT> "Aborts all task sets associated with the session" 
(Task set was changed to plural because task set is defined as an I-T-L nexus and there may be muliple ones in the session. <PAT>

---

From: "Julian Satran \(Actcom\)" <[email-masked]>
Date: Fri, 5 Jul 2002 07:08:26 +0300

I will do the text change (I hope it makes it easier for at least one reader
is not worse for anybody else).
The reason why we choose the wording was that SAM associates the task set
with an initiator by the session is wording is equivalent.

Julo
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, July 03, 2002 9:38 PM
Subject: RE: iSCSI: draft vs. 14 typos, suggestion, questions

> (Task set was changed to plural because task set is defined as an I-T-L
nexus and there may be muliple ones in the session. <PAT>

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 10 Jul 2002 16:38:39 -0700

Sorry, I'm catching up late on email....

I see that the latest wording on this is -

When the session timeout (the connection state timeout for the last failed connection) happens on the target,
it takes the following actions:
- Resets or closes the TCP connections (closes the session).
- Aborts all Tasks in the task set associated with the session.

I think the second bullet is incorrect.  While the previous wording had the
issue that Pat identified (that there may be one task set for each LU the session
can get to), the new wording still has that issue and in addition, also implies that
all tasks in the task set need to be terminated.  However, a LU may maintain only one
task set for multiple initiators (if TST=0 in control mode page) in which case, the
current wording implies that all tasks from other initiators need to be terminated
as well on one session timeout - which is not intended.

I am beginning to think that the notion of "task set" is beyond iSCSI and it's best
not to refer to it here.

I suggest the following text instead -

When the session timeout (section 4.3.5) happens on the target, it takes the following actions:
- Resets or closes the TCP connections (closes the session).
- Terminates all active tasks that were allegiant to the connection(s) that constituted the session.

Thanks.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
[email-masked]