Subject: iSCSI: DLB-T.17 (format error description)

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 9 Jul 2002 12:01:09 -0700

> [T.17]  6.4  Format Errors
>
>    The following two explicit violations of PDU layout rules are format
>    errors:
>
>         a)  illegal contents of the PDU header (except the Opcode) - for
>         ex., out-of-range values for certain fields
>         b)  inconsistent contents - for ex., value of one field conflicts
>         with that of another.
>
>    Format errors indicate a major implementation flaw in one of the par-
>    ties.
>
> The two "for ex."s aren't good enough.  Details on what is a format error
> need
> to be spelled out explicitly, given the drastic consequences of committing
> one.

I agree that the "for ex."s are not quite reassuring.  However, I believe those
are all that might happen in each class, so I don't want to remove them either.

I suggest the following text as the replacement -

------------------------------
6.4  Format Errors

   The following two explicit violations of PDU layout rules are format
   errors:

        a)  out-of-range values for fields (except the Opcode) in the PDU header
        b)  inconsistent values for fields in the PDU header, where value of one field conflicts with that of
another.

   Format errors indicate a major implementation flaw in one of the parties.

-------------------------------

Mallikarjun

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 10 Jul 2002 07:54:00 +0300

I would add also a reference to 9 (as the working draft has already :-))
Julo

                      "Mallikarjun C."                                                                                                      
                      <[email-masked]>        To:       <[email-masked]>                                                                  
                      Sent by:                 cc:                                                                                          
                      [email-masked]        Subject:  iSCSI: DLB-T.17 (format error description)                                         
                      .edu                                                                                                                  

                      07/09/2002 10:01                                                                                                      
                      PM                                                                                                                    
                      Please respond to                                                                                                     
                      "Mallikarjun C."                                                                                                      

> to be spelled out explicitly, given the drastic consequences of
committing

I agree that the "for ex."s are not quite reassuring.  However, I believe
those
are all that might happen in each class, so I don't want to remove them
either.

        a)  out-of-range values for fields (except the Opcode) in the PDU
header
        b)  inconsistent values for fields in the PDU header, where value
of one field conflicts with that of
another.

   Format errors indicate a major implementation flaw in one of the
parties.

Mallikarjun