Subject: iSCSI: strengthening queue condition on pg 37 [v 15]

From: Luben Tuikov <[email-masked]>
Date: Thu, 25 Jul 2002 20:54:31 -0400

The condition on page 37:

-If the PDU MaxCmdSN is less than the PDU ExpCmdSN-1 (in Serial
Arithmetic Sense), they are both ignored.

can be strengthened by specifying ``less than or equal''.
Then and only then is the queue size > 0.

-- 
Luben

P.S. Proof: Ignore* if  maxcmdsn <= expcmdsn-1.
Thus accept if maxcmdsn > expcmdsn-1,
which is maxcmdsn-expcmdsn+1 > 0,
but maxcmdsn-expcmdsn+1 is the queue size,
so accept* only if queue size > 0.

*Meaning ignore/accept the values of maxcmdsn and expcmdsn.

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 27 Jul 2002 16:37:03 +0300

that is not what the text says - and it is not accidental. Julo

Luben Tuikov <[email-masked]>
Sent by: [email-masked]
07/26/2002 03:54 AM

        To:     iSCSI <[email-masked]>
        cc: 
        Subject:        iSCSI: strengthening queue condition on pg 37 [v 15]

-- 
Luben