Subject: iSCSI: DLB's [T.37] 11.12 ImmediateData

From: "Rod Harrison" <[email-masked]>
Date: Sun, 7 Jul 2002 10:03:11 -0500

David,

	I believe the MAY is to allow the initiator to send no unsolicited
data if it so chooses. For non-immediate unsolicited the rule was the
initiator MUST send all of the unsolicited data possible, or no
unsolicited data. The presence of the F bit in the latter case removes
the possibility of any confusion over the amount of unsolicited data
at the target.

	- Rod

---

From: [email-masked]
Date: Mon, 8 Jul 2002 10:13:13 -0400

> the possibility of any confusion over the amount of unsolicited data

Yes, you're correct.  Adding a "MUST send all of the unsolicited
data possible" statement and leaving the "MAY"s as they are
would take care of this.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: "Julian Satran" <[email-masked]>
Date: Mon, 8 Jul 2002 21:30:07 +0300

But that statement already appears in 2.2.4  Why repeat it? Julo

[email-masked]
Sent by: [email-masked]
07/08/2002 05:13 PM
Please respond to Black_David

        To:     [email-masked], [email-masked]
        cc: 
        Subject:        RE: iSCSI: DLB's [T.37] 11.12 ImmediateData

Thanks,
--David

---

From: [email-masked]
Date: Tue, 9 Jul 2002 02:28:40 -0400

So the entire specification of how this pair of related features
(immediate data and unsolicited Data-In PDUs) behaves is in
one place.  I think I've seen a suggestion from Brian Forbes
to add subsection headings to 2.2.4 - perhaps a reference
back to the appropriate subsection will do the trick.
 
--David

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Monday, July 08, 2002 2:30 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: iSCSI: DLB's [T.37] 11.12 ImmediateData
Importance: High

	[email-masked] 

07/08/2002 05:13 PM 

Thanks,
--David