Subject: iSCSI: task set notes

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 10 Jul 2002 17:00:07 -0700

Julian,

A couple of other notes on the usage of "task set".  Please consider.

- In section 2.5.1.3,

"The I_T_L nexus identifies task sets and is carried by the LUN (and implied by the session identification)."

  Since an I_T_L nexus identifies only one task set, I suggest the following -

"The affected task set is identified by the I_T_L nexus, which in turn is identified by the LUN and by the
session identification."

- In section 9.5.1,

"4 - CLEAR TASK SET - aborts all Tasks for the Logical Unit."

  should be:

"4 - CLEAR TASK SET - aborts all Tasks in the appropriate task set as defined by the TST field in the Control
mode page ([SPC3])."

Thanks.

Mallikarjun

---

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Wed, 10 Jul 2002 22:19:43 -0400

> - In section 2.5.1.3,
> 
> "The I_T_L nexus identifies task sets and is carried by the 
> LUN (and implied by the session identification)."
> 
> "The affected task set is identified by the I_T_L nexus, 
> which in turn is identified by the LUN and by the
> session identification."

In the above paragraphs, it seems that "I_T nexus identification" should be
substituted for "session identification".

Regards,
Marjorie

---

From: "Julian Satran" <[email-masked]>
Date: Fri, 12 Jul 2002 05:01:20 +0300

thanks - Julo

"KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Sent by: [email-masked]
07/11/2002 05:19 AM
Please respond to "KRUEGER,MARJORIE (HP-Roseville,ex1)"

        To:     "'Mallikarjun C.'" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        RE: iSCSI: task set notes

> which in turn is identified by the LUN and by the

In the above paragraphs, it seems that "I_T nexus identification" should 
be
substituted for "session identification".

Regards,
Marjorie