Subject: RE: iSCSI: DLB's [T.6] 2.3 iSCSI Session Types

From: [email-masked]
Date: Mon, 8 Jul 2002 10:18:38 -0400

Ayman,

Something needs to be cleaned up here, as the current text appears
to allow all types of iSCSI PDUs on a discovery session.  I didn't
intend to restrict a discovery session to one Send Targets followed
by a logout (i.e., it could be kept open with the initiator periodically
sending a new Send Targets to see if anything has changed), but I
did intend to forbid SCSI commands, task management, etc. on Discovery
sessions.  Is that reasonable, or are there additional types of iSCSI
PDUs that you want to see allowed for new device notifications?

Thanks,
--David

> -----Original Message-----
> From: Ayman Ghanem [mailto:[email-masked]]
> Sent: Sunday, July 07, 2002 12:41 PM
> To: [email-masked]
> Subject: RE: iSCSI: DLB's [T.6] 2.3 iSCSI Session Types
> 
> 
> I prefer leaving this as "MAY" for implementations that want 
> to support new
> device notifications. There was a discussion on whether 
> discovery sessions
> should be long-lived or not. Using MAY allows both without 
> breaking any
> thing.
> 
> -Ayman
> 
> > [T.6] 2.3  iSCSI Session Types
> >
> >       b)  Discovery-session - a session opened only for 
> target discov-
> >       ery; the target MAY accept only text requests with 
> the SendTar-
> >       gets key and a logout request with reason "close the session".
> >
> > Change "MAY" to "MUST", and say that other requests MUST be 
> rejected.
> >
>

---

From: "Ayman Ghanem" <[email-masked]>
Date: Mon, 8 Jul 2002 10:53:45 -0500

David,

The issue that came up before was if a discovery session could be kept open,
why not allow the initiator and target to send NOPs, and allow the target to
send Async messages when new targets become available?

I don't mean to bring up this issue again at this stage, but using "MAY"
leaves room for implementations that want to support this. If we allow NOP
and Async PDUs on a discovery session, then changing "MAY" to "MUST" will be
fine.

-Ayman

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, July 08, 2002 9:19 AM
> To: [email-masked]; [email-masked]

---

From: Mark Bakke <[email-masked]>
Date: Mon, 08 Jul 2002 11:22:26 -0500

We could certainly disallow SCSI commands and task management
on discovery sessions, as David suggested.  Perhaps that's
enough.

--
Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054