Subject: RE: iSCSI: reference for CRC32C?

From: [email-masked]
Date: Mon, 29 Jul 2002 18:42:25 -0600

Jonathan, 

That informative reference is already in the draft. It has been in the draft since at least draft 10. Probably an informative reference to draft-sheinwald-iscsi-crc-02.txt which has been submitted to the RFC process would also be enlightening about why we chose to use a CRC and this particular CRC.

I thought Margorie's question was whether a normative reference was needed to fully define the algorithm.

Regards,
Pat

-----Original Message-----
From: Jonathan Stone [mailto:[email-masked]]
Sent: Monday, July 29, 2002 4:51 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: reference for CRC32C? 

In message <[email-masked]>[email-masked] writes
>Margorie,
>
>The text in 11.1 suffices to fully define the algorithm. 

Agreed, It does specify the algorithm. But IMHO the spec should still
cite the original source --- Castagnoli et al. --- because that is the
original source.  And because that's where to start looking, for anyone
who cares about the ins and outs of the specific choice of algorithm.

The citation i have  handy is:
@Article{castagnoli-crc,
  author =       { Guy Castagnoli and Stefan Braeuer and Martin Herrman},
  title =        {{Optimization of Cyclic Redundancy-Check Codes with 24
                  and 32 Parity Bits}},
  journal =      IEEE Transactions on Communication,
  year =         {1993},
  volume =       {41},
  number =       {6},
  pages =        {},
  month =        {June},
}

(I have a hardcopy, with page numbers, if I can find it.)

---

From: Jonathan Stone <[email-masked]>
Date: Mon, 29 Jul 2002 17:52:35 -0700

In message <[email-masked]>,
[email-masked] writes:

[....]

>fully define the algorithm.

Oh. That wasn't clear, but you could well be right.

If Julo adds a cross-reference to the sections which already have the
citations, that should cover all bases :)