Subject: iSCSI: Question on login min/Max

From: [email-masked]
Date: Mon, 1 Jul 2002 09:16:58 -0600

Julian,
 
In draft v14, page 210, The following text was added:
 
"Result function wherever mentioned states the function that can be applied to check the validity of the responder selection. Minimum means that the selected value cannot exceed the offered value. Maximum means that the selected value cannot be lower than the offered value."
 
What drove this change? This is a departure from what it was previously where we could just take the min/max of the two offered numbers.
 
So if I interpret this correctly, if:
 
Init   -> DefaultTime2Wait=2 (func is Max)
Target -> DefaultTime2Wait=1
 
Init detects an error and closes the TCP connection.
 
Correct?
 
Kevin

---

From: "Julian Satran" <[email-masked]>
Date: Mon, 1 Jul 2002 19:46:46 +0300

Kevin,

That part has some history.

Several drafts ago the selection was "by rule" - i.e., each of the parties 
stated what it wanted and the result was based on the rule (that both 
know).
This scheme, although simple, was felt as unnatural by many readers 
(implementers?) and we changed it to the selection by the responder - 
i.e., the responder selects the "right" value - respecting some rules. 
Obviously then the rule can't be "the maximum/minimum/other  of two 
values" as there are no two values on the wire and I felt that the best 
way to express this is to state the constraint the responder has to 
respect. This was the text you found in draft 13.

Bob Russell felt that a succinct statement stating this restriction in 
line with the Scope, Default etc. will be  simpler to follow and I think 
he is right..
The new text is the one you see in draft 14.  Except for one rule that was 
stated wrong (a typo) and is now corrected there is no difference between 
13 and 14.

And yes your interpretation of the rule is correct - at the sequence you 
show the initiator is supposed to close (protocol error).

Again - we did not have two offered numbers for a long time.

Julo

[email-masked]
07/01/2002 06:16 PM
Please respond to kevin_lemay

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        iSCSI: Question on login min/Max

Julian,

"Result function wherever mentioned states the function that can be 
applied to check the validity of the responder selection. Minimum means 
that the selected value cannot exceed the offered value. Maximum means 
that the selected value cannot be lower than the offered value."
 
What drove this change? This is a departure from what it was previously 
where we could just take the min/max of the two offered numbers.

 
 
Correct?
 
Kevin

---

From: [email-masked]
Date: Mon, 1 Jul 2002 11:08:39 -0600

Kevin,

I don't think the text changed the meaning of the draft. The following was in draft 10 under 2.2.4 Text mode negotiation:
For numerical and single literal negotiations, the responding party
MUST respond with the required key. The value it selects, based on the
selection rule specific to the key, becomes the negotiation result.
The selection of a value not admissible under the selection rules is
considered a protocol error and is handled accordingly.

Your example:
Init   -> DefaultTime2Wait=2 (func is Max)
Target -> DefaultTime2Wait=1
would have been a protocol error and closed the connection under the draft 10 rules and later. (I think this was in earlier drafts as well. I just didn't bother to look farther back.)

The impact of the new text is just editorial.

Regards,
Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 01, 2002 8:17 AM
To: [email-masked]
Cc: [email-masked]
Subject: iSCSI: Question on login min/Max

Julian,

 

 
 
Correct?
 
Kevin