Subject: RE: iSCSI: Invalid PDU before login PDU - what happens

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Thu, 18 Jul 2002 12:52:51 -0700

I guess you can use 0x04 (Protocol Error) for Reject reason.

 -lakshmi

-----Original Message-----
From: LEMAY,KEVIN (A-Roseville,ex1) [mailto:[email-masked]] 
Sent: Thursday, July 18, 2002 11:25 AM
To: [email-masked]; 'Satran, Julian'
Subject: iSCSI: Invalid PDU before login PDU - what happens

What is the correct behavior for a target when an initiator sends a
full-feature phase PDU before the initial login PDU?
 
I believe that this is:
 
i-> Cmd PDU
t-> Login Response - Reject reason = Invalid during login
    FIN
 
but where is it documented in the Spec?
 
Thanks,
 
Kevin

---

From: Parthi <[email-masked]>
Date: Fri, 19 Jul 2002 19:59:06 +0530

Hi :

> I guess you can use 0x04 (Protocol Error) for Reject reason.

Parthi>  target will terminate the connection and the session to
terminate
         if it's the first connection.

> but where is it documented in the Spec?

Parthi>  Draft -v14  6.8  Negotiation Failures says  ( Pg. no  10 9 )
     - During Login, any failure in negotiation MUST be considered a
       login process failure and the Login Phase must be termi-
       nated, and with it the connection. If the target detects the
       failure, it must terminate the login with the appropriate
       login response code.

> Kevin

thanks,
parthi

--
http://san.hcltech.com