Subject: RE: iSCSI: Decimal encoding - why 64 bits ?

From: Robert Snively <[email-masked]>
Date: Fri, 5 Jul 2002 16:37:58 -0700

The most common example would probably be the
IP address, which is a binary value.
It is often presented
as four separate decimal numbers for no reason
I can think of, except perhaps a feeling that
hexadecimal numbers were somehow less user
friendly for inexperienced users.

See RFC 0790 and RFC 0791.

Bob

> -----Original Message-----
> From: Martins Krikis [mailto:[email-masked]]
> Sent: Friday, July 05, 2002 7:42 AM
> To: Julian Satran (Actcom); [email-masked]
> Cc: [email-masked]
> Subject: Re: iSCSI: Decimal encoding - why 64 bits ?
> 
> 
> 
> --- "Julian Satran (Actcom)"
> <[email-masked]> wrote:
> > Martins - you have a very good point - and we
> > considered briefly to forbid
> > decimal from the outset but many of the team felt
> > that this  would be a bad
> > idea as values get copied from a context to another.
> > And the we looked at
> > coding for other RFCs and we found decimal
> > everywhere - addresses,
> > identifiers, ports etc., and thought it would be a
> > bad idea to forbid them
> > in iSCSI
> 
> Julian,
> 
> I cannot find a single post on this mailing list
> saying that forbidding decimal encoding for binary
> items would be a bad idea. I did find several (and
> quoted 4) that actually recommended dropping decimal
> encoding for binary items. Lately there have been
> many more such posts. All those other RFCs, I
> suspect, are actually dealing with numbers. I have
> no objections to using decimal encoding for numbers
> (that is things, that normally fit in your
> machine's registers and are treated as numerical,
> not as bit-strings). You have yet to provide an
> example of something that is clearly a binary
> string (and not used as a number) and is being
> commonly encoded in decimal. If you find such a
> thing, can you tell us what's the scheme for telling
> how many null-bytes this binary string starts with?
> 
> Martins Krikis, Intel Corp.
> 
> Disclaimer: these opinions are mine and may not
>              be those of my employer.
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Sign up for SBC Yahoo! Dial - First Month Free
> http://sbc.yahoo.com
>

---

From: "Julian Satran \(Actcom\)" <[email-masked]>
Date: Sat, 6 Jul 2002 10:24:44 +0300

You may want to add to the list port-numbers, domain specific name formats
(yes some domains mainly phone systems use decimal encodings).

A search for decimal encoded binary strings in the RFC domain gave well over
one-hundred results.

Julo
----- Original Message -----
From: "Robert Snively" <[email-masked]>
To: "'Martins Krikis'" <[email-masked]>; "Julian Satran (Actcom)"
<[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, July 06, 2002 2:37 AM
Subject: RE: iSCSI: Decimal encoding - why 64 bits ?

---

From: "Elizabeth G. Rodriguez" <[email-masked]>
Date: Sat, 6 Jul 2002 09:31:09 -0600

Given these examples, I believe that restricting decimal encoded binary
strings is not an option.

Elizabeth Rodriguez

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Julian Satran (Actcom)
Sent: Saturday, July 06, 2002 1:25 AM
To: Robert Snively; 'Martins Krikis'; [email-masked]
Cc: [email-masked]
Subject: Re: iSCSI: Decimal encoding - why 64 bits ?

You may want to add to the list port-numbers, domain specific name
formats
(yes some domains mainly phone systems use decimal encodings).

A search for decimal encoded binary strings in the RFC domain gave well
over
one-hundred results.

Julo

---

From: Paul Koning <[email-masked]>
Date: Sun, 7 Jul 2002 09:11:25 -0400

> strings is not an option.

Why not?  I don't see that phone numbers have any relevance to the
discussion.  And port numbers (just like IP addresses) are not 64 bit
values, which is what we were talking about.

	    paul