Subject: Re: iSCSI: DLB-T.26 (response for TASK REASSIGN)

From: "Julian Satran" <[email-masked]>
Date: Wed, 10 Jul 2002 07:12:49 +0300

Mallikarjun,

Your suggested text fits better in 6.1 or 8.x. In 9 it clutters the text.

Thanks,
Julo

                      "Mallikarjun C."                                                                                                      
                      <[email-masked]>        To:       <[email-masked]>                                                                  
                      Sent by:                 cc:                                                                                          
                      [email-masked]        Subject:  iSCSI: DLB-T.26 (response for TASK REASSIGN)                                       
                      .edu                                                                                                                  

                      07/09/2002 10:20                                                                                                      
                      PM                                                                                                                    
                      Please respond to                                                                                                     
                      "Mallikarjun C."                                                                                                      

> [T.26] 9.6  Task Management Function Response
>
>    For the functions ABORT TASK, ABORT TASK SET, CLEAR ACA, CLEAR TASK
>    SET, LOGICAL UNIT RESET, TARGET COLD RESET and TARGET WARM RESET, the
>    target performs the requested Task Management function and sends a
>    Task Management Response back to the initiator.
>
> TASK REASSIGN does not get a response.  Was this intended?

It may be appropriate to include it in this list, but then it would be nice
to make sure that the
target sends the response to the TMF first before acting on the reassigned
task (which might
possibly involve retransmitting an old status sent before the connection
failure with a new StatSN).
Initiators may get confused if the response for the reassigned task arrives
prior to the the response
to the TMF itself (even while there are no StatSN holes).

I suggest:

For all the task management functions defined in 9.5.1, the target performs
the requested function and sends a
Task Management Response back to the initiator.  In the case of the TASK
REASSIGN function, the target must
send the reponse to the task management function request first before
acting on the reassigned task.

Mallikarjun

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 10 Jul 2002 11:46:36 -0700

Julian,

I don't want to make an issue of it, but IMHO, since the Task Reassign
TMF causes two task instances in target to go active (the TMF itself, and
the reassigned task), it's best to describe the order of status delivery in
the TMF discussion itself - i.e. 9.6.  It's easy to miss if described elsewhere.

Thanks.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
[email-masked]