Subject: Re: An error message from iscsi target

From: Luben Tuikov <[email-masked]>
Date: Wed, 31 Jul 2002 05:14:44 -0400

Luben Tuikov wrote:
> 
> > James Lee wrote:
> >
> [cut]
> > Mar 23 01:08:28 <K> kernel: iSCSI:Send thread for connection 0 started.
> > Mar 23 01:08:28 <K> kernel: iSCSI:Receive thread for connection 0 started.
> > Mar 23 01:08:45 <K> kernel: iSCSI:Send thread for connection 0 started.
> > Mar 23 01:08:45 <K> kernel: iSCSI:Receive thread for connection 0 started.
> > Mar 23 01:09:04 <K> kernel: iSCSI:Send thread for connection 0 started.
> > Mar 23 01:09:04 <K> kernel: iSCSI:Receive thread for connection 0 started.
> 
> Here I'd assume that you connected to two separate disks, right?
> If not, then the problem starts here.
> 
> > Mar 23 01:24:16 <K> kernel: iSCSI:atomic_count != 0 <======================= HERE
> 
> Yep, this is a problem and if you can reproduce this (very importand to be
> able to do so), then I'd be glad to see how.

Spelling: ``important''. Doh -- I need some sleep.
 
> Once you get this, a kernel panic is imminent sooner or later.

I.e. you better reboot as soon as you see this.

Did you fix the scsi hosts same number problem?

You should eliminate those first before pointing the finger
at the target implementation.

If indeed this is the target implementation and you and I
can separately reproduce this, then I'd be really curious
to see how this happens. I cannot imagine where or how...

Try to reproduce this with 1, then with 2 then with 3 hosts,
etc.

Will check it tomorrow, er, later today.

-- 
Luben Tuikov, Senior Software Engineer, Splentec Ltd.
Bus: +1-905-707-1954x112, 9-5 EST. Fax: +1-905-707-1974.

---

From: Luben Tuikov <[email-masked]>
Date: Wed, 31 Jul 2002 16:34:35 -0400

To those of you who couldn't recognize that I emailed this
to IPS _by__mistake_ at 5 in the morning and who couldn't just
ignore it and move on (as is my experience with other mailing lists),
but had to email me personally asking for explanation:

IGNORE THIS MESSAGE, it was emailed to ips by mistake at 5 in the morning
when I was _extremely_ tired.