Subject: iSCSI: DLB-T.26 (response for TASK REASSIGN)

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 9 Jul 2002 12:20:53 -0700

> [T.26] 9.6  Task Management Function Response
>
>    For the functions ABORT TASK, ABORT TASK SET, CLEAR ACA, CLEAR TASK
>    SET, LOGICAL UNIT RESET, TARGET COLD RESET and TARGET WARM RESET, the
>    target performs the requested Task Management function and sends a
>    Task Management Response back to the initiator.
>
> TASK REASSIGN does not get a response.  Was this intended?

It may be appropriate to include it in this list, but then it would be nice to make sure that the
target sends the response to the TMF first before acting on the reassigned task (which might
possibly involve retransmitting an old status sent before the connection failure with a new StatSN).
Initiators may get confused if the response for the reassigned task arrives prior to the the response
to the TMF itself (even while there are no StatSN holes).

I suggest:

For all the task management functions defined in 9.5.1, the target performs the requested function and sends a
Task Management Response back to the initiator.  In the case of the TASK REASSIGN function, the target must
send the reponse to the task management function request first before acting on the reassigned task.

Mallikarjun

---

From: [email-masked]
Date: Wed, 10 Jul 2002 03:56:44 -0400

Ok with an upper case MUST for sending the TMF response
first, please.  Thanks, --David

> -----Original Message-----
> From: Mallikarjun C. [mailto:[email-masked]]
> Sent: Tuesday, July 09, 2002 3:21 PM
> To: [email-masked]
> Subject: iSCSI: DLB-T.26 (response for TASK REASSIGN)
> 
> 
> Initiators may get confused if the response for the 
> reassigned task arrives prior to the the response
> For all the task management functions defined in 9.5.1, the 
> target performs the requested function and sends a
> Task Management Response back to the initiator.  In the case 
> of the TASK REASSIGN function, the target must
> send the reponse to the task management function request 
> first before acting on the reassigned task.
> 
> 
> Mallikarjun

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 10 Jul 2002 18:02:05 +0300

As before - there is already text and commented issue dealing with that.
Julo

                      [email-masked]                                                                                                     
                      om                       To:       [email-masked], [email-masked]                                                   
                      Sent by:                 cc:                                                                                          
                      [email-masked]        Subject:  RE: iSCSI: DLB-T.26 (response for TASK REASSIGN)                                   
                      .edu                                                                                                                  

                      07/10/2002 10:56                                                                                                      
                      AM                                                                                                                    
                      Please respond to                                                                                                     
                      Black_David