Subject: RE: iSCSI: DLB-T.16 (resource requirement for connection reinsta tement)

From: [email-masked]
Date: Wed, 10 Jul 2002 03:56:39 -0400

Mallikarjun,

I think this ought to be related to ErrorRecoveryLevel - it looks like
you're suggesting that connection reinstatement SHOULD be supported
at ErrorRecoveryLevel 0 - at 1 and above, I believe it's already a
MUST.  I don't have a problem with that, does anyone else?

Thanks,
--David

> -----Original Message-----
> From: Mallikarjun C. [mailto:[email-masked]]
> Sent: Tuesday, July 09, 2002 2:52 PM
> To: [email-masked]
> Subject: iSCSI: DLB-T.16 (resource requirement for connection
> reinstatement)
> 
> 
> > [T.16] 4.3.4  Connection reinstatement
> > 
> >    Targets should support opening a second connection even 
> >    when they do not support multiple connections in Full Feature Phase. 
> > 
> > Looks like that ought to be an upper case "SHOULD".  I think this needs
> > further discussion.  Section 5.2 appears to use a lower case "must"
> > for this:
> 
> Let's be careful here - section 5.2 discusses the generic case of
"connection 
> cleanup" - that includes both implicit and explicit logouts - whereas
"connection 
> reinstatement" is just implicit logout.
> 
> While "connection cleanup" does not require additional connection
resources
> in the general case, a target wanting to support connection reinstatement
SHOULD
> support *opening* a second connection (though it may reject the Login if
it's
> for a different CID).
> 
> I believe that connection reinstatement is a useful functionality that the
targets 
> SHOULD support, so I agree that the change suggested by David is a
reasonable 
> one to make in 4.3.4 which only discusses connection reinstatement.
> 
> Mallikarjun
>

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 10 Jul 2002 12:21:23 -0700

David,

"Connection reinstatement" is related to ErrorRecoveryLevel only in 
one case (described below).  Even when no tasks were active (so 
no within-command/within-connection/connection recovery), connection 
reinstatement still is meaningful - simply the process of substituting one 
iSCSI connection with a new one bearing the same CID.

To summarize level of requirement for connection reinstatement wrt 
ErrorRecoveryLevel -

ErrorRecoveryLevel                              target's level of requirement
    0                                                             SHOULD
    1                                                             SHOULD
    2 (multi-conn sessions supported)            SHOULD
    2 (only single-conn sessions)                    MUST

[ The reason for the MUST in the last row is: While the target isn't aware of a
   connection failure, the initiator may have seen the connection fail and would 
   like to reassign tasks to a new instance of the same CID (i.e. connection 
   reinstatement) - target had already promised to support reassignment and so
   MUST allow this as a pre-requisite to reassignment. ]

My suggestion was to require SHOULD in the first 3 rows.

Thanks.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668 
Roseville CA 95747
[email-masked]