Subject: Re: iSCSI - working draft and IANA

From: "Julian Satran" <[email-masked]>
Date: Tue, 30 Jul 2002 16:00:21 +0300

Registering the current keys is an issue already raised by Mallikarjun. 
The only think I can comment about is that I don't see what we stand to 
gain (and I can cleraly see the  pain!).

As for the prefixes - they are aimed at clearly delineating what is 
mandatory (key defined in the basic iSCSI doc) from vendor or 
group=of-vendors additions.

The registration is meant to allow groups of vendors to agree on a key and 
provide a semantic doc (an RFC that can be informational).

Julo

Steve Senum <[email-masked]>
07/30/2002 01:48 AM

        To:     Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        Re: iSCSI - working draft and IANA

Julian,

1. I would suggest registering all the current iSCSI keys, auth methods,
and digests with the IANA, with references to the iSCSI RFC (when 
published),
and dropping the X#, Y#, and Z# prefixes.  This would be more consistent
with how I have seen this done in the past.

2. I am not sure I really see the need.  In other cases, this is done
to allow vendor specific registrations, but we already have a mechanism
for that (the X- prefix).  Note that there is no reason why a vendor
can't defined a vendor specific key in an informational RFC.

Regards,
Steve Senum

Julian Satran wrote:
> 
> Dear colleagues,
> 
> The current (today's) version of the draft has a revised IANA 
consideration
> section
> and specific  indication on how to build keys, authentication methods 
and
> digests.
> 
> David Black suggested that we might want to go for 3 different 
registries
> maintained by IANA for iSCSI
> and I liked the idea.
> 
> Please comment,
> Julo

---

From: Mark Bakke <[email-masked]>
Date: Tue, 30 Jul 2002 12:52:20 -0500

Julian-

I'm not sure I see the need for registering keys, but that
aside, if we register digest and auth methods I would suggest
that we also register an integer method number with each; this
will make it easier to add them to the MIBs.  I would also
suggest that we register the current ones as well as any
extensions.

--
Mark

Julian Satran wrote:
> 
> Registering the current keys is an issue already raised by Mallikarjun. The only think I can
> comment about is that I don't see what we stand to gain (and I can cleraly see the  pain!).
> 
> As for the prefixes - they are aimed at clearly delineating what is mandatory (key defined in the
> basic iSCSI doc) from vendor or group=of-vendors additions.
> 
> The registration is meant to allow groups of vendors to agree on a key and provide a semantic doc
> (an RFC that can be informational).
> 
> Julo
> 
>   07/30/2002 01:48 AM                      cc:        [email-masked]
> and digests with the IANA, with references to the iSCSI RFC (when published),
> > The current (today's) version of the draft has a revised IANA consideration
> > section
> > and specific  indication on how to build keys, authentication methods and
> > digests.
> >
> > David Black suggested that we might want to go for 3 different registries

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Bill Studenmund <[email-masked]>
Date: Tue, 30 Jul 2002 14:18:59 -0700 (PDT)

> gain (and I can cleraly see the  pain!).

I think what we stand to gain is that then the IANA folks know what has
already registered, so that someone can't register a name in the spec.
Or so that the spec can't later start using names already registered.

This discussion is assuming that the space open for IANA registration is
not contrained to exclude keys already in the spec.

Take care,

Bill