Subject: Yokohama Agenda and status of drafts

From: [email-masked]
Date: Mon, 1 Jul 2002 18:20:16 -0400

The IPS Yokohama agenda needs to be assembled fairly quickly,
so I'm going to run an "opt-in" process for this -- I currently
know about IPS agenda time requests/needs for:
	- SCSI MIB
	- iSCSI Plugfest
	- IPS Security WG Last Call results, including
		how to deal with AES Counter Mode
	- iSCSI Last Call results

Authors of all other drafts - if I don't hear from you
by the end of this week, the only mention of your draft
in Yokohama will be a brief statement that the authors
believe the draft is ready for WG Last Call, accompanied
by a request for anyone who disagrees to speak up in the
meeting or on the mailing list.

I've appended a summary of what the WG chairs believe
to be the current status of the drafts in the IP Storage WG.
Please let us know of any corrections.

Thanks,
--David

IETF IP Storage (ips) Working Group
WG Internet-Draft Status: July 2002
------------------------------------

Summary: 23 drafts total:
	- 2 are in the RFC Editor queue
	- 4 have completed WG Last Call
	- 1 is in WG Last Call
	- 3 will not be published as RFCs (WG Last Call comment resolution)
That leaves 13 drafts still to go through WG Last Call - there will
be a *lot* of WG Last Calls coming up after the Yokohama meeting week.

NOTE: PDF versions for some drafts are for ease of review only.  The
	definitive format for RFCs is text, and it is the text versions
	that will be forwarded to the IESG for publication as RFCs.

-- Security for all IPS protocols

draft-ietf-ips-security-13.txt
	To be a proposed standard RFC.  WG Last Call has just completed,
	a -14 version will include the editorial and minor technical changes
	from WG Last Call, and should be ready for submission to the
ADs/IESG
	shortly after Yokohama (and after one last check that it's aligned
	with the protocol drafts that reference it).

-- iSCSI

draft-ietf-ips-iscsi-14.txt
draft-ietf-ips-iscsi-14.pdf
	To become a proposed standard RFC.  Outstanding security issues
	have (finally) been resolved.  In WG Last Call which will
	complete on July 8th.  The -14 draft updated the -13 draft with
	changes from the first week of WG Last Call.

draft-ietf-ips-iscsi-boot-06.txt
	To become an informational RFC, after the main iSCSI document.
	WG Last Call expected shortly after Yokohama.

draft-ietf-ips-iscsi-reqmts-06.txt
	The IESG has approved publication as an informational RFC,
	and the draft is currently in the RFC Editor queue.

draft-ietf-ips-iscsi-name-disc-06.txt
	To become a proposed standard RFC.  WG Last Call expected shortly
	after Yokohama.

draft-ietf-ips-iscsi-slp-03.txt
	To become a proposed standard RFC.
	WG Last Call will be after the naming and discovery draft.

draft-ietf-ips-iscsi-string-prep-02.txt
	To become a proposed standard RFC.  WG Last Call expected shortly
	after Yokohama - at same time as name-disc draft.

draft-ietf-ips-iscsi-mib-05.txt
	To be a proposed standard RFC.  WG Last Call will follow main iSCSI
draft.
	Structure diagram available at:
ftp://ftpeng.cisco.com/mbakke/ips/iscsi-mib/Visio-ietf-iscsi-uml-model-05.pd
f

draft-ietf-ips-auth-mib-01.txt
	To be a proposed standard RFC. User identity information MIB split
out
	from basic iSCSI MIB for more general use, but currently only being
	used for iSCSI.  Will go to WG Last Call with the iSCSI MIB.
	Structure diagram available at:
ftp://ftpeng.cisco.com/mbakke/ips/auth-mib/Visio-ietf-ips-auth-mib-01.pdf

draft-sheinwald-iscsi-crc-01.txt
	The IESG has approved publication as an informational RFC, and the
draft
	is currently in the RFC Editor Queue.

-- FC Common Encapsulation

draft-ietf-ips-fcencapsulation-08.txt
draft-ietf-ips-fcencapsulation-08.pdf
	To be a proposed standard RFC.  Has completed WG Last Call.  Will
	be submitted to Area Directors and the IESG after the check of
	FCIP and iFCP against the final version of the security draft.

-- FCIP

draft-ietf-ips-fcovertcpip-11.txt
draft-ietf-ips-fcovertcpip-11.pdf
	To be a proposed standard RFC.  Has completed WG Last Call.  Will
	be submitted to Area Directors and the IESG after a check against
	the final version of the IPS Security draft.

draft-ietf-ips-fcip-slp-02.txt
	To be a proposed standard RFC.  WG Last Call expected shortly after
	Yokohama

draft-ietf-ips-fcip-mib-02.txt
	To be a proposed standard RFC.  Has been restructured to align with
	new structure of FC Management MIB and been reviewed by the WG's
	MIB Technical Expert.  Next revision should be ready for WG Last
Call.

-- iFCP

draft-ietf-ips-ifcp-12.txt
draft-ietf-ips-ifcp-12.pdf
	To be a proposed standard RFC.  Has completed WG Last Call.  Will
	be submitted to Area Directors and the IESG after a check against
	the final version of the security draft.

draft-ietf-ips-ifcp-mib-01.txt
	To be a proposed standard RFC.  Basically done.
	
-- iSNS

draft-ietf-ips-isns-11.txt
	To be a proposed standard RFC.  WG Last Call to follow iSCSI and
iFCP drafts.
		The related draft-ietf-dhc-isnsoption-01.txt requests
allocation
		of a DHC option code for iSNS, and is being handled in the
DHC WG.

draft-ietf-ips-isns-mib-02.txt
	To be a proposed standard RFC.  Basically done.  
	
-- SCSI MIB

draft-ietf-ips-scsi-mib-03.txt
	To be a proposed standard RFC.  -03 version should be ready for WG
Last
		Call (shortly after Yokohama).  Structure diagram available
at:
ftp://ftpeng.cisco.com/mbakke/ips/scsi-mib/Visio-scsi-uml-model-01.pdf
		Diagram showing relationships among SCSI family of MIBS
available at:
ftp://ftpeng.cisco.com/mbakke/ips/scsi-mib/Visio-scsi-mib-family-01.pdf

-- Fibre Channel Management MIB

draft-ietf-ips-fcmgmt-mib-02.txt
	To be a proposed standard RFC.  This work has been transferred
	to the IPS WG from the IPFC WG, and the scope has been expanded
	to include replacement of the FC Fabric Element MIB (RFC 2837).
	-02 version should be ready for WG Last Call shortly after Yokohama.

-- Last Call Drafts

draft-ietf-ips-fcencap-wglc-01.txt
draft-ietf-ips-fcip-wglc-02.txt
draft-ietf-ips-ifcp-wglcc-00.txt
	These drafts will not be published as RFCs.  They exist solely to
record
	the resolution of WG Last Call comments on the FC Encapsulation,
	FCIP and iFCP drafts.

----- Document Completion Guesstimates ------

A rough guess is 3 waves of documents:

(1) Main protocol standards.  WG Last Call has completed for:
		- FC Encapsulation
		- FCIP
		- iFCP
		- IPS Security (completed July 1st, new version coming
			to incorporate Last Call comments)
	The following documents are in WG Last Call:
		- iSCSI (completes July 8th)

(2) Supporting Protocol Documents.  WG Last Call expected shortly after
	the Yokohama meeting for:
		- iSCSI Naming/Discovery
		- iSCSI stringprep
		- iSCSI Boot
		- iSCSI SLP
		- FCIP SLP
		- iSNS
	If the iSCSI draft requires a second WG Last Call, WG Last Call on
	the iSCSI supporting drafts will wait to follow that.

(3) MIBs. WG Last Calls will be intermixed with supporting documents -
	all of the MIBs are done or close to done:
		- iSCSI MIB
		- FCIP MIB
		- iFCP MIB
		- iSNS MIB
		- SCSI MIB
		- FC Management MIB
	Expect multiple Last Call periods, rather than putting all the MIBs
	through WG Last Call at once.  SCSI MIB and FC Management MIB are
	likely to enter WG Last Call shortly after the Yokohama meeting
week.

-- Potential Additional Work

Additional drafts may be forthcoming in the future on:
	- Issues involved in gateways and bridges between iSCSI and other
SCSI
		protocols
	- Additional MIB(s) that extend the FC Management MIB to cover
additional
		aspects of Fibre Channel 

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449 *NEW*      FAX: +1 (508) 497-8500
[email-masked]         Cell: +1 (978) 394-7754
---------------------------------------------------

---

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Mon, 8 Jul 2002 10:38:01 -0700

David,

> 	To become a proposed standard RFC.  WG Last Call expected shortly

We have moved all of the normative text regarding iSCSI name construction
into the main iSCSI protocol draft and I believe the intent is that this
draft should be informational.

Thanks,
Marjorie

---

From: [email-masked]
Date: Tue, 9 Jul 2002 02:58:33 -0400

Marj gets 2 credits for transcontinental mind reading - I
was wondering whether the naming/discovery draft was still
going standards track - I'll correct the status of drafts
list that'll be used in Yokohama.

Thanks,
--David

> -----Original Message-----
> From: KRUEGER,MARJORIE (HP-Roseville,ex1)
> [mailto:[email-masked]]
> Sent: Monday, July 08, 2002 1:38 PM
> To: [email-masked]'; [email-masked]
> Subject: RE: Yokohama Agenda and status of drafts
> 
> 
> David,
> Regarding: 
>