Subject: RE: iSCSI: Decimal encoding - why 64 bits ?

From: [email-masked]
Date: Tue, 2 Jul 2002 16:04:45 -0600

David,
 
Like many others, I was under the impression that we had discussed this before. However, I have been unable to find a discussion in the archive. I think that we may be remembering the similar discussion on base64 representation for numbers. 
 
The limit of 64 bits for regular-binary-value appeared with the other value type definitions in 12-90.
 
The addition was preceeded by discussion in the Section 4.1 clarifications thread
http://www.pdl.cmu.edu/mailinglists/ips/mail/msg09774.html <http://www.pdl.cmu.edu/mailinglists/ips/mail/msg09774.html> 
but in reading that, I don't see any discussion of the 64 bit limit for regular-binary values. Then there was at least one comment in passing about decimal not being natural for binary strings in the base64 and numerical values thread (see Bill's text near the bottom of 
http://www.pdl.cmu.edu/mailinglists/ips/mail/msg10177.html <http://www.pdl.cmu.edu/mailinglists/ips/mail/msg10177.html> )
but whether 64 bits was the appropriate limit for decimal doesn't seem to have been discussed there either.
 
I think this is a new topic.
 
Regards,
Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 02, 2002 12:36 PM
To: [email-masked]; [email-masked]
Subject: RE: iSCSI: Decimal encoding - why 64 bits ?

Easy does it.  First of all - if someone will go find the mail
thread that discussed this (I also recall a discussion of
numbers vs. binary items) I'll take a look at it and make a
WG chair determination of what was or was not concluded.
 
Kevin's comment that decimal ought to be limited to 32 bits
is still valid at this point - a reference to prior discussions
without specifics isn't enough to dismiss it.  My rough
recollection of the discussion partially matches Julian's -
we reduced the required size to 64 bits from unlimited on
the assumption that platforms could cope with this ... and
now Kevin has raised the issue that two platforms he
considers important don't cope well with 64 bit arithmetic.
I don't recall discussion of whether to limit to 32 bits vs.
64 bits.
 
For now, this issue is open.
 
Thanks,
--David

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Tuesday, July 02, 2002 3:23 PM
To: [email-masked]
Subject: RE: iSCSI: Decimal encoding - why 64 bits ?

It was never supposed to be removed. Many values are passed around as decimal. 
We can't make any progress if we keep hitting the same things again-and-again after a decent consensus has been reached. 
And none of you has brought an argument that was not heard and dismissed before. 

Remember we moved from unlimited length decimal to 64 bit to alleviate implementer fears. 

Julo 

	Bill Studenmund <[email-masked]> 

07/02/2002 10:03 PM 
Please respond to Bill Studenmund 

        To:        "THALER,PAT (A-Roseville,ex1)" <[email-masked]> 
        cc:        "LEMAY,KEVIN (A-Roseville,ex1)" <[email-masked]>, Julian Satran/Haifa/IBM@IBMIL, <[email-masked]> 
        Subject:        RE: iSCSI: Decimal encoding - why 64 bits ? 

On Tue, 2 Jul 2002, THALER,PAT (A-Roseville,ex1) wrote:

> Bill,

> The decimal encoding is not just for numbers. It is also allowed for
> binary-values. Both CHAP and SRP exchange items that are identified as
> binary-values. In general these will be longer than 64 bits, but in
> cases where they are 64 bits or less the decimal encoding is currently
> allowed so we would have to support it.

I thought we had a big discussion about this, and we decided that decimal
was only used for numbers, hex for numbers and binary, and base64 only for
binary items. ??

Doh! I just looked in -14, and the text doesn't reflect that
understanding. Hmmm.

> The issue is that currently decimal encoding is allowed for
> binary-values and numbers less than 64 bits. There is little need for
> it over 32 bits. We have two other entirely adequate representations
> for those numbers. Why have something in there that causes extra code
> for no benefit?

All I can say is I thought it was removed. :-|

Take care,

Bill

---

From: Mark Bakke <[email-masked]>
Date: Tue, 02 Jul 2002 17:35:56 -0500

For what it's worth, none of the numeric values for iSCSI that
can be retrieved or set via the MIB require more than 32 bits
(other than counters, but I doubt we would ever send a counter
during negotiation :-).  The allowable ranges just didn't need
more than that.

Anyway, I haven't seen a need to provide support for 64-bit
values in our implementation yet, since none of the numeric
keys can have values that high.

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054