Subject: iSCSI: INQUIRY, version descriptor

From: Luben Tuikov <[email-masked]>
Date: Thu, 25 Jul 2002 20:43:44 -0400

Shouldn't we mention in the draft that Targets should
set the next available (eq. 0x0000) version descriptor
to 0x0960 in the INQUIRY data if additional length spans
it?

It is mentioned in SPC-3 (and SPC-2) and it would be more
convenient for implementors to see it in the iSCSI
document as well.

-- 
Luben

---

From: "Nandakumar Ramamurthy" <[email-masked]>
Date: Fri, 26 Jul 2002 12:16:51 +0530

Hi Luben,

The SPC-2 has this to say :

"The version descriptor fields provide for identifying up to eight
standards to which the device claims conformance."

"It is  recommended that the first version descriptor be used for the
SCSI architecture standard, followed by the physical standard, followed
by the physical/mapping protocol if any followed by the appropriate SPC
version, followed by the device type command set, followed by a
secondary command set if any."

Consider a target device that conforms to more than eight standards for the
SCSI architecture, and physical standards. In this case the INQUIRY response
data will not contain iSCSI version descriptor.  What will be the actions
taken by
the iSCSI target/initiator on finding a target device not conforming to
iSCSI ?

Thanks,
Nandakumar
Member Technical Staff
HCL Technologies, Chennai, INDIA.
http://san.hcltech.com

---

From: Luben Tuikov <[email-masked]>
Date: Fri, 26 Jul 2002 16:22:09 -0400

> the iSCSI target/initiator on finding a target device not conforming to

Nandakumar,

I will repeat AND quote my message again, since it seems that
you DIDN'T read it.

> > to 0x0960 in the INQUIRY data if additional length spans

As you see I said ``the next available (eq. 0x0000)'', so to answer your
pointless message: IF THERE IS AVALABLE VERSION DESCRIPTOR
THEN THE iSCSI IMPLEMENTATION SHOULD SET IT.

So, shouldn't this be mentioned in the draft?

Can someone more authoritative comment on this?

Julian, Mallikarjun, can you guys comment on this.

-- 
Luben

P.S. Nandrakumar, I cannot believe that you ACTUALLY copied
and TYPED the standard into your message -- apparently you
have NOTHING else to do, but not read messages and
type and copy standards into your messages which are
readily available on the net.
I'm subscribing to 4 more mailing lists and in no one
of those it is soooo difficult. Building your carreer
in a mailing list is always the wrong thing to do!

---

From: Luben Tuikov <[email-masked]>
Date: Fri, 26 Jul 2002 19:04:51 -0400

> the iSCSI target/initiator on finding a target device not conforming to

Obviously nothing. But surely you've figured this for yourself.

Anyway, in my original post I do mention:

``the next available (i.e. eq. 0x0000)''

which answers your question above just as well.

Now back to business and my original post:

Shouldn't this be mentioned in the iSCSI document?
It would be much more convenient to find iSCSI related
information in the iSCSI document(s) rather dig into
the T-10 standards/drafts.

Judging by the fact that mode pages are _mentioned_
in iSCSI (I know there are none) -- shows that this
was noticed and paid attention to.

Then version descriptors could be probably mentioned in
section (new) 3.2 and 3.1 become what is now known as 3.

Julian, David, Mallikarjun?

-- 
Luben