Subject: RE: iSCSI: reference for CRC32C?

From: [email-masked]
Date: Mon, 29 Jul 2002 16:44:07 -0600

Margorie,

The text in 11.1 suffices to fully define the algorithm. 

Regards,
Pat

-----Original Message-----
From: KRUEGER,MARJORIE (HP-Roseville,ex1)
[mailto:[email-masked]]
Sent: Monday, July 29, 2002 2:13 PM
To: Ips Reflector (E-mail)
Subject: iSCSI: reference for CRC32C?

Looking thru the current draft I can't find any doc. reference for the
definition of CRC32C.  Does the text in sec 11.1 suffice, or is there some
other document that fully defines the algorithm for CRC32C?  If so,
shouldn't it be referenced in the bibliography?

Thanks
Marjorie

---

From: Jonathan Stone <[email-masked]>
Date: Mon, 29 Jul 2002 16:51:19 -0700

In message <[email-masked]>[email-masked] writes
>The text in 11.1 suffices to fully define the algorithm. 

Agreed, It does specify the algorithm. But IMHO the spec should still
cite the original source --- Castagnoli et al. --- because that is the
original source.  And because that's where to start looking, for anyone
who cares about the ins and outs of the specific choice of algorithm.

The citation i have  handy is:
@Article{castagnoli-crc,
  author =       { Guy Castagnoli and Stefan Braeuer and Martin Herrman},
  title =        {{Optimization of Cyclic Redundancy-Check Codes with 24
                  and 32 Parity Bits}},
  journal =      IEEE Transactions on Communication,
  year =         {1993},
  volume =       {41},
  number =       {6},
  pages =        {},
  month =        {June},
}

(I have a hardcopy, with page numbers, if I can find it.)

---

From: "Yuval Avnon" <[email-masked]>
Date: Tue, 30 Jul 2002 10:55:36 +0200

Is there any reference CRC32C code available? (In addition to the
calculation examples in appendix B.4)

Thanks,
Yuval Avnon - Galileo technologies.