Subject: Re: iSCSI: DLB's [T.6] 2.3 iSCSI Session Types

From: "Julian Satran" <[email-masked]>
Date: Sun, 14 Jul 2002 17:06:09 +0300

My preference would be to stay with what is currently available - hit the 
initiator with a FIN. There is nothing to recover anyhow.

Julo

Ken Sandars <[email-masked]>
07/12/2002 10:39 PM
Please respond to Ken Sandars

        To:     [email-masked], Julian Satran/Haifa/IBM@IBMIL
        cc:     [email-masked]
        Subject:        Re: iSCSI: DLB's [T.6] 2.3  iSCSI Session Types

Hi all,

I'm wondering what the preferred mechanism is for a target to force an 
initiator to close a discovery session.

In the case ot a normal session, the AM-"target requests logout" pdu is 
allowed (I guess AM types 1-3 apply). So should we follow this model for 
discovery sessions, or just hit 'em with a FIN?

Thanks,
Ken
-- 
Ken Sandars
Eurologic Systems Ltd
[email-masked]

On Thursday 11 July 2002 5:01 am, [email-masked] wrote:
> Julian
>
> > I can agree with MUST but I will resist adding any notification.
> >
> > It is just the wrong thing to do.
>
> I don't care - getting to a MUST with a list of allowed PDUs that
> forbids all others from the current MAY that allows everything is
> what matters to me.
>
> At the moment, I've only seen Ayman ask for Async Message to be
> allowed on discovery sessions - does anyone else want to see that
> PDU allowed on discovery sessions?
>
> Thanks,
> --David
> ---------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 42 South St., Hopkinton, MA  01748
> +1 (508) 249-6449            FAX: +1 (508) 497-8018
> [email-masked]       Mobile: +1 (978) 394-7754
> ---------------------------------------------------

---

From: Ken Sandars <[email-masked]>
Date: Mon, 15 Jul 2002 09:43:06 +0000

Hi Julo and David,

Given that a FIN is an acceptable mechanism for the target to close a 
discovery session, we have no need for Async Message pdus on discovery 
sessions.

Cheers,
Ken 

-- 
Ken Sandars
Eurologic Systems Ltd
[email-masked]