Subject: Re: iSCSI: reference for CRC32C?

From: "Julian Satran" <[email-masked]>
Date: Tue, 30 Jul 2002 03:40:17 +0300

Nice - Marjorie & all - Did you by any chance look at the reference 
section?
I will add also a pointer to it although - as Pat pointed out -  this does 
not really belong
in this section.

Julo

Jonathan Stone <[email-masked]>
Sent by: [email-masked]
07/30/2002 02:51 AM

        To:     [email-masked]
        cc:     [email-masked], [email-masked]
        Subject:        Re: iSCSI: reference for CRC32C?

In message 
<[email-masked]>[email-masked] 
writes
>Margorie,
>
>The text in 11.1 suffices to fully define the algorithm. 

Agreed, It does specify the algorithm. But IMHO the spec should still
cite the original source --- Castagnoli et al. --- because that is the
original source.  And because that's where to start looking, for anyone
who cares about the ins and outs of the specific choice of algorithm.

The citation i have  handy is:
@Article{castagnoli-crc,
  author =       { Guy Castagnoli and Stefan Braeuer and Martin Herrman},
  title =        {{Optimization of Cyclic Redundancy-Check Codes with 24
                  and 32 Parity Bits}},
  journal =      IEEE Transactions on Communication,
  year =         {1993},
  volume =       {41},
  number =       {6},
  pages =        {},
  month =        {June},
}

(I have a hardcopy, with page numbers, if I can find it.)

---

From: Michael Smith <[email-masked]>
Date: Mon, 29 Jul 2002 18:44:51 -0700

I think this reference below was in one of Julian's earlier drafts. I happen
to have ASCII and EndNote citations from http://ieeexplore.ieee.org, but I'm
not saying this is the normative reference to CRC-C.

Optimization of cyclic redundancy-check codes with 24 and 32 parity bits
Castagnoli, G.; Brauer, S.; Herrmann, M. 
Communications, IEEE Transactions on , Vol.41, Iss.6, 1993
Pages: 883- 892
URL:
http://ieeexplore.ieee.org/iel1/26/5993/00231911.pdf?isNumber=5993&prod=JNL&
arnumber=00231911 (you need an IEEE subscription that goes back that far)

TY  - JOUR

TI  - Optimization of cyclic redundancy-check codes with 24 and 32 parity
bits

SP  - 883

EP  - 892

AU  - Castagnoli, G.

AU  - Brauer, S.

AU  - Herrmann, M.

PB  - Theoretical or Mathematical

KW  - optimisation

KW  - cyclic redundancy-check codes

KW  - minimum distance

KW  - shortened Hamming codes

KW  - weight distribution

KW  - shortened cyclic codes

KW  - high-speed special-purpose processor

KW  - CRC

KW  - block lengths

KW  - IEEE-802

KW  - cyclic codes

KW  - error correction codes

KW  - error detection codes

KW  - Hamming codes

KW  - optimisation

PY  - 1993

VL  - 41

IS  - 6

JO  - Communications, IEEE Transactions on

JA  - Communications, IEEE Transactions on

ER  - 

-----Original Message-----
From: Jonathan Stone [mailto:[email-masked]]
Sent: Monday, July 29, 2002 4:51 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI: reference for CRC32C? 

In message
<[email-masked]>pat_thaler@
agilent.com writes

---

From: [email-masked]
Date: Tue, 30 Jul 2002 12:04:11 -0600

Yuval,
Unless things have changed recently, SCTP uses the same polynomial and algorithm as iSCSI and includes tested sample code in their spec. See IETF's working group Tsvwg. 
Vince

|-----Original Message-----
|From: Yuval Avnon [mailto:[email-masked]]
|Sent: Tuesday, July 30, 2002 1:56 AM
|To: [email-masked]; [email-masked]; [email-masked]
|Subject: Re: iSCSI: reference for CRC32C?
|
|
|
|Is there any reference CRC32C code available? (In addition to the
|calculation examples in appendix B.4)
|
|Thanks,
|Yuval Avnon - Galileo technologies.
|
|----- Original Message -----
|From: <[email-masked]>
|To: <[email-masked]>; <[email-masked]>
|Sent: Tuesday, July 30, 2002 0:44
|Subject: RE: iSCSI: reference for CRC32C?
|
|
|> Margorie,
|>
|> The text in 11.1 suffices to fully define the algorithm.
|>
|> Regards,
|> Pat
|>
|> -----Original Message-----
|> From: KRUEGER,MARJORIE (HP-Roseville,ex1)
|> [mailto:[email-masked]]
|> Sent: Monday, July 29, 2002 2:13 PM
|> To: Ips Reflector (E-mail)
|> Subject: iSCSI: reference for CRC32C?
|>
|>
|> Looking thru the current draft I can't find any doc. 
|reference for the
|> definition of CRC32C.  Does the text in sec 11.1 suffice, or 
|is there some
|> other document that fully defines the algorithm for CRC32C?  If so,
|> shouldn't it be referenced in the bibliography?
|>
|> Thanks
|> Marjorie
|>
|