Subject: iSCSI consensus calls

From: [email-masked]
Date: Fri, 2 Aug 2002 19:26:53 -0400

Cleaning up some issues to prepare for WG Last Call ...

On July 24th, I posted the proposed resolution of issues
discussed in Yokohama to the list.  Having seen no
further list discussion, I believe the rough consensus of
the IPS WG is to follow the sense of the discussion
in Yokohama, specifically:

(1) No support for long-lived discovery sessions.
(2) Decimal encoding only for binary items whose
	values always fit in 64 bits.
(3) Must accept at least 8k of text in negotiation.
(4) No ErrorRecoveryLevel 0.5.  MAY try ERL 1
	mechanisms after negotiating ERL 0, but MUST
	be prepared for them to fail.
(5) Remove BidiInitialR2T key.
(6) Data resegmentation only via a new R-Data
	SNACK that always sends a new SCSI Response.
	SNACK tag associates new response with SNACK.

On the other hand, since the use of Irrelevant has
caused interoperability problems at the plugfest, I don't
think the "just put in examples" direction from Yokohama
will suffice - I believe this issue to be open.

On SRP, based on the proof of primality of the SRP primes
and subsequent discussion, I believe the rough consensus of
the IPS WG is:
	- Negotiate SRP_GROUP instead of announcing the prime
		and generator.
	- The largest required group is 1536 bits.
	- The SRP groups/primes will be used up to 2048 bits, the
		IKE MODP groups/primes will be used for larger sizes.
For the latter, computational efficiency issues have been raised
for both the SRP groups (prime format) and the IKE MODP groups
(generator != 2 for SRP).  I believe this situation does not
provide a solid reason to change from the default of using the
groups that are commonly used with SRP.  Paul Koning's objection
to the rough consensus on this item is noted.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 3 Aug 2002 08:36:01 +0300

David,

For irrelevant we have new wording in the text.
I guess the list may want to comment.  I did not hear a word not even from 
the plugfest participants!
I did not hear comments on the registry process either. 

Julo

[email-masked]
Sent by: [email-masked]
08/03/2002 02:26 AM

        To:     [email-masked]
        cc: 
        Subject:        iSCSI consensus calls

                                 IKE MODP groups/primes will be used for 
larger sizes.

Thanks,
--David