Subject: ExpDataSN in Response PDU

From: "Chuck Micalizzi" <[email-masked]>
Date: Wed, 28 Aug 2002 12:08:56 -0700

Julian,
	
    Can we rename the ExpDataSN field in the Response PDU?
    
    Since the addition of data sequences the ExpDataSN (in my
    opinion) is not an accurate title for this field.

    9.4.8 ExpDataSN
    The number of Data-In (read) PDUs the target has sent 
    for the command...

    Prior to the addition of data sequences it made sense that 
    the total DataIn PDU count was the same as the ExpDataSN. But
    since sequences require the DataSN to be reset at the start of 
    a sequence the total Data-In PDU count may not equal ExpDataSN. 

chuck

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 29 Aug 2002 09:01:43 +0300

Chuck,

Sorry - ay too late for a field name change.  It may be a bit misleading 
in the response but it is in the position held by ExpDataSN in other PDUs 
and it
is the total number of  Data-In PDUs. Data-In PDUs are not counted 
separately per sequence!

Julo

"Chuck Micalizzi" <[email-masked]>
Sent by: [email-masked]
28/08/02 22:08

        To:     <[email-masked]>
        cc: 
        Subject:        ExpDataSN in Response PDU

Julian,

    9.4.8 ExpDataSN

chuck