Subject: About F-bit in ISCSI Scsi command PDU

From: "Prashanth.C.A. Shetty" <[email-masked]>
Date: Tue, 13 Aug 2002 05:20:37 -0700 (PDT)

Hello All,
    As per the draft definition of F-bit explained in
the iSCSI SCSI command PDU section..."F-bit should be
set to 1 when no unsolicited data follow the command
PDU".
    My interpretation of the above statement is:
    F-bit in the command PDU is to be set to 1 by the
initiator only if solicited data needs to be sent to
the Target and should be zero for Unsolicited data
transfer.
    My question:
    If I need to send only immediate
data:..[dataxferlen <=
MaxRecvPduLen,InitalR2t=True,ImmediateData=True]....What
should be the F-bit set to????.
    Should it be set to ZERO[because IMMEDIATE DATA
ONLY[InitialR2t=True,ImmediateData=True] falls as one
of unsolicited data transfer type] or should it be set
to ONE[because no unsolicited data follows the command
PDU]????
   
Regards,
Prashanth

__________________________________________________
Do You Yahoo!?
HotJobs - Search Thousands of New Jobs
http://www.hotjobs.com

---

From: Bill Studenmund <[email-masked]>
Date: Tue, 13 Aug 2002 10:35:26 -0700 (PDT)

> set to 1 when no unsolicited data follow the command

Where did you see that text?

In draft 15, section 9.3.1, I see:

(F) is set to 1 when no unsolicited SCSI Data-Out PDUs follow this PDU.

> should be the F-bit set to????.

The text quoted above clarifies that F only applies to unsolicited data
PDUs, not immediate data.

> to ONE[because no unsolicited data follows the command

One, as there are no unsolicited Data-Out PDUs.

Note also that just because you negotiated ImmediateData=Yes, and it's
probably better to (saves a data PDU), you don't HAVE to send any. You
just can.

Take care,

Bill