Subject: Clarification in NOP's

From: "Rao, Sajjan" <[email-masked]>
Date: Fri, 2 Aug 2002 01:33:06 -0700

Hi,
            If in a NOP-Out ITT field contains 0xFFFFFFFF, then the draft
says the CmdSN contains the next CmdSN, However the CmdSN is not advanced
and the I bit should be 1. 
            Does it mean that, if In a NOP-Out ITT is 0xFFFFFFFF then I bit
should be set 1, and hence the CmdSN is not advanced, so what should a
target do in a case where the ITT is 0xFFFFFFFF and I is not set to 1, is it
an error?
The initiator can expect a NOP-In only if the ITT value is valid, so what
does a target do when ITT is 0xFFFFFFFF and I = 1?
 
Thanx in advance,
- Sajjan

---

From: [email-masked]
Date: Fri, 2 Aug 2002 19:03:18 -0400

>             If in a NOP-Out ITT field contains 0xFFFFFFFF, then the
> draft says the CmdSN contains the next CmdSN, However the CmdSN is
> not advanced and the I bit should be 1.

Current working draft says:

	If the Initiator Task Tag contains 0xffffffff the I bit must be set
	to 1 and the CmdSN is not advanced after this PDU is sent.

And that "must" probably ought to be a MUST ....

>             Does it mean that, if In a NOP-Out ITT is 0xFFFFFFFF then I
> bit should be set 1, and hence the CmdSN is not advanced, so what should
> a target do in a case where the ITT is 0xFFFFFFFF and I is not set to 1,
> is it an error?

Yes.

> The initiator can expect a NOP-In only if the ITT value is valid, so
> what does a target do when ITT is 0xFFFFFFFF and I = 1?
 
It's at least a Protocol Error and could be considered a Format Error.
Issuing a Reject PDU with Reason 0x09 (Invalid PDU field) is
preferable to closing the connection due to getting the I bit
wrong in a NOP, although the latter is permissible (Section 5.6).

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------