Subject: RE: iSCSI question

From: Shahram Davari <[email-masked]>
Date: Thu, 8 Aug 2002 13:21:16 -0700

Hi Bill,

Thanks for your reply. Please see my comments below:

1) I doubt that the session re-establishment code is simpler than PDU recovery code.
But think what you are saying is that, you need to have the session recovery anyway, so the PDU recovery is extra code.
2) Even if that is the case, it has nothing to do with the error recovery hierarchy.
The error recovery hierarchy must show what recovery should be tried before the other ones. In other words it has to show how the recovery escalates.
3) I think it should escalate as following: PDU -> Connection -> Session

Yours,
-Shahram  

> -----Original Message-----
> From: Bill Studenmund [mailto:[email-masked]]
> Sent: Thursday, August 08, 2002 3:59 PM
> To: Shahram Davari
> Cc: [email-masked]'; [email-masked]; 
> [email-masked];
> [email-masked]
> Subject: RE: iSCSI question
> 
> 
> On Thu, 8 Aug 2002, Shahram Davari wrote:
> 
> > Pat,
> >
> 
> > Thanks. I understand your point. Although terminating a 
> session may be
> > easy, but, starting a new session requires new login, parameter
> > exchange, new connections establishment, authentication, etc. So I
> > wonder how is this any simpler than a simple PDU retransmit?
> 
> It's simpler in terms of the code in both the initiator and target.
> 
> That's how it's simpler. :-)
> 
> Take care,
> 
> Bill
>

---

From: "Anshul Chadda" <[email-masked]>
Date: Thu, 8 Aug 2002 16:56:24 -0400

Isn't the error recovery hierarachy based on complexitiy??

* Session recovery(0)- some amount of code
* Command/PDU recovery(1)- more code than for session recovery
* Connection recovery(2) - even more code than for Command/PDU recovery

This basis of hierarchy makes negotiation of ErrorRecoveryLevel easier
between initiators and targets!!

Anshul

----- Original Message -----
From: "Shahram Davari" <[email-masked]>
To: "'Bill Studenmund'" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Thursday, August 08, 2002 4:21 PM
Subject: RE: iSCSI question

> But think what you are saying is that, you need to have the session
recovery anyway, so the PDU recovery is extra code.
> The error recovery hierarchy must show what recovery should be tried
before the other ones. In other words it has to show how the recovery
escalates.