Subject: RE: Error in running UNH iSCSI code

From: Chaoyang Deng <[email-masked]>
Date: Tue, 27 Aug 2002 10:05:46 -0400 (EDT)

Hi,

Please DO NOT use "manage" script on the target side. That is my fault, I
should not put the script in the target directory, which I used for
testing error only. :(

Have fun!

Chaoyang

On Tue, 27 Aug 2002, Asai Thambi S.P - CTD, Chennai. wrote:

> > I am using UNH  iSCSI code on Redhat Linux on virtual
> > machine. Here after
> > installing the initiator module and target module we got the following
> > errors on
> > the initiator end :
> >
> > Gotkey: SessionType=Normal
> > ../common/text_param.h : check_correctness:1368: ***ERROR***
> > key"SessionType" cannot be sent to initiator.
>
> The initiator should start the negotiation of the "SessionType" and
> the target has to check if it supports that type of session and proceed
> acccordingly. The target shouldn't initiate THIS key negotiation.
>
> This is a protocol error (if I'm wrong, correct me).
>
> > and at target end:
> > iscsi_target.c :  error: rx_data: rx_loop_0 total_rx_0
> > iscsi_rx_thread : trouble receiving data.
>
> The initiator on detecting the above ERROR, closes the connection.
> The target is waiting to  receive data from the socket and at that time,
> one end of the socket is closed and hence sock_recvmsg() at the target side
> returned a value <=0 ( I think it is 0).
>
> This protocol error occurs during session login, the connection is closed
> and hence
> the session is not established.
>
> Suppose this error occurs (generally it shouldn't occur) during connection
> login (session is in
> full feature phase),
> what should the initiator do?
> 	* close the connection or
> 	* close the session
>
> Can anybody through some more light on this?
>
> Thanks,
> asai thambi.
>

  +----------------------------------------------------+
  | Chaoyang Deng -- [email-masked] -- 603.862.1908 |
  | iSCSI Consortium, InterOperability lab (IOL),  UNH |
  | http://www.iol.unh.edu/consortiums/iscsi/          |
  | 204 Forest Park, Durham, NH 03824  -- 603.868.3470 |
  +----------------------------------------------------+

---

From: "Robert D. Russell" <[email-masked]>
Date: Tue, 27 Aug 2002 10:08:15 -0400 (EDT)

> 	* close the connection or

Close the connection.

Bob Russell

---

From: "Asai Thambi S.P - CTD, Chennai." <[email-masked]>
Date: Tue, 27 Aug 2002 18:48:25 +0530

Thanks,
asai thambi.