Subject: RE: iSCSI question

From: Shahram Davari <[email-masked]>
Date: Thu, 8 Aug 2002 11:27:13 -0700

Pat,
 
Thanks. I understand your point. Although terminating a session may be easy, but, starting a new session requires new login, parameter exchange, new connections establishment, authentication, etc. So I wonder how is this any simpler than a simple PDU retransmit?
 
Yours,
-Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, August 08, 2002 2:19 PM
To: Shahram Davari; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: iSCSI question

Shahram,
 
Wen you start a new session, you don't recover any PDUs. All the iSCSI state died with the old session. iSCSI doesn't know the new session had any relationship to the old session.
 
As Julian said, recovery at that point is up to the SCSI layer above iSCSI. It is up to SCSI to retry any commands that it wants to retry. When SCSI retries a command, iSCSI doesn't know it is a retry. To the iSCSI layer it is just like any other SCSI command it receives.
 
Pat
 
-----Original Message-----
From: Shahram Davari [mailto:[email-masked]]
Sent: Wednesday, August 07, 2002 8:44 AM
To: 'Julian Satran'
Cc: [email-masked]; [email-masked]
Subject: RE: iSCSI question

Julian,
 
To start a new session you need to start new connections and you need to support
the PDU recovery. So how is that a subset of PDU and connection recovery?

-Shahram
 
(I will explain the detailed clarity issues in another email)

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Wednesday, August 07, 2002 11:34 AM
To: Shahram Davari
Cc: [email-masked]; [email-masked]
Subject: RE: iSCSI question

Session recovery is in fact leaving all recovery to SCSI - it drops everything and creates a new session. 
As for you comment on the clarity of chapter 5 at this stage it makes sense to be either specific 
or keep this type of comment out of this context. 

Julo 

	Shahram Davari <[email-masked]> 

08/07/2002 06:09 PM 

        To:        Julian Satran/Haifa/IBM@IBMIL 
        cc:        [email-masked], [email-masked] 
        Subject:        RE: iSCSI question 

Julian, 
  
Thanks. I have read that section but it is not very clear. 
  
I also agree that Connection recovery requires everything in command recovery. 
But what about session recovery? isn't it a superset of both connection and command recovery? 
  
Yours, 
-Shahram 
-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Wednesday, August 07, 2002 11:03 AM
To: Shahram Davari
Cc: [email-masked]; [email-masked]
Subject: Re: iSCSI question

Sharam, 

You may want to go over the recovery chapter. 
It has detailed answers to all your questions. 
The superset/subset is based on functions you need for the next level. 

Session recovery drops real recovery to SCSI. 
Command recovery recovers from individual command errors without 
changing connection and the highest enable you to switch to a new connection and 
continue commands there. 

2 requires everything in 1. 

Julo 

	Shahram Davari <[email-masked]> 
Sent by: [email-masked] 

08/07/2002 05:17 PM 

       To:        [email-masked] 
       cc:         
       Subject:        iSCSI question 

Hi,

I have a question regarding the hierarchy of error recovery.
Section 6.13 mentions the hierarchy as:

2: Connection recovery
1: Digest failure recovery
0: Session recovery

And it states that the higher levels are a superset of the
lower levels and that the level of complexity increases from 0->1->2.

Couple of questions:

1) How is digest failure recovery done? by retransmission of PDUs?
2) Why is the connection recovery a superset of session recovery
and more complex?
3) It seems to me the order should be:

2: Session recovery
1: Connection recovery
0: Digest failure recovery

I appreciate any insight.

Thanks,
-Shahram

---

From: Bill Studenmund <[email-masked]>
Date: Thu, 8 Aug 2002 12:59:00 -0700 (PDT)

> Thanks. I understand your point. Although terminating a session may be
> easy, but, starting a new session requires new login, parameter
> exchange, new connections establishment, authentication, etc. So I
> wonder how is this any simpler than a simple PDU retransmit?

It's simpler in terms of the code in both the initiator and target.

That's how it's simpler. :-)

Take care,

Bill

---

From: "Amir Shalit" <[email-masked]>
Date: Thu, 8 Aug 2002 13:38:51 -0700

Shahram,

1) Connection reassignment requires more than PDU retransmission to handle
corner cases

2) Error recovery level 1&2 requires more buffering which takes space and
lowers performance. If
   you support error recovery level 1 you might as well support level 2.

Amir
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Shahram Davari
  Sent: Thursday, August 08, 2002 11:27 AM
  To: [email-masked]'; [email-masked]
  Cc: [email-masked]; [email-masked]
  Subject: RE: iSCSI question

  Pat,

  Thanks. I understand your point. Although terminating a session may be
easy, but, starting a new session requires new login, parameter exchange,
new connections establishment, authentication, etc. So I wonder how is this
any simpler than a simple PDU retransmit?

  Yours,
  -Shahram
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]
    Sent: Thursday, August 08, 2002 2:19 PM
    To: Shahram Davari; [email-masked]
    Cc: [email-masked]; [email-masked]
    Subject: RE: iSCSI question

    Shahram,

    Wen you start a new session, you don't recover any PDUs. All the iSCSI
state died with the old session. iSCSI doesn't know the new session had any
relationship to the old session.

    As Julian said, recovery at that point is up to the SCSI layer above
iSCSI. It is up to SCSI to retry any commands that it wants to retry. When
SCSI retries a command, iSCSI doesn't know it is a retry. To the iSCSI layer
it is just like any other SCSI command it receives.

    Pat

    -----Original Message-----
    From: Shahram Davari [mailto:[email-masked]]
    Sent: Wednesday, August 07, 2002 8:44 AM
    To: 'Julian Satran'
    Cc: [email-masked]; [email-masked]
    Subject: RE: iSCSI question

    Julian,

    To start a new session you need to start new connections and you need to
support
    the PDU recovery. So how is that a subset of PDU and connection
recovery?

    -Shahram

      -----Original Message-----
      From: Julian Satran [mailto:[email-masked]]
      Sent: Wednesday, August 07, 2002 11:34 AM
      To: Shahram Davari
      Cc: [email-masked]; [email-masked]
      Subject: RE: iSCSI question

      Session recovery is in fact leaving all recovery to SCSI - it drops
everything and creates a new session.
      As for you comment on the clarity of chapter 5 at this stage it makes
sense to be either specific
      or keep this type of comment out of this context.

      Julo

      Julian,

      I also agree that Connection recovery requires everything in command
recovery.
      But what about session recovery? isn't it a superset of both
connection and command recovery?

      Yours,
      -Shahram
      -----Original Message-----
      From: Julian Satran [mailto:[email-masked]]
      Sent: Wednesday, August 07, 2002 11:03 AM
      To: Shahram Davari
      Cc: [email-masked]; [email-masked]
      Subject: Re: iSCSI question

      Sharam,

      Session recovery drops real recovery to SCSI.
      Command recovery recovers from individual command errors without
      changing connection and the highest enable you to switch to a new
connection and
      continue commands there.

      Julo

                   To:        [email-masked]
                   cc:
                   Subject:        iSCSI question

      Hi,

      2: Connection recovery

      Couple of questions:

      2: Session recovery
      1: Connection recovery

      Thanks,
      -Shahram