Subject: iSCSI:Problem with use of NotUnderstood in negotiations

From: "John Hufferd" <[email-masked]>
Date: Mon, 12 Aug 2002 23:13:01 -0700

Isn't there a way to say that if you get a response of NotUnderstood, to a
key that you do not understand, or to a key that you did not offer, that it
is a protocol error.  That should stop the loop dead in its tracts.  It
could be stated on page 66.

The Pseudo Code would be,....do I understand the key, if not .... is
NotUnderstood its value ... if so protocol error!   (clearly if I do not
understand it, I did not offer it.)

.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/SSG San Jose Ca
Main Office (408) 256-0403, Tie: 276-0403,  eFax: (408) 904-4688
Home Office (408) 997-6136, Cell: (408) 499-9702
Internet address: [email-masked]

"THALER,PAT (A-Roseville,ex1)" <[email-masked]>@ece.cmu.edu on
08/12/2002 01:08:31 PM

Sent by:    [email-masked]

To:    Julian Satran/Haifa/IBM@IBMIL, [email-masked]
cc:
Subject:    RE: Problem with use of NotUnderstood in negotiations

Julian,

In the scenario, each device does use Notunderstood in a response.

A sends keyxxx
Silent data corruption occurs that changes keyxxx to keyxxy
B gets keyxxy and doesn't recognize it so it responds
keyxxy=Notunderstood
A gets that and thinks it is an offer of a key it doesn't understand
because it never sent keyxxy.
A therefore sends
keyxxy=Notunderstood
B gets keyxxy and doesn't recognize it so it responds
keyxxy=Notunderstood
.....

Regards,
Pat

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, August 09, 2002 9:24 PM
To: [email-masked]
Subject: RE: Problem with use of NotUnderstood in negotiations

Bill,

Perhaps the text is unabiguos but you just ignored the text that forbids
it.
The use of Notunderstood is limited to responses. Using it as you suggest
is a protocol error.
A repeated use will also violate the "no renegotiation rule".

Julo

                      Bill Studenmund
                      <wrstuden@wasabis        To:       Bart Crane
                      <[email-masked]>
                      ystems.com>              cc:       <[email-masked]>
                      Sent by:                 Subject:  RE: Problem with
                      use of NotUnderstood in negotiations
                      [email-masked]
                      .edu

                      08/10/2002 02:22
                      AM

On Fri, 9 Aug 2002, Bart Crane wrote:

?? In the scenario I describe, neither side believes it offered the key.

> Thus, there is no need to add another rule regarding not-responding to
> keys with NotUnderstood as a value, because a key with that value is
> a protocol error.
>
> This could be made more explicit, but there does not seem to be any
> ambiguity.

There obviously is ambiguity. The fact we're having this discussion is
proof. :-)

I'd support saying this case is a protocol error, since it means something
neither side understands got into the stream (and chances are an offer got
removed). But I think adding an explicit direction as to what to do is
needed.

Take care,

Bill

---

From: "Julian Satran" <[email-masked]>
Date: Tue, 13 Aug 2002 10:03:26 +0300

The (valid) point that Pat was making is that we do not request the 
receiver to check for every protocol error and it would
be advisable to say something about a "blanket" protection.

I have proposed a text for this in my previous note.
Again neither this nor the protocol errors are mandatory - but  a wise
implementer will do something.

Thanks,
Julo

John Hufferd@IBMUS
08/13/2002 09:13 AM

        To:     Julian Satran/Haifa/IBM@IBMIL@IBMDE
        cc:     [email-masked]
        From:   John Hufferd/San Jose/IBM@IBMUS
        Subject:        iSCSI:Problem with use of NotUnderstood in negotiations

Isn't there a way to say that if you get a response of NotUnderstood, to a 
key that you do not understand, or to a key that you did not offer, that 
it is a protocol error.  That should stop the loop dead in its tracts.  It 
could be stated on page 66.

.
.
.
John L. Hufferd

Julian,

A sends keyxxx

Regards,
Pat

-----Original Message-----
From: Julian Satran [mailto:[email-masked]]
Sent: Friday, August 09, 2002 9:24 PM
To: [email-masked]
Subject: RE: Problem with use of NotUnderstood in negotiations

Bill,

Julo

Bill Studenmund
<wrstuden@wasabis        To:       Bart Crane <[email-masked]>
ystems.com>              cc:       <[email-masked]>
Sent by:                 Subject:  RE: Problem with use of NotUnderstood 
in negotiations
[email-masked]
.edu

08/10/2002 02:22
AM

Take care,

Bill