Subject: iSCSI: Abort Task Set CmdSN: < or <=

From: "Tony Battersby" <[email-masked]>
Date: Mon, 12 Aug 2002 16:39:15 -0400

Draft 15, section 9.5.1:
"Task management requests must act on all the commands having a CmdSN lower
than the task management CmdSN."
"... all the tasks covered by the Task Management response (i.e., with CmdSN
not higher than the task management command CmdSN), ..."

"Lower than" is not the same as "not higher than" for the case of equal
CmdSN's, which could happen if an immediate command preceeded the task
management request.  So if an immediate command is issued followed by a Task
Management Function Request of ABORT TASK SET with the same CmdSN as the
immediate command, should the immediate command be aborted or not?

Anthony J. Battersby
Cybernetics

---

From: "Julian Satran" <[email-masked]>
Date: Tue, 13 Aug 2002 15:11:54 +0300

Tony,

Immediate commands are only partially ordered. It does not make too much
sense to have Task Management account for immediate commands
that are not completely ordered vs. the TM itself.
Abort Task Set should act only on commands that where issued before it and
immediate commands with the same CmdSN do not meet this criteria.

Julo

                      "Tony Battersby"                                                                                                              
                      <tonyb@cybernetic        To:       <[email-masked]>                                                                          
                      s.com>                   cc:                                                                                                  
                      Sent by:                 Subject:  iSCSI: Abort Task Set CmdSN: < or <=                                                       
                      [email-masked]                                                                                                             
                      .edu                                                                                                                          

                      08/12/2002 11:39                                                                                                              
                      PM                                                                                                                            
                      Please respond to                                                                                                             
                      tonyb                                                                                                                         

Draft 15, section 9.5.1:
"Task management requests must act on all the commands having a CmdSN lower
than the task management CmdSN."
"... all the tasks covered by the Task Management response (i.e., with
CmdSN
not higher than the task management command CmdSN), ..."

management request.  So if an immediate command is issued followed by a
Task

Anthony J. Battersby
Cybernetics