Subject: iSCSI and FCP

From: [email-masked]
Date: Thu, 8 Aug 2002 11:22:46 -0400

> > Also, a transport (iSCSI) shouldn't be influenced by
> > another transport (FCP), but only by the unifying layer,
> > i.e. SAM-3.
> 
> Well?

Ok as a "first principles" position, I suppose ... but FCP
has a lot of deployment experience, and is known to work.
In addition, bridges to FCP and other SCSI transports are
a reasonable thing to consider.  For example, both of these
contributed to the decision in Yokohama to drop the
BidiInitialR2T key.  So, I think "shouldn't be influenced"
isn't the right approach - there are things to be learned
from FCP's experience, and issues that arise in cross-
transport bridges should not be dismissed out-of-hand.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: Luben Tuikov <[email-masked]>
Date: Fri, 09 Aug 2002 10:29:30 -0400

[email-masked] wrote:
> Ok as a "first principles" position, I suppose ...

Sorry, my mistake again. (Can you have it any other way?!)

I always take the position of ``first principles'',
``black and white'', ``0 or 1'', etc. -- it's just
a lot easier and straightforward.

`` ... speaking as an engineer.''
                           -- Dilbert
-- 
Luben