Subject: RE: iSCSI Boot: Technical Issues

From: [email-masked]
Date: Mon, 23 Sep 2002 13:45:43 -0400

Except that I think Luben got his left and right
reversed ... how about:

      Within a group of 4 hexadecimal digits, leading
	zeros MAY be omitted, but at least one digit MUST
	be present if the group is not otherwise omitted.
	A trailing zero-valued group or groups MAY be omitted;
	the recipient MUST assume that omitted groups are zero
	and MUST suffix the zeroes to the right of the supplied
	groups.  A zero group that is to the left of any non-zero
	group MUST NOT be omitted.

       Examples:
        4A = 004A-0000-0000-0000
        12C-4-32 = 012C-0004-0032-0000
	  0-5F-C = 0000-005F-000C-0000

Thanks,
--David

> -----Original Message-----
> From: Mark Bakke [mailto:[email-masked]]
> Sent: Monday, September 23, 2002 1:11 PM
> To: Luben Tuikov
> Cc: Prasenjit Sarkar; [email-masked]
> Subject: Re: iSCSI Boot: Technical Issues
> 
> 
> Luben-
> 
> I like it.
> 
> --
> Mark
> 
> Luben Tuikov wrote:
> > 
> > --- Mark Bakke <[email-masked]> wrote:
> > > I see your point.  In fact, we would take "4" as
> > > 0004-0000-0000-0000.  How about saying:
> > >
> > > Within dashes, zeroes to the left; e.g. 4A == 004A.
> > > Missing dashed fields become zeroes to the right.
> > >
> > > 4A = 004A-0000-0000-0000
> > > 12C-4-32 = 012C-0004-0032-0000
> > 
> > The examples are great, though the stipulation is not
> > formal as there are _only_ two groups ``within dashes''.
> > 
> > A clear an unambiguous stipulation would include
> > this definition plus your examples:
> > 
> >       Within each group of 4 hexacedimal digits zeros are
> >       filled to the right, and groups of zeros are filled
> >       to the left.
> > 
> >       Example:
> >         4A = 004A-0000-0000-0000
> >         12C-4-32 = 012C-0004-0032-0000
> > 
> > The advantage is that is is formal, and unambiguous
> > without a doubt. It implicitly defines what a group
> > is (four hexadecimal digits), if not defined anywhere
> > in the embedding document.
> > 
> > --
> > Luben
> > 
> > =====
> > --
> > 
> > __________________________________________________
> > Do you Yahoo!?
> > New DSL Internet Access from SBC & Yahoo!
> > http://sbc.yahoo.com
> 
> -- 
> Mark A. Bakke
> Cisco Systems
> [email-masked]
> 763.398.1054
>

---

From: Luben Tuikov <[email-masked]>
Date: Mon, 23 Sep 2002 12:32:44 -0700 (PDT)

> 	group MUST NOT be omitted.

With all due respect David, I do not have my left and right
reversed.

Your definition is more reminicent of _how_ to do it,
rather than the true formalizm of _what_ it is.
It is also too long, talks about recipient, etc,
which are NOT needed since the right/left rule can
be applied at either end to the same effect.

``Within each group of 4 hexacedimal digits zeros are
  filled to the right, and groups of zeros are filled
  to the left.''

This is a necessary and sufficient definition, the minimal
such, and one may derive all of the stipulations which
you've mentioned.

E.g. the fact that a leading 0000 group must not be
omitted,
is implicit in this definition. (else, the LUN
representation would be ambiguous, contrary to the
assumption that it is not.)

group: an ordered sequence of 4 hexadecimal digits.
      (ordered -- human brain assumes without question)

within each group ... filled to the right:
  4 --> 0004, and etc _recursively_ for as many groups
there'd be (max 4 groups in LUN), i.e. 4-4 -> 0004-0004

groups of zeros are filled to the left:
that is, this is done to complement to 4 groups,
e.g. from the previous example:
0004-0004 -> 0004-0004-0000-0000

The more challenging example 0-4-0-4 is left as
an exercise to the reader. :-)

Thus, one cannot assume that 4 can somehow be equivalent
to 0000-0004-0000-0000, because of the _left_ rule -- that
is groups of zeros are ONLY filled to the left!
(as the definition stipulates)

Nevertheless, the definition I gave is more mathematical,
and though clearer, succinct and straightforward, I can
see how the average reader could cough up reading it.

-- 
Luben

=====
--

---

From: Bill Studenmund <[email-masked]>
Date: Mon, 23 Sep 2002 18:49:39 -0700 (PDT)

> 	  0-5F-C = 0000-005F-000C-0000

Sounds good.

Take care,

Bill