Subject: iSCSI: Last call issues for the Naming and Discovery document

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Mon, 9 Sep 2002 18:46:14 -0700

Some cleanup items for the iSCSI Naming and Discovery document:
 
1) Sec.1 p.5 and p. 14 define "iSCSI Address" but contradict each other.  p.
5 defines it as simply and IP address [& port] and p. 14 says it's the iSCSI
name and IP addr [+port].  Paragraph 5 needs to be modified to match p. 14.
 
2) Sec. 1 p. 17 says
 
In this example, Robert's SSN is like the iSCSI Name, his phone number and
addresses are analogous to the TCP addresses which make up an iSCSI session,
and "Robert Smith" would be a human-friendly label for this person.

The statement that Robert Smith's addresses are like an iSCSI session makes
no sense to me.  An iSCSI session is a relationship between two separate
iSCSI nodes.  Robert's addresses are only one end of the relationship.
Perhaps this paragraph means to say his phone number, etc. are like an iSCSI
nodes TCP addresses?
 
3) Sec. 1.1 p. 1 first sentence "iSCSI has given the Organizational naming
authority additional flexibility by permitting it to hand out local naming
authority to
   subordinate organizations."
 
I suggest changing this to "The iSCSI naming scheme was constructed to give
an organizational naming authority the flexibility to further subdivide the
responsibility for name creation to subordinate naming authorities."  Use of
"capital O" in Organization implies there's some globally defined naming
authority that this sentence is referring to.  
 
4) General comment on section 1.1  To reflect the definition in the iSCSI
main draft, sec. 2.2.6.3.2,  either the examples need to be changed to show
the ":" after the reversed domain name in the string, or the text needs to
be changed to say that these substrings are sub-domain names.
 
5)sec. 1.1, p 15 - this example is missing the ":" following the reversed
domain name.
 
6)sec. 3, p 1 - the last sentence is missing something.  It's "Moreover,
iSCSI discovery  mechanism only deals with target discovery and one still
needs to use  the SCSI protocol for LUN discovery." and should be "Moreover,
the iSCSI discovery  mechanisms listed here only deal with target discovery
and one still needs to use the SCSI protocol for LUN discovery."
 
7) sec. 3 p 2 - 2nd sentence is missing something. It's "The goal of iSCSI
discovery mechanism is to provide low overhead support for small iSCSI
setups, and scalable discovery solutions for large enterprise setups." and
should be "The goal of iSCSI discovery  mechanisms are to provide low
overhead support for small iSCSI setups, and scalable discovery solutions
for large enterprise setups." 
 
8) sec. 3, p 5  the sentence "This mechanism assumes that the IP address and
TCP port information are already available to the initiator." is missing
something, should be "This mechanism assumes that the target's IP address
and TCP port information are already available to the initiator."
 
9) appendix B.3, I think there's a typo in the first sentence.  "This
gateway presents logical targets (iSCSI Names) to the initiators, and maps
them to real iSCSI targets as it chooses." should be "This gateway presents
logical targets (iSCSI Names) to the initiators, and maps them to SCSI
targets as it chooses."

10)  appendix B.4 another typo?  "An iSCSI proxy is a SCSI gateway..."
should be "An iSCSI proxy is an iSCSI gateway.."
 
11) appendix B.5, p 4 refers to a "DMZ"  There is no definition of this term
in this document.  Needs to either be defined or substitute some more
descriptive phrase here.

Regards,

Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions
Hewlett-Packard

---

From: "Amir Shalit" <[email-masked]>
Date: Tue, 10 Sep 2002 11:00:36 -0700

IPS-All: Reminder: 3 drafts complete last call this weekB.4 is a subset of
B.3 and can be dropped. In case we keep it,
I suggest the following text:

An iSCSI gateway is a SCSI gateway presenting only virtual iSCSI targets
and virtual iSCSI initiators. A virtual iSCSI device is also called an iSCSI
proxy.

instead of:

 "An iSCSI proxy is a SCSI gateway that happens to be terminating the
   iSCSI protocol on both sides, rather than translate between iSCSI and
   some other transport."

An iSCSI proxy by itself is not a gateway making above sentence inaccurate.

Amir
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
KRUEGER,MARJORIE (HP-Roseville,ex1)
  Sent: Monday, September 09, 2002 6:46 PM
  To: 'Elizabeth Rodriguez'; IPS Mailing List (E-mail)
  Cc: Kaladhar Voruganti (E-mail); David Black (E-mail)
  Subject: iSCSI: Last call issues for the Naming and Discovery document

  1) Sec.1 p.5 and p. 14 define "iSCSI Address" but contradict each other.
p. 5 defines it as simply and IP address [& port] and p. 14 says it's the
iSCSI name and IP addr [+port].  Paragraph 5 needs to be modified to match
p. 14.

  2) Sec. 1 p. 17 says

  The statement that Robert Smith's addresses are like an iSCSI session
makes no sense to me.  An iSCSI session is a relationship between two
separate iSCSI nodes.  Robert's addresses are only one end of the
relationship.  Perhaps this paragraph means to say his phone number, etc.
are like an iSCSI nodes TCP addresses?

  I suggest changing this to "The iSCSI naming scheme was constructed to
give an organizational naming authority the flexibility to further subdivide
the responsibility for name creation to subordinate naming authorities."
Use of "capital O" in Organization implies there's some globally defined
naming authority that this sentence is referring to.

  8) sec. 3, p 5  the sentence "This mechanism assumes that the IP address
and TCP port information are already available to the initiator." is missing
something, should be "This mechanism assumes that the target's IP address
and TCP port information are already available to the initiator."

  11) appendix B.5, p 4 refers to a "DMZ"  There is no definition of this
term in this document.  Needs to either be defined or substitute some more
descriptive phrase here.

  Regards,

  Marjorie Krueger

---

From: Mark Bakke <[email-masked]>
Date: Tue, 10 Sep 2002 14:21:52 -0500

Marjorie-

Thanks for the detailed comments.  I've embedded my responses below.

--
Mark

> "KRUEGER,MARJORIE (HP-Roseville,ex1)" wrote:
> 
> 1) Sec.1 p.5 and p. 14 define "iSCSI Address" but contradict each other.  p. 5 defines it as
> simply and IP address [& port] and p. 14 says it's the iSCSI name and IP addr [+port].  Paragraph
> 5 needs to be modified to match p. 14.

How about (page 5):

   iSCSI nodes also have addresses. An iSCSI address specifies a single
   path to an iSCSI node and consists of the iSCSI name, plus a transport
   (TCP) address which uses the following format:

      <domain-name>[:<port>]

   Where <domain-name> is one of:

> 
> 2) Sec. 1 p. 17 says
> 
> In this example, Robert's SSN is like the iSCSI Name, his phone number and addresses are analogous
> to the TCP addresses which make up an iSCSI session, and "Robert Smith" would be a human-friendly
> label for this person.
> The statement that Robert Smith's addresses are like an iSCSI session makes no sense to me.  An
> iSCSI session is a relationship between two separate iSCSI nodes.  Robert's addresses are only one
> end of the relationship.  Perhaps this paragraph means to say his phone number, etc. are like an
> iSCSI nodes TCP addresses?

You're right; that's what I had meant.  I'll fix the wording.

> 
> 3) Sec. 1.1 p. 1 first sentence "iSCSI has given the Organizational naming authority additional
> flexibility by permitting it to hand out local naming authority to
> I suggest changing this to "The iSCSI naming scheme was constructed to give an organizational
> naming authority the flexibility to further subdivide the responsibility for name creation to
> subordinate naming authorities."  Use of "capital O" in Organization implies there's some globally
> defined naming authority that this sentence is referring to.
> 
> 4) General comment on section 1.1  To reflect the definition in the iSCSI main draft, sec.
> 2.2.6.3.2,  either the examples need to be changed to show the ":" after the reversed domain name
> in the string, or the text needs to be changed to say that these substrings are sub-domain names.
> 
> 5)sec. 1.1, p 15 - this example is missing the ":" following the reversed domain name.
> 
> 6)sec. 3, p 1 - the last sentence is missing something.  It's "Moreover, iSCSI discovery
> mechanism only deals with target discovery and one still needs to use  the SCSI protocol for LUN
> discovery." and should be "Moreover, the iSCSI discovery  mechanisms listed here only deal with
> target discovery and one still needs to use the SCSI protocol for LUN discovery."
> 
> 7) sec. 3 p 2 - 2nd sentence is missing something. It's "The goal of iSCSI discovery mechanism is
> to provide low overhead support for small iSCSI setups, and scalable discovery solutions for large
> enterprise setups." and should be "The goal of iSCSI discovery  mechanisms are to provide low
> overhead support for small iSCSI setups, and scalable discovery solutions for large enterprise
> setups."
> 
> 8) sec. 3, p 5  the sentence "This mechanism assumes that the IP address and TCP port information
> are already available to the initiator." is missing something, should be "This mechanism assumes
> that the target's IP address and TCP port information are already available to the initiator."
> 
> 9) appendix B.3, I think there's a typo in the first sentence.  "This gateway presents logical
> targets (iSCSI Names) to the initiators, and maps them to real iSCSI targets as it chooses."
> should be "This gateway presents logical targets (iSCSI Names) to the initiators, and maps them to
> SCSI targets as it chooses."
> 
> 10)  appendix B.4 another typo?  "An iSCSI proxy is a SCSI gateway..." should be "An iSCSI proxy
> is an iSCSI gateway.."
> 
> 11) appendix B.5, p 4 refers to a "DMZ"  There is no definition of this term in this document.
> Needs to either be defined or substitute some more descriptive phrase here.
> 
> 
> Regards,
> 
> Marjorie Krueger

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Tue, 10 Sep 2002 15:42:39 -0500

When we first added B.4, it was intended to be a special case of
the B.3 gateway, with the exception that a B.3 iSCSI-iSCSI gateway
would fully terminate iSCSI targets and initiators on both sides,
while a B.4 proxy would be aware that both sides are iSCSI, and
may pass some PDUs, and the data CRC, through the box without
modification.  It may also handle target naming and other things
more transparently.  The main reason to have this section was to
point out that if a SCSI gateway is aware that iSCSI is used on
both sides, it can do things like keep the CRC all the way through.

Amir writes:
> B.4 is a subset of B.3 and can be dropped. In case we keep it,
> and virtual iSCSI initiators. A virtual iSCSI device is also called an iSCSI proxy.
>  
> instead of:
>  

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: "Amir Shalit" <[email-masked]>
Date: Wed, 11 Sep 2002 15:42:21 -0700

IPS-All: Reminder: 3 drafts complete last call this weekAn iSCSI proxy
functionality (i.e. iSCSI device mapping) within a SCSI gateway can also
take advantage of the specific transport

properties mentioned in B.4.

Is it possible to re-word B.4 as such?

Amir

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Amir Shalit
  Sent: Tuesday, September 10, 2002 11:01 AM
  To: KRUEGER,MARJORIE (HP-Roseville,ex1); 'Elizabeth Rodriguez'; IPS
Mailing List (E-mail)
  Cc: Kaladhar Voruganti (E-mail); David Black (E-mail)
  Subject: RE: iSCSI: Last call issues for the Naming and Discovery document

  An iSCSI gateway is a SCSI gateway presenting only virtual iSCSI targets
  and virtual iSCSI initiators. A virtual iSCSI device is also called an
iSCSI proxy.

  instead of:

  An iSCSI proxy by itself is not a gateway making above sentence
inaccurate.

  Amir
    -----Original Message-----

    2) Sec. 1 p. 17 says

    In this example, Robert's SSN is like the iSCSI Name, his phone number
and addresses are analogous to the TCP addresses which make up an iSCSI
session, and "Robert Smith" would be a human-friendly label for this person.

    3) Sec. 1.1 p. 1 first sentence "iSCSI has given the Organizational
naming authority additional flexibility by permitting it to hand out local
naming authority to
       subordinate organizations."

    4) General comment on section 1.1  To reflect the definition in the
iSCSI main draft, sec. 2.2.6.3.2,  either the examples need to be changed to
show the ":" after the reversed domain name in the string, or the text needs
to be changed to say that these substrings are sub-domain names.

    5)sec. 1.1, p 15 - this example is missing the ":" following the
reversed domain name.

    7) sec. 3 p 2 - 2nd sentence is missing something. It's "The goal of
iSCSI discovery mechanism is to provide low overhead support for small iSCSI
setups, and scalable discovery solutions for large enterprise setups." and
should be "The goal of iSCSI discovery  mechanisms are to provide low
overhead support for small iSCSI setups, and scalable discovery solutions
for large enterprise setups."

    Regards,

    Marjorie Krueger