Subject: iSCSI: Last call issues for the Naming and Discovery document

From: [email-masked]
Date: Tue, 10 Sep 2002 16:06:24 -0600

In the interest of getting these out in a timely fashion, I haven't compared them to the other postings to see if there are duplicates.  Pat Thaler

Technical issues

The third paragraph of 1 has the following text: "An iSCSI node name is also the SCSI device name of an iSCSI device. The iSCSI name of a SCSI device...." The first sentence says the iSCSI node name and SCSI device name are the same but the next sentence uses a different term: iSCSI name which is used through much of the remainder of the document. (There only seems to be one later use of iSCSI node name.) Please state whether iSCSI name the same as iSCSI node name. Also, why does the first sentence use "iSCSI device" but the second sentence use "SCSI device"? It seems that both should use "iSCSI device"
I'm not sure if this is technical or editorial because it isn't clear whether the small differences in the terms were intended to refer to different items or whether they should have used the same terms.

Appendix B.1 and B.2: This should mention the effect of port redirectors and SOCKS servers on Send Targets because the address mapping performed on the headers will not be performed on Send Targets responses. The Send Targets would need to use the fully qualified domain name form of iSCSI address or, if it must use an IP address form, it would need to know the mapping used by the gateway (and whether the initiator was on the far side of the gateway). Also, either the gateway will have to be configured to map the default port on the initiator side to whatever port the target is using (which could also be the default port; if it isn't the default port the target would have to know to suppress the port number) or the target will have to know the mapping used for ports on the gateway to supply the initiator the right port number in the iSCSI address.

Some of the references do not have a reference in the body of the document and don't have a clear relationship to the document. Specifically, [5] IEEE 802 (which would be relevant if MAC address space was discussed at all but it isn't mentioned and [22] and [23] which are Java references. If these references are necessary then text should be added to the body to clarify their relevance.

Editorial nits

Fifth paragraph of 1: The first sentence would be better: "An iSCSI node also has one or more addresses." to make it clear that a node does not necessarily have just one address.

Address examples in 1. For completeness it would be nice for some of the addresses to include a <port>. If none of them do, then they should be renamed examples of domain-name.

2.2 second paragraph below the first show targets listing: The first sentence has a grammar problem. Suggest "allocated to the hosts. The alias can provide a more descriptive name."

The appendices should come at the end - after the Author's names.

---

From: Mark Bakke <[email-masked]>
Date: Wed, 11 Sep 2002 17:52:39 -0500

Pat-

Thanks for the careful read.  I've embedded my comments below.

--
Mark

> The third paragraph of 1 has the following text: "An iSCSI node name is also the SCSI device name of an iSCSI device. The iSCSI name of a SCSI device...." The first sentence says the iSCSI node nam…

OK; I'll clarify that:

- An iSCSI node name and iSCSI name are one and the same (perhaps I'll omit
  iSCSI node name as a term, and define that an iSCSI name is the unique
  identifier for an iSCSI node.

- The whole SCSI device name thing is a link to T10 stuff.  Jim and Marjorie, any
  ideas on how to make this more clear?

> Appendix B.1 and B.2: This should mention the effect of port redirectors and SOCKS servers on Send Targets because the address mapping performed on the headers will not be performed on Send Targets…

I'll add the SendTargets note; that will be helpful.  To handle IP address
and port translations when the domain names are not used, it would be necessary
to proxy the discovery session (SendTargets) as you mentioned.  I'll note
that as well.

> Some of the references do not have a reference in the body of the document and don't have a clear relationship to the document. Specifically, [5] IEEE 802 (which would be relevant if MAC address sp…

OK; some of these references are quite old, and are no longer used.  I will
remove them.

> Fifth paragraph of 1: The first sentence would be better: "An iSCSI node also has one or more addresses." to make it clear that a node does not necessarily have just one address.

OK

> Address examples in 1. For completeness it would be nice for some of the addresses to include a <port>. If none of them do, then they should be renamed examples of domain-name.

OK

> 2.2 second paragraph below the first show targets listing: The first sentence has a grammar problem. Suggest "allocated to the hosts. The alias can provide a more descriptive name."

OK

> The appendices should come at the end - after the Author's names.

OK

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054