Subject: Re: iSCSI Boot: Technical Issues

From: "Julian Satran" <[email-masked]>
Date: Mon, 23 Sep 2002 17:39:52 +0300

Mark,

Carefully. You may want to add the "0s to the right" as this is practical.
But don't add the LUN structure text. It is not always so. There are 
several types of LUN structures...
And I am sure you don't want to go there.

Julo

Mark Bakke <[email-masked]>
Sent by: [email-masked]
23/09/02 15:31

        To:     Luben Tuikov <[email-masked]>
        cc:     Prasenjit Sarkar/Almaden/IBM@IBMUS, [email-masked]
        Subject:        Re: iSCSI Boot: Technical Issues

Oh, yes, I forgot to specify that.

Actually, it should be "unspecified xxxx to the right are
all zeroes".  The reason is that the LUN field is not a
number; it is a structure.  The first two bytes are the
first-level LUN; the second two are the second-level LUN,
and so forth.  It's meant to allow a gateway to take, for
instance, a group of targets, each with their own LUNs,
make the original LUNs second-level LUNs, then make up its
own first-level LUN for each target.  These can be used
in other ways as well.

This all means that when specifying a first-level LUN, it
would be (let's say LUN 4) 0004-0000-0000-0000.  So saying
they are unspecified to the right would be the way to go.

--
Mark

Luben Tuikov wrote:
> 
> --- Mark Bakke <[email-masked]> wrote:
> >
> > Multiple-level LUNs (defined in 4.9.4) use as many xxxx
> > fields as
> > they need (e.g. xxxx-xxxx, xxxx-xxxx-xxxx, and
> > xxxx-xxxx-xxxx-xxxx
> > are all valid; unspecified xxxx are zeroes).
> 
> More formally: `` ... unspecified xxxx to the left, are
> zeros.''
> 
> --
> Luben
> 
> =====
> --
> 
> __________________________________________________
> Do you Yahoo!?
> New DSL Internet Access from SBC & Yahoo!
> http://sbc.yahoo.com

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: Mark Bakke <[email-masked]>
Date: Mon, 23 Sep 2002 09:46:11 -0500

Julian-

I agree on not adding LUN structure text; it's just too scary
for one thing, and like you said, it's not the only one.

If we can just say 0s to the right, that's fine with me.

Thanks,

Mark

Julian Satran wrote:
> But don't add the LUN structure text. It is not always so. There are several types of LUN
> structures...
>   Sent by: [email-masked]         To:        Luben Tuikov <[email-masked]>
>                                          cc:        Prasenjit Sarkar/Almaden/IBM@IBMUS,
>   23/09/02 15:31                 [email-masked]

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054