Subject: iscsi: iSCSI Boot -- Informational or Standards track

From: Elizabeth Rodriguez <[email-masked]>
Date: Wed, 18 Sep 2002 13:11:16 -0700

[chair hat off]

All

When reviewing the Boot document last week, one think I overlooked was the
fact that the boot draft is currently informational.
In my editorial comments (to the authors only), I listed the fact that it
was not written in the language of RFC 2119.
It was pointed out that the draft is informational.  I feel that it probably
should be standards track.
It lists minimum requirements for boot, parameters, as well as defaults for
optional parameters, and formats for these fields.
This appears to me to be content for a standards track document, not an
informational one.

Informational documents are of general interest/information, not necessarily
representative of group consensus.
This document seems to be one which is really trying to define parameters
and behavior needed for iSCSI Boot, 
which means interoperability considerations -- that is a standards track
type of document.

What does the rest of the group think?

Thanks,

Elizabeth

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 19 Sep 2002 08:56:02 +0300

Elizabeth,

I tend to agree. If it stays informational we will end up with a myriad of 
vendor specific ways of registering boot
data in DHCP for iSCSI.  An item that is not quoted as open  (perhaps it 
went in too late for the last call) was a request to format in a 
"generally accepted way"
information about the boot target (e.g., what OS image does it carry?).

Regards,
Julo

Elizabeth Rodriguez <[email-masked]>
Sent by: [email-masked]
18/09/02 23:11

        To:     [email-masked]
        cc: 
        Subject:        iscsi: iSCSI Boot -- Informational or Standards track

[chair hat off] 
All 
When reviewing the Boot document last week, one think I overlooked was the 
fact that the boot draft is currently informational.
In my editorial comments (to the authors only), I listed the fact that it 
was not written in the language of RFC 2119. 
It was pointed out that the draft is informational.  I feel that it 
probably should be standards track. 
It lists minimum requirements for boot, parameters, as well as defaults 
for optional parameters, and formats for these fields.
This appears to me to be content for a standards track document, not an 
informational one. 
Informational documents are of general interest/information, not 
necessarily representative of group consensus. 
This document seems to be one which is really trying to define parameters 
and behavior needed for iSCSI Boot, 
which means interoperability considerations -- that is a standards track 
type of document. 
What does the rest of the group think? 
Thanks, 
Elizabeth

---

From: [email-masked]
Date: Thu, 19 Sep 2002 11:39:58 -0400

> An item that is not quoted as open  (perhaps it went in too late
> for the last call) was a request to format in a "generally accepted way" 

The specific request was to modify the iscsi DHCP Root Path option
format to carry that information, and the response to that request is
a firm "NO"; as a result the item is not open.

I have privately advised the originator of the request to
find a more general way to do this via other DHCP options (preferably
existing ones, but new ones if necessary), which will have the
added benefit of providing this functionality for network boot
mechanisms other than iSCSI.  That should be written up in a separate
Internet-Draft, probably for the dhc WG rather than the ips WG.
That draft could reference the iSCSI boot draft, but as a mechanism
of wider applicability, I believe it's inappropriate to add this
material to the iSCSI boot draft.

Comments?
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------