Subject: RE: iSCSI: Last call issues for the Naming and Discovery document

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Tue, 10 Sep 2002 19:08:23 -0400

> This doesn't seem consistent with the iSCSI 
> (draft-ietf-ips-iscsi-16) use of "address". I can't find 
> anywhere where it calls the address the iSCSI name plus a 
> transport address. For example, in 11.8, it defines target address as:
> 
> TargetAddress=domainname[:port][,portal-group-tag]
> 
> This doesn't include iSCSI name and it does include 
> portal-group-tag which isn't mentioned in the Naming and 
> Discovery document. To harmonize the two documents, iSCSI 
> address should not include the iSCSI name and the option for 
> portal-group-tag should be added to Naming and Discovery.

The iSCSI protocol document is not defining the concept of an iSCSI address,
it's specifying the format of a key value pair.  The N&D doc is purely an
informative discussion of concepts.  I don't see any problem with speaking
of an iSCSI address as both the iSCSI name and IP address, since you can't
address a target without knowing it's iSCSI name.
 
> Also, the use of Address in the iSCSI draft is asymmetrical. 
> The iSCSI draft only applies the structure of address, 
> <domain-name>[:<port>], to target addresses. Initiator 
> address is generally not mentioned. While the iSCSI protocol 
> doesn't explicitly use initiator addresses, they may be 
> useful for other things such as management interfaces so a 
> target can report address along with who is connected. The 
> Naming and Discovery document should at least explain the 
> difference between the asymmetry in the use of address in 
> iSCSI and the symmetry in Naming and Discovery. One might 
> also mention that a target will be only able to report the 
> address of a connected initiator in one of the IP formats 
> because it doesn't ever receive a DNS based name.

A target could perform reverse lookup on an address, just as the initiator
would have to do a name lookup to find the target's IP address if it had a
host name.

Marj

---

From: "THALER,PAT (A-Roseville,ex1)" <[email-masked]>
Date: Tue, 10 Sep 2002 17:01:23 -0600

Mark,

This doesn't seem consistent with the iSCSI (draft-ietf-ips-iscsi-16) use of "address". I can't find anywhere where it calls the address the iSCSI name plus a transport address. For example, in 11.8, it defines target address as:

This doesn't include iSCSI name and it does include portal-group-tag which isn't mentioned in the Naming and Discovery document. To harmonize the two documents, iSCSI address should not include the iSCSI name and the option for portal-group-tag should be added to Naming and Discovery.

Also, the use of Address in the iSCSI draft is asymmetrical. The iSCSI draft only applies the structure of address, <domain-name>[:<port>], to target addresses. Initiator address is generally not mentioned. While the iSCSI protocol doesn't explicitly use initiator addresses, they may be useful for other things such as management interfaces so a target can report address along with who is connected. The Naming and Discovery document should at least explain the difference between the asymmetry in the use of address in iSCSI and the symmetry in Naming and Discovery. One might also mention that a target will be only able to report the address of a connected initiator in one of the IP formats because it doesn't ever receive a DNS based name.

Pat

-----Original Message-----
From: Mark Bakke [mailto:[email-masked]]
Marjorie-

Thanks for the detailed comments.  I've embedded my responses below.

--
Mark

> "KRUEGER,MARJORIE (HP-Roseville,ex1)" wrote:
> 
> Some cleanup items for the iSCSI Naming and Discovery document:
> 
> 1) Sec.1 p.5 and p. 14 define "iSCSI Address" but contradict each other.  p. 5 defines it as
> simply and IP address [& port] and p. 14 says it's the iSCSI name and IP addr [+port].  Paragraph
> 5 needs to be modified to match p. 14.

How about (page 5):

   iSCSI nodes also have addresses. An iSCSI address specifies a single
   path to an iSCSI node and consists of the iSCSI name, plus a transport
   (TCP) address which uses the following format:

      <domain-name>[:<port>]

   Where <domain-name> is one of:

<stuff deleted>

---

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Wed, 11 Sep 2002 19:06:44 -0400

>> The third paragraph of 1 has the following text: "An iSCSI 
>> node name is also the SCSI device name of an iSCSI device. 
>> The iSCSI name of a SCSI device...." The first sentence says 
>> the iSCSI node name and SCSI device name are the same but the 
>> next sentence uses a different term: iSCSI name which is used 
>> through much of the remainder of the document. (There only 
>> seems to be one later use of iSCSI node name.) Please state 
>> whether iSCSI name the same as iSCSI node name. Also, why 
>> does the first sentence use "iSCSI device" but the second 
>> sentence use "SCSI device"? It seems that both should use 
>> "iSCSI device"
> 
> 
> OK; I'll clarify that:
> 
> - An iSCSI node name and iSCSI name are one and the same 
> (perhaps I'll omit
>   iSCSI node name as a term, and define that an iSCSI name is 
> the unique identifier for an iSCSI node.
> 
> - The whole SCSI device name thing is a link to T10 stuff.  
> Jim and Marjorie, any ideas on how to make this more clear?

I admit I don't find any of the quoted text confusing.  The main draft uses
the same mixture of terms, and the paragraphs that preceed and follow this
paragraph further define and clarify the usage of terms.  I think the
current text is sufficient.  Perhaps you can add a pointer to the sections
in the main draft that you are paraphrasing here?

As to Pat's comment that "iSCSI device" should be used where "SCSI device"
is used, I disagree.  SCSI get's it's device name from the transport, and
this sentence is pointing out that the SCSI device name is derived from the
iSCSI name.  Perhaps if you change the following sentence:

"The iSCSI name of a SCSI device is the principal object used in
authentication of targets to initiators and initiators to targets."

to

"The iSCSI name is the principal object used in authentication of targets to
initiators and initiators to targets."

removing the reference to the "SCSI device"ness to avoid overloading this
sentence?

Cheers,
Marj

---

From: [email-masked]
Date: Wed, 11 Sep 2002 17:50:21 -0600

That looks like a good change. Pat
-----Original Message-----
From: KRUEGER,MARJORIE (HP-Roseville,ex1)

to

Cheers,
Marj