Subject: RE: iSCSI Boot Last Call - Technical Comments

From: [email-masked]
Date: Tue, 10 Sep 2002 18:25:51 -0600

Technical

4. last two paragraphs: 
   "If the "servername" field is provided by DHCP, then that field is
   used in conjunction with other associated fields to contact the boot
   server in the Boot stage (Section 6).

   However, if the "servername" field is not provided, then the
   "targetname" field is then used in the Discovery Service stage
   (Section 5)."

Shouldn't the second paragraph say "is used in conjunction with the other associated fields"? "targetname" doesn't provide the LUN or protocol. The "port" field is may be relevant because the Target address needs to be fetched and will include port if necessary.

5. first paragraph "if the DHCP server ... is unaware of the iSCSI Target Port Name" What does Target port name (defined as iSCSI Target Name together with a label that idenifies it as a target port name and the portal group tag) have to do with this? The DHCP server string definition doesn't include a Target port name and even if it did, the discovery service stage would be necessary to convert that into an address. The discovery service stage is required if the DHCP server provided a target name because it converts target name to an IP address and port number. It is also required if the DHCP server didn't provide an iSCSI string.

Reference [17]: Can a URL be used as a reference? Intel could change the structure of their website and the URL would no longer locate the document. It would be better to reference a document title.

Editorial

4. 5 paragraphs from the end, "several different LU" should be "several different LUs"

4. 3 paragraphs from the end, except for the sentence "If the "servername" field is blank ....", all the other statements about defaults are duplicates of statements in the paragraphs where the fields were defined. Moving the statement about servername to the servername paragraphs above and deleting this paragraph.

---

From: Mark Bakke <[email-masked]>
Date: Wed, 11 Sep 2002 17:34:16 -0500

Pat,

On #5, I think that this should say "iSCSI Target Name"; as you said,
portal groups are not necessary for boot.

Mark

[email-masked] wrote:
> 5. first paragraph "if the DHCP server ... is unaware of the iSCSI Target Port Name" What does Target port name (defined as iSCSI Target Name together with a label that idenifies it as a target port name and the portal group tag) have to do with this? The DHCP server string definition doesn't include a Target port
 name and even if it did, the discovery service stage would be necessary to convert that into an
address. The discovery service stage is required if the DHCP server provided a target name because
it converts target name to an IP address and port number. It is also required if the DHCP server
didn't provide an iSCSI string.

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054