Subject: RE: Logical Block address in iSCSI CDB

From: [email-masked]
Date: Tue, 3 Sep 2002 13:47:08 -0400

> My doubt is....  Do the logical block address contained in 
> SCSI CDB inside ISCSI PDUs are actual address of the remote disk.
> Can we change that ????

Yes and no in that order.
 
> What I am trying to do is,.......
> 
>   If SCSI sends only 2 block or 3 blocks, wait and collect data upto 16 
> blocks (Usual max PDU of ISCSI) and send them over the network so that it 
> will reduce the header over-head.

That sort of thing is usually called a proxy.  Proxies can do anything
they want, but have to take full responsibility for the results (e.g.,
if multiple SCSI operations have been combined into a single
iSCSI operation, when the iSCSI response comes back, it has to
be split into the individual responses that SCSI expects to
its individual operations.  iSCSI (like SCSI) generally does
not support scatter-gather over the wire - the blocks in an
individual read or write operation generally have to be contiguous.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: Eddy Quicksall <[email-masked]>
Date: Tue, 3 Sep 2002 17:31:29 -0400

What you are asking for is usually done at a slightly higher level than the
device driver. This is very common at the caching level (at least in
embedded systems). So something like iSCSI gets it for free.

Device drivers in lower end systems (like DOS) actually did this. So, if you
are writing iSCSI for DOS, you may want to put this in your device driver.
:)

Eddy 

-----Original Message-----
From: shesha bhushan [mailto:[email-masked]]
Sent: Tuesday, September 03, 2002 1:13 PM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Subject: Logical Block address in iSCSI CDB

Hi,
  I established a full feature phase in ISCSI and mounted a disk from a 
remote machine. I copied a file from my local file system to the mounted 
disk. SCSI issues a series of Write commands that are encapsulated inside 
ISCSI PDUs.

My doubt is....  Do the logical block address contained in SCSI CDB inside 
ISCSI PDUs are actual address of the remote disk. Can we change that ????

Any suggestions and indeas are highly appertiated.

Thanking You
Shesha
Arizona State University.

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com