Subject: RE: iSCSI Boot: Technical Issues

From: [email-masked]
Date: Mon, 23 Sep 2002 15:50:50 -0400

Luben,

	``Within each group of 4 hexadecimal digits zeros are
	  filled to the right,

So starting with "C" and filling zeroes to the right, I get
"C000".

	and groups of zeros are filled
		to the left.''

So starting from "15-2C" and filling to the left, I get
"0000-0000-15-2C" before applying the first part of the rule.

Perhaps now you wee why I fail to understand:

> This is a necessary and sufficient definition, the minimal
> such, and one may derive all of the stipulations which
> you've mentioned.

since I followed the exact words you wrote and got completely
wrong results ... that strongly suggests that the "sufficient"
part is wrong.

The problems here have to do with ambiguous meanings of "to
the left" and "to the right" - these have to be cleaned up.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

> -----Original Message-----
> From: Luben Tuikov [mailto:[email-masked]]
> Sent: Monday, September 23, 2002 3:33 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: iSCSI Boot: Technical Issues
> 
> 
> --- [email-masked] wrote:
> > Except that I think Luben got his left and right
> > reversed ... how about:
> > 
> >       Within a group of 4 hexadecimal digits, leading
> > 	zeros MAY be omitted, but at least one digit MUST
> > 	be present if the group is not otherwise omitted.
> > 	A trailing zero-valued group or groups MAY be omitted;
> > 	the recipient MUST assume that omitted groups are zero
> > 	and MUST suffix the zeroes to the right of the supplied
> > 	groups.  A zero group that is to the left of any
> > non-zero
> > 	group MUST NOT be omitted.
> 
> With all due respect David, I do not have my left and right
> reversed.
> 
> Your definition is more reminicent of _how_ to do it,
> rather than the true formalizm of _what_ it is.
> It is also too long, talks about recipient, etc,
> which are NOT needed since the right/left rule can
> be applied at either end to the same effect.
> 
> ``Within each group of 4 hexacedimal digits zeros are
>   filled to the right, and groups of zeros are filled
>   to the left.''
> 
> This is a necessary and sufficient definition, the minimal
> such, and one may derive all of the stipulations which
> you've mentioned.
> 
> E.g. the fact that a leading 0000 group must not be
> omitted,
> is implicit in this definition. (else, the LUN
> representation would be ambiguous, contrary to the
> assumption that it is not.)
> 
> group: an ordered sequence of 4 hexadecimal digits.
>       (ordered -- human brain assumes without question)
> 
> within each group ... filled to the right:
>   4 --> 0004, and etc _recursively_ for as many groups
> there'd be (max 4 groups in LUN), i.e. 4-4 -> 0004-0004
> 
> groups of zeros are filled to the left:
> that is, this is done to complement to 4 groups,
> e.g. from the previous example:
> 0004-0004 -> 0004-0004-0000-0000
> 
> The more challenging example 0-4-0-4 is left as
> an exercise to the reader. :-)
> 
> Thus, one cannot assume that 4 can somehow be equivalent
> to 0000-0004-0000-0000, because of the _left_ rule -- that
> is groups of zeros are ONLY filled to the left!
> (as the definition stipulates)
> 
> Nevertheless, the definition I gave is more mathematical,
> and though clearer, succinct and straightforward, I can
> see how the average reader could cough up reading it.
> 
> -- 
> Luben
> 
> 
> 
> 
> 
> =====
> --
> 
> __________________________________________________
> Do you Yahoo!?
> New DSL Internet Access from SBC & Yahoo!
> http://sbc.yahoo.com
>

---

From: Luben Tuikov <[email-masked]>
Date: Mon, 23 Sep 2002 13:13:21 -0700 (PDT)

> Perhaps now you wee why I fail to understand:

Yes, yes, yes.

Exchange left and right then. I must've been having
something else on my mind to _completely_ swap those two.

The important point is that you understand what I meant:

``Within each group of 4 hexacedimal digits zeros are
  filled to the left, and groups of zeros are filled
  to the right.''

This is what I meant and this is what you understood --
_that_ is the important thing.

... as is clear by the examples concurred in our emails.

-- 
Luben

=====
--