Subject: RE: iSCSI Boot: Technical Issues

From: [email-masked]
Date: Fri, 20 Sep 2002 17:32:38 -0400

> 1. Looks like there is no opposition to making this a standard draft.

With my WG co-chair hat on, I believe this to be the rough consensus of
the IP Storage WG.  Please limit the use of MUST/SHOULD/MAY and the
like to Section 4 of the draft.
 
> 2. After talking to an HCI person in IBM, I have the following proposal:
> 
> We can change the LUN format to be xxxx-xxxx-xxxx-xxxx
> 
> This notation is subtantially better than "xxxxxxxxxxxxxxxx" in terms of
> HCI errors and is almost equivalent to a 16-bit format representation.
> 
> Since most of the numbers are going to be zeros, all we need to do is to
> edit 1 set of "xxxx".

With my WG co-chair hat off, I definitely like this proposal.  

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: Mark Bakke <[email-masked]>
Date: Mon, 23 Sep 2002 08:38:36 -0500

"Robert D. Russell" wrote:
> 
> Mark -- Two clarifications please:
> 
> 1. Each x in xxxx is a hex digit, correct?

Correct.

> 
> 2. Are the missing xxxx supplied to the left, as Luben suggests,
>    or to the right, as was implied by the reason that this
>    whole discussion came up.  i.e., is 1234-5678
>    shorthand for 1234-5678-0000-0000 or for
>    0000-0000-1234-5678?
>    I believe the first interpretation (1234-5678-0000-0000)
>    is the only useful one, because the second interpretation
>    means you always have to enter all 4 groups of xxxx due to
>    the format of the 64-bit LUN field in iscsi PDUs.

You are correct; it should be to the right.  I should have read
your message before I sent the last response.

--
Mark

> 
> Thanks for the clarification.
> 
> Bob Russell
> InterOperability Lab
> University of New Hampshire
> [email-masked]
> 603-862-3774
> 
> On Fri, 20 Sep 2002, Luben Tuikov wrote:
> 
> > --- Mark Bakke <[email-masked]> wrote:
> > >
> > > Multiple-level LUNs (defined in 4.9.4) use as many xxxx
> > > fields as
> > > they need (e.g. xxxx-xxxx, xxxx-xxxx-xxxx, and
> > > xxxx-xxxx-xxxx-xxxx
> > > are all valid; unspecified xxxx are zeroes).
> >
> > More formally: `` ... unspecified xxxx to the left, are
> > zeros.''
> >
> > --
> > Luben
> >
> >
> >
> > =====
> > --
> >
> > __________________________________________________
> > Do you Yahoo!?
> > New DSL Internet Access from SBC & Yahoo!
> > http://sbc.yahoo.com
> >

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054

---

From: [email-masked]
Date: Mon, 23 Sep 2002 12:13:05 -0400

> Q: is xxxx-xxxx-xxxx-xxxx supposed to be _just_ as
> SAM-3 stipulates? (rhetorical question)
> 
> If so, then ``within each group of 4 hexacedimal digits
> zeros are filled to the right, and groups of zeros
> are filled to the left'' might be a wiser stipulation.
> 
> This ``right/left'' rule will be easy on the average user's
> (the luser :-)) brain not to strain too much to understand
> what it is (LUN) and that the good old '4' still
> works just as the newer '801F-0000-...'.

Clearer desciption of the same idea - it's four 16-bit hex
numbers separated by dashes, if there are less than four
numbers, the missing numbers are on the right and are all zero.

Thanks,
--David