Subject: RE: Logical Block Addresses in SCSI

From: [email-masked]
Date: Tue, 3 Sep 2002 19:24:17 -0400

> I have mounted a remote directory and created a file. So this will
generate 
> SCSI WRITE CDBs that contain Logical Block Addresses (LBA) which is 
> encapsulated in an ISCSI command PDU. How did SCSI at the local system 
> generate a valid LBA for the remote disk?

SCSI didn't - the filesystem at the local system read the filesystem
metadata and the directory and decided what blocks to use for the file
you created.  The LBA numbers were generated by the filesystem.  SCSI
doesn't understand the concept of files.

Thanks,
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

---

From: Robert Snively <[email-masked]>
Date: Fri, 13 Sep 2002 10:43:09 -0700

The development of LBA's is not done by SCSI.  It is
done by file systems, applications, and drivers outside
the SCSI layer.  In most cases, references to directories
or other meta-data is required to obtain correct LBA's for
a remote disk.

> -----Original Message-----
> From: shesha bhushan [mailto:[email-masked]]
> Sent: Tuesday, September 03, 2002 1:31 PM
> To: [email-masked]
> Subject: Logical Block Addresses in SCSI
> 
> 
> Hi All,
> 
> I have mounted a remote directory and created a file. So this 
> will generate 
> I appertiate all your answers.
> 
> Thanking You
> Shesha
> 
> _________________________________________________________________
> Send and receive Hotmail on your mobile device: http://mobile.msn.com
>