Subject: login response for non-login request.

From: Michael Morrison <[email-masked]>
Date: 25 Sep 2002 11:22:12 -0700

In the last paragraph of section 2.2.3 of draft 17

"Once the Login phase has started, if the target
receives any PDU except a Login request, it MUST send a Login reject
(with Status "invalid during login") and then disconnect. If the
initiator receives any PDU except a Login response, it MUST
immediately terminate the connection."

Shouldn't the target send back a Reject PDU with PROTOCOL ERROR in this
case?

why would the target send a Login Response to a non-login request?

Thanks

-- 
Michael Morrison
[email-masked]
ISTOR Networks
7585 Irvine Center Dr. Ste 250
Irvine Ca. 92618
PGP Key ID:
http://pgp.mit.edu:11371/pks/lookup?search=0x74C30155&op=index

---

From: Bill Studenmund <[email-masked]>
Date: Wed, 25 Sep 2002 15:28:10 -0700 (PDT)

> Shouldn't the target send back a Reject PDU with PROTOCOL ERROR in this

No. This case explicitly requires a Login Response.

> why would the target send a Login Response to a non-login request?

You mean besides the fact that's what the standard says? :-)

I think the idea is if we're not in FFP, only Login Req/Rsp PDUs are
valid. If we're in FFP, everything except them is valid. If the target
thinks the initiator broke that rule, it should not also break the rule in
telling the initiator that the initiator messed up. Thus a Login Rsp.

Also, things should be clearer for the initator. If it thinks it's not in
FFP, and it gets a PDU other than Login Rsp, it can immediately flag it as
an error.  It doesn't have to look and see, "oh, the target is saying I
did something wrong."

Take care,

Bill

---

From: "Robert D. Russell" <[email-masked]>
Date: Wed, 25 Sep 2002 17:24:06 -0400 (EDT)

Michael:

The simplest answer is because the target is allowed
to send only Login Response PDUs during login phase,
and it is therefore illegal for it to send a Reject PDU.

Best,

Bob Russell
InterOperability Lab
University of New Hampshire
[email-masked]
603-862-3774

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Sat, 28 Sep 2002 09:00:24 -0700

Hi Michael,
   It makes perfect sense. In case of processing the Login request the Target is in the Login processing state machine, if you will. Hence sending a Login reject is the most appropriate response. 
    The development process also stays simple in that manner.

Regards
Sukanta Ganguly
Opulent Systems

*********** REPLY SEPARATOR  ***********