Subject: Re: SAS and iSCSI

From: "Julian Satran" <[email-masked]>
Date: Mon, 2 Sep 2002 19:39:35 +0300

Extension (as keys, etc.) can be handled in iSCSI in a standard defined
way.

I assume that SAS (a limited distance serial attachement) and iSCSI are
complementary and I view SAS
a "local" (vs. SAN) attachment and iSCSI more as a network attachment.

Julo

                      Andre Hedrick                                                                                            
                      <andre@pyxtechnol        To:       Julian Satran/Haifa/IBM@IBMIL                                         
                      ogies.com>               cc:       [email-masked]                                                       
                                               Subject:  SAS and iSCSI                                                         
                      02/09/02 03:37                                                                                           

Hi Julian et al.

Give these are both "SCSI" type transports, what are the means to add
future SAS extentions and opcodes to the expected final version of the
working group document?

Would this be considered a vendor specific issue.

Regards,

Andre Hedrick
iSCSI Software Solutions Provider
http://www.PyXTechnologies.com/

---

From: Andre Hedrick <[email-masked]>
Date: Mon, 2 Sep 2002 12:04:25 -0700 (PDT)

Julian and David,

Thanks for the reply and update, I guess the second part never made it to
the reflector.

Will the additional opcodes and command descriptor blocks that
are definied in SAS be transferred using additional header segements by
the iSCSI transport?

This assumes there will be new opcodes as SAS is very much ontrack to be
an API for array management.  Specifically where many of the current
management applications of heavily mated to SCSI and SAS is a means to
grant them extended life, whereas the hardware is dying.  So in order to
acommidate such dependencies, the concern is to insure that iSCSI will be
adaptable to address their over short comings to be so tightly tied to a
transport layer and semi dependent of physical layers.

Cheers,

Andre Hedrick