Subject: RE: iscsi: iSCSI Boot -- Informational or Standards track

From: [email-masked]
Date: Wed, 18 Sep 2002 21:07:40 -0400

[WG chair hat on]
 
Folks,
 
Having just had to explain how/why fiddling with formats for
the DHCP Root Path option could cause interoperability problems,
I'm inclined to send have the boot draft go standards track in
order to specify that when the "iscsi:" prefix is used for the
DHCP Root Path option to support booting via iSCSI, then the format
defined in the boot draft MUST be used.  At the moment, I think use
of RFC 2119 imperatives (e.g., MUST) would be limited to Section 4
of the boot draft where this format is defined, but I think the
interoperability issue recently discussed on this list merits
using those imperatives.  Section 1 of the boot draft is about
requirements on booting mechanisms for iSCSI and hence does
not appear to warrant RFC 2119 imperatives.
 
Comments?
--David
---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 249-6449            FAX: +1 (508) 497-8018
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

-----Original Message-----
From: Elizabeth Rodriguez [mailto:[email-masked]]
Sent: Wednesday, September 18, 2002 4:11 PM
To: [email-masked]
Subject: iscsi: iSCSI Boot -- Informational or Standards track

[chair hat off] 

All 

When reviewing the Boot document last week, one think I overlooked was the
fact that the boot draft is currently informational.

In my editorial comments (to the authors only), I listed the fact that it
was not written in the language of RFC 2119. 
It was pointed out that the draft is informational.  I feel that it probably
should be standards track. 
It lists minimum requirements for boot, parameters, as well as defaults for
optional parameters, and formats for these fields.

This appears to me to be content for a standards track document, not an
informational one. 

Informational documents are of general interest/information, not necessarily
representative of group consensus. 
This document seems to be one which is really trying to define parameters
and behavior needed for iSCSI Boot, 
which means interoperability considerations -- that is a standards track
type of document. 

What does the rest of the group think? 

Thanks, 

Elizabeth

---

From: Bill Studenmund <[email-masked]>
Date: Thu, 19 Sep 2002 08:58:34 -0700 (PDT)

> not appear to warrant RFC 2119 imperatives.

Sounds appropriate.

Take care,

Bill