Subject: iSCSI: re: SCSI device names

From: "KRUEGER,MARJORIE (HP-Roseville,ex1)" <[email-masked]>
Date: Tue, 29 Oct 2002 13:27:47 -0800

David,
As you suggest, I've written a draft proposal to add an "naa." format to
iSCSI name formats and posted it before the draft-00 cutoff.  The draft is
available at
http://www.ietf.org/internet-drafts/draft-krueger-iscsi-name-ext-00.txt 

Could we please have 30 minutes of agenda time at the Atlanta IETF to
discuss this proposal?  

Thank you 
Marjorie Krueger
Networked Storage Architecture
Networked Storage Solutions
Hewlett-Packard

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Wednesday, October 23, 2002 12:53 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: SCSI device names
> 
> 
> Mallikarjun (and Rob),
> 
> Turning the iSCSI naming architecture into a T10 standard is 
> fine, but it looks like there's an item going back the other 
> way to bless the use of "naa." names with iSCSI.  I think the 
> window is closed on functional additions to the main iSCSI 
> draft, so any addition of "naa." should be written up as a 
> separate draft including all of the explanations of and 
> references to use of names for the same device across 
> multiple protocols.  The WG would need to discuss whether to 
> allow use of "naa." as a full iSCSI name vs. as a unique ID 
> returned only by VPD mode page access and the like.
> 
> There's still time to get a -00 draft in by the
> Atlanta cutoff (9am, Monday, October 28th) - I strongly 
> suggest doing so in order to get this onto the Atlanta IPS 
> agenda. Don't worry about fully polishing the draft, as the 
> major point is to tee up a discussion.
> 
> Thanks,
> --David
> ----------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 176 South St., Hopkinton, MA  01748
> +1 (508) 293-7953 **NEW**     FAX: +1 (508) 293-7786
> [email-masked]        Mobile: +1 (978) 394-7754
> ----------------------------------------------------
> 
> > -----Original Message-----
> > From: Mallikarjun C. [mailto:[email-masked]]
> > Sent: Wednesday, October 23, 2002 3:34 PM
> > To: Julian Satran; [email-masked]
> > Cc: Rob Elliott; Marjorie
> > Subject: Fw: SCSI device names
> > 
> > 
> > Julian and David,
> > 
> > Don't know if you're following this thread on T10, FYI.
> > 
> > Rob and I talked about this, I think it's a good idea to turn iSCSI's 
> > naming architeture into a T10 standard (if it's agreeable to T10 CAP).  
> > This also gets us out of the predicament of having LU WWNs contain 
> > (implicit) iSCSI-dependencies (because LU WWNs are keyed off of the 
> > unique device/port name).
> > 
> > If iSCSI's enhancements that Rob refers to below could not be
> > added to iSCSI rev19, then I suppose it'd have to wait for iSCSI's
> > standards status.  David, can you please comment?  In any case,
> > it shouldn't prevent T10 from adopting this into SPC-3.
> > --
> > Mallikarjun
> > 
> > Mallikarjun Chadalapaka
> > Networked Storage Architecture
> > Network Storage Solutions
> > Hewlett-Packard MS 5668
> > Roseville CA 95747
> > [email-masked]
> > 
> > ----- Original Message -----
> > From: "Elliott, Robert (Server Storage)" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Tuesday, October 22, 2002 5:23 PM
> > Subject: SCSI device names
> > 
> > 
> > The current rule in SAM-3 is that a device may have one
> > device name per
> > transport protocol.  This means, for example, that a target 
> > device with
> > both SAS and iSCSI target ports has two device names - the 
> iSCSI name
> > and the SAS device name.
> > 
> > Assuming 02-254 (WWNs for W-LUNs) passes, these would be
> > returned as two
> > device identifiers in VPD data:
> > 1. SAS device name
> > association=target device (2h)
> > protocol identifier=SAS (6h)
> > identifier type=NAA (3h)  
> > identifier=IEEE Registered format (NAA=5h), 8 bytes long
> > 
> > 2. iSCSI device name
> > association=target device (2h)
> > protocol identifier=iSCSI (5h)
> > identifier type=iSCSI name-based (7h)    (to be proposed in 02-419)
> > identifier=UTF-8 format string, up to 224 bytes long
> > 
> > It would be simpler if there were only one device name for a device.
> > 
> > Since only iSCSI has defined device names to date (SAS is
> > just planning
> > to include a device name now, and FCP-3 might define one 
> too), we have
> > an opportunity to make all device names follow the iSCSI name-based
> > format and let each device have a single device name regardless of
> > protocol.  
> > 
> > The iSCSI name format is a UTF-8 (similar to ASCII) string 
> that starts 
> > with a naming authority: "iqn."  for an iSCSI-defined 
> reverse domain 
> > name string (e.g.
> > "iqn.2001-04.com.acme:storage.disk2.sys1.xyz")
> > "eui."  for a hexadecimal representation of an EUI-64 
> identifier (e.g.
> > "eui.02004567A425678D")
> > 
> > iSCSI could easily add an "naa." type to carry a hexadecimal 
> > representation of an NAA identifier (e.g. "naa.52004567A425678D"), 
> > needed to carry the format used by SAS and Fibre Channel port names.
> > 
> > Then, a target device with target ports of different
> > protocols could use
> > any string format it likes as its sole device name. 
> > 
> > Likely choices:
> > iSCSI-only device: "iqn." (it may have no hardware names available) 
> > SAS-only device: "naa." FC-only device: "naa."
> > SRP-only device: "eui."
> > SBP-2-only device: "eui."
> > iSCSI/SAS combination device: "naa." since it is already using NAA
> > identifiers available for port names
> > SRP/iSCSI/SAS combination device: "naa." or "eui." since it 
> > already has
> > NAA and EUI-64s for port names
> > 
> > This would divorce the device name concept from the transport
> > protocols.
> > Transport protocols could still require their devices have a device
> > name, but wouldn't comment on the format.
> > 
> > --
> > Rob Elliott, [email-masked]
> > Industry Standard Server Storage Advanced Technology Hewlett-Packard
> > 
> > 
> > 
> > 
>

---

From: [email-masked]
Date: Wed, 30 Oct 2002 22:57:08 -0500

Marj,

It'll be on the agenda.  Please ensure that the
slides describing the proposal are clear about the
cross-transport SCSI motivations/aspects (i.e., provide a
clear description of the problem(s) that this proposal
is intended to solve).

Thanks,
--David

> From: KRUEGER,MARJORIE (HP-Roseville,ex1)
> [mailto:[email-masked]]
> Sent: Tuesday, October 29, 2002 4:28 PM
> To: [email-masked]'; [email-masked]; [email-masked]
> Cc: ELLIOTT,ROBERT (HP-Houston,Server Storage); [email-masked];
> John Hufferd ([email-masked]); IPS
> Subject: iSCSI: re: SCSI device names
> 
> 
> David,