Subject: question on reserve and release !

From: "Ramesh Ramakrishnan" <[email-masked]>
Date: Fri, 18 Oct 2002 14:13:53 -0700

> Hi All,
> 
> I have a question on how iscsi will handle the scsi reserve and release commands.
> 
> When multiple iscsi initiators make calls to the same iscsi target, the actual scsi
> device only sees one single scsi id (that of the scsi HBA on the iscsi target
> machine).  This would mean that different iscsi initiators sending scsi reserve
> command will be interpreted by the scsi target as commands from the same
> scsi initiator.  This defeats the purpose of implementing the scsi reserve/release
> commands.  And in a way, makes iscsi not very useful in environments where
> iscsi initiator requires exclusive access to a iscsi target. (Imagine a iscsi initiator
> doing a back up to a iscsi tape device when another iscsi initiator starts rewinding
> the same iscsi tape device.)
> 
>  Is this something that should be implemented in the iscsi target
> driver?  I found that Cisco's iscsi driver (1.8.1) for AIX has a  feature called 
> "reserve/release proxy".  Is this cisco's implementation for getting around this
> problem?  Has anyone any experience with that driver? Another interesting
> thing:  I only find reference to this reserve/release proxy mentioned in the AIX driver.
> 
> thanks
> ramesh

---

From: "Julian Satran" <[email-masked]>
Date: Sat, 19 Oct 2002 16:13:15 +0200

In fact the SCSI target sees ONE INITIATOR (name+port) per session. Julo

"Ramesh Ramakrishnan" <[email-masked]>
Sent by: [email-masked]
18/10/02 23:13
 
        To:     <[email-masked]>
        cc: 
        Subject:        question on reserve and release !