Subject: RE: iSCSI: question on reserve and release !

From: "YP Cheng" <[email-masked]>
Date: Tue, 22 Oct 2002 11:38:17 -0700

It is not very practical to try and map 10's or 100's of iSCSI hosts to 15
bits on a parallel SCSI bus. The gateway can maintain additional
reserve/release state and filter the commands thru the gateway to make this
work properly. Basically the gateway ends up maintaining the reservation for
the parallel SCSI device.

John Tyndall

I am in agreement with the above statement.  With the recommended
implementation, the gateway device of iSCSI to parallel SCSI becomes a
"broker" who on behalf of many initiators does a single reservation to the
target device.  As far as the target device is concerned, it still deals
with 15 maximum possible initiators.

Y.P. Cheng
Chief Scientist, Matisse Networks.

---

From: "John Tyndall" <[email-masked]>
Date: Tue, 22 Oct 2002 13:16:17 -0500

It is not very practical to try and map 10's or 100's of iSCSI hosts to 15 bits on a parallel SCSI bus. The gateway can maintain additional reserve/release state and filter the commands thru the gateway to make this work properly. Basically the gateway ends up maintaining the reservation for the parallel SCSI device.

John Tyndall
Architect
Crossroads Systems Inc.
Email  : [email-masked]
Phone : 512-928-7282

-----Original Message-----
From: YP Cheng [mailto:[email-masked]] 
Sent: Tuesday, October 22, 2002 12:19 PM
To: [email-masked]
Subject: RE: question on reserve and release !

> > When multiple iscsi initiators make calls to the same iscsi target, 
> > the actual scsi device only sees one single scsi id (that of the 
> > scsi HBA on the iscsi target machine).  This would mean that 
> > different iscsi initiators sending scsi reserve command will be 
> > interpreted by the scsi target as commands from the same scsi 
> > initiator.

> Which in turn would mean that the implementation of the iscsi to 
> parallel scsi gateway is broken.  SCSI is *not* an end to end protocol 
> whose CDBs can be transparently passed through when changing 
> transports.  For this example, the iscsi to scsi gateway either has to 
> present multiple initiators to the target or has to implement the 
> reserve and release functionality itself on behalf of the target 
> (which should then not be connected externally via any means other 
> than this gateway).

I'm confused by the above statements.  In a selection phase of parallel SCSI, one does know the Host ID bit on the SCSI bus.  Hence, only one initiator can reserve at a time.  Others gets "Reserve Conflict - Status 08".  For iSCSI, different initiators have their own respective sessions. The iSCSI to parallel SCSI gateway can easily emulating a Host ID bit - although it would need multiple logical SCSI busses when the number of initiators exceeds 15 on a wide SCSI bus.

Y.P. Cheng