Subject: iSCSI : Query about parameter exchange

From: "Priya Viswambharan" <[email-masked]>
Date: Fri, 4 Oct 2002 10:18:32 -0700

Hi all,
 
I have a query about parameter negotiation/declaration.
 
Consider the following scenario.
I --> T    T=1, csg=0, nsg=3
 
If the target has to send say its MaxRecvDataSegmentLength (or any other
key which is not valid in the Security phase) to the initiator, is it ok
for the target to respond with
T --> I    T=0, csg=1
            MaxRecvDataSegmentLength=<value>
so that it can notify the Initiator of its capacity.
 
I believe there are some implementations that behave this way. In a
Normal session, if such a login PDU is received from the Initiator the
target can send its MaxRecvDataSegmentLength through a Text response in
Full feature phase. But how could a target notify the Initiator of its
MaxRecvDataSegmentLength in the following 2 scenarios : 1) a Discovery
session 2) a Normal Session and the Initiator has not sent a text
request to the target. 
 
Thanks
Priya

---

From: Bill Studenmund <[email-masked]>
Date: Fri, 4 Oct 2002 12:31:39 -0700 (PDT)

> so that it can notify the Initiator of its capacity.

No. You can only exchange security parameters in Security phase.

Oh, you have to say csg=0 back since that was the stage the first packet
was in.

I think though that the target can say

T --> I T=1 csg=0 nsg=1

and then exchange keys in the normal phase.

> session 2) a Normal Session and the Initiator has not sent a text

As above, the target just forces a normal negotiation phase, and all is
well.

Take care,

Bill

---

From: "Julian Satran" <[email-masked]>
Date: Wed, 9 Oct 2002 01:44:09 +0200

Priya,

The correct target answer would be:

T à I    T=1, csg=0, nsg=1

indicating it wants  to move to stage 1.

After that the Initiator will answer:

I->T  T=x whatever ...

T->I  T=x Max....

This phase can end in a single handshake or have several.

Julo

                      "Priya                                                                                                                     
                      Viswambharan"            To:       <[email-masked]>                                                                       
                      <priyav@marantine        cc:                                                                                               
                      tworks.com>              Subject:  iSCSI : Query about parameter exchange                                                  
                      Sent by:                                                                                                                   
                      [email-masked]                                                                                                          
                      .edu                                                                                                                       

                      04/10/02 20:18                                                                                                             

Hi all,

I à T    T=1, csg=0, nsg=3

T à I    T=0, csg=1

I believe there are some implementations that behave this way. In a Normal
session, if such a login PDU is received from the Initiator the target can
send its MaxRecvDataSegmentLength through a Text response in Full feature
phase. But how could a target notify the Initiator of its
MaxRecvDataSegmentLength in the following 2 scenarios : 1) a Discovery
session 2) a Normal Session and the Initiator has not sent a text request
to the target.

Thanks

Priya