Subject: RE: IPS-ALL: iSNS WG Last Call

From: Anil Rijhsinghani <[email-masked]>
Date: Tue, 8 Oct 2002 09:04:37 -0600

Joshua:

Unless there are objections, it would be useful to add those hooks as an
option. In an environment where both FCIP and iSCSI are in use, and iSNS is
available, it may help to keep down the number of discovery protocols that
need to be managed by the user. Either SLP could be used for both, or iSNS.

Anil

-----Original Message-----
From: Joshua Tseng [mailto:[email-masked]]
Sent: Monday, October 07, 2002 4:08 PM
To: Anil Rijhsinghani; [email-masked]; [email-masked]
Subject: RE: IPS-ALL: iSNS WG Last Call

Anil,

It would be very easy, especially now that Portals can be
members of Discovery Domains.  All we would need to do is
to add a new Entity Protocol type (FCIP = 3).  FCIP connectivity
would then be established based on Portal membership in
Discovery Domains.  Other than that, we would just new narative
text describing how you use iSNS to set up FCIP sessions.

Please let me know if this is desireable for the FCIP folks.

Josh

> -----Original Message-----
> From: Anil Rijhsinghani [mailto:[email-masked]]
> Sent: Monday, October 07, 2002 1:43 PM
> To: [email-masked]'; [email-masked]
> Subject: RE: IPS-ALL: iSNS WG Last Call
> 
> 
> How hard would it be to add hooks for optional FCIP support 
> in iSNS? It
> currently supports only iFCP and iSCSI.
> 
> Regards,
> Anil
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, September 27, 2002 10:07 AM
> To: [email-masked]
> Subject: IPS-ALL: iSNS WG Last Call
> 
> 
> All,
> 
> We would like to announce IPS Working Group Last call for
> the Internet Storage Name Service (iSNS).
> 
> Details:
> 
> Document: Internet Storage Name Service (iSNS)
> URL: http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-13.txt
> Note: There are formatting (line length) problems with this draft.
> 	It may get updated to -14 shortly to correct them without
> 	change to its content.
> 
> Last call period: 2 Weeks
> Submit comments no later than: Sunday, October 13, 2002 at 5pm EST
> Editor:  Josh Tseng <[email-masked]>
>  
> Please submit editorial comments directly to Josh, with copy 
> to David Black
> ([email-masked]), and Elizabeth Rodriguez([email-masked])
> Submit technical comments to the IPS mailing list ([email-masked])
> 
> Editorial comments may be resolved directly by the editor of 
> the document,
> but any technical issues must be discussed on the IPS reflector.
> 
> Thanks,
> David Black & Elizabeth Rodriguez
> IPS co-chairs
> 
> ---------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 42 South St., Hopkinton, MA  01748
> +1 (508) 249-6449            FAX: +1 (508) 497-8018
> [email-masked]       Mobile: +1 (978) 394-7754
> ---------------------------------------------------
> 
> 
> ===========================================================
> Notice
> 
> All information transmitted hereby is intended only for the use of the
> addressee(s) named above and may contain confidential and privileged
> information.  Any unauthorized review, use, disclosure or 
> distribution is
> prohibited.  If the reader of this message is not the 
> intended recipient(s)
> or the employee or agent responsible for delivering the message to the
> intended recipient(s), you may not distribute or copy this 
> communication to
> another.  Anyone who receives this communication in error 
> should notify us
> immediately by telephone and mail the original message to us 
> at the above
> address and destroy all copies.
> ===========================================================
> 

===========================================================
Notice

All information transmitted hereby is intended only for the use of the
addressee(s) named above and may contain confidential and privileged
information.  Any unauthorized review, use, disclosure or distribution is
prohibited.  If the reader of this message is not the intended recipient(s)
or the employee or agent responsible for delivering the message to the
intended recipient(s), you may not distribute or copy this communication to
another.  Anyone who receives this communication in error should notify us
immediately by telephone and mail the original message to us at the above
address and destroy all copies.
===========================================================

---

From: "Dave Peterson" <[email-masked]>
Date: Tue, 8 Oct 2002 19:37:59 -0500

I object.
The FCIP group discussed this issue and agreed that SLPv2 was to be used for
FCIP Entity discovery.
As such, the recently completed FCIP draft contains no mention of iSNS
support.
A single dynamic discovery protocol is needed and its SLPv2.

...dap

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Anil Rijhsinghani
> Sent: Tuesday, October 08, 2002 10:05 AM
> To: 'Joshua Tseng'; [email-masked]

---

From: Ralph Weber <[email-masked]>
Date: Wed, 09 Oct 2002 06:08:53 -0500

Dave is 100% correct.

During the development of FCIP the issue of discovery mechanisms
was considered in detail. The decision was that iSNS is too heavy
weight a discovery protocol for FCIP needs and SLPv2 was chosen
and documented as the best fit solution.

Suggesting in iSNS that there is a relationship with FCIP will
lead to confusion when no supporting discussion can be found in
the FCIP RFC.

No changes are required in iSNS.

Thanks.

.Ralph