Subject: [Ips] iSCSI: length clarifications

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 15 Oct 2003 16:14:46 -0700

Julian,

In reviewing the port name text in section 3.4.2, I noticed the
following:
a text encoding as a hex-constant (see Section 5.1 Text
Format) of the ISID (for SCSI initiator port) or the
portal group tag (for SCSI target port) including the
initial 0X or 0x and the terminating null (14 bytes).

Given that ISID is 6 bytes binary (hence 12 nibbles), I think the
14 bytes account only for length "not including the terminating
null".  It would be good to fix it if we can.

In addition, a less critical (but useful) clarification is for text in
section 3.2.6.1 which says
"Initiators and targets MUST support the receipt of
iSCSI names of up to the maximum length of 223 bytes."

I suggest adding the same "not including the terminating null"
qualifier at the end of the quoted sentence as well.

Regards.
--
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard, Roseville
cbm [at] rose.hp.com

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Julian Satran" <[email-masked]>
Date: Thu, 16 Oct 2003 12:08:42 +0200

makes sense - Julo

"Mallikarjun C." <[email-masked]> 
16/10/2003 01:14

To
Julian Satran/Haifa/IBM@IBMIL
cc
[email-masked]
Subject
iSCSI: length clarifications

Julian,

Regards.
--
Mallikarjun

Mallikarjun Chadalapaka