Subject: [Ips] RE: iSNS boot information

From: "Kevin Gibbons" <[email-masked]>
Date: Sun, 2 Nov 2003 18:18:45 -0800

Josh,
    the latest drafts of the documents referenced would be:
1) Using DHCP to discover the iSNS
    http://www.ietf.org/internet-drafts/draft-ietf-dhc-isnsoption-10.txt
 
2) Using the Discovery Domain boot list option
    http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-21.txt
please see Section 6.11.2.9, Discovery Domain Features.
 
Please let me know if you have any questions.
    Regards, Kevin

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] 
	Sent: Saturday, November 01, 2003 6:53 AM
	To: Kevin Gibbons
	Cc: [email-masked]
	Subject: iSNS boot information

	Hi Kevin, 

	I found the following post to be very interesting. We're trying
to boot an iSCSI initiator using iSNS. Where is the document referenced
below? The link no longer works. Any other information you may have
would be quite useful. Thanks.

	Josh 

------------------------------------------------------------------------
-------- 

	To: [email-masked] 
	Subject: iSCSI Boot: use of iSNS 
	From: Kevin Gibbons <[email-masked]> 
	Date: Wed, 19 Mar 2003 10:48:33 -0800 
	Content-Type: text/plain 
	Sender: [email-masked] 

------------------------------------------------------------------------
-------- 

	At the IPS WG session at IETF 56, we discussed the iSCSI Boot
draft.  It 
	involved how to find the iSCSI target to boot from, as well as
security 
	issues for the process.  The following is a process using DHCP
and iSNS to 
	find the appropriate iSCSI target to use for boot: 
	1) use DHCP to find the iSNS Server.  Please see: 
	
http://www.ietf.org/internet-drafts/draft-ietf-dhc-isnsoption-05.txt
<http://www.ietf.org/internet-drafts/draft-ietf-dhc-isnsoption-05.txt>  

	2) query the iSNS server to find the Discovery Domain Feature
"Boot List 
	Enabled" for the specified iSCSI node or entity.  Please see: 
	
http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-18.txt
<http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-18.txt>  
	--- 
	6.10.2.9 Discovery Domain Features 
	   The Discovery Domain Features is a bitmap indicating the
features of 
	   this DD.  The bit positions are defined below.  A bit set to
1 
	   indicates the DD has the corresponding characteristics. 

	       Bit Position     DD Feature 
	       ------------     ---------- 
	          31 (Lsb)      Boot List Enabled (1)/Boot List Disabled
(0) 
	        All Others      RESERVED 
	    
	   Boot List: this feature indicates that the targets in this DD
provide 
	   boot capabilities for the member initiators, as described in
[iSCSI- 
	   boot]. 
	--- 
	Couple items: 
	1) The iSNS Server provides the ability to distribute security
policies. 
	2) The size of an iSNS Client may vary.  However, the code to
query the iSNS 
	server for a boot-list enabled DD based on an iSCSI name is not
very 
	complex.  Most of the complexity in iSNSP is on the server side.

	3) SLPv2 and multicast are other alternative methods to DHCP to
find the 
	iSNS server.  Additionally, SLPv2 is an alternative to iSNS for
locating the 
	target to boot from, which is already described in iSCSI-boot. 

SPECIAL NOTICE 

All information transmitted hereby is intended only for the use of the 
addressee(s) named  above and may contain confidential and privileged 
information. Any unauthorized  review, use, disclosure or distribution
of confidential and privileged information is prohibited. If the reader of
this message is not the intended recipient(s) or the employee or agent 
responsible for delivering the message to the intended recipient, you
are herby notified that you must not read this transmission and that
disclosure, copying, printing, distribution or use of any of the
information contained in or attached to this transmission is STRICTLY 
PROHIBITED.

Anyone who receives confidential and privileged information in error should 
notify us immediately by telephone and mail the original message to us at the
above address and destroy all copies.  To the extent any portion of this
communication contains public information, no such restrictions 
apply to that information. (gate01)

---

From: [email-masked]
Date: Mon, 3 Nov 2003 17:14:38 -0500

Kevin,
 
Thank you very much! After reading Section 6.11.2.9, I'm assuming what
we're trying to do should work. Our scenario is as follows:
 
Boot Windows XP w/ Microsoft's iSCSI driver
MS iSNS Server
 
We want our PC's to receive it's DCHP address along with first boot LUN
from iSNS in order to boot MS XP directly from it. Is this possible with
the current implementations addressed below?

Josh

-----Original Message-----
From: Kevin Gibbons [mailto:[email-masked]] 
Sent: Sunday, November 02, 2003 9:19 PM
To: Villagomez, Joshua
Cc: [email-masked]
Subject: RE: iSNS boot information

	Josh,

	
http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-21.txt please
see Section 6.11.2.9, Discovery Domain Features.

		-----Original Message-----
		From: [email-masked] [mailto:[email-masked]] 
		Sent: Saturday, November 01, 2003 6:53 AM
		To: Kevin Gibbons
		Cc: [email-masked]
		Subject: iSNS boot information

		Hi Kevin, 

		I found the following post to be very interesting. We're
trying to boot an iSCSI initiator using iSNS. Where is the document
referenced below? The link no longer works. Any other information you
may have would be quite useful. Thanks.

		Josh 

		To: [email-masked] 

		At the IPS WG session at IETF 56, we discussed the iSCSI
Boot draft.  It 
		involved how to find the iSCSI target to boot from, as
well as security 
		issues for the process.  The following is a process
using DHCP and iSNS to 
		find the appropriate iSCSI target to use for boot: 
		1) use DHCP to find the iSNS Server.  Please see: 

		2) query the iSNS server to find the Discovery Domain
Feature "Boot List 
		Enabled" for the specified iSCSI node or entity.  Please
see: 
	
http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-18.txt
<http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-18.txt>  
		--- 
		6.10.2.9 Discovery Domain Features 
		   The Discovery Domain Features is a bitmap indicating
the features of 
		   this DD.  The bit positions are defined below.  A bit
set to 1 
		   indicates the DD has the corresponding
characteristics. 

		       Bit Position     DD Feature 
		       ------------     ---------- 
		          31 (Lsb)      Boot List Enabled (1)/Boot List
Disabled (0) 
		        All Others      RESERVED 
		    
		   Boot List: this feature indicates that the targets in
this DD provide 
		   boot capabilities for the member initiators, as
described in [iSCSI- 
		   boot]. 
		--- 
		Couple items: 
		1) The iSNS Server provides the ability to distribute
security policies. 
		2) The size of an iSNS Client may vary.  However, the
code to query the iSNS 
		server for a boot-list enabled DD based on an iSCSI name
is not very 
		complex.  Most of the complexity in iSNSP is on the
server side. 
		3) SLPv2 and multicast are other alternative methods to
DHCP to find the 
		iSNS server.  Additionally, SLPv2 is an alternative to
iSNS for locating the 
		target to boot from, which is already described in
iSCSI-boot. 

SPECIAL NOTICE 

of confidential and privileged information is prohibited. If the reader
of

Anyone who receives confidential and privileged information in error
should 
notify us immediately by telephone and mail the original message to us
at the
above address and destroy all copies.  To the extent any portion of this
communication contains public information, no such restrictions 
apply to that information. (gate01)

---

From: "Kevin Gibbons" <[email-masked]>
Date: Mon, 3 Nov 2003 19:29:08 -0800

Josh,
    based on the draft specifications, your proposed design will work.
 
    The DHCP Server can provide a client both an IP-Address and the
primary, and optionally a secondary, iSNS Server address.  The client
can then obtain the boot target from the iSNS Server by querying for the
Discovery Domain marked as bootlist.
 
    A couple notes:
1) the iSNS DHC server option number has not yet been defined by IANA.
Any option number used now may change if/when the draft is ratified as
an RFC.
2) the DHC server would need to be properly configured to return the
appropriate iSNS Server address.
 
    Regards, Kevin

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] 
	Sent: Monday, November 03, 2003 2:15 PM
	To: Kevin Gibbons
	Cc: [email-masked]
	Subject: RE: iSNS boot information

	Kevin,
	 
	Thank you very much! After reading Section 6.11.2.9, I'm
assuming what we're trying to do should work. Our scenario is as
follows:

	We want our PC's to receive it's DCHP address along with first
boot LUN from iSNS in order to boot MS XP directly from it. Is this
possible with the current implementations addressed below?

	Josh

	-----Original Message-----
	From: Kevin Gibbons [mailto:[email-masked]] 
	Sent: Sunday, November 02, 2003 9:19 PM
	To: Villagomez, Joshua
	Cc: [email-masked]
	Subject: RE: iSNS boot information

		Josh,
		    the latest drafts of the documents referenced would
be:
		1) Using DHCP to discover the iSNS

	

			-----Original Message-----
			From: [email-masked] [mailto:[email-masked]] 
			Sent: Saturday, November 01, 2003 6:53 AM
			To: Kevin Gibbons
			Cc: [email-masked]
			Subject: iSNS boot information

			Hi Kevin, 

			I found the following post to be very
interesting. We're trying to boot an iSCSI initiator using iSNS. Where
is the document referenced below? The link no longer works. Any other
information you may have would be quite useful. Thanks.

			Josh 

			To: [email-masked] 

			At the IPS WG session at IETF 56, we discussed
the iSCSI Boot draft.  It 
			involved how to find the iSCSI target to boot
from, as well as security 
			issues for the process.  The following is a
process using DHCP and iSNS to 
			find the appropriate iSCSI target to use for
boot: 
			1) use DHCP to find the iSNS Server.  Please
see: 

			2) query the iSNS server to find the Discovery
Domain Feature "Boot List 
			Enabled" for the specified iSCSI node or entity.
Please see: 
	
http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-18.txt
<http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-18.txt>  
			--- 
			6.10.2.9 Discovery Domain Features 
			   The Discovery Domain Features is a bitmap
indicating the features of 
			   this DD.  The bit positions are defined
below.  A bit set to 1 
			   indicates the DD has the corresponding
characteristics. 

			       Bit Position     DD Feature 
			       ------------     ---------- 
			          31 (Lsb)      Boot List Enabled
(1)/Boot List Disabled (0) 
			        All Others      RESERVED 
			    
			   Boot List: this feature indicates that the
targets in this DD provide 
			   boot capabilities for the member initiators,
as described in [iSCSI- 
			   boot]. 
			--- 
			Couple items: 
			1) The iSNS Server provides the ability to
distribute security policies. 
			2) The size of an iSNS Client may vary.
However, the code to query the iSNS 
			server for a boot-list enabled DD based on an
iSCSI name is not very 
			complex.  Most of the complexity in iSNSP is on
the server side. 
			3) SLPv2 and multicast are other alternative
methods to DHCP to find the 
			iSNS server.  Additionally, SLPv2 is an
alternative to iSNS for locating the 
			target to boot from, which is already described
in iSCSI-boot. 

SPECIAL NOTICE

---

From: "Alan Warwick" <[email-masked]>
Date: Wed, 5 Nov 2003 10:11:47 -0800

Josh,

The Microsoft iSCSI initiator only supports boot by using an iSCSI HBA
card that has int 13 extensions. Booting from the software initiator is
not supported.  However given an iSCSI HBA card that supports these
drafts there is no reason why this would not work.

Alan Warwick

Microsoft

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, November 03, 2003 2:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ips] RE: iSNS boot information

Kevin,

MS iSNS Server

 

Josh

-----Original Message-----
From: Kevin Gibbons [mailto:[email-masked]] 
Sent: Sunday, November 02, 2003 9:19 PM
To: Villagomez, Joshua
Cc: [email-masked]
Subject: RE: iSNS boot information

	Josh,

	    Regards, Kevin

		-----Original Message-----
		From: [email-masked] [mailto:[email-masked]] 
		Sent: Saturday, November 01, 2003 6:53 AM
		To: Kevin Gibbons
		Cc: [email-masked]
		Subject: iSNS boot information

		Hi Kevin, 

		Josh 

		To: [email-masked] 

	

		       Bit Position     DD Feature 
		       ------------     ---------- 

SPECIAL NOTICE