Subject: [Ips] [Ips]target online notification

From: dan yo <[email-masked]>
Date: Fri, 14 Nov 2003 11:38:52 -0800 (PST)

Hi,
Suppose a host is connected to a target (discovered earlier through SendTargets) and the target goes offline.  When the target comes back online, is there a way in the iSCSI protocol to tell the host about it (other than using SCN in iSNS)?  or does the host have to do busy retry?  I am particularly interested in how the Microsoft iSCSI stack handles this situation.
Thanks.

---------------------------------
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard

---

From: Paul von Behren <[email-masked]>
Date: Fri, 14 Nov 2003 12:50:34 -0700

There's a related question for LUN configuration changes - suppose
the target is a RAID array and someone creates a LUN, or changes
it's visibility with LUN masking.  Is there some mechanism the
array can use to tell the host drivers to look for changes
in the LUN configuration.  In FCP, this is often done with
a LIP or RSCN.  Does iSCSI allow a target to send an SCN to
initiators?

thanks,
Paul

dan yo wrote:

> Hi,
> Suppose a host is connected to a target (discovered earlier through 
> SendTargets) and the target goes offline.  When the target comes back 
> online, is there a way in the iSCSI protocol to tell the host about it 
> (other than using SCN in iSNS)?  or does the host have to do busy 
> retry?  I am particularly interested in how the Microsoft iSCSI stack 
> handles this situation.
> Thanks.
> 
> ------------------------------------------------------------------------
> Do you Yahoo!?
> <http://antispam.yahoo.com/whatsnewfree>

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: [email-masked]
Date: Thu, 20 Nov 2003 13:25:32 -0800 (PST)

> a LIP or RSCN.  Does iSCSI allow a target to send an SCN to

I'm not that familiar with FCP, but isn't there a SCSI way to notice this?
iSCSI can transmit asynchronous UAs back to the initiator, so any
initiator logged into the target can (if there's an appropriate UA) find
out about the LUN change.

Take care,

Bill

---

From: Paul von Behren <[email-masked]>
Date: Thu, 20 Nov 2003 14:55:03 -0700

> I'm not that familiar with FCP, but isn't there a SCSI way to notice this?

As far as I know, SCSI standards have no mechanism for a target to
send a message asynchronously.  There have been many proposals,
but nothing is currently provided in the T10 specification.  There
certainly is nothing in common use.

> out about the LUN change.

UAs are a response to an initiator request and are only possible
if the initiator is actively sending SCSI requests.  If the
initiator is idle, then there is no message. And UAs won't help
at all to tell an initiator when administrative actions have made
the first logical unit available to that initiator (if the initiator
thinks there are no units on a target, it won't be issuing any I/Os
to get the UA).  This forces a "poll the universe" policy which does
not scale up.  Hence the FC approach of using a transport-specific
interface (LIP for loop and RSCN for fabric topologies).

I agree that a SCSI/T10 solution makes more sense.  But since
FC was unable to get this solution, I think it's unlikely that
iSCSI will.  I would rather have an iSCSI-specific solution
available rather than none.

Paul

---

From: [email-masked]
Date: Thu, 20 Nov 2003 14:39:47 -0800 (PST)

> certainly is nothing in common use.

iSCSI can. Please see the Asynchronous Message PDU, in section 10.9 of the
iSCSI RFC.

From the RFC:

The codes used for iSCSI Asynchronous Messages (events) are:

0 - a SCSI Asynchronous Event is reported in the sense data. Sense Data
that accompanies the report, in the data segment, identifies the
condition. The sending of a SCSI Event (Asynchronous Event Reporting in
SCSI terminology) is dependent on the target support for SCSI asynchronous
event reporting (see [SAM2]) as indicated in the standard INQUIRY data
(see [SPC3]). Its use may be enabled SCSI Control mode page (see [SPC3]).

> available rather than none.

See above. SAM-2 and SAM-3 agree that the fix needs to be there, and have
added it. :-)

From looking at SAM-3, section 5.9.7 "Unit Attention condition", there is
a list of UA-generating events. One of them, "g)", is "The logical unit
inventory has been changed." Thus I think that a UA for inventory changes
is the way to go.

Take care,

Bill

---

From: Paul von Behren <[email-masked]>
Date: Thu, 20 Nov 2003 16:06:45 -0700

[email-masked] wrote:
> 0 - a SCSI Asynchronous Event is reported in the sense data.

Asynchronous event reporting was removed from SAM-3 last November,
see http://www.t10.org/ftp/t10/document.02/02-458r0.pdf - and
look at recent SAM 3 versions (current is R9).

My impression is that AER was considered unimplementable (at
least by some).

It sounds like the iSCSI spec needs to be updated since this
is no longer a valid option.

> Sense Data

And then took it away :-(

> inventory has been changed." Thus I think that a UA for inventory changes

Agreed that UA works fine when the initiator is active.  What is missing
(now) is the ability to asynchronously notify the initiator.  The
typical approach for FC drivers is that when the initiator side
receives the RSCN, we rerun discovery logic - so some inquiry
will see the UA.

Paul

---

From: [email-masked]
Date: Thu, 20 Nov 2003 15:22:46 -0800 (PST)

> My impression is that AER was considered unimplementable (at

That's sad. iSCSI implemented it, and our target supports it, so it is
implementable in principle. :-)

Take care,

Bill