Subject: [Ips] Question about ABORT_TASK and unsolicited DATA_OUT stream

From: "Pittman, Joseph" <[email-masked]>
Date: Fri, 5 Dec 2003 14:26:22 -0500

I have a question about the interaction between ABORT_TASK
(or ABORT_TASK or CLEAR_TASK_SET) and a burst of unsolicited
DATA_OUTs.
 
Suppose the target and initiator have negotiated
  InitialR2T=no
  ImmediateData=no
  FirstBurstLength=64KB
  
and the initiator sends the following PDUs:
 
  SCSI_CMD/WRITE 128KB/F=0
  DATA_OUT/16KB/F=0
  DATA_OUT/16KB/F=0
  ABORT_TASK
 
When the target receives the abort task, should it expect
the initiator to send the remaining 32KB of the expected
64KB burst of unsolicited data?
 
Or does the initiator's sending of the ABORT_TASK imply
that it will not be sending any more data?
 
I looked through the iSCSI specification for an answer, and
found only this text which seems to relate to this topic:
 
  3.2.4.2 Data Transfer Overview
  ...
  An iSCSI initiator MAY choose not to send unsolicited data, only
  immediate data or FirstBurstLength bytes of unsolicited data with a
  command. If any non-immediate unsolicited data is sent, the total
  unsolicited data MUST be either FirstBurstLength, or all of the data
  if the total amount is less than the FirstBurstLength.
 
This says the initiator must send the full burst.  But somehow,
I don't think this section is really talking about the 'ABORT
during burst' case.

Is there any text, either in the iSCSI spec or the SCSI-3
specifications, which would provide an authoritative statement
on this?  If not, would any of the authors care to give some
guidance?
 
Thanks in advance for any help.
--
Joe Pittman
[email-masked]

---

From: Julian Satran <[email-masked]>
Date: Sat, 6 Dec 2003 12:35:54 -0500

The text considers this as another one of the "data and commands in 
flight" situation and says only that the target should cancel excution 
(that assumes also should not expect more data) return whatever status is 
pending - make sure all status was receive then send the response to 
abort.

Julo

"Pittman, Joseph" <[email-masked]> 
Sent by: [email-masked]
05/12/2003 14:26

To
<[email-masked]>
cc
"Jin, Tao" <[email-masked]>
Subject
[Ips] Question about ABORT_TASK and unsolicited DATA_OUT stream

 
 
  SCSI_CMD/WRITE 128KB/F=0
  DATA_OUT/16KB/F=0
  DATA_OUT/16KB/F=0
  ABORT_TASK

---

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 8 Dec 2003 12:17:23 -0500

Julian, can you please give a paragraph reference for that?

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Pittman, Joseph 
  Cc: [email-masked] ; [email-masked] ; Jin, Tao 
  Sent: Saturday, December 06, 2003 12:35 PM
  Subject: Re: [Ips] Question about ABORT_TASK and unsolicited DATA_OUT stream

  The text considers this as another one of the "data and commands in flight" situation and says only that the target should cancel excution (that assumes also should not expect more data) return whatever status is pending - make sure all status was receive then send the response to abort. 

  Julo 

        "Pittman, Joseph" <[email-masked]> 
        Sent by: [email-masked] 
        05/12/2003 14:26 
       To <[email-masked]>  
              cc "Jin, Tao" <[email-masked]>  
              Subject [Ips] Question about ABORT_TASK and unsolicited DATA_OUT stream 

    

    SCSI_CMD/WRITE 128KB/F=0 
    DATA_OUT/16KB/F=0
   DATA_OUT/16KB/F=0 
    ABORT_TASK

---

From: Julian Satran <[email-masked]>
Date: Tue, 9 Dec 2003 08:54:48 +0200

Eddy,

The paragraphs are 10.5 & 10.6. You have there what is expected from the 
initiator and target in case of abort. Particularly the target must wait 
only for answers to R2Ts it issued and initiator can truncate them by 
setting the F bit ASAP. etc.

Regards,
Julo

"Eddy Quicksall" <[email-masked]> 
08/12/2003 19:17

To
Julian Satran/Haifa/IBM@IBMIL
cc
<[email-masked]>, <[email-masked]>, "Jin, Tao" <[email-masked]>
Subject
Re: [Ips] Question about ABORT_TASK and unsolicited DATA_OUT stream

Eddy
----- Original Message ----- 
From: Julian Satran 
To: Pittman, Joseph 
Cc: [email-masked] ; [email-masked] ; Jin, Tao 
Sent: Saturday, December 06, 2003 12:35 PM
Subject: Re: [Ips] Question about ABORT_TASK and unsolicited DATA_OUT 
stream

Julo 

To
<[email-masked]> 
cc

 
  
  SCSI_CMD/WRITE 128KB/F=0 
  DATA_OUT/16KB/F=0
 DATA_OUT/16KB/F=0 
  ABORT_TASK