Subject: FW: FW: [Ips] iSCSI Service Assurance

From: Andy Plant <[email-masked]>
Date: Tue, 9 Dec 2003 09:25:55 +1100

As you can see from the responses to my question including the detailed one
from the author of the FCPING utility Bill Pierce I still don't really have
a solution (other than writing my own script). It seems to me that service
assurance facilities for iSCSI need to be built into the specification and
not "Bolted on" afterwards. Does anyone have any thoughts on what tool sets
have been discussed to provide "healthcheck" type facilities across iSCSI
based storage connections at levels above ICMP PING?
Rgds
Andy

-----Original Message-----
From: Bill Pierce [mailto:[email-masked]]
Sent: Saturday, 6 December 2003 03:18
To: Andy Plant
Subject: Re: FW: [Ips] iSCSI Service Assurance

Hi Andy,

Thanks for your inquiry.
Fcping works through a FibreChannel HBA API 
interface, so it can be used for FibreChannel,
FCIP, or iFCP, not iSCSI.  Said differently,
it should work if you have FC on the host end
and their are IP segments of the link, but not
if the link from the host is purely IP or 
ethernet.
If you're going iSCSI through
and IP NIC card, why not just use ping to the
IP address of your storage proxy. That will
test the IP links up to the iSCSI switch 
(the 9509 I'm guessing). 

If you're trying to verify volume(DAS, NAS, SAN)
availability to the application layer, which
is what Vikas seems to be after, why not just
write a simple program or script to 
open and read from a file on the suspect 
volume (or any LUN on the array in question) 
and check for errors.
Are also some decent commercial and free
monitoring tools out there as well if
you're looking for a more heavyweight 
solution (eg. bb4.com).

I wish I could direct you to TeraCloud's 
SRM product for this, but it's more focused on
Space availability and capacity planning 
than physical health monitoring.

Good luck. We visited Australia last year
and really loved it.  G'Day.

     - Bill Pierce

--- Andy Plant <[email-masked]> wrote:
> 
> G'Day Bill,
> I know I'm pushing my luck here but I've been
> reading what I can get on
> FCPING and before I commit time and resources to
> setting up a test I wanted
> to confirm that it is possible to use this utility
> to ping from a host using
> i-SCSI to access a LUN on a storage array across an
> IP network via a Cisco
> 9509 fibre switch.  The techo's here are telling me
> this can only be used on
> a directly connected fibre channel and thus couldn't
> be used to test the IP
> part of the connection.
> Hope you can help.
> Rgds
> Andy
> 
> -----Original Message-----
> From: Aggarwal, Vikas (OFT)
> [mailto:[email-masked]]
> Sent: Tuesday, 2 December 2003 10:10
> To: Andy Plant
> Subject: RE: [Ips] iSCSI Service Assurance
> 
> 
> http://www.tcloud.com/fcping_support.htm
> 

__________________________________
Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: [email-masked]
Date: Mon, 8 Dec 2003 18:19:06 -0800 (PST)

> based storage connections at levels above ICMP PING?

I think there are definitely pieces in the spec that can be used for this.

It's too late to add service assurance to the iSCSI standard, and I think
it would have been inappropriate. I think the best thing to do (which we
will be doing) will be to play with the standard we have, and see what
works and what doesn't.

The SCSI command, TEST UNIT READY, certainly is available for service
monitoring. You also can use NOP-OUT and NOP-IN to monitor iSCSI
functioning, but it would require more of a hook into the initiator. There
are (obvious :-) hooks to pass SCSI commads across an iSCSI connection,
but there aren't defined ones yet to inject iSCSI packets into an iSCSI
connection.

Take care,

Bill

---

From: Julian Satran <[email-masked]>
Date: Tue, 9 Dec 2003 09:07:53 +0200

Andy,

There is a pair of of NOPs built in just for that. I thing you may want to 
read them (and the rest of the spec) before finishing your 
recommendations.

Julo

Andy Plant <[email-masked]> 
Sent by: [email-masked]
09/12/2003 00:25

To
[email-masked]
cc

Subject
FW: FW: [Ips] iSCSI Service Assurance

As you can see from the responses to my question including the detailed 
one
from the author of the FCPING utility Bill Pierce I still don't really 
have
a solution (other than writing my own script). It seems to me that service
assurance facilities for iSCSI need to be built into the specification and
not "Bolted on" afterwards. Does anyone have any thoughts on what tool 
sets
have been discussed to provide "healthcheck" type facilities across iSCSI
based storage connections at levels above ICMP PING?
Rgds
Andy

-----Original Message-----
From: Bill Pierce [mailto:[email-masked]]
Sent: Saturday, 6 December 2003 03:18
To: Andy Plant
Subject: Re: FW: [Ips] iSCSI Service Assurance

Hi Andy,

Thanks for your inquiry.

     - Bill Pierce