Subject: RE: [Ips] Max iSCSI Sessions supported

From: "Ramesh Mangamuri" <[email-masked]>
Date: Thu, 29 Jan 2004 17:43:46 -0800

Here are some questions again.

1) What if we have multi-pathing software installed on the Host
OS(Initiator) ? 
2) How can we generate different ISIDs from the same initiator.? Is this
one configurable value?

More later ...,
Ramesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 5:20 PM
To: Ramesh Mangamuri
Cc: [email-masked]
Subject: Re: [Ips] Max iSCSI Sessions supported

On Thu, 29 Jan 2004, Ramesh Mangamuri wrote:

> Folks,
>
> I understand that there is possibility that there can be multiple
> connections in an iSCSI session. But, Can an iSCSI initiator have more
> than one active iSCSI session simultaneously with a given target.

Yes and no.

Strictly speaking, no. Any attempt to open a second session with the
target by a given initiator would trigger session reinstatement. This
represents the fact that there can be only one I_T nexus.

However since the identifier for an initiator is both the initiator name
and the ISID, the same initiator name can be used on different sessions
if
they have different ISIDs. This situation, though, can be dangerous and
should be avoided; the target would appear as two different SCSI devices
to the initiator's OS. Most OSs won't deal well with that situation. For
instance Microsoft Windows's auto-mounting of partitions could cause the
partitions on the disk to be mounted twice.

Take care,

Bill

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: John Hufferd <[email-masked]>
Date: Thu, 29 Jan 2004 17:58:14 -0800

If you change the ISID, even with the same Initiator node name, it is a 
different initiator.  You can make that work as if it is a single 
initiator with what we call a wedge driver, or what you are calling 
multipathing software. 

The ISIDs can have been given a number of ways to be specified, one of the 
ways is to use the OUI, that represents the Vendor ID, and then you may 
use your own technique to modify the rest of the bits in the ISID any way 
you wish, which makes the Total name (including the Node Name) unique 
within the world.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/System Group, San Jose CA
Main Office: (408) 256-0403, Tie: 276-0403, eFax: (408) 904-4688
Alt Office: (408) 997-6136, Cell: (408) 499-9702
Internet Address: [email-masked]

"Ramesh Mangamuri" <[email-masked]> 
Sent by: [email-masked]
01/29/2004 05:43 PM

To
<[email-masked]>
cc
<[email-masked]>
Subject
RE: [Ips] Max iSCSI Sessions supported

More later ...,
Ramesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 29, 2004 5:20 PM
To: Ramesh Mangamuri
Cc: [email-masked]
Subject: Re: [Ips] Max iSCSI Sessions supported

Yes and no.

Take care,

Bill

---

From: [email-masked]
Date: Thu, 29 Jan 2004 18:00:01 -0800 (PST)

> 1) What if we have multi-pathing software installed on the Host

What does that have to do with multiple sessions?

> 2) How can we generate different ISIDs from the same initiator.? Is this

Since the ISID is part of what identifies the initiator in iSCSI, your
question doesn't make sense; if you change the ISID, you have a different
initiator. What do you think an initiator is?

Take care,

Bill