Subject: [Ips] iSCSI: Correct value for ExpDataSN for bidirectional commands

From: "Ken Sandars" <[email-masked]>
Date: Mon, 26 Jan 2004 15:21:26 -0000

Hi people,

Does section 10.4.8 which clearly states that ExpDataSN is "the number
of Data-In (read) PDUs the target has sent for the command" hold for
bidirectional commands?

i.e. It's not the number of Data-In and R2T PDUs sent for the command is
it?

Thanks again,
Ken Sandars
Elipsan UK

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Ramesh Mangamuri" <[email-masked]>
Date: Sat, 31 Jan 2004 13:27:08 -0800

Hello Ken/Julian:

I have another proposal here for section 10.4.8:

Suggestion ---------------------------

10.4.8  ExpDataSN

   The number of Data-In (read) PDUs (for bidirectional commands this is
R2Ts + Data-Ins) the target has sent for the command.

   This field is reserved if the response code is not Command Completed
   at Target, or the command is Write only command.

How does this sound???

-Rams

-----Original Message-----
From: Ken Sandars [mailto:[email-masked]] 
Sent: Friday, January 30, 2004 12:57 PM
To: 'Julian Satran'; 'Mallikarjun C.'
Cc: [email-masked]; [email-masked]
Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for bidirectional
commands

Hi Julo,

As requested, two alternative proposals for section 10.4.8:

Suggestion 1 --------------------------

10.4.8  ExpDataSN

   The number of R2T and Data-In (read) PDUs the target has sent for the
   command.

   This field is reserved if the response code is not Command Completed
   at Target.

Suggestion 2 --------------------------

10.4.8  ExpDataSN

   The number of R2T and Data-In (read) PDUs the target has sent for the
   command.

   This field is reserved if the response code is not Command Completed
   at Target or the target sent no Data-In PDUs for the command.

----------------------------------------

I'm more than happy with any answer which clarifies when the field is
reserved.

Thanks,
Ken Sandars
Elipsan UK

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Mallikarjun C.
> Sent: 30 January 2004 20:29
> To: Ken Sandars
> Cc: 'Julian Satran'; [email-masked]; [email-masked]
> Subject: Re: [Ips] iSCSI: Correct value for ExpDataSN for 
> bidirectional commands
> 
> 
> Ken,
> 
> I am not sure we need to restrict the wording
> to commands with at least one Data-In PDU.  Do
> you see an issue?
> 
> In any case, if you have a specific wording suggestion,
> please send it to Julian directly (he owns the pen).
> 
> Regards.
> 
> Mallikarjun
> 
> 
> 
> Ken Sandars wrote:
> 
> > Hi Mallikarjun,
> > 
> > One final clarification request, and  I can sleep easy on 
> this topic!
> > 
> > Will the new wording for 10.4.8 be more general to indicate that 
> > ExpDataSN is the number of DataIn and R2T PDUs that were sent?
> > 
> > Is this field only valid for commands which have at least 
> one Data-In 
> > PDU?
> > 
> > 
> > Thanks again,
> > Ken Sandars
> > Elipsan UK
> > 
> 
>