Subject: [Ips] iSCSI: Terminating active tasks

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 26 Jan 2004 17:50:00 -0500

Suppose an active task is terminated due to a lost connection (item b below). When the connection is re-instated, should the active tasks get a check condition?

Note that there appeared to be a clarification added to draft 20+errata but that didn't make it into the final draft (as I remember, there were other objections to the errata). I don't know if the new wording is incorrect or if it is implied by draft 20's wording and therefore not necessary.

Can someone please give me your interpretation of the following?

draft 20:

If the tasks terminated in the above cases a), b, c) and d)are SCSI
tasks, they must be internally terminated as if with CHECK CONDITION
status. This status is only meaningful for appropriately handling
the internal SCSI state and SCSI side effects with respect to
ordering because this status is never communicated back as a
terminating status to the initiator. However additional actions may
have to be taken at SCSI level depending on the SCSI context as
defined by the SCSI standards (e.g., queued commands and ACA, UA for
the next command on the I_T nexus in cases a), b), and c) etc. - see
[SAM] and [SPC3]).

draft 20+errata:

[--same as above to here--] (e.g., queued commands and ACA, in
cases a), b), and c), after the tasks are terminated, the target
MUST report a unit attention condition on the next command processed
on any connection for each affected I_T_L nexus etc. - see [SAM] and
[SPC3]).

Eddy

---

From: Julian Satran <[email-masked]>
Date: Wed, 28 Jan 2004 09:24:26 +0200

Eddy,

[email-masked] wrote on 27/01/2004 00:50:00:

> Suppose an active task is terminated due to a lost connection (item b 
> below). When the connection is re-instated, should the active tasks 
> get a check condition?
> 
> Note that there appeared to be a clarification added to draft 
> 20+errata but that didn't make it into the final draft (as I remember,
> there were other objections to the errata). I don't know if the new 
> wording is incorrect or if it is implied by draft 20's wording and 
> therefore not necessary.
> 

The text you quote refers to the target (that has no chance to communicate 
any status).
The change that appears in the errata is that the UA is now mandatory when 
the connection is reinstated and you get new commands.

Julo

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips