Subject: [Ips] iSCSI: Correct value for ExpDataSN for bidirectional commands

From: "Ken Sandars" <[email-masked]>
Date: Tue, 27 Jan 2004 09:48:31 -0000

Hi people,

Does section 10.4.8 which clearly states that ExpDataSN is "the number
of Data-In (read) PDUs the target has sent for the command" hold for
bidirectional commands?

i.e. It's not the number of Data-In and R2T PDUs sent for the command is
it?

Thanks again,
Ken Sandars
Elipsan UK

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 27 Jan 2004 10:46:43 -0800

> of Data-In (read) PDUs the target has sent for the command" hold for

Yes.

> i.e. It's not the number of Data-In and R2T PDUs sent for the command is

No.  I believe an ExpDataSN mismatch at the initiator
is always interpreted as lost Data-In PDU(s), and could
trigger within-command recovery (appendix E.2.2).
-- 
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
cbm [at] rose.hp.com

---

From: Julian Satran <[email-masked]>
Date: Thu, 29 Jan 2004 17:13:57 +0200

It is in fact the Data-In + R2T - Julo

"Ken Sandars" <[email-masked]> 
Sent by: [email-masked]
27/01/2004 11:48

To
<[email-masked]>
cc

Subject
[Ips] iSCSI: Correct value for ExpDataSN for bidirectional commands

Hi people,

Thanks again,
Ken Sandars
Elipsan UK

---

From: "Mallikarjun C." <[email-masked]>
Date: Thu, 29 Jan 2004 10:28:40 -0800

Not sure why the initiator needs to be reported on the
total # of R2Ts in the final response....I presume
any mismatch in R2Ts is already factored into the status.

_If_ we indeed want to include R2Ts, I think it would be
necessary to make changes (10.4.8, E.2.2, and perhaps 6)
because I believe the current spec semantics are clear
that R2Ts are not included.
-- 
Mallikarjun

Mallikarjun Chadalapaka

---

From: [email-masked]
Date: Thu, 29 Jan 2004 14:45:30 -0800 (PST)

> that R2Ts are not included.

While I'll be honest that I don't understand _why_ R2Ts are factored into
the DataSN space along with Data-In PDUs, I've understood they were
comingled for over a year. I think it was about 16 months ago I asked
about this (before draft 20), and Julian explained that they shared the
same space.

So I don't think it's supposed to be something new.

Take care,

Bill

---

From: "Mallikarjun C." <[email-masked]>
Date: Thu, 29 Jan 2004 16:16:32 -0800

Sorry, I must have missed that thread.

I wish you had suggested the clarification
to be put into the spec.  The spec/appendix
is clearly saying something different (which
I am fine with).
-- 
Mallikarjun

Mallikarjun Chadalapaka

---

From: [email-masked]
Date: Thu, 29 Jan 2004 18:01:47 -0800 (PST)

> is clearly saying something different (which

Sorry, I haven't paid much attention to BiDi commands, and I expected the
spec was clearer.

Take care,

Bill