Subject: [Ips] iSCSI PDU multiple TCP segments

From: Alberto Alesina <[email-masked]>
Date: Tue, 6 Jan 2004 01:06:26 -0800 (PST)

Hello all,
 
I would appreciate if someone can answer my questions on iSCSI
 
- Can a iSCSI PDU span over multiple TCP segments ? (part of the iSCSI PDU in one TCP segment, remaining part in other TCP segments)
 
- If that is allowed, do the existent initiator implementations try to send an iSCSI PDU in the same TCP segement?
 
Thanks a lot for your time.
 
Regards,
Alberto Alesina

---------------------------------
Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes

---

From: [email-masked]
Date: Tue, 6 Jan 2004 09:23:04 -0500

> - Can a iSCSI PDU span over multiple TCP segments ? (part of the iSCSI
> PDU in one TCP segment, remaining part in other TCP segments)

Yes.  Data transfers are a common case, as even the common 4k or 8k
transfers are larger than the typical TCP segment size, and iSCSI is
capable of supporting much larger transfers.

> - If that is allowed, do the existent initiator implementations try
> to send an iSCSI PDU in the same TCP segement?

In general, I don't believe they make any special efforts over and
above what TCP normally does.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips