Subject: RE: [Ips] iSNS SLP service type

From: Andy Currid <[email-masked]>
Date: Thu, 22 Jan 2004 09:37:21 -0800

I thought this was covered in the iSCSI SLP draft,
which defines "service:iscsi:sms" for discovery of
storage management services. The template for that
service includes a protocol field which may be set
to "isns" to indicate an iSNS server.

Andy
--
Andy Currid                 Phone: 408 330 4507
iReady Corporation            Fax: 408 330 4521
[email-masked]           http://www.iready.com

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, January 22, 2004 09:20
> To: [email-masked]
> Subject: [Ips] iSNS SLP service type
> 
> 
> In reviewing the iSNS draft, I noticed it indicates you can use SLP to
> locate the iSNS server. There was, however, no discussion of 
> _how_ to use
> SLP to locate the iSNS server. At least none I saw.
> 
> So how should we create SLP URLs for iSNS servers? While not terribly
> complicated, it's important we are consistent. Otherwise the 
> clients won't
> find the server. :-)
> 
> Do we want to use, "service:isns"? Or "service:isns:server", 
> to leave room
> for iSNS inter-server functionality? For reference, for iSCSI, we use
> "service:iscsi:target".
> 
> Also, the iSNS heartbeat packet can list primary and backup 
> servers. Do we
> want to have an attribute with the service registration to 
> indicate that
> server's position in the failover order? Otherwise SLP-using services
> won't necessarily know which server to talk to.
> 
> Take care,
> 
> Bill
> 
> _______________________________________________
> Ips mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ips
>

---

From: [email-masked]
Date: Thu, 22 Jan 2004 09:55:52 -0800 (PST)

> to "isns" to indicate an iSNS server.

Ahhh... That's possible. To be honest, I was not really sure what the
"sms" server was good for when I read the iSCSI-SLP draft; it seemed
rather vague and not immediately relevant.

Now that you mention it, I notice that the iSCSI-SLP draft is mentioned in
the iSNS references section. However no part of the document actualy uses
that references.

Is it too late for iSNS draft comments? If not, I'd like to request/
comment that section 2.5.1 should mention that iSCSI-SLP offers the
service template for using SLP to locate iSNS servers.

Take care,

Bill