Subject: RE: [Ips] [iSCSI] Usage of ISID in discovery session

From: "Ramesh Mangamuri" <[email-masked]>
Date: Mon, 23 Feb 2004 13:46:14 -0800

Folks,
Can some one please clarify whether the question I have from my previous
mail discussion makes sense, or did I miss any portion here?

Any clarifications are appreciated.

-----Original Message-----
From: Ramesh Mangamuri 
Sent: Friday, February 20, 2004 5:44 PM
To: Mallikarjun C.; Lakshmi Ramasubramanian
Cc: [email-masked]
Subject: RE: [Ips] [iSCSI] Usage of ISID in discovery session

Once the discovery session was closed reuse of that ISID for a Normal
session won't be unique.

-----Original Message-----
From: Mallikarjun C. [mailto:[email-masked]] 
Sent: Friday, February 20, 2004 5:32 PM
To: Lakshmi Ramasubramanian
Cc: [email-masked]
Subject: Re: [Ips] [iSCSI] Usage of ISID in discovery session

No.

The uniqueness expectation from the ISID RULE is on the
four tuple: InitiatorName-ISID-TargetName-TPGT.

This _does not_ include the session type (discovery vs
normal).  And I view the discovery session as also one
that has to play by the ISID RULE.

The net is that discovery and normal sessions share
the same ISID numbering space.

M

Lakshmi Ramasubramanian wrote:

> Assume there's only one discovery session.
> 
> Is it okay for ISID of a discovery session to be same
> as ISID of a non-discovery session from the same initiator?
> If so, initiator can assign ISID for discovery sessions
> independent of other (Non-Discovery) sessions. Right?
> 
>  -lakshmi
> 
> -----Original Message-----
> From: Mallikarjun C. [mailto:[email-masked]] 
> Sent: Friday, February 20, 2004 5:05 PM
> To: Lakshmi Ramasubramanian
> Cc: [email-masked]
> Subject: Re: [Ips] [iSCSI] Usage of ISID in discovery session
> 
> I am not sure I see the need for multiple discovery
> sessions from the same initiator to a given iSCSI service
> access point unless I'm missing something.
> 
> If you're, OTOH, including the TargetName key and
> thus establishing session to a specific TPG of a target,
> the standard "no duplicate I_T nexus" rule applies - but
> again, I don't see the need for multiple discovery
> sessions in this case either.
> 
> Finally, I don't think one initiator needs to worry about
> the ISIDs of discovery sessions from other initiator network
> entities.
> 
> Lakshmi Ramasubramanian wrote:
> 
> 
>>What is the rule for picking ISIDs for discovery sessions?  Since
> 
> there 
> 
>>is no target can any ISID be used?  Or do we need to be aware of other
> 
> 
>>discovery sessions and not reuse the ISID ?
>>
>>thanks!
>> -lakshmi
>>
> 
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Mallikarjun C." <[email-masked]>
Date: Mon, 23 Feb 2004 16:45:13 -0800

Ramesh,

Can you please restate your question?   I am not sure
I see the question.

As I responded below, at any given point of time, all
discovery/normal sessions share the same ISID space
for a given InitiatorName-TargetName-TPG combination.
I am not sure however if that answers your question.

Mallikarjun