Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for bidirectionalcommands

From: "Ramesh Mangamuri" <[email-masked]>
Date: Mon, 2 Feb 2004 12:41:46 -0800

>From the discussion so far, I am interested to know Julian's plans on
about the below approaches in the case of a bidirectional commands. 

Implementation 1:
=================
Keep the same variable for both <R2TSNs & DataInSNs> so that there is no
need to introduce another new SNACK type for R2TSN.

Or,

Implementation 2:
=================
Use different variables for R2TSNs and DataInSN and introduce new SNACK
type for R2TSNs.

More later...,
Rams

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, February 02, 2004 12:06 PM
To: Ramesh Mangamuri
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for
bidirectionalcommands

On Mon, 2 Feb 2004, Ramesh Mangamuri wrote:

> To be honest I really don't know about the resources we would be
saving
> by combining R2TSN and DataSN into one variable in the of
bidirectional
> . But from logical standpoint, Pat's suggestion makes perfect sense to
> me.

I think the reason they are the same variable is that they (R2T numbers
and DataSN) are in the same number space, due to how SNACK Requests
work.
To request a given DataSN or a given R2T be retransmitted, the initiator
sends a SNACK Request of Type 0. That's a Type 0 for _either_ a R2T or
DataSN retransmit. So for the target to keep things clear, it has to use
the same number space for both.

I think separating the number spaces would be ok, but it means changing
SNACK requests so that BiDi commands can tell what's being asked for.

Take care,

Bill

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: [email-masked]
Date: Mon, 2 Feb 2004 13:08:49 -0800 (PST)

> about the below approaches in the case of a bidirectional commands.

As noted in my other note, I'd like to propose we consider this new SNACK
type as applying only for BiDi commands. Otherwise we impact all existing
implementations.

Take care,

Bill

---

From: Julian Satran <[email-masked]>
Date: Tue, 3 Feb 2004 13:10:13 +0200

As I stated I think we might have an editorial issue (two names for the 
same thing) but since this has also some history I would be really 
reluctant to make any change (except fixing the example and adding a 
statement explaining that they share the space).

Julo

"Ramesh Mangamuri" <[email-masked]> 
02/02/2004 22:41

To
<[email-masked]>
cc
<[email-masked]>, Julian Satran <[email-masked]>, 
<[email-masked]>, <[email-masked]>, <[email-masked]>
Subject
RE: [Ips] iSCSI: Correct value for ExpDataSN for bidirectionalcommands

Implementation 1:
=================

Or,

Implementation 2:
=================

More later...,
Rams

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, February 02, 2004 12:06 PM
To: Ramesh Mangamuri
Cc: [email-masked]; [email-masked]; [email-masked];

saving
bidirectional

Take care,

Bill