Subject: RE: [Ips] [iSCSI] Usage of ISID in discovery session

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Fri, 20 Feb 2004 17:11:24 -0800

Assume there's only one discovery session.

Is it okay for ISID of a discovery session to be same
as ISID of a non-discovery session from the same initiator?
If so, initiator can assign ISID for discovery sessions
independent of other (Non-Discovery) sessions. Right?

 -lakshmi

-----Original Message-----
From: Mallikarjun C. [mailto:[email-masked]] 
Sent: Friday, February 20, 2004 5:05 PM
To: Lakshmi Ramasubramanian
Cc: [email-masked]
Subject: Re: [Ips] [iSCSI] Usage of ISID in discovery session

I am not sure I see the need for multiple discovery
sessions from the same initiator to a given iSCSI service
access point unless I'm missing something.

If you're, OTOH, including the TargetName key and
thus establishing session to a specific TPG of a target,
the standard "no duplicate I_T nexus" rule applies - but
again, I don't see the need for multiple discovery
sessions in this case either.

Finally, I don't think one initiator needs to worry about
the ISIDs of discovery sessions from other initiator network
entities.

Lakshmi Ramasubramanian wrote:

> What is the rule for picking ISIDs for discovery sessions?  Since
there 
> is no target can any ISID be used?  Or do we need to be aware of other

> discovery sessions and not reuse the ISID ?
> 
> thanks!
>  -lakshmi
> 

-- 
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
cbm [at] rose.hp.com

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Mallikarjun C." <[email-masked]>
Date: Fri, 20 Feb 2004 17:32:10 -0800

No.

The uniqueness expectation from the ISID RULE is on the
four tuple: InitiatorName-ISID-TargetName-TPGT.

This _does not_ include the session type (discovery vs
normal).  And I view the discovery session as also one
that has to play by the ISID RULE.

The net is that discovery and normal sessions share
the same ISID numbering space.

M

---

From: [email-masked]
Date: Tue, 24 Feb 2004 15:20:43 -0800 (PST)

> the same ISID numbering space.

The one question I have is where in this do TargetName-less discovery
sessions fit in the ISID numbering space? Do we treat them as having a
TargetName=""? That would have the consequence of keeping the ISID-rule
code simple, as it always applies. It would preclude the potential of the
same initiator/ISID having two discovery sessions w/o TargetName open at
once, but I don't forsee that as a concern. The initiator can always
choose a second ISID if it needs two at once..

Take care,

Bill

---

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 24 Feb 2004 17:24:39 -0800

>It would preclude the potential of the
 > once, but I don't forsee that as a concern.

Back at the beginning of this thread, I said:

"I am not sure I see the need for multiple discovery
sessions from the same initiator to a given iSCSI service
access point"

I still don't see the need.

And yes, I'd recommend using a different ISID for each
discovery session established to the same iSCSI service
access point (if you really see the need to use multiple
sessions).
-- 
Mallikarjun

Mallikarjun Chadalapaka

---

From: [email-masked]
Date: Wed, 25 Feb 2004 11:59:55 -0800 (PST)

> I still don't see the need.

I understand _you_ don't see the need. _I_ also agree with you. :-) The
question was more to see if anyone else in the working group disagreed.

More to the point, I'd like to say that the target doesn't have to support
it. :-)

Take care,

Bill