Subject: RE: [Ips] iSNS failover and multi-server configurations

From: Andy Currid <[email-masked]>
Date: Thu, 5 Feb 2004 07:11:21 -0800

> From: [email-masked] [mailto:[email-masked]]
> ...
> 2) I see that DHCP can indicate multiple servers. But what 
> about SLP in face of multiple servers? Andy Currid suggested
> that SLP should only have the most-senior operational server
> registered.

That's more than I recall saying :-)

I agree with your suggestion that the SLP storage management
service template should include some form of precedence attribute.

Andy
--

> But what happens when either a formerly-off-line server comes
> back on line or an on-line server goes off-line? SLP does not
> seem well-suited for "server moved" notifications. Also, with
> SLP, if a server fails, what are the security considerations
> for the backup server to be able to de-register the server?
> 
> Would it be easier for SLP to add a "precedence" attribute 
> and have each server register with SLP, then have the client
> perform the same failover as DHCP and heartbeat do?

--
Andy Currid                 Phone: 408 330 4507
iReady Corporation            Fax: 408 330 4521
[email-masked]           http://www.iready.com

---

From: [email-masked]
Date: Thu, 5 Feb 2004 11:13:48 -0800 (PST)

> That's more than I recall saying :-)

Sorry, turns out that was Josh Tseng.

Take care,

Bill

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips