Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for bidirectional commands

From: [email-masked]
Date: Mon, 2 Feb 2004 11:01:30 -0700

I don't think "(read)" should be in there. We don't usually put read after Data-In. Also, I would rather have it a separate sentence. 

For read commands, the number of Data-In PDUs the target has sent for the command. For bidirectional commands, the number of Data-In PDUs and R2T PDUs the target has sent for the command.

or 

For bidirectional commands, the number of Data-In PDUs and R2T PDUs the target has sent for the command. For all other commands, the number of Data-In PDUs the target has sent for the command.

The more I think about it, the more I lean toward leaving 10.4.8 as it is and changing 3.2.2 to disentangle DataSN from R2TSN. Is it really worth these gymnastics to reduce bidirectional command context by one variable?

-----Original Message-----
From: Ramesh Mangamuri [mailto:[email-masked]]
Sent: Saturday, January 31, 2004 1:27 PM
To: Ken Sandars; Julian Satran; Mallikarjun C.
Cc: THALER,PAT (A-Roseville,ex1); [email-masked]
Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for bidirectional
commands

Hello Ken/Julian:

I have another proposal here for section 10.4.8:

Suggestion ---------------------------

10.4.8  ExpDataSN

   The number of Data-In (read) PDUs (for bidirectional commands this is
R2Ts + Data-Ins) the target has sent for the command.

   This field is reserved if the response code is not Command Completed
   at Target, or the command is Write only command.

How does this sound???

-Rams

-----Original Message-----
From: Ken Sandars [mailto:[email-masked]] 
Sent: Friday, January 30, 2004 12:57 PM
To: 'Julian Satran'; 'Mallikarjun C.'
Cc: [email-masked]; [email-masked]
Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for bidirectional
commands

Hi Julo,

As requested, two alternative proposals for section 10.4.8:

Suggestion 1 --------------------------

10.4.8  ExpDataSN

   The number of R2T and Data-In (read) PDUs the target has sent for the
   command.

   This field is reserved if the response code is not Command Completed
   at Target.

Suggestion 2 --------------------------

10.4.8  ExpDataSN

   The number of R2T and Data-In (read) PDUs the target has sent for the
   command.

   This field is reserved if the response code is not Command Completed
   at Target or the target sent no Data-In PDUs for the command.

----------------------------------------

I'm more than happy with any answer which clarifies when the field is
reserved.

Thanks,
Ken Sandars
Elipsan UK

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Mallikarjun C.
> Sent: 30 January 2004 20:29
> To: Ken Sandars
> Cc: 'Julian Satran'; [email-masked]; [email-masked]
> Subject: Re: [Ips] iSCSI: Correct value for ExpDataSN for 
> bidirectional commands
> 
> 
> Ken,
> 
> I am not sure we need to restrict the wording
> to commands with at least one Data-In PDU.  Do
> you see an issue?
> 
> In any case, if you have a specific wording suggestion,
> please send it to Julian directly (he owns the pen).
> 
> Regards.
> 
> Mallikarjun
> 
> 
> 
> Ken Sandars wrote:
> 
> > Hi Mallikarjun,
> > 
> > One final clarification request, and  I can sleep easy on 
> this topic!
> > 
> > Will the new wording for 10.4.8 be more general to indicate that 
> > ExpDataSN is the number of DataIn and R2T PDUs that were sent?
> > 
> > Is this field only valid for commands which have at least 
> one Data-In 
> > PDU?
> > 
> > 
> > Thanks again,
> > Ken Sandars
> > Elipsan UK
> > 
> 
> 
> _______________________________________________
> Ips mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ips
> 
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Ken Sandars" <[email-masked]>
Date: Mon, 2 Feb 2004 18:12:14 -0000

Hi Pat,

> From: [email-masked] [mailto:[email-masked]] 
> Sent: 02 February 2004 18:02
> To: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for 
> bidirectional commands
> 
> 
> I don't think "(read)" should be in there. We don't usually 
> put read after Data-In. Also, I would rather have it a 
> separate sentence. 
> 
> For read commands, the number of Data-In PDUs the target has 
> sent for the command. For bidirectional commands, the number 
> of Data-In PDUs and R2T PDUs the target has sent for the command.
> 
> or 
> 
> For bidirectional commands, the number of Data-In PDUs and 
> R2T PDUs the target has sent for the command. For all other 
> commands, the number of Data-In PDUs the target has sent for 
> the command.
> 
> The more I think about it, the more I lean toward leaving 
> 10.4.8 as it is and changing 3.2.2 to disentangle DataSN from 
> R2TSN. Is it really worth these gymnastics to reduce 
> bidirectional command context by one variable?
> 

This would affect Data/R2T SNACK processing, but that's probably
a good thing. Perhaps explicit Data SNACK and R2T SNACK types are
All that is needed. But is this needed, or just a can-o-worms?

Cheers,
Ken Sandars
Elipsan UK

> Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for 
> bidirectional commands
> 
> 
> Hello Ken/Julian:
> 
>    The number of Data-In (read) PDUs (for bidirectional 
> commands this is R2Ts + Data-Ins) the target has sent for the command.
> 
> Subject: RE: [Ips] iSCSI: Correct value for ExpDataSN for 
> bidirectional commands
> 
> Hi Julo,
> 
> I'm more than happy with any answer which clarifies when the 
> field is reserved.
> 
> 
> Thanks,
> Ken Sandars
> Elipsan UK
> 
> 
> 
> 
>