Subject: [Ips] is a share disk possible on SCSI/iSCSI level?

From: "sunzen.w" <[email-masked]>
Date: Mon, 1 Mar 2004 10:19:33 +0800

Hi,
  Storaging networking enables storage consolodation and deployment.Typically disk array 
serves as a storage server, its storage is parted and exported via storage networking protocols
such as iSCSI,etc. Share problem arises. Current solutions are mainly on upper file level, either 
additionally deploying a NAS or using a SAN file system. Is it possible on SCSI/iSCSI level? 
  In iSCSI spec, multi session on a target are allowed. is it for sharing?  On SCSI, OSD commands 
are designed.Is it the way for sharing on disk level?

sunzen
[email-masked]
2004-03-01

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Mon, 01 Mar 2004 05:06:30 +0200

iSCSI does nothing for sharing beyond what SCSI does. SCSI for block
devices does nothing - except the "reserve-release" Sharing has to be
managed at higher level. However the OSD command set is a bit richer and
allows checking credentials for accessing data. Allocation in OSD is
also managed by the device and that somewhat simplifies sharing. However
data access coordination (locks,RW exclusion etc.) still has to be
managed by some upper level entity like a file system

Julo