Subject: [Ips] iSCSI: reinstatement

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 30 Mar 2004 17:17:55 -0500

I just noticed this ("if an explicit logout was not performed earlier" ). The first part of the paragraph already said "possibly active" which could only happen if a logout had not been performed earlier. Is this just an overstatement or am I missing something?

Connection reinstatement is the process of an initiator logging in

with a ISID-TSIH-CID combination that is possibly active from the

target's perspective, which causes the implicit logging out of the

connection corresponding to the CID and reinstating a new Full

Feature Phase iSCSI connection in its place (with the same CID).

Thus, the TSIH in the Login PDU MUST be non-zero and CID does not

change during a connection reinstatement. The Login request performs

the logout function of the old connection if an explicit logout was

not performed earlier.

---

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 30 Mar 2004 15:44:54 -0800

Eddy,

Here's one scenario to consider.

- Logout Response (success) was on its way from the target to
   the initiator.
- TCP connection fails, initiator doesn't see the Logout Response.
- In the initiator's view, the connection is "possibly active from
   the target’s perspective".
- Initiator attempts a connection reinstatement.
- When the target receives the new reinstatement Login Request,
   an explicit logout was already performed in its view.  The
   current Login doesn't trigger the logout function.

Mallikarjun

Eddy Quicksall wrote:

> I just noticed this (“if an explicit logout was not performed earlier” 
> ). The first part of the paragraph already said “possibly active” which 
> could only happen if a logout had not been performed earlier. Is this 
> just an overstatement or am I missing something?
> 
>  
> 
> target’s perspective, which causes the implicit logging out of the
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips