Subject: Re: RIF: [Ips] is a share disk possible on SCSI/iSCSI level?

From: John Hufferd <[email-masked]>
Date: Thu, 11 Mar 2004 23:24:01 -0800

Perhaps this is a basic misunderstanding about what disk sharing means.

I think you are asking if there is something that is possible about 
sharing the same LU from different computers.  This is completely 
independent of the Network interconnect.  FC or iSCSI permit the Host 
systems to issue Reserves or Releases.  Even Persistent Reserves.  The 
question is does the File system on the Host systems know how to support a 
shared LU.  There are special File System available which know how to do 
this, and they are independent of the network and will operate on either 
FC or iSCSI. 

For normal pooled storage, the general support is the creation of a pool 
of Logical LUs on an external (perhaps RAID) Controller.  Many/most of 
these permit a Virtualized set of LUs that span across the various 
physical Disk Drives  (It can even be done on a single partitioned disk 
drive).  In this type of a configuration each host system puts their own 
File System on the LUs that they think are theirs.  As a rule, 
Reserve/Release is not an issue since each system will only "See" the LUs 
that belong to it.

There was some problems with this in the early days of FC, but today with 
various forms of zoning and LUN masking, this is not a big problem. 

With iSCSI, I think that most/all vendors are defining to the External 
Controllers the LUs that are addressable by authorized hosts, and those 
are the only LUs the Host can get at.  And, yes, in  most of the 
implementations these are logical LUs that map in some way to the physical 
disks.  And there is not usually any problems with Reserves.

This is pooled storage, not shared files and not shared (logical) disks.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/System Group, San Jose CA
Main Office: (408) 256-0403, Tie: 276-0403, eFax: (408) 904-4688
Alt Office: (408) 997-6136, Cell: (408) 499-9702
Internet Address: [email-masked]

Maffione Eugenio <[email-masked]> 
Sent by: [email-masked]
03/11/2004 11:30 AM

To
[email-masked]
cc
[email-masked]
Subject
RIF: [Ips] is a share disk possible on SCSI/iSCSI level?

Hi,
the compatibility of commercial iscsi gateway with reserve-release 
mechanism is not widely available, even if everyone agrees that clustering 
systems with iscsi targets (instead of expensive FC SAN) could cut down 
the costs of the solutions.
 
Any news about target implementation (also not commercial ...) with 
release-reserve support?
 
Eugenio
 
[email-masked]

                 -----Messaggio originale----- 
                 Da: [email-masked] per conto di sunzen.w 
                 Inviato: lun 01/03/2004 3.19 
                 A: [email-masked] 
                 Cc: 
                 Oggetto: [Ips] is a share disk possible on SCSI/iSCSI 
level?

                 Hi,
                   Storaging networking enables storage consolodation and 
deployment.Typically disk array
                 serves as a storage server, its storage is parted and 
exported via storage networking protocols
                 such as iSCSI,etc. Share problem arises. Current 
solutions are mainly on upper file level, either
                 additionally deploying a NAS or using a SAN file system. 
Is it possible on SCSI/iSCSI level?
                   In iSCSI spec, multi session on a target are allowed. 
is it for sharing?  On SCSI, OSD commands
                 are designed.Is it the way for sharing on disk level?

                 sunzen
                 [email-masked]
                 2004-03-01

                 _______________________________________________
                 Ips mailing list
                 [email-masked]
                 https://www1.ietf.org/mailman/listinfo/ips

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please contact us by
replying to [email-masked]. Thank you
====================================================================

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Paul von Behren <[email-masked]>
Date: Fri, 12 Mar 2004 06:56:55 -0700

> This is pooled storage, not shared files and not shared (logical) disks.

But shared logical units are commonly used with cluster software
along with SCSI 3 persistrent reservations or SCSI 2 reserve/release
(though the SCSI 2 commands should be avoided).  My interpretation
of the question was - are iSCSI disk/array vendors implementing
SCSI PR or reserve/release?

Paul

John Hufferd wrote:
> question is does the File system on the Host systems know how to support 
> a shared LU.  There are special File System available which know how to 
> do this, and they are independent of the network and will operate on 
> either FC or iSCSI.  
> 
> Reserve/Release is not an issue since each system will only "See" the 
> LUs that belong to it.
> 
> There was some problems with this in the early days of FC, but today 
> with various forms of zoning and LUN masking, this is not a big problem.
> 
> implementations these are logical LUs that map in some way to the 
> physical disks.  And there is not usually any problems with Reserves.
> 
> *Maffione Eugenio <[email-masked]>*
> mechanism is not widely available, even if everyone agrees that 
> clustering systems with iscsi targets (instead of expensive FC SAN) 
> could cut down the costs of the solutions.
> 
>                 Oggetto: [Ips] is a share disk possible on SCSI/iSCSI level?
>                
>                
> 
>                 Hi,

---

From: Paul Koning <[email-masked]>
Date: Fri, 12 Mar 2004 09:22:15 -0500

>>>>> "Paul" == Paul von Behren <[email-masked]> writes:

 >> This is pooled storage, not shared files and not shared (logical)
 >> disks.  .

 Paul> But shared logical units are commonly used with cluster
 Paul> software along with SCSI 3 persistrent reservations or SCSI 2
 Paul> reserve/release (though the SCSI 2 commands should be avoided).
 Paul> My interpretation of the question was - are iSCSI disk/array
 Paul> vendors implementing SCSI PR or reserve/release?

Yes.

	paul

---

From: [email-masked]
Date: Fri, 12 Mar 2004 09:08:31 -0800 (PST)

> SCSI PR or reserve/release?

Yes, both.

Take care,

Bill

---

From: Maffione Eugenio <[email-masked]>
Date: Thu, 11 Mar 2004 20:30:59 +0100

Hi,
the compatibility of commercial iscsi gateway with reserve-release mechanism is not widely available, even if everyone agrees that clustering systems with iscsi targets (instead of expensive FC SAN) could cut down the costs of the solutions.
 
Any news about target implementation (also not commercial ...) with release-reserve support?
 
Eugenio

	-----Messaggio originale----- 
	Da: [email-masked] per conto di sunzen.w 
	Inviato: lun 01/03/2004 3.19 
	A: [email-masked] 
	Cc: 
	Oggetto: [Ips] is a share disk possible on SCSI/iSCSI level?

	Hi,
	  Storaging networking enables storage consolodation and deployment.Typically disk array
	serves as a storage server, its storage is parted and exported via storage networking protocols
	such as iSCSI,etc. Share problem arises. Current solutions are mainly on upper file level, either
	additionally deploying a NAS or using a SAN file system. Is it possible on SCSI/iSCSI level?
	  In iSCSI spec, multi session on a target are allowed. is it for sharing?  On SCSI, OSD commands
	are designed.Is it the way for sharing on disk level?

	sunzen
	[email-masked]
	2004-03-01