Subject: RE: [Ips] iSCSI: clarification? data-in PDU->command status bit

From: [email-masked]
Date: Mon, 29 Mar 2004 15:31:48 -0500

1) is the intended sense - Status is sent *exactly* once for any
completed command, either via the status bit XOR a Response PDU.

The clarifying sentence indicating that it is wrong to set the
status bit AND send a Response PDU for the same command is a
reasonable addition.

Adding a new login parameter at this late stage is not possible.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of David Weibel
> Sent: Monday, March 29, 2004 2:52 PM
> To: [email-masked]
> Subject: [Ips] iSCSI: clarification? data-in PDU->command status bit
> 
> 
> [This topic appeared about 6 months ago in email archive without a
> clear resolution]
> 
>    Based on the iSCSI draft 20 is seems that it is legal for an iSCSI
target
> to set the command status bit in a data-in PDU and either return a SCSI
> response PDU or drop the response PDU on a successful CMD completion.
> 
> 	10.7.3  Flags (byte 1) The last SCSI Data packet sent from a target
> 	to an initiator for a  SCSI command that completed successfully
> 	(with a status of GOOD,  CONDITION MET, INTERMEDIATE or INTERMEDIATE
> 	CONDITION MET) may also  optionally contain the Status for the data
> 	transfer.  In this case,  Sense Data cannot be sent together with
> 	the Command Status.  If the  command is completed with an error,
> 	then the response and sense data  MUST be sent in a SCSI Response
> 	PDU (i.e., MUST NOT be sent in a  SCSI Data packet). For
Bidirectional
> 	commands, the status MUST be  sent in a SCSI Response PDU.
> 
>    I would like to purpose two possible clarifications to close the
> interpretation of this bit.
> 
> 1) Update section 10.7.3 to add a statement similar to the below.
> 
> 	... If the command status bit is set the target MUST 
> not send a SCSI
> 	response PDU.
> 
> (or) 2) Add a new login parameter that allows the target device to 
> notify the
> initiator of it's planned implementation of the bit.
> 
> 	12.XX  CommandStatusResponse
> 	Use: LO
> 	Senders: Target
> 	Scope: SW
> 
> 	CommandStatusResponse=<boolean-value>
> 
> 	Examples:
> 
> 		CommandStatusResponse=No
> 		CommandStatusResponse=Yes
> 
> 	Default is Yes
> 
> 	The CommandStatusResonse is used to define the target implementation
> 	of the data-in PDU's command status bit.  If CommandStatusResponse
is
> 	Yes then the target MUST followup a data-in PDU containing the
command
> 	status bit set with a scsi reponse PDU.  If CommandStatusResponse is
> 	No then that target device MUST not send the scsi response PDU.
> 
> ---
> 
> [past email archive postings]
> suggestion to drop the S bit -
>    http://www.pdl.cmu.edu/mailinglists/ips/mail/msg05757.html
> requested clarification on the S bit -
>    http://www.pdl.cmu.edu/mailinglists/ips/mail/msg12341.html
> 
> 
> _______________________________________________
> Ips mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ips
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Tue, 30 Mar 2004 16:52:04 +0200

I am against saying again what SCSI says already. Julo

[email-masked] 
Sent by: [email-masked]
29/03/04 22:31

To
[email-masked], [email-masked]
cc

Subject
RE: [Ips] iSCSI: clarification? data-in PDU->command status bit

Thanks,
--David

target
Bidirectional
is
command

---

From: William Studenmund <[email-masked]>
Date: Tue, 30 Mar 2004 18:46:16 -0800

> I am against saying again what SCSI says already. Julo

The problem we're seeing is that while SCSI says it already,
people are getting confused by it.

So do we clear up confusion or not? :-)

Take care,

BIll

---

From: Julian Satran <[email-masked]>
Date: Wed, 31 Mar 2004 19:33:25 +0200

read the errata - julo

William Studenmund <[email-masked]> 
30/03/04 18:46

To
Julian Satran/Haifa/IBM@IBMIL
cc
[email-masked], [email-masked], [email-masked]
Subject
Re: [Ips] iSCSI: clarification? data-in PDU->command status bit

Take care,

BIll

---

From: William Studenmund <[email-masked]>
Date: Wed, 31 Mar 2004 14:00:28 -0800

> read the errata - julo

Uhm, Julian, this whole thread has been in response to the errata. I
fail to see how "read the errata" will change my mind.

"If Status is sent with the data it MUST not be sent again  with a SCSI
Response PDU as this would violate SCSI rules (a single ...."

David's concern is confusion over "with  a SCSI Response PDU". You
(and I and DLB and most of the folks on the list) know that means you
don't send a PDU; you just removed the need. A few people new to
the spec, though, seem to think you still need to send the SCSI
Response PDU, just that it isn't carrying SCSI status. Or something like
that.

Adding a "MUST" will make things clear.

I'd suggest (if we can still make the change) something like:

"If Status is sent with the data it MUST not be sent again (SCSI
Response PDU MUST not be sent) as this would violate SCSI
rules (a single ...."

Take care,

Bill