Subject: [Ips] Request from T11.5 for editorial cleanup

From: Keith McCloghrie <[email-masked]>
Date: Thu, 25 Mar 2004 11:12:35 -0800 (PST)

Hi,

As you will have seen from recent messages to this list, a few changes
are required to draft-ietf-ips-fcmgmt-mib-04.txt as a result of the
IESG Expert Review process.

Meanwhile, I received the message below from Roger on behalf of T11.5.
Your WG chairs and I agree with Roger that these are purely editorial
clarifications, and that consistency with FC-SWAPI is a good thing.
So, I've taken the liberty of updating the draft as requested.

The latest draft can be found at:

  ftp://ftpeng.cisco.com/ftp/kzm/pub/draft-ietf-ips-fcmgmt-mib-05.txt

In due course, I will be submitting the latest draft as a new I-D.
If you have any concerns, please speak up.

Thanks,
Keith.
--------------
Forwarded message:
> From: Roger Cummings <[email-masked]>
> Message-ID: <8BE017CC8923D511A00A0008C78605EE0906084C@LMOXCH04>
> To: Keith McCloghrie <[email-masked]>
> Cc: Elizabeth Rodriguez <[email-masked]>, [email-masked]
> Subject: Issues with FC Management MIB
> Date: Fri, 12 Mar 2004 15:14:41 -0500
> 
> Keith,
> 
> At a recent conference call reviewing Letter Ballot comments on one of the
> T11.5 API projects, called FC-SWAPI, it was noted that clarifications of the
> definitions of several of the objects defined in the API should probably be
> reflected in the FC Management MIB. 
> 
> The specific SWAPI objects, and their clarified definitions are :
> 
> 1) SWAPI_STATS_LBL_RLRS
> 
> Count of Link resets. This is the number of Link Reset (LR) Primitive
> Sequences received.
> 
> 2) SWAPI_STATS_LBL_TLRS 
> 
> Count of Link resets. This is the number of Link Reset (LR) Primitive
> Sequences transmitted.
> 
> 4) SWAPI_STATS_LBL_ROLS
> 
> Count of Offline (OLS) Primitive Sequences received at this port.
> 
> 5) SWAPI_STATS_LBL_TOLS
> 
> Count of Offline (OLS) Primitive Sequences transmitted by this port.
> 
> 
> The corresponding definitions in draft-ietf-ips-fcmgmt-mib-04.txt are:
> 
> fcmPortRxLinkResets OBJECT-TYPE
>    
>     DESCRIPTION
>             "The number of Link resets (LR primitives) received."
> 
> fcmPortTxLinkResets OBJECT-TYPE
>         DESCRIPTION
>             "The number of Link resets (LRs primitive) transmitted."
> 
> fcmPortRxOfflineSequences OBJECT-TYPE
>     
>     DESCRIPTION
>             "The number of Offline Primitive OLS received at this port."
> fcmPortTxOfflineSequences OBJECT-TYPE
>     
>     DESCRIPTION
>             "The number of Offline Primitive OLS transmitted by this
>             port."
> 
> The problem here is that all of these objects are defined as the number of
> primitives, but LR and OLS are Primitive Sequences and not primitives. This
> was not at all clear in earlier versions of SWAPI, and I suspect that may
> have been what you based the definitions on. Primitive Sequences are already
> referenced in the MIB in the fcmPortPrimSeqProtocolErrors object type.
> 
> To make SWAPI & the FC Management MIB consistent, our suggestions would be:
> 
> fcmPortRxLinkResets OBJECT-TYPE
>    
>     DESCRIPTION
> 
> "The number of Link Reset (LR) Primitive Sequences received."
> 
> 
> fcmPortTxLinkResets OBJECT-TYPE
>         DESCRIPTION
> 
> "The number of Link Reset (LR) Primitive Sequences transmitted."
>     
> 
> fcmPortRxOfflineSequences OBJECT-TYPE
>     
>     DESCRIPTION
> 
> "The number of Offline (OLS) Primitive Sequences received at this port."
> 
> 
> fcmPortTxOfflineSequences OBJECT-TYPE
>     
>     DESCRIPTION
> 
> "The number of Offline (OLS) Primitive Sequences transmitted by this port."
> 
> 
> I think that this can be regarded purely as editorial clarification, because
> LR & OLS are clearly defined as Primitive Sequences in FC-FS. Is it too late
> to make these changes to the MIB? Do you need me to submit these changes
> "officially" as T11.5 Chair during IESG last call?
> 
> Regards,
> 
> 
> 
> 
> Roger Cummings
> Chair, TG T11.5
> 
> [email-masked]
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Michael MacFaden" <[email-masked]>
Date: Sun, 28 Mar 2004 17:08:00 -0800

Keith,

My comments on draft 5 can be found here:
http://www.macfaden.com/ietf/fc-mgmt-mib-5-reviewed.txt

I have no outstanding issues with this draft other than what is
mentioned above.

Mike MacFaden
Kazeon Systems, Inc

-----Original Message-----
From: Keith McCloghrie [mailto:[email-masked]] 
Sent: Thursday, March 25, 2004 11:13 AM
To: [email-masked]
Cc: [email-masked]; Michael MacFaden; [email-masked];
[email-masked]; [email-masked]; Keith McCloghrie
Subject: Request from T11.5 for editorial cleanup

Hi,

As you will have seen from recent messages to this list, a few changes
are required to draft-ietf-ips-fcmgmt-mib-04.txt as a result of the IESG
Expert Review process.

Thanks,
Keith.
--------------
Forwarded message:
> At a recent conference call reviewing Letter Ballot comments on one of

> the
> T11.5 API projects, called FC-SWAPI, it was noted that clarifications 
> of the definitions of several of the objects defined in the API should

> probably be reflected in the FC Management MIB.
> 
> The problem here is that all of these objects are defined as the 
> number of primitives, but LR and OLS are Primitive Sequences and not 
> primitives. This was not at all clear in earlier versions of SWAPI, 
> and I suspect that may have been what you based the definitions on. 
> Primitive Sequences are already referenced in the MIB in the
fcmPortPrimSeqProtocolErrors object type.
> I think that this can be regarded purely as editorial clarification, 
> because LR & OLS are clearly defined as Primitive Sequences in FC-FS. 
> Is it too late to make these changes to the MIB? Do you need me to 
> submit these changes "officially" as T11.5 Chair during IESG last
call?