Subject: [Ips] NOP-IN question

From: "Ken Craig" <[email-masked]>
Date: Mon, 12 Apr 2004 12:36:45 -0700

Section 10.18 in the iSCSI draft 20 states that an iSCSI
Initiator MUST send a NOP-OUT PDU if I, as an iSCSI Target,
generate a NOP-IN PDU with a valid TTT.  My question is
"How long is the Target supposed to wait before deciding
that the NOP-OUT PDU isn't coming?".  The draft does not
appear to give any guidance as to how long the Target is
supposed to wait to receive the NOP-OUT.  Would I be correct
in assuming I can use the time2wait and time2retain values
or is there some other mechanism for timing this out?

Thanks,
Kenneth Craig

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Tue, 13 Apr 2004 22:22:35 +0300

Ken,

There is no specific mechanism in place for this case.
You have to consider transport characteristics (RTT) and end-point 
characteristics.
Those can be set by an administrator or learned or both.

Julo

"Ken Craig" <[email-masked]> 
Sent by: [email-masked]
12/04/04 15:36

To
<[email-masked]>
cc

Subject
[Ips] NOP-IN question

Thanks,
Kenneth Craig

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 14 Apr 2004 08:41:48 -0700

In addition to what Julian said, let me add that the iSCSI spec 
generally considers the timeout values used by the iSCSI implementations 
to be outside its scope - I do not know of any exception.  Section 6 
makes this point several times wrt various timeout scenarios.

The Time2Wait/Retain are not to be used for timing any operations on one 
connection.  They are applicable only during the transition period from 
one connection to another.

Mallikarjun