Subject: RE: [Ips] iSCSI: NOP-Out during discovery

From: "Buck Landry" <[email-masked]>
Date: Wed, 28 Apr 2004 17:38:18 -0500

Is it intended that a NOP-Out is allowed during discovery? Technically since it is not a request, 3.3 probably does not restrict it.
<<<

Reading draft-ietf-ips-iscsi-20+errata.txt, I infer from 3.5 that all iSCSI PDUs are requests or responses, and 3.5.3.6 explicitly refers to NOP-Out as "NOP-Out Request".

If so, what about a login?
<<<

Good point.  In 3.3, s/"The target MUST ONLY"/"During Full Feature Phase, the target MUST ONLY"/

--buck

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eddy Quicksall
Sent: Wednesday, April 28, 2004 4:00 PM
To: [email-masked]
Subject: [Ips] iSCSI: NOP-Out during discovery

Is it intended that a NOP-Out is allowed during discovery? Technically since it is not a request, 3.3 probably does not restrict it. If so, what about a login?

3.3 iSCSI Session Types
        ....
    b) Discovery-session
            All other requests MUST be rejected.

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: [email-masked]
Date: Thu, 29 Apr 2004 08:38:49 -0400

Eddy,

You can send "SendTargets=All" to the target at any time
during discovery sessions.  This will definetly tell you if the
connection is alive and that is the only reason to keep the
session open anyway.

>From Appendix D:
   After obtaining a list of targets from the discovery target session,
   an iSCSI initiator may initiate new sessions to log in to the
   discovered targets for full operation. The initiator MAY keep the
   discovery session open, and MAY send subsequent SendTargets commands
   to discover new targets.

I would prefer if initiators just performed a new login for each
discovery session. Here are my reasons:
1. Less connections open = less resources wasted on the target.
2. Having two ways to report target changes adds complexity.
3. I doubt target lists will change that often, checking once when
the initiator boots or when an administrator asks seems sufficient.

Regards,

Aaron

                      "Eddy Quicksall"                                                                                                         
                      <eddy_quicksall_iVivity_iSCSI@c        To:       "Julian Satran" <[email-masked]>                              
                      omcast.net>                            cc:       <[email-masked]>, <[email-masked]>                                    
                      Sent by: [email-masked]            Subject:  Re: [Ips] iSCSI: NOP-Out during discovery                               

                      04/28/2004 08:39 PM                                                                                                      

Thanks, I found one popular company that is doing it to see if I'm still
alive.

I can see why they probably used a nop ... the spec discurrages using an
empty text request (4th paragraph in 5.2).

What is the expected way an initiator should test for "aliveness" during a
discovery session that is held open?

Eddy
 ----- Original Message -----
 From: Julian Satran
 To: Eddy Quicksall
 Cc: [email-masked] ; [email-masked]
 Sent: Wednesday, April 28, 2004 7:23 PM
 Subject: Re: [Ips] iSCSI: NOP-Out during discovery

 no - julo

 "Eddy Quicksall" <                                                        
 [email-masked]>                                 
 Sent by: [email-masked]                                               
                                                                        To 
                                                       <[email-masked]>      
 28/04/04 14:00                                                         cc 
                                                                           
                                                                   Subject 
                                                       [Ips] iSCSI:        
                                                       NOP-Out during      
                                                       discovery           

                                                                           

 Is it intended that a NOP-Out is allowed during discovery? Technically
 since it is not a request, 3.3 probably does not restrict it. If so, what
 about a login?

 3.3 iSCSI Session Types
         ....
     b) Discovery-session