Subject: RE: [Ips] Behaviour of iSCSI Initiator, if target is not returnin g "Target Portal Group Tag".

From: [email-masked]
Date: Tue, 20 Apr 2004 11:35:12 +0530

Yes, the initiator should close the connection.

thanks
Parthi

-----Original Message-----
From: Naveen Burmi [mailto:[email-masked]]
Sent: Monday, April 19, 2004 3:25 PM
To: [email-masked]
Subject: [Ips] Behaviour of iSCSI Initiator, if target is not returning
"Target Portal Group Tag".

Need some clarification regarding Target portal Group Tag.

Draft says that "iSCSI target MUST return the
TargetPortalGroupTag key with the first login response PDU
for all session types".  But it does not, explicitly, talks
about the action that needs to be taken by initiator if
target does not return this value.

Draft section 6.11 "Protocol Errors" says that "All violations of iSCSI PDU 
exchange sequences specified in this draft are also protocol errors."

Do we need to consider it as "protocol error"?

Thanks,
Naveen.

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 20 Apr 2004 08:09:36 -0400

Additionally, you may be behind in your draft ... draft 20+errata has a
correction to this since the TargetPortalGroupTag does not make sense in
some cases:

"The TargetPortalGroupTag key must also be returned by the target as a
confirmation during connection establishment when TargetName is given."

"... iSCSI target MUST return the TargetPortalGroupTag ... for all session
types when TargetName is given and the response is not a redirection."

Eddy