Subject: [Ips] iSCSI: NOP-Out during discovery

From: "Eddy Quicksall" <[email-masked]>
Date: Wed, 28 Apr 2004 17:00:07 -0400

Is it intended that a NOP-Out is allowed during discovery? Technically since it is not a request, 3.3 probably does not restrict it. If so, what about a login?

3.3 iSCSI Session Types
        ....
    b) Discovery-session
            All other requests MUST be rejected.

---

From: Julian Satran <[email-masked]>
Date: Wed, 28 Apr 2004 16:23:47 -0700

no - julo

"Eddy Quicksall" <[email-masked]> 
Sent by: [email-masked]
28/04/04 14:00

To
<[email-masked]>
cc

Subject
[Ips] iSCSI: NOP-Out during discovery

Is it intended that a NOP-Out is allowed during discovery? Technically 
since it is not a request, 3.3 probably does not restrict it. If so, what 
about a login?
 
3.3 iSCSI Session Types
        ....
    b) Discovery-session

---

From: "Eddy Quicksall" <[email-masked]>
Date: Wed, 28 Apr 2004 20:39:18 -0400

Thanks, I found one popular company that is doing it to see if I'm still alive. 

I can see why they probably used a nop ... the spec discurrages using an empty text request (4th paragraph in 5.2).

What is the expected way an initiator should test for "aliveness" during a discovery session that is held open?

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] ; [email-masked] 
  Sent: Wednesday, April 28, 2004 7:23 PM
  Subject: Re: [Ips] iSCSI: NOP-Out during discovery

  no - julo 

        "Eddy Quicksall" <[email-masked]> 
        Sent by: [email-masked] 
        28/04/04 14:00 
       To <[email-masked]>  
              cc  
              Subject [Ips] iSCSI: NOP-Out during discovery 

    
  3.3 iSCSI Session Types 
          .... 
      b) Discovery-session