Subject: [Ips] [iSCSI] Implicit\Explicit logout on Connection failure

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Tue, 18 May 2004 11:01:18 -0700

6.1.4.3 Connection Recovery (Page 66 in iSCSI RFC 3720) says that in the
event
of TCP Connection failure, initiator MUST close the connection and MUST
implicitly or explicitly logout of that connection. If the TCP
connection
had failed, how can the initiator send a logout command if there is only
one connection? Is the initiator expected to open a new connection to
send 
the logout command?
 
If there are more than one connection, should the initiator send the
logout
command on a different connection to logout the connection that failed?
 
thanks,
 -lakshmi

---

From: "Mallikarjun C." <[email-masked]>
Date: Tue, 18 May 2004 11:47:38 -0700

Note that the referenced text applies only if connection recovery is 
negotiated (i.e. operational ErrorRecoveryLevel=2).

 >Is the initiator expected to open a new connection to send
 > the logout command?

The following text in 6.1.4.3 answers your questions:

       Note: The logout function is mandatory. However, a new connection
       establishment is only mandatory if the failed connection was the
       last or only connection in the session.

Sending a Logout Request PDU for a CID different from the issuing 
connection is legal.
-- 
Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
cbm [at] rose.hp.com

Lakshmi Ramasubramanian wrote:
> implicitly or explicitly logout of that connection. If the TCP connection
> one connection? Is the initiator expected to open a new connection to send
> the logout command?
>  
> If there are more than one connection, should the initiator send the logout

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Carlos Rimola <[email-masked]>
Date: Tue, 18 May 2004 12:47:02 -0700

Lakshmi,

I think this is where the implicit keyword applies.  In other
words, it should go through the same process as if a Logout Req had been
sent and a Logour Resp received - implicitly.

Carlos Rimola

Silverback Systems

At 11:01 AM 5/18/2004, Lakshmi Ramasubramanian wrote:

6.1.4.3
Connection
Recovery
(Page 66 in iSCSI RFC 3720) says that in the event

of TCP Connection failure, initiator MUST close the connection and
MUST

had failed, how can the initiator send a logout command if there is
only

the logout command?

If there are
more than one connection, should the initiator send the logout

command on a different connection to logout the connection that
failed?

thanks,

-lakshmi