Subject: [Ips] Source Attribute of a Network Entity

From: "Yaron Klein" <[email-masked]>
Date: Sun, 16 May 2004 12:09:22 +0300

Hi folks,

Section 5.6.1 in the iSNS draft specifies that the Source Attribute MUST be either a Storage Node or a Control Node from the Network Entity. 

In the case where the Network Entity is a switch, the Storage Nodes it reflects may change through time (the user can add or remove Storage Nodes). Thus, it can register using one node, and when this node goes down, it must re-register under different node. This may cause inconsistency in the Network Entity representation. 

Thus, it may be better to allow the Source Attribute to be the Network Entity name (in iSCSI name format). This will ensure consistency in the Network Entity representation and provide better maintenance.

Yaron Klein
Sanrad

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Josh Tseng <[email-masked]>
Date: Sun, 16 May 2004 12:48:16 -0700 (PDT)

Yaron,

Note that the Network Entity is a container or
collection of storage nodes, and identifying it with
an iSCSI Name is probably not appropriate in most
cases.

Without knowing the specifics of your implementation,
my suggestion is to have your switch create a control
node with which to manage the registration and
deregistration of the Storage Nodes that it is in
control of.

Josh

--- Yaron Klein <[email-masked]> wrote:
> Hi folks,
> 
> Section 5.6.1 in the iSNS draft specifies that the
> Source Attribute MUST be either a Storage Node or a
> Control Node from the Network Entity. 
> 
> In the case where the Network Entity is a switch,
> the Storage Nodes it reflects may change through
> time (the user can add or remove Storage Nodes).
> Thus, it can register using one node, and when this
> node goes down, it must re-register under different
> node. This may cause inconsistency in the Network
> Entity representation. 
> 
> Thus, it may be better to allow the Source Attribute
> to be the Network Entity name (in iSCSI name
> format). This will ensure consistency in the Network
> Entity representation and provide better
> maintenance.
> 
> Yaron Klein
> Sanrad
> 
> 
> 

		
__________________________________
Do you Yahoo!?
SBC Yahoo! - Internet access at a great low price.
http://promo.yahoo.com/sbc/

---

From: Joe Souza <[email-masked]>
Date: Sun, 16 May 2004 13:02:16 -0700 (PDT)

Note that the Microsoft iSNS server does not currently allow control node registrations from network clients.  What I suggest in this case is to register a fictitious iSCSI node (type=initiator should be fine) for your entity and use that as the Source Attribute for your requests, if you don't currently have any target nodes registered for your entity.  Note also that as long as you have at least one target registered in your entity, you can use that target name as the Source Attribute for your requests.
 
-Joe

Josh Tseng <[email-masked]> wrote:
Yaron,

Josh