Subject: RE: [Ips] multiple iSCSI sessions

From: [email-masked]
Date: Fri, 21 May 2004 08:50:37 -0400

> Hi all,
> 
> - Can there be two different iSCSI sessions from different iSCSI initiator
ports
> to the same iSCSI target port (i.e. same target node + portal group tag)?

Yes.

> - Can two different iSCSI sessions from different iSCSI initiator ports
carry
> commands for the *same*  LUN within an iSCSI target node?

Yes.

> - Can the same LUN be in two different iSCSI target nodes?

Yes, although the SCSI-correct way to describe this is that the same LU
can be accessed via LUNs at two different targets.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Sat, 22 May 2004 08:23:34 -0400

Alberto Alesina <[email-masked]> wrote on 21/05/2004 18:49:19:

>  Julian..thanks for the reply. Please see inline 
> 
> >> - Can two different iSCSI sessions from different iSCSI initiator 
> >> ports carry commands for the *same*  LUN within an iSCSI target node? 

> >> 
> 
> > I assume you mean "same LU"  as LUN is the "LU number" and the 
> same LU may have different LUNs in 
> > different I_T nexi (different sessions in iSCSI) 
> > The response is yes. 
> Can the LU have the same LUN in different I_T nexi?
> 
Yes

> > See clarification above - yes if LU is what you meant 
> Similarly, can an LU belonging to two different target nodes have 
> the same LUN?

Yes

> Also, can the same block numbers in an LU be written to from 
> different I_T nexi? Does iSCSI target have to care about maintaining
> ordering consistency when two different iSCSI sessions are writing 
> to the same blocks in the same LU?
> 

That is the domain of the SCSI Block Devices commands sets (not iSCSI).
The general answer is that SCSI does not care about consistency not even 
about isolation
although isolation can be "enforced" with a (seldom implemented) feature.

> Thanks a lot for your time.
> 
> - Alberto
> 
> Do you Yahoo!?
> Yahoo! Domains - Claim yours for only $14.70/year