Subject: [Ips] iSCSI: number of PDU's

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 17 May 2004 11:36:11 -0400

There was a protocol change in 20+errata that I just noticed. I am wondering (and surprised) why it was done ... since we have all written our drivers and thought the protocol was stable. Especially when other less disruptive changes were asked for and turned down:

-- draft 20

10.4.8  ExpDataSN

   The number of Data-In (read) PDUs the target has sent for the

   command.

-- draft 20+erratta and RFC

10.4.8.  ExpDataSN

   The number of R2T and Data-In (read) PDUs the target has sent for the
   command.

Eddy

---

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 17 May 2004 12:48:30 -0400

MessageSorry, I didn't pickup the "target sent no data-in PDU's". Forget I said anything.

Eddy
  ----- Original Message ----- 
  From: Ken Sandars 
  To: 'Eddy Quicksall' ; [email-masked] 
  Sent: Monday, May 17, 2004 12:24 PM
  Subject: RE: [Ips] iSCSI: number of PDU's

  Hi Eddy,

  This was added for bi-directional command support. The next paragraph in the spec is the important one to consider. 

  For a WRITE-ONLY command, no Data-In pdus are sent, so the field is reserved (ie 0) - this is no change to draft 20 behaviour. For a READ-ONLY command there are no R2T pdus issued, so the number to report is the same as the number of Data-In pdus.

  However, for bidi commands, the ExpDataSN counter is the combined counter for both R2T and Data-In pdus (ie the target uses the one counter to track the pdus sent to the initiator for each command - essential for SNACK support). There was some talk about renaming it DataR2TSN (or something similar), but the authors chose to limit the changes to defining the semantics.

  End result - no change except for bidi commands.

  HTH,
  Ken.

  Ken Sandars
  Adaptec UK
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]] On Behalf Of Eddy Quicksall
    Sent: 17 May 2004 16:36
    To: [email-masked]
    Subject: [Ips] iSCSI: number of PDU's

    -- draft 20

    10.4.8  ExpDataSN

       command.

    10.4.8.  ExpDataSN

    Eddy

---

From: Julian Satran <[email-masked]>
Date: Tue, 18 May 2004 02:59:21 +0300

Eddy,

It is not a change - it is just a clarification.
Somewhere else in text there is statement that R2T and Data-In share the 
numbering space.
As others where confused the text was added to clarify the meaning for 
bi-directional commands (the only ones that have both Data-In and R2T).
The issue was on the list and addressed and the solution was agreed.
You have probably missed the discussion.

Julo

"Eddy Quicksall" <[email-masked]> 
Sent by: [email-masked]
17/05/04 11:36

To
<[email-masked]>
cc

Subject
[Ips] iSCSI: number of PDU's

There was a protocol change in 20+errata that I just noticed. I am 
wondering (and surprised) why it was done ... since we have all written 
our drivers and thought the protocol was stable. Especially when other 
less disruptive changes were asked for and turned down:
 
-- draft 20
 
10.4.8  ExpDataSN

 
10.4.8.  ExpDataSN
 
Eddy

---

From: "Ken Sandars" <[email-masked]>
Date: Mon, 17 May 2004 17:24:06 +0100

Hi Eddy,
 
This was added for bi-directional command support. The next paragraph in the
spec is the important one to consider. 
 
For a WRITE-ONLY command, no Data-In pdus are sent, so the field is reserved
(ie 0) - this is no change to draft 20 behaviour. For a READ-ONLY command
there are no R2T pdus issued, so the number to report is the same as the
number of Data-In pdus.
 
However, for bidi commands, the ExpDataSN counter is the combined counter
for both R2T and Data-In pdus (ie the target uses the one counter to track
the pdus sent to the initiator for each command - essential for SNACK
support). There was some talk about renaming it DataR2TSN (or something
similar), but the authors chose to limit the changes to defining the
semantics.

HTH,
Ken.
 
Ken Sandars
Adaptec UK

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eddy
Quicksall
Sent: 17 May 2004 16:36
To: [email-masked]
Subject: [Ips] iSCSI: number of PDU's

There was a protocol change in 20+errata that I just noticed. I am wondering
(and surprised) why it was done ... since we have all written our drivers
and thought the protocol was stable. Especially when other less disruptive
changes were asked for and turned down:

-- draft 20

10.4.8  ExpDataSN

   command.

10.4.8.  ExpDataSN

Eddy

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 18 May 2004 15:36:14 -0400

Thanks All ...

When I saw that change I did not read on to the next paragraph where it makes it clear that this is only for bi-directional.

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] ; [email-masked] 
  Sent: Monday, May 17, 2004 7:59 PM
  Subject: Re: [Ips] iSCSI: number of PDU's

  Eddy, 

  It is not a change - it is just a clarification. 
  Somewhere else in text there is statement that R2T and Data-In share the numbering space. 
  As others where confused the text was added to clarify the meaning for bi-directional commands (the only ones that have both Data-In and R2T). 
  The issue was on the list and addressed and the solution was agreed. 
  You have probably missed the discussion. 

  Julo 

        "Eddy Quicksall" <[email-masked]> 
        Sent by: [email-masked] 
        17/05/04 11:36 
       To <[email-masked]>  
              cc  
              Subject [Ips] iSCSI: number of PDU's 

    
  -- draft 20 
    
  10.4.8  ExpDataSN 

    
  10.4.8.  ExpDataSN 
    
  Eddy