Subject: [Ips] query about initiator

From: ulka vaze <[email-masked]>
Date: Tue, 28 Sep 2004 22:27:40 -0700 (PDT)

Hi All,
I have a questions regarding working of iscsi
initiator
1.Once Lgin is complete how does initiator finds
theLU's on target?
2.Does it fire inquiry first on device?
3.If target device has multiple LU s how does it
informs initiator about it?
Thanks
ulka 

__________________________________
Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.
http://promotions.yahoo.com/new_mail 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Wed, 29 Sep 2004 08:27:14 -0400

This is actually a SCSI issue, not iSCSI.

Once logged in, the initiator can discover the LU's in various ways.

1) In legacy SCSI, the initiator ususally will do some command to each
possible LU (Inquiry is ususally used for this). This method can still be
used today but it only gets one LU at a time.
2) Most recent targets will support the Report LUNs command. That will
report all LUs.

Eddy