Subject: RE: [Ips] resending Data-in with S bit set

From: "Dean Scoville" <[email-masked]>
Date: Tue, 5 Oct 2004 15:22:33 -0700

When you say only "Status" PDUs, do you mean only "SCSI Response" PDUs,
and that the target should remain silent about any phase collapsed Data-In PDUs? 
That doesn't make sense to me. If the initiator has 100 commands outstanding and
issues a Status SNACK because a received StatSN indicates that some PDUs are
missing, it shouldn't have to issue Data SNACKs for all of the outstanding commands
to see if one of them perhaps was using phase collapse and happened to have the
missing StatusSN. Is that really what is intended?
 
The last sentence in Section 3.2 defines a numbered response as:
 
    "Also, unless otherwise specified, status, response, or numbered response have the same meaning."
 
And Section 6.1.4.2 states:
 
    "Lost iSCSI numbered Response. It is recognized by either identifying a data digest
     error on a Response PDU or a Data-In PDU carrying the status, or by receiving a
     Response PDU with a higher StatSN than expected."
 
The above two RFC statements would lead me to believe that numbered responses include 
Data-In PDUs, and that the numbered responses referred to in Section 10.16.1 in 
reference to Status SNACKs should also include Data-In retransmissions.
 
Dean

-----Original Message-----
From: Eddy Quicksall [mailto:[email-masked]]
Sent: Tuesday, October 05, 2004 3:09 PM
To: Dean Scoville; Julian Satran
Cc: [email-masked]
Subject: Re: [Ips] resending Data-in with S bit set

Maybe my question was misunderstood. To say it another way:
 
Is it true that a Status SNACK only solicits Status PDUs and that it does not solicit Data-In PDUs which have the S bit set?
 
I interpret Julian's answer to this as "yes, that is true". 
 
Eddy

----- Original Message ----- 
From: Dean Scoville <mailto:[email-masked]>  
To: Julian Satran <mailto:[email-masked]>  ; Eddy Quicksall <mailto:[email-masked]>  
Cc: [email-masked] 
Sent: Tuesday, October 05, 2004 5:54 PM
Subject: RE: [Ips] resending Data-in with S bit set

Julian,
 
Section 10.16 states the following about PDUs transmitted as a result of a SNACK:
 
   "The numbered-response(s) or R2T(s), requested by a SNACK, MUST be
    delivered as exact replicas of the ones that the target transmitted originally
    except for the fields ExpCmdSN, MaxCmdSN, and ExpDataSN, which MUST
    carry the current values. R2T(s) requested by SNACK MUST  also carry the
    current values and except for resegmentation (see Section 10.16.3 Resegmentation)."
 
Section 10.16.1 describes Status and Data/R2T SNACK types as:
 
    0-Data/R2T SNACK - requesting retransmission of one or more Data-In or R2T PDUs.
    1-Status SNACK - requesting retransmission of one or more numbered responses.
 
It seems to me that if the target receives a Status SNACK for status sent on a Data-In 
PDU due to phase collapse, the target should send an exact replica of the Data-In PDU.

Similarly, if the target receives a Data SNACK, it should retransmit the Data-In PDU with
the S bit set, since it is a retransmission.
 
I may have misunderstood your recent posting, but I thought it said the target should 
generate a totally new SCSI Response PDU in response to the Status SNACK rather
than retransmitting the original Data-In PDU. And that it should send a Data-In PDU
without the S-bit set in the case of a Data SNACK. Both of these behaviors seem to 
violate what is stated in Sections 10.16 and 10.16.1 of the iSCSI RFC, as quoted above.
 
I would appreciate clarification on the target's expected response in these situations.
 
thanks,
 
Dean Scoville

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Julian Satran
Sent: Monday, October 04, 2004 7:43 AM
To: Eddy Quicksall
Cc: [email-masked]
Subject: Re: [Ips] resending Data-in with S bit set

Eddy, 

This is correct. 
The data-in PDUs don't have to be sent. 
The initiator has to request the data-in PDUs explicitly and MUST do so before it acks the status (that implicitly acks all the data and deletes any record of the command at target). 

Julo 

[email-masked] wrote on 04/10/2004 15:20:56:

> Can you confirm that the intent of 10.16.6. is as follows? 
>   
> If the Initiator has requested for a Status SNACK with BegRun=0 and 
> RunLength=0 (i.e, all unacknowledged status pdus) and the target has
> some Data-In PDUs carrying *status* that have not been acknowledged,
> the target will *not* resend those Data-In PDUs carrying the status. 
>   
> The unacknowledged queue looks like 
>   
>    response(statSN=5) ---> response(statSN=6) -----> Data-In w/S 
> bit(statSN=7) ----> response(statSN=8) 
>   
> The target will resend pdus with statSN 5, 6 and 8. The Data-In with
> statSN 7 will not be resent even though it sends status. 
>   
> Eddy 
>  _______________________________________________
> Ips mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ips

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 5 Oct 2004 18:44:09 -0400

Yes, when I said "Status PDUs", I used shorthand and meant SCSI Response PDUs".

What you point out is exactly the reason I wanted to know the intent and if I understood the spec correctly. I did not mean to say I agree or disagree with the intent.

Since the spec is finished, I think it is too late to argue for a change. It looks like the initiator just has to be a little smart when it needs all PDUs that carry status.

Eddy
  ----- Original Message ----- 
  From: Dean Scoville 
  To: Eddy Quicksall ; Julian Satran 
  Cc: [email-masked] 
  Sent: Tuesday, October 05, 2004 6:22 PM
  Subject: RE: [Ips] resending Data-in with S bit set

  Dean
    -----Original Message-----
    From: Eddy Quicksall [mailto:[email-masked]]
    Sent: Tuesday, October 05, 2004 3:09 PM
    To: Dean Scoville; Julian Satran
    Cc: [email-masked]
    Subject: Re: [Ips] resending Data-in with S bit set

    Eddy
      ----- Original Message ----- 
      From: Dean Scoville 
      To: Julian Satran ; Eddy Quicksall 
      Cc: [email-masked] 
      Sent: Tuesday, October 05, 2004 5:54 PM
      Subject: RE: [Ips] resending Data-in with S bit set

      Julian,

      thanks,

      Dean Scoville
        -----Original Message-----
        From: [email-masked] [mailto:[email-masked]]On Behalf Of Julian Satran
        Sent: Monday, October 04, 2004 7:43 AM
        To: Eddy Quicksall
        Cc: [email-masked]
        Subject: Re: [Ips] resending Data-in with S bit set

        Eddy, 

        This is correct. 

        Julo 

        > statSN 7 will not be resent even though it sends status. 

------------------------------------------------------------------------------

---

From: William Studenmund <[email-masked]>
Date: Tue, 5 Oct 2004 18:58:27 -0400

> missing StatusSN. Is that really what is intended?

To be honest, while I think that's what Julian said, I don't think 
that's correct. I think we should treat a phase-collapsed PDU as both a 
status PDU and a data PDU. The problem with requiring Data SNACK be the 
only way to request a retransmit is that if the initiator was looking 
for a specific StatSN, it has to retry every task to find it; the 
request is indexed inefficiently.

>  reference to Status SNACKs should also include Data-In 

Take care,

Bill

---

From: "Eddy Quicksall" <[email-masked]>
Date: Tue, 5 Oct 2004 22:58:36 -0400

I think Dean has a good point here. I missed the definition in 3.2 he gives below and now it looks like the intent was to include the Data-In PDUs with the S bit set as those sent in response to a Status SNACK. Also, it makes the most sense as Dean has pointed out.

Julian, can you please check with the other authors and see what the original intent was?

Eddy
  ----- Original Message ----- 
  From: Dean Scoville 
  To: Eddy Quicksall ; Julian Satran 
  Cc: [email-masked] 
  Sent: Tuesday, October 05, 2004 6:22 PM
  Subject: RE: [Ips] resending Data-in with S bit set

  Dean
    -----Original Message-----
    From: Eddy Quicksall [mailto:[email-masked]]
    Sent: Tuesday, October 05, 2004 3:09 PM
    To: Dean Scoville; Julian Satran
    Cc: [email-masked]
    Subject: Re: [Ips] resending Data-in with S bit set

    Eddy
      ----- Original Message ----- 
      From: Dean Scoville 
      To: Julian Satran ; Eddy Quicksall 
      Cc: [email-masked] 
      Sent: Tuesday, October 05, 2004 5:54 PM
      Subject: RE: [Ips] resending Data-in with S bit set

      Julian,

      thanks,

      Dean Scoville
        -----Original Message-----
        From: [email-masked] [mailto:[email-masked]]On Behalf Of Julian Satran
        Sent: Monday, October 04, 2004 7:43 AM
        To: Eddy Quicksall
        Cc: [email-masked]
        Subject: Re: [Ips] resending Data-in with S bit set

        Eddy, 

        This is correct. 

        Julo