Subject: [Ips] query about report luns command with microsoft iscsi initiator

From: ulka vaze <[email-masked]>
Date: Wed, 13 Oct 2004 23:01:35 -0700 (PDT)

Hi all,
I am using Microsoft initiator ver 1.02 for my target
server. which is on MAC .After Login completion it
send Report LUNs command.In this PDU it sends 16 byte
as expected data transfer length.
i am getting CDB as below
0xa0 00 00 00 00 00 00 00 00 10 00 00 00 00 00 00
I am not passing this cdb to scsi layer as I would be
generating the response at my iscsi layer only. So my
question is-
* Do i have to send report LUNs response as per the
format specified in SPC-2 in the data segment.
* From above CDB allocation length is coming 16 bytes 
so i'll give lun list and first lun address.is it
correct?
*in iscsi response pdu if check condition is not there
then will data segment contains only response data
from scsi?
anticipating reply.
thanks
ulka

_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Lakshmi Ramasubramanian" <[email-masked]>
Date: Thu, 14 Oct 2004 10:17:36 -0700

Ulka,

You are right - MS Initiator will send SCSI Report LUNs command with
buffer size 16 bytes. Target should return data in the format given in
SPC-2. Target should give the first lun address. If you have more than
one LUN to report, you should set the actual buffer size needed in the
first 4 bytes of the response (Format as given in SPC-2). Initiator will
retry ReportLUNs with a bigger buffer if more than one LUN is available.

Hope that answers your questions.

 -lakshmi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ulka vaze
Sent: Wednesday, October 13, 2004 11:02 PM
To: [email-masked]
Subject: [Ips] query about report luns command with microsoft iscsi
initiator

Hi all,