Subject: RE: [Ips] use of the I bit in a nop-out

From: "Dean Scoville" <[email-masked]>
Date: Fri, 22 Oct 2004 08:32:16 -0700

According to section 10.18.1, the I-bit MUST be set to 1 whenever ITT=0xffffffff in the NOP-Out PDU.
The I-bit keeps the CmdSN from advancing when the initiator either replies to a NOP-In ping
sent by the target or when it sends a NOP-Out to update the target's counters (without requiring
a reply).
 
Dean

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eddy Quicksall
Sent: Thursday, October 21, 2004 3:36 PM
To: [email-masked]
Subject: [Ips] use of the I bit in a nop-out

Can anyone point out a good use for the I bit in a NOP-out?
 
Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 22 Oct 2004 13:32:44 -0400

Yes, that is a requirement.  I failed to say it but what I should have asked was for an initiator generated ping with the ITT != 0xFFFFFFFF. 

Actually, you sparked a thought... it allows the ping code to be in a separate thread that does not have access to CmdSN numbering.

Eddy
  ----- Original Message ----- 
  From: Dean Scoville 
  To: Eddy Quicksall ; [email-masked] 
  Sent: Friday, October 22, 2004 11:32 AM
  Subject: RE: [Ips] use of the I bit in a nop-out

  Dean
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of Eddy Quicksall
    Sent: Thursday, October 21, 2004 3:36 PM
    To: [email-masked]
    Subject: [Ips] use of the I bit in a nop-out

    Eddy