Subject: [Ips] resending Data-in with S bit set

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 4 Oct 2004 09:20:56 -0400

Can you confirm that the intent of 10.16.6. is as follows?

If the Initiator has requested for a Status SNACK with BegRun=0 and RunLength=0 (i.e, all unacknowledged status pdus) and the target has some Data-In PDUs carrying *status* that have not been acknowledged, the target will *not* resend those Data-In PDUs carrying the status.

The unacknowledged queue looks like

   response(statSN=5) ---> response(statSN=6) -----> Data-In w/S bit(statSN=7) ----> response(statSN=8)

The target will resend pdus with statSN 5, 6 and 8. The Data-In with statSN 7 will not be resent even though it sends status.

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Mon, 4 Oct 2004 16:42:46 +0200

Eddy,

This is correct.
The data-in PDUs don't have to be sent.
The initiator has to request the data-in PDUs explicitly and MUST do so 
before it acks the status (that implicitly acks all the data and deletes 
any record of the command at target).

Julo

[email-masked] wrote on 04/10/2004 15:20:56:

> If the Initiator has requested for a Status SNACK with BegRun=0 and 
> RunLength=0 (i.e, all unacknowledged status pdus) and the target has
> some Data-In PDUs carrying *status* that have not been acknowledged,
> the target will *not* resend those Data-In PDUs carrying the status.
> 
> The target will resend pdus with statSN 5, 6 and 8. The Data-In with
> statSN 7 will not be resent even though it sends status.
> 
> Eddy