Subject: [Ips] Long CDBs and bi-directional commands

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 12 Nov 2004 15:17:49 -0500

I would like to test long CDB's and bi-directional commands. Does anyone know of any initiator that uses these?

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Mon, 15 Nov 2004 12:17:26 +0200

Eddy,

Object Storage uses both. It is likely that Intel's initiator uses both.
Mike Mesnier may have some details about how to get to it..
Kalman may know about "variants" of the source-forge initiator that 
support them too.

Regards,
julo

"Eddy Quicksall" <[email-masked]> 
Sent by: [email-masked]
12/11/04 22:17

To
<[email-masked]>
cc

Subject
[Ips] Long CDBs and bi-directional commands

I would like to test long CDB's and bi-directional commands. Does anyone 
know of any initiator that uses these?
 
Eddy_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: William Studenmund <[email-masked]>
Date: Tue, 16 Nov 2004 12:27:33 -0800

On Nov 12, 2004, at 12:17 PM, Eddy Quicksall wrote:

> I would like to test long CDB's and bi-directional commands. Does 
> anyone know of any initiator that uses these?

I'm not familiar with how other OSs handle this, but I believe all of 
the *BSDs support (privileged) programs sending SCSI commands directly 
to a device. So you could just write a program to make an initiator 
send such commands.

Take care,

Bill

---

From: Pat LaVarre <[email-masked]>
Date: Tue, 16 Nov 2004 14:34:38 -0700

> to a device. So you could just write a program to make an initiator 

Elsewhere I've seen SCSI pass thru facilities commonly require root 
privilege, limit CDB's to 16 or to 12 bytes max, and pass data thru 
only in or only out ... and the Mac OS X derivative of BSD requires PDT 
= x05 = DVD/ CD and rewritability for SCSI pass thru ... but maybe life 
in many BSD is better, I don't know.

Pat LaVarre
http://plavarre.blog-city.com/read/614076.htm