Subject: [Ips] why microsoft initiator sends mode sense

From: ulka vaze <[email-masked]>
Date: Tue, 2 Nov 2004 03:31:41 -0800 (PST)

Hi all,
 I am testing my iscsi target developed on MAC OS
X.Initially after LOgin is complete microsoft
initiator sends report Luns then Inquiry and then Read
capacity.After that it is sending read 10 with data
transfer length 512.Now in response to Read10 i send
DATA _IN pdu which has 512 bytes of data segment which
contains the data that i get from MAC's scsi layer.I
set the f=1 because only one data-in pdu ,i am setting
status bit 1 and sending status as good.
After receiving this response microsoft initiator
sends mode sense and asks for all mode pagess.I want
to know what could be the reason for this?
Also it exposes device with device tyep unknown and
number -1 what is the problem?
Pl. help i am badly stuck here .
Thanks
ulka

__________________________________ 
Do you Yahoo!? 
Check out the new Yahoo! Front Page. 
www.yahoo.com 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Pat LaVarre <[email-masked]>
Date: Tue, 2 Nov 2004 07:27:28 -0700

Ulka V:

As yet I know very nearly zero of iSCSI ... but speaking of SCSI 
generally, as in the t10.org texts, I can say:

> microsoft initiator

When PDT = x00 = DASD = HDD/ Flash, a fetch of all mode pages includes 
the header which includes the DSP ("device specific parameter") which 
includes a bit to say if the disk is rewritable, read-only, or absent.

> microsoft
> transfer length 512.
> ...
> device tyep unknown

To me, "device type" = "peripheral device type" = PDT = mask x1F of 
byte 0 of op x12 "INQUIRY" data ... so if the Inquiry went well, I 
don't understand how the device type can be unknown.

Pat LaVarre

---

From: William Studenmund <[email-masked]>
Date: Thu, 4 Nov 2004 11:27:08 -0800

> to know what could be the reason for this?

Uhm, because the Windows SCSI layer asked it to?

Asking for all mode pages is a common operation on device connect. It 
lets the initiator learn what the target can do.

> number -1 what is the problem?

You should check your mode sense and inquiry data responses.

Take care,

Bill