Subject: [Ips] RE: iSER Open Issues

From: "Caitlin Bestler" <[email-masked]>
Date: Tue, 7 Dec 2004 09:58:42 -0800

> From: "Mallikarjun C." <[email-masked]>
> Subject: Re: [Ips] iSER Open Issues
> 
> IMO, a default of None makes sense since these are 
> essentially RFC 3720 semantics (and RFC 3720-compliant 
> implementations do not negotiate/understand the new key).
> 

That is only true from the sending perspective, where "None"
essentially means "don't worry about it", and that does match
TCP semantics. You don't have to worry about overflowing the
target because TCP bottlenecking will efficiently prevent that.

But that is *not* the case at the other end. Instead of meaning,
"you can read these at whatever pace you want, it will only impact
Performance, not correctness" selecting "NONE" means you MUST at
least accept these messages from the transport layer at full speed.

I agree with the concern raised at the DC meeting that this is
not an appropriate default. An implementation that does not know
To set the key is probably *not* capable of meeting the requirements
of "NONE", and any capable of doing so would have no problem explicitly
setting the limit.

That said, explicitly setting the key is not that hard for *anyone*, so
What the default value is is really not that important, as long as it
is defined.

However, for simplicity of the specification I would recommend that it
either be the minimum or "NONE". That way no third special value is 
created.

--
Caitlin Bestler
Director Software Architecture
Siliquent Technologies
[email-masked]

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 08 Dec 2004 16:26:49 -0800

> But that is *not* the case at the other end.....selecting "NONE" 
means you MUST at
 > least accept these messages from the transport layer at full speed.

Let us not mix iSCSI-3720 semantics with what it means for RNICs that 
don't do graceful handling.

iSCSI-3720 places _no_ restrictions on how many unexpected PDUs must be 
received "at full speed" - the receiving iSCSI layer is allowed to 
discard an unexpected PDU without any processing and while the PDU is 
not received, the PDU sits in the transport buffers.

The thing I like about a "None" default is that an iSCSI-3720 pair that 
doesn't negotiate this key works the same way as an iSCSI-3720+iSER pair 
that chooses not to negotiate.

 > What the default value is is really not that important

Indeed.  Also what I said in the DC meeting.  Mike's request for list 
input was what prompted me.

Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
cbm [at] rose.hp.com

---

From: John Hufferd <[email-masked]>
Date: Wed, 8 Dec 2004 17:03:08 -0800

I agree with Mallikarjun, and the logic behind what he says.
.
.
John L. Hufferd
Senior Technical Staff Member (STSM)
IBM/System Group, San Jose CA
Main Office: (408) 256-0403, Tie: 276-0403, eFax: (408) 904-4688
Alt Office: (408) 997-6136, Cell: (408) 499-9702
Internet Address: [email-masked]

"Mallikarjun C." <[email-masked]> 
Sent by: [email-masked]
12/08/2004 04:26 PM

To
[email-masked]
cc

Subject
Re: [Ips] RE: iSER Open Issues

means you MUST at

Mallikarjun

Mallikarjun Chadalapaka