Subject: [Ips] Distinction between format and protocol error

From: "BillMurray" <[email-masked]>
Date: Wed, 8 Dec 2004 12:39:40 -0500

Sections 6.6 and 6.11 seem to clearly explain what
Format and Protocol Errors are and how they are
handled. However section 10 seems a bit contradictory
(unless reserved areas of the pdu header are not
considered fields).

How am I to interpret this?

Also, what is the difference between 'illegal' and
'inconsistent' in section 6.6 below?

6.6 Format Errors

The following two explicit violations of PDU layout rules are
format errors:

a) Illegal contents of any PDU header field except the Opcode
(legal values are specified in Section 10 iSCSI PDU Formats).
b) Inconsistent field contents (consistent field contents are
specified in Section 10 iSCSI PDU Formats).

10. iSCSI PDU Formats

Receipt of reserved code values in defined fields MUST be reported as a protocol error.

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Mallikarjun C." <[email-masked]>
Date: Wed, 08 Dec 2004 23:25:55 -0800

Please refer to a recent discussion thread:

http://www1.ietf.org/mail-archive/web/ips/current/msg01139.html

I think it answers your questions.

Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
Network Storage Solutions
Hewlett-Packard MS 5668
Roseville CA 95747
cbm [at] rose.hp.com

---

From: Julian Satran <[email-masked]>
Date: Thu, 9 Dec 2004 10:25:38 +0200

Bill,

What the text meant by illegal - is a field value that is wrong by itself 
(regardless of the value of other fields) while inconsistent meant with 
regard to other fields or the general context (e.g., an ITT and LU in 
response do not match those in a request although both are "legal" in a 
strict sense and may be even valid in the context).

We understand that in general inconsistent is a a particular case of 
illegal (dictionary definition for illegal is "forbidden by law or 
statute")

Julo 

"BillMurray" <[email-masked]> 
Sent by: [email-masked]
08-12-04 19:39
Please respond to
BillMurray <[email-masked]>

To
<[email-masked]>
cc

Subject
[Ips] Distinction between format and protocol error

6.6 Format Errors

10. iSCSI PDU Formats

Receipt of reserved code values in defined fields MUST be reported as a 
protocol error.

---

From: Julian Satran <[email-masked]>
Date: Thu, 09 Dec 2004 21:57:27 +0200

Bill,

What the text meant by illegal - is a field value that is wrong by
itself (regardless of the value of other fields) while inconsistent
meant with regard to other fields or the general context (e.g., an ITT
and LU in response do not match those in a request although both are
"legal" in a strict sense and may be even valid in the context).

We understand that in general inconsistent is a a particular case of
illegal (dictionary definition for illegal is "forbidden by law or statute")

Julo