Subject: RE: [Ips] I-D ACTION:draft-ietf-ips-auth-mib-06.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 1 Feb 2005 18:16:20 +0100

So this is hwta I get:

   C:\bwijnen\smicng\work>smicng ipsauth.inc
   E: f(ipsauth.mi2), (53,7) Leading sub-Id "mib-2" is not known in
      current module
   W: f(ipsauth.mi2), (5,5) "experimental" imported but not used
   *** 1 error and 1 warning in parsing

When I fix that, then it passes SYNTAX checking with SMIXng
It also passes smilint syntax checking then.
It also passes idnits checking.

I think I would change:

     ipsAuthDescriptors OBJECT IDENTIFIER ::= { ipsAuthObjects 1 }

     ipsAuthMethodTypes OBJECT IDENTIFIER ::= { ipsAuthDescriptors 1 }

   into something like:

     ipsAuthDescriptors OBJECT IDENTIFIER ::= { ipsAuthObjects 1 }

     ipsAuthMethodTypes OBJECT-IDENTITY
         STATUS         current
         DESCRIPTION   "Registration point for iSCSI Method Types".
         REFERENCE     "iSCSI Protocol Specification."
     ::= { ipsAuthDescriptors 1 }

   It lets you say some more about what this is.
   Not a blocking comment though.

I see in DESCRIPTION of ipsAuthInstIndex (which is a not-accessible index)
that values do not need to be preserved over reboot.
Does that also mean that ipsAuthInstDescr values do not need to be
preserved over reboot?

A similar (not need to be preserved over reboot) is present for:
ipsAuthIdentIndex, and yet there is a StorageType object in that
table. So what if the StorageType syas "permanent" ??
Or what if it says "nonVolatile"?

By the way, for a STorageType object you MUST specify which columns
(or none) of the writable columns must be writable for permanent 
objects.

You also need to describe if any (writable) objects in row can
be changed when the row is in "active" state.

This is all described in RFC2579 and in the mib-review-guidelines.

I need to check David Harrington comments first so as to not make
duplicates.

more later
Bert
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Mark Bakke
> Sent: Friday, January 28, 2005 03:39
> To: [email-masked]
> Cc: Michael MacFaden
> Subject: Re: [Ips] I-D ACTION:draft-ietf-ips-auth-mib-06.txt
> 
> 
> This draft was issued to address Michael MacFaden's MIB doctor review
> comments.  It also addresses a few issues (StorageType and top-level
> numbering) brought up in the iSCSI MIB review that apply here as well.
> 
> Here is a brief summary of changes since -05:
> 
> - IANA Considerations section added requesting OID
> - Text added to 4.2 to clarify that index values need not be 
> preserved 
> across reboots
> - Added the use of the StorageType TC for all tables 
> containing RowStatus
>   (this addresses a comment against the iSCSI MIB which also 
> applies here)
> - Renumbered top level to match Appendix D of 
> draft-ietf-ops-mib-review-guidelines-03.txt
> - Added DESCRIPTION text to Index attributes to say they need not be 
> preserved across reboots
> - Updated DESCRIPTIONs on RowStatus attributes
> - Added REFERENCE fields for ChapUserName, SrpUserName, and 
> KerbPrincipal attributes
> - Moved CHAP, SRP, and Kerberos references to Normative section
> 
> And a few administrative changes:
> - Authors' addresses updated
> - Authors' phone numbers removed
> - Dates updated
> - Updated IPR Notice
> - Updated first page IPR Notice
> - Updated copyright statement
> - Updated references
> 
> This MIB module passed smilint 0.4.3 with no errors.
> 
> Diffs between -05 and -06 are available at:
> 
> ftp://ftpeng.cisco.com/mbakke/ips/auth-mib/auth-mib-diffs-05-06.txt
> 
> The draft, along with a .mi2 MIB-only (no internet-draft 
> text) file are
> available at ftp://ftpeng.cisco.com/mbakke/ips/auth-mib/
> 
> Mark
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Mark Bakke <[email-masked]>
Date: Wed, 16 Feb 2005 23:04:26 -0600

Bert-

Thanks for the comments; I've addressed them below.  BTW, I just realized
that you and Michael were not explicitly copied on David Harrington's
comments and my responses, unless you are subscribed to the ips mailing
list.  I've forwarded these responses to both of you in case you did not
receive them.  I've copied David on this response as well.

Mark

Wijnen, Bert (Bert) wrote:

>So this is what I get:
OK; I'll fix.

>   Not a blocking comment though.
But an easy fix; I'll take care of it.

>Does that also mean that ipsAuthInstDescr values do not need to be
The intent is that ipsAuthInstDescr is preserved across reboot.  Since 
it's read-write,
but with no RowStatus, I assume I just need to add to the DESCRIPTION:

        This value must be preserved across reboots

>Or what if it says "nonVolatile"?
I didn't consider that StorageType would apply to an index value; that just
slipped right by.  This would affect all of the other Index values as 
well.  Any
ideas on the best way to handle this?  I need to think about this one.

>(or none) of the writable columns must be writable for permanent 
I assume that since the only read-write column (ipsAuthInstDescr) is not
in a table containing a RowStatus, and the all of the others are 
read-create,
that there are none of these to specify.

>be changed when the row is in "active" state.
Since there is no RowStatus for the table containing ipsAuthInstDescr, I
don't think the draft has any of these either.