Subject: [Ips] iSCSI - StatSN in a reinstatement

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 25 Feb 2005 16:11:23 -0500

10.12.9.  ExpStatSN

   For the first Login Request on a connection this is ExpStatSN for the

   old connection and this field is only valid if the Login Request

   restarts a connection (see Section 5.3.4 Connection Reinstatement).

   For subsequent Login Requests it is used to acknowledge the Login

   Responses with their increasing StatSN values.

10.13.4.  StatSN

   For the first Login Response (the response to the first Login

   Request), this is the starting status Sequence Number for the

   connection.  The next response of any kind, including the next Login

   Response, if any, in the same Login Phase, will carry this number +

   1.  This field is only valid if the Status-Class is 0.

I want to know if I understand correctly ... can you please confirm or contradict:

I don't think this is saying a login which reinstates a connection must

use ExpStatSN in the first login response.

Eddy
_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Sat, 26 Feb 2005 15:36:12 +0200

Eddy,

Responses don't carry ExpStatSN. The first Login Request must carry the 
ExpStatSN of the old connection on a reinstated connection to indicate the 
target what Responses where received and processed by the initiator before 
logout.

Julo

"Eddy Quicksall" <[email-masked]> 
Sent by: [email-masked]
25/02/2005 23:11

To
<[email-masked]>
cc

Subject
[Ips] iSCSI - StatSN in a reinstatement

10.12.9.  ExpStatSN

 
10.13.4.  StatSN

I want to know if I understand correctly ... can you please confirm or 
contradict:
I don't think this is saying a login which reinstates a connection must
use ExpStatSN in the first login response.
 
Eddy_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 28 Feb 2005 11:10:29 -0500

That is correct but what I was asking is if the paragraphs were implying that the first login response of a reinstated connection was supposed to use the ExpStatSN for the value of StatSN. I think not.

Eddy
  ----- Original Message ----- 
  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Saturday, February 26, 2005 8:36 AM
  Subject: Re: [Ips] iSCSI - StatSN in a reinstatement

  Eddy, 

  Responses don't carry ExpStatSN. The first Login Request must carry the ExpStatSN of the old connection on a reinstated connection to indicate the target what Responses where received and processed by the initiator before logout. 

  Julo 

        "Eddy Quicksall" <[email-masked]> 
        Sent by: [email-masked] 
        25/02/2005 23:11 
       To <[email-masked]>  
              cc  
              Subject [Ips] iSCSI - StatSN in a reinstatement 

  10.12.9.  ExpStatSN 

    
  10.13.4.  StatSN

---

From: Julian Satran <[email-masked]>
Date: Mon, 28 Feb 2005 19:59:50 +0200

It is not strictly required (the text does not say it is) and you could 
start a new sequence in the login response but it is not forbidden either.
And I assume that this is the path of least resistance - as the initial 
StatSN is arbitrary anyhow.

Julo

28/02/2005 18:10

To
Julian Satran/Haifa/IBM@IBMIL
cc
<[email-masked]>
Subject
Re: [Ips] iSCSI - StatSN in a reinstatement

That is correct but what I was asking is if the paragraphs were implying 
that the first login response of a reinstated connection was supposed to 
use the ExpStatSN for the value of StatSN. I think not.
 
Eddy
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Saturday, February 26, 2005 8:36 AM
Subject: Re: [Ips] iSCSI - StatSN in a reinstatement

Eddy, 

Julo 

To
<[email-masked]> 
cc

Subject

10.12.9.  ExpStatSN 

  
10.13.4.  StatSN