Subject: [Ips] [ANNOUNCE] iSER (iSCSI RDMA Extension) code added to OpenIB

From: "Dan Bar Dov" <[email-masked]>
Date: Mon, 7 Feb 2005 17:20:20 +0200

I am glad to announce the posting of iSER to the OpenIB svn. 

The code is now available under:   https://openib.org/svn/gen2/ulps/iser/

iSER is an important addition to OpenIB, adding significant capabilities and performance to InfiniBand enabled block and object storage

Mr. Yaron Haviv will cover in detail the iSER code architecture and implementation, during his Tuesday morning session (D9) at the 2005 OpenIB Developers Workshop.

About OpenIB-iSER:

OpenIB iSER is a fully functional and tested implementation, following all the latest iSCSI, DA, and iSER IETF draft RFC’s (including the latest generalization of iSER to InfiniBand).

iSER is a new direct access transport under iSCSI in addition to the TCP one, it is part of the new iSCSI Datamover Architecture (DA) separating the iSCSI control and management functionality from the actual SCSI Commands+Data.

iSCSI/iSER can be used for native InfiniBand storage and InfiniBand to GbE or FC gateways, where the implementation can leverage on all the iSCSI infrastructure including naming, discovery, security, notifications, error recovery, etc’ in a transparent manner. 

The actual transport (TCP or iSER) can be automatically selected based on the available hardware and path to target, enabling a single driver for GbE, IB, and FC which is centrally provisioned through iSCSI mechanisms such as iSNS and SLP.

OpenIB-iSER  conforms to the  Datamover  Architecture , it works with the Linux-iSCSI  4.2 branch, or with the latest  head  patch from Voltaire adding the Datamover Architecture support (an API  layer  for pluggable Datamover modules), it can also be used by other block or object (or cluster file system) iSCSI based implementations by simply adding the Datamover layer (the Linux-iSCSI DA patch changes/adds ~1000 LOC, such an adaptation can be done in few weeks)

More details on iSER, and links can be found in:

http://www.voltaire.com/iser.htm

Dan Bar Dov
Project Manager
Infiniband Storage Solutions
T +972-9-9717636
C +972-54-8080505
www.voltaire.com
The Grid Interconnect Company

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Christoph Hellwig <[email-masked]>
Date: Tue, 8 Feb 2005 10:50:49 +0100

If you want this code to get anywhere near the kernel tree write it to
the native Linux IB APIs instead of kdapl.