Subject: [Ips] RE: [linux-iscsi-devel] [ANNOUNCE] iSER (iSCSI RDMA Extension) code added to OpenIB

From: "Dan Bar Dov" <[email-masked]>
Date: Wed, 9 Feb 2005 15:14:38 +0200

The main reason for the implementation over kDAPL is the need to support both 
Ethernet RDMA and InfiniBand which many consider as one of the benefits of iSER 

The same goes for NFS/RDMA which is over kDAPL, and I'm sure is an important 
protocol for the Linux community 

If your concern is the kDAPL coding style and API conformance with Linux  than those issues 
are going to be resolved soon, by cleaning up the kDAPL implementation and make it comply 
with the Linux requirements.

In addition the DAPL license is in the process of being changed to GPL + BSD (the openIB standard).

Yes, it is possible to change it to OpenIB low layer API but we will be missing the bigger picture
That includes iSCSI/RDMA, NFS/RDMA where RDMA includes iWARP, IB and future RDMA transports.
I'm sure the strong interest Linux users have in iSER and NFS/RDMA along with our (and others) strong c
ommitment to conform to the Linux guidelines will enable us to resolve this matter.

For now the focus in this list is to support the Datamover Architecture that separates iSCSI from the 
transport with a lower Datamover API, enabling to plug-in Datamovers and the iSER Datamover itself will be pushed later.

I appreciate it if you can explain to me what are your concerns with kDAPL and if my response doesn't satisfy you.
 
Dan

> -----Original Message-----
> From: Christoph Hellwig [mailto:[email-masked]] 
> Sent: Tuesday, February 08, 2005 11:51 AM
> To: Dan Bar Dov
> Cc: [email-masked]; [email-masked]
> Subject: Re: [linux-iscsi-devel] [ANNOUNCE] iSER (iSCSI RDMA 
> Extension) code added to OpenIB
> 
> If you want this code to get anywhere near the kernel tree 
> write it to the native Linux IB APIs instead of kdapl.
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Christoph Hellwig <[email-masked]>
Date: Wed, 9 Feb 2005 18:41:02 +0100

> Ethernet RDMA and InfiniBand which many consider as one of the benefits of iSER 

I've not seen a single Ethernet RDMA implementation, nevermind the
driver stack for Linux.

> protocol for the Linux community 

In your dreams ;-)

> with the Linux requirements.

The whole kDAPL concept is rather worrysome.  We don't introduce
abstractions for the abstractions sake.  If you can show an abstraction
is usefull it'll be implemented.

> I appreciate it if you can explain to me what are your concerns with kDAPL and if my response doesn't satisfy you.

Honestly I think don't anyone with the smallest bit of taste would argue
in favour of kDAPL as it stands.