Subject: [Ips] RE: [linux-iscsi-devel] [ANNOUNCE] iSER (iSCSI RDMA Extension) code added to OpenIB

From: "Dan Bar Dov" <[email-masked]>
Date: Thu, 10 Feb 2005 10:32:41 +0200

Dear Christoph,

I find your answers pretty immature.

If we'd been discussing beer, we could talk about taste.
Since we discuss technology, I'd appreciate it if you could stick with talking to the point.

... You have no idea what my dreams are about.

Dan

> -----Original Message-----
> From: Christoph Hellwig [mailto:[email-masked]] 
> Sent: Wednesday, February 09, 2005 7:41 PM
> To: Dan Bar Dov
> Cc: Christoph Hellwig; 
> [email-masked]; [email-masked]
> Subject: Re: [linux-iscsi-devel] [ANNOUNCE] iSER (iSCSI RDMA 
> Extension) code added to OpenIB
> 
> On Wed, Feb 09, 2005 at 03:14:38PM +0200, Dan Bar Dov wrote:
> > The main reason for the implementation over kDAPL is the need to 
> > support both Ethernet RDMA and InfiniBand which many 
> consider as one 
> > of the benefits of iSER
> 
> I've not seen a single Ethernet RDMA implementation, 
> nevermind the driver stack for Linux.
> 
> > The same goes for NFS/RDMA which is over kDAPL, and I'm sure is an 
> > important protocol for the Linux community
> 
> In your dreams ;-)
> 
> > If your concern is the kDAPL coding style and API conformance with 
> > Linux  than those issues are going to be resolved soon, by 
> cleaning up 
> > the kDAPL implementation and make it comply with the Linux 
> requirements.
> 
> The whole kDAPL concept is rather worrysome.  We don't 
> introduce abstractions for the abstractions sake.  If you can 
> show an abstraction is usefull it'll be implemented.
> 
> > I appreciate it if you can explain to me what are your 
> concerns with kDAPL and if my response doesn't satisfy you.
> 
> Honestly I think don't anyone with the smallest bit of taste 
> would argue in favour of kDAPL as it stands.
> 
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Christoph Hellwig <[email-masked]>
Date: Thu, 10 Feb 2005 10:29:48 +0100

> Since we discuss technology, I'd appreciate it if you could stick with talking to the point.

Taste of beer is your personal issue.  Taste on how to design software
and interface is extremly important.

---

From: Andre Hedrick <[email-masked]>
Date: Thu, 10 Feb 2005 22:40:22 -0800 (PST)

Christoph,

Data integrity and knowledge about specifications and the deployment
override short comings in "architecture design".

This is not "linux kernel mailing list", it is the IETF reflector.

This is one point where industry is correct, and Linux needs to get a clue
with what customers want and not operate as if the OS is still a graduate
student kid project.

Every point Dan made was about technology and deployment.

Would you kindly discuss technology and not dictatorship games of control?
Dan as already agreed to the concept of "architecture design", and some
are waiting to see "design".

Taste is knowing Tawny Porta is bottom of the barrel but the masses are
clueless, while Reserve Porta is the good stuff.  Point of the taste
debate is knowledge and experience shows appreciation ...

Well I should stop ranting and wait for the discussion to return to
technology.

Andre Hedrick
LAD Storage Consulting Group