Subject: [Ips] iSCSI: proper response if no targets available

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 28 Feb 2005 13:49:54 -0500

A SendTargets response MUST NOT contain target names if there are no

   targets for the requesting initiator to access.

Does this mean the response would be:

"TargetName="

or

No Data Segment?

Eddy
_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Buck Landry" <[email-masked]>
Date: Mon, 28 Feb 2005 17:36:21 -0600

Appendix D. also says
 
... Each target is returned as a target record.  A target record begins with the TargetName text key, followed by a list of TargetAddress text keys, and bounded by the end of the text response or the next TargetName key, which begins a new record. ...
<<<
 
If each target takes the form of a target record, and you have zero targets, then you should have zero "target records", and therefore zero instances of "TargetName"/"TargetAddress".
 
So, I believe you should return no data segment.
 
--buck

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eddy Quicksall
Sent: Monday, February 28, 2005 12:50 PM
To: [email-masked]
Subject: [Ips] iSCSI: proper response if no targets available

"TargetName="

or

No Data Segment?

Eddy