Subject: [Ips] Re: Redirection in discovery

From: Julian Satran <[email-masked]>
Date: Sat, 12 Mar 2005 16:18:39 -0500

Eddy,

You should be able to use redirection on a discovery session.
As redirection is an exception response a good initiator should expect no 
answer except the redirection answer
and a target redirector may be as "laconic" as giving a single redirection 
address to "providing a full response to SendTargets".
BTW I expect this to be the case especially when the redirection is 
temporary.

Julo

"Eddy Quicksall" <[email-masked]> 
12/03/2005 14:06

To
Julian Satran/Haifa/IBM@IBMIL
cc

Subject
Redirection in discovery

Is it intended that redirection can't be used in a discovery session?
 
Eddy
 
_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Sat, 12 Mar 2005 17:58:17 -0500

What threw me was the following paragraph:

      1 - Redirection - indicates that the initiator must take further

          action to complete the request.  This is usually due to the

          target moving to a different address.  All of the redirection

          status class responses MUST return one or more text key

          parameters of the type "TargetAddress", which indicates the

          target's new address.

Since it says "MUST return ... TargetAddress" and if I only want to redirect the discovery, I don't have a TargetAddress.

Eddy

----- Original Message ----- 

  From: Julian Satran 
  To: Eddy Quicksall 
  Cc: [email-masked] 
  Sent: Saturday, March 12, 2005 4:18 PM
  Subject: [Ips] Re: Redirection in discovery

  Eddy, 

  You should be able to use redirection on a discovery session. 
  As redirection is an exception response a good initiator should expect no answer except the redirection answer 
  and a target redirector may be as "laconic" as giving a single redirection address to "providing a full response to SendTargets". 
  BTW I expect this to be the case especially when the redirection is temporary. 

  Julo 

        "Eddy Quicksall" <[email-masked]> 
        12/03/2005 14:06 
       To Julian Satran/Haifa/IBM@IBMIL  
              cc  
              Subject Redirection in discovery 

    
  Eddy 

------------------------------------------------------------------------------

---

From: "Eddy Quicksall" <[email-masked]>
Date: Sat, 12 Mar 2005 18:22:24 -0500

Oh, sorry... by TargetAddress, the spec is not saying I need to actually have a TargetName supplied ... is that correct?

Eddy
  ----- Original Message ----- 
  From: Eddy Quicksall 
  To: Julian Satran 
  Cc: [email-masked] 
  Sent: Saturday, March 12, 2005 5:58 PM
  Subject: Re: [Ips] Re: Redirection in discovery

            target's new address.

  Eddy

  ----- Original Message ----- 

    From: Julian Satran 
    To: Eddy Quicksall 
    Cc: [email-masked] 

    Eddy, 

    Julo 

         

    Eddy 

----------------------------------------------------------------------------

---

From: Julian Satran <[email-masked]>
Date: Sat, 12 Mar 2005 23:51:24 -0500

That is correct - you do not have to have a TargetName. Julo

"Eddy Quicksall" <[email-masked]> 
12/03/2005 18:22

To
Julian Satran/Haifa/IBM@IBMIL
cc
<[email-masked]>
Subject
Re: [Ips] Re: Redirection in discovery

Oh, sorry... by TargetAddress, the spec is not saying I need to actually 
have a TargetName supplied ... is that correct?
 
Eddy
----- Original Message ----- 
From: Eddy Quicksall 
To: Julian Satran 
Cc: [email-masked] 
Sent: Saturday, March 12, 2005 5:58 PM
Subject: Re: [Ips] Re: Redirection in discovery

 
Since it says "MUST return ... TargetAddress" and if I only want to 
redirect the discovery, I don't have a TargetAddress.
 
Eddy
 
----- Original Message ----- 
From: Julian Satran 
To: Eddy Quicksall 
Cc: [email-masked] 
Sent: Saturday, March 12, 2005 4:18 PM
Subject: [Ips] Re: Redirection in discovery

Eddy, 

Julo 

To

Subject
Redirection in discovery

Eddy