Subject: RE: [Ips] MIB Doctor review: draft-ietf-ips-fcip-mib-07.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Thu, 21 Apr 2005 00:07:59 +0200

Rob, thanks for that information.
It raises various questions:

- The referenced document (where I supposedly should be able
  to find underlying explanations of why some objects are 
  defined as they are) is not a current or even a final one.
  Needs to be fixed I would say
- You seem to imply that IETFers who want to review this MIB
  document and want to understand the underlying technology
  that they must purchase some other T11 document.
  Does NOT seem right to me

Oh well... something for your WG chairs and Ad to deal with.

Bert

> -----Original Message-----
> From: Robert Snively [mailto:[email-masked]]
> Sent: Wednesday, April 20, 2005 18:52
> To: Wijnen, Bert (Bert); Keith McCloghrie
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Ips] MIB Doctor review: draft-ietf-ips-fcip-mib-07.txt
> 
> 
> FC-SW, rev 3.3, Oct 1997 is obsolete and has been withdrawn.
> It was never a standard at that level. It is available
> from some standards documentation companies.  Contact me
> if you are interested in that particular issue.
> 
> The present document is INCITS 384:2004, FC-SW-3.  By
> copyright regulations of INCITS, it can be purchased on
> the INCITS store for $18 per download or $60 for a paper
> copy.  The next revision is FC-SW-4.  FC-SW-4 is presently
> in development and is available in draft form on www.t11.org
> under the "drafts" button.
> 
> Robert Snively, Chair INCITS TC T11
> 
> Brocade Communications Systems, Inc.
> 1745 Technology Drive
> San Jose, CA 95110
> 
> +1 408 333 8135
> [email-masked] 
> 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > Wijnen, Bert (Bert)
> > Sent: Wednesday, April 20, 2005 8:43 AM
> > To: 'Keith McCloghrie'
> > Cc: [email-masked]; [email-masked]
> > Subject: RE: [Ips] MIB Doctor review: draft-ietf-ips-fcip-mib-07.txt
> > 
> > 
> > Inline
> > 
> > > -----Original Message-----
> > > From: Keith McCloghrie [mailto:[email-masked]]
> > > Sent: Wednesday, April 20, 2005 16:03
> > > To: [email-masked]
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: [Ips] MIB Doctor review: 
> draft-ietf-ips-fcip-mib-07.txt
> > > 
> > > 
> > > Hi Bert,
> > > 
> > > > I have done a MIB-Doctor review of this draft.
> > > > 
> > > > Below are my comments.  Some are serious, some are
> > > > more nits/admin-related.
> > > 
> > > All the nits/admin-related you found appear to be valid.
> > 
> > Good to see that we agree on that.
> > 
> > > I can respondto a few of the others.
> > > 
> > > > ...
> > > >
> > > > - In the FcDomainId TC they talk about FC entity while 
> they talk 
> > > >   about FCIP entity in FcEntityMode TC. Is that intentional
> > > >   or just inconsistent?
> > >  
> > > I think it's intentional.
> > > 
> > Mmm... then maybe some additional text in the DESCRIPTION clauses as
> > to what one and the other mean migth be helpfull to readers like 
> > myself.
> > 
> > > > - I see (in
> > > >    FcDomainIdOrZero ::= TEXTUAL-CONVENTION
> > > >     STATUS current
> > > >     DESCRIPTION
> > > >             "The Domain Id (of a FC swit
> > > >             has been assigned."
> > > >     SYNTAX  Integer32 (0..239)
> > > > 
> > > >   While the FcDomainId in this MIB document is:
> > > >     SYNTAX    OCTET STRING (SIZE(1))
> > > >   That is pretty inconsistent between the two MIB modules.
> > > >   This sort of proves my previous point about inconsistencies
> > > >   and/or name clashes right away.
> > >  
> > > While it seems like an "inconsistency", it originates in the Fibre
> > > Channel specifications which seem to define a Domain_ID as 
> > an integer
> > > value stored in a 1-byte field.  E.g., in a header for the 
> > > FSPF (routing)
> > > protocol, there is a 4-byte field defined as:
> > > 
> > >     Recipient Domain_ID: This field shall specify the 
> > Domain_ID of the
> > >     neighbor Switch. If the neighbor Domain_ID is known, then the
> > >     Recipient Domain_ID value shall be set to 
> 000000h||Domain_ID. If
> > >     the neighbor Domain_ID is unknown, then the Recipient 
> Domain_ID
> > >     value shall be FFFFFFFFh.
> > > 
> > >     Valid values for the Domain_ID are: 01h-EFh.
> > > 
> > > The usage of concatenation (000000h||Domain_ID) requires it 
> > > to be an octet
> > > string; having a *range* of values (01h-EFh) requires it to 
> > > be an integer.
> > > So, it's both !!  
> > > 
> > 
> > Thanks for the explanation. In such a (intentional case), I would 
> > probably the rename the two TCs to FcIntegerDomainIdOrZero and
> > FcStringDomainId or some such. The FcDomainIdOrZero is alread
> > in RFC-Ed queue I believe, so changing that is not easy at 
> this point.
> > Maybe rename the one in this doc to: FcDomainIdInOctetForm ?
> > And add some of the above explanantion to the DESCRIPTION clause?
> > Possibly also add another reference in the REFENCES section for
> >       REFERENCE "FC-SW, rev 3.3, 21 October 1997, section 3."
> > I did a quick hunting around on T11 web page, but could not find
> > it yet. I see under FC-SW a cover letter from 1997, but no document.
> > So a (better) ptr to the underlying spec might be very helpfull.
> > 
> > > > - On page 10 I see:
> > > >     REFERENCE
> > > >       "IETF IPS Working Group - 
> draft-ietf-ips-fcovertcpip-12.txt"
> > > >   That makes that internet-draft normative (I think). Just 
> > > so you know.
> > >  
> > > This is now RFC 3821.
> > > 
> > OK good, so it can easily be a normative reference then.
> > Would be good to update it with the RFC number.
> > I think that draft name is used at several places!
> > 
> > Bert
> > 
> > > Keith.
> > > 
> > 
> > _______________________________________________
> > Ips mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ips
> > 
> > 
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Allison Mankin <[email-masked]>
Date: Sun, 24 Apr 2005 10:35:44 -0700

Bert,

Thanks for calling out several references issue for us, one
in an earlier mail.

Points

1. The reference to 3821 (FCIP) certainly needs to normative 
   (this is from a different message of yours on the thread).

2. As to the underlying INCITS document being for charge,
   I think this is something IETF "deals with"?   I quickly
   found my way to RFC 3621, the hubmib WG's Power Ethernet MIB,
   where IEEE-802.3af is a normative reference, but must be purchased.
   Same situation, right?

3. We do need Elizabeth as shepherd to manage the sorting out 
   of which INCITS document is to be referenced, and to put
   in some mention of the fact that work is in progress.

Allison