Subject: [Ips] Negotiating dependent key values

From: "Erez Zilber" <[email-masked]>
Date: Fri, 22 Apr 2005 12:21:33 +0300

Hi,
 
Some key values that are negotiated in the login phase may be dependent of other key values. If key value 'A' should be negotiated only if key value 'B' is negotiated to some value, can they be sent in the same login message? Should they be sent in different login messages?
 
Thanks
 
Erez Zilber
Software Engineer
T 972-9-9717689
www.voltaire.com <http://www.voltaire.com/> 
The Grid Interconnect Company

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Fri, 22 Apr 2005 13:23:56 +0300

> Some key values that are negotiated in the login phase may be

> dependent of other key values. If key value 'A' should be negotiated

> only if key value 'B' is negotiated to some value, can they be sent

> in the same login message? Should they be sent in different login
messages?

They can be sent in the same message or in different
messages (there is no rule to mandate either form).

Setting the values is meant to be done when everything
has been said and there has be no intervening explicit or implicit "reset".