Subject: RE: [Ips] negotiating more than once

From: "Buck Landry" <[email-masked]>
Date: Wed, 4 May 2005 16:01:03 -0500

Well, rfc3720 5.2.2 says

"Proposing a value not admissible (e.g., not within the specified
   bounds) MAY be answered with the constant "Reject" or the acceptor
   MAY select an admissible value."

So, the target doesn't have to respond with Reject -- it could just respond w/"No".

--buck

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eddy Quicksall
Sent: Wednesday, May 04, 2005 11:59 AM
To: [email-masked]
Subject: [Ips] negotiating more than once

The top of page 55 says this:

   Reject or Irrelevant are legitimate negotiation options where allowed
   but their excessive use is discouraged.  A negotiation is considered
   complete when the acceptor has sent the key value pair even if the
   value is "Reject", "Irrelevant", or "NotUnderstood.  Sending the key
   again would be a re-negotiation and is forbidden for many keys.

Take this case:

  The initiator says ImmediateData=OK. The target says ImmediateData=Reject.

The negotiation is now finished. Since ImmediateData defaults to YES and if the target can't take immediate data then what is the target to do? The only thing would be to close the connection.

Does anyone disagree? How about "does anyone agree"?

Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Wed, 4 May 2005 17:05:17 -0400

Ahh... Thanks, I didn't notice that.

Eddy

----- Original Message ----- 
From: "Buck Landry" <[email-masked]>
To: "Eddy Quicksall" <[email-masked]>; 
<[email-masked]>
Sent: Wednesday, May 04, 2005 5:01 PM
Subject: RE: [Ips] negotiating more than once

Well, rfc3720 5.2.2 says

So, the target doesn't have to respond with Reject -- it could just respond 
w/"No".

--buck

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eddy 
Quicksall
Sent: Wednesday, May 04, 2005 11:59 AM
To: [email-masked]
Subject: [Ips] negotiating more than once

Take this case:

The negotiation is now finished. Since ImmediateData defaults to YES and if 
the target can't take immediate data then what is the target to do? The only 
thing would be to close the connection.

Eddy