Subject: [Ips] New work item: iSCSI Implementer's Guide

From: [email-masked]
Date: Mon, 13 Jun 2005 15:52:30 -0400

Everyone,

The IPS WG has received Area Director approval to work on
an iSCSI Implementers Guide.  This will be a standards
track draft (will become a Proposed Standard RFC) whose
purpose is to clarify and correct any problems in the
iSCSI RFC (RFC 3720).  It is **not** a license to
revisit iSCSI design decisions, make major changes to
the iSCSI protocol or add major functionality to iSCSI,
although it may be a means to discourage implementation
of things that aren't in use (e.g., a sentence saying
that iSCSI markers SHOULD NOT be implemented would be
within reason).

I want to thank Mallikarjun for agreeing to edit this
draft.  The initial version should be submitted with a
name  of draft-ietf-ips-iscsi-impl-guide-00.txt or
something like that.

To a first approximation, the things that belong in
the implementers guide are things that an implementer wishes
s/he had known after first reading RFC 3720 ... but had
to learn/figure out the hard way.  So far, we have two
topics for this draft:
- Update to task management function handling when multiple
	tasks are to be terminated (Mallikarjun C.).
- Explanation of why REPORT LUNS command cannot cause an
	iSCSI overrun (David B.).
If Eddy Q. comes up with a specific proposal to clarify
some error conditions that a target should not be REQUIRED
to check (and we agree to it), that could be a third topic.
Those who would like to see other topics covered should send
those suggestions to the list, but be aware than any suggestion
to cover a topic will be interpreted as an offer to write
text describing it ...

My initial intention is to hold this draft open for a while
so that we can pick up more issues as they arise - at the
moment, my thinking is to hold this open for at least a year.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: David Wysochanski <[email-masked]>
Date: Mon, 20 Jun 2005 16:33:00 -0400

> to cover a topic will be interpreted as an offer to write
I would propose a clarification of the ISID rule in discovery
sessions, as outlined (at least partially) here:
http://www1.ietf.org/mail-archive/web/ips/current/msg00882.html