Subject: RE: [Ips] New work item: iSCSI Implementer's Guide

From: "Elliott, Robert (Server Storage)" <[email-masked]>
Date: Tue, 14 Jun 2005 10:06:29 -0500

T10 has finished SAM-3 (ANSI INCITS 402-2005) and is wrapping up SPC-3.
When (and how) should iSCSI be updated from its SAM-2 basis?

Some changes to consider:
* SCSI Command PDU: add Task Priority field
* SCSI Command PDU ATTR field: make Untagged obsolete
* Asynchronous Message: make SCSI Asynchronous Event Reporting obsolete
* Task Management Function Request PDU: make TARGET RESET obsolete
* Task Management Function Request PDU: add QUERY TASK
* Task Management Function Response PDU Response field: add FUNCTION
SUCCEEDED (for QUERY TASK or any other new function that wants to use
it)

SAM-4 is still in its early stages, but it includes a new feature that
also warrants consideration:
* SCSI Response PDU: add a Retry Delay field

--
Rob Elliott, [email-masked]
Hewlett-Packard Industry Standard Server Storage Advanced Technology
https://ecardfile.com/id/RobElliott

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, June 13, 2005 2:53 PM
> To: [email-masked]
> Subject: [Ips] New work item: iSCSI Implementer's Guide
> 
> Everyone,
> 
> The IPS WG has received Area Director approval to work on
> an iSCSI Implementers Guide.  This will be a standards
> track draft (will become a Proposed Standard RFC) whose
> purpose is to clarify and correct any problems in the
> iSCSI RFC (RFC 3720).  It is **not** a license to
> revisit iSCSI design decisions, make major changes to
> the iSCSI protocol or add major functionality to iSCSI,
> although it may be a means to discourage implementation
> of things that aren't in use (e.g., a sentence saying
> that iSCSI markers SHOULD NOT be implemented would be
> within reason).
> 
> I want to thank Mallikarjun for agreeing to edit this
> draft.  The initial version should be submitted with a
> name  of draft-ietf-ips-iscsi-impl-guide-00.txt or
> something like that.
> 
> To a first approximation, the things that belong in
> the implementers guide are things that an implementer wishes
> s/he had known after first reading RFC 3720 ... but had
> to learn/figure out the hard way.  So far, we have two
> topics for this draft:
> - Update to task management function handling when multiple
> 	tasks are to be terminated (Mallikarjun C.).
> - Explanation of why REPORT LUNS command cannot cause an
> 	iSCSI overrun (David B.).
> If Eddy Q. comes up with a specific proposal to clarify
> some error conditions that a target should not be REQUIRED
> to check (and we agree to it), that could be a third topic.
> Those who would like to see other topics covered should send
> those suggestions to the list, but be aware than any suggestion
> to cover a topic will be interpreted as an offer to write
> text describing it ...
> 
> My initial intention is to hold this draft open for a while
> so that we can pick up more issues as they arise - at the
> moment, my thinking is to hold this open for at least a year.
> 
> Thanks,
> --David
> ----------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 176 South St., Hopkinton, MA  01748
> +1 (508) 293-7953             FAX: +1 (508) 293-7786
> [email-masked]        Mobile: +1 (978) 394-7754
> ----------------------------------------------------
> 
> _______________________________________________
> Ips mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ips
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: [email-masked]
Date: Tue, 14 Jun 2005 15:42:08 -0400

Rob,

I don't think advancing iSCSI from SAM-2 to SAM-3 or beyond is a
sufficient reason by itself to make incompatible changes, so:

- The implementers guide is an ok place to a) remove features, e.g.,
	say that SCSI Asynchronous Event Reporting SHOULD NOT be supported
	because SAM-3 has made it obsolete, and b) do housekeeping
	e.g., rename TARGET WARM RESET and TARGET COLD RESET for SAM-3
	purposes without functional change.
- Added features belong in a separate draft that defines both the
	feature (e.g., QUERY TASK) and the key used to negotiate whether
	it is supported.  All added features or incompatible iSCSI changes
	for SAM-3 must be negotiated so that an implementation that
	provides NotUnderstood responses for all new SAM-3 keys receives
	RFC 3720 behavior.

All-in-all, I think putting all the SAM-3 and related changes
into a separate draft is probably better than trying to spread them
across two drafts, although I'd have no problem with repeating feature
removal (e.g., SCSI Asynchronous Event Reporting SHOULD NOT be
implemented) in both the Implementer's Guide and a separate SAM-3
for iSCSI draft.

Thanks,
--David

> Behalf Of Elliott, Robert (Server Storage)
> Sent: Tuesday, June 14, 2005 11:06 AM
> To: [email-masked]
> Subject: RE: [Ips] New work item: iSCSI Implementer's Guide
>