Subject: [Ips] Data Out PDU's

From: "Ken Craig" <[email-masked]>
Date: Tue, 30 Aug 2005 11:12:27 -0700

I have a question about Data Out PDUs.

I, as a Target, have negotiated DataSequenceInOrder and
DataPDUInOrder.  If I generate a R2T for two Write commands
does the spec allow the Data Out PDUs for those two R2T's
to be intermingled even though each Data Out PDU is in
sequence and in order?  Something like:

Write Cmd 0 - Data Out PDU - SN #0
Write Cmd 1 - Data Out PDU - SN #0
Write Cmd 0 - Data Out PDU - SN #1
Write Cmd 1 - Data Out PDU - SN #1
Write Cmd 0 - Data Out PDU - SN #2 with Final Bit
Write Cmd 1 - Data Out PDU - SN #2 with Final Bit

Thanks for your help,
Kenneth Ray Craig, Jr.

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Paul Koning <[email-masked]>
Date: Tue, 30 Aug 2005 14:18:57 -0400

>>>>> "Ken" == Ken Craig <[email-masked]> writes:

 Ken> I have a question about Data Out PDUs.  I, as a Target, have
 Ken> negotiated DataSequenceInOrder and DataPDUInOrder.  If I
 Ken> generate a R2T for two Write commands does the spec allow the
 Ken> Data Out PDUs for those two R2T's to be intermingled even though
 Ken> each Data Out PDU is in sequence and in order?  

Yes -- the ordering requirement is for order within a transfer, i.e.,
a single write command.

  paul

---

From: Gwendal Grignou <[email-masked]>
Date: Tue, 30 Aug 2005 12:27:02 -0700

> Yes -- the ordering requirement is for order within a transfer, i.e.,
I don't think so [10.8]:

Within a CONNECTION outstanding R2Ts MUST be fulfilled by the initiator
in the order in which they were received.

Gwendal.