Subject: Re: [Ips] Login Phase in iSER over IB

From: "Alex Nezhinsky" <[email-masked]>
Date: Thu, 25 Aug 2005 15:03:16 +0300

Mallikarjun,

>> The only explicit sanctioning here is the requirement to use the same
>> connection on the transport level both for the login and the 
>> full-featured phases:

> I am fine with that requirement. This is strongly implied in RFC 3720
> and the current iSER draft, and does not create any new dependencies 

> My concern was about mandating the second statement: "....For a 
> transport layer that provides message delivery capability, such as 
> [IB], the iSCSI Layer MUST interact with the transport layer
directly". 

Well, to summarize:

In 3.1.6: "...the RDMA-Capable Protocol implementation supports the 
use of this messaging capability by the iSCSI Layer directly..." 
is ok, as it speaks of a possible support for the direct interaction,
not mandating it.

In 3.1.6.1, we can eliminate the word "directly" (leaving the "MUST") or

eliminate both, like this: "...such as [IB], the iSCSI Layer interacts 
with the transport layer to use the messaging capability..."

Anyway, the last statement in 3.1.6.1 remains: "The same connection 
MUST be used for both the iSCSI Login phase and the subsequent 
iSER-supported Full-Feature phase."

What do you think?
 
Alexander Nezhinsky
 
Software Engineer
Infiniband Storage Solutions
<http://www.voltaire.com/> 
9 Ha-Menofim, Herzelya 46725 Israel
tel: +972- 9- 9717637
fax: +972- 9- 9717660
mobile: +972-50-7504376

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Mallikarjun C." <[email-masked]>
Date: Thu, 25 Aug 2005 10:28:31 -0700

> What do you think?

I think leaving out that statement in its entirety is the right thing. 
In normalizing the iSER spec out of iWARP-specifics (which I fully 
support), we've to be cautious not to introduce IB-specifics into the 
iSER draft.

 > Anyway, the last statement in 3.1.6.1 remains:

Agreed, with one editorial - s/iSER-supported/iSER-assisted/.

Mallikarjun

Mallikarjun Chadalapaka
Networked Storage Architecture
StorageWorks Division
Hewlett-Packard MS 5668
Roseville CA 95747
cbm [at] rose.hp.com