Subject: [Ips] SendTargets sent with other key in Text Request

From: Rohan Sen <[email-masked]>
Date: Thu, 18 Aug 2005 21:55:20 +0530

What should the Target do if it receives a Text Request PDU in
Discover Session containing the following keys :

"        - SendTargets=All"
"        - MaxRecvDataSegmentLength=1000" (invalid as per rfc3720
Appendix D Page 229)

Should the target send a Reject PDU stating Protocol Error but not
close the connection or
should it simply close the connection without sending any ISCSI PDU ?
-- 
thanks,
Rohan Sen

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Julian Satran <[email-masked]>
Date: Mon, 29 Aug 2005 09:56:27 +0300

The target should respond with a Reject PDU. It can then choose to 
continue or  close the connection/session a it sees fit.
Closing the connection without answering should be reserved for the cases 
in which a DOS attack is suspected - in which case it will be probably be 
followed by some initiator (addresses) being blacklisted.

Julo

Rohan Sen <[email-masked]> 
Sent by: [email-masked]
18-08-05 19:25

To
ISCSI <[email-masked]>
cc

Subject
[Ips] SendTargets sent with other key in Text Request

"        - SendTargets=All"