Subject: RE: [Ips] Question about iSCSI 3rd party reservation.

From: "Galloway, Bill" <[email-masked]>
Date: Wed, 17 Aug 2005 10:06:55 -0500

3d party reservations are not required in SPC3. The reserve/release
commands are actually obsolete in SPC3. The replacement is persistent
reserve/release which is not required by SPC3 and is optional in SBC2.

Bill Galloway

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Javen.Wu
> Sent: Tuesday, August 16, 2005 4:10 PM
> To: [email-masked]
> Cc: Tim Szeto
> Subject: [Ips] Question about iSCSI 3rd party reservation.
> 
> Hi guys,
> >3d party reservation is mandatory implement in SPC3.
> > In fact, I want to know how the 3rd party reserve work for iSCSI.
> > U know, if application wanna issue a 3rd party reservation. he will 
> > birng a  3rd party device ID in CDB.
> > How to translate the 3rd party ID to a real node name?
> > I suspect if a parellel SCSI user wanna issue a 3rd 
> reservation, he will 
> > fill Target ID to the 3rd device ID field.
> > And if a FC user wanan issue a 3rd reservation, he will 
> fill WWN to the 
> > 3rd device ID field.
> > So I guess if a iSCSI user wanna issue 3rd reservation, the CDB of 
> > reserve(10) will bring iqn name.
> > I am not sure my guess is correct,just a guess.
> > 
> > Your reponse is appreciated. I just wanna discuss SCSI 
> protocol implementation 
> > in iSCSI target emulation.
> > Thx again!
> > BR
> > Javen
> 
> 
> 
> _______________________________________________
> Ips mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ips
> 

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Jim Hafner <[email-masked]>
Date: Wed, 17 Aug 2005 20:32:56 -0400

The "ALIAS" commands in SPC-3 is designed exactly to solve this problem of 
naming a third party in a small field when the name is larger than can fit 
in that field.  Support for this command is optional, but I would expect 
that an implementation of RESERVE/RELEASE(10) will support the ALIAS 
commands as well ... or else "it won't work".

Jim Hafner/Almaden/IBM
Tel: (408) 927-1892, Fax: (408) 927-3030 (t/l 457)
Email:[email-masked]

William Studenmund <[email-masked]>
Sent by: [email-masked]
08/17/2005 10:00 AM
 
        To:     "Javen.Wu" <[email-masked]>
        cc:     Tim Szeto <[email-masked]>, [email-masked]
        Subject:        Re: [Ips] Question about iSCSI 3rd party 
reservation.

>> 3d party reservation is mandatory implement in SPC3.

As Bill noted, this statement is incorrect.

What is correct is that, according to SPC2, if you implement the
RESERVE(10) command, you also must implement 3rd party reservations.

>> How to translate the 3rd party ID to a real node name?

You don't. And that's the problem with RESERVE(10).

>> I suspect if a parellel SCSI user wanna issue a 3rd reservation, he
>> will fill Target ID to the 3rd device ID field.
>> And if a FC user wanan issue a 3rd reservation, he will fill WWN to
>> the 3rd device ID field.

Technically the WWN is in the parameter list, which is transfered as
part of the data phase. But you are correct that the command should
carry the iqn name. And the problem with RESERVE(10) is that the
parameter list can only be 8 bytes, which won't fit an iqn name.

And that's why our (Wasabi's) target does not implement RESERVE(10) &
RELEASE(10). It will never work right.

>> Your reponse is appreciated. I just wanna discuss SCSI protocol
>> implementation in iSCSI target emulation.
>> Thx again!

#### PGP.sig has been removed from this note on August 17, 2005 by Jim 
Hafner