Subject: [Ips] DDP draft specification

From: "Eddy Quicksall" <[email-masked]>
Date: Fri, 19 Aug 2005 17:49:20 -0400

I'm asking this question for a collegue that is having trouble sending mail:

Subject: DDP draft specification

Hi,

The below 2 sentences are from draft-ietf-rddp-ddp-05.txt

1. DDP provides enough information in each DDP Segment to allow the ULP Payload in each inbound DDP Segment payloads to be directly Placed into the correct ULP Buffer, even when the DDP Segments arrive out-of-order. 

2. This specification requires reliable, in order Delivery LLPs.

First sentence says that DDP segments which are MPA FPDUs in TCP case can arrive out-of-order and second sentence says that LLP (MPA layer) needs to provide ordered delivery. Isn't it contradictory?

Regards,

Sanjay
_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Mike Ko <[email-masked]>
Date: Fri, 19 Aug 2005 16:31:53 -0700

Eddy,

For a cleanly layered design, all LLP segments will be delivered in order. 
 To provide out of order data placement support, the DDP draft stated in 
section 2.3 under "Direct Data Placement" that this "may require the Data 
Sink to implement the LLP and DDP as one functional block."

Mike
Sent by:        [email-masked]
To:     <[email-masked]>
cc:     Sanjay Goyal <[email-masked]> 
Subject:        [Ips] DDP draft specification

I'm asking this question for a collegue that is having trouble sending 
mail:
Subject: DDP draft specification
Hi,
The below 2 sentences are from draft-ietf-rddp-ddp-05.txt
1. DDP provides enough information in each DDP Segment to allow the ULP 
Payload in each inbound DDP Segment payloads to be directly Placed into 
the correct ULP Buffer, even when the DDP Segments arrive out-of-order. 
2. This specification requires reliable, in order Delivery LLPs.
First sentence says that DDP segments which are MPA FPDUs in TCP case can 
arrive out-of-order and second sentence says that LLP (MPA layer) needs to 
provide ordered delivery. Isn't it contradictory?
Regards,
Sanjay_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 19 Aug 2005 16:41:13 -0700

The DDP and LLP can still be cleanly layered with out of order
placement, but the clean interface has to distinguish between
when the LLP provides a DDP Segment for placement and when
it is delivered.