Subject: Re: [Ips] Question regarding SessionType

From: William Studenmund <[email-masked]>
Date: Tue, 6 Dec 2005 11:49:32 -0800

On Dec 6, 2005, at 11:36 AM, <[email-masked]> wrote:

> It is good that there is an escape. However, that means that offering 
> the key late might cause it to get rejected by a target that would 
> have accepted it when offered early. This is a good reason to suggest 
> in the implementer guide that the key "SHOULD" be set in the initial 
> Login request if Discovery is going to be offered.

Enthusiastically agreed.

Take care,

Bill
_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: [email-masked]
Date: Tue, 6 Dec 2005 12:36:24 -0700

It is good that there is an escape. However, that means that offering the key late might cause it to get rejected by a target that would have accepted it when offered early. This is a good reason to suggest in the implementer guide that the key "SHOULD" be set in the initial Login request if Discovery is going to be offered.

Regards,
Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ken Sandars
Sent: Tuesday, December 06, 2005 4:57 AM
To: 'William Studenmund'
Cc: 'Julian Satran'; [email-masked]; [email-masked]
Subject: RE: [Ips] Question regarding SessionType

Hi Bill,

Thanks for pointing that out - a handy escape hatch!

Cheers
Ken

> -----Original Message-----
> From: William Studenmund [mailto:[email-masked]] 
> Sent: 06 December 2005 16:10
> To: Ken Sandars
> Cc: 'Julian Satran'; [email-masked]; [email-masked]
> Subject: Re: [Ips] Question regarding SessionType
> 
> 
> On Dec 4, 2005, at 10:15 PM, Ken Sandars wrote:
> 
> > Hi Julo,
> >
> > I think there is merit in having a recommendation in the 
> implementor 
> > guide
> > that if the SessionType key is going to be set to "Discovery", it 
> > should be
> > set in the initial Login request.
> >
> > Clearly this only affects named sessions since the only 
> legal unnamed
> > session requires SessionType=Discovery in the initial Login request.
> >
> > Say an initiator wants to create a named discovery session 
> but doesn't
> > supply SessionType in the initial Login request. The target will 
> > assume the
> > SessionType is Normal (as it is the default value), and negotiate
> > accordingly. Some consequences of this are:
> 
> Ken, a solution to this issue is that it is legitimate for the target 
> to reject SessionType=Discovery. Thus if you get a 
> SessionType=Discovery after the initial PDU, just reject it. Section 
> 12.21 states this explicitly.
> 
> Take care,
> 
> Bill
> 
>