Subject: RE: [Ips] iSER API's

From: "Dan Bar Dov" <[email-masked]>
Date: Mon, 9 Jan 2006 03:50:39 +0200

Indeed on Linux the direction is towards a generic RDMA interface. CMA provides a generic CM abstraction, and the ib_verbs API is planned to extend over iWARP one way or another. 
The DM was deemed unnecessary, the API between iSCSI & SCSI and the underlying iSER enforced redesign of the iSER API to conform with iSCSI and SCSI rather then implement yet another layer between iSER and iSCSI/SCSI (namely DM).
 
Dan

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of John Hufferd
	Sent: Friday, January 06, 2006 11:18 PM
	To: Eddy Quicksall; [email-masked]
	Subject: RE: [Ips] iSER API's

	Eddy,

	What APIs are you asking about?  The SCSI CLASS Driver to the Device Driver (Mini Port Driver) should have the same interfaces for iSER as it is available for iSCSI.  If you mean between the Device Driver (Mini Port Driver) and the RNIC, that will probably be the RNIC vendors interface if they have implemented all or part of the iSER or Data Mover in the RNIC itself, or the RNIC vendor's interfaces to their version of the verbs (at least until the OS implements its own RDMA interfaces that implement the RDMA verbs). 

	I believe that, over time, most OSs will have generic RDMA interfaces, which can be use by all certified RNIC hardware, and any application (user space or kernel space); in that case the iSER module will probably interface to that OS's RDMA interfaces.

	.

	.

	.

	John L Hufferd

	Sr. Executive Director of Technology

	Brocade Communications Systems, Inc

	[email-masked]

	Office Phone: (408) 333-5244; eFAX: (408) 904-4688

	Alt Office Phone: (408) 997-6136; Cell: (408) 627-9606

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Eddy Quicksall
	Sent: Friday, January 06, 2006 11:42 AM
	To: [email-masked]
	Subject: [Ips] iSER API's

	Is there any work afoot to design some standard iSER API's?

	Eddy

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: "Eddy Quicksall" <[email-masked]>
Date: Mon, 9 Jan 2006 10:06:49 -0500

Here is an example of what I mean when I say API:

ISER_SendControl is used to send SCSI commands, SCSI TMF's, unsolicited SCSI Data-out, SCSI Responses and iSCSI Asyncronous Message.

ISER_RC_T ISER_SendControl( 

ISER_CONNECTION_HANDLE_T connectionHandle,

pISCSI_HEADER pHeader,

pISER_PDU_QUALIFIERS pPDUQualifiers );

Returns: ISER_GOOD or ISER_FAILED

connectionHandle The connection handle returned by ISER_Connect

pHeader              A pointer to an iSCSI header.

pPDUQualifiers     A pointer to a set of qualifiers. The only qualifiers that need to be actually set are the ones relevant to the iSCSI header.

  ----- Original Message ----- 
  From: Dan Bar Dov 
  To: John Hufferd ; Eddy Quicksall ; [email-masked] 
  Sent: Sunday, January 08, 2006 8:50 PM
  Subject: RE: [Ips] iSER API's

  Dan

----------------------------------------------------------------------------

    Eddy,

    .

    .

    .

    John L Hufferd

    [email-masked]

----------------------------------------------------------------------------

    Eddy

---

From: Dave Wysochanski <[email-masked]>
Date: Sat, 14 Jan 2006 18:56:33 -0500

This might be a good work item for SNIA IPS WG, provided there was 
enough interest.

Eddy Quicksall wrote:

> ISER_SendControl is used to send SCSI commands, SCSI TMF's, 
> unsolicited SCSI Data-out, SCSI Responses and iSCSI Asyncronous Message.
>
>  
>
> pPDUQualifiers     A pointer to a set of qualifiers. The only 
> qualifiers that need to be actually set are the ones relevant to the 
> iSCSI header.
>
>     From: Dan Bar Dov <mailto:[email-masked]>
>     To: John Hufferd <mailto:[email-masked]> ; Eddy Quicksall
>     <mailto:[email-masked]> ; [email-masked]
>     <mailto:[email-masked]>
>     Indeed on Linux the direction is towards a generic RDMA interface.
>     CMA provides a generic CM abstraction, and the ib_verbs API is
>     planned to extend over iWARP one way or another.
>     The DM was deemed unnecessary, the API between iSCSI & SCSI and
>     the underlying iSER enforced redesign of the iSER API to conform
>     with iSCSI and SCSI rather then implement yet another layer
>     between iSER and iSCSI/SCSI (namely DM).
>      
>     Dan
>
>         ------------------------------------------------------------------------
>         From: [email-masked] <mailto:[email-masked]>
>         [mailto:[email-masked]] On Behalf Of John Hufferd
>         What APIs are you asking about?  The SCSI CLASS Driver to the
>         Device Driver (Mini Port Driver) should have the same
>         interfaces for iSER as it is available for iSCSI.  If you mean
>         between the Device Driver (Mini Port Driver) and the RNIC,
>         that will probably be the RNIC vendors interface if they have
>         implemented all or part of the iSER or Data Mover in the RNIC
>         itself, or the RNIC vendor's interfaces to their version of
>         the verbs (at least until the OS implements its own RDMA
>         interfaces that implement the RDMA verbs).
>
>          
>
>         I believe that, over time, most OSs will have generic RDMA
>         interfaces, which can be use by all certified RNIC hardware,
>         and any application (user space or kernel space); in that case
>         the iSER module will probably interface to that OS's RDMA
>         interfaces.
>
>          
>
>         .
>
>         .
>
>         .
>
>         John L Hufferd
>
>         [email-masked] <mailto:[email-masked]>
>
>         ------------------------------------------------------------------------
>