Subject: [Ips] Changes to iSNS MIB

From: "Scott Kipp" <[email-masked]>
Date: Tue, 21 Feb 2006 14:42:07 -0700

IPS Working Group,

The 8th revision of the iSNS MIB can be found at:

http://www.ietf.org/internet-drafts/draft-ietf-ips-isns-mib-08.txt

This 8th revision was a major rewrite and includes the following changes to simplify the MIB:

1) Change the MIB so that it monitors instead of configures iSNS:

Starting with isnsDdsInfo, remove modify capabilities.
   - changed MAX-ACCESS to read-only in following objects:
        isnsDdsSymbolicName, isnsDdsStatus
   - Removed isnsDdsRowStatus object, and from IsnsDdsEntry, isnsServerIscsiDdsDdObjGroup, isnsServerIfcpDdsDdObjGroup
   - Removed isnsDdsMemberRowStatus object, and from IsnsDdsMemberEntry, isnsServerIscsiDdsDdObjGroup
   - changed MAX-ACCESS to read-only in following objects:
        isnsDdSymbolicName, isnsDdFeatures
   - Removed isnsDdRowStatus object, and from IsnsDdEntry, isnsServerIscsiDdsDdObjGroup, isnsServerIfcpDdsDdObjGroup
   - changed MAX-ACCESS to read-only in following objects:
        isnsDdMemberIscsiName
   - Removed isnsDdMemberRowStatus object, and from IsnsDdiScsiMemberEntry, isnsServerIscsiDdsDdObjGroup, isnsServerIfcpDdsDdObjGroup
   - changed MAX-ACCESS to read-only in following objects:
        isnsDdMemberPortalAddrType, isnsDdMemberPortalAddr, isnsDdMemberPortalPortType, isnsDdMemberPortalPort
   - Removed isnsDdMemberPortalRowStatus object, and from IsnsDdPortalMemberEntry, isnsServerIfcpDdsDdObjGroup
   - Removed isnsDdMemberFcRowStatus object, and from IsnsDdFcPortMemberEntry, isnsServerIfcpDdsDdObjGroup

2) Removed Client Information:
removed all client tables.
     a. isnsClntInfo
     b. isnsClntInstTable, isnsClntInstEntry, all objects in table
     c. isnsClntSrvrCfgTable, isnsClntSrvrCfgEntry, all objects in table
     d. isnsClntDscvrdSrvrTable, isnsClntDscvrdSrvrEntry, all objects in table
     e. isnsClntRegEntityTable, isnsClntRegEntityEntry, all objects in table

   Removed other client related objects
     a. Notifications: isnsClientStart, isnsClientInitialRegistration, isnsClientLostConnection
     b. Groups: isnsClntAttributesGroup, isnsClientNotificationGroup adjusted the numbering of isnsGroups
     c. Compliances: isnsIscsiClientComplianceV1, isnsIfcpClientComplianceV1, adjusted the numbering of isnsCompliances

   - Removed isnsClntSrvrCfgRowStatus object, and from isnsClntSrvrCfgEntry, isnsClientAttributesGroup
   - Removed isnsServerIfcpCntlNodeGroup, and object isnsCntlNodeFcPortRowStatus, removed from isnsIfcpServerComplianceV1
   - Removed isnsServerNextIdxGroup from isnsIscsiServerComplianceV1 and isnsIfcpServerComplianceV1

3) Removed previous Revision History since this was a major rewrite.

4) Authors
   - Remove Josh Tseng and Tim McSweeney and add Scott Kipp and G.D.Ramkumar
5) Other changes as suggested by Keith McCloghrie.

Thanks,
Scott Kipp

SPECIAL NOTICE

All information transmitted hereby is intended only for the use of the
addressee(s) named above and may contain confidential and privileged
information. Any unauthorized review, use, disclosure or distribution
of confidential and privileged information is prohibited. If the reader
of this message is not the intended recipient(s) or the employee or agent
responsible for delivering the message to the intended recipient, you are
hereby notified that you must not read this transmission and that disclosure,
copying, printing, distribution or use of any of the information contained
in or attached to this transmission is STRICTLY PROHIBITED.

Anyone who receives confidential and privileged information in error should
notify us immediately by telephone and mail the original message to us at
the above address and destroy all copies.  To the extent any portion of this
communication contains public information, no such restrictions apply to that
information. (gate01)

_______________________________________________
Ips mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ips

---

From: [email-masked]
Date: Tue, 21 Feb 2006 16:55:12 -0500

Everyone interested in iSNS,

Please review this new draft of the iSNS MIB.  Believe it or not, this
draft is still in the IPS WG (it's our last MIB).  I plan to issue a
Working Group Last Call on this draft in the next couple of weeks, with
WG Last Call to end sometime around the Dallas IETF meetings, but you
don't have to wait for this Last Call to start before making comments.

Also, please ignore the silly McData "may contain confidential and
privileged information" footer on Scott's original message.  That sort
of footer does not apply to anything sent to the IPS mailing list.

Thanks,
--David (ips WG chair)
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: Scott Kipp [mailto:[email-masked]] 
> Sent: Tuesday, February 21, 2006 4:42 PM
> To: [email-masked]
> Cc: G.D. Ramkumar; Kevin Gibbons
> Subject: [Ips] Changes to iSNS MIB
> 
> 
> IPS Working Group,
>
>    - Removed isnsDdsRowStatus object, and from IsnsDdsEntry, 
> isnsServerIscsiDdsDdObjGroup, isnsServerIfcpDdsDdObjGroup
>    - Removed isnsDdsMemberRowStatus object, and from 
> IsnsDdsMemberEntry, isnsServerIscsiDdsDdObjGroup
>    - Removed isnsDdRowStatus object, and from IsnsDdEntry, 
> isnsServerIscsiDdsDdObjGroup, isnsServerIfcpDdsDdObjGroup
>    - Removed isnsDdMemberRowStatus object, and from 
> IsnsDdiScsiMemberEntry, isnsServerIscsiDdsDdObjGroup, 
> isnsServerIfcpDdsDdObjGroup
>         isnsDdMemberPortalAddrType, isnsDdMemberPortalAddr, 
> isnsDdMemberPortalPortType, isnsDdMemberPortalPort
>    - Removed isnsDdMemberPortalRowStatus object, and from 
> IsnsDdPortalMemberEntry, isnsServerIfcpDdsDdObjGroup
>    - Removed isnsDdMemberFcRowStatus object, and from 
> IsnsDdFcPortMemberEntry, isnsServerIfcpDdsDdObjGroup
> 
>      a. Notifications: isnsClientStart, 
> isnsClientInitialRegistration, isnsClientLostConnection
>      b. Groups: isnsClntAttributesGroup, 
> isnsClientNotificationGroup adjusted the numbering of isnsGroups
>      c. Compliances: isnsIscsiClientComplianceV1, 
> isnsIfcpClientComplianceV1, adjusted the numbering of isnsCompliances
> 
>    - Removed isnsClntSrvrCfgRowStatus object, and from 
> isnsClntSrvrCfgEntry, isnsClientAttributesGroup
>    - Removed isnsServerIfcpCntlNodeGroup, and object 
> isnsCntlNodeFcPortRowStatus, removed from isnsIfcpServerComplianceV1
>    - Removed isnsServerNextIdxGroup from 
> isnsIscsiServerComplianceV1 and isnsIfcpServerComplianceV1
> 
>